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Overview
Welcome to the SheetMetal Design User's Guide. This guide is intended for users who need to become quickly 
familiar with the SheetMetal Design Version 5 product. 

This overview provides the following information:

●     SheetMetal Design in a Nutshell

●     Before Reading this Guide

●     Getting the Most Out of this Guide

●     Accessing Sample Documents

●     Conventions Used in this Guide

SheetMetal Design in a Nutshell

The SheetMetal Design workbench is a new generation product offering an intuitive and flexible user interface. 
It provides an associative feature-based modeling, making it possible to design sheet metal parts in concurrent 
engineering between the unfolded or folded part representation.

SheetMetal Design offers the following main functions:

●     Associative and dedicated sheet metal feature-based modeling

●     Concurrent engineering between the unfolded or folded part representation

●     Access to company-defined standards tables

●     Dedicated drawing capability including unfolded view and specific settings.

All sheet metal specifications can be re-used by the Knowledge Advisor workbench to capture corporate 
knowledge and increase the quality of designs.

Natively integrated, SheetMetal Design offers the same ease of use and user interface consistency as all V5 
applications.

As a scalable product, SheetMetal Design can be used in cooperation with other current or future companion 
products in CATIA V5 such as Assembly Design and Generative Drafting. The widest application portfolio in the 
industry is also accessible through interoperability with CATIA Solutions Version 4 to enable support of the full 
product development process from initial concept to product in operation.

The SheetMetal Design User's Guide has been designed to show you how to design sheet metal parts of 
varying levels of complexity.



Before reading this guide, you should be familiar with basic Version 5 concepts such as document 
windows, standard and view toolbars. Therefore, we recommend that you read the Infrastructure User's 
Guide that describes generic capabilities common to all Version 5 products. It also describes the general 
layout of V5 and the interoperability between workbenches.

You may also like to read the following complementary product guides, for which the appropriate license is 
required: 

●     Part Design User's Guide: explains how to design precise 3D mechanical parts.

●     Assembly Design User's Guide: explains how to design assemblies.

●     Generative Drafting User's Guide: explains how to generate drawings from 3D parts and assembly 
definitions.

 

Getting the Most Out of this Guide

To get the most out of this guide, we suggest that you start reading and performing the step-by-step 
Getting Started tutorial.

Once you have finished, you should move on to the next sections, which explain how to handle more 
detailed capabilities of the product.

The Workbench Description section, which describes the SheetMetal Design workbench will also certainly 
prove useful. 

 

Accessing Sample Documents

To perform the scenarios, you will be using sample documents contained in the 
online\cfysa\samples\SheetMetal folder. For more information about this, refer to Accessing Sample 
Documents in the Infrastructure User's Guide.

 

 

Getting the Most out of This Guide



Conventions
Certain conventions are used in CATIA, ENOVIA & DELMIA documentation to help you recognize and 
understand important concepts and specifications. 

Graphic Conventions

The three categories of graphic conventions used are as follows:

●     Graphic conventions structuring the tasks

●     Graphic conventions indicating the configuration required

●     Graphic conventions used in the table of contents

Graphic Conventions Structuring the Tasks

Graphic conventions structuring the tasks are denoted as follows:

This icon... Identifies...

estimated time to accomplish a task

a target of a task

the prerequisites

the start of the scenario

a tip

a warning

information

basic concepts

methodology

reference information

information regarding settings, customization, etc.

the end of a task



functionalities that are new or enhanced with this release

allows you to switch back to the full-window viewing mode

Graphic Conventions Indicating the Configuration Required 

Graphic conventions indicating the configuration required are denoted as follows:

This icon... Indicates functions that are... 

specific to the P1 configuration

specific to the P2 configuration

specific to the P3 configuration

Graphic Conventions Used in the Table of Contents

Graphic conventions used in the table of contents are denoted as follows:

This icon... Gives access to...

Site Map

Split View mode

What's New?

Overview

Getting Started

Basic Tasks

User Tasks or the Advanced Tasks

Workbench Description

Customizing

Reference

Methodology

Glossary



Index

Text Conventions

The following text conventions are used:

●     The titles of CATIA, ENOVIA and DELMIA documents appear in this manner throughout the text.

●     File -> New identifies the commands to be used.

●     Enhancements are identified by a blue-colored background on the text.

How to Use the Mouse

The use of the mouse differs according to the type of action you need to perform.

Use this
mouse button... Whenever you read...

 
●     Select (menus, commands, geometry in graphics area, ...)

●     Click (icons, dialog box buttons, tabs, selection of a location in the document window, 
...)

●     Double-click

●     Shift-click

●     Ctrl-click

●     Check (check boxes)

●     Drag

●     Drag and drop (icons onto objects, objects onto objects)

●     Drag

●     Move

●     Right-click (to select contextual menu)



What's New?
There are no new or improved capabilities in Version 5 Release 14 of CATIA SheetMetal Design.

 



Getting Started

Before getting into the detailed instructions for using SheetMetal Design , the following tutorial provides 
a step-by-step scenario demonstrating how to use key functionalities.

The main tasks proposed in this section are: 

Entering the Workbench
Defining the Sheet Metal Parameters

Creating the First Wall
Creating the Side Walls

Creating a Cutout
Creating Automatic Bends Automatically

Extracting Drawings from the Sheet Metal Part 

 

 
All together, these tasks should take about 15 minutes to complete.



Entering the Workbench

The SheetMetal Design or Generative SheetMetal Design functions are available when you are in the Part 
environment. Several functions are integrated from the Part Design workbench.

This task shows how to enter the workbench.

 

For the SheetMetal Design workbench, choose the Mechanical Design -> Sheet Metal Design item 
from the Start menu.
For the Generative Sheetmetal Design workbench, choose the Mechanical Design -> Generative 
Sheetmetal Design item from the Start menu.

According to the chosen workbench, the corresponding Sheet Metal toolbar is displayed and ready to use.



You may add the SheetMetal Design or the Generative SheetMetal Design workbench to your Favorites, 
using the Tools -> Customize item. For more information, refer to the Infrastructure User's Guide.



Defining the Sheet Metal Parameters

This task shows you how to configure the sheet metal parameters.

1.  Click the Sheet Metal Parameters icon .

The Sheet Metal Parameters dialog box is displayed. 

2.  Enter 1mm in the Thickness field.

3.  Enter 5mm in the Default Bend Radius field.

4.  Select the Bend Extremities tab.



5.  Select Tangent in the Bend Extremities combo list.

An alternative is to select the bend type in the graphical combo list.

6.  Click OK to validate the parameters and close the dialog box.

The Sheet Metal Parameters feature is added in the specification tree.

The other two tabs are not used in this scenario.

 

 



Creating the First Wall

This task shows how to create the first wall of the sheet metal Part.

1.  Click the Sketcher icon  then select the xy plane.

2.  Select the Profile icon .

3.  Sketch the profile as shown below:

4.  Click the Exit workbench icon  to return to the 3D world.

The sketch remains selected.



5.  Click the Wall icon .

The Wall Definition dialog box opens.

By default, the Material Side is set to the top.

6.  Click OK.

The Wall.1 feature is added in the specification tree

The first wall of the Sheet Metal Part is known as the reference wall.



Creating the Side Walls

This task shows you how to add other walls to the sheet metal part.

1.  Click the Wall on Edge icon .

The Wall On Edge Definition dialog box opens.

2.  Select the left edge.

3.  Enter 50mm in the Value field.

The application previews the wall.

By default, the material side is such that it ensures a continuity with the reference profile. If needed, 

invert it using the Reverse side button, or clicking the arrow.



4.  Click the Reverse Position button to Invert the sketch profile.

5.  Click OK.

The wall is created and the Wall On Edge.1 feature is displayed in the specification tree:

6.  Select the right edge.

7.  Click the Wall on Edge icon  again.

The Wall On Edge Definition dialog box opens with the parameters previously selected.

8.   Invert the sketch profile and click OK to validate.

9.  Click the Wall on Edge icon  again.

10.  Select the front edge.

The Wall Definition dialog box opens with the 

parameters previously selected.

11.  Enter 30mm in the Value field and 10mm in 

the Limit1 and Limit2 fields, then invert the 

sketch profile.

12.  Press OK to validate.



The final part looks like this: 

 



Creating a Cutout

In this task, you will learn how to: 
●     open a sketch on an existing face

●     define a profile in order to create a cutout.

1.  Select Wall On Edge.2 from the 

geometry area to define the working 

plane.

2.  Click the Sketcher icon .

3.  Click the Elongated Hole icon  to create the profile.

To access the oblong profile, click the 

black triangle on the Rectangle icon.

It displays a secondary toolbar.

4.  Click to create the first point and drag the 

cursor.

5.  Click to create the second point.

The first semi-axis of the profile is 

created.

6.  Drag the cursor and click to create the 

third point.

The second semi-axis is created and the 

oblong profile is displayed.



7.  Click the Exit workbench icon  to return to the 3D world.

8.  Select the Cutout icon .

The Pocket Definition dialog box is 
displayed and a cutout is previewed 
with default parameters. 

9.  Set the Type to Up to last option to define the limit of your cutout.

This means that the application will limit the cutout onto the last possible face, that is the 
opposite wall.

10.  Click OK.

This is your cutout:

 

 



Creating the Bends Automatically

This task applies to the SheetMetal Design workbench only, NOT to the Generative Sheetmetal Design 
workbench.

This task shows how to create the bends automatically.

 
1.  Click the 

Automatic 

Bends 

icon .

The bends are 

created.

The bends are displayed in the specification tree: Automatic Bends.1

The sheet metal part 
looks like this:

 



Extracting Drawings
from the Sheet Metal Part

This task shows how to create the sheet metal part views in the Generative Drafting workbench.

The sheet metal part is displayed.

1.  Click  or select File -> New...

2.  Select the Drawing type and click OK.

The Generative Drafting  workbench is launched. The New Drawing dialog box opens.

3.  Click OK.

For more information about this workbench, refer to Generative Drafting User's Guide. 

4.  The drawing sheet appears.

5.  Tile the windows horizontally using the Window -> Tile Horizontally menu item.

6.  Select the Unfolded View icon  in the Projections toolbar from Generative Drafting Workbench.

This icon is added to the Projections toolbar provided the Sheet Metal workbench is present.

7.  Choose the xy plane in the Sheet Metal specification tree. The unfolded view is previewed. 



8.  Click in the drawing to validate and generate the view, with the bend axes and bend limits when applicable.

 

 



Basic Tasks
The Basic Tasks section explains how to create and modify various kinds of features.

 
Managing the Default Parameters

Creating Walls
Recognizing Walls From an Existing Part

Extruding
Isolating Walls

Creating Rolled Walls
Creating Bends on Walls

Creating Swept Walls
Unfolding
Pockets

Stamping
Patterning

Corner Relief
Creating Corners

Creating Chamfers
Mapping Elements

Saving As DXF
Interoperability With Wireframe 



Managing the Default Parameters

This section explains and illustrates how to use or modify various kinds of features. The information you 
will find is listed below.

Using SheetMetal Design assumes that you are in a CATPart document.

 

Edit the parameters: select the Parameters tab, the wall thickness and bend radius values.

Modify the bend extremities : select the Bend Extremities tab and choose a predefined bend type. 

Define the bend corner relief: select the Bend Corner Relief tab and choose a predefined corner relief 
type. 

Define the bend allowance: select the Bend Allowance tab and define the allowance value (K factor).

 



Editing the Sheet and Tool Parameters

This section explains how to change the different sheet metal parameters needed to create your first feature.

1.  Click the Sheet Metal Parameters icon .

The Sheet Metal Parameters dialog box is displayed.

2.  Change the Thickness if needed.

 
3.  Change the Minimum Bend Radius if needed.

The Minimum Bend radius defines the minimum internal radius allowing the creation of a bend. 

 You can set the value to 0 to create bend with no radius. If using the DIN standard, the KFactor automatically sets to 0 as well.

This option is only relevant with the Generative Sheetmetal Design workbench.

4.  Change the Default Bend Radius if needed.

The Default Bend Radius corresponds to the internal radius and is linked by default to the creation of the bends.

Convention dictates that the inner angle between the two elements is used to define the bend.
It can vary from 0deg to 180deg exclusive. This angle is constant and the bend axis is rectilinear.

This option is only relevant with the Generative Sheetmetal Design workbench.

5.  Click OK to validate the Sheet Metal Parameters.

 
The Standard field displays the Standard to use with the part, if implemented. The name of this standard file is defined in a Design Table.
When the Check all the bend radii button is checked, and you click OK in the Sheet Metal Parameters dialog box, existing bend radii are checked and a list displays flanges or bends that do not use the minimum Bend 
Radius value as defined in step 3. Therefore, they will not be modified.

Parameters can be defined in a Design Table. To do so, press the Sheet Standards Files... button to access to the company-defined standards, if need be. For more information, refer to the Customizing Standard Files 

section.

All parameters hereafter, or only some of them, can be defined in this Design Table:
 Sheet Metal Parameters Column associated in the Design Table Definition

Standard in Sheet Metal 
Parameters SheetMetalStandard sheet reference name

Thickness Thickness sheet thickness
Minimum Bend Radius MinimumBendRadius minimum bend radius
Default Bend Radius DefaultBendRadius default bend radius
K Factor KFactor neutral fiber position
Radius Table RadiusTable path to the file with all available radii

In all cases, the Thickness parameter must be defined in the Design Table in order for the other parameters to be taken into account.

Whenever both Radius Table and Default Bend Radius are defined in the Design Table, only the Radius Table will be taken into account for the bend creation.



 Standard Names For Holes Column associated in the Design Table Definition
Clearance Hole ClearanceHoleStd path to the Clearance Hole Standard file
Index Hole IndexHoleStd path to the Index Hole Standard file
Manufacturing Hole ManufacturingHoleStd path to the Manufacturing Hole Standard file
Fastener Hole FastenerHoleStd path to the Fastener Hole Standard file

 Standard Names For Stamps Column associated in the Design Table Definition
Flanged Hole ExtrudedHoleStd path to the Flanged Hole Standard file
Bead BeadStd path to the Bead Standard file
Circular Stamp CircularStampStd path to the Circular Stamp Standard file
Surface Stamp SurfaceStampStd path to the Surface Stamp Standard file
Flanged CutOut FlangedCutoutStd path to the Flanged CutOut Standard file
Curve Stamp CurveStampStd path to the Curve Stamp Standard file

 When a parameter refers to a path, another sub-Design Table will be associated to the corresponding feature.
 1. Here is an example for the use of a bend allowance table:

 Main Sheet Metal Parameters Design Table
 

 Radius Table For Thickness 2 
This table defines available all bend radii for a thickness of 2 mm. A design table will be created on the Default Bend Radius of the Sheet Metal Parameters and on the Radius of each bend.

 

 Bend Table for Thickness 2 and Bend Radius 1
Whenever a bend is created, a radius table will be associated. If the configuration "Bend Radius = 1mm" is selected,  a new design table (the Bend Table) will be created from BendTableT2R1.xls in order to compute the 
bend allowance.
According to the open angle, the bend deduction will be read in the Allowance column or interpolated if necessary.

 

 2. Here is an example for the use of a hole standard file:

 Main Sheet Metal Parameters Design Table
 

 Hole Standard 
Whenever a hole is created, a design table will associate its radius with a standard name.

 



 3. Here is an example for the use of a stamp standard file:

 Main Sheet Metal Parameters Design Table
 

Whenever a stamp is created, a design table will associate its dimension with a standard name.
     
 

●     Surface Stamp

     
 

●     Curve Stamp

     
 

●     Circular Stamp

     
 

●     Bead

     
 

●     Bridge

     
 

●     Flanged Cutout

     
 

●     Extruded Hole
(or Flanged Hole in the Generative Sheetmetal Design workbench)

     
 

●     Stiffening Rib



Modifying the Bend Extremities

This section is only available with the SheetMetal Design products.

This section explains how to change the bend extremities, i.e. how to change axial relimitations for a 
straight bend.

1.  Click the Sheet Metal Parameters icon .

The Sheet Metal Parameters dialog box is displayed.

2.  Click the Bend Extremities tab to access parameters defining bend extremities.

 

 
3.  Choose a bend extremity, either from the drop-down list or using the graphical button 

underneath.

●     Minimum with no relief (default option): the bend corresponds to the common area of 
the supporting walls along the bend axis, and shows no relief.

●     Square relief: the bend corresponds to the common area of the supporting walls along 
the bend axis, and a square relief is added to the bend extremity. The L1 and L2 
parameters can be modified if needed. 

●     Round relief: the bend corresponds to the common area of the supporting walls along the 
bend axis, and a round relief is added to the bend extremity. The L1 and L2 parameters 
can be modified if needed.

●     Linear: the unfolded bend is split by two planes going through the corresponding limit 
points (obtained by projection of the bend axis onto the edges of the supporting walls).

●     Tangent: the edges of the bend are tangent to the edges of the supporting walls.



●     Maximum: the bend is calculated between the furthest opposite edges of the supporting 
walls.

4.  Click OK to validate.

 



Defining the Bend Corner Relief

This section is only available for the Sheet Metal Design workbench, NOT for the Generative Sheetmetal 
Design workbench.

This section explains how to change the bend corner relief.

Open CornerRelief01.CATPart if you are using the Sheet Metal Design workbench. 

Within the Tools -> Options -> General -> Parameters -> Knowledge tab, check the Load 
Extended Language Libraries option.

1.  Click the Sheet Metal 

Parameters icon .

The Sheet Metal 

Parameters dialog box 

is displayed.

The third tab concerns 
the bend corner relief.

By default, no corner relief is created when a bend is created. Check the Automatic corner relief 
creation option to activate this creation every time a bend is created.

Three corner relief types are available. Select the icon corresponding to the requested type:

●      : 

square: the square corner relief is created using the bend limits. Its 
dimensions are defined by the width of the unfolded bends.

●      : 

circular: its center is located at the intersection of the bend axes. For 
that option, a radius is proposed by default. It is equal to the bend 
radius + the thickness. To change it: 

●     Select Formula -> Deactivate from the contextual menu of the 
input field and enter a new value,

●     click on the  button and entering a new formula.

●      :

triangular: the triangular relief is created from the intersection point 
of the inner bend limits towards the intersection points of the outer 
bend limits with each wall. 

file:///E|/Www/cnqr14/Doc/online/cfysm_C2/samples/CornerRelief01.CATPart


The corner relief is not previewed during its creation.

The corner relief is taken into account in the unfolded view.

●     For better result, you should select the Maximum Bend Extremities option when creating corner 
relief.

●     These parameters are applied to each corner relief created or to be created, except to those with 
that have been redefined, or the locally defined corner relieves.



Computing the Bend Allowance

This section explains the calculations related to folding/unfolding operations.

1.  Click the SheetMetal Parameters icon 

.

The Sheet Metal Parameters dialog box is 

displayed.

The fourth tab concerns the bend allowance.

 
●     Bend Allowance

 The bend allowance corresponds to the unfolded bend width.

 

 
bend < 90deg bend > 90deg 

 L is the total unfolded length
A and B the dimensioning lengths as defined on the above figure. They are similar to the DIN 
definition.



 
●     K Factor

 Physically, the neutral fiber represents the limit between the material compressed area inside the bend 
and the extended area outside the bend. Ideally, it is represented by an arc located inside the thickness 
and centered on the bend axis. 

The K factor defines the neutral fiber position:

W = α * (R + k * T)

where:

W is the bend allowance
R the inner bend radius
T the sheet metal thickness
α the inner bend angle in radians.

If β is the opening bend angle in degrees:

α = π * (180 - β) / 180

When you define the sheet metal parameters, a literal feature defines the default K Factor and a formula 
is applied to implement the DIN standard. This standard is defined for thin steel parts. Therefore the K 
Factor value ranges between 0 and 0.5.

The DIN definition for the K factor slightly differs. 

W = α * (R + k' * T/2)
Therefore k' = 2 * k and ranges from 0 to 1.

 This formula can be deactivated or modified by right-clicking in the K factor field and choosing an option 
from the contextual menu. It can be re-activated by clicking the Apply DIN button. Moreover, the limit 
values can also be modified.

 When a bend is created, its own K Factor literal is created. 
Two cases may then occur:

a.  If the Sheet Metal K Factor has an activated formula using the default bend radius as input 
parameter, the same formula is activated on the bend K Factor replacing the default bend radius 
by the local bend radius as input.

b.  In all other cases, a formula "equal to the Sheet Metal K Factor" is activated on the local bend K 
Factor.
This formula can also be deactivated or modified.

 
●     Bend Deduction



 When the bend is unfolded, the sheet metal deformation is thus represented by the bend deduction V, 
defined by the formula:

L = A + B + V
(refer to the previous definitions). 

Therefore the bend deduction is related to the K factor using the following formula:

V = α * (R + k * T) - 2 * (R + T) * tan ( min(π/2,α) / 2)

 This formula is used by default. However, it is possible to define bend tables on the sheet metal 
parameters. These tables define samples: thickness, bend radius, open angle, and bend deduction. In 
this case, the bend deduction is located in the appropriate bend table, matching thickness, bend radius, 
and open angle. If no accurate open angle is found, an interpolation will be performed. 

 When updating the bend, the bend deduction is first computed using the previously defined rules. Then 
the bend allowance is deduced using the following formula:

W = V + 2 * (R + T) * tan ( min(π/2,α) / 2)

When the bend deduction is read in the bend table, the K factor is not used.



Creating Walls
 

This section explains and illustrates different methods to create walls.

Create a wall from a sketch: use the sketcher to define the profile, and set the material side.

Create a wall tangent to another one: select a profile coincident with an existing wall, and select the wall 
to which it should be tangent

 
Create a wall from an edge: select a wall edge, set the height, limits, angle, then the sketch and material 
sides

 



Creating Walls from a Sketch

This task shows how to create a wall from a sketch.

You must be in the Sheet Metal Workbench, with a .CATPart document open, and you must have defined 

the sheet metal parameters. 

Set the sketcher grid to H = 100mm and V = 100mm, using the Tools -> Options, Mechanical 

Design -> Sketcher, Sketcher tab.

1.  Click the Sketcher icon  then select the xy plane.

2.  Select the Profile icon .

3.  Sketch the profile as shown below:

4.  Click the Exit workbench icon  to return to the 3D world.



5.  Click the Wall icon .

The Wall Definition dialog box opens.

By default, the Material Side is set to the top.

6.  Click OK.

The Wall.1 feature is added in the specification tree.

The first wall of the Sheet Metal Part is known as the Reference wall.

●     Click the sketcher icon  from the Wall Definition dialog box, if you wish to directly edit the 

selected sketch. When exiting the sketcher, you then go back to the wall creation step, without 
having to reactivate the Wall icon.



This is also very useful if you have selected an 

edge from a wall and clicked the Wall icon . 

In this case, the sketcher is automatically activated 
and the plane defined as being the selected edge's 
plane. 

You can then directly draw a sketch, then exit the 
sketcher and return to the wall creation step. 

●     You can directly create a wall with a hole, by selecting a sketch with an inner profile (the profiles 
must not intersect):

 

 
Sketch with inner profile Resulting wall

Note however, that the emptied area is part of the wall and is not a separate cutout that can 
be edited.



Creating Tangent Walls

This task shows how to create a wall tangent to a planar part of another wall or of a flange. This 

capability will then allow this tangent wall to be seen when unfolding the part, even though there is no 

bend linking it to its tangent support, provided this support is unfoldable too.

Open the TangentWall1.CATPart document from the samples directory.

1.  Select a face of an existing wall and click the Sketcher icon .

Here we selected the flange's planar face.

2.  Select the Profile icon  and sketch the profile as shown below.

You can also select Sketch.2 from the specification tree.

3.  Using the Constraint Defined in Dialog box icon, set coincidence constraints between the edges 

where the support and sketch are to coincide.

4.  Click the Exit workbench icon  to return to the 3D world.

file:///E|/Www/cnqr14/Doc/online/cfysm_C2/samples/SheetMetal/TangentWall1.CATPart


5.  Make sure the sketch is still active, then 

click the Wall icon .

The Wall Definition dialog box opens. 

Note the orientation of the wall to be created.

6.  Click inside the Tangent to field, then 

select the wall to which the new wall has 

to be tangent.

Here, you need to select the planar 

face of the flange.

Note that the orientation automatically changes to conform to the material orientation already defined on 
the support wall.

7.  Click OK.

The wall is created and a Wall.xxx 

feature is added in the specification tree.



8.  Click the Unfold icon .

The tangent wall is unfolded as a wall linked by a bend to another wall, would be.

If you want to create the wall on a wall that cannot be unfolded, the system issues a warning and 

prevents you from creating the tangent wall.



Creating Walls From An Edge

This task shows how to create walls from edges of an existing wall. This function is used to create a box in an 
easy and quick way from an existing reference wall.

At least one wall must already exist.

Open the Wall1.CATPart document from the samples directory.

1.  Click the Wall on Edge icon  

and select an edge of an existing 

wall.  

The Wall On Edge Definition dialog 

box is displayed together with a 

preview of the wall. 

2.  Define the type of wall to be created 

by specifying the Reference, that is:

●     the Height of the wall: that is the 
orthogonal projection from the top of the 
wall on edge to the reference wall.

Select the  icon to define the height 

of the wall from the bottom of the 

reference wall or the  icon to define 

the height of the wall from the top of the 
reference wall.

file:///E|/Www/cnqr14/Doc/online/cfysm_C2/samples/SheetMetal/Wall1.CATPart


●     the Length of the wall: that is the 
absolute value of the wall on edge 
without bend.

●     the limits of the wall: Limit 1 and Limit 2. These texts only indicate on which side a given limit is. They are 

not precisely on the limit spots. The actual locations of the limits are defined with the     icons 
and an input distance that is taken into account respectively from the inner side of an existing bend, the 
inner side of an existing wall or the outer side of an existing wall. 

●     the angle of the wall: by default it is perpendicular to the plane containing the edge. You may modify it 
according to your needs. it is updated dynamically on the screen.

This preview gives information about: 

●     the Sketch Profile: by default, if you pick an edge on the top of the reference wall, the direction of the wall 

is upwards, if you pick an edge on the bottom of the reference wall the direction of the wall is downwards. 

Preview with top edge selected Preview with bottom edge selected

You can invert the sketch's 

position, and therefore the wall's,  

using the Reverse Position 

button. 



Preview with bottom edge selected and sketch profile inverted

●     the material side: by default the material 
side is proposed so as to keep a 
continuity with the reference profile. 

However, you can change it by 
clicking the red arrow or the 
Reverse Side button.  

3.  Check the Clearance option to offset 

the wall on edge from the selected 

edge. 

The entered value is the radius of 

the bend on this edge. 

Wall on edge with clearance Wall on edge without clearance

Note that the reference wall remains unchanged when changing the bend radius value. It is the Wall on Edge's 
length that is affected.



4.  You can also choose to create the wall with or without a bend by checking the With Bend option.

●     If there is no wall from which a limit can be computed, the reference element is the edge of the reference 
wall.

●     A wall on edge is defined by the selected 
edge (reference edge). When the 
reference edge is modified, by adding 
any feature that shortens the edge (a 
bend to an adjacent wall on edge or a 
cutout for example) the wall on edge 
based on this reference edge is 
recomputed.
To avoid this you may:  

❍     create the bend manually on the wall 
modifying the edge used as the 
reference to  create the other wall

❍     reorder the creation of walls to 
postpone the creation of the 
modifying feature

 

●     Both limits are computed with the same reference icon.

●     The bend is not previewed, even if the option With Bend is checked. However it will be created.

●     The selected options are modal and will be proposed to create the next wall.

●     Walls on edge being contextual features, if you break the profiles continuity by inverting the material side 
of a wall, you may have to manually re-specify all features based upon the modified one, even if they are 
not directly connected to the modified wall, in order to update the part afterwards.

This is the case when creating a 
wall on edge from another wall on 
edge, for example:



●     If you invert the material side of the 
reference wall on which the first wall on 
edge has been created, both walls on 
edge are relocated (as if you were 
flipping the geometry):

●     If you invert the material side of the first 
wall on edge (and not the material side 
of the reference wall), the second wall on 
edge is relocated. Indeed, its 
specification being relative to the first 
wall on edge, when its input data (i.e. 
the edge selected on the first wall on 
edge) is modified, the second wall on 
edge is rebuilt at a new location. 

5.  Click OK in the Wall On Edge Definition dialog box.

A WallOnEdge.x element is created in the specification tree.

●     A WallOnEdge.x element can be edited: double-click it in the graphic area or in the specification tree to 
display its creation dialog box and modify the parameters described above, including the edge from which 
it is created. However, the sketch of a wall on edge cannot be edited directly.

●     Would you need to edit the sketch of a wall on edge, you have to isolate it first. See Isolating Walls.

●     You can cut or copy and paste a wall on edge. 

●     If you cut and paste a wall on edge with children elements, these children elements are lost. This may 
result in update errors.

●     You cannot undo an Isolate action after having modified the wall.

●     Isolating a wall on edge erases all updating data.

 



Recognizing Walls From an Existing Part

This functionality is only available with SheetMetal Design.

This task illustrates how to create a sheet metal part using an existing Part, that is recognizing the thin 
part shapes of the part as created using the Part Design workbench or from a CATIA Version 4 Solid for 
example.

Open the WallScenario1.CATPart document from the samples directory.

The document contains a part created in the Part Design workbench and it looks like this:

1.  Click the Walls Recognition icon .
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2.  Click any face to be the reference wall.

The Walls Recognition Definition dialog box is 
displayed. 

3.  Choose the Wall creation mode: 

●     Part body recognition: the whole solid is 

processed and walls are created wherever 

possible

●     Only selected faces: only explicitly selected 

faces of the solid are processed and the 

corresponding walls are created.

The Reference wall is indicated in the Walls Recognition Definition dialog box for information only (it is 
grayed out).

4.  Select faces as the Compulsory walls.

These are faces from which the walls are to be generated when there might be an ambiguity. For 

example, if the initial part is a box, you will need to select two opposite inner faces and outer 

faces on the other two sides of the box, in order to avoid overlapping when generating the walls. 

5.  Set the Internal profiles recognition mode: 

●     As cut out wall: generates walls with inner profiles (no cutout feature is generated)

●     One cut out by wall: regardless of how many pockets there are on a face of the solid, only one 

cutout feature is generated per wall

●     One cut out by profile: for each inner profile on the sketch-based solid,  a cutout feature is 

generated

●     None: whether there are pockets on the solid faces, or not, no cutout feature is created in the 

resulting SheetMetal features.

The Generate Bends check button allows the automatic creation of bends as the walls are being 
created, wherever applicable.



6.  Click Apply.

The walls are generated from the Part 
Design geometry.

The Walls Recognition.1 feature is 
added to the tree view. 

At the same time, the sheet metal parameters are created, deduced from the Part geometry.

7.  Select the icon  to display the sheet 

metal parameters:

●     the Thickness is equal to 1mm

●     the Bend radius is twice the thickness value

●     the Bend Extremities field is set to Square 
relief.



You can modify a few of these parameters. 
The Thickness parameter cannot be modified because it is based, like the bend extremities and radius, 
on the initial solid geometry . However you can modify these parameters (bend radius and bend 
extremities) to be taken into account for sheet metal features other than the "recognized" ones.
The bend allowance, being used to unfold the part, and the corner relief affect all features, and therefore 
can be edited even for "recognized" features.

8.  Click OK in the Sheet Metal Parameters when all parameters have been redefined where needed.

The solid is now a Sheet Metal part. All the features are displayed in the specification tree.
●     Once the solid has been converted to a Sheet Metal part, you can create bends as with any other 

Sheet Metal part, or modify/add Sheet Metal features to complete the design.

●     Uncheck the Generate Bends button, if you do not wish bends to be created automatically.



Extruding

This task explains how to create a wall by extrusion.
You can extrude sketches composed of lines, circles, projection of lines, and projection of circles.

You must have defined the Sheet Metal parameters.
A model is available in the Extrude1.CATPart from the samples directory.

1.  Click the Extrusion icon .

2.  Select a sketch.

The Extrusion Definition dialog box is displayed. 

Several types of extrusion are available:  
●     Dimension : the requested input data are a sketch and a dimension,

●     Up to plane or Up to surface: a plane or a surface are input as limit to the extrusion. These 
functions are used to create walls that are not rectangular.

3.  Edit the Length1 and Length2 to set both extremities, for option Dimension.
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4.  Define the options as needed:

●     Check the option Mirrored extent to extent the material on both sides of the sketch.  In that case, 
only Length1 can be edited. 

 

This option is only available if the type is set to Dimension.

●     Check Symmetrical thickness to create thickness inside and outside the sketch.



●     Push Invert Material Side to invert the direction of the creation of the material.

 

5.  Click OK.

The walls corresponding to the selected sketch are created according to the specified options, 

and added to the specification tree.

●     When the extrusion is the first Sheet Metal feature of the Part, the reference wall is the first wall 
created based on the first segment of the sketch.

●     For option Up to Surface, while the wall end that is limited by the surface has the shape of the 
surface, its thickness does not fit the surface. It is a "rectangular" polygon defined by the first edge 
that comes into contact with the surface.



 

●     Such an extrusion can also be performed on a sketch made 
of lines and arcs of circle, provided there are no tangency 
discontinuities between the different elements. 
However, in this case: 

❍     the Up to plane or Up to surface capabilities are not 
available, 

❍     you cannot isolate such an extrusion,

❍     if the element of the extruded sketch connected to the 
part is an arc of circle, the extrusion will not display in 
the unfolded view. To avoid this, prefer to create a User 
Defined Flange or remove the arc of circle of the 
extruded sketch and create a bend to connect the 
extrusion to the part.

●     Extrusion walls can be edited and/or isolated.

The sketch may not be closed. 

 



Isolating Walls
This task explains how to isolate a wall. This is possible in two cases: 

●     after having created walls by extrusion (see Extruding)

●     after having created a wall on edge (see Creating Walls from an Edge).

 
You must have defined the Sheet Metal parameters.
A model is available in the Extrude2.CATPart from the samples directory.

Isolating Extruded Walls
1.  Right-click the Extrusion.1 feature and choose the 

Extrusion.1 object -> Isolate contextual menu item.

The Extrusion Isolate dialog box is displayed.  

2.  Select one of the wall of the extrusion to be isolated.

The selected wall is highlighted in the geometry.

This wall is the reference wall, meaning that it can 

be modified and the other walls will take the 

modification into account. On the other hand if the 

other walls are modified the reference wall is an 

anchoring wall, and modifications will be made 

around it. 

The Extrusion Isolate dialog box is updated.

3.  Click OK in the dialog box.

The walls of the extrusion have been isolated, each with its own sketch. Yet coincidence 

constraints are automatically generated between the isolated walls. 
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The extrusion's initial sketch is retained (Sketch.1 in the example above).

4.  Double-click the sketch of the reference wall (here 

Sketch.3) and modify it by increasing its length.

5.  Exit the Sketcher using the Exit icon .

The Part is updated.

You can note that the wall that was adjacent to the 

pad, now lies on it, as it is the reference wall that 

was modified.



However, had you modified the sketch of the wall 
lying on the pad (Sketch.4), moving it further away 
from Wall.2 as shown here to the right, the updated 
pad would not take the gap between the walls into 
account.

The resulting part looks like this (Wall.3 has been 
modified but still coincides with Wall.2):

Isolating Walls on Edge
1.  Right-click the wall on edge and choose the Wall On Edge contextual menu item.

The wall on edge is then changed to a standard wall, as you can see from the specification 

tree. 



 

You can then edit its sketch if needed.

In the present case, the wall on edge had been 
created with a bend. Therefore when isolating this 
wall from the reference wall, the bend is created as 
a separate feature that can be edited as well.

The angle value between the two walls is displayed 
for edition.

●     You cannot undo an Isolate action after having modified the wall.

●     Isolating a wall on edge erases all updating data.



Creating Rolled Walls

This task shows how to create rolled walls (such as pipes, open pipes with flange, etc.).

You must have defined the Sheet Metal parameters, and have a sketch available, in the form of an 
circular arc.
The part is available in the Rolledwall1.CATPart from the samples directory.

1.  Click the Extrusion icon .

2.  Select the circular sketch.

3.  Make sure the type is set to Dimension.

4.  Length 1 and Length 2 indicate the location of Limit 1 

and Limit 2.

5.  Define the options as needed (the length being down to -50 mm):
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●     Check the option Mirrored extent to extend the material on 
both sides of the sketch. In that case, only Length1 can be 
edited.

●     Check Symmetrical thickness to create thickness inside 
and outside the sketch.

●     Click Invert Material Side to invert the direction of the 
creation of the material.

6.  Click OK in the dialog box to create the rolled wall:



The rolled wall is a particular extrusion: 
●     the input sketch is either a circular arc or a closed circle,

●     the creation type is always Dimension.

The sketch may be open. In that case, you can define where the opening should be.

The sketch may be closed. In that case, you have no control on the opening location.

The only operations you can combine with a rolled wall in a Sheet Metal model are flanges and cutouts. 

No other elements (standard wall, bend,...) are allowed.

 



Creating Bends on Walls
 

This section explains and illustrates different methods to create bends on walls. Bends can only be created 
between walls, whether manually or automatically, and not between any other Sheet Metal features, such as 
stamps for example.

Manually create bends from walls: select the two walls, set the bend radius value, the bend extremities, 
and specify the use of corner relief
Generate bends automatically: select the part, then a reference wall

Create conical bends: select the part, and choose a reference wall

Create bends from a line: select a sketch, set the creation mode and limiting option, set the radius and 
angle in relation to the selected sketch.

 



Manually Creating Bends from Walls

This task explains two ways to create bends between walls in the Sheet Metal part.
These bends can be created on non-connex walls, and with a constant radius value.

Open the BendExtremities01.CATPart document from the samples directory.

1.  Select the Bend icon .

The Bend Definition dialog box opens.

Note that the Radius field is in gray because it is driven by a formula when editing the sheetmetal parameters: at 

that time, you cannot modify the value.

2.  Select Wall.2 and Wall.5 in the specification tree.

The Bend Definition dialog box is updated.

3.  Right-click the Radius field and select 

Formula -> Deactivate from the 

contextual menu to change the value.
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4.  Enter 4mm for the Radius and click 

Preview.

The bend is previewed, along with its 
orientation symbolized by arrows. The 
Left and Right texts further indicate this 
orientation and are useful to define 
different bend extremities. 

5.  Click the More>> button to display further options: 

You can define:  
●     the left and right extremity settings (see also extremities definition settings)

●     the corner relief definition settings

●     and the bend allowance settings.

6.  Within the Left Extremity tab, choose the 

Mini with round relief bend extremity type, 

deactivate the L1  and L2 length formulas, 

and set them to 6mm and 3mm 

respectively.

       



7.  Click the Right Extremity tab, and choose 

the Curved shape type.

8.  Click Preview to visualize the left and right 

extremities.

9.  Click OK in the Bend Definition dialog box.

The Bend (identified as Cylindrical Bend) 

is created with the specified extremity 

types and is added to the specification 

tree. 

●     The extremities and the corner relief defined with the current dialog box will apply locally and prevail over any 
other global definition.

●     Be careful when creating bends with square or round relief. Depending on the geometry configuration, this 
can lead to removing more matter than you would expect. Indeed, a corner relief being computed on the 
whole intersection of the elements involved (bends or bend/wall), in the following configuration, the matter is 
removed till the end of the wall.



Bend with no relief Bend with square relief
In this case, it is best to replace the bend corner relieves with cutouts (identified in red in the figure 
below) that will act as corner relieves removing matter to the part.

 



Generating Bends Automatically

This functionality is only available with SheetMetal Design.

This task explains how to automatically generate bends between walls in the Sheet Metal part. You can 
first create all the bends, then modify the parameters for any of the generated bends.

However, when an ambiguity arises, that is when more than two bends end on the same vertex, the 
bends are not automatically generated. You then need to create them manually, so as to explicitly select 
the walls between which the bends are to be created.

Open the BendExtremities01.CATPart document from the samples directory.

1.  Select the Automatic Bends icon .

The bends are created. 
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2.  Double-click the bend of 

interest: Bend.4

The Bend Definition dialog 

box opens.

3.  Right-click the Radius field: 

the contextual menu 

appears.

4.  Deactivate the formula:

you can now change the 

value.

5.  Enter 4mm for the Radius 

and click Preview.

Bend.4 is modified. 

6.  Click the More button to display further options: 



You can re-define:  
●     the left and right extremity settings (see also extremities definition settings)

●     the corner relief definition settings

●     and the bend allowance settings.

7.  Within the Left Extremity tab, 

choose the Mini with round 

relief bend extremity type, 

deactivate the L1  and L2 

length formulas, and set 

them to 6mm and 3mm 

respectively.

8.  Click the Right Extremity tab, 

and choose the Curved shape 

type.

9.  Click OK in the Bend Definition dialog box.

The bend is modified with the specified options



The extremities and the corner relief defined with the current dialog box will apply locally and prevail 
over any other global definition.

 

Push the more button to display:
●     the extremities definition settings,

●     the corner relief definition settings, 

●     and the bend allowance settings.

 



Creating Conical Bends

This task explains how to generate conical bends between two walls in the Sheet Metal part.
These bends are different from the standard bend in that they allow different radius values at each end 
of the bend.

Open the ConicalBend1.CATPart document from the samples directory.

1.  Select the Conic Bend icon .

The Conic Bend Definition dialog box opens.

2.  Select Wall.1 and Wall.2 in the specification tree or in the 

geometry.

The Bend Definition dialog box is updated, and arrows are 

displayed indicating the walls orientation.

You can click on the arrow to invert them if needed.

The LIM1 and LIM2 texts indicate the endpoints for the 

bend.

3.  Enter the radius values for each end of the conical bend.

If the difference between the specified radius values does not allow the generation of a cone with 

an angle greater than 1 degree, a warning is issued prompting you to increase one of the radii.

Click OK in the Warning dialog box, and increase/decrease the radius values.

By default, Radius 2 is twice Radius 1.
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4.  Click More... to display further options.

5.  Choose the bend extremities:

●     Mini with no relief: the shortest possible bend is created, and presents no relief

●     Curve shaped: the bend is created keeping the tangency continuity with the support walls.

●     Maximum: the bend is calculated between the furthest opposite edges of the supporting walls.

6.  Click OK.

The Bend is created. 



●     The two walls must be connected by the edge of their internal faces.

●     The Angle field is locked. It indicates the angle value between the two walls between which the bend 
is computed.

●     Should you choose the Curve shaped extremity option, the bend would look like this:



Creating Bends From a Line

This task explains how to generate bends based on a line (also called flat bends). A wall and a bend are 
created.

Open the FlatBend1.CATPart document from the samples directory.

1.  Select the reference wall then the Bend From 

Flat icon .

The Bend From Flat Definition dialog box 

opens.

2.  Select a sketch (Sketch.3 here).

This sketch must necessarily be a line.

3.  You can choose the line extrapolation option:

●      the line is extrapolated up to the wall edge (Bend From Flat Until)

●      the line is not extrapolated, and the bend is limited to the line's length (Bend From Flat 

Length)

The Radius value is the one defined when editing the sheetmetal parameters:
Right-click the Radius field and select Formula -> Deactivate from the contextual menu to 
change the value.
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4.  Set the angle value between the generated wall and the reference wall.

5.  Click OK to create the bend.

     

●     When creating such a bend on a reference wall 
(first wall), an arrow indicates which part is to be 
folded. Click this arrow to invert the side that will 
be bent.

 

●     Such bends cannot be created, if the section to be 
folded already intersects the part. 

 
●     Bends from line should be performed on end walls, or prior to creating further walls on the bent one.

●     Perform the bend before creating the stamping features, as stamps are not retained when the part is 
folded with the bend.



Creating Swept Walls
 

This section explains and illustrates how to create and use various kinds of swept walls, i.e. walls based on a 
given profile that is swept along a spine.

Create a flange: select a spine, and set the radius, length, and angle values.

Create a hem: select a spine, and set the radius, and  length values.

Create a tear drop: select a spine, and set the radius, and  length values.

Create a swept flange: select a spine, and a user-defined profile

Redefine swept walls limits: choose the Relimited type, and select a point lying on the spine or a 
plane normal to the spine and intersecting it as limits

Selecting the Spine
Whatever the type of the swept wall you wish to create, you first need to select one or more contiguous edges 
to make up the spine along which the profile, either pre- or user-defined, is to be swept. You can:

●     manually select one, or more, edge(s)

Selection without propagation Resulting flange without propagation
    

●     select  one edge and click the Tangency Propagation button: all contiguous and tangent edges are 
selected. In this case, would you need to remove one edge, you need to manually select it. Remember that 
only extremity edges can be removed without breaking the continuity between edges.



Selection with propagation Resulting flange with propagation



Creating a Flange

This task explains how to generate a flange from a spine and a profile.

Open the SweptWall01.CATPart document from the samples directory.

1.  Select the Flange icon .

  

The Flange Definition dialog box opens. 

2.  Select the edge as shown in red.

file:///E|/Www/cnqr14/Doc/online/cfysm_C2/samples/SheetMetal/SweptWall01.CATPart


3.  Enter 2mm in the Radius field,

10mm in the Length field and 120deg for the 

Angle.

4.  Click the More button to display the Bend Allowance tab allowing you to locally redefine the 

bend allowance settings. 

You may need to deactivate the formula using the contextual menu on the field and choosing 

Formula -> Deactivate before editing the value.

In this case, the new K Factor value overrides the value set in the Sheet Metal Parameters.

5.  Click OK to create the flange.



The feature is added to the specification tree.

●     Use the Tangency Propagation button to select all tangentially contiguous edges forming the spine 
(see Selecting the Spine).

●     You can redefine the flange limits by choosing the Relimited option (see Redefining Swept Walls 
Limits).



Creating a Hem

This task explains how to generate a hem from a spine and a profile.

The SweptWall01.CATPart document is still open from the previous task.
If not, open the SweptWall02.CATPart document from the samples directory.

1.  Select the Hem icon  in the Swept Walls sub-

toolbar.

The Hem Definition dialog box opens.

2.  Select the edges as shown in red.
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3.  Enter 2mm in the Radius field, and 3mm in the Length 

field.

4.  Click the More button to display the Bend Allowance tab allowing you to locally redefine the 

bend allowance settings. 

You may need to deactivate the formula using the contextual menu on the field and choosing 

Formula -> Deactivate before editing the value.

In this case, the new K Factor value overrides the value set in the Sheet Metal Parameters.

5.  Click OK to create the hem.



The feature is added to the specification tree.

●     Use the Tangency Propagation button to select all tangentially contiguous edges forming the spine 
(see Selecting the Spine).

●     You can redefine the hem limits by choosing the Relimited option (see Redefining Swept Walls 
Limits).



Creating a Tear Drop

This task explains how to generate a tear drop from a spine and a profile.

The SweptWall01.CATPart document is still open from the previous task.
If not, open the SweptWall03.CATPart document from the samples directory.

1.  Select the Tear Drop icon  in the Swept Walls sub-

toolbar.

The Tear Drop Definition dialog box opens.

2.  Select the edge as shown in red.

file:///E|/Www/cnqr14/Doc/online/cfysm_C2/samples/SheetMetal/SweptWall01.CATPart
file:///E|/Www/cnqr14/Doc/online/cfysm_C2/samples/SheetMetal/SweptWall03.CATPart


3.  Enter 3mm in the Radius field, and 8mm in the Length 

field.

4.  Click the More button to display the Bend Allowance tab allowing you to locally redefine the 

bend allowance settings. 

You may need to deactivate the formula using the contextual menu on the field and choosing 

Formula -> Deactivate before editing the value.

In this case, the new K Factor value overrides the value set in the Sheet Metal Parameters.

5.  Click OK to create the tear drop.



The feature is added to the specification tree.

 
●     Use the Tangency Propagation button to select all tangentially contiguous edges forming the spine 

(see Selecting the Spine).

●     You can redefine the hem limits by choosing the Relimited option (see Redefining Swept Walls 
Limits).



Creating a Swept Flange 

This task explains how to generate a swept flange from a spine and a user-defined profile.

The SweptWall01.CATPart document is still open from the previous task.
If not, open the SweptWall04.CATPart document from the samples directory. As a profile is already 
defined on the part, you will be able to skip step 1 of the scenario.

1.  If you are using the SweptWall01.CATPart document, click the Sketcher icon , and define a 

profile in the yz plane as shown below:

Then quit the Sketcher, using the Exit icon .

If you are using the SweptWall04.CATPart, go directly to step 2 as the profile is already 

defined.

2.  Select the Swept Flange icon in the Swept Walls sub-

toolbar.

The User Defined Flange Definition dialog box opens. 

3.  Select the edge and the profile, as shown in red.
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The dialog box looks like this:

4.  Click the More button to display the Bend Allowance tab allowing you to locally redefine the 

bend allowance settings. 

You may need to deactivate the formula using the contextual menu on the field and choosing 

Formula -> Deactivate before editing the value.



In this case, the new K Factor value overrides the value set in the Sheet Metal Parameters.

5.  Click OK to create the swept flange.

The feature is added in the specification tree.

 

●     Use the Tangency Propagation button to select all tangentially contiguous edges forming the spine 
(see Selecting the Spine).

●     You can redefine the hem limits by choosing the Relimited option (see Redefining Swept Walls 
Limits).



Redefining Swept Wall Limits

This task explains how to redefine the spine's limits when creating any type of swept walls, using existing 
geometric elements: points lying on the spine or intersecting planes.

Open the SweptWall01.CATPart document.

1.  Select the Flange icon .

The Flange Definition dialog box opens. 

2.  Using the combo list, choose the Relimited type.

The Flange Definition dialog box is updated and now displays two Limit fields. 

 

 
3.  Select the spine.

Here we select a single edge. See also Selecting the Spine.
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4.  Successively select the two limiting elements. 

Here we select a point lying on the spine as the first selecting element, and a plane intersecting 

the spine as the second limiting element.

 

Make sure intersecting elements are normal to the spine, and they intersect it only once.



5.  Specify the swept wall values.

In the example of the flange you set the Radius, Length and Angle values. You may also click 

More >> to display further options. See Creating a Flange. 

6.  Click OK.

The swept wall is created within the limits on the spine.

  



Unfolding
Unfolded Sheet Metal parts can be displayed in two ways:

Folded/Unfolded View Access
Concurrent Access

 
Each Sheet Metal feature is created in a given view: folded, or unfolded. Editing a feature must be done 
in its definition view. If not, a message is automatically issued, prompting you to change views, before 
editing the feature.
 

 



Folded/Unfolded View Access

This task shows how to unfold the part. 

To perform this scenario, you can open any sheet metal sample provided in this user's guide.

1.  Click the Unfold icon .

The part is unfolded according to the reference wall plane or web, as shown below. 

2.  Click this icon  again to refold the part for the next task.

●     In SheetMetal Design, bend limits and stamping are now displayed in the unfolded view. However, 

cutouts created on stamps are not.

●     When designing in context, if a CATProduct document contains several sheet metal parts, only one 
part can be visualized in the unfolded view at a time.



Concurrent Access

This functionality is P2 for SheetMetal Design.

To perform this scenario, you can open any sheet metal sample provided in this user's guide.

This task explains how to display the sheet metal part in two windows: one with the folded view, one with the unfolded 
view. Any modification in one window is displayed in the other window.

1.  Click the Multi-view icon .

The part is unfolded in a second window.  

2.  Choose the Window -> Tile Horizontally menu item.

Both windows are tiled. Activate the window in which you want to work. 



●     Any modification in one view is taken into account in the other view enabling the user to make modifications in the 
best possible context.

●     In the multi-view mode as in the standard unfolded view, all constraints are displayed in the geometrical views.

●     Once in the Multi-view mode, the standard icon Unfold is not longer available.

●     The Multi-view function is not available from a standard unfolded view.

●     Only parts with bends can be unfolded.

●     Cutting faces and open faces are not displayed in Multi-view mode (SheetMetal Design)



Pockets
Creating a Cutout
Splitting Geometry

 



Creating a Cutout

This task explains how to create a cutout in a wall.
Creating a cutout consists in extruding a profile and removing the material resulting from the extrusion.

Open the Cutout1.CATPart document.

1.  Click the Cutout icon .

2.  Select a profile.

        
 

The Pocket Definition dialog box is displayed and CATIA 

previews a cutout with default parameters. 

 

Once the sketch is selected, you can modify it by clicking the Sketcher icon .

3.  Select the type.
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Several limit types are available: 

●     Dimension: the cutout depth is defined by the specified value

●     Up to next: the limit is the first face the application detects while extruding the profile. This face must stops the 

whole extrusion, not only a portion of it, and the hole goes through material.

●     Up to last: the last face encountered by the extrusion is going to limit the cutout

●     Up to plane: the cutout is limited by the selected plane

●     Up to surface: the cutout is limited by the selected surface

When an Offset value is required, it is the distance between the limiting element and the top face of the cutout, if the 
latter does not result in a complete hole through the material.

The LIM1 and LIM2 texts in the geometry area indicate the top and bottom limits of the cutout.

●     The Reverse Side option lets you choose between removing the material defined within the profile, which is the 

application's default behavior, or the material surrounding the profile. 

●     The Reverse Direction option allows you to invert the direction of the extrusion pointed by the arrow.

4.  Click OK in the Pocket Definition dialog box.

The cutout is created. 

You may want to fold or unfold the part prior to creating the cutout, depending on the selected profile and the expected 
results. Selecting the same profile, the resulting cutout when created in the unfolded view is seen above, while below, 
the cutout was created in folded view.



However, you also have to be careful when designing the Part, not to create the cutout in the unfolded view as this may 
lead, when folding the part, to completely or partially removing another section of the Part. It is best, whenever 
possible, to create the wall based on a sketch integrating the shape of the cutout.

Cutout removing material Cutout not removing material based on wall's sketch 
modification

4.  Click More>> to display the maximum information.

●     You can define 'Limit2' as the second limit by using the 
same options as for Limit 1 (Dimension, Up to last, up 
to plane, up to surface). 

●     You can choose between a direction normal to the 
profile or define a new direction by selecting geometry 
in the Reference field.

●     You can choose the cutout to be normal to the sheet 
metal part: check the Activation button and define the 
sheet metal side.

5.  Select the Support (here we chose the wall)



May you want to create a cutout on an overlapping element or a bend with radius=0, either choose the top skin of the 
element, or unfold the part to create the cutout.

●     Refer to the Component Catalog Editor documentation to have further information on how to use catalogs.

●     Refer to the Pocket task in the Part Design User's Guide for further details on how to create cutouts.

 

file:///E|/Www/cnqr14/Doc/online/prtug_C2/prtugbt0502.htm


Splitting Geometry

This functionality is only available with SheetMetal Design.

This task shows how to create a split normal to a sheet metal part by means of a cutting surface.

Open the Split1.CATPart document.

1.  Click the Split icon . The Split dialog box appears. 

 

2.  Select the Splitting Surface.

3.  Select the Reference Side of the element to split.

 

The red arrow shows the side to keep
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4.  Click the Inverse Side button to keep the other side.

5.  Click Apply to preview the split: the side to 

be removed is highlighted in green. 



6.  Click OK to split the element.

The created element (identified as 
Split.xxx) is added to the specification 
tree.



You can create a split using the unfolded view of the part.



Stamping
This section explains and illustrates how to create and use various kinds of stamps.

●     Stamps must be created on walls, or walls on edge, except for the stiffness rib that is to be created 
on a bend. 

●     If a stamp is created over the limit between several supports, such as walls, bends, and so forth, this 
stamp is not visible on the unfolded view.

●     When unfolding a part, only the largest imprint of the stamp is retained on the stamped wall.

●     Stamps cannot be created on an unfolded part.

Creating Standard Stamping Features
Creating User-Defined Stamping Features

 



Creating Standard Stamping Features
 

This section explains and illustrates how to create and use various kinds of stamps.
The table below lists the information you will find.

Create a point stamp: select a point on a face, and set the stamping parameters. 

Create an extruded hole: select a point on a face, and set the stamping parameters. 

Create a curve stamp: select a sketch, and set the stamping parameters. 

Create a surface stamp: select a sketch, and set the stamping parameters. 

Create a bridge: select a point on a face, set the stamping parameters, and select an edge to give the 
bridge orientation. 

Create a louver: select a sketch, and set the stamping parameters. 

Create a stiffening rib: select the external surface of a bend, and set the stamping parameters. 



Creating a Point Stamp

This task shows you how to create a point stamp by specifying the punch geometrical parameters.

Open the Stamping.CATPart document from the samples directory.

1.  Click the Point Stamp icon .

2.  Select a point on the top face. 

A grid is displayed to help you position the point 
stamp.

The Point Stamp Definition dialog box opens, providing default values.

3.  Change the value in the different fields, if needed:

●     Height H

●     Radius R1

●     Radius R2

●     Angle A

●     Diameter D

4.  Click Apply to preview the point stamp.

 
5.  Click OK to validate.

The point stamp (identified as Point Stamp.xxx) is created and the specification tree is updated accordingly.
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Check the No radius option to deactivate the Radius R1 and 
R2 values, and to create the bridge stamp without a fillet.



Creating an Extruded Hole

This task shows you how to create an extruded hole by specifying the punch geometrical parameters.

The Stamping.CATPart document is still open from the previous task.
If not, open the Stamping8.CATPart document.

1.  Click the Extruded Hole icon .

2.  Select the surface where you want to place 

the hole.

A grid  is displayed to help you position the 

flanged hole and the Flanged Hole Definition 

dialog box opens, providing default values.

3.  Change the value in the different fields, if 

needed:

●     Height H

●     Radius R

●     Angle A

●     Diameter D

4.  Click Apply to preview the flanged hole.

5.  Click OK to validate. 

The extruded hole (identified as Extruded Hole.xxx) is created and the specification tree is updated accordingly.
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Check the No radius option to deactivate the Radius 
R1 and R2 values, and to create the point stamp 
without a fillet.

 



Creating a Curve Stamp

This task shows you how to create a curve stamp by specifying the punch geometrical parameters.

The Stamping.CATPart document is still open from the previous task.
If not, open the Stamping3.CATPart document from the samples directory.

1.  Click the Curve Stamp icon .

2.  Select Sketch-for-Curve-Stamp, the curve previously defined. 

The Curve Stamp Definition dialog box opens, providing default values.
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3.  Change the value in the different fields, if needed:

●     Height H: the total height

●     Radius R1: the outer bend radius

●     Radius R2: the outer bend radius

●     Angle A: the stamping draft angle 

●     Length L: the stamps' maximum width

4.  Click Apply to preview the curve stamp.

 

5.  Click OK to validate.

The curve stamp (identified as Curve Stamp.xxx) is created and the specification tree is 

updated accordingly.



 



●     Check the No radius option to deactivate the Radius 
R1 and R2 values, and to create the curve stamp 
without a fillet.

 
●     Check the Obround option to round off the edges of 

the curve stamp.
 

 

Obround option checked Obround option unchecked

 



Creating a Surface Stamp

This task shows you how to create a surface stamp by specifying the punch geometrical parameters.

The Stamping.CATPart document is still open from the previous task.

If not, open the Stamping4.CATPart document from the samples directory.

1.  Click the Surface Stamp icon .

2.  Select Sketch-for-Surface-Stamp, the profile previously defined. 

The Surface Stamp Definition dialog box opens, providing default values.

 

3.  Change the value in the different fields, if needed:

●     Height H

●     Radius R1

●     Radius R2

●     Angle A
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4.  Click Apply to preview the surface stamp.

5.  Click OK to validate.

The surface stamp (identified as Surface Stamp.xxx) is created and the specification tree is updated accordingly.

 

Check the No radius option to deactivate the Radius R1 
and R2 values, and to create the surface stamp without a 
fillet.

 



Creating a Bridge

This task shows you how to create a bridge by specifying the punch geometrical parameters.

The Stamping.CATPart document is still open from the previous task.
If not, open the Stamping5.CATPart document from the samples directory.

1.  Click the Bridge icon .

2.  Select a point on the top face where you want to place the bridge.

The Bridge Definition dialog box opens, providing default values. 

3.  Change the value in the different fields, if 

needed:

●     Height H

●     Radius R1

●     Radius R2

●     Angle A

●     Length L1

●     Length L2

4.  Select an edge to give the direction of the bridge.
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5.  Click Apply to preview the bridge.

 
6.  Click OK to validate.

The bridge (identified as Bridge.xxx) is created and the specification tree is updated accordingly.

 

Check the No radius option to deactivate the Radius R1 
and R2 values, and to create the bridge stamp without a 
fillet.

 



Creating a Louver 

This task shows you how to create a louver by specifying the punch geometrical parameters.

Open the Stamping6.CATPart document from the samples directory.

1.  Click the Louver icon .

2.  Select Sketch-for-Louver, a profile previously defined on Wall.2. The Louver Definition dialog box opens, providing default 

values.

The louver opening face is represented in the sketch by the element that does not present any tangency continuity with the other 
lines/curve segments of the sketch. In case there are several non-continuous elements, the first one is used as the opening face.

3.  Change the value in the different fields, if needed:

●     Height H

●     Radius R1

●     Radius R2

●     Angle A1

●     Angle A2

4.  Click Apply to preview the louver.

5.  Click OK to validate.

The louver (identified as Louver.xxx) is created and the specification tree is updated accordingly.
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Check the No radius option to deactivate the Radius R1 and 
R2 values, and to create the louver stamp without a fillet.



Creating a Stiffening Rib

This task shows you how to create a stiffness rib by specifying the punch geometrical parameters.

Open the Stamping7.CATPart document from the samples directory.

1.  Click the Stiffness Rib icon .

2.  Select the external surface of Bend.1, where you want to place a stiffener.

Note that the stiffener will always be centered on the bend radius, wherever the point may be along the curve.

A grid is displayed.

The Stiffening Rib Definition dialog box opens, providing default  values.

3.  Change the value in the different fields, if 

needed:

●     Radius R1

●     Radius R2

●     Angle A

●     Length L

4.  Click Apply to preview the stiffness rib.

5.  Click OK to validate.

The stiffening rib (identified as Stiffnening Rib.xxx) is created and the specification tree is updated accordingly.
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Check the No radius option to deactivate the Radius R1 and R2 values, and to create the stiffening rib without a fillet.



Creating User-Defined Stamping Features
Two user-defined stamping features are available: 

 Create a punch and a die:  define the punch and die features, select a wall, choose the punch and die as stamping elements, select an 
edge on the wall and give an angle for orientation purposes.

 Open and cut faces: define the punch, select a wall, define the cutting faces and opening faces of the punch, select an edge on the 
wall and give an angle for orientation purposes.

 Edit a user-defined stamp: double-click the existing stamp and change its type, or select, or remove cutting and opening faces

What You Should Know 

In both tasks illustrating either a stamp based on a punch and a die, or a punch with cutting and opening faces, the punch positioning is 
defined as below: 

Defining the Punch in Relation to the Wall to be Stamped

The punch is defined within the absolute (default) axis-
system of the .CATPart document. (o, x, y, z) is the 
axis associated with the punch. The punching direction 
on the punch (Dp) must be equal to z.

The punching direction on the wall (Dw) is normal to 
the selected wall face, and is oriented from the selected 
wall face towards the opposite face.

The punch is applied matching Dp on Dw and matching the punch's (x, y) plane onto the selected wall face:



Defining the Die in Relation to the Wall to be Stamped
This is useful only when defining a punch a die, and does not apply to punches with cutting and opening faces.

The die is also defined within the absolute (default) axis-
system of the .CATPart document. (o, x, y, z) is the 
axis associated with the punch. The punching direction 
on the die (Dd) must be equal to z. 

The illustration is a section view of the die.

The die is applied matching Dd on Dw and matching the die's (x, y) plane onto the selected wall face:



Creating a Punch with a Die

This task explains how to create a stamp from punch and die features. 

First, you will define a punch and a die in Part Design, in the absolute axis-system.
Then, in a Sheet Metal part, you will bring the punch and the die features (and their axis system) to a point you have selected. If necessary, you will 
define a rotation of the axis system from a reference line.

This user-defined stamping cannot be combined with the Opening and Cutting Faces approach.

All .CATParts are available from the samples directory (PunchDie1.CATPart, Punch1.CATPart and Die1.CATPart or NEWPunchDie1.CATPart, 
NEWPunch1.CATPart and NEWDie1.CATPart for Generative Sheetmetal Design or Aero_PunchDie1.CATPart, Aero_Punch1.CATPart and 
Aero_Die1.CATPart for Aerospace Sheetmetal Design).

1.  Start the Part Design application.

2.  Insert a PartBody (menu Insert -> Body) to define the punch.

3.  Enter the sketcher  select the yz plane, 

and draw the profile of the punch, and a 

rotation shaft.

 

The punch must be oriented as described 
in Defining the Punch in Relation to the 
base feature to be Stamped.

4.  Return to the 3D space and create the punch 

using the Shaft icon .

5.  Repeat from step 2 to step 4 to define the die, making sure that it is oriented as described in Defining the Die in Relation to the base feature 

to be Stamped.

file:///E|/Www/cnqr14/Doc/online/cfysm_C2/samples/SheetMetal/PunchDie1.CATPart
file:///E|/Www/cnqr14/Doc/online/cfysm_C2/samples/SheetMetal/Punch1.CATPart
file:///E|/Www/cnqr14/Doc/online/cfysm_C2/samples/SheetMetal/Die1.CATPart
file:///E|/Www/cnqr14/Doc/online/cfysm_C2/samples/SheetMetal/NEWPunchDie1.CATPart
file:///E|/Www/cnqr14/Doc/online/cfysm_C2/samples/SheetMetal/NEWPunch1.CATPart
file:///E|/Www/cnqr14/Doc/online/cfysm_C2/samples/SheetMetal/NEWDie1.CATPart
file:///E|/Www/cnqr14/Doc/online/cfysm_C2/samples/Aero_PunchDie1.CATPart
file:///E|/Www/cnqr14/Doc/online/cfysm_C2/samples/Aero_Punch1.CATPart
file:///E|/Www/cnqr14/Doc/online/cfysm_C2/samples/Aero_Die1.CATPart


6.  Return to the Sheet Metal application, and if needed, use the Define In Work Object on the PartBody containing the wall or the base feature 

to be stamped.

7.  Click the User Stamping icon  from the Stamping tool bar and select a base feature, or a face where the stamping is to be created. 

This base feature or face is used to define the stamping location and direction, by matching the punch's origin to the selected point on the 

base feature.

The User Defined Stamp Definition dialog box is displayed:

8.  Make sure the With die  icon is pressed 

down and select the Punch feature from the 

specification tree.

The punch's positioning is previewed in the 

geometry.

9.  Select the Die feature. 

The die's positioning is previewed in the 

geometry as well.



10.  Check the No Fillet button is you do not wish the stamp to be filleted, or set the radius value if you wish the stamp to be filleted. 

Stamp without fillet Stamp with fillet

11.  If needed, define the stamp's positioning on the selected base feature by choosing:

●     a Reference for rotation: by default, it is the sketch axis, but you can also select any line or edge on base feature.

●     a Rotation angle value: you can either enter a value in the dialog box, or use the manipulator in the geometry to define this value.

●     a new Origin point on the base feature to coincide with the punch's point of origin.

This is especially useful for non-circular stamps, but you can very well create the stamp as is, without further positioning.

13.  Click OK to validate and create the stamping.

By default the Punch and Die parts are set in No Show mode when clicking OK to create the stamp on the base feature. 



●     Radius is the radius of the bend between the stamping and the base feature.

●     Punch and Die are the bodies you have defined previously. If the punch and the die are in another CATPart document, activate this document 
before clicking the punch or the die.

●     If you select two reference lines in addition to the plane, this will create two editable constraints to position the stamping. These constraints are 
editable.

 
●     A user-defined stamping can be edited (punch, die, position, constraints).

●     As the punch and die are not symmetrical, you cannot create such features as a cutout, a hole, a corner, etc., on this kind of stamping.

●     If you enter a punch and a die, the stamping is 
the difference of the shape of both features.

 

●     The punch height cannot be superior to the base 
feature height, otherwise it is considered as a 
cutout.



●     You may create a user-defined stamping from a 
punch only but you cannot create a fillet.  

 

●     Only the stamping sketch is displayed in unfolded 
views.

 

●     The punch and die bodies can be defined in the 
Sheet Metal part where the stamping is to be 
created (see PunchDie1.CATPart or 
NEWPunchDie1.CATPart in the samples 
directory).

In this case, make sure you select the 
Define In Work Object on the PartBody 
containing the base feature to be stamped, 
prior to actually creating the stamp.

or as two separate Part Design parts (Punch1.CATPart and Die1.CATPart from the samples directory)

 

In this case, when selecting the punch or die feature, the system automatically copies this feature into the .CATPart document into which the base 
feature to be stamped is located.
A link is retained between the initial punch or die feature and its copy.
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Opening and Cutting Faces

This task explains how to create a stamp from a punch feature with cutting and opening faces. 

First, you will define a punch in Part Design, in the absolute axis system.
Then, in a Sheet Metal part, you will bring the punch feature (and its axis system) to a point you have 
selected. If necessary, you will define a rotation of the axis system from a reference line.

This user-defined stamping cannot be combined with the Punch and Die approach.

All CATParts, OpenFaces1.CATPart and CuttingFaces1.CATPart, are available from the samples directory.

1.  Start the Part Design application.

2.  Insert a PartBody (menu Insert -> 

Body) to define the punch.

3.  Enter the sketcher  select the yz 

plane, and draw the profile of the 

punch.

4.  Return to the 3D space and create the 

punch using the pad icon  and the 

fillet icon .

  

The punch must be oriented as described in Defining the Punch in Relation to the Wall to be Stamped.

●     The punch can be defined in the Sheet Metal part where the stamping is to be created or in another 
part.
In this case, when selecting the punch feature, the system automatically copies it into the .CATPart 
document into which the wall to be stamped is located.
A link is retained between the initial punch feature and its copy.

●     If you define a punch with cutting faces, they should come below the sheet.
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5.  Return to the Sheet Metal application, and if needed, use the Define In Work Object on the 

PartBody containing the wall to be stamped.

6.  Click the User Stamping icon  from the Stamping tool bar and select a wall or a face where 

the stamping is to be created. 

This wall or face is used to define the stamping location and direction, by matching the punch's 

origin to the selected point on the wall.

The User Defined Stamp Definition dialog box is displayed, along with a grid that will help you 

position the punch.

7.  Click the With cut-out and opening  icon.



8.  Select the punch (Body.2).

The punch is previewed on the wall.

9.  Select both top faces of the oblong 

features of the part (Pad.2 and 

Pad.3).  

The Faces for cut-out field is 
updated in the dialog box, and now 
reads: 2 Faces. 

10.  Click the Faces for opening field and 

select the lateral faces of the punch 

(Pad.1).

11.  Click Apply.

The stamp is previewed with the opening 
faces:

12.  Check the No Fillet button is you do not wish the stamp to be filleted, or set the radius value if 

you wish the stamp to be filleted. 



13.  If needed, define the stamp's positioning on the selected wall by choosing:

●     a Reference for rotation: by default, it is the sketch axis, but you can also select any line or edge 

on the wall.

●     a Rotation angle value: you can either enter a value in the dialog box, or use the manipulator in 

the geometry to define this value.

●     a new Origin point on the wall to coincide with the punch's point of origin.

This is especially useful for non-circular stamps, but you can very well create the stamp as is, without 
further positioning.

14.  Click OK to validate and create the stamping. 

The stamp is automatically set in No Show mode. 

 

Stamping with opening faces



 

Stamping with opening and cutting faces

●     Radius is the radius of the bend between the stamping and the wall.

●     Punch is the body you have defined previously. If the punch is in another CATPart document, 
activate this document before clicking the punch.

●     The Faces for cut-out and Faces for opening faces must be picked on the punch, not on the 
wall. 
If the punch is located into another .CATPart document, these faces must be picked on the copy of 
the punch where the wall to be stamped is located.

If you select two reference lines in addition to the plane, this will create two editable constraints to 
position the stamping. These constraints are editable.

 
●     A user-defined stamping can be edited (punch, die, position, constraints)

●     Check the No fillet option to deactivate the Radius R1 value, and to create the stamp without a 
fillet.



Editing User-Defined Stamps

This task explains how to edit a user-defined stamp, that is: 

●     to change its type

●     add or remove cutting and opening faces 

To perform this scenario, you can open any .CATPart document containing a user-defined stamp.

1.  Double-click the existing user-defined stamp from the specification tree.

The User Defined Stamp Definition dialog box is displayed. 



2.  Change stamp type using the icons:

●     If you change from With die to With opening, the Die feature no longer is selected, and you need 

to select Faces for opening.

●     If you change from With opening to With die, the punch faces no longer are selected and you may 

select a die feature if you wish (it is not compulsory).

Basically, only the punch remains selected.
If you are working with a punch with opening faces (With opening option) you may want to add or 
remove some opening faces:

3.  Click in the Faces for opening field then:

●     select a face in the geometry to add it to the already selected opening faces

●     select an already selected face to remove it from the opening faces

●     use the Clear selection contextual menu to remove all opening faces that have been previously 

selected. 

4.  Modify any other parameter as needed.

5.  Click OK in the User Defined Stamp Definition dialog box to take these modifications into 

account.

The stamp is updated accordingly.

 



Patterning
This section explains and illustrates how to create various kinds of patterns on Sheet Metal parts.

Create rectangular patterns: select the element to be duplicated, set the patterning type, and its 
parameters, and the reference direction
Create circular patterns: select the element to be duplicated, set the axial reference  parameters, the 
reference direction, and possibly the crown definition
Create user-defined patterns: select the element to be duplicated, and the positioning sketch and 
anchor point 

To know more about patterns, refer to the Part Design User's Guide.



Creating Rectangular Patterns

In this task, you are going to create rectangular cutouts according to a pattern.
These features make the creation process easier.

 

In the Generative Sheetmetal Design workbench, you can only duplicate flanges, cutouts, holes, 
stamps (except stiffening ribs), stamps without fillet (radius=0) and Generative Sheetmetal Design 
patterns.

 These features must lie on a unique and planar wall.
     

For the SheetMetal Design workbench, open the 
RectangularPattern1.CATPart document.
For the Generative Sheetmetal Design workbench, 
open the NEWRectangularPattern1.CATPart 
document.

The Sheet Metal part looks like this:

1.  Select the rectangular cutout you want to 

duplicate.

2.  Click the Rectangular Pattern icon .

The Rectangular Pattern Definition dialog box is displayed. Each tab is dedicated to a 
direction to define the location of the duplicated feature. 
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3.  Set the specification for the First Direction 

by selecting the first edge (Edge.1) as 

shown, to specify the first direction of 

creation.

An arrow is displayed on the wall. 

The Reverse button enables to modify 

the direction.

You can also click the arrow in the 3D 

geometry.

4.  Keep the Instances & Spacing options to 

define the parameters.

Choosing these parameters types dims the 

Length field because the application no 

longer needs this specification to space the 

instances.

You can set the duplication parameters by choosing the number of instances, the spacing between 
instances, or the total length of the zone filled with instances.
Three options are available: 

●     Instances & Length: the spacing between instances is automatically computed based on 

the number of instances and the specified total length

●     Instances & Spacing: the total length is automatically computed based on the number of 

instances and the specified spacing value

●     Spacing & Length: the number of instances is automatically computed to fit the other 

two parameters.

For each of these cases only two fields are active, allowing you to define the correct value.

If you set Instances & Length or Spacing & Length parameters, note that you cannot 

define the length by using formulas.



Patterns should not go beyond the model.

5.  Enter 2 as the number of instances you wish to obtain in the first direction.

6.  Define the spacing along the grid: enter 30mm.

Defining the spacing along the grid and the length of your choice, would make the application compute 
the number of possible instances and space them at equal distances.

7.  Now, click the Second Direction tab to 

define the other parameters.

Note that defining a second direction is not 
compulsory. Creating a rectangular pattern 
defining only one direction is possible.

8.  Select the second edge (Edge.2), as 

shown, to define the second direction.

9.  Keep the Instances & Spacing option: 

enter 8 and 10 mm in the appropriate 

fields.

Additional cutouts have been aligned along 

this second direction.

10.  Click OK to repeat the cutouts.



After the update, the Sheet Metal part looks like 
this:

11.  Select this icon  to unfold the part:

The pattern is updated on the unfolded view.



 
12.  Click the More>> button to display further options.

 

The Simplified representation option lets you lighten the pattern geometry, when more than 10 
instances are generated in one direction. What you need to do is just check the option, and click Preview. 
The system automatically simplifies the geometry:

You can also specify the instances you do not want 
to see by double-clicking the dots. These instances 
are then represented in dashed lines during the 
pattern definition and then are no longer visible 
after validating the pattern creation. The 
specifications remain unchanged, whatever the 
number of instances you view. This option is 
particularly useful for patterns including a large 
number of instances.

 



Creating Circular Patterns

In this task, you are going to create circular cutouts according to a pattern.
These features make the creation process easier.

 
In the Generative Sheetmetal Design workbench, you can only duplicate flanges, cutouts, holes, stamps (except stiffening ribs), 
stamps without fillet (radius=0) and Generative Sheetmetal Design patterns.

 These features must lie on a unique and planar wall.
     

For the SheetMetal Design workbench, open the 
CircularPattern1.CATPart document.
For the Generative Sheetmetal Design workbench, open the 
NEWCircularPattern1.CATPart document.

The Sheet Metal part looks like this:

1.  Select the circular cutout you want to duplicate.

2.  Click the Circular Pattern icon .

The Circular Pattern Definition dialog box is 

displayed.

3.  Define the Axial Reference by choosing the Parameters 

type, and reference direction.
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●     Instance(s) & total angle: the number of patterns as 

specified in the instances field are created, in the specified 

direction, and evenly spread out over the total angle.

●     Instance(s) & angular spacing: the number of patterns as 

specified in the instances field are created in the specified 

direction, each separated from the previous/next one of the 

angular angle value.



●     Angular spacing & total angle: as many patterns as 

possible are created over the total angle, each separated from 

the previous/next one of the angular angle value.

●     Complete crown: the number of patterns as specified in the 
instances field are created over the complete circle (360deg). 

 

If you set Instance(s) & total angle or Angular spacing & total angle parameters, note that you cannot define the length by 
using formulas.

4.  Click the Reference element and select the element defining the rotation axis.

Here select the face on which lies the circular cutout.



●     To define a direction, you can select an edge or a planar face.
Should you select the face of a wall, the rotation axis would be normal to that face.

●     Click the Reverse button to inverse the rotation direction.

Now you are going to add a crown to this pattern.

5.   Click the Crown Definition tab, and choose which 

parameters you wish to define the crown.

This figure may help you define these parameters:

 
●     Circle(s) and crown thickness: you define the number of circles and they are spaced out evenly over the specified crown 

thickness

●     Circle(s) and circle spacing: you define the number of circles and the distance between each circle, the crown thickness being 
computed automatically

●     Circle(s) spacing and crown thickness: you define the distance between each circle and the crown thickness, and the number of 
circles is automatically computed.

For example, using the values described above for the 
Angular spacing & total angle option, you could 
define the crown as: 



Note that one of the pattern is created beyond the wall.  

You can delete instances of your choice when creating or editing a 
pattern. To do so, just select the points materializing instances in 
the pattern preview.

The instance is deleted, but the point remains, as you may wish 
to click it again to add the instance to the pattern definition again.

6.  Click the More>> button to display further options:

Using these options, you can change the position of the selected 

cutout within the crown. For example, if you set the Row in 

angular direction parameter to 4, this is what you obtain: the 

initially selected cutout is the fourth instance, based on the 

rotation direction, of the pattern.

Typically, in this case, you might want to edit the pattern and 

click again the instance that you removed above, to get a full 

pattern.

●     The Simplified representation option lets you lighten the pattern geometry, when more than 10 instances are generated in 
one direction. What you need to do is just check the option, and click Preview. The system automatically simplifies the 
geometry:
You can also specify the instances you do not want to see by double-clicking them . These instances are then represented in 
dashed lines during the pattern definition and then are no longer visible after validating the pattern creation. The specifications 
remain unchanged, whatever the number of instances you view. This option is particularly useful for patterns including a large 
number of instances.

●     When checking the Radial alignment of instances, all instances have the same orientation as the original feature. When 
unchecked, all instances are normal to the lines tangent to the circle.

In case you use the circular cutout as a reference element, it means the axial reference of the pattern will be the same as the 
rotation axis of the circular cutout. As a result, when the cutout is duplicated, the first crown instances will be superimposed on one 
another. 

To avoid this, uncheck Radial alignment of instances, so that the instances are properly positioned around the cutout.



7.  Click OK to create the pattern.

 



Creating User-Defined Patterns
The User Pattern command lets you duplicate a cutout, a stamp, or any other feature as many times as 
you wish at the locations of your choice.
Locating instances consists in specifying anchor points. These points are sketches.

 

In the Generative Sheetmetal Design workbench, you can only duplicate flanges, cutouts, holes, stamps 
(except stiffening ribs), stamps without fillet (radius=0) and Generative Sheetmetal Design patterns.

 These features must lie on a unique and planar wall.
    

For the SheetMetal Design workbench, open the UserPatterns1.CATPart document.
For the Generative Sheetmetal Design workbench, open the NEWUserPatterns1.CATPart document.

1.  Select the feature to be duplicated.

Here we selected the cutout. 

2.  Click the User Pattern icon 

.

The User Pattern Definition 

dialog box is displayed.

3.  Select 'Sketch 3' in the 

specification tree and click 

Preview.

The sketch contains the points 

you need to locate the 

duplicated cutouts. 

By default, the application positions each instance with respect to the center of gravity of the element to 
be duplicated. To change this position, use the anchor field: click the anchor field and select a vertex or a 
point.
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4.  Click inside the Anchor field 

and select the point (Point.1) 

to indicate a new reference 

location.

5.  You can then click the points 

corresponding to the pattern 

instances to be removed.

6.  Click OK in the User Pattern 

Definition dialog box.

Cutouts are created at the 

points of the sketch.

Would you need to unfold the part using the  icon, you would notice that the pattern is updated.

 



Corner Relief
This section explains and illustrates different methods to create corner relieves on bends.

Redefine an automatic corner relief: double-click an automatic corner relief, edit its parameters in the 
dialog box

Create a local corner relief: select two or more bends, the corner relief type and parameters

See also Bend Corner Relief parameters settings. 
 



Redefining an Automatic Corner Relief

This task explains how to redefine automatic corner relieves on a Sheet metal part.

Open the CornerRelief01.CAPTPart model from the samples directory.

1.  Double-click the bend on which the corner relief 

you want to redefine is located.

It may be easier to double-click it from the 

specification tree. 

The Bend Definition dialog box is displayed. 

2.  Click the More button and select the Bend Corner Relief tab.

This tab is similar to the Corner Relief tab of Sheet Metal Parameters dialog box. 
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3.  Choose a new corner relief type, and click OK 

to validate. 

This definition will apply to the current 

corner relief, and will prevail over any other 

corner relief definition you may enter 

through the Sheet Metal Parameter dialog 

box. 

 



Creating A Local Corner Relief Relief

This task explains how to define a corner relief locally on a set of bends.
Depending on the number of bends involved, not all types of corner relief are available.

Open the CornerRelief02.CATPart document from the samples directory.
The part needs to be unfolded prior to creating the corner relief.

1.  Click the Corner Relief icon .

The Corner Relief Definition dialog box  is 

displayed. 

       

2.  Select the supports on which a corner relief 

should be created.

By default the User Corner Relief  is active in the Corner Relief Definition dialog box.

3.  Select the sketch, directly in the document.

As soon as the sketch has been selected the sketcher 
icon is displayed in the dialog box allowing you to edit 
the selected sketch, if needed.
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4.  Click OK in the Corner Relief Definition dialog 

box.

        

5.  Fold the part to check the corner relief in 3D.

You can use the Catalog icon  to open the Catalog Browser.

For more information on catalogs, please refer to the Component Catalog Editor documentation.

If you choose another corner relief type, the scenario maybe slightly different:

●     circular: by default the corner relief 

center  is located at the 

intersection of the bend axes.

You can select a point as the circle's center.

A radius is proposed by default. It is equal to the bend radius + the thickness. You can change it by: 

●     Selecting Formula -> Deactivate from the contextual menu of the input field and enter a new 
value,

●     or clicking on the  button and entering a new formula.



 

Unfolded circular corner relief Folded circular corner relief

●     square: the square corner relief  is created using the bend limits. Its dimensions are defined by the 

width of the unfolded bends.

Available between two bends only.

 

Unfolded square corner relief Folded square corner relief

●     triangular: the triangular corner relief  is created from the intersection point of the inner bend limits 

towards the intersection points of the outer bend limits with each wall. 

Available between two bends only.



 
 

Unfolded triangular corner relief Folded triangular corner relief

Only the User-defined and Circular corner relief type allow the selection of more than two bends.



Creating Corners

This task shows how to create one or more corner(s)  on a Sheet Metal part, that is to round off sharp 
edges, much like a fillet between two faces of a Part Design Body.
This corner creation operation can be performed indifferently on the folded or unfolded view, and only 
one support (i.e. the corner when previewed should not lie over two supports).

 
Open the Corners1.CATPart document.

1.  Click the Corner icon .

The Corner Definition dialog box is displayed. 

2.  Set the radius value.

3.  Choose the type of edge you wish to round off: 

●     using the Select All button: all convex or concave edges, or 

all edges of both types

●     any edge manually selected

By default both buttons are checked, to allow the selection of 
any edge type whether manually or automatically.

●     Once you have selected an edge, you can no longer modify this option, unless you cancel the 
selection.

●     If you check the Convex Edge(s) button and you select a concave edge, a warning is issued 
indicating that you did not select an edge corresponding to the active type.
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4.  With only the Convex Edge(s) button checked, select a 

sharp edge on a part.

As soon as you selected one edge, the dialog box is 

updated and the Select All button changes to Cancel 

Selection.

The corner is previewed on the edge, with the current 

radius value.

5.  Click Cancel Selection, make sure that both Convex Edge(s) and Concave Edge(s) buttons 

are checked, then click the Select All button.

All sharp edges of the part are selected, the Select All button taking into account the chosen 

type (convex, concave, or both) and the corners previewed.



6.  Click OK in the dialog box.

All sharp edges of the part are rounded off to create smooth corners.



To deselect an edge, simply click it again. For quick selection in a complex part, you can select all edges 
with the Select All check button, then deselect one or two edges.

●     When you select an edge that is not sharp, such as the edge between a wall and a bend for 
example, a warning is issued.

●     As you select more edges, the Edge(s) field of the dialog box is updated.

●     When using the Select All button, you select all edges (whether concave, convex, or both) present 
at the time. If when modifying the Sheet Metal part, new edges are created, these will not be 
automatically rounded off.

 

 



Creating Chamfers

This task shows how to create one or more chamfer(s)  on a Sheet Metal part, that is to cut off, or fill in 
sharp edges of Sheet Metal parts.
This chamfer creation operation can be performed indifferently on the folded or unfolded view, and only 
one support (i.e. the chamfer when previewed should not lie over two supports).

 Open the Corners1.CATPart document.

1.  Click the Chamfer icon .

The Chamfer Definition dialog box is 

displayed. 

2.  Choose the chamfer Type:

●     Thickness chamfer : to be able to 

select edges that represent the thickness 

of the part

●     Welding chamfer : to be able to 

select edges that represent the area of the 
part where it can be welded to another 
part.
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With the Thickness chamfer type only, you can choose the type of edge you wish to chamfer: 
●     using the Select All button: all convex or concave edges, or all edges of both types

●     any edge manually selected

By default both buttons are checked, to allow the selection of any edge type whether manually or 
automatically.

●     Once you have selected an edge, you can no longer modify this option, unless you cancel the 
selection.

●     If you check the Convex Edge(s) button and you select a concave edge, a warning is issued 
indicating that you did not select an edge corresponding to the active type.

3.  Select a sharp edge on a part.

The chamfer is previewed on the edge.

As soon as you selected one edge, the dialog box is updated and the Select All button changes to 

Cancel Selection.

4.  Choose a chamfer Mode. You can either enter:

●     a length value and an angle: the length is 
computed on one side of the edge and the 
angle from the chamfer's limit on the same 
side

●     two lengths: these lengths are computed 
from the selected edge on both sides.

You can use the Reverse button to inverse all edges' side, on which the values are taken into account;
Use the arrow displayed on each edge to locally invert only one edge.



5.  Click Cancel Selection then, make sure that both Convex Edge(s) and Concave Edge(s) 

buttons are checked,  and click the Select All button.

All sharp edges of the part are selected, the Select All button taking into account the chosen 

type (convex, concave, or both) and the chamfers previewed.

6.  Click OK in the dialog box.

All sharp edges of the part are cut off or filled in. 



To deselect an edge, simply click it again. For quick selection in a complex part, you can select all edges 
with the Select All button, then deselect one or two edges.

●     When you select an edge that is not sharp, such as the edge between a wall and a bend for 
example, a warning is issued.

●     As you select more edges, the Edge(s) field of the dialog box is updated.

●     When using the Select All button, you select all edges (whether concave, convex, or both) present 
at the time. If when modifying the Sheet Metal part, new edges are created, these will not be 
automatically chamfered.

 

 



Mapping Elements

 

This task shows how to create curves or points from a sketch (as designed using the Sketcher) or from 
existing curves or points,  onto a Sheet Metal part; and to fold/unfold it, just as other Sheet Metal 
elements. 
This is especially useful when: 

●     you want to generate a logotype

●     you want to define an area for chemical milling

●     you want to create a cutout (pocket) to solve the overlapping of walls for example (the overlapping 
can be checked with the Sheet Metal Production product).

 

If you use SheetMetal Design, open the Mapping1.CATPart document.
If you use Generative Sheetmetal Design, open the NEWMapping1.CATPart document.
If you use Aerospace SheetMetal Design, open the Aero_Mapping.CATPart document.

These samples already contain a pre-defined sketch that will be mapped onto the part. 

Otherwise, you would need to defined a sketch by entering the Sketcher workbench , selecting the 

wall onto which the curve should lie, and drawing the sketch you wish.
 

1.  Make sure the sketch is selected, and click the Point or Curve Mapping icon  .

The Elements To Map definition dialog box is displayed, indicating which elements have been 
selected for mapping.
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 You can manage the list of elements:

●     to remove an element, select it from the list and use the Clear selection contextual menu

●     to add an element,  select it directly in the geometry.
Order in the list does not matter. 

2.  Select the Mapping Context, that is the element of the part on which the curve should be 

generated when folding or unfolding.

The Mapping Context is not necessarily the support element on which the element to be mapped has 
been drawn. Indeed, by default, the Mapping Context is the last Sheet Metal feature that has been 
created or modified, that is the current feature in the specification tree.

3.  Click OK. The curve mapping is created and added in the specification tree.

 
 

Folded view of the curve mapping Unfolded view of the curve mapping



●     You can select several sketches/curves/points to be mapped at a time.

●     Mapped curves can be created across several walls and bends.

 

 



Saving As DXF

 
This task shows how save the generated geometry as a DXF document.

To perform this scenario, you can open any sheet metal sample provided in this user's guide.

 
1.  Click the Save As DXF 

icon .

The Select a DXF file 

dialog box is displayed 

allowing you to 

navigate to the correct 

location. 

2.  Indicate the correct path and file name (we saved it as PartSavedAsDXF.dxf).

3.  Click Save.

The geometry has been saved, and can be imported as a DXF file in any system supporting this type.

4.  Close the CATPart Document.

5.  Click File -> Open.

6.  From the File Selection 

dialog box, choose the 

.dxf file type, then select 

the saved part 

(PartSavedAsDXF.dxf).



7.  Click Open.

     
The unfolded view of the part is opened within the Drafting workbench, because the .dxf type is recognized as 
being a drafting type of document.



Note that the axes of  bends and planar hems, tear drops, or flanges are automatically displayed on the drawing.

 
Refer also to DXF/DWG Settings from the Infrastructure User's Guide.

 

 



Interoperability With Wireframe
Creating Points
Creating Lines
Creating Planes



Creating Points

 

This task shows the various methods for creating points: 
●     by coordinates

●     on a curve

●     on a plane

●     on a surface

●     at a circle/sphere center

●     tangent point on a curve

●     between

 
Open the Points3D1.CATPart document.

 
1.  Click the Point icon  .

The Point Definition dialog box appears.

2.  Use the combo to choose the desired point type.

Coordinates 
●     Enter the X, Y, Z 

coordinates in the current 
axis-system.

●     Optionally, select a 
reference point.

The corresponding 
point is displayed.

 

 

When creating a point within a user-defined axis-system, note that the Coordinates in absolute axis-
system check button is added to the dialog box, allowing you to be define, or simply find out, the point's 
coordinates within the document's default axis-system.
If you create a point using the coordinates method and an axis system is already defined and set as 
current, the point's coordinates are defined according to current the axis system. As a consequence, the 
point's coordinates are not displayed in the specification tree.

The axis system must be 
different from the absolute 
axis.
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On curve 
●     Select a curve

●     Optionally, select a 
reference point.

If this point is not on 
the curve, it is 
projected onto the 
curve.
If no point is 
selected, the curve's 
extremity is used as 
reference.

 

●     Select an option point to 
determine whether the new 
point is to be created: 

❍     at a given distance 
along the curve from 
the reference point

❍     a given ratio between 
the reference point and 
the curve's extremity.

    

●     Enter the distance or ratio 
value.
If a distance is specified, it 
can be: 

❍     a geodesic distance: the 
distance is measured 
along the curve

❍     an Euclidean distance: 
the distance is 
measured in relation to 
the reference point 
(absolute value).

The corresponding point is 
displayed.



If the reference point is located at the curve's extremity, even if a ratio value is defined, the created 
point is always located at the end point of the curve.

You can also: 
●     click the Nearest extremity button to display the point at the nearest extremity of the curve.

●     click the Middle Point button to display the mid-point of the curve.

Be careful that the arrow is orientated towards the inside of the curve (providing the curve is not closed) 
when using the Middle Point option.

●     use the Reverse Direction button to display: 
❍     the point on the other side of the reference point (if a point was selected originally)

❍     the point from the other extremity  (if no point was selected originally).

●     click the Repeat object after OK if you wish to create equidistant points on the curve, using the 
currently created point as the reference, as described in Creating Multiple Points in the Wireframe 
and Surface User's Guide. 

You will also be able 
to create planes 
normal to the curve 
at these points, by 
checking the Create 
normal planes also 
button, and to create 
all instances in a new 
geometrical set  by 
checking the Create 
in a new 
geometrical set 
button.
If the button is not 
checked the 
instances are created 
in the current 
geometrical set .

 

●     If the curve is infinite and no reference point is explicitly given, by default, the reference point is the 
projection of the model's origin

●     If the curve is a closed curve, either the system detects a vertex on the curve that can be used as a 
reference point, or it creates an extremum point, and highlights it (you can then select another one if 
you wish) or the system prompts you to manually select a reference point.

 

Extremum points created on a 
closed curve are now 
aggregated under their parent 
command and put in no show in 
the specification tree.



On plane 
●     Select a plane.

●     Optionally, select a point to 
define a reference for 
computing coordinates in 
the plane.

If no point is 
selected, the 
projection of the 
model's origin on the 
plane is taken as 
reference. 

 

 

 
●     Optionally, select a surface 

on which the point is 
projected normally to the 
plane.

If no surface is 
selected, the 
behavior is the same.

Furthermore, the 
reference direction 
(H and V vectors) is 
computed as 
follows: 
With N the normal to 
the selected plane 
(reference plane), H 
results from the 
vectorial product of Z 
and N (H = Z^N). 
If the norm of H is 
strictly positive then 
V results from the 
vectorial product of N 
and H (V = N^H).
Otherwise, V = N^X 
and H = V^N.

Would the plane 
move, during an 
update for example, 
the reference 
direction would then 
be projected on the 
plane. 



●     Click in the plane to display a point.

On surface 
●     Select the surface where 

the point is to be created.

 

●     Optionally, select a 
reference point. By default, 
the surface's middle point is 
taken as reference. 

●     You can select an element 
to take its orientation as 
reference direction or a 
plane to take its normal as 
reference direction.
You can also use the 
contextual menu to specify 
the X, Y, Z components of 
the reference direction.

●     Enter a distance along the 
reference direction to 
display a point.

 

    

Circle/Sphere center 
●     Select a circle, circular arc, 

or ellipse, or

●     Select a sphere or a portion 
of sphere.



A point is displayed 
at the center of the 
selected element.

    

Tangent on curve 
●     Select a planar curve and a 

direction line.

A point is displayed 
at each tangent. 

    

The Multi-Result 
Management dialog 
box is displayed 
because several 
points are 
generated. 

●     Click YES: you can then 
select a reference element, 
to which only the closest 
point is created.

●     Click NO: all the points are 
created.

For further information, refer to 
the Managing Multi-Result 
Operations chapter.

Between
●     Select any two points.

file:///E|/Www/cnqr14/Doc/online/cfyug_C2/cfyugmultiresult.htm
file:///E|/Www/cnqr14/Doc/online/cfyug_C2/cfyugmultiresult.htm


●     Enter the ratio, that is the 
percentage of the distance 
from the first selected 
point, at which the new 
point is to be.
You can also click Middle 
Point button to create a 
point at the exact midpoint 
(ratio = 0.5).

Be careful that the arrow is orientated towards the inside of the curve (providing the curve is not closed) 
when using the Middle Point option.

●     Use the Reverse direction 
button to measure the ratio 
from the second selected 
point.

 
If the ratio value is greater than 1, the point is located on the virtual line beyond the selected points.

3.  Click OK to create the point.

The point (identified as Point.xxx) is added to the specification tree.

●     Parameters can be edited in the 3D geometry. For more information, refer to the Editing Parameters 
chapter.

●     You can isolate a point in order to cut the links it has with the geometry used to create it. To do so, 
use the Isolate contextual menu. For more information, refer to the Isolating Features chapter.
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Creating Lines

This task shows the various methods for creating lines: 

●     point to point

●     point and direction

●     angle or normal to curve

●     tangent to curve

●     normal to surface

●     bisecting

 
It also shows you how to create a line up to an element, define the length type and automatically 
reselect the second point.

 
Open the Lines1.CATPart document.

1.  Click the Line icon  .

The Line Definition dialog box is displayed. 

2.  Use the drop-down list to choose the desired line type.

 
A line type will be proposed automatically in some cases depending on your first element selection.

 

Defining the line type
 

Point - Point 

 
This command is only available with the 
Generative Shape Design 2 product.

●     Select two points.
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A line is displayed between the two 
points.
Proposed Start and End points of the 
new line are shown.

●     If needed, select a support surface.
In this case a geodesic line is created, i.e. 
going from one point to the other according to 
the shortest distance along the surface 
geometry (blue line in the illustration below).
If no surface is selected, the line is created 
between the two points based on the shortest 
distance.

If you select two points on closed surface (a 
cylinder for example), the result may be unstable. 
Therefore, it is advised to split the surface and only 
keep the part on which the geodesic line will lie. 

 
The geodesic line is not available with the Wireframe and Surface workbench.



 
●     Specify the Start and End points of the new line, that is the line endpoint location in relation to the 

points initially selected. These Start and End points are necessarily beyond the selected points, 
meaning the line cannot be shorter than the distance between the initial points.

●     Check the Mirrored extent option to create a line symmetrically in relation to the selected Start 
and End points.

 
The projections of the 3D point(s) must already exist on the selected support. 

Point - Direction 
 

●     Select a reference Point and a Direction line.
A vector parallel to the direction line is 
displayed at the reference point. 
Proposed Start and End points of the new line 
are shown.



●     Specify the Start and End points of the new 
line.
The corresponding line is displayed.

 
The projections of the 3D point(s) must already exist on the selected support. 

  

Angle or Normal to curve
 

●     Select a reference Curve and a Support 
surface containing that curve.



- If the selected curve is planar, then the 
Support is set to Default (Plane).

- If an explicit Support has been 
defined, a contextual menu is available 
to clear the selection.

 
●     Select a Point on the curve.

●     Enter an Angle value.

A line is displayed at the given angle 
with respect to the tangent to the 
reference curve at the selected point. 
These elements are displayed in the 
plane tangent to the surface at the 
selected point. 
You can click on the Normal to Curve 
button to specify an angle of 90 
degrees. 
Proposed Start and End points of the 
line are shown. 

●     Specify the Start and End points of the new line.
The corresponding line is displayed.



●     Click the Repeat object after OK if you wish 
to create more lines with the same definition as 
the currently created line. 
In this case, the Object Repetition dialog box is 
displayed, and you key in the number of 
instances to be created before pressing OK.

As many lines as indicated in the dialog box are 
created, each separated from the initial line by a 
multiple of the angle value.

 

You can select the Geometry on Support check box if you want to create a geodesic line onto a support 

surface. 

The figure below illustrates this case.

 

Geometry on support option not checked Geometry on support option checked

 
This line type enables to edit the line's parameters. Refer to Editing Parameters to find out how to 
display these parameters in the 3D geometry.
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Tangent to curve
 

●     Select a reference Curve and a point or 
another Curve to define the tangency. 

❍     if a point is selected (mono-tangent mode): 
a vector tangent to the curve is displayed 
at the selected point.

❍     If a second curve is selected (or a point in 
bi-tangent mode), you need to select a 
support plane. The line will be tangent to 
both curves.

 - If the selected curve is a line, then the 
Support is set to Default (Plane).

- If an explicit Support has been 
defined, a contextual menu is available 
to clear the selection.

 When several solutions are possible, you 
can choose one (displayed in red) 
directly in the geometry, or using the 
Next Solution button.

     

 

 

Line tangent to curve at a given point Line tangent to two curves
●     Specify Start and End points to define the new line.

The corresponding line is displayed.



 

Normal to surface 
 

●     Select a reference Surface and a Point.
A vector normal to the surface is displayed at 
the reference point. 
Proposed Start and End points of the new line 
are shown.

 If the point does not lie on the support surface, the minimum distance between the point and the surface 
is computed, and the vector normal to the surface is displayed at the resulted reference point.



●     Specify Start and End points to define the new 
line.
The corresponding line is displayed.



 

●     Select the support surface onto which the 
bisecting line is to be projected, if needed.

●     Specify the line's length in relation to its 
starting point (Start and End values for each 
side of the line in relation to the default end 
points).
The corresponding bisecting line, is displayed.

●     You can choose between two solutions, using 
the Next Solution button, or directly clicking 
the numbered arrows in the geometry.

Bisecting 
 

●     Select two lines. Their bisecting line is the line 
splitting in two equals parts the angle between 
these two lines. 

●     Select a point as the starting point for the line. 
By default it is the intersection of the bisecting 
line and the first selected line.



3.  Click OK to create the line.

The line (identified as Line.xxx) is added to the specification tree.

  ●     Regardless of the line type, Start and End values are specified by entering distance values or by 
using the graphic manipulators.

●     Start and End values should not be the same.

●     Check the Mirrored extent option to create a line symmetrically in relation to the selected Start 
point. 
It is only available with the Length Length type.

●     In most cases, you can select a support on which the line is to be created. In this case, the selected 
point(s) is projected onto this support.

●     You can reverse the direction of the line by either clicking the displayed vector or selecting the 
Reverse Direction button (not available with the point-point line type).

     

Creating a line up to an element
 This capability allows you to create a line up to a point, a curve, or a surface.

●     It is available with all line types, but the Tangent to curve type.

 

Up to a point
●     Select a point in the Up-to 1 and/or Up-to 2 

fields.

Here is an example with the Bisecting line type, 
the Length Length type, and a point as Up-to 
2 element.



 

Up to a curve
●     Select a curve in the Up-to 1 and/or Up-to 2 

fields.

Here is an example with the Point-Point line 
type, the Infinite End Length type, and a 
curve as the Up-to 1 element.

 

Up to a surface
●     Select a surface in the Up-to 1 and/or Up-to 2 

fields.

Here is an example with the Point-Direction line 
type, the Length Length type, and the surface 
as the Up-to 2 element.

  

●     If the selected Up-to element does not intersect with the line being created, then an extrapolation is 
performed. It is only possible if the element is linear and lies on the same plane as the line being 
created.
However, no extrapolation is performed if the Up-to element is a curve or a surface.

●     The Up-to 1 and Up-to 2 fields are grayed out with the Infinite Length type, the Up-to 1 field is 
grayed out with the Infinite Start Length type, the Up-to 2 field is grayed out with the Infinite End 
Length type.

●     The Up-to 1 field is grayed out if the Mirrored extent option is checked.

●     In the case of the Point-Point line type, Start and End values cannot be negative.

  
 

Defining the length type



 ●     Select the Length Type: 
❍     Length: the line will be defined according to the Start and End points values

❍     Infinite: the line will be infinite

❍     Infinite Start Point: the line will be infinite from the Start point

❍     Infinite End Point: the line will be infinite from the End point

By default, the Length type is selected.
The Start and/or the End points values will be greyed out when one of the Infinite options is chosen.

  
 

Reselecting automatically a second point
This capability is only available with the Point-Point line method.

1.  Double-click the Line icon .

The Line dialog box is displayed.

2.  Create the first point.

 

The Reselect Second Point at next start option 
appears in the Line dialog box.

3.  Check it to be able to later reuse the 

second point.

4.  Create the second point.

5.  Click OK to create the first line.

  



 

The Line dialog box opens again with the 
first point initialized with the second 
point of the first line.

6.  Click OK to create the second line.

 To stop the repeat action, simply uncheck the option or click Cancel in the Line dialog box.
  

●     Parameters can be edited in the 3D geometry. For more information, refer to the Editing Parameters 
chapter.

●     You can isolate a line in order to cut the links it has with the geometry used to create it. To do so, 
use the Isolate contextual menu. For more information, refer to the Isolating Features chapter.
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Creating Planes

 
This task shows the various methods for creating planes:

 

●     offset from a plane

●     parallel through point

●     angle/normal to a plane

●     through three points

●     through two lines

●     through a point and a line

●     through a planar 
curve

●     normal to a curve

●     tangent to a surface

●     from its equation

●     mean through points

 

 
Open the Planes1.CATPart document.

 
1.  Click the Plane icon  .

The Plane Definition dialog box appears.

2.  Use the combo to choose the desired Plane type.

 
Once you have defined the plane, it is represented by a red square symbol, which you can move using 
the graphic manipulator.

Offset from plane

●     Select a reference Plane then enter an 
Offset value.

A plane is displayed offset from the reference 
plane.
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Use the Reverse Direction button to  reverse 
the change the offset direction, or simply click 
on the arrow in the geometry.

      
●     Click the Repeat object after OK if you wish to 

create more offset planes . 
In this case, the Object Repetition dialog box is 
displayed, and you key in the number of instances to 
be created before pressing OK.

As many planes as indicated in the dialog box 
are created (including the one you were 
currently creating), each separated from the 
initial plane by a multiple of the Offset value. 

 

Parallel through point 

●     Select a reference Plane and a Point.



A plane is displayed parallel to the reference 
plane and passing through the selected point.

Angle or normal to plane 

●     Select a reference Plane and a Rotation 
axis.
This axis can be any line or an implicit 
element, such as a cylinder axis for 
example. To select the latter press and hold 
the Shift key while moving the pointer over 
the element, then click it.

●     Enter an Angle value.

 



A plane is displayed passing through the 
rotation axis. It is oriented at the specified 
angle to the reference plane. 

●     Click the Repeat object after OK if you wish to create more planes at an angle from the initial 
plane. 
In this case, the Object Repetition dialog box is displayed, and you key in the number of instances 
to be created before pressing OK.

As many planes as indicated in the dialog box 
are created (including the one you were 
currently creating), each separated from the 
initial plane by a multiple of the Angle value.

Here we created five planes at an angle of 20 
degrees.

 This plane type enables to edit the plane's parameters. Refer to Editing Parameters to find out how to 
display these parameters in the 3D geometry.

Through three points 

●     Select three points.
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The plane passing through the three points is 
displayed. You can move it simply by dragging it 
to the desired location.

Through two lines 

●     Select two lines.

The plane passing through the two line 
directions is displayed.
When these two lines are not coplanar, the 
vector of the second line is moved to the first 
line location to define the plane's second 
direction. 



Check the Forbid non coplanar lines button to specify that both lines be in the same plane.

Through point and line 

●     Select a Point and a Line.

The plane passing through the point and the line 
is displayed. 

 



Through planar curve 

●     Select a planar Curve.

The plane containing the curve is displayed.

Tangent to surface 

●     Select a reference Surface and a Point.



A plane is displayed tangent to the surface at 
the specified point.

Normal to curve 

●     Select a reference Curve.

●     You can select a Point. By default, the 
curve's middle point is selecte.



A plane is displayed normal to the curve at the 
specified point. 

Mean through points 

●     Select three or more points to display the 
mean plane through these points.

It is possible to edit the plane by first selecting 
a point in the dialog box list then choosing an 
option to either:

●     Remove the selected point

●     Replace the selected point by another 
point.



Equation 

●     Enter the A, B, C, D components of the Ax 
+ By + Cz = D plane equation.

 

Select a point to position the plane through this 
point, you are able to modify A, B, and C 
components, the D component becomes grayed.

 

Use the Normal to compass button to position 
the plane perpendicular to the compass 
direction.

Use the Parallel to screen button to parallel to 
the screen current view.



3.  Click OK to create the plane.

The plane (identified as Plane.xxx) is added to the specification tree.
  

●     Parameters can be edited in the 3D geometry. For more information, refer to the Editing Parameters 
chapter.

●     You can isolate a plane in order to cut the links it has with the geometry used to create it. To do so, 
use the Isolate contextual menu. For more information, refer to the Isolating Features chapter.
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Advanced Tasks
The Advanced Tasks section explains how to use further functions that may not be as common as the 
ones described in the Basic Tasks section, as well as the integration of the SheetMetal Design 
workbench and elements with other workbenches.

 
Integration With Part Design
Integration With Weld Design

Integration with Generative Drafting
Designing in Context

Managing PowerCopies
Browsing the Sheet Metal Catalog
Looking For Sheet Metal Features 



Integration With Part Design

For the Sheet Metal Design workbench, open the Stiffener1.CATPart document.
For the Generative Sheetmetal Design workbench, open the NEWStiffener1.CATPart document.

  
This scenario, which is valid for both the Sheet Metal Design workbench and the Generative Sheet Metal 
Design workbench, is illustrated using screen captures from the Sheet Metal Design workbench. Results 
will slightly differ in the Generative Sheetmetal Design workbench, for which Automatic bends are not 
available. 

  
In a CATPart document, you may have Part Design features and Sheet Metal features according to the 
following rules:

●     Part Design features can be created before Sheet Metal features.

●     a Part Design feature can also be created after Sheet Metal features as long as the part is 
in folded view.

●     in the unfolded view, the Part Design feature will not be displayed.

●     it is no longer possible to create Sheet Metal features after this last Part Design feature in 
folded view.

1.  Create two walls with an Automatic or Conical Bend for the Sheet Metal Design workbench or two 

walls with a Cylindrical or Conical Bend for the Generative Sheetmetal Design workbench.

2.  Switch to the Part Design workbench.

3.  Launch the Sketcher and draw an oblique line in the yz plane.

4.  Click the icon  to create a Stiffener.
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5.  Switch to the Sheet Metal Design workbench or to the Generative Sheet Metal Design workbench.

6.  Click the Unfold icon .

The stiffener is not displayed on the unfolded view.
 

To add a Generative Sheetmetal Design feature and switch to the Sheet Metal Design workbench or to 
the Generative Sheetmetal Design Design workbench, select the Bend for example and right-click the 
Define In Work Object item. The Generative Sheetmetal Design feature will be added after the Bend 
but before the Stiffener.



Integration With Weld Design
You can open the Integration.CATProduct document from the samples directory to replay the scenario.
If you use the Generative Sheetmetal Design workbench, open the NEWIntegration.CATProduct document.

In a CATProduct document, you may have Weld Design features and Sheet Metal features according to the following rules:

●     Weld Design features are created after Sheet Metal features.

●     in the unfolded view, the Weld Design feature will not be displayed.

●     it is no longer possible to create Sheet Metal features after this last Weld Design feature.

1.  Create two walls.

2.  Switch to Weld Design workbench.

 
3.  Create a weld (in our scenario, we create a Single-V Butt weld)

To add a Generative Sheetmetal Design feature and switch to the Sheet Metal Design workbench, select any of the two walls and 
make it current.

 
The Generative Sheetmetal Design feature will be added after the Bend but before the Stiffener.
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Integration with Generative Drafting
This task explains how to generate an unfolded view of a part with swept wall in a drawing sheet. The 
axes of planar hems, tear drops, and flanges are displayed within the drawing.

 
For the SheetMetal Design workbench, open the SweptWall01.CATPart document.
For the Generative Sheetmetal Design workbench, open the NEWSweptWall1.CATPart document.

Make sure you have an appropriate Generative Drafting license.

Make sure that the Generate axis option is checked in the Tools -> Options -> Mechanical Design -
> Drafting -> View tab, prior to generating a view in a .CATDrawing document.

  

1.  Click  or select File -> New...

2.  Select the Drawing type and click OK.

3.  Click OK.

For more information about this workbench, refer to Generative Drafting User's Guide.
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4.  The drawing sheet appears.

5.  Tile the windows horizontally using the Window -> Tile Horizontally menu item.

6.  Select the Unfolded View icon  in the Projections toolbar from the Generative Drafting 

workbench.

This icon is active in the Projections toolbar provided the Generative Sheetmetal Design workbench is 

present.

7.  Choose the xy plane in the Sheet Metal specification tree. A preview of the view is displayed in 

the drawing.

8.  Click in the drawing to validate the view creation. The unfolded view is displayed with the planar 

swept wall axes.



Designing in Context
This section explains and illustrates how to create and use various kinds of features.
The table below lists the information you will find.

Design in context: from a CATProduct document, create a new CATPart document, and create a complete 
SheetMetal Part.
Modify the design: modify another part from another document and update the SheetMetal Part.



Designing in Context

This task explains how to create a Sheet Metal part in an Assembly context.

For the Sheet Metal Design workbench, open the Scenario2.CATProduct document.
For the Generative Sheetmetal Design workbench, open the NEWScenario2.CATProduct document.

  
This scenario, which is valid for both the Sheet Metal Design workbench and the Generative Sheet Metal Design 
workbench, is illustrated using screen captures from the Sheet Metal Design workbench. Results will slightly differ in 
the Generative Sheetmetal Design workbench, for which Automatic bends are not available. 

  

You are in Assembly Design workbench.

The document contains two parts.

1.  Right-click Product1 in the 

specification tree and select 

Components -> New Part...

Provided the Manual Input 
option is checked in Tools -> 
Options -> Infrastructure -
> Product Structure, 
Product Structure tab, the 
Part Number dialog box is 
displayed:
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2.  Enter Part3 in the New part 

Number field and click OK.

A New Part dialog box proposes 

two locations to define the origin 

point.

For more information, refer to 

Inserting a New Part, in the 

Product Structure User's Guide.

 

3.  Click No to locate the part origin according to the Product1 origin point.

Make sure you are in Design Mode:

●     Select Product1

●     Choose Edit -> Representations ->Design Mode

4.  Expand the tree and activate the Part3 Part body by double-clicking. 

5.  Switch to the Sheet Metal Design workbench or to the Generative Sheetmetal Design workbench.



6.  Select the Sheet Metal parameters icon  to create the Sheet Metal characteristics for the part: 

●     1mm for the Thickness

●     3mm for the Bend radius

●     Linear for the Bend extremities

and click OK.

7.  Choose the Tools -> Options -> Infrastructure -> Part Infrastructure, General tab and check the 

Keep link with selected object option, then click OK.

8.  Click the Sketcher icon  and select the zx plane.

9.  Select the Profile icon .

 
10.  Sketch the profile and set the constraints as shown below:

 

●     5mm between the Sheet Metal 
vertical walls and each pad

●     0mm between the Sheet Metal 
horizontal walls and each pad top

●     0mm between the last point of the 
Sheet Metal sketch and the right pad 
side.

11.  Click the Exit icon  to return to the 3D world.

12.  Select the Extrusion icon 

.



13.  Select the Sheet Metal profile.

The Extrusion Definition dialog 

box appears.

14.  Enter 70mm for Length1 then 

click OK.

The Material Side should be set to the 
outside.

15.  Perform this step only if you are using the Sheet Metal Design workbench: select the Automatic Bends icon 

.

The bends are created.

The new features are shown in 
the specification tree: 

●     Extrusion.1 with five 
walls

●     Automatic Bends.1 with 
four bends (for the Sheet 
Metal Design workbench 
only).

The Sheet Metal part looks like this:

 



Modifying the Design

In this task, you are going to modify the height and the sketch of Pad.1.

For the Sheet Metal Design workbench, the Scenario2.CATProduct document is open from the previous 
task. If not, open the Scenario2_2.CATProduct document from the samples directory.

For the Generative Sheetmetal Design workbench, open the NEWScenario2.CATProduct document.
  

This scenario, which is valid for both the Sheet Metal Design workbench and the Generative Sheet Metal 
Design workbench, is illustrated using screen captures from the Sheet Metal Design workbench. Results 
will slightly differ in the Generative Sheetmetal Design workbench, for which Automatic bends are not 
available. 

   

1.  Double-click Part1\PartBody\Pad.1 in the 

specification tree.

The dialog box is displayed. 

2.  Enter 40mm for the Length and click OK.

The pad is updated.

3.  Double-click Part3 and Update the Sheet Metal part using the Update   icon.

4.  Double-click Part1\Pad.1\Sketch.1.
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5.  Modify the sketch:

6.  Click the Exit icon  to return to the 3D world.

The constraints are respected. 

After the Part3 update, the document looks like this:

 



Managing PowerCopies

 
Create PowerCopies: Select the Insert ->Advanced Replication Tools -> PowerCopy Creation 
command, select the elements making up the PowerCopy from the specification tree, define a name for 
the PowerCopy and its reference elements then choose an icon for identifying it.

 
Instantiate PowerCopies: Select the Insert -> Instantiate From Document command, select the 
document or catalog containing the  powercopy, complete the Inputs within the dialog box selecting 
adequate elements in the geometric area.

 
Save PowerCopies into a Catalog: Select the PowerCopy from the specification tree, select the Insert -> 
Advanced Replication Tools -> PowerCopy Save In Catalog... command, enter the catalog name 
and click Open.

 



Creating PowerCopy Features
This task shows how to use create PowerCopy elements, to be reused later.
A PowerCopy is a set of features (geometric elements, formulas, constraints and so forth) that are 
grouped in order to be used in a different context, and presenting the ability to be re-specified according 
to the context when pasted.
This PowerCopy captures the design intent and know-how of the designer thus enabling greater reusability 
and efficiency.

Open the PowerCopyStart.CATPart document.

1.  Select the Insert ->Advanced Replication Tools -> PowerCopy Creation menu item.

The PowerCopy Definition dialog box is displayed. 

2.  Select, from the specification tree, the elements to be included in the PowerCopy. 

The 
PowerCopy 
Definition 
dialog box is 
automatically 
filled with 
information 
about the 
selected 
elements. 

3.  Define the PowerCopy as you wish to create it:

The Definition tab lets you assign a name to the PowerCopy and presents its components in 
the 3D viewer.
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The Inputs tab lets 
you rename the 
reference elements 
making up the 
PowerCopy.

You can do that for clarification purposes as to their roles,  by selecting the elements in the viewer and 

entering a new name in the Name field.

In this example, we renamed all three elements and in brackets you still can read the elements' default 

name based on their type.

The Parameters tab 
lets you define which of 
the parameter values 
used in the PowerCopy 
you will be able to 
modify at instantiation 
time.

Simply check the Published button.

Use the Name field to give a more explicit name to the element.

The 
Documents 
tab shows 
the complete 
path and role 
of Design 
tables that 
are 
referenced 
by an 
element 
included in 
the Power 
Copy.



The Icon tab lets you 
modify the icon 
identifying the 
PowerCopy in the 
specifications tree. 

A subset of icons is available from the Icon choice button.
If you click ... the Icon Browser opens, giving you access to all the graphic icons installed with the CATIA 
software.

Use the Grab screen 
button to  capture an 
image of the 
PowerCopy to be 
stored with its 
definition in the catalog 
(see Saving PowerCopy 
Features).

Use the Remove preview button to delete the image captured with the Grab screen button.

4.  Click OK to create the PowerCopy.

The PowerCopy is displayed close to the top of the specification tree.
●     Double-click the PowerCopy in the specification tree to display the PowerCopy Definition dialog box 

and edit its contents.

●     A formula is automatically included in a Power Copy definition when all its parameters are included.
Otherwise, i.e. if at least one parameter is not selected as part of the Power Copy, you have to 
manually select the formula to make it part of the definition. If you do so, all the formula's parameters 
that have not been explicitly selected, are considered as inputs of the Power Copy.

●     Once your PowerCopy is created, do not delete the referenced elements used to make up the 
PowerCopy.

 



Instantiating PowerCopy Features

This task shows how to instantiate PowerCopies once they have been created as described in Creating PowerCopy Features.
There are three ways to do this: 

1.  using the contextual menu
2.  using the Insert -> Instantiate From Document menu item
3.  using a catalog

The PowerCopyStart.CATPart document is still open from the previous task, otherwise, 0pen the 
PowerCopyStartResults1.CATPart document.

Using the Contextual Menu Item: 

1.  Select the PowerCopy feature from the specification tree.

2.  Right-click to display the contextual menu, and choose the PowerCopy.1 object -> instantiate menu item. 

The Insert Object dialog box is displayed. 

3.  Complete the Inputs within the dialog box by selecting 

the adequate element in the geometric area.

You need to click the arrow to invert the First Edge 
orientation.

 

Check the Repeat option to be able to repeat the instantiation.
In this case, once you have clicked OK in  the Insert Object dialog box, the latter remains open, the PowerCopy's Inputs are 
listed and ready to be replaced by new inputs, as described above.
Modified parameters using Parameters button are retained as well for the next instantiation.
To exit the command, you then need to uncheck the Repeat button or click Cancel.
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5.  You can also click on the Parameters button to display 

the Parameters dialog box and modify values, if 

needed.

6.  Use the Create formulas button to automatically create 

a formula on every parameters with the same name 

provided there are any.

7.  Click OK in the Parameters dialog box.

 

The Documents button lets you access the list of documents (such as design tables) pointed by one of the elements making 
up the Power copy. 
If there are documents, the Documents dialog box opens and you can click the Replace button to display the File Selection 
dialog box and navigate to a new design table to replace the initial one.
When no document is referenced, the Documents button is grayed within the Insert Object dialog box.

8.  Click OK to create the PowerCopy instance.

The PowerCopy is instantiated in context, meaning 
its limits are automatically re-defined taking into 
account the elements on which it is instantiated.

Using the Insert Menu: 

1.  Select the Insert -> Instantiate From Document menu item.

The Select PowerCopy dialog box is displayed allowing you to navigate to the document or catalog where the  power 

copy is stored.



 

2.  Select the document containing the Powercopy.

The Insert Object dialog box is displayed.

Use the Reference list to choose the correct PowerCopy when several have been defined in the document.

3.  Continue the instantiation as described in Using the Contextual Menu item, step 3.

Using the catalog: 

You need to have a catalog available, created either:
●     using the Catalog capability, see the Infrastructure User's Guide.

●     using the Insert -> Advanced Replication Tools -> PowerCopy Save In Catalog... menu item.

1.  Click the  icon.

If accessing a catalog for the first time, you need to navigate to the catalog location. This location is stored in the 

settings for faster access later on.

2.  Select the catalog containing the PowerCopy you wish to instantiate.



3.  Select the PowerCopy to be instantiated, then you can:

●     drag and drop it onto the reference element

●     double-click the PowerCopy 

●     or right-click on the PowerCopy in the dialog box and use the Instantiate contextual menu.

From then on, you instantiate the PowerCopy as described Using the Contextual Menu item, step 3.

●     You can only instantiate a PowerCopy if the PowerCopy itself and the features making it up have been created in the 
current view mode: i.e. you will be able to instantiate a PowerCopy created in 3D mode, only on a feature in 3D mode, not 
on an unfolded feature.

●     The  icon is always grayed when instantiating Power Copies. It is available with User Features and allows you to 

create and modify URLs.

 



Saving PowerCopy Features

This task shows how to use store Power Copy elements into a catalog, for later use as described in 
Instantiating PowerCopy Features.

Open the PowerCopyStartResults1.CATPart document.

1.  Select the PowerCopy from the specification tree for example.

2.  Choose the 

Insert -> 

Advanced 

Replication 

Tools -> 

(PowerCopy) 

Save In 

Catalog... menu 

item.

The Catalog 

Save dialog box 

is displayed: 

●     When creating a 
catalog for the first 
time, click the ... 
button to display the 
Open dialog box, and 
navigate to the 
location where you 
wish to create a 
catalog.
Then simply key in 
the catalog name and 
click Open.
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●     If you wish to add a PowerCopy to an existing catalog, simply activate the Update an existing 
catalog option in the Catalog Save dialog box

By default, the Catalog Save dialog box recalls the catalog accessed last.

3.  Click OK.

The PowerCopy has been stored in the catalog.

 



Browsing the Sheet Metal Catalog

Open the CornerRelief03.CATPart document from the samples directory.

In this case, the Catalog Browser opens, and lets you choose from a number of sketches.

 

1.  Select a sketch and click OK in the Catalog Browser.

You return to the Corner Relief Definition dialog box, 
that has been updated with the Sketcher icon.

file:///E|/Www/cnqr14/Doc/online/cfysm_C2/samples/SheetMetal/CornerRelief03.CATPart


2.  Click the sketcher icon, and move the sketch to 

position it properly in relation to the part. 

 

 

3.  Click OK, and check the part in a folded view.



Looking For Sheet Metal Features

This task shows how to use the Search capabilities on Sheet Metal Features, in order to detect any 
specific kind of feature.

Open the PowerCopyStart.CATPart document.

1.  Select the Edit ->  Search menu item.

The Search dialog box is displayed. 

2.  From the Type Workbench list choose Sheet Metal.

You can then display the list of Sheet Metal features from the Type list: 

3.  Select the type of feature you wish to find within the open .CATPart document, and click Search.

The list of all elements of the selected type is displayed in the Objects found field:

file:///E|/Www/cnqr14/Doc/online/cfysm_C2/samples/SheetMetal/PowerCopyStart.CATPart


You can select an element from the list, it will be highlighted in the geometry area.

To find out more on the search capabilities, refer to Selecting Using the Search... Command (General 
Mode) and Selecting Using the Search... Command (Favorites and Advanced Modes) from the 
Infrastructure User's Guide.

 



Workbench Description
The SheetMetal Design application window looks like this:
Click the hotspots to display the related documentation. 

 

Menu Bar
Sheet Metal Toolbar
Constraints Toolbar

Reference Elements Toolbar
Specification Tree 



Menu Bar

The various menus and menu commands that are specific to Sheet Metal Design are described below.

 

Start File Edit View Insert Tools Windows Help

Tasks corresponding to general menu commands are described in the Infrastructure User's Guide. Refer to the 
Menu Bar section. 

Insert 

For... See...

 

Sketcher... Refer to Sketching in the Sketcher User's 
Guide.

Sheet Metal 
Parameters...

Managing the Default Parameters

Walls Recognition... Creating Walls from an Existing Part

Wall... Creating Walls from a Sketch

Wall on Edge... Creating Walls from an Edge

Extrusion... Extruding

Bends Insert -> Bends

Swept Walls Insert -> Swept Walls

Unfold Insert -> Unfold

ShePocket Insert -> ShePocket

Stampings Insert -> Stampings

Patterns Insert -> Patterns

CornerRelief... Creating a Local Corner Relief

Corners Insert -> Corners

Mapping... Mapping Curves
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Save As DXF... Saving As DXF

Constraints
Setting Constraints in the Part Design User's 
Guide

Advanced Replication 
Tools

Insert -> Replication Tools

Instantiate From 
Document...

Instantiating PowerCopies

Insert -> Bends
 For... See... 

Automatic Bends Generating Bends Automatically

Bend Creating Bends From Walls

Conic Bend Creating Conical Bends

Bend Generating a Bend from a Line 

Insert -> Swept Walls
For... See... 
Flange Creating a Flange

Hem Creating a Hem

Tear Drop Creating a Tear Drop

Swept Flange Creating a Swept Flange

Insert -> Unfold
For... See... 
Unfold 3D View

MultiView Concurrent Access

Insert -> ShePocket
For... See... 

Cutout... Creating a Cutout

Split... Splitting Geometry

Insert -> Stampings
For... See... 
Point Stamp Creating a Point Stamp
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Extruded Hole Creating an Extruded Hole

Curve Stamp Creating a Curve Stamp

Surface Stamp Creating a Surface Stamp

Bridge Creating a Bridge

Louver Creating a Louver

Stiffening Rib Creating a Stiffening Rib

User Stamping Creating User-Defined Stamping Features

Insert -> Patterns
For... See... 
Rectangular Pattern Creating Rectangular Patterns

Circular Pattern Creating Circular Patterns

User-Defined Pattern Creating User-Defined Patterns

Insert -> Corners
For... See... 
Corner Creating Corners

Chamfer Creating Chamfers

 

Insert -> Replication Tools
For... See... 
PowerCopy Creation Creating PowerCopies

PowerCopy Save in 
Catalog

Saving PowerCopies

 



Sheet Metal Toolbar

  

See Managing the Default Parameters

     

See Creating Walls from an Existing Part

See Creating Walls from a Sketch

See Creating Walls from an Edge

See Extruding

See Creating Bends

See Creating Swept Walls

     

See Unfolding the Part

     

See Pockets

See Stamping

See Patterning

See Creating a Local Corner Relief



See Creating Corners

See Creating Chamfers

See Mapping Elements

       

See Saving As DXF



Constraints Toolbar

  

See Setting Constraints from the Part Design User's Guide
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Reference Elements Toolbar

   

See Creating Points

See Creating Lines

See Creating Planes

 



Specification Tree
Within the SheetMetal Design workbench, you can generate a number of features that are identified in the 
specification tree by the following icons.

Further information on general symbols in the specification tree are available in Symbols Used in the 
Specification Tree.

 

Sheet Metal Parameters  Rectangular Pattern

Wall Circular Pattern

Wall On Edge User-Defined Pattern

Extrude Corner Relief

Automatic Bends Corner

Bend Chamfer

Conical Bend Mapping

Flat Bend Point

Flange Line

Hem Plane

Tear Drop   

User-defined Flange   

Cutout   

Split   

Point Stamp   

Extruded Hole   

Curve Stamp    

Surface Stamp    

Bridge    

file:///E|/Www/cnqr14/Doc/online/cfyugprt_C2/cfyugsymbol1.htm
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Louver    

Stiffening Rib    

User-Defined Stamp    



Glossary 

       

B

bend A feature joining two walls

bend extremity Axial relimitation for a straight bend

C

corner relief A feature created at the intersection of several bends or of a bend and a wall allowing to 
remove matter so that the part can fold/unfold without overlapping.

cutout A feature corresponding to an opening through a feature.
The shape of the opening corresponds to the extrusion of a profile.

E

extrusion A feature created by extruding a profile and adding thickness

F

flange A feature created by sweeping a profile along a spine.
The different flanges or swept walls available are: simple and swept flange, hem and tear 
drop.

P

pattern A set of similar features repeated in the same feature or part

profile An open or closed profile including arcs and lines created by the Profile command in the 
Sketcher workbench

R



reference wall The first created wall; when unfolding the part, it is the fixed wall.

S

stamping A feature created by embossing sheet metal.
The different stampings available are:
point/circular, extruded/flanged hole, flanged cutout, curve, surface, bridge, louver and 
stiffening rib.

W

wall A feature created by adding thickness to a profile

 



Index 

                  

A
Assembly Design workbench 

interoperability  
Automatic Bends 

command   

automatic bends   

B
Bend 

command  
bend allowance 

defining  
bend corner relief 

defining  

bend extremities  

defining  
Bend From Flat 

command  
bend radius 

defining   
bends 

creating     
bisecting 

lines  

Bridge  

command  
browsing 

Sheet Metal catalog  



C
catalog  
Chamfer 

command  
chamfers 

creating  
Circular Pattern 

command  

circular stamp  

clearance  
command 

Automatic Bends   

Bend  

Bend From Flat  

Bridge  

Chamfer  

Circular Pattern  

Circular Stamp  

Conical Bend  

Corner  

Corner Relief  

Curve Stamp  

Cutout   

Extrusion    

Flange  

Flanged Hole  

Fold/Unfold Curves  

Hem  

Isolate  

Line  

Louver   

Multi Viewer  



Plane  

Point  

PowerCopy Creation  

PowerCopy Instantiation  

PowerCopy Save In Catalog  

Rectangular Pattern  

Save As DXF  

Sheet Metal Parameters     

Split  

Stiffening Rib  

Surface Stamp  

Swept Flange  

Tear Drop  

Unfold  

Unfolded View  

User Pattern  

User Stamping   

Wall   

Wall on Edge  

Walls Recognition  
Commands 

Search  
Conical Bend 

command  

conical bends  
Corner 

command  
Corner Relief 

command  

corner relief  

defining  

editing  

local  



corners 

creating  

creating  

bends     

bridges  

chamfers  

circles  

circular stamp  

conical bends  

corners  

curve stamp  

curves  

cutouts  

extruded hole  

flanges  

hems  

lines  

louver  

louvers  

patterns    

planes  

points  

Power Copy  

stamps          

stiffnening rib  

surface stamp  

swept flange  

swept walls  

tear drops  

user-defined stamps  

walls       

creating bends  



creating line  

creating plane  

creating point  

creating walls  
crown 

defining  

Curve Stamp  
curves 

creating  
Cutout 

command   

cutout  
cutouts 

creating  

cutting faces  

D
defining 

bend allowance  

bend corner relief  

bend extremities  

bend radius   

corner relief  

crown  

thickness   

die stamps  

drawing  
drawings 

producing  

DXF format  



E
editing 

corner relief  

user-defined stamps  
elements 

Sheet Metal Design  

extruded hole  
extruded walls 

isolating  
Extrusion 

command    

F
Flange 

command  
Flanged Hole 

command  
flanges 

creating  

flat bends  
Fold/Unfold Curves 

command  

Folding  

folding   

G
Generative Drafting 

workbench   

H



Hem 

command  
hems 

creating  

I
instantiating 

Power Copy  
interoperability 

Assembly Design workbench  

Part Design workbench   

Weld Design workbench  

Wireframe  
Isolate 

command  
isolating 

extruded walls  

walls  

walls on edge  

L
line 

creating  
lines 

bisecting  
local 

corner relief  

Louver  

command  
louvers 

creating  



M
managing 

Power Copy  

Sheet Metal parameters  

manual bends  

material side     
Multi Viewer 

command  

multi-viewing  

O
open faces  

P
parameters  
Part Design workbench 

interoperability   

patterns  

creating    

user-defined  
plane 

creating  
point 

creating  
Power Copy 

creating  

instantiating  

managing  

saving  



PowerCopy Creation 

command  
PowerCopy Instantiation 

command  
PowerCopy Save In Catalog 

command  

punch   

R
Rectangular Pattern 

command  

reference wall      

relief  
rolled walls 

walls  

S
Save As DXF 

command  
saving 

Power Copy  

saving data  
Search 

Commands  
searching 

sheet metal features  

Sheet Metal catalog  
Sheet Metal Design 

elements  

workbench  
sheet metal features 

searching  
Sheet Metal Parameters 



command     
Sheet Metal parameters 

managing  
Split 

command  
splitting 

elements  
stamps 

creating   

user-defined   

Stiffening Rib  

command  

Surface Stamp  
Swept Flange 

command  
swept flange 

creating  
swept walls 

creating  

T
tangent walls  
Tear Drop 

command  
tear drops 

creating  
thickness 

defining   

U
Unfolded View 

command  



unfolded view   

Unfolding  

unfolding   
User Pattern 

command  
User Stamping 

command   
user-defined 

patterns  

stamps   
user-defined stamps 

creating  

editing  

W
Wall 

command   

wall clearance  
Wall on Edge 

command  

wall on edge  
walls 

creating       

isolating  

rolled walls  

walls by extrusion  

walls from sketch  

walls on edge  

isolating  
Walls Recognition 

command  
Weld Design workbench 

interoperability  



Wireframe 

interoperability  
workbench 

Generative Drafting   

Sheet Metal Design  
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