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Overview 
Welcome to the Photo Studio User's Guide. This guide is intended for users who need to become quickly familiar 
with the Photo Studio product.

This overview provides the following information:

●     Photo Studio in a Nutshell 

●     Before Reading this Guide

●     Getting the Most Out of this Guide 

●     Accessing Sample Documents 

●     Conventions Used in this Guide 

Photo Studio in a Nutshell

Photo Studio  enables you to easily and interactively create photorealistic images and simple animations of a 
product.

Thanks to its ease of use and to the interactive preview of rendering specifications as they are applied, Photo 
Studio is the perfect tool for any "non specialist" user who wishes to deliver a high quality photorealistic image at 
any time and without the help of rendering specialists.

Photo Studio contributes to enhance project collaboration by enabling users to produce and share quality 
representations of their ideas. By giving a realistic simulation of the model appearance, it can also be used to 
validate the quality of the design at any time during the product development process.

Before Reading this Guide
All users should be familiar with basic Infrastructure concepts such as document windows, standard and view 
toolbars as well as the 3D compass.
Prior to reading this book, we therefore recommend that you read the Infrastructure User's Guide.

You may also find useful to read the Real Time Rendering User`s Guide that allows you to define material 
specifications that will be shared across your entire product development process as well as map materials onto 
products to produce photorealistic images.

Getting the Most Out of this Guide



If you are a first time user, we suggest that you start with the Getting Started tutorial providing information for 
starting a Photo Studio session. 

Once you have finished, you should move on to the User Tasks section of this guide. This steps you through 
procedures such as managing cameras, light sources, pictures, scenes and so on.

The Workbench Description section, which describes the Photo Studio workbench, and the Customizing section, 
which explains how to set up the options, will also certainly prove useful.

Navigating in the Split View mode is recommended. This mode offers a framed layout allowing direct access from 
the table of contents to the information.

Accessing Sample Documents
To perform the scenarios, you will be using sample documents contained in the online/phsug/samples folder. 

For more information about this, refer to Accessing Sample Documents in the Infrastructure User's Guide.

Conventions Used in this Guide
To learn more about the conventions used in this guide, refer to the Conventions section.
 

http://canly1dsy/ajtCXR14/Doc/online/bascuphs_C2/bascuphs0000.htm
http://canly1dsy/ajtCXR14/Doc/online/basug_C2/basugbt0208.htm


Conventions
Certain conventions are used in CATIA, ENOVIA & DELMIA documentation to help you recognize and understand 
important concepts and specifications. 

Graphic Conventions

The three categories of graphic conventions used are as follows:

●     Graphic conventions structuring the tasks

●     Graphic conventions indicating the configuration required

●     Graphic conventions used in the table of contents

Graphic Conventions Structuring the Tasks

Graphic conventions structuring the tasks are denoted as follows:

This icon... Identifies...

estimated time to accomplish a task

a target of a task

the prerequisites

the start of the scenario

a tip

a warning

information

basic concepts

methodology

reference information

information regarding settings, customization, etc.

the end of a task



functionalities that are new or enhanced with this release

allows you to switch back to the full-window viewing mode

Graphic Conventions Indicating the Configuration Required 

Graphic conventions indicating the configuration required are denoted as follows:

This icon... Indicates functions that are... 

specific to the P1 configuration

specific to the P2 configuration

specific to the P3 configuration

Graphic Conventions Used in the Table of Contents

Graphic conventions used in the table of contents are denoted as follows:

This icon... Gives access to...

Site Map

Split View mode

What's New?

Overview

Getting Started

Basic Tasks

User Tasks or the Advanced Tasks

Workbench Description

Customizing

Reference

Methodology

Glossary



Index

Text Conventions

The following text conventions are used:

●     The titles of CATIA, ENOVIA and DELMIA documents appear in this manner throughout the text.

●     File -> New identifies the commands to be used.

●     Enhancements are identified by a blue-colored background on the text.

How to Use the Mouse

The use of the mouse differs according to the type of action you need to perform.

Use this
mouse button... Whenever you read...

 
●     Select (menus, commands, geometry in graphics area, ...)

●     Click (icons, dialog box buttons, tabs, selection of a location in the document window, 
...)

●     Double-click

●     Shift-click

●     Ctrl-click

●     Check (check boxes)

●     Drag

●     Drag and drop (icons onto objects, objects onto objects)

●     Drag

●     Move

●     Right-click (to select contextual menu)



What's New?

New Functionalities

Camera Commands Toolbar
This new toolbar lets you manage the camera position as well as the focal length when working in 
perspective view.

Multi-View Configuration
The Multi-View capability lets you define a multi-view configuration within your 3D viewer: you can 
define either a manual or automatic configuration, or customize standard views.

Enhanced Functionalities

Environment Wallpaper
When working with environments, you sometimes need to use the File Selection dialog box to select an 
image for an environment wall. The File Selection dialog box now lets you access documents stored in 
the document environments you defined in the Tools->Options->General->Document tab.

Light Sources
A spherical manipulator lets you position the light direction.
Standard and surfacic light sources are now supported in presentations created using the DMU Navigator 
product.

Materials
When working with materials, you sometimes need to use the File Selection dialog box to select a 
material texture, for instance. The File Selection dialog box now lets you access documents stored in the 
document environments you defined in the Tools->Options->General->Document tab.

Shooting
A new button in the Shooting Definition dialog box lets you update the camera preview when needed.

Stickers
Ability to zoom the sticker image using the transparency viewer.
A new symbol in the specification tree identifies stickers with no texture image.

Working with ENOVIA LCA: Optimal CATIA PLM Usability
The Sticker command is not grayed out anymore when working in Explode mode. In addition to that, 
you can now save cameras, environments, shootings and light sources provided that a DMU Review has 
been created and activated.

Customizing Settings

General
Ability to select the view mode to be used by default when entering the Photo Studio workbench.
You can also activate or deactivate automatically the material display when entering the Photo Studio 
workbench.

Display
You can now use the Show normal option to display the normal when using the Position along Normal 
and Position Specular commands. 

Sticker
A new option lets you activate or deactivate the real time representation of stickers.

 



Getting Started
The following tutorial aims at guiding you when you open the Photo Studio workbench for the first time.  

It provides 3 step-by-step tasks for: 

  

Entering the Photo Studio Workbench
Loading Products

Creating a Quick Render

 

 All together, these tasks should take 10 minutes to complete.

 

         The result will look like this:



Entering the Photo Studio Workbench

 
This first task will show you how to open the Photo Studio workbench.

 
The only pre-requisite for this task is to have a current Version 5 session running.

 
1.  From the Start menu, select Infrastructure->Photo Studio.

The Photo Studio workbench opens: 

 

 

Now, let's perform the next task to learn how to load documents in your Photo Studio 
workbench. 

 

 

http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/images/workbenchNLS.gif


Loading Products
 

 
This task will show you how to load products in your Rendering workbench.

 
Make sure that the Shading with Material icon is selected from the View toolbar.

1.  From the Insert menu, select the Existing Component... command. The following dialog box is displayed.

 

You can also right-click the product in the specification tree then select the Components -> Existing 
Component... contextual menu.



2.  Select "Products" in the "Files of type" field.

3.  Select the Lamp.CATProduct document, for instance. Note that you can select any other document from the 

"samples" folder.

The sample documents are installed in user guide-specific sample folders. In the online documentation 

filetree, one sample folder is dedicated to the Photo Studio User`s Guide. For more information on where 

sample documents are installed by default, see Accessing Sample Documents in the Version 5 - 

Infrastructure User's Guide. 

4.  Click Open.

 

 

The product is loaded in the Rendering workbench.

 

http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/samples/Lamp.CATProduct
http://canly1dsy/ajtCXR14/Doc/online/basug_C2/basugbt0208.htm


Creating a Quick Render  
 

 
This task will show you how to very simply create a nice image of your product.

If you did not follow the steps 1 to 4 in the previous task, open the Lamp.CATProduct. 

Select the Shading with Material icon from the View toolbar.

The product looks like this: 

 

 

1.  Click the Quick Render icon .

The Rendering Output window opens to display the rendered image. The image resolution is 
the one of the window containing your product.

http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/samples/Lamp.CATProduct


 

 
A message indicates the name and the location of the image.

2.  Click OK to close the window.

 

 



Basic Tasks
Camera Management

Light Management
Picture Management

Stickers
Animations

Environment Management
Shooting
Materials

Multi-View Configuration

 



Camera Management
 

Creating a Camera from a Viewpoint
Using Knowledgeware Parameters

Using the Camera Commands Toolbar 



Creating a Camera from a Viewpoint 
 

 

The camera enables you to specify a viewpoint from which a photorealistic image will be computed. This task will show you how to create 
a camera and manage its specifications.

Open the LAMP.CATProduct document. 

1.  Click the Create Camera icon . The camera is created at the current viewpoint.

 

2.  Click the Camera item in the specification tree and rotate the model to see the camera symbol:

This standard visualization is not affected by any change of scale ("zoom").

In case you wish to hide the camera representation, click the camera in the specification tree then select the Camera object-
>Hide/Show Representation contextual command. Inversely, this command lets you show a hidden representation.

You can create several cameras at different locations to have different viewpoints.
The camera which is taken into account to render a given image is said to be active. Any other camera is inactive.

http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/samples/Lamp.CATProduct


3.  Use the two spheres and the two squares displayed in green on the 3D representation to interactively manipulate and position the 

camera.

This visualization is affected by changes of view scale (zoom) and is activated when selecting a camera in the scene or in the 

specification tree. Otherwise, all elements are set to the standard visualization. 

Conical camera

Pyramid height = focal length 
and

Pyramid base = film dimensions

 

Cylindrical camera

Plane = film dimensions 

●     the source point (1) rotates the camera around its target point

●     the target point (2) rotates the camera around its source point

●     the source green square translates and rotates the camera around its target point

●     the target green square translates and rotates the camera around its source point.

Cameras are needed to render and view a scene. "An image is worth a thousand words": the better the camera is positioned, the 
more accurate the saying is.

 
4.  Select the camera in the specification tree then right-click and select the Edit->Properties command (or use the ALT+ENTER 

keyboard shortcut). The Properties dialog box is displayed: 



5.  In the Lens tab, select the lens Type: Perspective or Parallel, i.e. to obtain a conical or a cylindrical projection. The Preview area 

shows the result of your selection accordingly.

A conical camera is equivalent to a standard camera, with a non-zero focal length. 

Parallel lines in the camera line of view appear to intersect at the same point.

Perspective cameras are used in most cases since they are close to the human vision. 

In the case of a cylindrical camera, parallel lines never appear as intersecting.

These cameras are mainly used to define architectural viewpoints. 

6.  Specify the Focal Length, which determines the field of view, in millimeters.

The focal length is the distance between the camera origin and the viewing plane.

In a cylindrical projection, the focal length is replaced by a zoom factor which determines the scale of view (i.e. "Scale" appears 

instead of "Focal Length" in the dialog box).



 

 
You can also specify the camera view directly inside the preview window by zooming, rotating or panning the view:

 
7.  Click the Position tab to define the target and origin position.

 



 
You can define the Origin and the Target position in millimeters along the X, Y and Z axes.

 
If you are not satisfied with the values you defined, you can click the  button next to the desired parameter to reset its value.

 The Feature Properties tab provides general information on the currently selected camera, e.g. its name, its creation date, etc. 

Snapping the compass to the camera lets you modify the camera position and orientation very easily simply by dragging the arcs 
of the compass as shown below:

 

 For detailed information about compass manipulation, refer to Moving Objects Using the 3D Compass in the Infrastructure User`s 
Guide.

 
8.  Check the Update camera from View option if you wish to adjust (i.e. center) automatically the camera whenever the viewpoint is 

modified:

 

    

 This avoids selecting the Update from View contextual command each time a viewpoint modification is done.

9.  Click OK when finished.

10.  If you want to position yourself behind the camera and observe the captured image, select the Window ->Camera Window 

command: a new window displaying the camera viewpoint is opened. When you manipulate the handler in this window, the camera 

is simultaneously positioned in the main window.

●     Window -> Tile Vertically

●     Window -> Cascade

http://canly1dsy/ajtCXR14/Doc/online/basug_C2/basugbt0800.htm


 

    

 

Note: You can choose three arrangements for the opened windows, i.e. horizontal, vertical and cascading by selecting the 

following commands from the menu bar:

●     Window -> Tile Horizontally

●     Window -> Tile Vertically

●     Window -> Cascade

 
Example of vertical tiling

 

To close the camera window, you can either click the cross in the top-right corner of the window or reselect the Window -> 
Camera Window->Camera x command.

You can double-click the Camera item in the specification tree to position the camera from the current point of view. 

You can also select the camera in the specification tree then the Update From View contextual menu to update the camera when 

the viewpoint is modified.

 



Using Knowledgeware Parameters 

 

The camera shows you how to control camera parameters using Knowledgeware tools. This enables you to link parameters 
to constraints like formulas in order to, for instance, automatically update the camera position whenever the object is 
moved.

Open the Lamp.CATProduct document. 

1.  Create a camera by clicking the Create Camera icon . The camera is created at the current viewpoint.

 

You can refer to Creating a Camera for detailed information on cameras.

2.  Make sure that the camera is selected either in the geometry area or in the specification tree then click the 

Formula icon  from the Knowledge toolbar to open the f(x) dialog box:

http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/samples/Lamp.CATProduct


The Parameter list displays the parameters related to the camera:

●     KweType: controls the lens type of the camera. This parameter is an integer and you can choose between 
"0" for perspective or "1" for parallel. The default value is "0"

●     KweViewAngle: controls the view angle of the camera. The default value is "15°"

●     KweFocus: controls the focal length (i.e. the field of view) for perspective cameras. The default value is 
"420mm"

●     KweZoom: controls the zoom factor (i.e. the field of view) for parallel cameras. The default value is "1"

●     KweVisuMode: controls the representation of the camera, i.e. whether the camera is displayed in the 
geometry area or not. The default value is "1" which means that the camera is displayed.

●     KweUpdateFromView: controls the update mode of the camera. You can choose between "0" to indicate 
that the camera should not be updated when the viewpoint is modified and "1" to indicate that the camera 
should be updated. The default value is "0"

●     KweOriginX: controls the position of the camera origin along the X axis (in mm)

●     KweOriginY: controls the position of the camera origin along the Y axis (in mm)

●     KweOriginZ: controls the position of the camera origin along the Z axis (in mm)

●     KweTargetX: controls the position of the camera target along the X axis (in mm)

●     KweTargetY: controls the position of the camera target along the Y axis (in mm)

●     KweTargetZ: controls the position of the camera target along the Z axis (in mm)

●     KweZenithX: controls the rotation of the camera around the X axis

●     KweZenithY: controls the rotation of the camera around the Y axis

●     KweZenithZ: controls the rotation of the camera around the Z axis.



3.  To edit a parameter, select it from the list: the selected parameter appears in the "Edit name of the value of the 

current parameter" field along with the corresponding value in the field to the right.

In this scenario, we will select the KweUpdateFromView parameter:

4.  Enter the "1" in the field displayed to the right to indicate that the camera should be updated according to the 

viewpoint.

For detailed information on how to use the other fields available from this dialog box, refer to Getting Familiar 
With the f(x) Dialog Box.

5.  Click OK or Apply + OK to validate and close the dialog box.

The parameter is modified.

 
6.  Modify the viewpoint (by rotating the object, for instance) and check the result: the camera is updated accordingly 

as shown below:

 

  

  Picture 1 - Camera with original viewpoint     Picture 2 - Camera after viewpoint modification

 You can also create formulas to constrain the parameters of your choice. For instance, you could associate the 
center of a part to the camera target so that the camera position changes according to the the object position.
For detailed information on how to create and use formulas, refer to Formulas.

http://canly1dsy/ajtCXR14/Doc/online/cfyugkwr_C2/cfyugat3400.htm
http://canly1dsy/ajtCXR14/Doc/online/cfyugkwr_C2/cfyugat3400.htm
http://canly1dsy/ajtCXR14/Doc/online/basug_C2/basugat3200.htm


Using the Camera Commands Toolbar

This task aims at showing how to use the Camera Commands toolbar to manipulate cameras more easily.

Open the Lamp.CATProduct document.

 

This scenario assumes that at least one camera has been created as explained in Creating a Camera.

The Camera Commands toolbar is displayed by default under the Menu bar when accessing the Photo Studio workbench:

 

 Some of the commands available in this toolbar can also be accessed from the menu bar or by right-clicking the camera in the 
specification tree then selecting the corresponding contextual command:
 

Camera toolbar Contextual command/Menu item

 Camera Window (default) Window->Camera Window menu item

 Camera Window Window->Camera Window menu item

 Update from View Update from View contextual command

 Manipulate Focal No contextual command or menu item
  

 

1.  Select a camera in the pulldown list (where you see "None" right now) which contains all the cameras you may have 

previously created.

The camera commands are activated:

 

Note that if the camera you selected is a cylindrical camera (i.e. the lens type is "parallel"), only the first two 
commands will be activated because the Manipulate Focal command only applies to conical cameras (i.e. with a 
"perspective" lens).

 

2.  If you want to position yourself behind the camera and observe the captured image, click the Camera Window  

icon: a new window displaying the camera viewpoint is opened. When you manipulate the handler in this window, the 

camera is simultaneously positioned in the main window.

http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/samples/Lamp.CATProduct


You can choose three arrangements for the opened windows, i.e. horizontal, vertical and cascading by selecting the 

following commands from the menu bar:

●     Window -> Tile Horizontally

●     Window -> Tile Vertically

●     Window -> Cascade.

Example of vertical tiling

Once the Camera Window command is activated, the icon turns from  to .

To deactivate the command and close the camera window, you can either click the cross in the top-right corner of 
the window or reselect the Window -> Camera Window->Camera x command.

 

3.  To adjust (i.e. center) the camera when the viewpoint is modified, click the Update from View  icon. 

Do not forget that each time the viewpoint is modified, you need to click the Update from View icon to re-adjust the 

camera.



 

 
Picture 1 - Camera with starting viewpoint Picture 2 - Camera after viewpoint modification

If you want the camera to be adjusted automatically each time the viewpoint is changed, double-click the Update 

from View icon (which turns ). To go back to the standard update mode, just click the icon again. 

Another method to adjust automatically the camera is to access the camera properties then check the Update 

Camera from View option.

 

4.  Click the Manipulate Focal  icon to modify the focal length (i.e. the distance between the camera origin and the 

viewing plane) directly in the 3D viewer.

A green circle appears with an arrow indicating the current focal length in millimeters as shown below:

 



 

You can then drag the green arrow clockwise to increase the focal length or anticlockwise to decrease it. 
When you drag the arrow, the value in millimeters is updated and the focal length changes accordingly. 

The position of the camera origin is also modified simultaneously (the camera moves backward or forward) so that 
the model always fits into the camera field of view. Therefore, the perspective is modified without having to zoom in 
or out afterwards.

 

 

The focal length can also be defined via the camera properties in the Lens tab. If you access the Properties dialog 
box, you will see that the value displayed in the viewer matches the one displayed in the Focal Length field.

Activating the Manipulate Focal command also keeps the Update from View command activated (the icon turns 

): this means that the camera will be automatically updated each time the viewpoint is modified. There is no 
need to click the Update from View icon after each modification of the viewpoint.

 To exit the Manipulate Focal command, click the  icon.

 



Light Management
 

Creating a Light Source
Creating a Surfacic Light Source

Using the Light Commands Toolbar 



Creating a Light Source
 

 This task shows you how to create a light source and define its parameters. Lights let you illuminate the objects to be rendered as you 
wish for example, by highlighting a specific element in your scene, thus focusing the viewer`s attention.

 
Open the Lamp.CATProduct document.

You can choose between three different types of light sources: spot, point and directional. 

 
1.  Click the Create Spot Light icon  to create a source with a conical shape:    

 

Note that the representation of the light source displayed above corresponds to the default representation mode (i.e. "wireframe 
display). You can choose to display the light source in shading mode by checking the corresponding option in the Tools->Options-
>Infrastructure->Photo Studio->Display tab.

This light source is located at a given place, emitting the light isotropically inside a cone of influence determined by the 

privileged direction of illumination (forming the axis of revolution) and the angle that the edge of the cone forms with this axis. 

Spot light sources are mainly used to simulate spot light (the most frequently used lights) and are useful for tuning the lighting 

of each object individually. 

 

You can also click the Create Point Light  icon: 

http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/samples/Lamp.CATProduct


  

 

this creates a source situated at a given point, emitting light isotropically, i.e. in all directions. This light source type is mainly 
used to simulate light bulb, for instance. 

 

or click the Create Directional Light  icon :

this creates a light source coming from a given direction, generating constant intensity parallel lighting. This light source type is 
mainly used to simulate a global lighting as the sun does.

Note: you can click anywhere in the geometry area to see the light symbol:

          

 

                  Spot light                 

 

 Point light Directional light 

 

Anchoring point is the position of the light source and is represented by a small star. When the source is characterized by a 
direction, the anchoring point coincides with the origin of the arrow.
In the case of a spot or punctual light source, the anchoring point physically localizes the source. In the case of a directional 
light source, it can be used (with the target point) to define the illumination direction.

2.  To activate a light source, simply select it in the specification tree then check the Light On option from the contextual menu.

Inversely, to deactivate a light source, simply select it in the specification tree then uncheck the Light On option from the 

contextual menu.

Note: Light sources illuminating the scene are said to be active (On). Otherwise, they are inactive (Off) and do not cast any 

light.



                  

 

 

 

Direction vector represents the privileged direction of illumination of the source for spot and directional light sources. It is 
visualized by an arrow whose origin is the anchoring point of the source.

Anchoring point is the position of the light source and is represented by a small star. When the source is characterized by a 
direction, the anchoring point coincides with the origin of the arrow.
In the case of a spot or punctual light source, the anchoring point physically localizes the source. In the case of a directional 
light source, it can be used (with the target point) to define the illumination direction.

2.  To activate a light source, simply select it in the specification tree then check the Light On option from the contextual menu.

Inversely, to deactivate a light source, simply select it in the specification tree then uncheck the Light On option from the 

contextual menu.

Note: Light sources illuminating the scene are said to be active (On). Otherwise, they are inactive (Off) and do not cast any 

light.

Due to OpenGL limitations, some active lights may not be seen in the 3D window though they are defined as being "active". In 
that case, a warning sign identifies the light in the specification tree.
On most platforms, up to 8 lights can be seen at the same time, however this number may be higher depending on the graphics 
card.

3.  As for cameras, you can interactively manipulate a light source:

 
●     the source point (1) rotates the spot around its target point

●     the target point (2) rotates the spot around its source point

●     the upper green manipulator translates and rotates the spot around its target point

●     the lower green manipulator translates and rotates the spot around its source point.

Note: manipulators only apply to spot light sources.  



 

4.  Select the light then the Edit->Properties command (or use the ALT+ENTER keyboard shortcut) to access the Lighting tab in 

order to edit the lighting parameters.

You can also select the light in the specification tree then the Properties or the Light object-> Definition... contextual command 

to open the Properties dialog box: 

 

The Type field lets you modify the source type by selecting a new type from the pulldown list: Spot, Point or Directional. 

 
5.  Use the Color slider or the value-entry field to modify the light luminosity, then click the  button if you want to choose another 

color (the default color is white): 

 



You can enter a value comprised between 0 and 255 for any of these fields.

The overall color of a light source is composed of three independent colors: diffuse, ambient an specular. The values of these 
colors are given in RGB mode or in HLS mode by three real positive values:

●     HLS (Hue, Saturation, Luminance) model is an intuitive, easy to use tool for describing or 
modifying a color
Hue is the "color" of the color. It is the name by which the color is designated and is used to
define the desired color
Saturation is the intensity of the color. The higher the number, the more intense the color. 
It is used to tune the purity of the color
Luminance is the brightness of the color, i.e. the degree to which the pure color is diluted by
white or black. The larger the number, the lighter the color. It is used to adjust intensity.

●     RGB (Red, Green, Blue) model is a more physical model. It is based on the tri-stimulus theory
of the human perception system. This model is usually used to define, with a high precision, the
three primary components of the color.

6.  Click OK to confirm and close the Color dialog box. 

7.  Define the light Intensity using the slider or the value-entry field. 

The intensity of a light source is the maximal lightness value of three colors (ambient, diffuse and specular).  

The light color will be computed by multiplying the Red, Green and Blue values you defined in previous step by the intensity value. 

Therefore, this parameter allows you to adjust the luminosity of the light source, while preserving its chrominance ("color") 

component.

You can enter values comprised between 0 and 4: the higher the value, the more saturated (i.e. the whiter) the light. More 

precisely, as soon as the intensity value exceeds 1, the color starts saturating. 

8.  The Falloff field lets you define the light energy attenuation.

By default, the falloff is Linear and the attenuation start ratio is set to 0 (i.e. the attenuation starts from light origin). 

You can choose between the following attenuations: 

●     None: no lighting end which means that the light energy will be constant and infinite. The cone limits, however, are kept

●     Linear: light energy decreases linearly with a 1/r ratio ("r" = distance to light origin) and stops at attenuation end. For 

instance, if the energy received at a distance of 10 mm from the light origin will be equal to 1/10th of the light energy at light 

origin

●     Realistic: light energy decreases with a 1/r2 ratio and becomes negligible at attenuation end. A realistic falloff requires a high 

value when distant objects are to be illuminated. 

Note: directional lights do not disperse and therefore have no falloff.



 The following picture illustrates the three different types of light energy attenuation:

 
9.    The Lighting tab also lets you define:

●     Source Angle

 

  

 

Enables you to define the half-angle of the cone, that is the angle between the revolution axis and the cone edge (for spot light 

sources only). 

The angle is a value between 0 and 90 degrees. This means that a value of 90 degrees would generate a light source equivalent to 

a punctual light source. 

 

●     Attenuation End 

    Defines in millimeters the maximum distance for light attenuation (i.e. the distance to the center from which the lighting is null or 
negligible). 

 



●     Attenuation Start Ratio 

 
  

Defines as a ratio from the center to the target, the distance from which light starts to fall off, i.e. to attenuate. For example:
0      corresponds to an attenuation starting from the center (i.e. from light origin)
0.5   corresponds to an attenuation starting from the middle
1      corresponds to an attenuation starting from the end, i.e. a null attenuation.

●     Attenuation Angle Ratio 

  

Defines as a fraction of the light angle the angle to the light axis from which the light starts to attenuate. 
For example:
0      corresponds to an attenuation starting from the axis
0.5   corresponds to an attenuation starting from the half-angle
1      corresponds to an attenuation starting from the end, i.e. a null attenuation.

Note that you also position your pointer over the one of the side lines then click and drag the segment to modify the attenuation 
angle ratio.

The following are samples illustrating the various results you can obtain for lighting according to the values you set:

           

 

        Angle: 30 deg                                  Angle: 30 deg                                Angle: 30 deg
         Intensity: 0.5                                   Intensity: 1                                   Intensity: 1
         Attenuation end: 610 mm               Attenuation end: 470 mm            Attenuation end: 870 mm
         Start ratio: 1                                    Start ratio: 0.5                              Start ratio: 1
         Angle ratio: 1                                   Angle ratio: 0.5                            Angle ratio: 0.75



 

10.  Use the Area tab if you intend to create a surfacic light source by defining the corresponding light area: Rectangle, Disk, Sphere or 

Cylinder. In that case, the Properties dialog box will slightly change according the area you selected.

For more information on surfacic light sources, refer to Defining a Surfacic Light source in this guide.

11.  Access the Shadows tab then check the Ray Traced option if you want to enable shadow casting. When Off, shadows are not 

calculated for this light source.

Note: this option is used for rendering only.

12.  Click the Position tab to define the light source anchoring point and the point to which the source is directed, respectively in the 

Origin and Target areas. 

You can define this position in millimeters along the X, Y and Z axes. 

 Note that you can click the  button at anytime to reset the light source to the default position.

 
13.  The Reference Axis area lets you define the light source position relative to the Model axis or to the Viewpoint according to the radio 

button you select:

 
●     Model

By default, any light source you create is positioned relative to the model and thus, moving the viewpoint moves the light 
source along the model.
Click the thumbnail below to see the corresponding animation:

http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/images/anim_attachtomodel.gif


 
●     Viewpoint

Attaching a light source to the viewpoint means that moving the viewpoint only moves the model; the light source keeps the 
same position in the window.
Click the thumbnail below to see the corresponding animation:

 

 When a light source is attached to the viewpoint, it is identified by an anchor symbol in the specification tree as shown 
below for Light 1:

 

 Note that you can also attach a light source to the viewpoint by right-clicking it in the specification then selecting 
Attach to View. Inversely, once a light source is attached to the viewpoint, you can re-attach it to the model by 
unchecking Attach to View. 

The Feature Properties tab provides general information on the currently selected light source, e.g. its name, its creation date, etc.

14.  Click OK to apply the parameters to the light source. 

 
15.  If you want to display the light source viewpoint (to visualize the object as if you were positioned behind the light source), right-click 

the light item in the specification tree then select the Light View contextual command:

 

To go back to the original view, select the View->Modify->Previous View command or click the Previous View  icon from 

the Viewpoint toolbar. Then, you can switch to the light view by clicking the Next View  icon.

 
Right-clicking the light item in the specification tree also lets you select the Update from View contextual command to adjust 

(i.e. center) the light source when the viewpoint is modified as shown below:

http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/images/anim_attachtoview.gif


  Update from View -> 

 
16.  If you want to position the light source along a perpendicular to the point you click on the object.

To do so:

●     right-click the light source item in the specification tree (or the light symbol in the geometry area) and select the Position 

along Normal contextual command

then

●     place your pointer over any point of the object and click: the light source is positioned along the normal to the selected point.

Note that as long as the Position along Normal command is active, you can hold down the left-mouse button and keep on 

moving the cursor to find the best position.

Click the thumbnail below to see the corresponding animation:

 

 Note that instead of holding down then releasing the left-mouse button, you can also click a point on the object to position the 
light source then move your cursor over another point and click again, etc. until you are satisfied with the result.

 
When satisfied with the result, deactivate the Position along Normal command by selecting any other command in the 

workbench or by pressing the Esc key.

 
17.  You can also manipulate the specular effect of your light source.

To do so:

●     right-click the light source item in the specification tree (or the light symbol in the geometry area) and select the Position 

Specular contextual command

then

●     place your pointer over any point of the object and click: the specular spot is positioned at the selected point.

 

http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/images/anim_normalmanipulation.gif


Note that as long as the Position Specular command is active, you can hold down the left-mouse button and keep on moving the 

cursor to find the best position for the specular spot.

Click the thumbnail below to see the corresponding animation:

 

 Note that instead of holding down then releasing the left-mouse button, you can also click a point on the object to position the 
specular spot then move your cursor over another point and click again, etc. until you are satisfied with the result.

 
When satisfied with the result, deactivate the Position Specular command by selecting any other command in the workbench or 

by pressing the Esc key.

18.  You can position the direction of the light source by right-clicking the light source in the specification tree (or in the geometry area) 

then selecting the Position Direction contextual command.

This command lets you manipulate in a very precise way your light source along predefined circles that are centered on the light 

target.

 
When you click the icon, the light symbol is replaced with the following symbol representing the light manipulator in 3D, the red 
arrow representing the light direction (i.e. the target):

 

 
When you point at an arrow, a predefined dotted circle is displayed like this:

 

 

If you drag your mouse along that circle, the light source is rotated along its axis.

Now if you position your mouse over an arc, a predefined dotted circle will also appear. 
If you drag your mouse along that circle, this will change the position of the light origin along the selected arc:

http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/images/anim_specularmanipulation.gif


 

 

Note that you can move the light position step-by-step by pressing the Ctrl key then dragging your mouse simultaneously. 
By default, the light source is rotated 10 degrees by 10 degrees but you can modify this value if needed via the Direction dialog 
box.

 
You can also perform the following actions when right-clicking then selecting one of these contextual commands: 

 
Edit Light Direction

This dialog box lets you edit the light direction, the rotation step as well as the quick orientation:

 

 

●     Direction: the three spin boxes displayed let you define the position of the direction vector along the X, Y and Z directions. 
The direction vector represents the privileged direction of illumination of the source and is visualized by the red arrow whose 
origin is the light source origin.
As soon as you modify a value, the light source is updated simultaneously in the geometry area.



 

●     Step-by-Step Rotation: this area lets you define the rotation angle in degrees. The default value is 10.00 but you can enter 
your own value if needed using the spin box.
When the rotation angle has been defined, click the desired button to start rotating your light source around the corresponding 
axis by the angle you specified.

For instance, clicking X+ means that the light source will be rotated by the specified angle positive (i.e. clockwise) around the 
X axis whereas clicking -X will rotate the light source by the specified angle negative (i.e. anticlockwise) around the X axis:

 

 

Starting position: X New position: -X
Rotation = 45 degrees

 
Note that using these buttons amounts to manipulating the light source directly in the geometry area using the Ctrl key.

 

●     Quick Orientation: this area lets you position the light source parallel to the absolute axis system.
For instance, clicking Y will modify the light origin in order to position the light source parallel to the Y axis.
Inversely, clicking -Y will invert the position of the light source along the Y axis:

 

 
Quick Orientation = Y Quick Orientation = -Y

 

●     Compass: this button lets you position the light source according to the compass orientation.

When satisfied, click OK to validate your parameters.



 

Edit Light Parameters

Selecting this command opens the Properties dialog box (detailed above in this scenario) which lets you modify the light source 
parameters as needed.

 Save Light Direction

 
Selecting this command opens the following dialog box:

 

 

Once you are satisfied with the position of your light source, click the Save button to store the light position.
Each light position is saved under the following name: Direction.n, for instance "Direction.1" for the first position, "n" being 
incremented by one for each new position you save.
You can save as many positions as necessary but keep in mind that you are not allowed to modify the position name.

When finished, click OK to validate.

If you want to use afterwards one of the light positions you saved, just re-select the Save Light Direction contextual command 
then double-click the desired position: the light position will be updated accordingly in the geometry area.

 

Rotation

The rotation commands let you rotate the light source around the absolute axis system:

●     by default, the Free Rotation contextual command is activated and lets you rotate freely your light source around the X, Y or 
Z axis using the two green manipulators

●     if you activate the Rotate around X command, you will be able to rotate up or down your light source around the X axis only

●     if you activate the Rotate around Y command, you will be able to rotate up or down your light source around the Y axis only

●     if you activate the Rotate around Z command, you will be able to rotate up or down your light source around the Z axis only.

When you select the rotation around the X, Y or Z axis, the green manipulators are hidden and only the light target is displayed:

 



 

Lock Manipulator

When you point at one of the two green manipulators then right-click, you can also lock the selected manipulator using the Lock 
Manipulator contextual command. This command applies to the local X and Y axes of the light source.

Locking a manipulator means that the rotation in the plane defined by the selected manipulator will be locked: the locked 
manipulator is hidden and you will only be able to move your light source around the unlocked axis of the light source which 
means that the mouse will move only up or down.

 

 
No manipulator is locked One manipulator is locked

 
To unlock the manipulator, right-click then select Lock Manipulator again.

Once a manipulator is locked, you can also click anywhere in the geometry area then press the space bar to hide the manipulator 
symbol. 
This is especially useful when working with big models because you can still change the light position by pointing at the hidden 
manipulator (in that case, the cursor shape changes) without being bothered by the display of this manipulator on your model.

 This is illustrated by the example below in three steps (from left to right):

1.  one manipulator is locked
2.  the cursor shape changes
3.  you can still drag the hidden manipulator to modify the light direction



 

    

 
To redisplay the manipulator, you just need to press the space bar again.

 
When satisfied with the direction position, press the Esc key to exit the Position Direction command.

 
The rendered image below illustrates the result you can obtain once light sources have been defined:

 
More about light sources

Light sources created in the Photo Studio workbench are supported in:

●     reviews created using DMU Navigator. Refer to the "DMU Review" section in the Version 5 - DMU Navigator User's Guide to for detailed 
information

●     presentations created using DMU Navigator. Refer to the "DMU Presentation" section in the Version 5 - DMU Navigator User's Guide.

 



Creating a Surfacic Light Source
 

 

This task shows you how to create a surfacic light and define its parameters. Surfacic light sources are 
similar to ordinary light sources and are designed to create a soft, and thus more realistic, lighting. 
However, bear in mind that there is a price to pay in performance when using such lights.

When working with OpenGL, rectangular and disk light sources are replaced by a spot light source and 
sphere and cylinder light sources are replaced by a punctual light source.

 
Open the Lamp.CATProduct document.

You can choose between four different types of surfacic light sources: rectangular, disk, spherical and 
cylindrical.

 1.  Click the Create Rectangle Area Light  icon to create a surfacic light source with a 

rectangular shape, just as a rectangular spot light would do: 

 

 

http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/samples/Lamp.CATProduct


 Note that the representation of the light source displayed above corresponds to the default 
representation mode (i.e. "wireframe display). You can choose to display the light source in 
shading mode by checking the corresponding option in the Tools->Options->Infrastructure-
>Photo Studio->Display tab.

You can also click the:

Create Disk Area Light  icon to simulate spot lights, very useful for tuning the lighting 
of each object individually:

 

 

Create Sphere Area Light  icon to simulate a light bulb, but in a softer and more 
realistic way than the point light does:  



 

Create Cylinder Area Light  icon to simulate neons, for instance:

 

 

 
Note: you can click anywhere in the geometry area to see the light symbol:

   Rectangle area light Disk area light Sphere area light Cylinder area light

 

2.  As for ordinary light sources, you can interactively manipulate surfacic light sources:



   

 

2.  As for ordinary light sources, you can interactively manipulate surfacic light sources:

 

 

 

 

 

 

 

 

 

●     the source point (1) rotates the surface around its target point

●     the target point (2) rotates the surface around its source point

●     the upper green manipulator translates and rotates the surface around its target point

●     the lower green manipulator translates and rotates the surface around its source point.

 

Note: this does not apply to punctual surfacic light sources (i.e. sphere and cylinder) as they 
have no target point but only a source point.

3.  Select the light then the Edit->Properties command to access the Lighting tab in order to edit 

the lighting parameters. 



The Type field lets you modify the source type by selecting a new type from the pulldown list: 
Spot, Point or Directional. However, changing the source type will set the surface type (under 
the Area tab) to "None" in order to avoid inconsistencies.

4.  Use the slider to modify the color intensity, then click the  button if you want to choose 

another color (the default color is white). Refer to Defining a Light Source for detailed 

information.

 

5.  Define the light area Angle, the attenuation End as well as the attenuation Start and Angle 

Ratios. Refer to Defining a Light Source for detailed information.

 
6.  Use the Falloff field to define the light energy attenuation. Refer to Defining a Light Source.



 

7.  Access the Shadows tab then check the Ray Traced option if you want to enable shadow casting. 

When Off, shadows are not calculated for this light source. 

Note: this option is used for rendering only.

8.  Access the Area tab:

 

9.  Indicate the light area dimensions in the appropriate fields, Length and Width in our example. 

You can either use the slider or enter the value directly in the field.

The Type field lets you modify the surface type without having to use the icons from the Scene 
Editor toolbar. The fields will be modified accordingly. For instance, choosing a Sphere area 
will replace the "Width", "Length" and "Angle" fields with the "Radius" field.
In addition to that, the source type (under the Lighting tab) will also be modified to match the 
new surface type.



 

10.  The Samples U, V fields let you define the rendering sampling precision along the U and V axes. 

It is thus relevant for rendering purposes only.

The lighting will be computed according to the number of samples defined along the U and V 

axes: the more light sources, the less grainy the lighting. However, there is a price to pay in 

performance when defining a great number of samples.

The maximum number of samples you can enter is 40, the optimum value being comprised 

between 7 and 10.

 

Once surfacic light sources have been created, you can activate or deactivate the Show Area 
option to show/hide the selected light source when rendering the object. Note that the surface 
representation of a deactivated light source will also be hidden in the geometry.

 

11.  Click the Position tab to define the light source anchoring point and the point to which the source 

is directed, respectively in the Origin and Target areas. 

You can define this position in millimeters along the X, Y and Z axes.

As far as sphere and cylinder area light sources are concerned, you just have to define the 

Origin. 

 

12.  Use the Reference Axis area to define the light source position relative to the Model axis or to the 

Viewpoint. Refer to Defining a Light source for more information.

 
13.  Click OK to validate your parameters.

 
More about surfacic light sources

Surfacic light sources created in the Photo Studio workbench are supported in:

●     reviews created using DMU Navigator. Refer to the "DMU Review" section in the Version 5 - DMU 
Navigator User's Guide to for detailed information

●     presentations created using DMU Navigator. Refer to the "DMU Presentation" section in the Version 5 
- DMU Navigator User's Guide.



Using the Light Commands Toolbar
 

This task aims at showing how to use the Light Commands toolbar to manipulate standard and surfacic light sources more 
easily.

Open the Lamp.CATProduct document.

 

This scenario assumes that at least one light source has been created as explained in Defining a Light Source.

The Light Commands toolbar is displayed by default under the Menu bar when accessing the Real Time Rendering 2 
workbench:

 

 Note that all the commands available in this toolbar can also be accessed by right-clicking the light source in the specification 
tree then selecting the corresponding contextual command:
 

Light toolbar Contextual command

 Turn Light On/Off (default) Light On (checked)

 Turn Light On/Off Light On (unchecked)

 Light View Light View

 Update from View Update from View

 Toggle Light Attachment 
(default) Attach to View (unchecked)

 Toggle Light Attachment Attach to View (checked)

 Position along Normal Position along Normal

 Position Specular Position Specular

 Position Direction Position Direction
  

 

1.  Select a light source in the pulldown list (where you see "None" right now) which contains all the light sources you 

may have previously created.

The light commands are activated:

http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/samples/Lamp.CATProduct


 

According to the light source you select, the look of the Turn Light On/Off icon will change to reflect the status of 

the light source:  indicates that the selected light is active and  indicates that the selected light is inactive.

 

2.  To activate a light source, select it in the pulldown list then click the  icon.

Inversely, to deactivate a light source, select it in the pulldown list then click the  icon.

Light sources illuminating the scene are said to be active (On). Otherwise, they are inactive (Off) and do not cast 

any light.

3.  Click the Light View  icon to display the light source viewpoint, i.e. to visualize the object as if you were 

positioned behind the light source:

To go back to the original view, select the View->Modify->Previous View commands or click the Previous view 

 icon from the Viewpoint toolbar. Then, you can switch again to the light view by clicking the Next View  
icon.

4.  Click the Update from View  icon to adjust (i.e. center) the light source when the viewpoint is modified as 

shown below:



         Update from View -->

5.  Use the Toggle Light Attachment icon to attach the light source to the model or to the viewpoint. 

By default, any light source you create is positioned relative to the model and is identified by the  icon in the 

Light Commands toolbar. This means that moving the viewpoint moves the light source along the model. 

Click the thumbnail below to see the corresponding animation:

 

To attach the light source to the viewpoint, click the Toggle Light Attachment icon which will turn . 
Attaching a light source to the viewpoint means that moving the viewpoint will only move the model; the light 
source will keep the same position in the window.
Click the thumbnail below to see the corresponding animation:

 

 

6.  Click the Position along Normal  icon to position the light source along a perpendicular to the point you click 

on the object in the geometry area.

When you hold down the left-mouse button, the representation of the light source is hidden but reappears when 
you release the button.

As long as the Position along Normal mode is active (i.e. when the icon looks like this: ), you can hold down 
the left-mouse button and keep on moving the cursor to find the best position. 

Click the thumbnail below to see the corresponding animation:

http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/images/anim_attachtomodel.gif
http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/images/anim_attachtoview.gif


 

 

Note that instead of holding down then releasing the left-mouse button, you can also click a point on the object to 
position the light source then move your cursor over another point and click again, etc. until you are satisfied with 
the result.

 When satisfied with the light source position, click the  icon to exit the Position along Normal mode.

 

7.  Click the Position Specular  icon then the object in the geometry to position the specular spot as desired.

This capability helps you to tune the specular effect and can also be used to analyze surfaces (curves).

When you hold down the left-mouse button, the representation of the light source is hidden but reappears when 
you release the button.

As long as the Position Specular mode is active (i.e. when the icon looks like this: ), you can hold down the 
left-mouse button and keep on moving the cursor to find the best position for the specular spot.

Click the thumbnail below to see the corresponding animation:

 

 

Note that instead of holding down then releasing the left-mouse button, you can also click a point on the object to 
position the specular spot then move your cursor over another point and click again, etc. until you are satisfied with 
the result.

 When satisfied with the light source position, click the  icon to exit the Position Specular mode.

8.  To position quickly the light direction, click the Position Direction  icon.

This command lets you manipulate in a very precise way your light source along predefined circles that are 

centered on the light target.

 
When you click the icon, the light symbol is replaced with the following symbol representing the light manipulator in 
3D, the red arrow representing the light direction (i.e. the target):

http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/images/anim_normalmanipulation.gif
http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/images/anim_specularmanipulation.gif


 

 
When you point at an arrow, a predefined dotted circle is displayed like this:

 

 

If you drag your mouse along that circle, the light source is rotated along its axis.

Now if you position your mouse over an arc, a predefined dotted circle will also appear. 
If you drag your mouse along that circle, this will change the position of the light origin along the selected arc:

 

 

Note that you can move the light position step-by-step by pressing the Ctrl key then dragging your mouse 
simultaneously. By default, the light source is rotated 10 degrees by 10 degrees but you can modify this value if 
needed via the Direction dialog box.

 
You can also perform the following actions when right-clicking then selecting one of these contextual commands: 

 
Edit Light Direction

This dialog box lets you edit the light direction, the rotation step as well as the quick orientation:



 

 

●     Direction: the three spin boxes displayed let you define the position of the direction vector along the X, Y and 
Z directions. The direction vector represents the privileged direction of illumination of the source and is 
visualized by the red arrow whose origin is the light source origin.
As soon as you modify a value, the light source is updated simultaneously in the geometry area.

 

●     Step-by-Step Rotation: this area lets you define the rotation angle in degrees. The default value is 10.00 but 
you can enter your own value if needed using the spin box.
When the rotation angle has been defined, click the desired button to start rotating your light source around the 
corresponding axis by the angle you specified.

For instance, clicking X+ means that the light source will be rotated by the specified angle positive (i.e. 
clockwise) around the X axis whereas clicking -X will rotate the light source by the specified angle negative (i.e. 
anticlockwise) around the X axis:

 

 

Starting position: X New position: -X
Rotation = 45 degrees



 
Note that using these buttons amounts to manipulating the light source directly in the geometry area 
using the Ctrl key.

 

●     Quick Orientation: this area lets you position the light source parallel to the absolute axis system.
For instance, clicking Y will modify the light origin in order to position the light source parallel to the Y axis.
Inversely, clicking -Y will invert the position of the light source along the Y axis:

 

 
Quick Orientation = Y Quick Orientation = -Y

 

●     Compass: this button lets you position the light source according to the compass orientation.

When satisfied, click OK to validate your parameters.

 

Edit Light Parameters

Selecting this command opens the Properties dialog box which lets you modify the light source parameters as 
needed. For detailed information on this dialog box, refer to Adjusting Light Source Parameters.

 Save Light Direction

 
Selecting this command opens the following dialog box:



 

 

Once you are satisfied with the position of your light source, click the Save button to store the light position.
Each light position is saved under the following name: Direction.n, for instance "Direction.1" for the first position, 
"n" being incremented by one for each new position you save.
You can save as many positions as necessary but keep in mind that you are not allowed to modify the position 
name.

When finished, click OK to validate.

If you want to use afterwards one of the light positions you saved, just re-select the Save Light Direction 
contextual command then double-click the desired position: the light position will be updated accordingly in the 
geometry area.

 

Rotation

The rotation commands let you rotate the light source around the absolute axis system:

●     by default, the Free Rotation contextual command is activated and lets you rotate freely your light source 
around the X, Y or Z axis using the two green manipulators

●     if you activate the Rotate around X command, you will be able to rotate up or down your light source around 
the X axis only

●     if you activate the Rotate around Y command, you will be able to rotate up or down your light source around 
the Y axis only

●     if you activate the Rotate around Z command, you will be able to rotate up or down your light source around 
the Z axis only.

When you select the rotation around the X, Y or Z axis, the green manipulators are hidden and only the light target 
is displayed:

 



 

Lock Manipulator

When you point at one of the two green manipulators then right-click, you can also lock the selected manipulator 
using the Lock Manipulator contextual command. This command applies to the local X and Y axes of the light 
source.

Locking a manipulator means that the rotation in the plane defined by the selected manipulator will be locked: the 
locked manipulator is hidden and you will only be able to move your light source around the unlocked axis of the 
light source which means that the mouse will move only up or down.

 

 
No manipulator is locked One manipulator is locked

 
To unlock the manipulator, right-click then select Lock Manipulator again.

Once a manipulator is locked, you can also click anywhere in the geometry area then press the space bar to hide 
the manipulator symbol. 
This is especially useful when working with big models because you can still change the light position by pointing at 
the hidden manipulator (in that case, the cursor shape changes) without being bothered by the display of this 
manipulator on your model.

 This is illustrated by the example below in three steps (from left to right):

1.  one manipulator is locked
2.  the cursor shape changes
3.  you can still drag the hidden manipulator to modify the light direction

 



    

 
To redisplay the manipulator, you just need to press the space bar again.

 When satisfied with the direction position, click the  icon to exit the Position Direction mode.

 



Picture Management
 

Managing Picture Sequences
Saving Pictures 



Managing Picture Sequences

 
This task explains how to manage pictures when rendering a product.

 

Open the Shooting.CATProduct document.

Select the Shading with Material icon from the View toolbar.

 
1.  Click the Render Shooting icon  to open the Render dialog box.

2.  Click the Render Single Frame icon . The Rendering Output window opens and the 

processing starts:

 

http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/samples/Shooting.CATProduct


You can also click the Quick Render icon  to render an image.

3.  Click the Fit All In icon  to zoom the current view out so that the whole document fits 

into the available space in the viewer area as shown below:



 

 
You can also zoom in or out the current view with your mouse.

 4.  Use the zoom icon  to display the image with a zoom equal to 1. 

If the rendering computation takes too much time, you can interrupt it by clicking the Stop 

icon .

 

Note: the background colour of the Rendering Output window depends on the background 
color set in the Tools->Options->General->Display->Visualization tab, whether 
graduated or customized. 

By default, the image is saved as CatiaRender.tif in a temporary. If you wish to modify the 
name and the default location, please refer to the next task that learns you how to save 
pictures. 

 

 



Saving Pictures

From a Rendering Output

From a Shooting Definition

 

Rendering Output

 
This task aims at explaining how to save a computed image.  

1.  In the Rendering Output dialog box, click the Save icon  to open the Save As dialog box.

 

 

 

 

 



 

2.  Navigate to the desired location then enter the image name as well as the format in the appropriate fields. 

The supported formats are:

bmp Microsoft Windows Bitmap Format

jpg JPEG (Joint Photographic Experts Group) Fair Quality

jpg JPEG Medium Quality

jpg JPEG High Quality

pic Apple Macintosh Format

png Portable Network Graphics

psd Photoshop Format

rgb Silicon Graphics 24-bit RGB color

tga Truevision Targa file format

tif TIFF (Tagged Image File Format) True Color

tif TIFF True Color Compressed

3.  Click Save.

The image is saved.

For more information on saving documents for the first time or under another name, refer to the 
Infrastructure Version 5 documentation.

 

              

Shooting Definition

 
This task explains how to modify the default name, format and location when saving a rendered animation .  

 1.  Click the Create Shooting icon  to open the Shooting definition dialog box.

2.  Under the Frame tab, select the "On disk" option and specify the new Directory and Name of the image.
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3.  Choose a Frame format from the pulldown list. The supported Frame formats are:

bmp Microsoft Windows Bitmap Format

jpg JPEG (Joint Photographic Experts Group) Fair Quality

jpg JPEG Medium Quality

jpg JPEG High Quality

pic Apple Macintosh Format

png Portable Network Graphics

psd Photoshop Format

rgb Silicon Graphics 24-bit RGB color

tga Truevision Targa file format

tif TIFF (Tagged Image File Format) True Color

tif TIFF True Color Compressed

4.  Select an Animation file format from the supported format list: 

Frame Sequence

avi Microsoft Windows Audio-Video Interleaved

mov Apple Quick Time Movie

movie Silicon Graphics Movie

mpg MPEG(Moving Picture Expert Group)-1 Video 

Note: the image names of a turntable animation sequence are based on the path and name defined 
above. Image names are then prefixed with frame numbers: for instance, for an animation containing 3 
frames, choosing MyTurntable.tif  for the image name will produce MyTurntable_0001.tif, 
MyTurntable_0002.tif and MyTurntable_0003.tif . 

5.  Click OK.

The default location is modified and, once rendered, the animation file will be saved in the frame and 
animation format you selected.



If you do not specify any file extension, the default format will be  .tif. 

4.  Select an Animation file format from the supported format list: 

Frame Sequence

avi Microsoft Windows Audio-Video Interleaved

mov Apple Quick Time Movie

movie Silicon Graphics Movie

mpg MPEG(Moving Picture Expert Group)-1 Video 

Note: the image names of a turntable animation sequence are based on the path and name defined 
above. Image names are then prefixed with frame numbers: for instance, for an animation containing 3 
frames, choosing MyTurntable.tif  for the image name will produce MyTurntable_0001.tif, 
MyTurntable_0002.tif and MyTurntable_0003.tif . 

5.  Click OK.

The default location is modified and, once rendered, the animation file will be saved in the frame and 
animation format you selected.

Images rendered in .tif  format can easily be used for compositing thanks to alpha channel support. Alpha 
channel  determines the opacity level of the pixel and is used for generating graphic effects when 
overlaying two bitmaps. Image pixels that do not cover any geometrical object have a transparent alpha 
channel, thus allowing to nicely embed the rendered image in any other image used as background.

 



Stickers
 

Applying Stickers
Modifying Stickers 



Applying Stickers
  

 

This task explains how to apply a sticker on a digital mockup (i.e. CATProducts, CATParts, cgr and 
MultiCAD files). Stickers will be taken into account when computing an image or a movie and will be 
displayed in the resulting document.

Open the RED-CAR.CATProduct document. 

Select the Tools->Options->General->Display->Navigation commands then check the Highlight 
faces and edges option in the Visualization tab. This option enables to highlight the sticked face. 

Select also the Shading with Material icon from the View toolbar.

 
1.  Click the Apply Sticker icon  to open the Sticker dialog box. 

 Note: You can also select directly in the geometry area the element onto which the sticker 
should be applied then click the Apply Sticker icon. If you do so, you can skip step 2 and jump 
to step 3.
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2.  Select the 3D geometry location where you want to apply the sticker:

●     for a V5 model, you can either select one or multiple elements using the multi-selection in 
the 3D window or select the desired element(s) in the specification tree

●     for a V4 model, you can select a face or the entire product as well either in the 3D window 
or in the specification tree

●     for cgr and MultiCAD files, you can select either a face or the entire product in the 3D 
window or in the specification tree. As far as cgr files are concerned, the sticker will be 
applied onto the entire product.

However, note that applying a sticker onto the entire product will result in a longer response 
time when manipulating geometry.



 Depending on the location where you click, the sticker is applied the following way:

●     if you click an object in the specification tree, the sticker's manipulator is centered by 
default on the selected object and its size is proportional to the size of this object

●     if you click an object in the geometry area, the manipulator is centered by default on the 
point you clicked and is positioned along the normal to this point.

 3.  Click the  button to choose the type of mapping: either Planar, Spherical or Cylindrical.

 

 These different mapping types are available to let you select the most appropriate mapping for 
the shape of the geometry:

●     Planar Mapping is similar to a slide projector (a picture on a wall, for instance). You can use 
it for stickers with two privileged directions such as a picture of a chessboard or a wall of 
bricks

●     Spherical Mapping is similar to a painted light bulb. You can use it for stickers that do not 
have a privileged direction

●     Cylindrical Mapping is similar to placing a label on a can of food. You can use it for stickers 
having a privileged direction such as a picture of marble.

 
When a sticker is created and applied onto geometry, it is placed under a node named Stickers 
which is located under the current active product:

 



 In our example, the symbol identifying the sticker means that the sticker has been applied onto 
an element and has a texture image.

 The number of selected elements is displayed in the Selection field.

The sticker is applied (with a visualization in transparency and a default image) and is tangent 
to the surface.

The shape of the manipulator reflects the mapping type selected in step 3 ("Planar" in our 
example):

 

 

You can assign a new default image to the sticker using the Tools->Options->Infrastructure-
>Photo Studio->Sticker tab.

 
3.  Use the manipulator handles to adjust the texture scale as shown below:

 

 

 

 

 

 

 When the sticker is selected, the compass is automatically snapped to it to let you position the 
sticker as you wish in the geometry:



 

 However, as soon as you access the Sticker dialog box, the compass disappears.

For detailed information on object manipulation with the compass, refer to Manipulating Objects 
Using the Mouse and Compass.

 
You can also use the Texture tab`s sliders in the Sticker dialog box:

●     Size: defines the sticker size in millimeters

●     Scale U, V: determines how the sticker is stretched along u- and v-axes

●     Position U, V: determines the gizmo position along u- and v-axes. By default, the sticker 
image is centered

●     Use Normal: lets you apply the sticker according to the plane projection. The Reverse 
Normal option lets you invert the normal. When "Use Normal" is not checked, the sticker is 
applied on both sides of the selected element

●     Flip U, V: inverts the sticker texture along u- and v-axes

●     Orientation: defines the gizmo rotation around U, V and W axes. The W axis represents 
the normal to the surface.

You can click the  icon to resize U and V proportionally. This is especially useful for square 
shapes such as the Floor material. 

When this option is on, the Scale V field is grayed and the icon changes to .
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When the lock is green, clicking an highlighted element automatically removes the sticker 
applied onto it. Just click the green lock so that it turns orange in order to lock the selection and 
prevent any removal.

 
4.  Click the Lighting tab:

 

5.  Use the Color slider to set the sticker color or click [...] opposite Color then choose the color to be 

used for the material texture. The Color dialog box is displayed allowing you to select the exact 

color you wish to define as a texture:



You can click in the preview area to choose the color, or even key in the exact value of the 
desired color. You can enter a value comprised between 0 and 255 for any of these fields.

When finished, click OK (or Apply then OK) to validate and close the Color dialog box.

6.  Define the other lighting parameters:

●     Luminosity: determines the intensity of light diffused in any direction by the object, even if 
not lit by any light source

●     Contrast: the intensity of light diffused by the object when lit by light sources

●     Shininess: intensity and color of light reflected in one particular direction (highlights)

●     Transparency: determines the degree of transparency of an object. The higher the value, 
the more transparent the object.

7.  Click OK to validate your parameters.

The sticker is applied according to the parameter values you specified: 



 

You can create as many stickers as you wish on the same geometry and make them overlap 
each other, the last sticker created being placed on top.

You are now ready to modify the sticker properties.

 



Modifying Stickers

 

This task explains how to modify the sticker properties such as the lighting or the projected image, for 
instance.

Open the RED-CAR.CATProduct and apply a sticker as explained in Applying Stickers.

 
1.  Select the sticker in the specification tree then choose Properties from the contextual menu (or 

use the ALT+ENTER keyboard shortcut).

You can also double-click the Sticker icon or select the Sticker object->Definition... 

command to open the Sticker dialog box which lets you modify the sticker properties as well.  

Note: the Properties dialog box does not allow you to perform geometry modifications on a 

sticker that is already sticked. To do so, access the Sticker dialog box using the Sticker 

object->Definition... command. 
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The Feature Properties tab provides general information on the currently selected sticker, e.g. 
its name, its creation date, etc.

The Rendering tab enables you to modify the Texture and Lighting parameters: 

The Texture and Lighting parameters displayed in this dialog box are identical to those 
contained in the Stick dialog box, except that you can not manipulate the viewpoint 
interactively.



2.  If you want to apply an image to the sticker, click the ... button to open the File Selection dialog 

box.

The supported image formats are .bmp, .rgb, .jpg and .tif (this format supports transparency 

so that you can see the underlying stickers and geometry in the transparent areas of your 

image). 

3.  Navigate to the image you wish to apply then click Open.

 
The name, the path and the graphical representation of the chosen image are displayed in the 

Image field: 

  

 

 

 

Whatever image format you choose, you can access the Lighting tab to check the "Use 

Transparent Color" option then click the  icon to open the transparency viewer (the 
default transparent color is Black): 



 Note: the transparent color results from a comparison between pure color components. There 
is no tolerancy which implies that some aliasing artifacts may appear.

This dialog box lets you select the color onto which the transparency will be applied after 
clicking OK.

You can now zoom the sticker image to be used in the Pick Transparent Color dialog box. This 
is especially useful for choosing the pixel to be used as a color reference for transparency.
To do so, press and hold down the middle mouse button, then click the left (or right) mouse 
button and drag (still holding the middle mouse button down) upwards to zoom in or 
downwards to zoom out.
For instance, the image below has been zoomed out:



 

 

To reframe automatically the image, you can click the Fit All In  button anytime.

When satisfied, click OK to validate and close the dialog box.

4.  Click OK to validate your new sticker parameters.

The new sticker properties are applied onto the object:



 

 Picture 1 - Sticker applied onto RED CAR

 
Note: you can also generate a rendered image of the sticker by clicking the Quick Render 

icon : 

 

 
Picture 2 - Quick render of RED CAR`s sticker (with Lake scene in background) 

 



More about stickers

Stickers are identified by three different symbols in the specification tree:

●      for a sticker that is applied onto geometry and for which a texture image has been defined

●      for a sticker that is not applied onto geometry (typically, when you select the Sticker command 
without having previously selected the element onto which the sticker should be applied)

●      for a sticker that is applied onto geometry but for which no texture image has been defined.

Moreover, when no texture image has been defined for a sticker, it is not possible to generate a 
rendered image. If you try to do so, an error message is displayed.

 

 



Animations
 

Creating a Turntable
Defining Animation Parameters

Previewing and Rendering a Turntable 



Creating a Turntable

 

This task explains how to create a turntable which is the preliminary step before rendering an animation. 

A turntable lets you generate a movie of your model, permitting a better analysis of the design quality. 
It is a set of successive images. The movie generated consists in a rotation of the active camera around 
an axis. 

 
Open the LAMP.CATProduct document.

1.  Click the Create Turntable icon  to open the Turntable dialog box.

 

 The turntable symbol is displayed on the product: 
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You can now define the model rotation axis. The entire product geometry will be able to rotate 
around that axis.

2.  Position the turntable along the x, y, and z axes by dragging it to the desired location using the 

compass:

 

3.  Rotate the turntable along the u, v and w axes:



4.  In the Turntable dialog box, indicate the rotation Start and End angles in degrees.

By definition, the turntable is a simple rotation animation. The rotation can be limited to less 

than 360 degrees (for instance a half-turn, that is 180 degrees). 

The end angle is identified by an arrow as shown in the picture below:

Note: you can change the rotation direction by clicking the Reverse Direction button. 

5.  Click OK.

The turntable is created and you are now ready to define the animation parameters.

Select the turntable axis in the specification tree then Axis object -> Definition... from the 
contextual menu to edit the turntable rotation axis.

 



Defining Animation Parameters 

 
This task shows you how to define animation parameters.

 
1.  Click the Create Shooting icon  to open the Shooting Definition dialog box.

For detailed information on Frame and Quality parameters, refer to Setting Image Quality Parameters in this 
guide.

 2.  Click the Animation tab:

 

 3.  Select the simulation to be rendered from the pulldown list.

 

4.  Key in the complete animation Duration in seconds. 

This gives you the feedback of the effective animation lapse time. It depends on the number of frames per seconds 

specified in the scene.

The default value (twenty-five frames per seconds) displayed in the Duration field is the standard number of 

images used on a tape recorder. 

 5.  Indicate the Frequency of computation according to the total number of frames in the animation.



 6.  In the Frame count field, choose the number of frames that are going to be replayed in the animation.

 
7.  In the Compute field, indicate whether you wish to compute All frames or only a specified number of frames. In that 

case, you have to enter the start and end frames as well as the step between the computed frames.

 

When creating renders based on tracks and sequences, you will only be able to set the Frequency parameter, the 
others being grayed. The adequate DMU license is required to modify tracks and sequences:

●     shooting tracks of moving objects or sequences including moving objects requires a DMU Fitting Simulator 2 
(FIT) license

●     shooting tracks of mechanisms or sequences including mechanisms requires a DMU Kinematics Simulator 2 
(KIN) license

●     shooting tracks and sequences of lights, textures and cameras requires no DMU license.

 
8.  Click OK.

The shooting is defined and you can now preview and render your animation. 

 

 



Previewing and Rendering a Turntable

 

This task shows you how to animate a product in a simulation once you have defined the turntable and 
the animation parameters.

 
1.  Select the turntable axis.

2.  Click the Simulation  icon. The Edit Simulation dialog box appears:

 

 
3.  Move the turntable as you wish using the compass.

4.  Click the Insert button to record the desired shots in your animation. 

As soon as you insert your first keyframe, the dialog box buttons are activated to let you 

Modify, Delete or Skip the current shot by clicking the appropriate button.  



For more information on animating in a simulation and using the Manipulation toolbar, refer to 
Animating Scene Elements in a Simulation in this guide.
However, note that you cannot add objects to a simulation based on a turntable (even if the 
"Edit simulation objects" button is available).

5.  Keep on inserting keyframes then preview the animation by clicking the Play forward  

button with the "Animate viewpoint" option checked.

When you run the simulation, the animated object rotates around the turntable axis:

                   

 

6.  Click the Render Shooting icon  to render your animation. The Render dialog box opens:



 

 For detailed information on this window, refer to Setting Image Frame and Quality Parameters.

7.  Click the Render Animation icon .

The animation is rendered and saved under a default location. Just click the picture below to 
run the animation:



 You can also render an animation by selecting the desired shooting in the specification tree then 
clicking the Render Animation contextual menu.

Do not forget to select the corresponding turntable in the Shooting Definition dialog box as 
shown below, otherwise the Render Animation icon will be grayed.
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Environment Management
 

Creating an Environment
Managing Walls

Defining the Wallpaper
Importing an Environment 



Creating an Environment 
 

 

This task will show you how to create an environment. Three environment types are available: box, sphere and cylinder. 

An environment is a simplified simulation of a landscape surrounding your model and directly reflected by your model. It 
is an efficient way to get a very quick feedback of the illumination behavior of your model and check its integration in its 
final environment. For example, placing neon lights as a 3D-texture on the ceiling will be used for car body design, while 
referring to a picture of a Norvegian forest for the walls will produce an impressive marketing image of a newly designed 
chainsaw.

Open the RED-CAR.CATProduct document.

 1.  Click the Create Box Environment  icon if you want to create an environment with a rectangular shape (to 

represent a room for example). 

 
2.  Zoom out then click anywhere in the geometry area to deselect the environment.

You can also 

click the Create Sphere Environment  icon if you 
want an environment being a non-dimensional sphere with 
two hemispheres: north and south (to simulate a sky for 
example).

click the Create Cylinder Environment  icon 
if you want an enviroment having a cylindrical 
shape:
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Showroom environments (square or cylindrical shape) correspond to a square or cylinder room without 
windows, with a texture or an image on the walls, floor and ceiling.  

This type of environment is a very efficient tool for design study of very close reflection, for instance, reflection 
of rows of neon lights on a car body.

Their size can be set and they can be positioned at a desired location. 
They are always visible and will appear as other geometrical elements of the model at their defined location.

Sky-ground environments (spherical shape) will be used to simulate the reflections of a "real world" onto 
the geometry. Texture simulating grounds or skies will provide good results. They totally surround the model.

 

As soon as you create an environment, it becomes active. Any previously created environment is deactivated 
in the specification tree, only one active environment being taken into account at rendering time. 

In our example, Environment 2 has been created and 
Environment 1 is deactivated.

To activate an environment, just select it in the 
specification tree then select the Environment Active 
command from the contextual menu. 

 

  



 

3.  Position your pointer over the edges then use the green segments   displayed to resize the 

environment walls:

●     click and drag a segment to resize the walls according to the edges

●     shift-click and drag a segment to resize the walls according to the center.

4.  Select the environment in the specification tree then right-click and choose the Edit -> Properties command (or 

use the ALT+ENTER keyboard shortcut). The Properties dialog box is displayed.

5.  The Dimensions tab enables you to define the environment size. In our example, specify the Length, Width and 

Height of the walls in millimeters.

6.  Click the Position tab to interactively define:

●     the environment translation from the Origin along the X, Y or Z axis

●     the environment translation along the X, Y, or Z Axis.



The Feature Properties tab provides general information on the currently selected environment, e.g. its name, 
its creation date, etc. 

You can also interactively position your environment by dragging the compass and dropping it onto the 
environment. 

 



Managing Walls
 

 
This task will introduce wall list management.

Open the RED-CAR.CATProduct document and create an environment as explained in Creating an 
Environment.

1.  In the specification tree, select an environment wall (or select it directly in the 3D window).

 

2.  Right-click to display the contextual menu then uncheck the Wall Active option. The selected 

wall is grayed in the specification tree and is not taken into account at rendering time, as shown 

in the example below:
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Only the edges of the deactivated wall are displayed in the environment representation except 
if you have specified to display inactive environments (select the Tools->Options->Product 
commands then the Rendering tab). 

 
The geometry shadows are projected onto environment flat walls.

 



Defining the Wallpaper 

 

 

This task will show you how to associate images to your environment walls either using the default 
textures provided in the default material library or custom textures. 

 
Open the RED-CAR.CATProduct document then create an environment.

Using default textures

 
1.  Select any wall of the environment for which the wallpaper should be defined.

Note: As far as showroom environments are concerned, you can apply a different texture to 
each wall of the environment.

2.  Click the Apply Material icon  to display the Library window. 

The material to be applied onto the wall must have a texture, otherwise an error message will 
be displayed.

3.  Click the Construction tab, for example, then select Marble Paving. 

4.  Click Apply Material to map the image texture of the material onto the selected wall.

5.  Repeat these steps for the other walls if you want to.

Instead of clicking Apply, you can also use the contextual menu then copy the material before 
pasting it or drag and drop the material directly onto the wall.
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6.  Select the Shading with Material icon from the View toolbar.

The material texture is mapped onto the selected wall.

 

 
 

7.  To modify the mapped texture properties, right-click the corresponding environment wall in the 

specification tree then select the Properties or the object->Definition... command from the 

contextual menu.

The Properties dialog box is displayed:

 



 The Texture tab lets you modify the Image Name as well as the material Scale, Position and 
Orientation.

 

Note: the Image Name field lets you modify the mapped texture either by choosing another 

texture from the default material library or by choosing a custom texture. 

 
8.  The Flip U,V checkboxes lets you invert the material texture along U and V axes.

 
Check the Lock Texture Fit option if you want to prevent texture fit alteration when modifying 
the environment size.



 

9.  Define the image repetititon along U and V, as well as its scale, its position and its orientation:

U and V correspond to parameters of the local parametric surface.

●     Repeat U, V: lets you specify whether or not you want the texture repeated ad infinitum 
along u- and v-axes

●     Scale U, V: determines how the texture is stretched along u- and v-axes

●     Position U, V: determines the position of the texture along u- and v-axes. By default, the 
image is centered

●     Orientation: defines the rotation of the texture on surfaces.

 

You can click the Link U and V scales icon  to resize U and V proportionally. This is 
especially useful for square shapes, the Floor material for instance.

Note that when this option is on, the Scale V field is grayed and the icon changes to .

Use the Fit All in Wall option to automatically scale the texture in order to fit it in the wall.

 
10.  Click the Lighting tab and check the "Shadows" option if you want to enable shadow casting on the 

wall.

 

 
When the option is off, the wall is visible even if not illuminated.

 
Note: this option is used for rendering only.



11.  Click OK or Apply + OK to validate and close the Properties dialog box.

Using custom textures

 
1.  Select any wall of the environment onto which the wallpaper should be applied.

2.  Right-click then select Properties or the object->Definition... command from the contextual 

menu then access the Texture tab:

 
3.  Enter the name of the texture to be mapped directly in the Image Name field or click the ... button 

to navigate to the desired file.



Depending on the document environments (i.e. the method to be used to access your 

documents) you allowed in the Document settings, an additional window may appear 

simultaneously to the File Selection dialog box to let you access your documents using an 

alternate method:

 

 In our example, four document environments have been allowed among which the DLName 
environment. If you want to access your texture files using DLNames, for instance, just click 
the Logical File System button: this will open a specific dialog box dedicated to the DLName 
environment.
For detailed information on this dialog box, refer to Opening Existing Documents Using the 
Browse Window.

4.  Click OK to validate. 

5.  Repeat steps 1 to 4 for the other walls.

Once a file name has been entered in the Image Name field, the other fields are grayed out to 

let you modify the texture properties. To do so, repeat steps 9 to 12 detailed above in Using 

default textures.

6.  Click OK to validate your modifications.
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The following example shows an environment onto which custom textures have been applied:

 



Importing an Environment 
 

 

This task will show you how to generate an environment based on stitched images computed by Realviz 
Stitcher® from a series of pictures. The generated files to be imported in Photo Studio are of type .cam.

 

1.  Click the Import an Environment  icon from the Scene Editor toolbar to open the File Selection 

dialog box.

2.  Navigate to the desired .cam file then click OK to validate.

The file is imported and directly mapped onto an environment (either cubical, cylindrical or 
spherical), the convenient shape being automatically detected: 

 



Shooting
 

Setting Image Frame and Quality Parameters
Setting Indirect Illumination Parameters 



Setting Image Frame and Quality Parameters
 

 
This task shows how to define the rendering style and quality parameters. 

 

●     Open the Shooting.CATProduct document

●     Make sure that the Shading with Material icon is selected in the View toolbar.

 1.  Click the Create Shooting icon  to open the Shooting Definition dialog box the select "Shooting 1" from the Shooting 

Name pulldown list: 
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Under the Frame tab, the Scene area lets you specify the elements to be rendered as well as the way of rendering them. By 
default, the active environment and any other active source are rendered. 

 

2.  In the the appropriate fields of the Scene area, select the Camera, Environment and Available Lights you want to render.  

If no light is selected, a default directional light orthogonal to the image plane will be used (therefore producing very few 
shadows).

As it may take a very long time to compute the preview when working with large models, no preview is displayed by 
default. 

However, you can now click the Camera View  button to display a preview of the camera or of the current viewpoint 
(depending on what you selected in the Camera pulldown list).
In our scenario, the result looks like this when clicking the Camera View button:

 

 
Once the preview is displayed, the Camera View button is grayed out and will remain deactivated unless you select 
another value in the Camera pulldown list.

3.  In the Image size area, define the size of the rendered image using the slider or manually. 

4.  Indicate the ratio between the frame height and width in the Custom field.

By default, the pixel number is locked ( ). However, the pixel number and the ratio can be linked together so that, 
whenever you change the pixel number, the ratio value is adjusted according to this number and reciprocally. To do so, 

click the Lock Size Ratio icon (which turns green ).

You can also use the Predefined format option to retrieve standard ratios. The corresponding Ratio and pixel number will be 
displayed.

5.  In the Output area, check the "On disk" option if you want to modify the name of the computed image. By default, it is saved 

in a temporary folder under the name "CatiaRender.tif".

The "On disk" option also lets you change the default location. For more information, refer to the Saving Pictures task in 
this guide.

 
6.  The Quality tab lets you specify rendering, shadow and accuracy parameters, all of them impacting the rendering computation 

duration.



 

 

 
7.  Indicate the maximum number for:

●     Reflections

●     Refractions

●     Rebounds (the maximum number of times a ray, either reflected or refracted, can rebound onto a surface).

For instance, if you choose 2 reflections and have two parallel mirrors in your scene, you will see the reflections of the 

reflections in each mirror ; choosing 1 instead, you will not see the secondary reflections.

Note: the number of rebounds cannot exceed the sum (Reflections + Refractions) and cannot be lower than 1.



No texture rendering means that only the material lighting characteristics will be taken into account for the rendering and 
the environment wall texture are not rendered as well. This option can be used to speed up rendering at early stage for 
example. 

If you check the "Show shadows" option, only the shadows produced by the active lights will be rendered, otherwise no 
shadows are computed. This can be useful to speed up rendering.

Now, let's define the accuracy parameters that control the oversampling of the final image: 

8.  Select the accuracy type.

Predefined: sets a fixed sag value for calculating tessellation on all objects.

●     a low value means that a very fine mesh is used to render surfaces, but the drawback is that pre-processing 
and rendering will take more time

●     a high value means that a very coarse mesh is used, but the advantage is that pre-processing and rendering 
will take less time.

Custom: the Custom parameters are defined through three values: a minimum number of samples, a maximum number of 
samples and a threshold. 

●     minimum sample: specifies the minimum number of samples, i.e. minimum number of
rays taken at each corner of a pixel square to measure the color. In our example, we 
have chosen a minimum of 1 ray at each corner of a square of 4 × 4 pixels

●     threshold: specifies the percentage over which an oversampling is done if the contrast
in any RGB component between the currently calculated pixels and the neighboring
pixels weighted by their sum is greater than this threshold.
The lower this value, the more oversampling and the longer the rendering time

●     maximum sample: specifies the maximum number of samples, i.e. rays, per pixel. 
In our example, we have chosen a maximum of 1 ray per pixel.

The preview area to the right shows you the effect of each setting. 

Note that anti-aliasing sets a better oversampling. Anti-aliasing modifies the appearance of lines in order to make the 
jagged edges look smoother. To do so, the square pixels composing the lines are put in shades of gray or in-between color.

9.  Click the Animation tab to define the animation parameters.

For more information on the animation, refer to the Defining Animation Parameters task in this guide.

10.  Click OK.

The next step is to render the shooting you have defined.

 

11.  Click the Render Shooting icon  to open the Render dialog box. 

A summary of the selected scene characteristics (viewpoint, number of active lights, shadows activated or not, etc.) is 

displayed.



 

 

 

12.  Select a shooting then click the Render Single Frame button  or the Render Animation icon , depending on the 

type of render you wish to create.

The Rendering Output window opens and displays the rendering result. 

 

Note: you can also render an animation or a single frame by selecting the desired shooting in the specification tree then 
selecting the Render Animation or the Render Single Frame contextual menu.
The background colour of the Rendering Output window depends on the background color set in the Tools->Options-
>General->Display->Visualization tab.

 
After selecting an animation as current shooting, the Compressor Setup... button is activated to let you set the type of 
compressor from the Choose Compressor dialog box:

 



 This dialog box allows you to choose a CODEC from the list of CODECs installed on your computer, then configure it. The 
role of the CODEC is to compress your video files.

Installing Version 5 does NOT install CODECs on your computer. The list of CODECs differs from one platform to another. 
For information about how to configure the CODEC, refer to the CODEC supplier's documentation.

On Windows, the Compressor list contains several options among which "Full Frames (Uncompressed)". Selecting this 
option prior to recording has the following effects: 

●     the resulting video file is larger (because it is not compressed)

●     but performance during the recording is enhanced (because each frame is not compressed as soon as it is recorded). 

Note that if you installed DirectShow on your machine, you will be able to use all CODECs and compression options provided 
by the DirectShow multimedia architecture. Therefore, additional CODECs will be available in the Compressor list.

The following images illustrate different types of rendering:

 

 

 

 

 

 

  

 
Textures off, two active lights, shadows off

and an average accuracy. 
Textures on, two active lights, shadows on,
anti-aliasing off and the lowest accuracy. 

 

 

 

 

 

 

 

 

 

 

 

 

   

 
Textures on, two active lights, shadows on

and the lowest accuracy. 
Textures on, two active lights, shadows on 

and an average accuracy.

 



  

 

 
The  icon identifies the most recently rendered shooting in the specification tree, the other shootings being identified 

by the  icon. 

Click the Redo Render  icon if you wish to redo the last render performed, whether it was a single frame or an 
animation.

 

Once a shooting has been defined, you can edit its parameters afterwards by re-accessing the Shooting Definition dialog 
box. To do so, select the shooting to be modified in the specification tree then the Shooting object -> Definition... 
contextual command.



Setting Indirect Illumination Parameters

 

This task shows how to tune your shooting quality by creating indirect illumination. This functionality produces 
amazing realistic renderings by creating smoother shading. 

 

Open the Shooting.CATProduct document. 

Make sure that the Shading with Material icon is selected in the View toolbar.

 1.  Click the Create Shooting icon  to open the Shooting Definition dialog box then access the Indirect 

Illumination tab:

 

 
2.  Click the Active check box to activate Final Gathering. Once it is activated, the other fields are activated.

Final Gathering acts like an energy transmitter in the sense that the light striking the object is not only 

computed from the light sources you may have defined but also from the other elements composing the 

scene.

More precisely, the hemispherical area surrounding each shaded point is used to calculate the light 

energy. Rays are sent in the appropriate directions in this hemisphere and, as the light bounces from 

one object to another, the light energy is computed on any surfaces surrounding the object. This is what 

we call "indirect illumination":
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3.  In the Rays field, define the number of rays that will be sent at random from each pixel in the hemisphere 

to calculate the indirect illumination factor which will be multiplied by the material diffuse parameter 

coefficient. 

As a consequence, no indirect illumination will be computed for materials with a null diffuse value.

For instance, in case of a complex scene with many elements and  light sources, choosing a high number 

of rays is a good idea to have a fine result (at the cost of a lower performance). 

The trick is to balance the rendering quality and the computation duration:
- setting a too low number produces a low quality image since soft patterns of light and shadow may 
appear but the shooting duration is shorter.
- on the other hand, setting a too high value produces a high quality image since a great number of rays 
are fired but the more rays, the longer the shooting duration.

4.  Indicate the Maximum radius in millimeters. 

This parameter is used to allow better performance and represents an interpolation: a final gather result 

could be computed for each pixel but computation time would be unbearable in most cases. As indirect 

illumination tends to vary rather slowly, it is possible to interpolate from previous final gather results and 

still get an accurate result.

Each time a final gather point is requested to compute the indirect illumination on a pixel, neighbouring 

results are checked to see if they can be reused with minimal interpolation errors.

Maximum radius represents the maximum distance of previous final gather points to be reused. As a 

consequence, any previous points located at a distance greater than the maximum indicated (i.e. outside 

a sphere whose radius is the maximum radius you indicated) are not taken into account.

Usually, the illumination in a wall does not vary much when you just move over a minimal distance. But 

in a corner, artifacts may appear if one wall uses points from the other. This is avoided by the maximum 

radius criterium.



A useful schema to determine the correct value to be used is to first set a high maximum radius then 
decrease it progressively until you reach a value that does not produce artifacts for the given scene.

Note: 

●     If set to 0, the maximum radius will be computed from the scene extent.

●     The lower the maximum radius, the smoother the shading and the more accurate the illumination as 

rays will be sent closer from each other.

However, there is a price to pay in performance when setting a low value since the number of Final 

Gathering steps will be increased.  

 
5.  Once Final Gathering is activated, you can check the Do not use ambient option in the Material area in 

order not to take into account the material ambient coefficient when computing indirect illumination.

Ambient coefficient corresponds to the light intensity diffused in any direction by the object, even if not lit 

by any light source. This parameter affects the whole object, including the shadowed area.

6.  Click OK to validate your parameters.

While tuning your scene parameters, start using a few number of rays (i.e. a value < 100) with a high 
maximum radius. Then, when satisfied with the scene definition, you can increase the number of rays 
and decrease the maximum radius value.

 
7.  Click the Render Shooting icon  then select either the Render Single Frame icon  or the 

Render Animation icon , depending on the type of render you wish to create.



Picture 1 - 5 rays
Maximum radius: 1000

Computation time < 1 minute 

Picture 2 - 50 rays
Maximum radius: 500

Computation time < 1 minute

 

Picture 3 - 500 rays
Maximum radius: 100

Computation time = 1 minute

Picture 4 - 5000 rays
Maximum radius: 80

Computation time = 5 minutes

Pay attention to the shooting quality parameters, they have a great influence on performance and image 
quality.

The following is another example of Final Gathering: 



 



Materials
 

Using Materials for Rendering 



Using Materials for Rendering

 

This task aims at showing you how to define the material attributes for a rendering.   

You can apply a material to each instance within a CATProduct. This functionality is especially relevant for rendering purposes since it lets 
you apply a different texture to each instance. Therefore, there will be as many materials as instances. The material preview will however 
display the last material applied to the instance. 

For detailed information about applying a material and modifying material properties, refer to the Version 5 Real Time Rendering User`s 
Guide.

Open the Shooting.CATProduct document.

In case no material has been applied, the rendered image will be computed using the color and transparency defined in the basic graphic 
properties of the part, starting with the the object located at the lowest level in the specification tree. 
An object with no mapped material will appear as if it was made of matte plastic, without any relief and transparent or not (depending on 
the transparency degree defined in the Properties dialog box). 

As a consequence, it is recommended to apply a material onto each part of your model in order to compute the image from the material 
properties and thus, generate a far more realistic image.

 
1.  In the specification tree, select the plus sign besides the item referred to as "body".

2.  Right-click the Red Paint material then select the Properties command (or use the ALT+ENTER keyboard shortcut).

The Properties dialog box is displayed:
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5.  Click the Rendering tab to define the Lighting parameters:  

Ambient: the intensity of light diffused in any direction by the object, even if not lit by any light source. The ambient light is 
essentially used to show objects or parts of objects that are not illuminated directly by the light source.
The intensity is defined by a coefficient (with a value between 0 and 1). 
This parameter affects the whole object, including the shadowed area. 

Diffuse: the intensity of light diffused by the object when lit by light sources. The intensity is defined by a coefficient (with a 
value between 0 and 1).
Typically, a shiny metal surface would have a diffuse reflectance value close to 0, while a piece of cardboard would have a value 
probably above 0.9. 

Specular: intensity and color of light reflected in one particular direction (highlights).
Typically, a polished object would have a high value for the specular reflectance coefficient, while a more mat surface would 
have a lower one.

Roughness: dullness of an object (size of the reflecting zone). 
Set the value to a minimum to generate very sharp highlights on very shiny surfaces. Set the shininess to a higher value to 
generate large specular spots creating a duller effect on rougher surfaces. 

Transparency: the degree of transparency of an object and color of the filter interfering with the light passing through an 
object.
The transparency color acts like a photographic filter which modifies artificially the light rays received by an optical lens. 
It is generally identical to the ambient and diffuse color but when it is different, the shadows cast by the object are colored 
accordingly. For instance, a blue object with a red transparency color will cast slightly red shadows. 
The higher the value, the more transparent the object (in the example the value is 0.75), the lower the value, the more opaque 
the object.

Refraction: degree of light passing obliquely through an object. The refraction is defined by a coefficient (value between 1 and 
2).
Set to 1, the transparent object will show no light distortion. As an example, water has a 1.2 coefficient. 

Reflectivity: degree of reflectivity of an object. Set to a high value, the object reflects its environment. 

 

 

6.  Click the Texture tab to edit the material texture parameters. 

You can use the Flip U, V checkboxes to invert the material texture along U and V axes.

Note that when clicking the ... button to open the File Selection dialog box and choose a new texture, an additional window may 
appear simultaneously depending on the document environments (i.e. the method to be used to access your documents) you 
allowed in the Document settings. This additional window lets you access your documents using an alternate method and looks 
something like this:



 

 

In our example, four document environments have been allowed among which the DLName environment. If you want to access 
your texture files using DLNames, for instance, just click the Logical File System button: this will open a specific dialog box 
dedicated to the DLName environment.
For detailed information on the Browse dialog box, refer to Opening Existing Documents Using the Browse Window.

 
For more information on this tab, refer to the Version 5 Real Time Rendering documentation - Modifying Material Texture 

Properties.

A preview is displayed in the Properties window but it slightly differs from the rendered image. The following are examples of 
rendered images with their corresponding lighting preview: 

Lighting Preview Quick Render

         
             Default 

     
         Transparency = 0.90 

 

         Reflectivity = 0.94 

 

In order to get a more precise idea of the rendered material appearance, you can click the Ray Traced Preview  icon to 
display a preview of the material in the Properties window. To deactivate this preview mode, just click the icon once again. 

7.  Click OK.

The material attributes are defined. 
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Multi-View Configuration 
 

Automatic Configuration
Manual Configuration

Standard View Customization
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Creating a Multi-View: Automatic Configuration

 

 

The multi-view mode is a brand new capability allowing you to customize the multi-view configuration within a 3D viewer.
The automatic configuration is defined in the Automatic tab of the Views and Layout dialog box.

 For detailed information on the other tabs provided in this dialog box, refer to Creating a Multi-View: Manual Configuration 
and Creating a Multi-View: Standard View Customization.

 
What you should know before you start

In order to take full advantage of this scenario, you need to be familiar with the basic vocabulary:

●     "Viewer" is the screen area in which 3D objects are drawn

●     "View" is a part of the viewer. Usually, the viewer has one single view but it can also be divided into 4 parts 
representing a different view each. When a viewer is split into several views, it is identified as a "multi-view" viewer

●     "Viewpoint" is the set of parameters required for defining a 3D view volume, i.e. the eye of the user, the view 
direction, the focus point and the axis system defining the position of the user. It can be defined as the position in 
model coordinates at which the eye is looking

●     "Layout" defines how the viewer is divided into different areas (= views) and how these areas are located

●     "Configuration" is a layout made up of views, each of them being defined with a viewpoint.

Bear in mind that the multi-view configuration remains active throughout the whole Version 5 session but it is not saved 
when using the Save As... command. For instance, if you apply a multi-view configuration then save and close your 
document before reopening it, this document will be displayed in a single-view configuration using the last active view 
before the save.

However, the configuration is stored in the CATSettings directory and therefore, you can reuse it from one session to 

another by clicking the Create Multi-View  icon. If no customization has been defined, the default configuration is 
applied.

Open the Views.CATProduct document.

 
1.  Select the View->Navigation Mode-> Multi-View Customization... command to open the Views and Layout 

dialog box then select the Automatic tab:
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This dialog box is made up of three areas:

●     View Selection lets you select a group of views as well as their location and orientation

●     Viewpoint Manipulation lets you manipulate the viewpoint using the following options:
❍     Rotation Lock: locks the viewpoint rotation

❍     Translation Lock: locks the viewpoint translation

❍     Viewpoint Synchronization: imposes a synchronization between the views when a viewpoint 
transformation (rotation, translation or zoom) is made in one of them. Note that you cannot activate 
both Translation Lock and Viewpoint Synchronization

●     Confirmation: lets you validate or cancel the configuration.

 

For any 3D object, there are six standard views according to the coordinate system of the object. These views 
mapped onto a cube, each face of this cube being perpendicular to one of the directions of the 3D axis. 
Whatever the orientation of the cube, the observer can see three faces (i.e. three standard views) as shown 
below:



 

 
An isometric view can be added to these views. The direction of this isometric view starts from the vertex 
formed by the three faces towards the center of the cube.

 

The View Selection area represents the unfolded cube of standard views: each square represents a standard 
view and the one placed at the center is the base view around which adjacent views will be automatically 
generated.
In the default configuration displayed below, the base view is the standard "Left View":

 

ISO = Isometric View

TP = Top View

BK = Back View

LF = Left View

FR = Front View

BM = Bottom View

 

 

 2.  Select the standard view to be used as base view using one of these two methods:

 

●     select directly in the View Selection area the view to be set as the base view: the selected view will be 
placed at the center and all the adjacent views will be regenerated accordingly.
In the example below, the Back View is selected:



 

  

 
●     click the right translation arrow  to shift the Back View to the center (or any other translation arrow 

depending on the standard view you want to set as base view).
Clicking a translation arrow shifts the views in the arrow's direction.

 
3.  Click Apply to apply the configuration to the current 3D viewer and keep the Views and Layout dialog box 

displayed:

 

 
As soon as you apply a configuration to the current viewer, the Create Multi-View  icon in the View 

toolbar changes to  to indicate that the multi-view mode is now active.



 
When you manipulate a viewpoint in one of the four views, the other three viewpoints are not modified and you 
can manipulate them independently:

 

 

4.  Select a group of views by clicking an Isometric View in one of the four corners of the View Selection area. 

This amounts to selecting a vertex of the cube and the user will then see the three adjacent faces.

The selected Isometric View will be computed from its three adjacent views and the four views (Isometric + 

adjacent) will be highlighted:

 

 
Another example when the Isometric View in the top-right corner is selected:



 

 
The View Selection area also contains four rotation arrows (such as ) enabling you to change the orientation 
of the current base view: one click on an arrow rotates the base view by 90 degrees in the arrow's direction.
When the base view is rotated, all the adjacent views as well as the isometric view are recalculated.

 5.  Click the  arrow repeatedly and check the result in the View Selection area. Below is an example with starting 

position displayed to the left:

 

 

6.  Activate the lock options (+ click Apply) if needed:

●     Rotation Lock locks the rotation in all the views, except the Isometric View

●     Translation Lock locks the translation in all the views, except the Isometric View.

 
7.  Activate the Viewpoint Synchronization option then click Apply if you want the other three viewpoints to be 

modified simultaneously when you manipulate one of them.



 

 

8.  When satisfied with your configuration, click OK (or Apply then OK) to validate and close the Views and Layout 

dialog box.

To go back to the standard viewer, just click the Create Multi-View  icon from the View toolbar.

Note that when you reselect the View->Navigation Mode-> Multi-View Customization... command, the 

Views and Layout dialog box the last used tab is activated with the last applied configuration.



Creating a Multi-View: Manual Configuration

 

 

The multi-view mode is a brand new capability allowing you to customize your multi-view configuration within a 3D viewer.
The manual configuration is defined in the Manual tab of the Views and Layout dialog box.

 For detailed information on the other tabs provided in this dialog box, refer to Creating a Multi-View: Automatic Configuration 
and Creating a Multi-View: Standard View Customization.

 
What you should know before you start

In order to take full advantage of this scenario, you need to be familiar with the basic vocabulary:

●     "Viewer" is the screen area in which 3D objects are drawn

●     "View" is a part of the viewer. Usually, the viewer has one single view but it can also be divided into 4 parts representing a 
different view each. When a viewer is split into several views, it is identified as a "multi-view" viewer

●     "Viewpoint" is the set of parameters required for defining a 3D view volume, i.e. the eye of the user, the view direction, the 
focus point and the axis system defining the position of the user. It can be defined as the position in model coordinates at 
which the eye is looking

●     "Layout" defines how the viewer is divided into different areas (= views) and how these areas are located

●     "Configuration" is a layout made up of views, each of them being defined with a viewpoint.

Bear in mind that the multi-view configuration remains active throughout the whole Version 5 session but it is not saved when 
using the Save As... command. For instance, if you apply a multi-view configuration then save and close your document before 
reopening it, this document will be displayed in a single-view configuration using the last active view before the save.

However, the configuration is stored in the CATSettings directory and therefore, you can reuse it from one session to another 

by clicking the Create Multi-View  icon. If no customization has been defined, the default configuration is applied.

Open the Views.CATProduct document.

 
1.  Select the View->Navigation Mode-> Multi-View Customization... command to open the Views and Layout dialog 

box then select the Manual tab:
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This dialog box is made up of five areas:

●     Configuration Selection lets you select a predefined multi-view configuration from the pulldown list

●     View Selection lets you set the current view as well as the orientation of the selected viewpoint

●     Viewpoint Manipulation lets you manipulate the viewpoint using the following options:
❍     Rotation Lock: locks the viewpoint rotation

❍     Translation Lock: locks the viewpoint translation

❍     Viewpoint Synchronization: imposes a synchronization between the views when a viewpoint transformation 
(rotation, translation or zoom) is made in one of them. Note that you cannot activate both Translation Lock 
and Viewpoint Synchronization

●     Standard Views icons let you set the desired standard view as the current view. The standard views displayed in 
the left part of the dialog box are identical to the one of the Quick View toolbar

●     Confirmation: lets you validate or cancel the configuration.
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2.  In the Configuration Selection area, select the desired configuration from the pulldown list of predefined configuration. 

As soon as a configuration is selected, the four views displayed in the View Selection area are automatically updated 

accordingly. 

Each view composing the configuration represents a standard view and the current view is identified by a lighter 

color. 

You can choose among the following configurations: Four-View, Main view to the right or Main view on top:

 
●     Four-View

 

 
In this configuration, the viewer is divided into four equal views, each of them being identified as follows:

 

RI = Right View

TP = Top View

FR = Front View

ISO = Isometric View

 
●     Main view to the right



 

 
In this configuration, the viewer is divided into two parts. The main view is displayed to the right and three auxiliary 
views are displayed to the left:

 

RI = Right View

TP = Top View

FR = Front View

ISO = Isometric View

 

 
●     Main view on top

 



 
In this configuration, the viewer is divided into two parts. The main view is displayed on top and three auxiliary views 
are displayed at the bottom:

 

RI = Right View

TP = Top View

FR = Front View

ISO = Isometric View

 

 
In our example, we select "Main view to the right".

 
3.  Click Apply to apply the selected configuration to the current 3D viewer and keep the Views and Layout dialog box 

displayed:



 

 
As soon as you apply a configuration to the current viewer, the Create Multi-View  icon in the View toolbar 

changes to  to indicate that the multi-view mode is now active.

 
When you manipulate a viewpoint in one of the four views, the other three viewpoints are not modified and you can 
manipulate them independently:

 



 
4.  To set a view as the current view, simply click it in the View Selection area. In the example below, the isometric view 

has been set as the current view:

 

 

5.  Select one of the standard views displayed to the left to apply it to the current view: for instance, click the Back View 

 icon to set the Back View as the current view as shown below:

 

 
When you click Apply, the selected standard view is applied to the corresponding view you in the viewer.

Another way to apply a standard view in the viewer is to select in the viewer the view you want to modify (in that 
case, the compass is displayed in the top-right corner of the selected view) then select a standard view from the 
Quick View toolbar.
However, do not forget that if you do not also change the corresponding view in the View Selection area, the 
modification you made in the viewer will not be kept when clicking Apply.

 
The View Selection area also contains four rotation arrows (such as ) enabling you to change the orientation of 
the current base view: one click on an arrow rotates the base view by 90 degrees in the arrow's direction.

 6.  Click the  arrow repeatedly and check the result in the View Selection area. Below is an example with starting 

position displayed to the left:



 

 
Note that if the current view is an isometric view, the rotation step will be 60 degrees and not 90 degrees:

 

 
You also have the ability to use the four view selectors (such as ) to change the view direction by predetermined 
increments.

 
7.  Click the  arrow repeatedly and check the result in the View Selection area. Below is an example with a Back View as 

the current view and the starting position displayed to the left:

 

 

●     If the current view is not an isometric view:
❍     clicking the left or right selector makes the view's horizontal axis change by a predetermined increment. If 

you click a selector then the opposite afterwards, the view direction is reversed

❍     clicking the up or down selector makes the view's vertical axis change by a predetermined increment. If you 
click a selector then the opposite afterwards, the view direction is reversed

●     If the current view is an isometric view: clicking one of the four selectors makes the view direction change to one 
of the eight possible isometric views by predetermined increments. 
Note that the view direction for an isometric view is always the direction from the eye point (= the location of the 
viewer's eye within the 3D scene) to the axis origin.
The picture below illustrates the eight eye points for the different isometric views:



 

Therefore the result will be as follows when clicking the  arrow repeatedly for an isometric view:

 

 

8.  Activate the lock options (+ click Apply) if needed:

●     Rotation Lock locks the rotation in the view you select (i.e. the current view)

●     Translation Lock locks the translation in the view you select (i.e. the current view).

 
Note: Rotation/Translation Lock and Viewpoint Synchronization cannot be activated simultaneously. Activating 
Rotation Lock or Translation Lock automatically deactivates Viewpoint Synchronization, and inversely.

 

9.  Activate the Viewpoint Synchronization option then click Apply if you want the other three viewpoints to be modified 

simultaneously when you manipulate one of them.

In the example below, the main viewpoint has been modified and the three others have been updated accordingly:



 

 

10.  When satisfied with your configuration, click OK (or Apply then OK) to validate and close the Views and Layout dialog 

box.

Note that when you reselect the View->Navigation Mode-> Multi-View Customization... command, the Views 

and Layout dialog box the last used tab is activated with the last applied configuration.

 To go back to the standard viewer, just click the Create Multi-View  icon from the View toolbar.



Creating a Multi-View: Standard View Customization

 

 

The multi-view mode is a brand new capability allowing you to customize the default standard views within a 3D viewer.
This customization is defined in the Standard Views tab of the Views and Layout dialog box.

 For detailed information on the other tabs provided in this dialog box, refer to Creating a Multi-View: Manual Configuration and 
Creating a Multi-View: Automatic Configuration.

 
What you should know before you start

In order to take full advantage of this scenario, you need to be familiar with the basic vocabulary:

●     "Viewer" is the screen area in which 3D objects are drawn

●     "View" is a part of the viewer. Usually, the viewer has one single view but it can also be divided into 4 parts representing a 
different view each. When a viewer is split into several views, it is identified as a "multi-view" viewer

●     "Viewpoint" is the set of parameters required for defining a 3D view volume, i.e. the eye of the user, the view direction, the 
focus point and the axis system defining the position of the user. It can be defined as the position in model coordinates at 
which the eye is looking.

Bear in mind that the configuration remains active throughout the whole Version 5 session but it is not saved when using the 
Save As... command. For instance, if you apply a specific configuration then save and close your document before reopening it, 
this document will be displayed using the last active view before the save.

However, the view direction and orientation you define in this tab are stored in the CATSettings directory and therefore, you can 

reuse your customization from one session to another by clicking the Create Multi-View  icon. If no customization has 
been defined for a standard view, the default standard view is applied.

Open the Views.CATProduct document.

 
1.  Select the View->Navigation Mode-> Multi-View Customization... command to open the Views and Layout dialog 

box then select the Standard Views tab:
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Note that you can also access the Standard Views tab by selecting the View->Named Views... command then 

choosing a view from the list before clicking the Properties button.

This dialog box is made up of six areas:

●     Standard Views icons let you select the standard view to be customized

●     View Selection lets you modify the direction and orientation of the selected standard view

●     View Direction lets you manipulate the viewpoint

●     Apply to axis lets you specify the axis to which the modification will be applied

●     Reset All lets you restore all the standard views to their original default direction and orientation

●     Confirmation: lets you validate or cancel the configuration.

 

2.  Select a standard view to customize by clicking one of the icons displayed to the left. By default, the Front View is 

selected. In our example, we click the Back View  icon.

When a standard view is selected, the preview displayed in the View Selection area is updated:



 
The standard views displayed in this dialog box are identical to those available in the Quick View toolbar:

 

Isometric View

Front View

Back View

Left View

Right View

Top View

Bottom View

 3.  Click Apply then OK to apply the Back View to the current viewer:

 

file:///E|/www/ajtCXR14/Doc/online/basug_C2/basugbt1801.htm#hj-Quick View toolbar


 
4.  Re-select the View->Navigation Mode-> Multi-View Customization... command to re-open the Views and Layout 

dialog box: the Back View icon is still selected and we can now start customizing it.

 

5.  Use the four translation arrows (such as ) to shift the selected standard view by 90 degrees in the arrow's direction.

Below is an example of the result you can obtain when clicking repeatedly the  arrow with the Back View as the 

selected view and starting position displayed to the left:

 

 

Note that if the current standard view is an isometric view, the isometric view's direction changes to one of the eight 
possible isometric views using predetermined increments.

Below is an example using repeatedly the  arrow with starting position displayed to the left:

 

 

6.  Use the four rotation arrows (such as ) to change the orientation of the current view: one click on an arrow rotates 

the view by 90 degrees in the arrow's direction.

Below is an example using repeatedly the  arrow with starting position displayed to the left:



 

 
Note that if the current standard view is an isometric view, the view will be rotated by 60 degrees:

 

7.  Use the three fields displayed in the View Direction area to change the direction of the current view.

This area indicates the direction of the selected standard view along the X, Y and Z axis (as shown below):

 

 

To change the direction, you can enter one of these three values in the desired field: -1, 0 or 1 before clicking Apply.
Note that if the selected view is not an isometric view, you can enter a value only in one of the tree fields: as soon as 
a value is entered in a field, the other two are automatically filled with the value "0". On the contrary, if the selected 
view is an isometric view, you can enter a value in the three fields.

If you enter a positive value other than "1", it will be changed to "1" and if you enter a negative value other than "-
1", it will be changed to "-1".
For instance, entering "-1" instead of "1" in the first field to the left  will invert the view direction along the X axis:



 

8.  Use the Apply to axis area to position the selected standard view according to the local axis or to the axis you select:

●     when "Use local axis" is displayed, it means that the standard view will be positioned according to the active (i.e. 

current) local axis. If no local axis is active, the standard view will be positioned according to the global axis 

system displayed in the bottom right corner of the screen.

To set an axis as current, just right-click it in the specification tree or in the geometry area then select the xxx 

object->Set As Current contextual command.

●     checking the Select axis option lets you position the standard view according to a specific axis: to select the axis 

to be used, first select the text "No Selection" then click the axis to be used in the geometry area. The name of 

the selected axis will be displayed in the Select axis field:

 

 

The directions of the selected axis will be saved in the CATSettings directory and will be applied to the standard view. 

Note that the Select axis option remains activated even if you select another standard view. Therefore, do not forget 
to deactivate the option if you want to use the local axis.

 

In case your current axis sytem is left-handed, the standard views will be positioned according to the global axis 
system. 
For detailed information about defining a three-axis system locally, refer to Axis System. 

If you want to restore all the standard views to their original direction and orientation, click the Reset All button.

file:///E|/www/ajtCXR14/Doc/online/cfyugprt_C2/cfyugaxis_system.htm


 
9.  When satisfied with your configuration, click OK (or Apply then OK) to validate and close the Views and Layout dialog 

box.

 

10.  In the View toolbar, click the icon of the standard view you have just customized (Back View in our example).

The modified standard view is applied to the current viewer and you see that the result is totally different from the 

one in step 3 where the original standard Back View has been applied:

 



Advanced Tasks
Scene Definition
Scene Tuning

Catalog Browsing
Interoperability with V4 Scene Elements

Working with ENOVIA LCA: Optimal CATIA PLM Usability 



Scene Definition
 

Defining a Scene
Animating Scene Elements in a Simulation 



Defining a Scene 
 

 

This task gives you a quick methodology to define the parameters involved in the scene creation, i.e. light 
sources, camera, textures and describe their spatial arrangement in a three-dimensional world.

Open the RED-CAR.CATProduct document. 

Select the Shading with Material icon from the View toolbar. 

 
1.  Create an empty environment (either box, cylindrical or spherical).

2.  Choose the point of view you want to use then click the Create Camera icon . 

3.  Click the Create Spot Light icon  to define a conical light source then orientate the light as 

you wish with the help of the light preview on the environment walls.  

4.  Select the Light View command from the specification tree to make sure you have the desired 

illumination. This command lets you see the light point of view. Only the lit elements contained in 

the light preview shape will be lit at rendering time.

Set the lighting attenuation in order that it does not end before the environment, otherwise the 
environment will be almost entirely shadowed.

5.  Click the Quick Render icon  to make a quick render from the light view. Perform as many 

modifications as necessary and check that what you get is really what you want to lit.

6.  Click the Camera item in the specification tree then select the Camera View command from the 

contextual menu.

You can then perform changes and make quick renders to adjust the frameset to your needs.

http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/samples/RED-CAR.CATProduct


7.  Apply a texture on your environment and your part(s) by clicking the Apply Material icon  

and check the result by creating a quick render.  

Once you are satisfied, you can create a shooting to have a finer result. To do so:

8.  Click the Create Shooting icon  to define the shooting parameters.

We advise you not to modify the default shooting parameters except those concerning 
accuracy. When the accuracy parameters is set beneath the mid value, you should obtain a 
result nearly as identical as the quick render.

9.  Select a material in the specification tree then choose the Properties command from the 

contextual menu to adjust the material parameters.

10.  Click the Render Shooting icon  to check the result then go back to the material Properties 

to correct the parameter definition if necessary.



Here are a few tips for lighting parameters:

●     Ambient: use very carefully the Ambient parameter ("good" values are around 10%) to 
avoid final color saturation

●     Diffuse: start by setting the Diffuse parameter to the minimum intensity: when you define 
the material lighting, the sum of all parameters (except Shininess) should be roughly equal 
to 1 to render the material with realism, but nothing forbids you to choose higher or lower 
sum values to achieve special effects: they may simply be harder to control

●     Reflectivity/Specular: set the Reflectivity and the Specular parameters simultaneously 

●     Transparency: if the material is transparent, define a Transparency value. 
We recommend you to define this parameter at the end.

11.  When the result is satisfactory, adjust the shooting parameters to refine the result such as the 

reflection number, the anti-aliasing, etc. in the Shooting Definition dialog box.

12.  Click OK when you have finished. 

The scene is defined and ready to be rendered.



Animating Scene Elements in a Simulation  

 

This task shows you how to animate the various elements composing the scene, i.e. cameras, lights, 
environments and materials. 

The Light 1 object will be taken as a simulation example to illustrate this task but bear in mind that the 
method is identical whether you animate a camera, a light, an environment or a material.

 
Open the Shooting.CATProduct document.

 
1.  Click the Simulation  icon. The Select dialog box opens:

2.  Select the object to be animated then click OK to validate. 

The Edit Simulation dialog box appears:

http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/samples/Shooting.CATProduct


 

If you first select the element to be animated in the specification tree, then click the Simulation 
icon afterwards, the Select dialog will not be displayed.

As you can see it below, running the Simulation command snaps the compass to the element to 
be animated, enabling you to manipulate it very easily:



3.  Click the Insert button to record the starting shot.

4.  Modify the lighting orientation using the 3D compass.

5.  Click the Insert button to record the desired keyframe and insert it into your simulation scenario. 

As you insert your first keyframe, the dialog box buttons are activated to let you Modify, Delete or 

Skip the recorded shots.

The initial position is automatically recorded. If you need to reposition your object, just delete its 
first position or modify it.

 
6.  Select the interpolation which defines the number of steps between the shots you have recorded.

 

The lower the number, the slower the replay speed.

Note: the interpolation is used for preview only and does not affect the rendered animation. 

 
7.  Use the other VCR buttons to play backward, step forward, modify the speed, etc.

 

8.  Click the Play Forward button  to preview the animation.



You can also use one of the loop modes to:

 run the simulation once

 run the simulation in a continuous way

 run then reverse the simulation in a continuous way.

 
Note that you can press the Edit analysis button at any time to open the Edit Analysis in Simulation 
dialog box which lets you edit the interferences you may have previously defined. In case no 
interference has been defined, the dialog box is empty.

9.  Click the Edit simulation objects button to edit objects included in your simulation.

10.  Select the simulation object to edit from the proposed list then click the Edit... button to open the 

Properties dialog box:



11.  Modify the object parameters as desired then click the OK button twice to close the Properties and 

Edit Simulation Objects dialog boxes. 

If you wish to animate more elements in your simulation, click the Add... button. This opens the 
Select dialog box and enables you to select additional objects:



12.  Modify the parameters and the object position to change the viewpoint as often as necessary, clicking 

the Insert button to record each of the desired shot. 

 

13.  Replay your simulation with the "Animate viewpoint" option checked: 

 

The simulation is replayed and shows the viewpoint changes you recorded. Click the picture below 
to run the simulation:

 

 

Note: this option can be activated whenever you want, either before recording the simulation or 
after.

You can activate the "Automatic insert" at any time. This option records the shots automatically as 
you move the object as often as necessary.

http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/images/carsimulation.gif


14.  Click OK to save your simulation.

Your simulation is identified in the specification tree along with the simulation path displayed in the 
geometry area:

   

Whenever you wish to modify the simulation, just double-click its path or its name in the 
specification tree to re-open the Edit Simulation dialog box.

Note: you can also record a fitting track using lights and environments. For detailed information 
on tracks, refer to Using Tracks in the Version 5 - DMU Fitting Simulation documentation.

 



Scene Tuning
 

Tuning Light Sources for Rendering
Tuning Materials for Rendering 



Tuning Light Sources for Rendering 
 

 
This task gives you some tips to help you tuning the light source parameters when rendering a scene.

Open the TuningLightsStart.CATProduct document. 

Select the Shading with Material icon from the View toolbar. Select also the perspective view from the 
View->Render Style menu.

1.  Create a Quick Render .

 

 

Step 1 - No light source 

In our example, we aim at creating a light source that matches the lighting of the environment 
pictures, i.e. the sun light.

2.  Create a Directional Light  then a Quick Render to check the result.

http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/samples/TuningLightsStart.CATProduct


Step 2 - One directional light source

 As you can see it above, the result is better but still not realistic enough. 

Note: if there is not shadow cast on the pavement, edit the Bottom wall properties then check 

the Shadows "On" option under the Lighting tab. 

3.  Modify the light orientation using the green manipulators so that the red car shadow matches the 

shadows of the cars parked behind. For our example, a correct position would be:

●     origin in top rear left

●     target in bottom front right

Changing the viewpoint may be helpful to position the light (for example you can use the Top or 
Left view).

4.  Double-click the camera to go back to the original viewpoint then create a Quick Render.



When using spot or point lights, pay attention to the lighting end in order to make sure that the 

light cone includes the object and thus, correctly illuminates it. Otherwise, the object will be too 

dark.

For more information on light sources, refer to Defining a Light Source in this guide.

5.  For a more realistic lighting, you may need to create soften shadows.

To do so, simply duplicate the original light (Copy->Paste), slightly modify the orientation of the 

new lights then decrease the intensity (only one light cast shadows) as shown in step 6:

6.  Access the Lighting parameters in the Properties dialog box to soften the light and give it a faint 

yellow color.

  

Intensity parameters: Red= 173, Green= 173, Blue= 167 



Do not forget to check the "Ray Traced" option to activate shadows.

7.  Edit the Lighting parameters of the duplicated light (intensity parameters: R=G=B= 80) then check 

the Shadows option "off" before creating a quick render.

You can use the Stop icon to interrupt the process as soon as an unsatisfactory result is detected.

When using a spot or point light, changing the Attenuation may also make the lighting more 
realistic.

 
8.  When satisfied, Create a Shooting then Render it to check the result:

 

Shooting rendered from current viewpoint 



Shooting rendered from camera viewpoint

Bear in mind that the more light sources, the more difficult the tuning of the global illumination of 
the scene.

For more information on shooting creation, refer to Setting Image Quality Parameters in this 

guide. 



Tuning Materials for Rendering 

 
This task gives you some tips to help you tuning the material parameters when rendering a scene.

Open the TuningMaterialsStart.CATProduct document. 

Select the Shading with Material icon from the View toolbar. Select also the perspective view from the View-
>Render Style menu.

1.  Create a quick render to detect the material parameters which need to be modified:

 

Specular and Reflectivity parameters set to 0  

2.  Access the Rendering parameters in the Properties dialog box. 

We will start by modifying the Red Paint color and lighting so that the material looks like having the 

iridescent and reflective properties of the metal:

http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/samples/TuningMaterialsStart.CATProduct


 

 

The paint color was assigned the following values:

Red=182

Green=6

Blue=24



 
Note that you can click the Ray Traced Preview  icon anytime to display a rendered image of 
the material in the Properties window. When you want to deactivate this mode, just click the icon 
once again.

Play with the Diffuse coefficient to adjust more precisely the material lighting. 

Do not forget that Specular coefficient tunes the intensity of light coming directly from the light 
source, whereas Reflectivity coefficient defines the amount of reflected light coming from other 
objects (indirect light).

3.  Click OK to validate before creating a quick render:

4.  Access the Glass lighting parameters in the Properties dialog box . As for Red Paint, the glass should be 

reflective and shiny:

 



The glass color was assigned the following values:

Red=30

Green=30

Blue=30

5.  Click OK to validate then create a quick render.



Note: if you want the red car lighting to be similar to the one of the other cars (in background), 
thus being as close as possible to reality, just set the Luminosity value to 0.75. 
The quick render result will be:

We suggest that you create a quick render after each parameter modification to check the impact on 
the material.

6.  Now let`s deal with the tyre color and access the Rubber material properties. The following values have 

been applied:

 



The rubber color was assigned the following values:

Red=61

Green=61

Blue=61

7.  When satisfied, validate your parameters then click the Render Shooting icon to check the final result:



 Shooting rendered from current viewpoint

 Shooting rendered from camera viewpoint

For more information on shooting, refer to Setting Image Quality Parameters in this guide.



Catalog Browsing
 

Browsing the Scene Catalog 



Browsing the Scene Catalog 

 

In this task you will learn how to browse the Scene catalog and instantiate its components.  

Would you need further information about catalogs (creation, preview, query, and so on), please refer to the Version 
5 - Component Catalog Editor User's Guide.

This default catalog is located under: 

downloaddirectory/OS/startup/components/Rendering/Scene.catalog

where OS is the operating system, for example intel_a (on Windows).

Open the RED-CAR.CATProduct document.

 1.  Open the Catalog browser dialog box by clicking the Catalog Browser  icon. The Scene catalog opens:

2.  Double-click a family from the list to display its components.

3.  Click the selected component to see its preview as shown below:

http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/samples/RED-CAR.CATProduct


4.  Click the Table>> button to show/hide the catalog descriptions and keywords. By default, the table is 

hidden. 

 Note: as far as Shootings are concerned, many informations are provided in the Table such as Name, Width 
and Height of the computed image, Texture, Shadows, etc.



 No component is provided by default. You have to create the components to be taken into account for the 
shooting or drag and drop existing elements to include them in the catalog.

The  button lets you perform a query using a filter.

The  button lets you perform a query on multiple levels in your catalog. 

For detailed information on these two capabilities, refer to the "Making a Smart Query in a Catalog" in the 
Version 5 - Component Catalog Editor User's Guide.

5.  Instantiate the desired element by double-clicking it. 

Then you just have to adapt the instantiated element to your product. In the example below, the environment 

dimensions have been slightly modified so that the scene looks more realistic:



Picture 1 - Desert scene instantiation

Picture 2 - Quick render of Desert scene

You can also Copy->Paste or drag and drop the element directly onto the product in the specification tree.



Interoperability with V4 Scene Elements 
 

 
This task shows you how to convert V4 scene elements (environments, cameras, lights and turntables) into V5 scene elements.

A V4I license is required to copy V4 scene elements.

Open the V4TEAPOT_AND_CAT.model document.

 
1.  Double-click "MASTER" to display the tree.

2.  Click the plus sign beside "IMDE2" to display the scene elements.

3.  Select the element you wish to copy. If you want to copy several elements, you can use the multiselection:

http://canly1dsy/ajtCXR14/Doc/online/phsug_C2/samples/V4TEAPOT_AND_CAT.model


4.  Copy the element(s) by selecting Edit -> Copy in the menu bar or by right-clicking and selecting Copy in the contextual menu

5.  Open a product, for example, using the Start -> Infrastructure -> Photo Studio menu. 

6.  Activate the root product or an already existing node then paste the new elements by selecting the Edit->Paste command or by 

right-clicking the Paste contextual menu. In our example, the copied elements are pasted in "Product2" window:

Note: You may have to zoom out successively to see entirely the environment.



As you can see it in the above pictures, the copied scene elements keep the same names as well as their parameter values in 
most cases. For instance, a V4 spot light is converted to a spot light in V5 with the same angle, intensity, attenuation angle ratio, 
etc.
However, there are slight discrepancies since V4 and V5 scene elements are not fully equivalent:

●     Lights: V4 target is different from V5 target (which is computed with the target point and the attenuation end)

●     Cameras: V5 cameras do not have any width and height as this is the case for V4 cameras

●     Environments: 3D textures applied onto V4 environment walls are not converted. Environments converted from V4 to V5 are 
always "bare"
Moreover, as far as spherical environments are concerned, they are always converted to big size environments because V4 
spherical environments are sizeless

●     Turntables: a turntable is always pasted with the V4 environment it is associated with since V4 turntables cannot be created 
on their own like in V5. In our example, you can see that Turntable 1 is associated with V4 Transparent Cubic Environment.
Note also that the angle of a converted turntable is always equal to 360 degrees, whichever value in V4.

 



Working with ENOVIA LCA: Optimal CATIA PLM 
Usability

 

When working with ENOVIA LCA, the safe save mode prevents the user from creating or editing data 
in CATIA that cannot be correctly saved in ENOVIA LCA.
Working in this mode means that certain commands are unavailable (i.e. grayed) as you enter the Photo 
Studio workbench.

ENOVIA LCA offers two different storage modes: Workpackage (Document kept - Publications Exposed) and 
Explode (Document not kept).

Below are listed the commands along with their accessibility status in Explode mode and, in some cases, 
the rules that are applied to the restricted commands.

 
Command Accessibility in LCA 

(Explode mode)
Warning/Comment

Apply Material YES (restricted use) Materials with textures are stored without the 
associated texture image.
Materials applied onto products are not saved 
when closing the session.

Edit material properties YES (restricted use) Materials with textures are stored without the 
associated texture image.
Materials applied onto products are not saved 
when closing the session.

Create Spot Light YES (restricted use) Spot light sources can be created and saved 
only when working with the DMU Review

Create Point Light YES (restricted use) Point light sources can be created and saved 
only when working with the DMU Review

Create Directional Light YES (restricted use) Directional light sources can be created and 
saved only when working with the DMU Review

Edit light properties YES (restricted use) Modifications applied to light sources can be 
saved only when working with the DMU Review

Create Camera YES (restricted use) Cameras can be created and saved only when 
working with the DMU Review



Edit camera properties YES (restricted use) Modification applied to cameras can be saved 
only when working with the DMU Review

Create Box Environment YES (restricted use) Box environments can be created and saved 
only when working with the DMU Review

Create Sphere Environment YES (restricted use) Sphere environments can be created and 
saved only when working with the DMU Review

Create Cylinder Environment YES (restricted use) Cylinder environments can be created and 
saved only when working with the DMU Review

Edit environment properties YES (restricted use) Modifications applied to environments can be 
saved only when working with the DMU Review

Apply Sticker YES (restricted use) Stickers are not saved when closing the 
session

Edit sticker properties YES (restricted use) Modifications applied to stickers are not saved 
when closing the session

Create Shooting YES (restricted use) Shootings can be created and saved only when 
working with the DMU Review

Render Shooting YES (restricted use) Shootings can be created and saved only when 
working with the DMU Review

Shooting object->Definition YES (restricted use) Modifications applied to the shooting definition 
can be saved only when working with the DMU 
Review

Redo Render YES (restricted use) Shootings can be created and saved only when 
working with the DMU Review

Quick Render YES  

Simulation NO (grayed out)
 

Create Turntable NO (grayed out)
 

When working in Workpackage mode (Document kept - Publications Exposed), all the above-mentioned 
commands are available.



Saving Photo Studio Objects in ENOVIA LCA 
Using the DMU Review

When working with ENOVIA LCA, a new working method dealing with the DMU Review enables you to 
create and save Photo Studio objects in ENOVIA LCA when working in Explode (Structure Exposed - 
Document not kept) or Workpackage (Document kept - Publications Exposed) mode.

The DMU Review can be seen as folder in which applicative data can be organized. The DMU Review is 
linked to a product structure and only has meaning in the context of that product structure. It can 
contain:

●     a hierarchy of Reviews 

●     applicative data at any level of the Review hierarchy.

For detailed information on the DMU Review, refer to "About DMU Review" in the Version 5 - DMU 
Navigator User's Guide.

This working method is relevant for the following objects:

●     cameras

●     environments (box, sphere and cylinder)

●     light sources (spot, point and directional)

●     shootings.

In our scenario, we will use the camera as an example but the same method can be used for 
environments and light sources.

To ensure seamless integration, you must have both a CATIA and ENOVIA session running.

1.  In the Product Structure workbench of CATIA V5, click the Connect to Enovia LCA  icon to 

establish the connection between CATIA V5 and ENOVIA LCA.

 

2.  In ENOVIA LCA, send your document to CATIA. For detailed information, refer to "Sending an 

ENOVIA LCA Document into CATIA V5" in the Version 5 - ENOVIA/CATIA Interoperability User's 

Guide.



3.  In CATIA V5, access the DMU Navigator workbench then click the Create Review  icon: a 

review is created and identified in the specification tree as "DMU Review.n" (if this is the first 

review you create, the review will be named "DMU Review.1"):

 

 
Note that if no DMU Review is activated, the DMU Review will be created at the product root 
level.

 

4.  Double-click the DMU Review you have just created to activate it: the Review will now be 

activated, which you can verify by right-clicking it and noticing the checkmark next to the Review 

Activated status.

The symbol identifying the DMU Review in the tree is also updated as shown below:

 

 

5.  Access the Photo Studio workbench then click the Create Camera icon to create a camera.

The camera is created in the DMU Review:

 



 6.  Define the camera properties. For detailed information, refer to Creating a Camera.

 

7.  Access the Product Structure workbench again then click the Save Data in ENOVIA V5 Server 

 icon to save your CATIA V5 data in ENOVIA.

For detailed information, refer to "Saving an ENOVIA LCA Document from CATIA V5" in the 

Version 5 - ENOVIA/CATIA Interoperability User's Guide.



Workbench Description

The Photo Studio Version 5 application window looks like this: 

Click the hotspots to see the related documentation.

 

Menu Bar
Scene Editor Toolbar
Animation Toolbar

Render Toolbar
Apply Material Toolbar

Viewpoint Toolbar
Light Commands Toolbar

Camera Commands Toolbar
Quick Reference Card 



Menu Bar 
 

This section presents the menu bar tools and commands dedicated to the Photo Studio workbench.

Many other operations are documented in the Version 5 Infrastructure User`s Guide.

Start File Edit View Insert Tools Windows Help

 

Start
The Start menu is a navigation tool intended to help you toggle between different workshops. The contents of the Start menu vary according to 
the configurations and/or products installed.

For... See...

Infrastructure->Photo Studio Entering the Photo Studio workbench 

For more information about the Start menu, refer to the 
Infrastructure documentation.

  

  

  

 

 

File
The File menu lets you perform file creation, opening, saving and printing operations. Refer to the Infrastructure documentation.

 

Edit
The Edit menu lets you manipulate selected objects. Please refer to the Infrastructure documentation.

http://canly1dsy/ajtCXR14/Doc/online/basug_C2/basugbt0302.htm
http://canly1dsy/ajtCXR14/Doc/online/basug_C2/basugwd0100.htm
http://canly1dsy/ajtCXR14/Doc/online/basug_C2/basugwd0100.htm


 

View
The View menu lets you view document contents. Please refer to the Infrastructure documentation.

View - >Toolbars

For... See...

  

  

  

  

Animation Animation Toolbar

Apply 
Material

Apply Material Toolbar

Render Render Toolbar

Scene 
Editor

Scene Editor

  

  

 

Scene Editor Toolbar

For... See...

Create Box Environment Creating an Environment

Create Spot Light Defining the Light Parameters

Create Camera Creating a Camera from a Viewpoint

Animation Toolbar

For... See...

Create Turntable Creating a Turntable

Simulation Previewing and Rendering a Turntable and Animating Scene Elements in a Simulation

Apply Material Toolbar

For... See...

Apply Material Defining the Wallpaper + Refer to the Real Time Rendering documentation

Apply Sticker Stickers

http://canly1dsy/ajtCXR14/Doc/online/basug_C2/basugwd0100.htm


Catalog Browser Browsing the Scene Catalog

Render Toolbar

For... See...

Create Shooting Defining Animation Parameters, Setting Image Quality Parameters

Render Shooting Previewing and Rendering a Turntable, Setting Image Quality Parameters

Quick Render Creating a Quick Render

 

Insert

For... See...

  

  

  

  

  

Existing 
Component...

Loading Products

  

Tools
The Tools menu lets you perform image capture and album management, set user preferences and manage macros. lease refer to the 
Infrastructure documentation.

 

Window
The Window menu lets you arrange document windows in relation one to the other. Please refer to the Infrastructure documentation.

 

Help
The Help menu lets you get help on the currently active command and the product in general. Please refer to the Infrastructure documentation.

http://canly1dsy/ajtCXR14/Doc/online/basug_C2/basugwd0100.htm
http://canly1dsy/ajtCXR14/Doc/online/basug_C2/basugwd0100.htm
http://canly1dsy/ajtCXR14/Doc/online/basug_C2/basugwd0100.htm


Scene Editor Toolbar 
This toolbar contains the following tools for creating and managing scene elements:

See Creating an Environment

See Creating an Environment

See Creating an Environment

See Importing an Environment

See Defining a Light Source

See Defining a Light Source

See Defining a Light Source

See Defining a Surfacic Light Source

See Defining a Surfacic Light Source

See Defining a Surfacic Light Source

See Defining a Surfacic Light Source

See Creating a Camera from a Viewpoint



Animation Toolbar 
This toolbar contains the following tools for creating turntables and animating scene elements:

See Creating a Turntable

See Previewing and Rendering a Turntable and Animating Scene Elements in a Simulation



Render Toolbar 
This toolbar contains the following tools for creating shootings and renderings. 

See Defining Animation Parameters, Setting Image Quality Parameters

See Previewing and Rendering a Turntable, Setting Image Quality Parameters

See Setting Image Quality Parameters

See Creating a Quick Render



Apply Material Toolbar 
This toolbar contains the following tools for applying materials and stickers as well as browsing material catalogs. 

See Applying a Material in the Version 5 - Real Time Rendering User`s Guide.

See Applying Stickers

See Browsing the Scene Catalog

http://canly1dsy/ajtCXR14/Doc/online/cfyugrendering_C2/cfyugapplymaterial.htm


Viewpoint Toolbar 
This toolbar contains the following tools for adjusting your viewpoint. 

See Looking At Objects in the Version 5 - DMU Navigator User`s Guide

See Defining a Light Source

See Defining a Light Source

See Magnifying in the Version 5 - DMU Navigator User`s Guide



Light Commands Toolbar 
This toolbar contains the following tools for manipulting and adjusting light sources:

See Using the Light Commands Toolbar

See Using the Light Commands Toolbar

See Using the Light Commands Toolbar

See Using the Light Commands Toolbar

See Using the Light Commands Toolbar

See Using the Light Commands Toolbar

See Using the Light Commands Toolbar



Camera Commands Toolbar 
This toolbar contains the following tools for adjusting your cameras:

See Using the Camera Commands Toolbar     

See Using the Camera Commands Toolbar

See Using the Camera Commands Toolbar



Quick Reference Card

Scene Editor

Environments  Scenario

 Click the icon to create an environment with a rectangular shape.

 Click the icon to create an environment with a spherical shape.

 Click the icon to create an environment with a cylindrical shape.

Click the icon then select the .cam file to import to generate the environment.Scenario

Light Sources  Scenario

Click the icon to create a light source with a conical shape.

Click the icon to create a light source emitting light in all directions.

    
Click the icon to create a light source generating constant intensity parallel lighting.

Surfacic Light Sources  Scenario

Click the icon to create a surfacic light source with a rectangular shape.

Click the icon to create a surfacic light source with a disk shape.

Click the icon to create a surfacic light source with a spherical shape.

Click the icon to create a surfacic light source with a cylindrical shape.

Camera  Scenario

    
Click the icon to create a camera at the current viewpoint.

Animation

Create a Turntable  Scenario

 Click to create the turntable, then position it along the x, y and z axes.

Create a Simulation  Scenario

 Select the object to be animated then click the icon to define the animation. 



or Click the icon, choose the object to be animated from the Select dialog box then define the animation.

Render

Create a Shooting  Scenario

 Click the icon then specify the elements to be rendered, the rendering style and quality parameters.

Render a Shooting  Scenario

 Click this icon then choose whether you want to render an animation or a single frame.

or In the specification tree, select the desired shooting then click the Render Animation or the Render Single Frame 
contextual command.

Redo a Render  

Click the icon to redo the last render performed.

Create a Quick Render  

Click the icon to generate very quickly a rendered image of your product.

Light Commands

Using the Light Commands Toolbar  Scenario

 Select a light source from the pulldown list then click the icon to deactivate the light source.

 Select a light source from the pulldown list then click the icon to activate the light source.

Click the icon to display the light source viewpoint.

Click the icon to adjust (i.e. center) the light source when the viewpoint is modified.

Click the icon to attach the active light source to the viewpoint.

Click the icon to attach the active light source to the model.

Click the icon to position the light source along a perpendicular to the point you click on the object in the geometry 
area.

Click the icon then the object in the geometry to position the specular spot.



Using the Camera Commands Toolbar  Scenario

 Select a camera from the pulldown list then click the icon to display the camera viewpoint in a new window.

Click the icon to switch from the camera window to the standard window.

 Select a camera from the pulldown list then click the icon to update the camera when the viewpoint is modified.

 Select a perspective camera from the pulldown list, click the icon then manipulate the camera to define the focal 
length.

Apply Material

Apply a Material  Scenario

 Select the element onto which the material should be applied then click the icon and choose a material from the 
Library.

Apply a Sticker  Scenario

Click the icon then select the Stick contextual command and choose the 3D location onto which the sticker should 
be applied.

Browse the Scene Catalog  Scenario

Click the icon to open the Scene catalog then double-click the selected elements to instantiate them.

or Click the icon to open the Scene catalog, copy then paste the selected element directly onto the product in the 
specification tree.

or Click the icon to open the Scene catalog, drag and drop the selected element directly onto the product in the 
specification tree.

 

Camera Commands



Customizing Photo Studio

Before you start your first working session, you can customize the way you work to suit your habits.
This type of customization is stored in permanent setting files: these settings will not be lost if you end your 
session.

1.  Select the Tools -> Options command.

The Options dialog box displays. 

2.  Choose the Infrastructure category in the left-hand box.

3.  Click the Photo Studio workbench.

The options for Photo Studio settings appear, organized in tab pages.

4.  Select the tab corresponding to the parameters to be customized:

❍     the Display tab lets you define the rendering display

❍     the General tab lets you define general settings for light sources

❍     the Output tab lets you define the rendering output

❍     the Satellites tab lets you define the remote computers used when distributing rendering. This tab is 

available only when using Photo Studio Optimizer

❍     the Sticker tab lets you define the sticker default image.

5.  Change these options according to your needs. 

6.  Click OK when done.



Display
 

 

 

This tab deals with the following categories of options:
●     active lights

●     inactive lights

●     inactive environments

●     light manipulator

 
Active Lights

 

 This area lets you control the display of active lights, whether they be standard or surfacic light sources.

Wireframe display

Displays the representation of the light source in wireframe mode:
 

   Spot light source:
   wireframe display

  By default, this option is activated.



  

 
Shaded display

Displays the representation of the light source in shading mode as shown below:
 

   Spot light source:
    shaded display

 
You can use the manipulators to interactively position the light source as you would do for the default 
wireframe representation.
This display helps you visualize more easily which part of the object will be illuminated as shown below:

 

    



 Note that the color of the shaded representation corresponds to the color defined for the light source (via 
the Lighting tab in the Properties dialog box). In the above example, the light intensity has been assigned 
a green color.

 By default, this option is cleared.

 

Inactive Lights

 

 
No display

Turns off inactive light display.

 By default, this option is activated.

 
Full display

Turns on inactive light display.

 By default, this option is cleared.

 

Inactive Environments

 

 
No display

Turns off the inactive environment display.

 By default, this option is activated.



 Simplified display

Displays inactive environments in a simplified way.

 By default, this option is cleared.

 
Full display

Turns on the inactive environment display.

 By default, this option is cleared.
 Note: dynamic reflections are no longer supported.

Light Manipulator

 

 
Show normal

This option is relevant only when the Position along Normal or Position Specular command is active. It 
allows you to display the normal of the surface when you move the mouse over the surface and therefore, 
helps you to position the light source.

To be able to use this option, you need to activate the light source (either by clicking the light symbol in 
the geometry area or by selecting the light in the Light Commands toolbar) then, move your mouse over 
the surface to see the normal:

 

 The option is 
activated

The option is not 
activated

 



 

  By default, this option is cleared.



General
 

 

 

This tab deals with the following categories of options: 
●     new light position

●     view mode

●     material display.

New Light Position

 

 This area lets you define how the new light sources you will create will be positioned. You can choose 
between three modes:

 Default mode

The light source will be positioned in the upper part of the geometry area, oriented down and centered:



 Spot light source - "Default" mode

 By default, this option is activated.

 As Viewpoint

The light source will be positioned according to the user's viewpoint:

 

Spot light source - "As viewpoint" mode

 By default, this option is cleared.



 
Gravitational

The light source will be positioned along the X, Y or Z axis of the model. The axis to be used is defined by 
checking the corresponding radio button next to "Gravitational":

 

Spot light source - "Gravitational" mode along Y axis

 By default, this option is cleared.

View Mode

 

 This area lets you define the view mode to be used by default when entering the Photo Studio workbench:

 

Parallel

If this option is selected, it means that when entering the Photo Studio Rendering workbench, your model 
will be displayed in a parallel view.

 By default, this option is cleared.



 

Perspective

If this option is selected, it means that when entering the Photo Studio workbench, your model will be 
displayed in a perspective view.

 By default, this option is cleared.

 

Last saved

If this option is selected, it means that when entering the Photo Studio workbench, each model you open 
will be displayed in the view (i.e. perspective or parallel) used to display the model at the time it was 
saved.
For instance, if you are working with a product in a perspective view then save it before closing the 
document, re-opening this product after activating the Last saved option will automatically display it in a 
perspective view.

Note: once your model has been saved, if your change the viewpoint afterwards then close the model 
without saving it again, this new viewpoint will not be used when activating the Last saved option.

 By default, this option is activated.

 
Material Display

 

 

View material

If this option is activated, it means that when entering the Photo Studio workbench, the visualization 
mode is automatically switched to "Shading with Material". 
The Shading with Material rendering style lets you display materials that have been applied onto your 
model.
Therefore, you do not need to select the View->Render Style->Shading with Material  command or 

click the Shading with Material  icon anymore.

  By default, this option is cleared.



Output 
  

 

 

This tab deals with the following categories of options:
●     quick render

●     save

Quick Render

 

 

Image Size
●     From active viewpoint: indicates that the image is defined from the active viewpoint

●     Fixed: lets you define the image width and height in pixels by entering the desired values in the field 
nex to "Fixed".

 By default, the "From active viewpoint" option is activated.

Output
●     On screen: indicates that the rendering output will be displayed on screen

●     On disk: indicates that the rendering output will be saved on a disk. You need to specify the new path 

and name of the image either by entering them directly in the field or by clicking the  icon to 
browse your folders to the desired location.

 By default, the "On screen" option is activated.



 

 

Increment name if file already exists

This option is used to add the suffix "_ number" to the name of the file if the file already exists. The 
number will be automatically incremented as necessary, e.g.  "CatiaRender_1.tif", "CatiaRender_2.tif", and 
so on.

 By default, this option is cleared.

  

Save



Satellites
  

 

This tab deals with one category of options: Distributed Rendering.
Distributed rendering enables to decrease rendering time since several processors are used to generate 
the image.
This category concerns the definition of the remote computers ("satellites") used in network to compute a 
rendered image.

 This tab is available only when using Photo Studio Optimizer.

 For detailed information on how to use this tab, refer to "Using Distributed Rendering" in the Version 5 
Photo Studio Optimizer User's Guide.



Stickers 
   

 

 

This tab deals with the following categories of options: 
●     default image

●     real time representation.

Default Image

 

This area lets you replace the default sticker image with your own image.  

Simply enter the path to the user-defined image or use the  icon to open the File Selection dialog box which 

lets you browse your folders to the desired location.

 
Real Time Representation

 If this option is selected, it means that when a sticker is applied, its representation is displayed in the geometry 
area:



 Example 1
The option is activated

Example 2
The option is not activated

 However, note that when you select the sticker in the specification tree, the sticker representation is displayed 
even if the Activate real time representation option is not activated.

 By default, this option is activated.



Glossary 

            

 

A
accuracy A parameter enabling to define the degree of precision of the rendering quality

ambient 
lighting

The intensity of light emitted by any light source

animation A rendering of successive positions of a product recorded in a simulation

anti-aliasing A graphic design technique that involves adding colored pixels to smooth the jagged edges 
of a graphic

attenuation The action of lessening illumination

  

C
camera A rectangular-shaped element with a lens used to specify the chosen viewpoint to take the 

image

cylinder area 
light

A surfacic light source with a cylinder shape used to simulate neons, for instance

  

D
diffuse lighting The intensity of light diffused by the object when lit by light sources

directional 
light

A light coming from a given direction (like the sun, for instance) generating constant 
intensity parallel lighting

disk area light A surfacic light source with a disk shape used to simulate spot lights

  



E
environment A geometrical element, either rectangular, cylindrical or spherical, used to simulate interior 

as well as exterior scenes

  

F
Final Gathering A method used to compute light energy on any surfaces surrounding an object in the scene. 

Synonym: "indirect illumination"

  

L
light source A source of light illuminating the object to be rendered

  

M
mapping A method used to apply an image onto an object in order this object acquires a surface 

texture

material An object that can be mapped onto a geometry to simulate visually and physically the 
components an object is made of (e.g. wood, stone, etc.)

  

P
part A 3D entity obtained by combining different features

photo-realistic An image with a quality quite similar to a real image or a picture

point light A punctual illumination (like a bulb, for instance) emitting light isotropically, i.e. in all 
directions

product  A 3D entity containing several components

property The attribute or characteristic of an object that defines its state, appearance or value



  

R
raytracing A photo-realistic image resulting from the calculation of the path of light reaching the 

product from various angles. Each pixel is created by calculating the behavior of a number 
of rays from these different points over the area covered by that pixel

rectangle area 
light

A surfacic light source with a rectangular shape used to simulate a rectangular spot light

reflection A light wave returned from a surface

reflectivity The ability to reflect light

refraction The degree of light passing obliquely through an object

rendering A photo-realistic drawing of three-dimensional objects

roughness The dullness of an object (it represents the size of the reflecting zone)

  

S
scene A reusable configuration enabling to put models on stage using cameras, light sources, 

environments, turntables

shooting A set of parameters used to define a rendering

specification 
tree

An area of the document window reserved for viewing the design specifcations of a part, 
presented in the form of a tree structure

specular 
lighting

The dullness of an object

sphere area 
light

A surfacic light source with a sphere shape used to simulate a light bulb, but in a softer and 
more realistic way than the point light does

spot light A light source emitting the light isotropically inside a cone of influence determined by the 
privileged direction of illumination (forming the axis of revolution) and the angle that the 
edge of the cone forms with this axis.

sticker An image that can be mapped onto a face of a product

surfacic light 
source

A source of light similar to ordinary light sources and designed to create a soft, and thus 
more realistic, lighting. Compare light source

  

T



texture An image that can be mapped onto a geometry

transparency The degree of transparency of an object. The object transparency defines its property of 
transmitting light so that elements lying beyond are seen

turntable A revolvable platform enabling to generate a sequence of images representing the model 
rotation around a user-defined axis

  

 



Index 

                    

A
accuracy  
adjustment 

sticker  
ambient 

lighting  

Animate viewpoint option  
animation 

format  

parameters  

replay  

scene  

Animation toolbar  

anti-aliasing  

Apply Material command   

Apply Material toolbar  

Apply Sticker command  
applying 

sticker  

B
background color  
box 

environment  
browse 

catalog  



C
camera 

conical  

cylindrical  

focal length  

Knowledgeware integration  

lens  

manipulate  

properties  

view  

Camera Commands toolbar  

Camera View command  

Camera Window command   
catalog 

browse  

description  

keyword  

scene  
color 

intensity  

sticker  
command 

Apply Material   

Apply Sticker  

Camera View  

Camera Window   

Catalog Browser   

Create Box Environment  

Create Camera   

Create Command  

Create Cylinder Area Light  

Create Cylinder Environment  

Create Directional Light  



Create Disk Area Light, Create Disk Area Light command  

Create Point Light  

Create Rectangle Area Light  

Create Shooting      

Create Sphere Area Light  

Create Sphere Environment  

Create Spot Light  

Create Spotlight  

Create Turntable  

Edit Light Direction  

Edit Light Parameters  

Fit All In  

Formula  

Free Rotation  

Import an Environment  

Insert Existing Components  

Light View  

Lock Manipulator  

Manipulate Focal  

Next View   

Position along Normal  

Position Direction  

Position Specular  

Previous View   

Properties         

Quick Render     

Redo Render  

Render Animation  

Render Shooting      

Rotate around X  

Rotate around Y  

Rotate around Z  



Save Light Direction  

Simulation   

Toggle Light Attachment  

Turn Light On/Off  

Update from View   

compass  
conical 

camera  

Create Box Environment command  

Create Camera command    

Create Cylinder Area Light command  

Create Cylinder Environment command  

Create Directional Light command  

Create Point Light command  

Create Rectangle Area Light command  

Create Shooting command      

Create Sphere Area Light command  

Create Sphere Environment command  

Create Spot Light command   

Create Turntable command  
cylinder 

environment  
cylindrical 

camera  

D
diffuse 

lighting  
dimensions 

environment  



E
Edit Light Direction command  

Edit Light Parameters command  

Edit simulation objects option  
ENOVIA-CATIA 

interoperability   
environment 

box  

cylinder  

dimensions  

importing  

properties  

resize  

sphere  

wallpaper  

Environment Active contextual command  

F
Feature Properties    

Final Gathering  

Fit All In command  

Flip U,V  
focal length 

camera  
format 

animation  

image  

Formula command  
frame 

shooting  

Free Rotation command  



G
gizmo  

I
image 

format  

Import an Environment command  
importing 

environment  

indirect illumination  

Insert Existing Components command  
intensity 

color  
interoperability 

ENOVIA-CATIA   

V4 scene elements  
interrupt 

render  

L
layout 

sticker  
lens 

camera  

library (material)  

light area  

Light Commands toolbar  

Light On option  
light source 

manipulate  



symbol  

tuning  

Light View command  
lighting 

ambient  

attenuation  

diffuse  

material properties  

parameters    

position  

position along normal   

properties   

reference axis  

reflectivity  

refraction  

roughness  

shape  

specular  

specular manipulation   

transparency  

wall  

link u,v  

Lock Manipulator command  

loop mode  

M
manipulate 

camera  

light source  

Manipulate Focal command  
mapping 



sticker  
material ambient 

shooting  
materials 

render  

tuning  
Menu 

toolbar  
modifying 

sticker  

multi-view configuration  

N
Next View command   

O
option 

Wall Active  
output 

render  

oversampling  

P
parameters 

animation  

lighting    

Photo Studio workbench   
picture 

save  
position 



lighting  

Position along Normal command  

Position Direction command  

Position Specular command  
preview 

turntable  

Previous View command   
properties 

camera  

environment  

lighting   

sticker  

texture  

Properties command         

Q
quality 

shooting  

Quick Render command     

R
Redo Render command  
reflectivity 

lighting  
refraction 

lighting  
render 

interrupt  

materials  

output  

shooting   



sticker  

Render Animation command  

Render Shooting command      

Render toolbar   
replay 

animation  
resize 

environment  

Rotate around X command  

Rotate around Y command  

Rotate around Z command  
roughness 

lighting  

S
save 

picture  

Save Light Direction command  
scene 

animation  

catalog  

creation  

Scene Editor toolbar   

Shadows option    

shape (lighting)  
shooting 

definition  

frame  

material ambient  

quality  

render   

Show shadows option  



Simulation command   
specular 

lighting  
specular manipulation 

lighting   
sphere 

environment  
sticker 

adjustment  

applying  

color  

layout  

mapping  

modifying  

properties  

render  

symbol  

transparency  
symbol 

sticker  

T
tessellation  
texture 

properties  

Toggle Light Attachment  
toolbar 

Animation  

Apply Material  

Camera Commands  

Light Commands  

Menu  



Render   

Scene Editor   

Viewpoint  
Tools Options - Photo Studio 

Display  

General  

Output  

Satellites  

Stickers  
transparency 

lighting  

sticker  
tuning 

light source  

materials  

Turn Light On/Off command  
turntable 

creation  

preview  

U
u,v 

link  

Update from View command   

Use Transparent Color option  

V
V4 scene elements 

interoperability  
view 

camera  



Viewpoint toolbar  

W
wall 

lighting  

Wall Active option  
wallpaper 

environment  
workbench 

Photo Studio   
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