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Overview
Welcome to the Generative Sheetmetal Design User's Guide. This guide is intended for users who need to 
become quickly familiar with the Generative Sheetmetal Design Version 5 product. 

This overview provides the following information:

●     Generative Sheetmetal Design in a Nutshell

●     Before Reading this Guide

●     Getting the Most Out of this Guide

●     Accessing Sample Documents

●     Conventions Used in this Guide

Generative Sheetmetal Design in a Nutshell

The Generative Sheetmetal Design workbench is a new generation product offering an intuitive and flexible 
user interface. It provides an associative feature-based modeling, making it possible to design sheet metal 
parts in concurrent engineering between the unfolded or folded part representation.

Generative Sheetmetal Design offers the following main functions:

●     Associative and dedicated sheet metal feature-based modeling

●     Concurrent engineering between the unfolded or folded part representation

●     Access to company-defined standards tables

●     Dedicated drawing capability including unfolded view and specific settings.

All sheet metal specifications can be re-used by the Knowledge Advisor workbench to capture corporate 
knowledge and increase the quality of designs.

Natively integrated, Generative Sheetmetal Design offers the same ease of use and user interface consistency 
as all V5 applications.

As a scalable product, Generative Sheetmetal Design can be used in cooperation with other current or future 
companion products in CATIA V5 such as Assembly Design and Generative Drafting. The widest application 
portfolio in the industry is also accessible through interoperability with CATIA Solutions Version 4 to enable 
support of the full product development process from initial concept to product in operation.

The Generative Sheetmetal Design User's Guide has been designed to show you how to design sheet metal 
parts of varying levels of complexity.



Before reading this guide, you should be familiar with basic Version 5 concepts such as document 
windows, standard and view toolbars. Therefore, we recommend that you read the Infrastructure User's 
Guide that describes generic capabilities common to all Version 5 products. It also describes the general 
layout of V5 and the interoperability between workbenches.

You may also like to read the following complementary product guides, for which the appropriate license is 
required: 

●     Part Design User's Guide: explains how to design precise 3D mechanical parts.

●     Assembly Design User's Guide: explains how to design assemblies.

●     Generative Drafting User's Guide: explains how to generate drawings from 3D parts and assembly 
definitions.

 

Getting the Most Out of this Guide

To get the most out of this guide, we suggest that you start reading and performing the step-by-step 
Getting Started tutorial.

Once you have finished, you should move on to the next sections, which explain how to handle more 
detailed capabilities of the product.

The Workbench Description section, which describes the Generative Sheetmetal Design workbench, and 
the Customizing section, which explains how to customize the Generative Sheetmetal Design workbench, 
will also certainly prove useful. 

 

Accessing Sample Documents

To perform the scenarios, you will be using sample documents contained in the 
online\cfysa\samples\SheetMetal folder. For more information about this, refer to Accessing Sample 
Documents in the Infrastructure User's Guide.

 

 

Before Reading This Guide



Conventions
Certain conventions are used in CATIA, ENOVIA & DELMIA documentation to help you recognize and 
understand important concepts and specifications. 

Graphic Conventions

The three categories of graphic conventions used are as follows:

●     Graphic conventions structuring the tasks

●     Graphic conventions indicating the configuration required

●     Graphic conventions used in the table of contents

Graphic Conventions Structuring the Tasks

Graphic conventions structuring the tasks are denoted as follows:

This icon... Identifies...

estimated time to accomplish a task

a target of a task

the prerequisites

the start of the scenario

a tip

a warning

information

basic concepts

methodology

reference information

information regarding settings, customization, etc.

the end of a task



functionalities that are new or enhanced with this release

allows you to switch back to the full-window viewing mode

Graphic Conventions Indicating the Configuration Required 

Graphic conventions indicating the configuration required are denoted as follows:

This icon... Indicates functions that are... 

specific to the P1 configuration

specific to the P2 configuration

specific to the P3 configuration

Graphic Conventions Used in the Table of Contents

Graphic conventions used in the table of contents are denoted as follows:

This icon... Gives access to...

Site Map

Split View mode

What's New?

Overview

Getting Started

Basic Tasks

User Tasks or the Advanced Tasks

Workbench Description

Customizing

Reference

Methodology

Glossary



Index

Text Conventions

The following text conventions are used:

●     The titles of CATIA, ENOVIA and DELMIA documents appear in this manner throughout the text.

●     File -> New identifies the commands to be used.

●     Enhancements are identified by a blue-colored background on the text.

How to Use the Mouse

The use of the mouse differs according to the type of action you need to perform.

Use this
mouse button... Whenever you read...

 
●     Select (menus, commands, geometry in graphics area, ...)

●     Click (icons, dialog box buttons, tabs, selection of a location in the document window, 
...)

●     Double-click

●     Shift-click

●     Ctrl-click

●     Check (check boxes)

●     Drag

●     Drag and drop (icons onto objects, objects onto objects)

●     Drag

●     Move

●     Right-click (to select contextual menu)



What's New?

New Functionalities

Local fold and unfold of bends
You can now fold planar faces, as well as unfold cylindrical or conical faces in folded views, without 
changing the flattened view. 

Overlap detection
A new command now lets you check overlapping areas on flat views. 

Mirror
You can now mirror a given sheet metal feature. This duplicates a sheet metal feature symmetrically 
with respect to a plane.

Hybrid Design
You can now create wireframe and surfacic features within the same solid body which impacts the 
behavior of overlapping and local fold/unfold of bends. 

Enhanced Functionalities

Cutouts
Additional possibilities are now available when creating a cutout: you can choose a direction for the 
cutout that is different from, or equal to, the normal direction. Additionally, the extrusion can now be of 
lesser length than the thickness. You can also now specify several supports for the cutout, instead of 
just one previously. 

Stamp recognition
Stamps can now be recognized as Generative SheetMetal Design stamps.

Half-pierce for stamps
The new half pierce feature is available for circular stamps, curve stamps and surface stamps.

New options for surface stamps
Additional possibilities are now available when creating surface stamps. You can now define a stamp 
based on profile containing a punch and die sketch, a 3D curve sketch or a sketch with several inner 
contours. 

Flange pattern
You can now create a pattern from a flange on rectangular, circular or user-defined patterns.

Hopper
        Selecting a ruled surface is now possible when creating a hopper. 
Document chooser integration
        You can now customize the document environment (Tools > Options > General > Document tab) in order 
to select documents or paths using various interfaces (folder, Enovia, and so on). The interface can be 
customized for a folder or DLName path selection interface. 

 

 
 

  

file:///E|/Www/cnqr14/Doc/online/cfyugprt_C2/cfyughybrid_design.htm
file:///E|/Www/cnqr14/Doc/online/cfyugstamp_C2/cfyughalfpiercestamp.htm
file:///E|/Www/cnqr14/Doc/online/cfyugbas_C2/cfyugbrowsewindow.htm


Getting Started

Before getting into the detailed instructions for using Generative Sheetmetal Design , the following 
tutorial provides a step-by-step scenario demonstrating how to use key functionalities.

The main tasks proposed in this section are: 

Entering the Workbench
Defining the Sheet Metal Parameters

Creating the First Wall
Creating the Side Walls

Creating a Cutout
Extracting Drawings from the Sheet Metal Part 

 

 
All together, these tasks should take about 15 minutes to complete.

This tutorial, which is common to the Sheet Metal Design User's Guide and to the Generative Sheet 
Metal Design User's Guide, is illustrated using screen captures from the Sheet Metal Design workbench. 
At times, the user interface or results will slightly differ in the Generative Sheetmetal Design workbench. 
For more specific information concerning the Generative Sheetmetal Design workbench, refer to the 
User Tasks in this guide.



Entering the Workbench

The SheetMetal Design or Generative SheetMetal Design functions are available when you are in the Part 
environment. Several functions are integrated from the Part Design workbench.

This task shows how to enter the workbench.

 

For the SheetMetal Design workbench, choose the Mechanical Design -> Sheet Metal Design item 
from the Start menu.
For the Generative Sheetmetal Design workbench, choose the Mechanical Design -> Generative 
Sheetmetal Design item from the Start menu.

According to the chosen workbench, the corresponding Sheet Metal toolbar is displayed and ready to use.



You may add the SheetMetal Design or the Generative SheetMetal Design workbench to your Favorites, 
using the Tools -> Customize item. For more information, refer to the Infrastructure User's Guide.



Defining the Sheet Metal Parameters

This task shows you how to configure the sheet metal parameters.

1.  Click the Sheet Metal Parameters icon .

The Sheet Metal Parameters dialog box is displayed. 

2.  Enter 1mm in the Thickness field.

3.  Enter 5mm in the Default Bend Radius field.

4.  Select the Bend Extremities tab.



5.  Select Tangent in the Bend Extremities combo list.

An alternative is to select the bend type in the graphical combo list.

6.  Click OK to validate the parameters and close the dialog box.

The Sheet Metal Parameters feature is added in the specification tree.

The other two tabs are not used in this scenario.

 

 



Creating the First Wall

This task shows how to create the first wall of the sheet metal Part.

1.  Click the Sketcher icon  then select the xy plane.

2.  Select the Profile icon .

3.  Sketch the profile as shown below:

4.  Click the Exit workbench icon  to return to the 3D world.

The sketch remains selected.



5.  Click the Wall icon .

The Wall Definition dialog box opens.

By default, the Material Side is set to the top.

6.  Click OK.

The Wall.1 feature is added in the specification tree

The first wall of the Sheet Metal Part is known as the reference wall.



Creating the Side Walls

This task shows you how to add other walls to the sheet metal part.

1.  Click the Wall on Edge icon .

The Wall On Edge Definition dialog box opens.

2.  Select the left edge.

3.  Enter 50mm in the Value field.

The application previews the wall.

By default, the material side is such that it ensures a continuity with the reference profile. If needed, 

invert it using the Reverse side button, or clicking the arrow.



4.  Click the Reverse Position button to Invert the sketch profile.

5.  Click OK.

The wall is created and the Wall On Edge.1 feature is displayed in the specification tree:

6.  Select the right edge.

7.  Click the Wall on Edge icon  again.

The Wall On Edge Definition dialog box opens with the parameters previously selected.

8.   Invert the sketch profile and click OK to validate.

9.  Click the Wall on Edge icon  again.

10.  Select the front edge.

The Wall Definition dialog box opens with the 

parameters previously selected.

11.  Enter 30mm in the Value field and 10mm in 

the Limit1 and Limit2 fields, then invert the 

sketch profile.

12.  Press OK to validate.



The final part looks like this: 

 



Creating a Cutout

In this task, you will learn how to: 
●     open a sketch on an existing face

●     define a profile in order to create a cutout.

1.  Select Wall On Edge.2 from the 

geometry area to define the working 

plane.

2.  Click the Sketcher icon .

3.  Click the Elongated Hole icon  to create the profile.

To access the oblong profile, click the 

black triangle on the Rectangle icon.

It displays a secondary toolbar.

4.  Click to create the first point and drag the 

cursor.

5.  Click to create the second point.

The first semi-axis of the profile is 

created.

6.  Drag the cursor and click to create the 

third point.

The second semi-axis is created and the 

oblong profile is displayed.



7.  Click the Exit workbench icon  to return to the 3D world.

8.  Select the Cutout icon .

The Pocket Definition dialog box is 
displayed and a cutout is previewed 
with default parameters. 

9.  Set the Type to Up to last option to define the limit of your cutout.

This means that the application will limit the cutout onto the last possible face, that is the 
opposite wall.

10.  Click OK.

This is your cutout:

 

 



Extracting Drawings
from the Sheet Metal Part

This task shows how to create the sheet metal part views in the Generative Drafting workbench.

The sheet metal part is displayed.

1.  Click  or select File -> New...

2.  Select the Drawing type and click OK.

The Generative Drafting  workbench is launched. The New Drawing dialog box opens.

3.  Click OK.

For more information about this workbench, refer to Generative Drafting User's Guide. 

4.  The drawing sheet appears.

5.  Tile the windows horizontally using the Window -> Tile Horizontally menu item.

6.  Select the Unfolded View icon  in the Projections toolbar from Generative Drafting Workbench.

This icon is added to the Projections toolbar provided the Sheet Metal workbench is present.

7.  Choose the xy plane in the Sheet Metal specification tree. The unfolded view is previewed. 



8.  Click in the drawing to validate and generate the view, with the bend axes and bend limits when applicable.

 

 



User Tasks
The tasks you can perform in the Generative Sheetmetal Design workbench are described in the following 
chapters and tasks.

Managing the Default Parameters
Recognizing Walls From an Existing Part

Creating Walls
Creating Bends on Walls

Creating Extrusions
Creating Swept Walls
Aggregating Bodies
Creating a Hopper

Unfolding
Creating a Hole

Creating a Cutout
Stamping
Patterning
Mirroring

Creating a Local Corner Relief
Creating Corners

Creating Chamfers
Mapping Elements

Interoperability with Wireframe
Integration with Other Workbenches

Designing in Context
Managing PowerCopies

Browsing the Sheet Metal Catalog
Looking For Sheet Metal Features

Saving As DXF



Managing the Default Parameters

This section explains and illustrates how to use or modify various kinds of features.

Using Generative Sheetmetal Design assumes that you are in a CATPart document.

Edit the parameters: select the Parameters tab, the wall thickness and bend radius values.

Modify the bend extremities : select the Bend Extremities tab and choose a predefined bend type. 

Define the bend allowance: select the Bend Allowance tab and define the allowance value (K factor).

 



Editing the Sheet and Tool Parameters

This section explains how to change the different sheet metal parameters needed to create your first feature.

1.  Click the Sheet Metal Parameters icon .

The Sheet Metal Parameters dialog box is displayed.

2.  Change the Thickness if needed.

 
3.  Change the Minimum Bend Radius if needed.

The Minimum Bend radius defines the minimum internal radius allowing the creation of a bend. 

 You can set the value to 0 to create bend with no radius. If using the DIN standard, the KFactor automatically sets to 0 as well.

4.  Change the Default Bend Radius if needed.

The Default Bend Radius corresponds to the internal radius and is linked by default to the creation of the bends.

Convention dictates that the inner angle between the two elements is used to define the bend.
It can vary from 0deg to 180deg exclusive. This angle is constant and the bend axis is rectilinear.

5.  Click OK to validate the Sheet Metal Parameters.

 
The Standard field displays the Standard to use with the part, if implemented. The name of this standard file is defined in a Design Table.
When the Check all the bend radii button is checked, and you click OK in the Sheet Metal Parameters dialog box, existing bend radii are checked and a list displays flanges or bends that do not use the minimum Bend 
Radius value as defined in step 3. Therefore, they will not be modified.

Parameters can be defined in a Design Table. To do so, press the Sheet Standards Files... button to access to the company-defined standards, if need be. For more information, refer to the Customizing Standard Files 

section.

All parameters hereafter, or only some of them, can be defined in this Design Table:
 Sheet Metal Parameters Column associated in the Design Table Definition

Standard in Sheet Metal 
Parameters SheetMetalStandard sheet reference name

Thickness Thickness sheet thickness
Minimum Bend Radius MinimumBendRadius minimum bend radius
Default Bend Radius DefaultBendRadius default bend radius
K Factor KFactor neutral fiber position
Radius Table RadiusTable path to the file with all available radii

In all cases, the Thickness parameter must be defined in the Design Table in order for the other parameters to be taken into account.

Whenever both Radius Table and Default Bend Radius are defined in the Design Table, only the Radius Table will be taken into account for the bend creation.

 Standard Names For Holes Column associated in the Design Table Definition
Clearance Hole ClearanceHoleStd path to the Clearance Hole Standard file
Index Hole IndexHoleStd path to the Index Hole Standard file
Manufacturing Hole ManufacturingHoleStd path to the Manufacturing Hole Standard file
Fastener Hole FastenerHoleStd path to the Fastener Hole Standard file

  



 Standard Names For Stamps Column associated in the Design Table Definition
Flanged Hole ExtrudedHoleStd path to the Flanged Hole Standard file
Bead BeadStd path to the Bead Standard file
Circular Stamp CircularStampStd path to the Circular Stamp Standard file
Surface Stamp SurfaceStampStd path to the Surface Stamp Standard file
Flanged CutOut FlangedCutoutStd path to the Flanged CutOut Standard file
Curve Stamp CurveStampStd path to the Curve Stamp Standard file

 When a parameter refers to a path, another sub-Design Table will be associated to the corresponding feature.
 

Example for a bend allowance table:
 A bend table is associated to the default bend radius. Each bend radius is linked by a formula to the default bend radius.

If a bend table is defined, the bend allowance (for a given angle) is taken into account when the bend is created. Otherwise, the default K factor is used.

You should know that bend tables are used only for:

●     the default bend radius; in the case of a non-standard bend, the K factor is used by default. In this case, you will need to modify manually the local K factor if you want the required allowance to be taken into account.

●     the Bend and Bend from Flat features; other features use the K factor for flat length computation.

  
 Main Sheet Metal Parameters Design Table
 

  
 Bend Table for Thickness 2 and Default Bend Radius

According to the open angle, the bend deduction will be read in the Deduction column or interpolated if necessary.
 

 
Example for a hole standard file:

 Main Sheet Metal Parameters Design Table
 

  
 Hole Standard 

Whenever a hole is created, a design table will associate its radius with a standard name.
 

 
Example for a stamp standard file:

 Main Sheet Metal Parameters Design Table



 

Whenever a stamp is created, a design table will associate its dimension with a standard name.
     
 

●     Surface Stamp

     
 

●     Curve Stamp

     
 

●     Circular Stamp

     
 

●     Bead

     
 

●     Bridge

     
 

●     Flanged Cutout

     
 

●     Extruded Hole
(or Flanged Hole in the Generative Sheetmetal Design workbench)

     
 

●     Stiffening Rib



Modifying the Bend Extremities

This section is only available with the SheetMetal Design products.

This section explains how to change the bend extremities, i.e. how to change axial relimitations for a 
straight bend.

1.  Click the Sheet Metal Parameters icon .

The Sheet Metal Parameters dialog box is displayed.

2.  Click the Bend Extremities tab to access parameters defining bend extremities.

 

 
3.  Choose a bend extremity, either from the drop-down list or using the graphical button 

underneath.

●     Minimum with no relief (default option): the bend corresponds to the common area of 
the supporting walls along the bend axis, and shows no relief.

●     Square relief: the bend corresponds to the common area of the supporting walls along 
the bend axis, and a square relief is added to the bend extremity. The L1 and L2 
parameters can be modified if needed. 

●     Round relief: the bend corresponds to the common area of the supporting walls along the 
bend axis, and a round relief is added to the bend extremity. The L1 and L2 parameters 
can be modified if needed.

●     Linear: the unfolded bend is split by two planes going through the corresponding limit 
points (obtained by projection of the bend axis onto the edges of the supporting walls).

●     Tangent: the edges of the bend are tangent to the edges of the supporting walls.



●     Maximum: the bend is calculated between the furthest opposite edges of the supporting 
walls.

4.  Click OK to validate.

 



Computing the Bend Allowance

This section explains the calculations related to folding/unfolding operations.

1.  Click the SheetMetal Parameters icon 

.

The Sheet Metal Parameters dialog box is 

displayed.

The fourth tab concerns the bend allowance.

 
●     Bend Allowance

 The bend allowance corresponds to the unfolded bend width.

 

 
bend < 90deg bend > 90deg 

 L is the total unfolded length
A and B the dimensioning lengths as defined on the above figure. They are similar to the DIN 
definition.



 
●     K Factor

 Physically, the neutral fiber represents the limit between the material compressed area inside the bend 
and the extended area outside the bend. Ideally, it is represented by an arc located inside the thickness 
and centered on the bend axis. 

The K factor defines the neutral fiber position:

W = α * (R + k * T)

where:

W is the bend allowance
R the inner bend radius
T the sheet metal thickness
α the inner bend angle in radians.

If β is the opening bend angle in degrees:

α = π * (180 - β) / 180

When you define the sheet metal parameters, a literal feature defines the default K Factor and a formula 
is applied to implement the DIN standard. This standard is defined for thin steel parts. Therefore the K 
Factor value ranges between 0 and 0.5.

The DIN definition for the K factor slightly differs. 

W = α * (R + k' * T/2)
Therefore k' = 2 * k and ranges from 0 to 1.

 This formula can be deactivated or modified by right-clicking in the K factor field and choosing an option 
from the contextual menu. It can be re-activated by clicking the Apply DIN button. Moreover, the limit 
values can also be modified.

 When a bend is created, its own K Factor literal is created. 
Two cases may then occur:

a.  If the Sheet Metal K Factor has an activated formula using the default bend radius as input 
parameter, the same formula is activated on the bend K Factor replacing the default bend radius 
by the local bend radius as input.

b.  In all other cases, a formula "equal to the Sheet Metal K Factor" is activated on the local bend K 
Factor.
This formula can also be deactivated or modified.

 
●     Bend Deduction



 When the bend is unfolded, the sheet metal deformation is thus represented by the bend deduction V, 
defined by the formula:

L = A + B + V
(refer to the previous definitions). 

Therefore the bend deduction is related to the K factor using the following formula:

V = α * (R + k * T) - 2 * (R + T) * tan ( min(π/2,α) / 2)

 This formula is used by default. However, it is possible to define bend tables on the sheet metal 
parameters. These tables define samples: thickness, bend radius, open angle, and bend deduction. In 
this case, the bend deduction is located in the appropriate bend table, matching thickness, bend radius, 
and open angle. If no accurate open angle is found, an interpolation will be performed. 

 When updating the bend, the bend deduction is first computed using the previously defined rules. Then 
the bend allowance is deduced using the following formula:

W = V + 2 * (R + T) * tan ( min(π/2,α) / 2)

When the bend deduction is read in the bend table, the K factor is not used.



Recognizing Walls From an Existing Part

This task illustrates how to recognize an existing part as a sheet metal part, i.e. recognize as sheet metal 
features the thin part shapes of a part created using the Part Design workbench or of a CATIA Version 4 
Solid, for example. You can also use this functionality to recognize parts created using the SheetMetal 
Design workbench as Generative Sheetmetal Design parts.

Currently, walls and bends can be recognized. Hems are recognized as walls.

Open the NEWRecognize01.CATPart document.

This document contains a part created in the Part Design workbench:

1.  Click the Recognize icon . The Recognize Definition dialog box is displayed. 

 

file:///E|/Www/cnqr14/Doc/online/cfysm_C2/samples/SheetMetal/NEWRecognize01.CATPart


Note that the With Wall recognition option is already selected, and grayed out. This is because 

at least walls will be recognized, regardless of the other options you may choose. 

2.  Select a reference face. It will be the reference face for unfolding and for the definition of the 

sheet metal parameters (i.e. all default parameters will be based on this face).

3.  For the purpose of this scenario, select Full recognition to specify that you want as many 

features (walls, bends) as possible to be recognized. Doing this automatically selects the With 

Bend recognition option.

You can also manually select the faces to be recognized as walls, after having activated the 

corresponding field. Then, select the With Bend recognition option, activate the associated field 

and manually select the faces to be recognized as bends.

4.  Click OK to validate. 

The walls are generated from the Part Design geometry. The Recognize.1 feature is added to 

the tree view. 

At the same time, the sheet metal parameters are created, deduced from the Part geometry.

 

5.  Select the Sheet Metal Parameters icon  to display the sheet metal parameters. 

 



 

On the Parameters tab:

❍     the Thickness is equal to 20mm,

❍     the Minimum Bend Radius value is set to 0mm,

❍     the Default Bend Radius value amounts to twice that of the thickness.

On the Bend Extremities tab:

❍     the bend extremities are set to Minimum with no relief.

You can modify a few of these parameters. The Thickness parameter cannot be modified 

because it is based, like the bend extremities and radius, on the initial solid geometry. However, 

you can modify other parameters (minimum bend radius, default bend radius and bend 

extremities) in order for them to be taken into account for sheet metal features other than the 

"recognized" ones.

The bend allowance, being used to unfold the part, and the bend corner relief affect all features, 

and therefore can be edited even for "recognized" features.

 



You can also define the sheet metal parameters prior to recognizing the part. In this case, 
you need to make sure that the Thickness parameter value corresponds to the part 
thickness.

6.  When all parameters have been redefined as needed, click OK in the Sheet Metal Parameters 

dialog box.

The solid is now a Generative Sheetmetal Design part. You can now deal with it as with any other 

Generative Sheetmetal Design part, adding Generative Sheetmetal Design features to complete 

the design, or unfolding it.

In certain cases, there may be an ambiguity as regards the faces from which the walls are to be 
generated. For example, if the initial part is a box such as shown below, you will need to select two 
opposite inner faces, and outer faces on the other two sides of the box, in order to avoid overlapping 
when recognizing the walls. 

 Faces to select Recognition result
 



Creating Walls
This section explains and illustrates different methods to create walls.

Create a wall from a sketch: use the sketcher to define the profile, and set the material side.

Create a wall tangent to another one: select a profile coincident with an existing wall, and select the wall 
to which it should be tangent.

Create a wall from an edge: select a wall edge, set the height, limits, angle, then the material sides.



Creating Walls from a Sketch

This task shows how to create a wall from a sketch.

You must be in the Sheet Metal Workbench, with a .CATPart document open, and you must have defined 

the sheet metal parameters. 

Set the sketcher grid to H = 100mm and V = 100mm, using the Tools -> Options, Mechanical 

Design -> Sketcher, Sketcher tab.

1.  Click the Sketcher icon  then select the xy plane.

2.  Select the Profile icon .

3.  Sketch the profile as shown below:

4.  Click the Exit workbench icon  to return to the 3D world.



5.  Click the Wall icon .

The Wall Definition dialog box opens.

By default, the Material Side is set to the top.

6.  Click OK.

The Wall.1 feature is added in the specification tree.

The first wall of the Generative Sheetmetal Design Part is known as the Reference wall.

●     Click the Sketcher icon  from the Wall Definition dialog box, if you wish to directly edit the 

selected sketch. When exiting the sketcher, you then go back to the wall creation step, without 

having to reactivate the Wall icon.



This is also very useful if you have selected 
an edge from a wall and clicked the Wall 

icon . 

In this case, the sketcher is automatically 
activated displaying a square sketch 
constrained to the plane perpendicular to 
the support of the selected edge.

You can then directly draw a sketch, then 
exit the sketcher and return to the wall 
creation step. 

    

●     You can directly create a wall with a hole, by selecting a sketch with an inner profile (the profiles 
must not intersect):



 

 
Sketch with inner profile Resulting wall

Note however, that the emptied area is part of the wall and is not a separate cutout that can 
be edited.



Creating Tangent Walls

This task shows how to create a wall tangent to a planar part of another wall or of a flange. This 

capability will then allow this tangent wall to be seen when unfolding the part, even though there is no 

bend linking it to its tangent support, provided this support can also be unfolded.

Open the NEWTangentWall1.CATPart document.

1.  Select a face of an existing wall and click the Sketcher icon .

Here we selected the flange's planar face.

2.  Select the Profile icon  and sketch the profile as shown below.

3.  Using the Constraint Defined in Dialog box icon, set coincidence constraints between the edges 

where the support and sketch are to coincide.

4.  Click the Exit workbench icon  to return to the 3D world.

5.  Make sure the sketch is still active, then click the Wall icon . The Wall Definition dialog box 

is displayed.

file:///E|/Www/cnqr14/Doc/online/cfysm_C2/samples/SheetMetal/NEWTangentWall1.CATPart


 

Note the arrow which indicates the orientation of the wall to be created.

 
6.  Make sure the Tangent to field is active, then select the wall to which the new wall has to be 

tangent. Here, you need to select the planar face of the flange.

Note that the orientation automatically changes to conform to the material orientation already 

defined on the support wall.

 



7.  Click OK.

The wall is created and a Wall.xxx feature is added in the specification tree.

 

8.  Click the Unfold icon .

The tangent wall is unfolded as a wall linked by a bend to another wall, would be.



If you want to create the wall on a wall that cannot be unfolded, the system issues a warning and 

prevents you from creating the tangent wall.

 



Creating Walls From An Edge

This task shows how to create walls from edges of an existing wall. This function is used to create a box in an 
easy and quick way from an existing reference wall.

At least one wall must already exist.

Open the NEWWall1.CATPart document from the samples directory.

1.  Click the Wall on Edge icon  

and select an edge of an existing 

wall.  

The Wall On Edge Definition dialog 

box is displayed together with a 

preview of the wall. 

2.  Define the type of wall to be created 

by specifying the Reference, that is:

●     the Height of the wall: that is the 
orthogonal projection from the top of the 
wall on edge to the reference wall.

Select the  icon to define the height 

of the wall from the bottom of the 

reference wall or the  icon to define 

the height of the wall from the top of the 
reference wall.

●     the Length of the wall: that is the 
absolute value of the wall on edge 
without bend.
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3.  You can now relimit the wall by 

selecting planes for the First and 

Second Limit:

●     type:

❍     Undefined reference

❍     Up To Plane

●     Offset

●     Plane 

As a consequence, the generated wall is not 
necessarily rectangular.  

   
 

4.  Define the angle of the wall: by default it is perpendicular to the plane containing the edge. You may 

modify it according to your needs. it is updated dynamically on the screen.

This preview gives information about: 

●     the Sketch Profile: by default, if you pick an edge on the top of the reference wall, the direction of the wall 

is upwards, if you pick an edge on the bottom of the reference wall the direction of the wall is downwards. 

Preview with top edge selected Preview with bottom edge selected

You can invert the sketch's 

position, and therefore the wall's,  

using the Reverse Position 

button. 

Preview with bottom edge selected and sketch profile inverted



●     the material side: by default the material 
side is proposed so as to keep a 
continuity with the reference profile. 

However, you can change it by 
clicking the red arrow or the 
Reverse Side button.  

5.  Check the Clearance option to offset 

the wall on edge from the selected 

edge. 

The entered value is the radius of 

the bend on this edge. 

Wall on edge with clearance Wall on edge without clearance
    

Note that the reference wall remains unchanged when changing the bend radius value. It is the Wall on Edge's 
length that is affected.

6.  You can also choose to create the wall with or without a bend by checking the With Bend option.

●     If there is no wall from which a limit can be computed, the reference element is the edge of the reference 
wall.



●     A wall on edge is defined by the selected 
edge (reference edge). When the 
reference edge is modified, by adding 
any feature that shortens the edge (a 
bend to an adjacent wall on edge or a 
cutout for example) the wall on edge 
based on this reference edge is 
recomputed.
To avoid this you may:  

❍     create the bend manually on the wall 
modifying the edge used as the 
reference to  create the other wall

❍     reorder the creation of walls to 
postpone the creation of the 
modifying feature

 
●     Both limits are computed with the same reference icon.

●     The bend is not previewed, even if the option With Bend is checked. However it will be created.

●     The selected options are modal and will be proposed to create the next wall.

●     Walls on edge being contextual features, if you break the profiles continuity by inverting the material side of 
a wall, you may have to manually re-specify all features based upon the modified one, even if they are not 
directly connected to the modified wall, in order to update the part afterwards.

This is the case when creating a 
wall on edge from another wall on 
edge, for example:

●     If you invert the material side of the 
reference wall on which the first wall on 
edge has been created, both walls on 
edge are relocated (as if you were 
flipping the geometry):



●     If you invert the material side of the first 
wall on edge (and not the material side 
of the reference wall), the second wall on 
edge is relocated. Indeed, its 
specification being relative to the first 
wall on edge, when its input data (i.e. 
the edge selected on the first wall on 
edge) is modified, the second wall on 
edge is rebuilt at a new location. 

7.  Click OK in the Wall On Edge Definition dialog box.

A WallOnEdge.xxx element is created in the specification tree.

●     A WallOnEdge.x element can be edited: double-click it in the graphic area or in the specification tree to 
display its creation dialog box and modify the parameters described above, including the edge from which it 
is created. However, the sketch of a wall on edge cannot be edited directly.

●     You can cut or copy and paste a wall on edge. 

●     If you cut and paste a wall on edge with children elements, these children elements are lost. This may 
result in update errors.

●     You cannot undo an Isolate action after having modified the wall.

●     Isolating a wall on edge erases all updating data.

   
 

Creating a Wall On Edge on a 
Flange or a Stamp

 

Open the NEWWall3.CATPart document.
Let's take an example with a user flange. 

 

1.  Click the Wall on Edge icon  

and select the edge of the user 

flange.  
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2.  Click OK in the Wall on Edge 

Definition dialog box to create the 

wall on edge on the user flange. 

 



Creating Bends on Walls
 

This section explains and illustrates different methods to create bends on walls. Bends can only be created 
between walls and not between any other Sheet Metal features, such as stamps for example.

Manually create bends from wall: select the two walls, set the bend radius value, the bend extremities, 
and specify the use of corner relief
Create conical bends: select the two walls, set the right and left bend radius values as well as the bend 
extremities.
Create flat bends: select a sketch, set the creation mode and limiting option, set the radius and angle in 
relation to the selected sketch.

 Create local fold and unfold of bends: select the two faces and the fold angle.



Manually Creating Bends from Walls

This task explains two ways to create bends between walls in the Sheet Metal part.
These bends can be created on non-connex walls, and with a constant radius value.

Open the NEWBendExtremities01.CATPart document.

1.  Select the Bend icon . The Bend Definition dialog box is displayed.

 

Note that the Radius field is in gray because it is driven by a formula when editing the sheetmetal parameters: at that 

time, you cannot modify the value.

2.  Select Support 1 and Support 2 in the specification tree or in the geometry area. The two supports must be 

connected by the edge of their internal faces. 

The Bend Definition dialog box is updated, and arrows are displayed, indicating the walls 

orientation. When relevant (which is not the case in our example), you can click the 

arrows to invert the orientation.

The left and right endpoints for the bend are identified using text.

3.  Right-click the Radius field and select Formula -> Deactivate from the contextual menu to change the value.

You can set the Radius value to 0. 

 
4.  Enter 4mm for the radius and click Preview. The bend is previewed, along with its orientation symbolized by 

arrows. 
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5.  Click the More>> button to display additional options: 

You can define:  
●     the left and right extremity settings (see also extremities definition settings)

●     the corner relief definition settings

●     and the bend allowance settings.

 
6.  Click the Left Extremity tab, and choose the Mini with round relief bend extremity type.

7.  Then, deactivate the L1  and L2 length formulas (as previously explained in step 3), and set them to 6mm and 

3mm respectively.
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8.  Click the Right Extremity tab, and choose the Curved shape type.

 

9.  Click Preview to visualize the left and right extremities.

      

10.  Click OK in the Bend Definition dialog box.

The bend (identified as Cylindrical Bend) is created with the specified extremity types and 

is added to the specification tree. 



 
●     The extremities and the corner relief defined with the current dialog box will apply locally and prevail over any other 

global definition.

●     Be careful when creating bends with square or round relief. Depending on the geometry configuration, this can lead 
to removing more matter than you would expect. Indeed, a corner relief being computed on the whole intersection of 
the elements involved (bends or bend/wall), in the following configuration, the matter is removed till the end of the 
wall.

Bend with no relief Bend with square relief
In this case, it is best to replace the bend corner relieves with cutouts (identified in red in the figure below) 
that will act as corner relieves removing matter to the part.

 
Creating a Bend on a Flange or a Stamp
Let's take an example with a surface stamp. 

Open the NEWBendExtremities02.CATPart document. 
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1.  Select the Bend icon . The Bend Definition dialog box is displayed. 

2.  Select the surface stamp's face as Support 1. 

3.  Select Wall.3 in the specification tree as Support 2. 

 

 
4.  Click OK in the Bend Definition dialog box to create the bend on the surface stamp. 

 

To deselect a wall, simply click on another wall available in the part. 

The stamp must be open, contain a planar face, and have a radius higher than 0. 



Creating Conical Bends

This task explains how to create conical bends between two walls in a Sheet Metal part.

Conical bends are different from the standard bend in that they allow different radius values at each end of 
the bend.

Open the NEWBendExtremities01.CATPart document.

1.  Select the Conical Bend icon . The Bend Definition dialog box appears.

 

 
2.  Select Support 1 and Support 2 in the specification tree or in the geometry area. The two 

supports must be connected by the edge of their internal faces.

The Bend Definition dialog box is updated, and arrows are displayed, 

indicating the walls orientation. When relevant (which is not the case in our 

example), you can click the arrows to invert the orientation. 

The left and right endpoints for the bend are identified using text.
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3.  Enter the radius values for each end of the conical bend. For example, enter 5mm as the left radius 

and 20mm as the right radius.

●     By default, Right Radius amounts to twice Left Radius.

●     Note that the radius is computed based on the left and right endpoints for the 
bend. This radius, once computed, will be larger than the specified value. 

●     When the size of each support differs, the bend may exceed the top of the cone. 
In such a case, computing the radius value is impossible. 

 
The Angle field is locked. If you then click the Preview button, it is updated, 

indicating the angle value between the two walls between which the bend is 

computed. 

 



4.  Click More... to display additional options.

 



5.  Optionally, on the Left Extremity and Right Extremity tabs, click the graphical button to choose 

the bend extremities:

●     Mini with no relief (default option): the bend corresponds to the common area 

of the supporting walls along the bend axis, and shows no relief.

●     Mini with square relief: the bend corresponds to the common area of the 

supporting walls along the bend axis, and a square relief is added to the bend 

extremity. The L1 and L2 parameters can be modified if needed. 

●     Mini with round relief: the bend corresponds to the common area of the 

supporting walls along the bend axis, and a round relief is added to the bend 

extremity. The L1 and L2 parameters can be modified if needed.

●     Linear shape: the unfolded bend is split by two planes going through the 

corresponding limit points (obtained by projection of the bend axis onto the edges 

of the supporting walls).

●     Curve shaped: the edges of the bend are tangent to the edges of the supporting 

walls.

●     Maximum bend: the bend is calculated between the furthest opposite edges of 

the supporting walls.

6.  Optionally, on the Bend Allowance tab, define the K factor (which performs calculations related to 

folding/unfolding operations). Refer to Computing the Bend Allowance for complete information.

7.  Click OK. The conical bend is created. 





Creating Bends From a Line

This task explains how to generate bends based on a line (also called flat bends). A wall and a bend are 
created.

Open the NEWFlatBend1.CATPart document.

1.  Select the reference wall then the Bend 

From Flat icon .

The Bend From Flat Definition dialog box 

opens.

2.  Select a profile (Sketch.2 here) containing 

one or several lines.

This sketch must necessarily be a line.

Selected lines appear in the Lines combo 

list.

The line(s) must not intersect an area where a 3D feature (such as a longitudinal chamfer, or a stamp 
created from punch and die) lies.
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3.  You can choose the line extrapolation option:

 Axis 

 BTL (Bent Tangent Line): line corresponding to the limits of the bend's fillet

 IML (Inner Mold Line): line created by intersecting the internal surfaces of the bend (before 

filleting) and the wall

 OML (Outer Mold Line): line created by intersecting the bend support and a plane perpendicular to 

the wall and normal to the OML.

The Radius and the KFactor values are the one 
defined when editing the sheetmetal parameters:
Right-click the Radius or the KFactor field and 
select Formula -> Deactivate from the contextual 
menu to change the value.

 You can set the Radius value to 0.

4.  Set the angle value between the generated 

wall and the reference wall.

5.  Click OK to create the bend.

 



●     When creating such a bend on a reference wall (first wall), an arrow indicates which part is to be 
folded. Click this arrow to invert the side that will be bent.

●     Bends from line should be performed on end walls, or prior to creating further walls on the bent one.

●     Perform the bend before creating stamping features, as stamps are not retained when the part is 
folded with the bend.



Creating Local Fold and Unfold

This task explains how to fold or unfold bends in the Sheet Metal part.
 

Local Fold and Unfold applies to cylindrical faces such as flange, bend and surfaces recognized as bend. 

In our example, we chose local fold and unfold of bends.

Open the NEWFoldUnfoldBends.CATPart document.

1.  Select the Unfolding icon . The Unfolding Definition dialog box is displayed.

 

 

Unfold

1.  Select Wall.1 as reference face on the geometry.

Angle type is disabled and set to Natural.

Angle is at 90 degrees.

 

2.  Select Cylindrical Bend.1 and Cylindrical Bend.2
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3.  Click on Preview to visualize the unfolding of the bends you selected.

 

4.  Click on OK to unfold the bends.

The Unfolding.1 feature is created in the specification tree.

The following options are available in the Unfolding Definition dialog box:

●     Reference face: fixed part of the body

●     Unfold Faces: bend(s) to unfold

●     Angle: disabled, corresponds to the angle of the selected face to fold that is 90 degrees by defaut

●     Angle type: disabled, set to natural by default



 

Fold

1.  Select the Folding icon . The Folding Definition dialog box is displayed.

 

2.  Select Wall.3 as reference face.

 

3.  Select Cylindrical Bend.1

A red arrow is displayed indicating the direction of the angle.

 

4.  In the Folding Definition dialog box, select Defined as angle type and 45 degrees as angle.

5.  Click on Preview to visualize the folding of the bend you selected.



 

6.  Click on OK to fold the selected bend.

The Folding.1 feature is created in the specification tree.

The following options are available in the Folding Definition dialog box:

●     Reference face: fixed part of the body

●     Fold faces: bend(s) to fold

●     Angle: corresponds to the angle of the selected face to unfold

●     Angle type
❍     Natural: when selected, the angle is set to 90 degrees by default and is disabled

❍     Defined: allows you to choose the bend angle with the up and down arrows

❍     Spring back: the angle of the bend is based on the natural angle with additional degrees.

 

Bend folded with a Spring back angle at 90 degrees.



 

Bend folded with a natural angle at 90 degrees.

To fold or unfold a part with a bending cycle, each element of the cylindrical bend has to be selected individually.

 

●     Multiselection is possible but since unfold faces must be in the same domain you must fold/unfold the parts one after 

the other. You cannot create folded faces with null radius.

●     The fold/unfold feature is only available in folded view, as the flattened view is not modified.



You cannot fold/unfold bends:
●     if faces to fold are not in the same domain,

●     if faces to unfold have a null radius,

●     if cylindrical faces are generated from stamps or rolled walls.

  

In hybrid context, even though a wall is created with one or several features, none are aggregated under the wall in the 
specification tree. 

Specification tree's behavior in pre-hybrid context.

 

Specification tree's behavior in hybrid context.

Yet, if you open a part created in a previous release, the specification tree will be displayed accordingly to the previous 
behavior.
Fore more information about Hybrid Design, refer to the Hybrid Design section.

file:///E|/Www/cnqr14/Doc/online/cfyugprt_C2/cfyughybrid_design.htm


Checking Overlapping

 

This task shows how check the overlapping of different areas of the part. This is usually done when the part has been designed, 
bends created and the part is unfolded.
Overlapping between areas of the part are highlighted.

 
Open the NewOverlap01.CATPart document from the samples directory.

 
1.  Click the Unfold icon  to unfold the part.

2.  Click the Check Overlapping icon .

The area with the overlapping is highlighted in red. 

The Overlapping Detection dialog box is displayed indicating how many 
overlaps are present on the analyzed part.

3.  Click OK.

A curve is generated. This curve can then be used to solve the overlapping, by redesigning the involved feature's 

sketches or specifications.

4.  Click OK.

Generated curve on unfolded view Generated curve on folded view
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When no overlapping is detected, the Overlapping Detection dialog box 
indicates so:

In hybrid context, the curve generated after an overlapping detection is aggregated under the part body in the specification tree.

 

 Specification tree's behavior in hybrid 
context.

 Specification tree's behavior in pre-hybrid context.

 

 



Creating Extrusions
 

This section explains and illustrates how to create various kinds of extrusions.

Extrude: choose the extrusion type, specify the length and choose additional options.

Create Rolled Walls: select a circular sketch, specify the rolled wall type and choose additional options.



Extruding

This task explains how to create a wall by extrusion.
You can extrude sketches composed of lines, circles, projection of lines, and projection of circles.

You must have defined the Sheet Metal parameters.
A model is available in the NEWExtrude1.CATPart from the samples directory.

1.  Click the Extrusion icon .

2.  Select a sketch.

The Extrusion Definition dialog box is 

displayed. 

Several types of extrusion are available:  
●     Dimension : the requested input data are a sketch and a dimension,

●     Up to plane or Up to surface: a plane or a surface are input as limit to the extrusion. These 
functions are used to create walls that are not rectangular.

3.  Edit the Length1 and Length2 to set both extremities, for option Dimension.

By default, the Length1 value is positive.
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The sketch you selected appears in the Selection field

You can now edit it by clicking the Sketcher icon  if you wish to modify it.

4.  Define the options as needed:

●     Check the option Mirrored extent to extent the material on both sides of the sketch. In that case, 
only Length1 can be edited. 

 

This option is only available if the type is set to Dimension.

●     Check Symmetrical thickness to create thickness inside and outside the sketch.



●     Push Invert Material Side to invert the direction of the creation of the material.

 

5.  Click OK.

The walls corresponding to the selected sketch are created according to the specified 

options, and added to the specification tree.

●     When the extrusion is the first Sheet Metal feature of the Part, the reference wall is the first wall 
created based on the first segment of the sketch.

●     For option Up to Surface, while the wall end that is limited by the surface has the shape of the 
surface, its thickness does not fit the surface. It is a "rectangular" polygon defined by the first edge 
that comes into contact with the surface.



 

●     Such an extrusion can also be performed on a sketch 
made of lines and arcs of circle, provided there are 
no tangency discontinuities between the different 
elements. 
However, in this case: 

❍     the Up to plane or Up to surface capabilities 
are not available, 

❍     you cannot isolate such an extrusion,

❍     if the element of the extruded sketch connected 
to the part is an arc of circle, the extrusion will 
not display in the unfolded view. To avoid this, 
prefer to create a User Defined Flange or remove 
the arc of circle of the extruded sketch and create 
a bend to connect the extrusion to the part.

●     Extrusion walls can be edited.

The sketch may not be closed, and must contain at least a line.



Creating Rolled Walls

This task shows how to create rolled walls (such as pipes, open pipes with flange, etc.).

You must have defined the Sheet Metal parameters, and have a sketch available, in the form of an 
circular arc.
The part is available in the Rolledwall1.CATPart from the samples directory.

1.  Click the Rolled Walls icon .

2.  Select the circular sketch.

3.  Make sure the type is set to 

Dimension.

4.  Length 1 and Length 2 indicate the 

location of Limit 1 and Limit 2.

5.  Define the options as needed.
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●     Check the option Mirrored extent to 
extend the material on both sides of the 
sketch. In that case, only Length1 can be 
edited.

●     Check Symmetrical thickness to create 
thickness inside and outside the sketch.

●     Click Invert Material Side to invert the 
direction of the creation of the material.

6.  Click OK in the dialog box to create the 

rolled wall.



 Unfold Reference

 Two symmetrical faces are generated so that the rolled wall can be unfolded.

To do so, click the unfold icon .

 You can unfold the rolled wall using three different references:
 

●     Start point



 

●     End point

 

●     Middle point

  
The rolled wall is a particular extrusion, indeed the input sketch is either a circular arc or a closed circle.

The sketch may be open. In that case, you can define where the opening should be.
The opening angle must be at least 0.5 degree.

The sketch may be closed. In that case, you have no control on the opening location.



The only operations you can combine with a rolled wall in a Sheet Metal model are flanges and cutouts. 

No other elements (standard wall, bend,...) are allowed.

 



Creating Swept Walls
 

This section explains and illustrates how to create and use various kinds of swept walls, i.e. walls based on a 
given profile that is swept along a spine.

Create a flange: select a spine, and set the radius, length, and angle values.

Create a hem: select a spine, and set the radius, and  length values.

Create a tear drop: select a spine, and set the radius, and  length values.

Create a swept flange: select a spine, and a user-defined profile

Selecting the Spine
Whatever the type of the swept wall you wish to create, you first need to select one or more contiguous edges 
to make up the spine along which the contour, either pre- or user-defined, is to be swept. You can:

●     manually select one, or more, edge(s)

Selection without propagation Resulting flange without propagation
    

●     select  one edge and click the Tangency Propagation button: all contiguous and tangent edges are 
selected. In this case, would you need to remove one edge, you need to manually select it. Remember that 
only extremity edges can be removed without breaking the continuity between edges.



Selection with propagation Resulting flange with propagation



Creating a Flange 

This task explains how to generate a flange from a spine and a profile.

For the Generative Sheetmetal Design workbench, open the NEWSweptWall01.CATPart document.

For the Aerospace SheetMetal Design workbench, open the Aero_SweptWall01.CATPart document.

1.  Select the Flange icon  in the Swept Walls sub-toolbar.

 

 The Flange Definition dialog box is displayed. 

 
Note that the image in the right-hand pane of the dialog box is updated as you choose your parameters and options, 

and provides a graphical explanation about the current selection.

 

By default, the icon which is pre-selected next to the Angle field corresponds to an acute angle  for the Generative 

Sheetmetal Design workbench, and to an obtuse angle  for the Aerospace SheetMetal Design workbench.

2.  Select the edge as shown in red.
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 The Spine field is updated with the selected edge.

●     You can use the Remove All button to remove the selected edge(s).

●     You can use the Propagate button to select all tangentially contiguous edges forming the spine.

The drop-down list offers two choices: 

●     Basic: the flange is created along the whole support.

●     Relimited: the flange is created within limits you define on the support (points, for example). 

3.  Leave Basic selected. 

Selecting Relimited updates the dialog with two new fields (Limit 1 and Limit 2) to let you specify the flange limits. You can 
then select as the limits two points, two planar faces, a point and a planar face, or a point and a vertex, as shown below, for 
example. Note that right-clicking in the Limit 1 and Limit 2 fields lets you create the limits (points, plane) or choose the X, Y 
or Z plane on-the-fly.

 
 



 
4.  Choose the flange parameters:

●     Enter 15mm in the Length field. Use the icons  next to the field to specify the type of 

length. Note that the length is always computed using the lowest external point of the flange.

●     Enter 45deg in the Angle field. Use the icons next to the field to specify whether the angle is acute  or 

obtuse .

●     Enter 2mm in the Radius field.

 
5.  Check the Trim Support option to trim the selected edge.

●     The Trim Support option only works in the case of a planar support.

●     You cannot select Relimited and Trim Support at once. Indeed, lateral cuts in the sheet metal part are currently not 
supported when the support is trimmed (i.e. the flange must be created from one edge of the sheet metal part to the 
other). 

 
6.  Click the Reverse Direction button to reverse the direction of the flange.

7.  Click the Invert Material Side button to invert the material side. (This option is only available when the Trim Support 

option is checked, otherwise it is deactivated.)

8.  Click the More button to display the Bend Allowance tab allowing you to locally redefine the bend allowance settings. 

You may need to deactivate the formula using the contextual menu on the field and choosing Formula -> Deactivate 

before editing the value.



 

In this case, the new K Factor value overrides the value set in the Sheet Metal Parameters.

A preview of the flange to be created is displayed in the geometry area.

 

9.  When you are satisfied with the result, click OK to create the flange. The flange is created and the feature is added to 

the specification tree.
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Creating a Hem

This task explains how to generate a hem from a spine and a profile.

The NEWSweptWall01.CATPart document is still open from the previous task.
If not, open the NEWSweptWall02.CATPart document from the samples directory.

1.  Select the Hem icon  in the Swept 

Walls sub-toolbar.

The Hem Definition dialog box opens.

 
Note that the image in the right-hand pane of the dialog box is updated as you choose your parameters and 

options, and provides a graphical explanation about the current selection.

2.  Select the edge as shown.

 The Spine field is updated with the selected edge.
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●     You can use the Remove All button to remove the selected edge(s).

●     You can use the Propagate button to select all tangentially contiguous edges forming the spine.

The drop-down list offers two choices: 

●     Basic: the hem is created along the whole support.

●     Relimited: the hem is created within limits you define on the support (points, for example). 

3.  Leave Basic selected. 

Selecting Relimited updates the dialog with two new fields (Limit 1 and Limit 2) to let you specify the hem limits. You 
can then select as the limits two points, two planar faces, a point and a planar face, or a point and a vertex, for 
example. Note that right-clicking in the Limit 1 and Limit 2 fields lets you create the limits (points, plane) or choose the 
X, Y or Z plane on-the-fly.

 

4.  Enter 3mm in the Length field, and 2mm in the Radius field.

5.  Check the Trim Support option to trim the selected edge.

●     The Trim Support option only works in the case of a planar support.

●     You cannot select Relimited and Trim Support at once. Indeed, lateral cuts in the sheet metal part are currently not 
supported when the support is trimmed (i.e. the hem must be created from one edge of the sheet metal part to the 
other). 

6.  Click the Reverse Direction button to reverse the direction of the hem.

7.  Click the More button to display the Bend Allowance tab allowing you to locally redefine the bend allowance 

settings. 

You may need to deactivate the formula using the contextual menu on the field and choosing Formula -> 

Deactivate before editing the value.



In this case, the new K Factor value overrides the value set in the Sheet Metal Parameters.

A preview of the hem to be created is displayed in the geometry area.

 

8.  When you are satisfied with the result, click OK to create the hem. The hem is created and the feature is added to 

the specification tree.
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Creating a Tear Drop

This task explains how to generate a tear drop from a spine and a profile.

The NEWSweptWall01.CATPart document is still open from the previous task.
If not, open the NEWSweptWall03.CATPart document from the samples directory.

1.  Select the Tear Drop icon  in the 

Swept Walls sub-toolbar.

The Tear Drop Definition dialog box 
opens.

 
Note that the image in the right-hand pane of the dialog box is updated as you choose your parameters and 

options, and provides a graphical explanation about the current selection.

2.  Select the edge as shown in red.

 The Spine field is updated with the selected edge.
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●     You can use the Remove All button to remove the selected edge(s).

●     You can use the Propagate button to select all tangentially contiguous edges forming the spine.

The drop-down list offers two choices: 

●     Basic: the tear drop is created along the whole support.

●     Relimited: the tear drop is created within limits you define on the support (points, for example). 

3.  Leave Basic selected. 

Selecting Relimited updates the dialog with two new fields (Limit 1 and Limit 2) to let you specify the tear drop limits. 
You can then select as the limits two points, two planar faces, a point and a planar face, or a point and a vertex, for 
example. Note that right-clicking in the Limit 1 and Limit 2 fields lets you create the limits (points, plane) or choose the 
X, Y or Z plane on-the-fly.

 
 

4.  Enter 8mm in the Length field, and 3mm in the Radius field.

5.  Check the Trim Support option to trim the selected edge.

●     The Trim Support option only works in the case of a planar support.

●     You cannot select Relimited and Trim Support at once. Indeed, lateral cuts in the sheet metal part are currently not 
supported when the support is trimmed (i.e. the tear drop must be created from one edge of the sheet metal part to 
the other). 

 
6.  Click the Reverse Direction button to reverse the direction of the tear drop.

7.  Click the More>> button to display the Bend Allowance tab allowing you to locally redefine the bend allowance 

settings. 

You may need to deactivate the formula using the contextual menu on the field and choosing Formula -> 

Deactivate before editing the value.



In this case, the new K Factor value overrides the value set in the Sheet Metal Parameters.

A preview of the tear drop to be created is displayed in the geometry area.

 

8.  When you are satisfied with the result, click OK to create the tear drop. The tear drop is created and the feature is 

added to the specification tree.
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Creating a User Flange 

This task explains how to generate a user flange from a spine and a user-defined profile.

The NEWSweptWall01.CATPart document is still open from the previous task.
If not, open the NEWSweptWall04.CATPart document from the samples directory. As a profile is already 
defined on the part, you will be able to skip step 2 of the scenario.

1.  Select the User Flange icon in the Swept Walls sub-toolbar.
 

The User Defined Flange Definition dialog box opens. 

 

 2.  If you are using the NEWSweptWall01.CATPart document, click the Sketcher icon , and 

define a profile in the yz plane as shown below:
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Then quit the Sketcher, using the Exit icon .

If you are using the NEWSweptWall04.CATPart, go directly to step 3 as the profile is already 

defined.

3.  Select the edge and the profile, as shown in red.

4.  Click the More button to display the Bend Allowance tab allowing you to locally redefine the 

bend allowance settings. 

You may need to deactivate the formula using the contextual menu on the K Factor field and 

choosing Formula -> Deactivate before editing the value.
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In this case, the new K Factor value overrides the value set in the Sheet Metal Parameters.

5.  Click OK to create the user flange.

The feature is added in the specification tree.

●     Use the Remove All button to remove the selected edge(s).

●     Use the Propagate button to select all tangentially contiguous edges forming the spine.
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As far as the profile is concerned, remember that:
●     There must be a tangency continuity with the edge on which the flange is created,

●     The plane must be normal to the spine.

 



Aggregating Bodies
 

This task shows you, when creating a bend, to aggregate, under the current body containing a wall, the 
created bend as well as the body containing the second wall.

Open the NEWBendExtremities03.CATPart document.

 
This capability is available with the Bend and Bend From Flat functionalities.
Let's take an example with the Bend.

1.  In the specification tree, define Wall.2 (in 

Body.1) as current: right-click and select 

Define In Work Object from the contextual 

menu.

 

 

2.  Select the Bend icon .

The Bend Definition dialog box opens.
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3.  Select Wall.2 and Wall.3 in the specification 

tree.

The Bend Definition dialog box is updated.

 

4.  Click Preview to visualize the bend.

5.  Click OK in the Bend Definition dialog box.

 

The Bend (identified as Cylindrical Bend.x) is created 

and added to the specification tree. 

You can see that it appears under the Body.1 node 

and aggregates Body.2 containing Wall.3.



You can perform the same operation by defining PartBody as the current object and selecting Wall.1 and 
Wall.2 as inputs. PartBody contains the cylindrical bend, that aggregates Body.1 (itself containing 
Wall.2).



    Creating a Hopper
This task illustrates how to create a surfacic and a canonic hopper between two sketched profiles, with an opening line (for 
unfolding operations) defined by an edge for surfacic hoppers or two points for canonic hoppers. 

Open the NEWHopper01.CATPart document. This document contains two sketches, as well as a point on each sketch.

Surfacic hopper
  

Surfacic hoppers are defined by a ruled surface selected by the user or created thanks to the loft command. Defining a surfacic 
hopper via a loft is highly recommended since it allows detection of all canonical segments. 

The two sketches used to define the loft can be on parallel or non parallel planes. 

The reference wire and the invariant point, used to unfold the hopper, must lie on the surface, as well as the tear wire. 

1.  Click the Hopper icon . The Hopper dialog box is displayed. 

 

2.  Right-click on No selection field and select Create Multi-sections surface.
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The Multi-sections Surface Definition dialog box is displayed.

3.  Select Sketch.1 and Sketch.2 in the specification tree as surfaces.

4.  Click on the Coupling tab and start coupling sketches together.

You should end up with eight couplings.



 

5.  Click on Preview if you want to visualize the loft, then on OK.

6.  Select a reference wire lying on the surface of the hopper.

In our example, we select an edge.

 

7.  Select an invariant point lying both on the surface and on the reference wire.

A preview of the unfolded hopper is displayed, as well as its thickening in light blue.



 

8.  Select a tear wire. 

In our example, we select the same edge as the reference wire.

The unfolded view of the hopper starting from the tear wire is displayed.



 

 

 

●     The surface must be ruled otherwise you will not be able to create a hopper.

●     If you want to modify your selections in the Hopper dialog box, you can right-click in the field and select Clear selection in the 
contextual menu.

 
9.  Click OK to validate and exit the dialog box. The hopper is created.



 

 

10.  If you now click the Unfold icon , the hopper is unfolded as follows:

 

 



You can modify the hopper you are creating thanks to the options available in the Hopper dialog box.

●     Invert material side: the red arrow indicates the direction for thickening the hopper. You can change the thickening direction 

by clicking either this red arrow or the Invert material side button.

●     Neutral fiber: the selected input surface is considered to be the hopper neutral fiber. This option proves to be useful when the 

offset input surface is not ruled.

●     Reference wire: is an edge lying on the surface or a curve.

When you right-click on the Reference Wire field, you can select other types of reference wires.

❍     Create line

❍     Create Intersection

❍     Create Projection 

❍     Create Extract

●     Invariant point: point lying on the surface and the reference wire.

When you right-click on the Invariant point field, you can create you own invariant point.

●     Invert fixed side: the green arrow indicates the fixed side for unfolding: the hopper may be unfolded from the side opposite to 

the arrow. You can change the unfolding direction by clicking either this green arrow or the Invert fixed side button.

●     Tear wire: defines the opening line. It can be a curve going through the surface or several edges.

 

Canonic hopper
  

Canonic hoppers can be conical, cylindrical or planar. Their defining sketches can be on parallel planes when creating a canonical 
hopper. They may be open or closed; they should have similar shapes, and should be composed of arcs of circles and straight 
segments. For each segment or arc in a sketch, there should be a corresponding segment or arc in the other sketch. In the case of 
arcs, the projection of their centers onto the other sketch plane must match. 

To sum up, each edge in a sketch must be an offset from a corresponding edge in the other sketch so that the resulting hopper 
may be conical, cylindrical or planar. 

The two points defining the opening line (one point on each sketch) must have been created explicitly prior to creating the hopper. 
Each point should lie on a corresponding segment.

1.  Click the Hopper icon . Select Canonic hopper in the Hopper dialog box that is displayed. 

 



2.  Select Sketch.1 as the first profile, either from the geometry area or from the specification tree. 

3.  Select Sketch.2 as the second profile.

4.  Select Sketch.3 as the first point for the opening line. 

5.  Select Sketch.4 as the second point for the opening line. 

Note that the first point of the opening must be on the first profile, and the second point must be on the second 
profile. 

A preview of the hopper is displayed. You can notice two arrows starting from the first point.

 

 

❍     The green arrow indicates the fixed side for unfolding: the hopper may be unfolded from the side opposite to the arrow. 
You can change the unfolding direction by clicking either this green arrow or the Invert fixed side button.

❍     The red arrow indicates the direction for thickening the hopper. You can change the thickening direction by clicking 
either this red arrow or the Invert material side button.

  

6.  Click OK to validate and exit the dialog box. The hopper is created.

 



  

7.  If you now click the Unfold icon , the hopper is unfolded as follows:

 

  



Unfolding
Unfolded Sheet Metal parts can be displayed in two ways:

Folded/Unfolded View Access
Concurrent Access

 
Each Sheet Metal feature is created in a given view: folded, or unfolded. Editing a feature must be done 
in its definition view. If not, a message is automatically issued, prompting you to change views, before 
editing the feature.
 

 



Folded/Unfolded View Access

This task shows how to unfold the part. 

To perform this scenario, you can open any sheet metal sample provided in this user's guide.

1.  Click the Unfold icon .

The part is unfolded according to the reference wall plane or web, as shown below. 

2.  Click this icon  again to refold the part for the next task.

●     In SheetMetal Design, bend limits and stamping are now displayed in the unfolded view. However, 

cutouts created on stamps are not.

●     When designing in context, if a CATProduct document contains several sheet metal parts, only one 
part can be visualized in the unfolded view at a time.



Concurrent Access

This functionality is P2 for SheetMetal Design.

To perform this scenario, you can open any sheet metal sample provided in this user's guide.

This task explains how to display the sheet metal part in two windows: one with the folded view, one with the unfolded 
view. Any modification in one window is displayed in the other window.

1.  Click the Multi-view icon .

The part is unfolded in a second window.  

2.  Choose the Window -> Tile Horizontally menu item.

Both windows are tiled. Activate the window in which you want to work. 



●     Any modification in one view is taken into account in the other view enabling the user to make modifications in the 
best possible context.

●     In the multi-view mode as in the standard unfolded view, all constraints are displayed in the geometrical views.

●     Once in the Multi-view mode, the standard icon Unfold is not longer available.

●     The Multi-view function is not available from a standard unfolded view.

●     Only parts with bends can be unfolded.

●     Cutting faces and open faces are not displayed in Multi-view mode (SheetMetal Design)



Creating a Hole

This task shows you how to create a hole, that consists in removing material from a body.

Open the Hole1.CATPart document.

1.  Click the Hole icon .

The Hole definition dialog box opens.

2.  Select the Point that will be the center of the hole.

It can be either a sketch containing one or more points, or a point, or several points. The points 

must be on the same support.

●     The point can be selected anywhere in the geometry, not necessarily on a surface. In that case, an 
orthogonal projection will be performed.

●     You can also directly click the surface: a point will be created under the pointer. 

●     To deselect a point, click it in the specification tree. 

3.  Select the Support object where the hole will be positioned.

●     The support can be different from the support where the point lies. In that case, an orthogonal 
projection will be performed.
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The hole is previewed with default 
parameters.

4.  Define the value for the diameter of the hole in the Diameter field.

If you change the Diameter value using the spinners, the preview of the hole automatically updates. 
However, if you enter a value directly in the field, you need to click the Apply button to update the 
preview.

5.  Click OK to validate.

The hole (identified as Hole.xxx) is created and the specification tree is updated accordingly.

Holes can be created on the unfolded parts and on bends.

For have further information on standard files, refer to the Customizing section.



Creating a Cutout

This task explains how to create a cutout in a wall.
Creating a cutout consists in extruding a profile and removing the material resulting from the extrusion.

Open the NEWCutout1.CATPart document.

1.  Click the Cutout icon .

The Cutout Definition dialog box is displayed and the skin to be impacted by the cutout is displayed in a different color.

 

     

2.  Select a profile (sketch.3 in our example).

A preview of the projected cutout is displayed.

 
Once the sketch is selected, you can modify it by clicking the Sketcher icon .

●     The Reverse Side option lets you choose between removing the material defined within the profile, which is the application's default 

behavior, or the material surrounding the profile. 

●     The Reverse Direction option allows you to invert the direction of the extrusion pointed by the arrow.

3.  Click OK in the Cutout Definition dialog box.

The cutout is created. 
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Several end limit types are available: 

●     Up to next: the limit is the first face the application detects while extruding the profile. This face must stops the whole extrusion, not 

only a portion of it, and the hole goes through material.

●     Up to last: the last face encountered by the extrusion is going to limit the cutout.

●     Dimension: the cutout depth is defined by the specified value.

4.  In the specification tree, double click on Cut Out.1 to display the Cutout Definition dialog box.

5.  Click More>> to display the maximum information.



Here the Cutout's impacted skin is set to Default, that is, the surface on which lies Sketch.3

7.  Click on  and select the support for the cutout.

The Support Selection dialog box is displayed.

8.  Select Wall.1 as your new support for the cutout.

9.  Close the Support Selection dialog box and click OK in the Cutout Definition dialog box.

The cutout is created on Wall.1. 

Specifying the support for the cutout avoid confusions in case of overlaps.

For instance, if you try to create a cutout on the part below, the following message is displayed:

To avoid this, you have to select the exact support for the cutout.



 

 
●     When Lying on skin is checked, 

❍     The End limit and Start limit types are automatically set to Dimension and disabled,

❍     The Depth is set to 0mm and disabled,

❍     The skin to be impacted is displayed on the part.

The cutout is not projected anymore on the skin. It is based on a sketch that inevitably lies on a surface.

This option is available only when creating a standard cutout.

In case the prism resulting from the cutout's profile and direction is tangent to the impacted skin, the projection is non-
valid and the cutout cannot be created.

To avoid this, check Lying on skin or select a wall as support to be able to create your cutout.

 
Open the NEWCutout1.CATPart document again.

1.  Click the Cutout icon .

2.  Select Sheetmetal pocket as Cutout type in the combo 

box.

The skin to be impacted remains grey and the End limit type 

is disabled.

3.  Set the Depth to 1mm.

4.  Select Sketch.3 as profile.

A preview of the cutout is displayed. In our example, the 

cutout will impact only half the wall.
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5.  Click OK in the Cutout Definition dialog box.

The cutout is created. 

 

4.  In the specification tree, double click on Cut Out.1 to display the Cutout Definition dialog box.

5.  Click More>> to display the maximum information.

The Direction is already selected (Sketch.3). By default, it is set as 

normal to the profile.

 

7.  Uncheck Normal to profile.

8.  In the Reference field, right-click on Sketch.3 and select Create line. 

9.  Select the line to perform a cutout normal to the line direction. 



 

10.  Click on OK to create the cutout normal to the line direction.

●     The pocket cutout can be created only on a planar and monosupport surface (i.e. a wall or the planar face of a flange).

●     May you want to create a cutout on an overlapping element or a bend with radius=0, either choose the top skin of the element (as 
shown in the picture above), or unfold the part to create the cutout.

●     You cannot create a pocket cutout on a stamp or a surfacic flange.

●     You cannot create 
❍     a standard cutout on a pocket cutout 

❍     a standard cutout on a feature impacting a pocket cutout.

●     You can create
❍     a pocket cutout on a standard cutout.

❍      a pocket cutout on a pocket cutout,



 

 

You can use the Catalog icon  to open the Catalog Browser.

●     Refer to the Component Catalog Editor documentation to have further information on how to use catalogs.

●     Refer to the Create a Pocket task in the Part Design User's Guide for further details on how to create cutouts.
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Stamping
This section explains and illustrates how to create and use various kinds of stamps.

●     Stamps must be created on walls, or walls on edge, except for the stiffness rib that is to be created 
on a bend. 

●     If a stamp is created over the limit between several supports, such as walls, bends, and so forth, this 
stamp is not visible on the unfolded view.

●     When unfolding a part, only the largest imprint of the stamp is retained on the stamped wall.

●     Stamps cannot be created on an unfolded part.

Creating Standard Stamping Features
Recognizing Stamping Features

Creating User-Defined Stamping Features
 



Creating Standard Stamping Features
 

This section explains and illustrates how to create and use various kinds of stamps.
The table below lists the information you will find.

Create a flanged hole: select a point on a face, and set the stamping parameters. 

Create a bead: select a profile, and set the stamping parameters. 

Create a circular stamp: select a point on a face, and set the stamping parameters. 

Create a surface stamp: select a sketch, and set the stamping parameters. 

Create a bridge: select a point on a face, set the stamping parameters, and select an edge to give the 
bridge orientation. 
Create a flanged cutout: select a profile, and set the stamping parameters. 

Create a stiffening rib: select the external surface of a bend, and set the stamping parameters. 

Create a curve stamp: select a sketch, and set the stamping parameters. 

Create a louver: select a sketch, an opening line and set the stamping parameters. 



Creating a Flanged Hole

This task shows you how to create a flanged hole by specifying the punch geometrical parameters.

For the Generative Sheetmetal Design workbench, open the NEWStamping.CATPart document.
For the Aerospace SheetMetal Design workbench, open the Aero_Stamping.CATPart document.

1.  Click the Flanged Hole icon .

2.  Click the surface where you want to place the hole.

A grid  is displayed to help you position the flanged hole.

 

 The Flanged Hole Definition dialog box is displayed, providing default values. 
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Note that the image in the right-hand pane of the dialog box is updated as you choose your parameters and 

options, and provides a graphical explanation about the current selection.

Also note that the options available in the dialog box are updated according to the items selected in the 

Definition Type area.

 

 
3.  Choose the diameter that should be dimensioned from the Parameters choice list:

❍     Major Diameter

❍     Minor Diameter

❍     Two Diameters (major and minor diameters)

❍     Punch & Die

4.  Specify whether the flanged hole should be created without a cone (i.e. only with the filleted portion of the 

flanged hole) or with a cone (i.e. with the filleted portion of the flanged hole and with a cone). 



Note that selecting the Without cone option has the following consequences:

●     The Height H field is disabled, the height being automatically computed in this case.

●     Deactivating the Radius field is impossible, because the radius value for the flanged hole external 

curvature must be specified in this case.

5.  If you want to use a standard, click the Standard File button and browse to select a standard file. In this 

case, the standard parameters will be used, and you do not need to specify the flanged hole parameters. You 

can skip the next step.

6.  Choose the flanged hole parameters:

●     In the Height H field, specify the height value for the flanged hole. Use the icon next to the field to 

specify the reference from which the height is defined:  or .

●     In the Radius R field, specify the radius value for the flanged hole external curvature. Use the icon next 

to the field to disable this option.

●     In the Angle A field, specify the angle value for the flanged hole. 

This option is not available for the Two Diameters or Punch & Die parameters, as the 

angle is automatically computed in these cases.

●     In the Diameter D field, specify the major diameter value for the flanged hole. 

This option is not available for the Minor Diameter parameter, as the major diameter is automatically 

computed in this case.

●     In the Diameter d field, specify the minor diameter value for the flanged hole.

This option is not available for the Major Diameter parameter, as the minor diameter is automatically 

computed in this case.



7.  Click Preview to visualize the flanged hole.

8.  Click OK to validate. 

The flanged hole (identified as Flanged Hole.xxx) is created and the specification tree is 

updated accordingly.

 Flanged hole viewed from the front

 



 Flanged hole viewed from the back

Refer to the Customizing Standard Files chapter for more information about defining the Standards Files.



Creating a Bead

This task shows you how to create a bead, that is a local deformation in the web.

Open the NEWStamping6.CATPart document.
If you use the Aerospace SheetMetal Design workbench, open the Aero_Stamping6.CATPart document.

1.  Click the Bead icon .

2.  Select the spine 

profile where you 

want to place the 

bead.

The Bead 

definition dialog 

box is 

displayed, 

providing 

default values.

3.  Change the value in the different fields, if needed:

●     Height H

●     Radius R

●     Section Radius R1 (corresponding to the cross section value)

●     End Radius R2

The Sketch is automatically set to the sketch you chose.
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The vector for the 
direction of the bead is 
shown in the model and a 
preview of the bead 
appears and a vector 
shows its direction.

4.  Click Preview to visualize the bead.

5.  Click OK to validate.

The bead (identified as Bead.xxx) is created and the specification tree is updated accordingly.

The vector cannot be reverted until the bead spine is defined.

You can use 0 as the Radius value to deactivate the Radius R value, and to create the bead without a 
fillet.

Please refer to the Customizing Standard Files chapter to define the Standards Files.



Creating a Circular Stamp

This task shows you how to create a point stamp by specifying the punch geometrical parameters.

Open the NEWStamping.CATPart document from the samples directory.
If you use the Aerospace SheetMetal Design workbench, open the Aero_Stamping.CATPart document.
 
You have now the choice between several parameters to dimension the diameter of your circular stamp.

1.  Click the Circular Stamp icon .

2.  Select a point on the top face. 

A grid is displayed to help you position the circular 
stamp.

The Circular Stamp Definition dialog box opens, providing default values.

3.  Choose the diameter that should be dimensioned from 

the Parameters choice list:

❍     Major Diameter

❍     Minor Diameter

❍     Two Diameters (major and minor diameters)

❍     Punch & Die

4.  Change the value in the different fields, if needed:

●     Height H: use the icon next to the field to 

specify the reference from which the height is 

defined:  or .

●     Radius R1

●     Radius R2

●     Angle A

●     Diameter D
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4.  Click Preview to visualize the circular stamp.

 
5.  Click OK to validate.

The circular stamp (identified as Circular Stamp.xxx) is created and the specification tree is updated accordingly.

 

To create the point stamp without a fillet, unselect the Radius 
R1 and Radius R2 checkbox in the Circular Stamp Definition 
dialog box.

Please refer to the Customizing Standard Files chapter to define the Standards Files.



Creating a Surface Stamp

This task shows you how to create a surface stamp by specifying the punch geometrical parameters.

Open the NEWStamping4.CATPart document from the samples directory.

If you use the Aerospace SheetMetal Design workbench, open the Aero_Stamping4.CATPart document.

Stamps can be based on different types of profile:
●     a profile containing a sketch with several inner contours

●     a profile containing a 3D curve sketch

●     a profile containing a punch and die sketch intersecting with the part

You can now apply parameters, such as height, radius, angle etc. on the top or on the bottom of the surface stamp: 

●     When selecting , parameters are applied to the top of the surface stamp 

●     When selecting , parameters are applied to the bottom of the surface stamp

You can now create Half pierce stamps. For more information, refer to the Creating a Half Pierce Stamp section.

1.  Click the Surface Stamp icon .

2.  In the specification tree, select Sketch-for-Surface-Stamp, the profile previously defined. 

The Surface Stamp Definition dialog box opens, providing default values. 

3.  Change the value in the different fields, if needed.

In our example, we chose the following values:

●     Height H: 4mm

●     Radius R1: 2mm

●     Radius R2: 2mm

●     Angle A: 90deg
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4.  Click in the Opening Edges field and select a 

sketch's edge.

 

5.  Click Preview to visualize the surface stamp with 

an opening edge.

6.  Click OK to validate.

The surface stamp (identified as Surface Stamp.1) is created and the specification tree is updated accordingly.

 

You can disable Radius R1 and Radius R2 if you want to 
create the surface stamp without a fillet.

Now let's create a stamp of type 1 based on a profile containing several inner contours: one stamp in a direction and other stamps in 
opposite direction.

1.  Click the Surface Stamp icon .

 



2.  In the specification tree, select Sketch-multicontour-type1

The Surface Stamp Definition dialog box opens.

3.  Select Angle as Definition type and the first type of stamp 

 

4.  Change the value in the different fields, if needed.

In our example, we chose the following values:

●     Height H: 10mm

●     Radius R1: 1mm

●     Radius R2: 1mm

●     Angle A: 90deg

5.  Click Preview to visualize the surface stamp.

 

6.  Click OK to validate.

The surface stamp with several inner contour (identified as Surface Stamp.2) is created and the specification tree is updated 

accordingly.

Now, let's create another stamp based on a profile containing several inner contours of type 2.

1.  Click the Surface Stamp icon .

2.  In the specification tree, select Sketch-multicontour-type2

The Surface Stamp Definition dialog box opens. 

3.  Select Angle as Definition type and the second type of stamp 



4.  Change the value in the different fields, if needed.

In our example, we chose the following values:

●     Height H: 13mm

●     Radius R1: disabled

●     Radius R2: disabled

●     Angle A: 60deg

5.  Click Preview to visualize the surface stamp.

6.  Click OK to validate.

The surface stamp with several inner contour (identified as Surface Stamp.3) is created and the specification tree is updated 

accordingly.

 

Now, let's create a stamp based on a profile containing 2 contours (one inside the other)

1.  Click the Surface Stamp icon .

 

2.  In the specification tree, select Sketch-punch&die

The Surface Stamp Definition dialog box opens. 

 

3.  Select Punch and Die as Definition type.

When Punch and Die is selected, only the second type of stamp is enabled 



4.  Change the value in the different fields, if needed.

In our example, we chose the following values:

●     Height H: 13mm

●     Radius R1: disabled

●     Radius R2: disabled

●     Angle A: disabled

5.  Click Preview to visualize the surface stamp.

 

6.  Click OK to validate.

The surface stamp with two contours (identified as Surface Stamp.4) is created and the specification tree is updated accordingly.

Each punch edge must be parallel to the corresponding 
die edge.

Now, let's create a stamp based on a profile containing a 3D curve.

To do this, open the XXX.CATPart document from the samples directory.
If you use the Aerospace SheetMetal Design workbench, open the XXX.CATPart document.

1.  Click the Surface Stamp icon .

 



2.  In the specification tree, select Folded curve.1.

The Surface Stamp Definition dialog box opens. 

Make sure that Angle is selected as parameter, as well as the first type of stamp.

 

3.  Change the value in the different fields, if needed:

●     Height H:20mm

●     Radius R1: 2mm

●     Radius R2: 2mm

●     Angle A: 90deg

4.  Click Preview to visualize the surface stamp.

 

5.  Click OK to validate.

The surface stamp with a 3D curve profile (identified as Surface Stamp.xxx) is created and the specification tree is updated 

accordingly.

You can also create a stamp based on a 3D multicurve 
profile.

For instance, you can create a surface stamp based on 
the Folded curve.5 and obtain the following result:

Avoid as much as possible a coincidence between the edge of the sketch profile and the edge of the wall. Instead, let the sketch profile 
exceed the edge of the wall.

Insert a screen capture

 



Creating a Bridge

This task shows you how to create a bridge by specifying the punch geometrical parameters.

Open the NEWStamping5.CATPart document from the samples directory.

1.  Click the Bridge icon .

2.  Select a point on the top face where you want to place the bridge.

The Bridge Definition dialog box opens, providing default values. 

3.  Change the value in the different fields, if 

needed:

●     Height H

●     Radius R1

●     Radius R2

●     Angle A

●     Length L1

●     Length L2

4.  Select an edge to give the direction of the bridge.
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5.  Click Preview to visualize the bridge.

 
6.  Click OK to validate.

The bridge (identified as Bridge.xxx) is created and the specification tree is updated accordingly.

 

You can use 0 as the Radius value to deactivate the 
Radius R value, and to create the bridge without a fillet.

Please refer to the Customizing Standard Files chapter to define the Standards Files.
 



Creating a Flanged Cutout

This task shows you how to create a flanged cutout by specifying the punch geometrical parameters.

Open the NEWStamping8.CATPart document.
If you use the Aerospace SheetMetal Design workbench, open the Aero_Stamping8.CATPart document.

1.  Click the Flanged Cutout icon . 

2.  Select a profile. 

The Flanged Cutout Definition dialog box is displayed, providing default values.
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3.  Change the value in the different fields, if needed:

●     Height H

●     Radius R

●     Angle A

 
4.  Click Preview to visualize the flanged cutout. 

 

 
5.  Click OK to validate. 

The flanged cutout (identified as Flanged Cutout.xxx) is created and the specification tree is updated 

accordingly.

 



 

You can use 0 as the Radius value to deactivate the Radius R value, and to create the flanged cutout 
without a fillet.

 

 Note that if you create a flanged cutout from a sketch that is not tangent continuous, you cannot 
design any other feature on it (such as bend, cutout, hole).

Please refer to the Customizing Standard Files chapter to define the Standards Files.



Creating a Stiffening Rib

This task shows you how to create a stiffness rib by specifying the punch geometrical parameters.

Open the NEWStamping7.CATPart document from the samples directory.

 If you use the Aerospace SheetMetal Design workbench, open the Aero_Stamping7.CATPart document.

1.  Click the Stiffening Rib icon .

2.  Select the external surface of Bend.1, where you want to place a stiffener.

Note that the stiffener will always be centered on the bend radius, wherever the point may be along the curve.

A grid is displayed.

The Stiffening Rib Definition dialog box opens, providing default  values.

3.  Change the value in the different fields, if 

needed:

●     Length L

●     Radius R1

●     Radius R2

●     Angle A

4.  Click Preview to visualize the stiffness rib.

5.  Click OK to validate.

The stiffening rib (identified as Stiffnening Rib.xxx) is created and the specification tree is updated accordingly.
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You can use 0 as the Radius value to deactivate the 
Radius R1 value, and to create the stiffening rib 
without a fillet.

Please refer to the Customizing Standard Files chapter to define the Standards Files.



Creating a Curve Stamp

This task shows you how to create a curve stamp by specifying the punch geometrical parameters.

Open the NEWStamping3.CATPart document.
If you use the Aerospace SheetMetal Design workbench, open the Aero_Stamping3.CATPart document.

1.  Click the Curve Stamp icon .

2.  Select Sketch-for-Curve-Stamp, the curve previously defined. 

The Curve Stamp Definition dialog box opens, providing default values.

3.  Change the value in the different 

fields, if needed:

●     Height H: the total height

●     Radius R1: the outer bend 

radius

●     Radius R2: the inner bend 

radius

●     Angle A: the stamping draft 

angle 

●     Length L: the stamps' 

maximum width

4.  Click Preview to visualize the 

curve stamp.

5.  Click OK to validate.

The curve stamp (identified as Curve Stamp.xxx) is created and the specification tree is updated accordingly.
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●     You can use 0 as the Radius value to 
deactivate the Radius R and Radius R2 
values, and to create the curve stamp 
without a fillet.

●     Check the Obround option to round off the edges of the curve stamp.

 

Obround option checked Obround option unchecked

Please refer to the Customizing Standard Files chapter to define the Standards Files.

 



Creating a Louver 

This task shows you how to create a louver by specifying the punch geometrical parameters.

Open the NEWStamping11.CATPart document.

1.  Click the Louver icon .

2.  Select Sketch-for-Louver, a profile previously defined on Wall.2. The Louver Definition dialog box opens, providing default values.

The louver opening face is represented in the sketch by the element that does not present any tangency continuity with the other lines/curve 
segments of the sketch. In case there are several non-continuous elements, the first one is used as the opening face.

3.  Change the value in the different fields, if needed:

●     Height H

●     Radius R1

●     Radius R2

●     Angle A1

●     Angle A2

4.  Select an edge of the sketch as the Opening Line: it indicates the position of the opening face of the louver.

5.  Click Preview to visualize the louver.

6.  Click OK to validate.

The louver (identified as Louver.xxx) is created and the specification tree is updated accordingly.
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Recognizing Stamping Features

This task illustrates how to recognize a stamp geometry in order to create a Generative Sheetmetal 
Design stamping feature provided it is on a planar and single support. 

Consequently, the following types of stamps can be recognized:

●     Circular stamp

●     Curve stamp

●     Surface stamp

●     Bead

●     Bridge

●     Louver

The recognize feature enables to create a Generative Sheetmetal Design stamping feature from a V4 
model or parts created with Sheetmetal Design.

 
The Part Feature Recognition license is required to activate this feature in the Generative Sheetmetal 
Design Workbench. 

Open the NEWRecognize03.CATPart document. This document contains a part created from a V4 model.

1.  Click the Recognize icon . The Recognize Definition dialog box is displayed. 

Note that the With Wall recognition option is already selected, and grayed out. This is because 
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at least walls will be recognized, regardless of the other options you may choose.

2.  Select a reference face. It will be the reference face for unfolding and for the definition of the 

sheet metal parameters (i.e. all default parameters will be based on this face).

3.  Select With stamps recognition and manually select all the faces to be recognized as stamps.

4.  Select the reference face as a face to be recognized as wall.



5.  Click OK to validate. 

The stamps are generated from the geometry. 

The Recognize.1 feature is added to the tree view. 

At the same time, the sheet metal parameters are created, deduced from the Part geometry.

6.  Select the Sheet Metal Parameters icon  to display the sheet metal parameters. 



 

On the Parameters tab:

❍     the Thickness is equal to 1.5mm,

❍     the Default Bend Radius value amounts to twice that of the thickness.

On the Bend Extremities tab:

❍     the bend extremities are set to Minimum with no relief.

You can modify a few of these parameters. The Thickness parameter cannot be modified 

because it is based, like the bend extremities and radius, on the initial solid geometry. However, 

you can modify other parameters (default bend radius and bend extremities) in order for them to 

be taken into account for sheet metal features other than the "recognized" ones.

The bend allowance, being used to unfold the part, and the bend corner relief affect all features, 

and therefore can be edited even for "recognized" features.

You can also define the sheet metal parameters prior to recognizing the part. In this case, you need to 
make sure that the Thickness parameter value corresponds to the part thickness.



6.  When all parameters have been redefined as needed, click OK in the Sheet Metal Parameters 

dialog box.

The solid is now a Generative Sheetmetal Design part. You can now deal with it as with any other 

Generative Sheetmetal Design part, adding Generative Sheetmetal Design features to complete 

the design, or unfolding it.

●     There is no stiffening rib recognition, since the support feature for the stamp must be planar.

●     Stamps containing inner contours such as flanged hole, flanged cutout cannot be recognized.



Creating User-Defined Stamping Features
Two user-defined stamping features are available: 

 Create a punch with a die:  define the punch and die features, select a wall, choose the punch and die as stamping elements, select 
an edge on the wall and give an angle for orientation purposes.

 Create a punch with opening faces:  define the punch, select a wall, define the opening faces of the punch, select an edge on the wall 
and give an angle for orientation purposes.

 Edit a user-defined stamp: double-click the existing stamp and change its type, or select, or remove cutting and opening faces

What You Should Know 

In both tasks illustrating either a stamp based on a punch and a die, or a punch with cutting and opening faces, the punch positioning is 
defined as below: 

Defining the Punch in Relation to the Wall to be Stamped

The punch is defined within the absolute (default) axis-
system of the .CATPart document. (o, x, y, z) is the 
axis associated with the punch. The punching direction 
on the punch (Dp) must be equal to z.

The punching direction on the wall (Dw) is normal to 
the selected wall face, and is oriented from the selected 
wall face towards the opposite face.

The punch is applied matching Dp on Dw and matching the punch's (x, y) plane onto the selected wall face:



Defining the Die in Relation to the Wall to be Stamped

This is useful only when defining a punch a die, and does not apply to punches with cutting and opening faces.

The die is also defined within the absolute (default) axis-
system of the .CATPart document. (o, x, y, z) is the 
axis associated with the punch. The punching direction 
on the die (Dd) must be equal to z. 

The illustration is a section view of the die.

The die is applied matching Dd on Dw and matching the die's (x, y) plane onto the selected wall face:

 



Creating a Punch with a Die

This task explains how to create a stamp from punch and die features. 

First, you will define a punch and a die in Part Design, in the absolute axis-system.
Then, in a Sheet Metal part, you will bring the punch and the die features (and their axis system) to a point you have selected. If necessary, you will 
define a rotation of the axis system from a reference line.

You can also position the stamp according to the punch and die features positioning and direction thanks to the On context option. 

This user-defined stamping cannot be combined with the Opening and Cutting Faces approach.

All .CATParts are available from the samples directory (PunchDie1.CATPart, Punch1.CATPart and Die1.CATPart or NEWPunchDie1.CATPart, 
NEWPunch1.CATPart and NEWDie1.CATPart for Generative Sheetmetal Design or Aero_PunchDie1.CATPart, Aero_Punch1.CATPart and 
Aero_Die1.CATPart for Aerospace Sheetmetal Design).

1.  Start the Part Design application.

2.  Insert a PartBody (menu Insert -> Body) to define the punch.

3.  Enter the sketcher  select the yz plane, 

and draw the profile of the punch, and a 

rotation shaft.

 

The punch must be oriented as described 
in Defining the Punch in Relation to the 
base feature to be Stamped.

4.  Return to the 3D space and create the punch 

using the Shaft icon .

5.  Repeat from step 2 to step 4 to define the die, making sure that it is oriented as described in Defining the Die in Relation to the base feature 

to be Stamped.
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6.  Return to the Sheet Metal application, and if needed, use the Define In Work Object on the PartBody containing the wall or the base feature 

to be stamped.

7.  Click the User Stamping icon  from the Stamping tool bar and select a base feature, or a face where the stamping is to be created. 

This base feature or face is used to define the stamping location and direction, by matching the punch's origin to the selected point on the 

base feature.

The User Defined Stamp Definition dialog box is displayed:

8.  Make sure the With die  icon is pressed 

down and select the Punch feature from the 

specification tree.

The punch's positioning is previewed in the 

geometry.

9.  Select the Die feature. 

The die's positioning is previewed in the 

geometry as well.



10.  Check the No Fillet button is you do not wish the stamp to be filleted, or set the radius value if you wish the stamp to be filleted. 

Stamp without fillet Stamp with fillet

11.  If needed, define the stamp's positioning on the selected base feature by choosing:

●     a Reference for rotation: by default, it is the sketch axis, but you can also select any line or edge on base feature.

●     a Rotation angle value: you can either enter a value in the dialog box, or use the manipulator in the geometry to define this value.

●     a new Origin point on the base feature to coincide with the punch's point of origin.

This is especially useful for non-circular stamps, but you can very well create the stamp as is, without further positioning.

12.  If needed, select the In Context check box.

The punch and die's positioning is previewed on the geometry.

 

When selecting the On Context check box, the stamp's positioning and direction are not defined in relation to the base feature anymore.

Only the punch and die's axis system is taken into account and the stamp is created according to their positioning and direction. 
Once On Context is selected, the position on wall cannot be modified nor the direction of the stamp: the fields available in Position on wall section 
and the Reverse direction button are disabled.

13.  Click OK to validate and create the stamping.

By default the Punch and Die parts are set in No Show mode when clicking OK to create the stamp on the base feature. 



●     Radius is the radius of the bend between the stamping and the base feature.

●     Punch and Die are the bodies you have defined previously. If the punch and the die are in another CATPart document, activate this document 
before clicking the punch or the die.

●     If you select two reference lines in addition to the plane, this will create two editable constraints to position the stamping. These constraints are 
editable.

 
●     A user-defined stamping can be edited (punch, die, position, constraints).

●     As the punch and die are not symmetrical, you cannot create such features as a cutout, a hole, a corner, etc., on this kind of stamping.

●     If you enter a punch and a die, the stamping is 
the difference of the shape of both features.

 

●     The punch height cannot be superior to the base 
feature height, otherwise it is considered as a 
cutout.



●     You may create a user-defined stamping from a 
punch only but you cannot create a fillet.  

 

●     Only the stamping sketch is displayed in unfolded 
views.

 

●     The punch and die bodies can be defined in the 
Sheet Metal part where the stamping is to be 
created (see PunchDie1.CATPart or 
NEWPunchDie1.CATPart in the samples 
directory).

In this case, make sure you select the 
Define In Work Object on the PartBody 
containing the base feature to be stamped, 
prior to actually creating the stamp.

or as two separate Part Design parts (Punch1.CATPart and Die1.CATPart from the samples directory)

 

In this case, when selecting the punch or die feature, the system automatically copies this feature into the .CATPart document into which the base 
feature to be stamped is located.
A link is retained between the initial punch or die feature and its copy.
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Creating a Punch with Opening Faces
This task explains how to create a stamp from a punch feature with opening faces. 

First, you will define a punch in Part Design, in the absolute axis system.
Then, in a Sheet Metal part, you will bring the punch feature (and its axis system) to a point you have 
selected. If necessary, you will define a rotation of the axis system from a reference line.
You can also position the stamp according to the punch and die features positioning and direction thanks 
to the On context option. 

This user-defined stamping cannot be combined with the Punch with a Die approach.

The CATPart documents are available from the samples directory, NEWOpenFaces1.CATPart for is 
Generative Sheetmetal Design or Aero_OpenFaces1.CATPart for Aerospace Sheetmetal Design.

1.  Start the Part Design application.

2.  Insert a PartBody (menu Insert -> Body) to define the punch.

3.  Enter the Sketcher workbench , select the yz plane, and draw the profile of the punch.

4.  Return to the 3D space and create the punch using the pad icon  and the fillet icon .

 

The punch must be oriented as described in Defining the Punch in Relation to the base feature to be 
Stamped.

●     The punch can be defined in the Sheet Metal part where the stamping is to be created or in another 
part.
In this case, when selecting the punch feature, the system automatically copies it into the .CATPart 
document into which the base feature to be stamped is located.
A link is retained between the initial punch feature and its copy.
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5.  Return to the Sheet Metal application, and if needed, use the Define In Work Object on the 

PartBody containing the base feature to be stamped.

6.  Click the User Stamp icon  from the Stamping toolbar and select a base feature where the 

stamping is to be created. 

This base feature is used to define the stamping location and direction, by matching the 

punch's origin to the selected point on the base feature.

The User Defined Stamp Definition dialog box is displayed.

7.  Click the With opening  icon.

8.  Select the punch (Body.2). The punch is previewed on the base feature.



 

 
9.  Click the Faces for opening field and select the lateral faces of the punch (Pad.1).

 

 
10.  Click Preview. The stamp is previewed with the opening faces:

10.  Select the On Context check box if you wish to position the stamp according to the positioning 

and direction of the punch and die features.

11.  Click Preview. The stamp is previewed with the opening faces at the point where the punch and 

die were created on the part:



 

For more information about the On context check box, refer to the Creating a Punch with a Die section.

12.  Check No Fillet is you do not wish the stamp to be filleted, or set the radius value if you wish the 

stamp to be filleted. 

13.  If needed, define the stamp's positioning on the selected base feature by choosing:

●     a Reference for rotation: by default, it is the sketch axis, but you can also select any 

line or edge on the base feature.

●     a Rotation angle value: you can either enter a value in the dialog box, or use the 

manipulator in the geometry to define this value.

●     a new Origin point on the base feature to coincide with the punch's point of origin.



This is especially useful for non-circular stamps, but you can very well create the stamp as is, 
without further positioning.

14.  Click OK to validate and create the stamping. 

The stamp is automatically set in No Show mode. 



●     Radius is the radius of the bend between the stamping and the base feature.

●     Punch is the body you have defined previously. If the punch is in another .CATPart document, 
activate this document before clicking the punch.

●     The Faces for opening must be picked on the punch, not on the base feature. 
If the punch is located into another .CATPart document, these faces must be picked on the copy of 
the punch where the base feature to be stamped is located.

●     If you modify the selected punch, the user-defined stamp with the opening faces will not be updated 
accordingly, nor will it be updateable. If you want to update the user-defined stamp, you will need to 
edit it; in the User Defined Stamp Definition dialog box, clear the Faces for opening field and re-
select the lateral faces of the modified punch.

●     Avoid using stamps with faces merging with the face of the base feature to be stamped, as it would 
be difficult to remove afterwards, especially on a curved part.
If you do use such a stamp, select the stamp face tangent to the base feature and define it as an 
open face.

●     If you select two reference lines in addition to the plane, this will create two editable constraints to 
position the stamping. These constraints are editable.

 
●     A user-defined stamping can be edited (punch, die, position, constraints).

●     Check the No fillet option to deactivate the Radius R1 value, and to create the stamp without a fillet.



Editing User-Defined Stamps

This task explains how to edit a user-defined stamp, that is: 

●     to change its type

●     add or remove cutting and opening faces 

To perform this scenario, you can open any .CATPart document containing a user-defined stamp.

1.  Double-click the existing user-defined stamp from the specification tree.

The User Defined Stamp Definition dialog box is displayed. 



2.  Change stamp type using the icons:

●     If you change from With die to With opening, the Die feature no longer is selected, and you need 

to select Faces for opening.

●     If you change from With opening to With die, the punch faces no longer are selected and you may 

select a die feature if you wish (it is not compulsory).

Basically, only the punch remains selected.
If you are working with a punch with opening faces (With opening option) you may want to add or 
remove some opening faces:

3.  Click in the Faces for opening field then:

●     select a face in the geometry to add it to the already selected opening faces

●     select an already selected face to remove it from the opening faces

●     use the Clear selection contextual menu to remove all opening faces that have been previously 

selected. 

4.  Modify any other parameter as needed.

5.  Click OK in the User Defined Stamp Definition dialog box to take these modifications into 

account.

The stamp is updated accordingly.

 



Patterning
This section explains and illustrates how to create various kinds of patterns on Sheet Metal parts.

Create rectangular patterns: select the element to be duplicated, set the patterning type, and its 
parameters, and the reference direction
Create circular patterns: select the element to be duplicated, set the axial reference  parameters, the 
reference direction, and possibly the crown definition
Create user-defined patterns: select the element to be duplicated, and the positioning sketch and 
anchor point 

To know more about patterns, refer to the Part Design User's Guide.



Creating Rectangular Patterns

In this task, you are going to create rectangular cutouts according to a pattern.
These features make the creation process easier.

 

In the Generative Sheetmetal Design workbench, you can only duplicate flanges, cutouts, holes, 
stamps (except stiffening ribs), stamps without fillet (radius=0) and Generative Sheetmetal Design 
patterns.

 These features must lie on a unique and planar wall.
     

For the SheetMetal Design workbench, open the 
RectangularPattern1.CATPart document.
For the Generative Sheetmetal Design workbench, 
open the NEWRectangularPattern1.CATPart 
document.

The Sheet Metal part looks like this:

1.  Select the rectangular cutout you want to 

duplicate.

2.  Click the Rectangular Pattern icon .

The Rectangular Pattern Definition dialog box is displayed. Each tab is dedicated to a 
direction to define the location of the duplicated feature. 
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3.  Set the specification for the First Direction 

by selecting the first edge (Edge.1) as 

shown, to specify the first direction of 

creation.

An arrow is displayed on the wall. 

The Reverse button enables to modify 

the direction.

You can also click the arrow in the 3D 

geometry.

4.  Keep the Instances & Spacing options to 

define the parameters.

Choosing these parameters types dims the 

Length field because the application no 

longer needs this specification to space the 

instances.

You can set the duplication parameters by choosing the number of instances, the spacing between 
instances, or the total length of the zone filled with instances.
Three options are available: 

●     Instances & Length: the spacing between instances is automatically computed based on 

the number of instances and the specified total length

●     Instances & Spacing: the total length is automatically computed based on the number of 

instances and the specified spacing value

●     Spacing & Length: the number of instances is automatically computed to fit the other 

two parameters.

For each of these cases only two fields are active, allowing you to define the correct value.

If you set Instances & Length or Spacing & Length parameters, note that you cannot 

define the length by using formulas.



Patterns should not go beyond the model.

5.  Enter 2 as the number of instances you wish to obtain in the first direction.

6.  Define the spacing along the grid: enter 30mm.

Defining the spacing along the grid and the length of your choice, would make the application compute 
the number of possible instances and space them at equal distances.

7.  Now, click the Second Direction tab to 

define the other parameters.

Note that defining a second direction is not 
compulsory. Creating a rectangular pattern 
defining only one direction is possible.

8.  Select the second edge (Edge.2), as 

shown, to define the second direction.

9.  Keep the Instances & Spacing option: 

enter 8 and 10 mm in the appropriate 

fields.

Additional cutouts have been aligned along 

this second direction.

10.  Click OK to repeat the cutouts.



After the update, the Sheet Metal part looks like 
this:

11.  Select this icon  to unfold the part:

The pattern is updated on the unfolded view.



 
12.  Click the More>> button to display further options.

 

The Simplified representation option lets you lighten the pattern geometry, when more than 10 
instances are generated in one direction. What you need to do is just check the option, and click Preview. 
The system automatically simplifies the geometry:

You can also specify the instances you do not want 
to see by double-clicking the dots. These instances 
are then represented in dashed lines during the 
pattern definition and then are no longer visible 
after validating the pattern creation. The 
specifications remain unchanged, whatever the 
number of instances you view. This option is 
particularly useful for patterns including a large 
number of instances.

●     When you duplicate a pattern of flange, the edge of the flange spine and its instances have to be 
tangent to the wall edge: you cannot choose a direction of patterning not parallel to the flange spine.

●     All instances of the flange pattern must lie on the same face as the flange pattern. 



Creating Circular Patterns

In this task, you are going to create circular cutouts according to a pattern.
These features make the creation process easier.

 In the Generative Sheetmetal Design workbench, you can only duplicate flanges, cutouts, holes, stamps (except stiffening ribs), 
stamps without fillet (radius=0) and Generative Sheetmetal Design patterns.

 These features must lie on a unique and planar wall.
     

For the SheetMetal Design workbench, open the 
CircularPattern1.CATPart document.
For the Generative Sheetmetal Design workbench, open the 
NEWCircularPattern1.CATPart document.

The Sheet Metal part looks like this:

1.  Select the circular cutout you want to duplicate.

2.  Click the Circular Pattern icon .

The Circular Pattern Definition dialog box is 

displayed.

3.  Define the Axial Reference by choosing the Parameters 

type, and reference direction.
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●     Instance(s) & total angle: the number of patterns as 

specified in the instances field are created, in the specified 

direction, and evenly spread out over the total angle.

●     Instance(s) & angular spacing: the number of patterns as 

specified in the instances field are created in the specified 

direction, each separated from the previous/next one of the 

angular angle value.



●     Angular spacing & total angle: as many patterns as 

possible are created over the total angle, each separated from 

the previous/next one of the angular angle value.

●     Complete crown: the number of patterns as specified in the 
instances field are created over the complete circle (360deg). 

 

If you set Instance(s) & total angle or Angular spacing & total angle parameters, note that you cannot define the length by 
using formulas.

4.  Click the Reference element and select the element defining the rotation axis.

Here select the face on which lies the circular cutout.



●     To define a direction, you can select an edge or a planar face.
Should you select the face of a wall, the rotation axis would be normal to that face.

●     Click the Reverse button to inverse the rotation direction.

Now you are going to add a crown to this pattern.

5.   Click the Crown Definition tab, and choose which 

parameters you wish to define the crown.

This figure may help you define these parameters:

 
●     Circle(s) and crown thickness: you define the number of circles and they are spaced out evenly over the specified crown 

thickness

●     Circle(s) and circle spacing: you define the number of circles and the distance between each circle, the crown thickness being 
computed automatically

●     Circle(s) spacing and crown thickness: you define the distance between each circle and the crown thickness, and the number of 
circles is automatically computed.

For example, using the values described above for the 
Angular spacing & total angle option, you could 
define the crown as: 



Note that one of the pattern is created beyond the wall.  

You can delete instances of your choice when creating or editing a 
pattern. To do so, just select the points materializing instances in 
the pattern preview.

The instance is deleted, but the point remains, as you may wish 
to click it again to add the instance to the pattern definition again.

6.  Click the More>> button to display further options:

Using these options, you can change the position of the selected 

cutout within the crown. For example, if you set the Row in 

angular direction parameter to 4, this is what you obtain: the 

initially selected cutout is the fourth instance, based on the 

rotation direction, of the pattern.

Typically, in this case, you might want to edit the pattern and 

click again the instance that you removed above, to get a full 

pattern.

●     The Simplified representation option lets you lighten the pattern geometry, when more than 10 instances are generated in 
one direction. What you need to do is just check the option, and click Preview. The system automatically simplifies the 
geometry:
You can also specify the instances you do not want to see by double-clicking them . These instances are then represented in 
dashed lines during the pattern definition and then are no longer visible after validating the pattern creation. The specifications 
remain unchanged, whatever the number of instances you view. This option is particularly useful for patterns including a large 
number of instances.

●     When checking the Radial alignment of instances, all instances have the same orientation as the original feature. When 
unchecked, all instances are normal to the lines tangent to the circle.

In case you use the circular cutout as a reference element, it means the axial reference of the pattern will be the same as the 
rotation axis of the circular cutout. As a result, when the cutout is duplicated, the first crown instances will be superimposed on one 
another. 

To avoid this, uncheck Radial alignment of instances, so that the instances are properly positioned around the cutout.



7.  Click OK to create the pattern.

●     When you duplicate a pattern of flange, the edge of the flange spine and its instances have to be tangent to the wall edge: you 
cannot choose a direction of patterning not parallel to the flange spine.

●     All instances of the flange pattern must lie on the same face as the flange pattern.

 



Creating User-Defined Patterns

The User Pattern command lets you duplicate a cutout, a stamp, or any other feature as many times as 
you wish at the locations of your choice.
Locating instances consists in specifying anchor points. These points are sketches.

 In the Generative Sheetmetal Design workbench, you can only duplicate flanges, cutouts, holes, stamps 
(except stiffening ribs), stamps without fillet (radius=0) and Generative Sheetmetal Design patterns.

 These features must lie on a unique and planar wall.
    

For the SheetMetal Design workbench, open the UserPatterns1.CATPart document.
For the Generative Sheetmetal Design workbench, open the NEWUserPatterns1.CATPart document.

1.  Select the feature to be duplicated.

Here we selected the cutout. 

2.  Click the User Pattern icon 

.

The User Pattern Definition 

dialog box is displayed.

3.  Select 'Sketch 3' in the 

specification tree and click 

Preview.

The sketch contains the points 

you need to locate the 

duplicated cutouts. 

By default, the application positions each instance with respect to the center of gravity of the element to 
be duplicated. To change this position, use the anchor field: click the anchor field and select a vertex or a 
point.
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4.  Click inside the Anchor field 

and select the point (Point.1) 

to indicate a new reference 

location.

5.  You can then click the points 

corresponding to the pattern 

instances to be removed.

6.  Click OK in the User Pattern 

Definition dialog box.

Cutouts are created at the 

points of the sketch.

Would you need to unfold the part using the  icon, you would notice that the pattern is updated.

●     When you duplicate a pattern of flange, the edge of the flange spine and its instances have to be 
tangent to the wall edge: you cannot choose a direction of patterning not parallel to the flange spine.

●     All instances of the flange pattern must lie on the same face as the flange pattern.

 



Mirroring

In this task, you are going to mirror a given feature, that is, to duplicate it symmetrically with respect to 

a plane.

 
●     You can mirror a hole, a cutout, a flange, a stamp, a pattern or another mirror.

●     Whatever feature you choose to mirror, it must lie on a unique, planar wall.

●     It is mandatory that the result of the mirroring should lie on the part, otherwise it cannot be 
mirrored.

Open the NEWMirror01.CATPart document.

A cutout and a relimited flange are displayed on the wall.

1.  Click on the Mirror icon .

The Mirror definition dialog box is displayed.

2.  Select the feature to mirror, that is, Cut Out.1 in our example.
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3.  Select the zx plane in the 3D window.

The selected plane and a preview of the cutout to be mirrored is displayed.

4.  Click on Preview to visualize the mirrored cutout.



There is three different ways to select a mirroring plane :

●     In the 3D window, as in our example.

●     with a right click on the Mirroring field in the Mirror definition dialog box.

●     with a right click in the workbench background.

5.  Click on Ok to create the mirrored cutout.



The mirror feature is displayed in the specification tree.

If you selected the mirroring plane with a right click, the plane feature is also displayed in the 
specification tree, allowing you to double click on it should you need to edit it.

If you selected the mirroring plane with a right click, an icon is displayed in the Mirror definition 

dialogue box so that you can modify it if needed.

6.  Select Flange.3.

7.  Click on the Mirror icon  and select the zx plane.

The flange to be mirrored is displayed.

8.  Click on Preview if you want to visualize the mirrored flange, then on OK to create it.



When mirroring a flange, it is mandatory that the result of the mirror should lie on an edge.



Creating a Local Corner Relief

This task explains how to define a corner relief locally on a set of supports.

Open the CornerRelief01.CATPart document from the samples directory.
The part needs to be unfolded prior to creating the corner relief.

1.  Click the Corner Relief icon .

The Corner Relief Definition dialog 

box  is displayed. 

2.  Select the supports on which a 

corner relief should be created (here 

we chose Surfacic Flange.1 and 

Surfacic Flange.2)

A notch was defined on the web profile between the two fillets' flanges; so that flanges do not intersect. This 
operation enables to prepare the web as to create the flanges that will be later used to define the corner relief.

●     By default the User Profile  is active in the Corner Relief Definition dialog box.
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1.  Select the sketch, directly 

in the 3D geometry.

 

 As soon as the sketch has been selected, 

the Sketcher  icon is displayed in the 

dialog box allowing you to edit the selected 
sketch, if needed. 

The red arrow lets you choose the direction 
of matter to remove. Click it to reverse the 
direction.

2.  Click OK in the Corner 

Relief Definition dialog 

box.

 You can use the Catalog icon  to open the Catalog Browser.

For more information on catalogs, please refer to the Using Catalogs chapter in the CATIA Infrastructure User Guide.

●     Select the Circular Profile  

using the down arrow. 

file:///E|/Www/cnqr14/Doc/online/cfyugsheetmetal_C2/cfyugsheetmetal01.htm


1.  Define the default radius: it is equal to the bend radius + the thickness.

In our example, we defined a radius of 15 mm.

By default the corner relief center is located at the intersection of the bend axes. You can select a point as 
the circle's center. 

2.  Select the vertex between 
the two flanges: it will be 
the center of the corner 
relief.

3.  Click OK in the Corner 

Relief Definition dialog 

box.

 

The created element (identified as Corner Relief.xxx) is added to the specification tree.

3.  Fold the part to check the corner relief in 3D.



Folded user corner relief Folded circular corner relief

The Supports Redefinition checkbox 

enables to redefine the supports' sides thus 

adding matter to these supports.

In that case, the created element (identified 

as Corner Relief.xxx) appears before the 

supports in the specification tree.

●     Please note that checking this button means that the corner relief replaces the surfacic flange's side. This side 

must therefore exists: when creating the surfacic flange, do not define the side as None.

●     In hybrid context, when checking Supports Redefinition, the Surfacic flanges are hidden in the 3D since the 

define in work object parameter is applied to the corner relief.

●     Moreover, the sketch is not aggregated anymore under the corner relief in the specification tree. 



Yet, if you open a part created in a previous release, the specification tree will be displayed accordingly to 

the previous behavior.

Fore more information about Hybrid Design, refer to the Hybrid Design section.

Unfolded user corner relief
with redefined supports

Folded user corner relief
with redefined supports 
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The image besides shows two surfacic 
flanges creating with Angle as support type.
The two blue dotted lines represent the 
limits of the unfolded surfacic flanges.

 

●     The creation of a corner relief with supports redefined is not possible as it is not located within the limits of the 
unfolded flanges.

●     A corner relief with supports redefined cannot be created if its profile implies adding matter to the web.

 

 



Creating Corners
This task shows how to create one or more corner(s) on a Sheet Metal part, that is to round off sharp edges, much like a fillet between two 
faces of a Part Design body.
This corner creation operation can be performed indifferently on the folded or unfolded view, and only one support (i.e. the corner when 
previewed should not lie over two supports).

 

Open the Corner1.CATPart document.
If you use Aerospace SheetMetal Design, open the Corner_Aero1.CATPart document.

1.  Click the Corner icon . The Corner dialog box is displayed. 

 

 
2.  Set the radius value.

3.  Choose the type of edge you wish to round off: Convex Edge(s) and/or Concave Edge(s). For the purpose of this scenario, leave 

both options selected.

Once you have selected an edge, you can no longer modify the chosen options (they are grayed out), unless you cancel the selection.
 

4.  Click to select a convex edge on a part.

As soon as you selected one edge, the dialog box is updated and the Select All button changes to Cancel Selection.

 

The corner is previewed on the edge, with the current radius value.

 
5.  Click to select a concave edge on a part.
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 The corner is previewed on the edge, with the current radius value.
 

6.  Click Cancel Selection then click the Select All button. All edges of the part are selected and the corners previewed.

7.  Click OK in the dialog box.

All sharp edges of the part are rounded off to create smooth corners.



    

To deselect an edge, simply click it again. For quick selection in a complex part, you can select all edges with the Select All check button, 
then deselect one or two edges.

    
●     When you select an edge that is not sharp, such as the edge between a wall and a bend for example, a warning is issued.

●     As you select more edges, the Edge(s) field of the dialog box is updated.

●     When using the Select All button, you select all edges present at the time. If when modifying the part, new edges are created, these will 
not be automatically rounded off.

 

 



Creating Chamfers
This task shows how to create one or more chamfer(s)  on a Sheet Metal part, that is to cut off, or fill in 
sharp edges of Sheet Metal parts.
This chamfer creation operation can be performed indifferently on the folded or unfolded view, and only 
one support (i.e. the chamfer when previewed should not lie over two supports).

 

Open the Corner1.CATPart document.
If you use Aerospace SheetMetal Design, open the Corner_Aero1.CATPart document.

1.  Click the Chamfer icon .

The Chamfer Definition dialog box is 

displayed. 

You can choose the type of edge you wish to chamfer: 
●     using the Select All button, you can select all convex edges on the part

●     any edge you select manually.

 
2.  Leave the Convex Edge(s) option selected.

3.  Select a sharp edge on a part. 

 
If you want to create a longitudinal chamfer, you can select a single long edge. This allows you 

to create a welding chamfer, for example.

The chamfer is previewed on the edge.

Remember that when you create a chamfer on one edge it is automatically propagated on the tangent 
edge.

As soon as you selected one edge, the dialog box is updated and the Select All button changes to 

Cancel Selection.
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3.  Choose a chamfer mode. You can either enter:

●     two lengths: these lengths are computed 
from the selected edge on both sides.
Here, we chose two lengths of 10mm.

   

●     a length value and an angle: the length is 
computed on one side of the edge and the 
angle from the chamfer's limit on the same 
side.
Here, we chose a length of 10mm and an 
angle of 60deg.

You can use the Reverse button to inverse all edges' side, on which the values are taken into account.

4.  Click Cancel Selection then click the Select All button.

All sharp edges of the part are selected, the Select All button taking into account the chosen 

type and the chamfers previewed.



5.  Click OK in the dialog box.

All sharp edges of the part are cut off or filled in. 



     
To deselect an edge, simply click it again. For quick selection in a complex part, you can select all edges 
with the Select All button, then deselect one or two edges.

     
●     When you select an edge that is not sharp, such as the edge between a wall and a bend for example, 

a warning is issued.

●     As you select more edges, the Edge(s) field of the dialog box is updated.

●     When using the Select All button, you select all edges present at the time. If when modifying the 
part, new edges are created, these will not be automatically chamfered.

●     When the sharp edge is selected in the thickness of the wall, its length has to be equivalent to the 
wall's thickness.

●     If the sharp edge is not selected in the thickness of the wall, it has to limit the faces of the wall.

 

 



Mapping Elements

 

This task shows how to create curves or points from a sketch (as designed using the Sketcher) or from 
existing curves or points,  onto a Sheet Metal part; and to fold/unfold it, just as other Sheet Metal 
elements. 
This is especially useful when: 

●     you want to generate a logotype

●     you want to define an area for chemical milling

●     you want to create a cutout (pocket) to solve the overlapping of walls for example (the overlapping 
can be checked with the Sheet Metal Production product).

 

If you use SheetMetal Design, open the Mapping1.CATPart document.
If you use Generative Sheetmetal Design, open the NEWMapping1.CATPart document.
If you use Aerospace SheetMetal Design, open the Aero_Mapping.CATPart document.

These samples already contain a pre-defined sketch that will be mapped onto the part. 

Otherwise, you would need to defined a sketch by entering the Sketcher workbench , selecting the 

wall onto which the curve should lie, and drawing the sketch you wish.
 

1.  Make sure the sketch is selected, and click the Point or Curve Mapping icon  .

The Elements To Map definition dialog box is displayed, indicating which elements have been 
selected for mapping.
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 You can manage the list of elements:

●     to remove an element, select it from the list and use the Clear selection contextual menu

●     to add an element,  select it directly in the geometry.
Order in the list does not matter. 

2.  Select the Mapping Context, that is the element of the part on which the curve should be 

generated when folding or unfolding.

The Mapping Context is not necessarily the support element on which the element to be mapped has 
been drawn. Indeed, by default, the Mapping Context is the last Sheet Metal feature that has been 
created or modified, that is the current feature in the specification tree.

3.  Click OK. The curve mapping is created and added in the specification tree.

 
 

Folded view of the curve mapping Unfolded view of the curve mapping



●     You can select several sketches/curves/points to be mapped at a time.

●     Mapped curves can be created across several walls and bends.

 

 



Interoperability with Wireframe
Creating Points
Creating Lines
Creating Planes



Creating Points

 

This task shows the various methods for creating points: 
●     by coordinates

●     on a curve

●     on a plane

●     on a surface

●     at a circle/sphere center

●     tangent point on a curve

●     between

 
Open the Points3D1.CATPart document.

 
1.  Click the Point icon  .

The Point Definition dialog box appears.

2.  Use the combo to choose the desired point type.

Coordinates 
●     Enter the X, Y, Z 

coordinates in the current 
axis-system.

●     Optionally, select a 
reference point.

The corresponding 
point is displayed.

 

 

When creating a point within a user-defined axis-system, note that the Coordinates in absolute axis-
system check button is added to the dialog box, allowing you to be define, or simply find out, the point's 
coordinates within the document's default axis-system.
If you create a point using the coordinates method and an axis system is already defined and set as 
current, the point's coordinates are defined according to current the axis system. As a consequence, the 
point's coordinates are not displayed in the specification tree.

The axis system must be 
different from the absolute 
axis.
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On curve 
●     Select a curve

●     Optionally, select a 
reference point.

If this point is not on 
the curve, it is 
projected onto the 
curve.
If no point is 
selected, the curve's 
extremity is used as 
reference.

 

●     Select an option point to 
determine whether the new 
point is to be created: 

❍     at a given distance 
along the curve from 
the reference point

❍     a given ratio between 
the reference point and 
the curve's extremity.

    

●     Enter the distance or ratio 
value.
If a distance is specified, it 
can be: 

❍     a geodesic distance: the 
distance is measured 
along the curve

❍     an Euclidean distance: 
the distance is 
measured in relation to 
the reference point 
(absolute value).

The corresponding point is 
displayed.



If the reference point is located at the curve's extremity, even if a ratio value is defined, the created 
point is always located at the end point of the curve.

You can also: 
●     click the Nearest extremity button to display the point at the nearest extremity of the curve.

●     click the Middle Point button to display the mid-point of the curve.

Be careful that the arrow is orientated towards the inside of the curve (providing the curve is not closed) 
when using the Middle Point option.

●     use the Reverse Direction button to display: 
❍     the point on the other side of the reference point (if a point was selected originally)

❍     the point from the other extremity  (if no point was selected originally).

●     click the Repeat object after OK if you wish to create equidistant points on the curve, using the 
currently created point as the reference, as described in Creating Multiple Points in the Wireframe 
and Surface User's Guide. 

You will also be able 
to create planes 
normal to the curve 
at these points, by 
checking the Create 
normal planes also 
button, and to create 
all instances in a new 
geometrical set  by 
checking the Create 
in a new 
geometrical set 
button.
If the button is not 
checked the 
instances are created 
in the current 
geometrical set .

 

●     If the curve is infinite and no reference point is explicitly given, by default, the reference point is the 
projection of the model's origin

●     If the curve is a closed curve, either the system detects a vertex on the curve that can be used as a 
reference point, or it creates an extremum point, and highlights it (you can then select another one if 
you wish) or the system prompts you to manually select a reference point.

 

Extremum points created on a 
closed curve are now 
aggregated under their parent 
command and put in no show in 
the specification tree.



On plane 
●     Select a plane.

●     Optionally, select a point to 
define a reference for 
computing coordinates in 
the plane.

If no point is 
selected, the 
projection of the 
model's origin on the 
plane is taken as 
reference. 

 

 

 
●     Optionally, select a surface 

on which the point is 
projected normally to the 
plane.

If no surface is 
selected, the 
behavior is the same.

Furthermore, the 
reference direction 
(H and V vectors) is 
computed as 
follows: 
With N the normal to 
the selected plane 
(reference plane), H 
results from the 
vectorial product of Z 
and N (H = Z^N). 
If the norm of H is 
strictly positive then 
V results from the 
vectorial product of N 
and H (V = N^H).
Otherwise, V = N^X 
and H = V^N.

Would the plane 
move, during an 
update for example, 
the reference 
direction would then 
be projected on the 
plane. 



●     Click in the plane to display a point.

On surface 
●     Select the surface where 

the point is to be created.

 

●     Optionally, select a 
reference point. By default, 
the surface's middle point is 
taken as reference. 

●     You can select an element 
to take its orientation as 
reference direction or a 
plane to take its normal as 
reference direction.
You can also use the 
contextual menu to specify 
the X, Y, Z components of 
the reference direction.

●     Enter a distance along the 
reference direction to 
display a point.

 

    

Circle/Sphere center 
●     Select a circle, circular arc, 

or ellipse, or

●     Select a sphere or a portion 
of sphere.



A point is displayed 
at the center of the 
selected element.

    

Tangent on curve 
●     Select a planar curve and a 

direction line.

A point is displayed 
at each tangent. 

    

The Multi-Result 
Management dialog 
box is displayed 
because several 
points are 
generated. 

●     Click YES: you can then 
select a reference element, 
to which only the closest 
point is created.

●     Click NO: all the points are 
created.

For further information, refer to 
the Managing Multi-Result 
Operations chapter.

Between
●     Select any two points.
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●     Enter the ratio, that is the 
percentage of the distance 
from the first selected 
point, at which the new 
point is to be.
You can also click Middle 
Point button to create a 
point at the exact midpoint 
(ratio = 0.5).

Be careful that the arrow is orientated towards the inside of the curve (providing the curve is not closed) 
when using the Middle Point option.

●     Use the Reverse direction 
button to measure the ratio 
from the second selected 
point.

 
If the ratio value is greater than 1, the point is located on the virtual line beyond the selected points.

3.  Click OK to create the point.

The point (identified as Point.xxx) is added to the specification tree.

●     Parameters can be edited in the 3D geometry. For more information, refer to the Editing Parameters 
chapter.

●     You can isolate a point in order to cut the links it has with the geometry used to create it. To do so, 
use the Isolate contextual menu. For more information, refer to the Isolating Features chapter.
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Creating Lines

This task shows the various methods for creating lines: 

●     point to point

●     point and direction

●     angle or normal to curve

●     tangent to curve

●     normal to surface

●     bisecting

 
It also shows you how to create a line up to an element, define the length type and automatically 
reselect the second point.

 
Open the Lines1.CATPart document.

1.  Click the Line icon  .

The Line Definition dialog box is displayed. 

2.  Use the drop-down list to choose the desired line type.

 
A line type will be proposed automatically in some cases depending on your first element selection.

 

Defining the line type
 

Point - Point 

 
This command is only available with the 
Generative Shape Design 2 product.

●     Select two points.
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A line is displayed between the two 
points.
Proposed Start and End points of the 
new line are shown.

●     If needed, select a support surface.
In this case a geodesic line is created, i.e. 
going from one point to the other according to 
the shortest distance along the surface 
geometry (blue line in the illustration below).
If no surface is selected, the line is created 
between the two points based on the shortest 
distance.

If you select two points on closed surface (a 
cylinder for example), the result may be unstable. 
Therefore, it is advised to split the surface and only 
keep the part on which the geodesic line will lie. 

 
The geodesic line is not available with the Wireframe and Surface workbench.



 
●     Specify the Start and End points of the new line, that is the line endpoint location in relation to the 

points initially selected. These Start and End points are necessarily beyond the selected points, 
meaning the line cannot be shorter than the distance between the initial points.

●     Check the Mirrored extent option to create a line symmetrically in relation to the selected Start 
and End points.

 
The projections of the 3D point(s) must already exist on the selected support. 

Point - Direction 
 

●     Select a reference Point and a Direction line.
A vector parallel to the direction line is 
displayed at the reference point. 
Proposed Start and End points of the new line 
are shown.



●     Specify the Start and End points of the new 
line.
The corresponding line is displayed.

 
The projections of the 3D point(s) must already exist on the selected support. 

  

Angle or Normal to curve
 

●     Select a reference Curve and a Support 
surface containing that curve.



- If the selected curve is planar, then the 
Support is set to Default (Plane).

- If an explicit Support has been 
defined, a contextual menu is available 
to clear the selection.

 
●     Select a Point on the curve.

●     Enter an Angle value.

A line is displayed at the given angle 
with respect to the tangent to the 
reference curve at the selected point. 
These elements are displayed in the 
plane tangent to the surface at the 
selected point. 
You can click on the Normal to Curve 
button to specify an angle of 90 
degrees. 
Proposed Start and End points of the 
line are shown. 

●     Specify the Start and End points of the new line.
The corresponding line is displayed.



●     Click the Repeat object after OK if you wish 
to create more lines with the same definition as 
the currently created line. 
In this case, the Object Repetition dialog box is 
displayed, and you key in the number of 
instances to be created before pressing OK.

As many lines as indicated in the dialog box are 
created, each separated from the initial line by a 
multiple of the angle value.

 

You can select the Geometry on Support check box if you want to create a geodesic line onto a support 

surface. 

The figure below illustrates this case.

 

Geometry on support option not checked Geometry on support option checked

 
This line type enables to edit the line's parameters. Refer to Editing Parameters to find out how to 
display these parameters in the 3D geometry.
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Tangent to curve
 

●     Select a reference Curve and a point or 
another Curve to define the tangency. 

❍     if a point is selected (mono-tangent mode): 
a vector tangent to the curve is displayed 
at the selected point.

❍     If a second curve is selected (or a point in 
bi-tangent mode), you need to select a 
support plane. The line will be tangent to 
both curves.

 - If the selected curve is a line, then the 
Support is set to Default (Plane).

- If an explicit Support has been 
defined, a contextual menu is available 
to clear the selection.

 When several solutions are possible, you 
can choose one (displayed in red) 
directly in the geometry, or using the 
Next Solution button.

     

 

 

Line tangent to curve at a given point Line tangent to two curves
●     Specify Start and End points to define the new line.

The corresponding line is displayed.



 

Normal to surface 
 

●     Select a reference Surface and a Point.
A vector normal to the surface is displayed at 
the reference point. 
Proposed Start and End points of the new line 
are shown.

 If the point does not lie on the support surface, the minimum distance between the point and the surface 
is computed, and the vector normal to the surface is displayed at the resulted reference point.



●     Specify Start and End points to define the new 
line.
The corresponding line is displayed.



 

●     Select the support surface onto which the 
bisecting line is to be projected, if needed.

●     Specify the line's length in relation to its 
starting point (Start and End values for each 
side of the line in relation to the default end 
points).
The corresponding bisecting line, is displayed.

●     You can choose between two solutions, using 
the Next Solution button, or directly clicking 
the numbered arrows in the geometry.

Bisecting 
 

●     Select two lines. Their bisecting line is the line 
splitting in two equals parts the angle between 
these two lines. 

●     Select a point as the starting point for the line. 
By default it is the intersection of the bisecting 
line and the first selected line.



3.  Click OK to create the line.

The line (identified as Line.xxx) is added to the specification tree.

  
●     Regardless of the line type, Start and End values are specified by entering distance values or by 

using the graphic manipulators.

●     Start and End values should not be the same.

●     Check the Mirrored extent option to create a line symmetrically in relation to the selected Start 
point. 
It is only available with the Length Length type.

●     In most cases, you can select a support on which the line is to be created. In this case, the selected 
point(s) is projected onto this support.

●     You can reverse the direction of the line by either clicking the displayed vector or selecting the 
Reverse Direction button (not available with the point-point line type).

     

Creating a line up to an element
 This capability allows you to create a line up to a point, a curve, or a surface.

●     It is available with all line types, but the Tangent to curve type.

 

Up to a point
●     Select a point in the Up-to 1 and/or Up-to 2 

fields.

Here is an example with the Bisecting line type, 
the Length Length type, and a point as Up-to 
2 element.



 

Up to a curve
●     Select a curve in the Up-to 1 and/or Up-to 2 

fields.

Here is an example with the Point-Point line 
type, the Infinite End Length type, and a 
curve as the Up-to 1 element.

 

Up to a surface
●     Select a surface in the Up-to 1 and/or Up-to 2 

fields.

Here is an example with the Point-Direction line 
type, the Length Length type, and the surface 
as the Up-to 2 element.

  

●     If the selected Up-to element does not intersect with the line being created, then an extrapolation is 
performed. It is only possible if the element is linear and lies on the same plane as the line being 
created.
However, no extrapolation is performed if the Up-to element is a curve or a surface.

●     The Up-to 1 and Up-to 2 fields are grayed out with the Infinite Length type, the Up-to 1 field is 
grayed out with the Infinite Start Length type, the Up-to 2 field is grayed out with the Infinite End 
Length type.

●     The Up-to 1 field is grayed out if the Mirrored extent option is checked.

●     In the case of the Point-Point line type, Start and End values cannot be negative.

  
 

Defining the length type



 ●     Select the Length Type: 
❍     Length: the line will be defined according to the Start and End points values

❍     Infinite: the line will be infinite

❍     Infinite Start Point: the line will be infinite from the Start point

❍     Infinite End Point: the line will be infinite from the End point

By default, the Length type is selected.
The Start and/or the End points values will be greyed out when one of the Infinite options is chosen.

  
 

Reselecting automatically a second point
This capability is only available with the Point-Point line method.

1.  Double-click the Line icon .

The Line dialog box is displayed.

2.  Create the first point.

 

The Reselect Second Point at next start option 
appears in the Line dialog box.

3.  Check it to be able to later reuse the 

second point.

4.  Create the second point.

5.  Click OK to create the first line.

  



 

The Line dialog box opens again with the 
first point initialized with the second 
point of the first line.

6.  Click OK to create the second line.

 To stop the repeat action, simply uncheck the option or click Cancel in the Line dialog box.
  

●     Parameters can be edited in the 3D geometry. For more information, refer to the Editing Parameters 
chapter.

●     You can isolate a line in order to cut the links it has with the geometry used to create it. To do so, 
use the Isolate contextual menu. For more information, refer to the Isolating Features chapter.
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Creating Planes

 
This task shows the various methods for creating planes:

 

●     offset from a plane

●     parallel through point

●     angle/normal to a plane

●     through three points

●     through two lines

●     through a point and a line

●     through a planar 
curve

●     normal to a curve

●     tangent to a surface

●     from its equation

●     mean through points

 

 
Open the Planes1.CATPart document.

 
1.  Click the Plane icon  .

The Plane Definition dialog box appears.

2.  Use the combo to choose the desired Plane type.

 
Once you have defined the plane, it is represented by a red square symbol, which you can move using 
the graphic manipulator.

Offset from plane

●     Select a reference Plane then enter an 
Offset value.

A plane is displayed offset from the reference 
plane.
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Use the Reverse Direction button to  reverse 
the change the offset direction, or simply click 
on the arrow in the geometry.

      
●     Click the Repeat object after OK if you wish to 

create more offset planes . 
In this case, the Object Repetition dialog box is 
displayed, and you key in the number of instances to 
be created before pressing OK.

As many planes as indicated in the dialog box 
are created (including the one you were 
currently creating), each separated from the 
initial plane by a multiple of the Offset value. 

 

Parallel through point 

●     Select a reference Plane and a Point.



A plane is displayed parallel to the reference 
plane and passing through the selected point.

Angle or normal to plane 

●     Select a reference Plane and a Rotation 
axis.
This axis can be any line or an implicit 
element, such as a cylinder axis for 
example. To select the latter press and hold 
the Shift key while moving the pointer over 
the element, then click it.

●     Enter an Angle value.

 



A plane is displayed passing through the 
rotation axis. It is oriented at the specified 
angle to the reference plane. 

●     Click the Repeat object after OK if you wish to create more planes at an angle from the initial 
plane. 
In this case, the Object Repetition dialog box is displayed, and you key in the number of instances 
to be created before pressing OK.

As many planes as indicated in the dialog box 
are created (including the one you were 
currently creating), each separated from the 
initial plane by a multiple of the Angle value.

Here we created five planes at an angle of 20 
degrees.

 This plane type enables to edit the plane's parameters. Refer to Editing Parameters to find out how to 
display these parameters in the 3D geometry.

Through three points 

●     Select three points.
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The plane passing through the three points is 
displayed. You can move it simply by dragging it 
to the desired location.

Through two lines 

●     Select two lines.

The plane passing through the two line 
directions is displayed.
When these two lines are not coplanar, the 
vector of the second line is moved to the first 
line location to define the plane's second 
direction. 



Check the Forbid non coplanar lines button to specify that both lines be in the same plane.

Through point and line 

●     Select a Point and a Line.

The plane passing through the point and the line 
is displayed. 

 



Through planar curve 

●     Select a planar Curve.

The plane containing the curve is displayed.

Tangent to surface 

●     Select a reference Surface and a Point.



A plane is displayed tangent to the surface at 
the specified point.

Normal to curve 

●     Select a reference Curve.

●     You can select a Point. By default, the 
curve's middle point is selecte.



A plane is displayed normal to the curve at the 
specified point. 

Mean through points 

●     Select three or more points to display the 
mean plane through these points.

It is possible to edit the plane by first selecting 
a point in the dialog box list then choosing an 
option to either:

●     Remove the selected point

●     Replace the selected point by another 
point.



Equation 

●     Enter the A, B, C, D components of the Ax 
+ By + Cz = D plane equation.

 

Select a point to position the plane through this 
point, you are able to modify A, B, and C 
components, the D component becomes grayed.

 

Use the Normal to compass button to position 
the plane perpendicular to the compass 
direction.

Use the Parallel to screen button to parallel to 
the screen current view.



3.  Click OK to create the plane.

The plane (identified as Plane.xxx) is added to the specification tree.
  

●     Parameters can be edited in the 3D geometry. For more information, refer to the Editing Parameters 
chapter.

●     You can isolate a plane in order to cut the links it has with the geometry used to create it. To do so, 
use the Isolate contextual menu. For more information, refer to the Isolating Features chapter.
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Integration with Other Workbenches
Integration With Part Design
Integration With Weld Design

Integration with Generative Drafting
Defining Generative View Styles

Producing Drawings with Generative View Styles



Integration With Part Design
For the Sheet Metal Design workbench, open the Stiffener1.CATPart document.
For the Generative Sheetmetal Design workbench, open the NEWStiffener1.CATPart document.

  
This scenario, which is valid for both the Sheet Metal Design workbench and the Generative Sheet Metal 
Design workbench, is illustrated using screen captures from the Sheet Metal Design workbench. Results 
will slightly differ in the Generative Sheetmetal Design workbench, for which Automatic bends are not 
available. 

  
In a CATPart document, you may have Part Design features and Sheet Metal features according to the 
following rules:

●     Part Design features can be created before Sheet Metal features.

●     a Part Design feature can also be created after Sheet Metal features as long as the part is 
in folded view.

●     in the unfolded view, the Part Design feature will not be displayed.

●     it is no longer possible to create Sheet Metal features after this last Part Design feature in 
folded view.

1.  Create two walls with an Automatic or Conical Bend for the Sheet Metal Design workbench or two 

walls with a Cylindrical or Conical Bend for the Generative Sheetmetal Design workbench.

2.  Switch to the Part Design workbench.

3.  Launch the Sketcher and draw an oblique line in the yz plane.

4.  Click the icon  to create a Stiffener.
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5.  Switch to the Sheet Metal Design workbench or to the Generative Sheet Metal Design workbench.

6.  Click the Unfold icon .

The stiffener is not displayed on the unfolded view.
 

To add a Generative Sheetmetal Design feature and switch to the Sheet Metal Design workbench or to 
the Generative Sheetmetal Design Design workbench, select the Bend for example and right-click the 
Define In Work Object item. The Generative Sheetmetal Design feature will be added after the Bend 
but before the Stiffener.



Integration With Weld Design

You can open the Integration.CATProduct document from the samples directory to replay the scenario.
If you use the Generative Sheetmetal Design workbench, open the NEWIntegration.CATProduct document.

In a CATProduct document, you may have Weld Design features and Sheet Metal features according to the following rules:

●     Weld Design features are created after Sheet Metal features.

●     in the unfolded view, the Weld Design feature will not be displayed.

●     it is no longer possible to create Sheet Metal features after this last Weld Design feature.

1.  Create two walls.

2.  Switch to Weld Design workbench.

 
3.  Create a weld (in our scenario, we create a Single-V Butt weld)

To add a Generative Sheetmetal Design feature and switch to the Sheet Metal Design workbench, select any of the two walls and 
make it current.

 
The Generative Sheetmetal Design feature will be added after the Bend but before the Stiffener.
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Integration with Generative Drafting

This task explains how to generate an unfolded view of a part with swept wall in a drawing sheet. The 
axes of planar hems, tear drops, and flanges are displayed within the drawing.

 For the SheetMetal Design workbench, open the SweptWall01.CATPart document.
For the Generative Sheetmetal Design workbench, open the NEWSweptWall1.CATPart document.

Make sure you have an appropriate Generative Drafting license.

Make sure that the Generate axis option is checked in the Tools -> Options -> Mechanical Design -
> Drafting -> View tab, prior to generating a view in a .CATDrawing document.

  

1.  Click  or select File -> New...

2.  Select the Drawing type and click OK.

3.  Click OK.

For more information about this workbench, refer to Generative Drafting User's Guide.
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4.  The drawing sheet appears.

5.  Tile the windows horizontally using the Window -> Tile Horizontally menu item.

6.  Select the Unfolded View icon  in the Projections toolbar from the Generative Drafting 

workbench.

This icon is active in the Projections toolbar provided the Generative Sheetmetal Design workbench is 

present.

7.  Choose the xy plane in the Sheet Metal specification tree. A preview of the view is displayed in 

the drawing.

8.  Click in the drawing to validate the view creation. The unfolded view is displayed with the planar 

swept wall axes.



Defining Generative View Styles

This section intends to give you information about Generative Sheetmetal Design-specific generative view style parameters. 

Generative view styles make it possible to customize the appearance of drawings via a set of parameters defined in an XML file. Some 
generative view style parameters are specifically available to produce customized drawings from parts designed in the Generative 
Sheetmetal Design workbench. 

Customizing these parameters is an administrator task. By default, a pre-defined generative view style file, DefaultGenerativeStyle.xml, is 
delivered. This file is located in install_root/resources/standard/generativeparameters. It should not be deleted.

Administrators can customize this file to define their default generative view styles. They can also use this file as a template for creating 
new generative view styles.

When finished, generative view style files must be placed by default in install_root/resources/standard/generativeparameters to make 
them available to the user.
For additional information on how to customize parameters, or more generally on generative view styles, see the Generative Drafting 
User's Guide. The Administration Tasks chapter deals with the administration of generative view styles. The Basic Tasks > Generative 
View Styles chapter explains how to use generative view styles.

 
An appropriate Generative Drafting license is required.

 

SheetMetal parameters

To customize SheetMetal parameters, launch the Standard Definition dialog box, available via Tools -> Standards. Choose the 
generativeparameters category, and then open the DefaultGenerativeStyle.xml file from the drop-down list. Expand the Standard -
> DefaultGenerativeStyle -> SheetMetal -> SheetMetalDesign nodes of the tree.

The parameters available under the Bend node specify how specific sheet metal elements should be projected in a Generative Drafting 
view. 

  
Parameter Value Description

OML 1 = Visible
0 = Hidden Specifies whether the OML (Outer Mold Line) should be projected. 

BTLs 1 = Visible
0 = Hidden Specifies whether BTLs (Bend Tangent Lines) should be projected. 

 



Producing Drawings with Generative View Styles

This tasks shows you how to produce drawings using generative view styles.

Generative view styles make it possible to customize the appearance of drawings via a set of parameters 
defined in an XML file, DefaultGenerativeStyle.xml . Some generative view style parameters are 
specifically available to produce customized drawings from parts designed in the Generative Sheetmetal 
Design workbench. It is the administrator's job to provide suitable styles. Refer to Defining Generative 
View Styles for more information.
For more information on generative view styles and other drafting capabilities, see the Generative 
Drafting User's Guide.

Open the NEWSweptWall1.CATPart document.
Make sure you have an appropriate Generative Drafting license.

1.  Specify your settings before you start: select Tools  -> Options  -> Mechanical Design -> 

Drafting -> Administration tab, and uncheck Prevent generative view style creation.

This activates generative view style functionalities.

2.  Select Start -> Mechanical Design -> Drafting.

The New Drawing Creation dialog box appears. The empty sheet layout is pre-selected.

 

  

3.  Simply click OK. You switch to the Drafting workbench and an empty drafting sheet is created.

4.  For ease of use, tile the windows horizontally using the Window -> Tile Horizontally menu 

item.

5.  Select the Unfolded View icon  in the Projections toolbar from the Generative Drafting 
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workbench. The Generative View Style toolbar is automatically displayed.

 

  

6.  Select one of the available styles from the list, DefaultGenerativeStyle in this case.

7.  Return to the 3D document and select a plane surface on the sheet metal part. The sheet metal 

reference wall plane will be used automatically. 

 

If you prefer to specify which plane should be used, you can also select the plane in the Sheet 

Metal specification tree. 

A preview of the view is displayed in the drawing. 

8.  Click in the drawing to validate the view creation. The unfolded view is created, using the sheet 

metal-specific styles defined by the chosen generative view style. Here, the OML (Outer Mold 

Line) and the BTLs (Bend Tangent Lines) are projected in the view, as specified in the 

DefaultGenerativeStyle.xml file.

 



  



Designing in Context
This section explains and illustrates how to create and use various kinds of features.
The table below lists the information you will find.

Design in context: from a CATProduct document, create a new CATPart document, and create a complete 
SheetMetal Part.
Modify the design: modify another part from another document and update the SheetMetal Part.



Designing in Context

This task explains how to create a Sheet Metal part in an Assembly context.

For the Sheet Metal Design workbench, open the Scenario2.CATProduct document.
For the Generative Sheetmetal Design workbench, open the NEWScenario2.CATProduct document.

  
This scenario, which is valid for both the Sheet Metal Design workbench and the Generative Sheet Metal Design 
workbench, is illustrated using screen captures from the Sheet Metal Design workbench. Results will slightly differ in 
the Generative Sheetmetal Design workbench, for which Automatic bends are not available. 

  

You are in Assembly Design workbench.

The document contains two parts.

1.  Right-click Product1 in the 

specification tree and select 

Components -> New Part...

Provided the Manual Input 
option is checked in Tools -> 
Options -> Infrastructure -
> Product Structure, 
Product Structure tab, the 
Part Number dialog box is 
displayed:
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2.  Enter Part3 in the New part 

Number field and click OK.

A New Part dialog box proposes 

two locations to define the origin 

point.

For more information, refer to 

Inserting a New Part, in the 

Product Structure User's Guide.

 

3.  Click No to locate the part origin according to the Product1 origin point.

Make sure you are in Design Mode:

●     Select Product1

●     Choose Edit -> Representations ->Design Mode

4.  Expand the tree and activate the Part3 Part body by double-clicking. 

5.  Switch to the Sheet Metal Design workbench or to the Generative Sheetmetal Design workbench.



6.  Select the Sheet Metal parameters icon  to create the Sheet Metal characteristics for the part: 

●     1mm for the Thickness

●     3mm for the Bend radius

●     Linear for the Bend extremities

and click OK.

7.  Choose the Tools -> Options -> Infrastructure -> Part Infrastructure, General tab and check the 

Keep link with selected object option, then click OK.

8.  Click the Sketcher icon  and select the zx plane.

9.  Select the Profile icon .

 
10.  Sketch the profile and set the constraints as shown below:

 

●     5mm between the Sheet Metal 
vertical walls and each pad

●     0mm between the Sheet Metal 
horizontal walls and each pad top

●     0mm between the last point of the 
Sheet Metal sketch and the right pad 
side.

11.  Click the Exit icon  to return to the 3D world.

12.  Select the Extrusion icon .



13.  Select the Sheet Metal profile.

The Extrusion Definition dialog 

box appears.

14.  Enter 70mm for Length1 then 

click OK.

The Material Side should be set to the 
outside.

15.  Perform this step only if you are using the Sheet Metal Design workbench: select the Automatic Bends icon 

.

The bends are created.

The new features are shown in 
the specification tree: 

●     Extrusion.1 with five 
walls

●     Automatic Bends.1 with 
four bends (for the Sheet 
Metal Design workbench 
only).

The Sheet Metal part looks like this:

 



Modifying the Design

In this task, you are going to modify the height and the sketch of Pad.1.

For the Sheet Metal Design workbench, the Scenario2.CATProduct document is open from the previous 
task. If not, open the Scenario2_2.CATProduct document from the samples directory.

For the Generative Sheetmetal Design workbench, open the NEWScenario2.CATProduct document.
  

This scenario, which is valid for both the Sheet Metal Design workbench and the Generative Sheet Metal 
Design workbench, is illustrated using screen captures from the Sheet Metal Design workbench. Results 
will slightly differ in the Generative Sheetmetal Design workbench, for which Automatic bends are not 
available. 

   

1.  Double-click Part1\PartBody\Pad.1 in the 

specification tree.

The dialog box is displayed. 

2.  Enter 40mm for the Length and click OK.

The pad is updated.

3.  Double-click Part3 and Update the Sheet Metal part using the Update   icon.

4.  Double-click Part1\Pad.1\Sketch.1.
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5.  Modify the sketch:

6.  Click the Exit icon  to return to the 3D world.

The constraints are respected. 

After the Part3 update, the document looks like this:

 



Managing PowerCopies

 
Create PowerCopies: Select the Insert ->Advanced Replication Tools -> PowerCopy Creation 
command, select the elements making up the PowerCopy from the specification tree, define a name for 
the PowerCopy and its reference elements then choose an icon for identifying it.

 
Instantiate PowerCopies: Select the Insert -> Instantiate From Document command, select the 
document or catalog containing the  powercopy, complete the Inputs within the dialog box selecting 
adequate elements in the geometric area.

 
Save PowerCopies into a Catalog: Select the PowerCopy from the specification tree, select the Insert -> 
Advanced Replication Tools -> PowerCopy Save In Catalog... command, enter the catalog name 
and click Open.

 



Creating PowerCopy Features

This task shows how to use create PowerCopy elements, to be reused later.
A PowerCopy is a set of features (geometric elements, formulas, constraints and so forth) that are 
grouped in order to be used in a different context, and presenting the ability to be re-specified according 
to the context when pasted.
This PowerCopy captures the design intent and know-how of the designer thus enabling greater reusability 
and efficiency.

Open the PowerCopyStart.CATPart document.

1.  Select the Insert ->Advanced Replication Tools -> PowerCopy Creation menu item.

The PowerCopy Definition dialog box is displayed. 

2.  Select, from the specification tree, the elements to be included in the PowerCopy. 

The 
PowerCopy 
Definition 
dialog box is 
automatically 
filled with 
information 
about the 
selected 
elements. 

3.  Define the PowerCopy as you wish to create it:

The Definition tab lets you assign a name to the PowerCopy and presents its components in 
the 3D viewer.
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The Inputs tab lets 
you rename the 
reference elements 
making up the 
PowerCopy.

You can do that for clarification purposes as to their roles,  by selecting the elements in the viewer and 

entering a new name in the Name field.

In this example, we renamed all three elements and in brackets you still can read the elements' default 

name based on their type.

The Parameters tab 
lets you define which of 
the parameter values 
used in the PowerCopy 
you will be able to 
modify at instantiation 
time.

Simply check the Published button.

Use the Name field to give a more explicit name to the element.

The 
Documents 
tab shows 
the complete 
path and role 
of Design 
tables that 
are 
referenced 
by an 
element 
included in 
the Power 
Copy.



The Icon tab lets you 
modify the icon 
identifying the 
PowerCopy in the 
specifications tree. 

A subset of icons is available from the Icon choice button.
If you click ... the Icon Browser opens, giving you access to all the graphic icons installed with the CATIA 
software.

Use the Grab screen 
button to  capture an 
image of the 
PowerCopy to be 
stored with its 
definition in the catalog 
(see Saving PowerCopy 
Features).

Use the Remove preview button to delete the image captured with the Grab screen button.

4.  Click OK to create the PowerCopy.

The PowerCopy is displayed close to the top of the specification tree.

●     Double-click the PowerCopy in the specification tree to display the PowerCopy Definition dialog box 
and edit its contents.

●     A formula is automatically included in a Power Copy definition when all its parameters are included.
Otherwise, i.e. if at least one parameter is not selected as part of the Power Copy, you have to 
manually select the formula to make it part of the definition. If you do so, all the formula's parameters 
that have not been explicitly selected, are considered as inputs of the Power Copy.

●     Once your PowerCopy is created, do not delete the referenced elements used to make up the 
PowerCopy.

 



Instantiating PowerCopy Features

This task shows how to instantiate PowerCopies once they have been created as described in Creating PowerCopy Features.
There are three ways to do this: 

1.  using the contextual menu
2.  using the Insert -> Instantiate From Document menu item
3.  using a catalog

The PowerCopyStart.CATPart document is still open from the previous task, otherwise, 0pen the 
PowerCopyStartResults1.CATPart document.

Using the Contextual Menu Item: 

1.  Select the PowerCopy feature from the specification tree.

2.  Right-click to display the contextual menu, and choose the PowerCopy.1 object -> instantiate menu item. 

The Insert Object dialog box is displayed. 

3.  Complete the Inputs within the dialog box by selecting 

the adequate element in the geometric area.

You need to click the arrow to invert the First Edge 
orientation.

 

Check the Repeat option to be able to repeat the instantiation.
In this case, once you have clicked OK in  the Insert Object dialog box, the latter remains open, the PowerCopy's Inputs are 
listed and ready to be replaced by new inputs, as described above.
Modified parameters using Parameters button are retained as well for the next instantiation.
To exit the command, you then need to uncheck the Repeat button or click Cancel.
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5.  You can also click on the Parameters button to display 

the Parameters dialog box and modify values, if 

needed.

6.  Use the Create formulas button to automatically create 

a formula on every parameters with the same name 

provided there are any.

7.  Click OK in the Parameters dialog box.

 

The Documents button lets you access the list of documents (such as design tables) pointed by one of the elements making 
up the Power copy. 
If there are documents, the Documents dialog box opens and you can click the Replace button to display the File Selection 
dialog box and navigate to a new design table to replace the initial one.
When no document is referenced, the Documents button is grayed within the Insert Object dialog box.

8.  Click OK to create the PowerCopy instance.

The PowerCopy is instantiated in context, meaning 
its limits are automatically re-defined taking into 
account the elements on which it is instantiated.

Using the Insert Menu: 

1.  Select the Insert -> Instantiate From Document menu item.

The Select PowerCopy dialog box is displayed allowing you to navigate to the document or catalog where the  power 

copy is stored.



 

2.  Select the document containing the Powercopy.

The Insert Object dialog box is displayed.

Use the Reference list to choose the correct PowerCopy when several have been defined in the document.

3.  Continue the instantiation as described in Using the Contextual Menu item, step 3.

Using the catalog: 

You need to have a catalog available, created either:
●     using the Catalog capability, see the Infrastructure User's Guide.

●     using the Insert -> Advanced Replication Tools -> PowerCopy Save In Catalog... menu item.

1.  Click the  icon.

If accessing a catalog for the first time, you need to navigate to the catalog location. This location is stored in the 

settings for faster access later on.

2.  Select the catalog containing the PowerCopy you wish to instantiate.



3.  Select the PowerCopy to be instantiated, then you can:

●     drag and drop it onto the reference element

●     double-click the PowerCopy 

●     or right-click on the PowerCopy in the dialog box and use the Instantiate contextual menu.

From then on, you instantiate the PowerCopy as described Using the Contextual Menu item, step 3.

●     You can only instantiate a PowerCopy if the PowerCopy itself and the features making it up have been created in the 
current view mode: i.e. you will be able to instantiate a PowerCopy created in 3D mode, only on a feature in 3D mode, not 
on an unfolded feature.

●     The  icon is always grayed when instantiating Power Copies. It is available with User Features and allows you to 

create and modify URLs.

 



Saving PowerCopy Features

This task shows how to use store Power Copy elements into a catalog, for later use as described in 
Instantiating PowerCopy Features.

Open the PowerCopyStartResults1.CATPart document.

1.  Select the PowerCopy from the specification tree for example.

2.  Choose the 

Insert -> 

Advanced 

Replication 

Tools -> 

(PowerCopy) 

Save In 

Catalog... menu 

item.

The Catalog 

Save dialog box 

is displayed: 

●     When creating a 
catalog for the first 
time, click the ... 
button to display the 
Open dialog box, and 
navigate to the 
location where you 
wish to create a 
catalog.
Then simply key in 
the catalog name and 
click Open.
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●     If you wish to add a PowerCopy to an existing catalog, simply activate the Update an existing 
catalog option in the Catalog Save dialog box

By default, the Catalog Save dialog box recalls the catalog accessed last.

3.  Click OK.

The PowerCopy has been stored in the catalog.

 



Browsing the Sheet Metal Catalog

Open the CornerRelief03.CATPart document from the samples directory.

In this case, the Catalog Browser opens, and lets you choose from a number of sketches.

 

1.  Select a sketch and click OK in the Catalog Browser.

You return to the Corner Relief Definition dialog box, 
that has been updated with the Sketcher icon.
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2.  Click the sketcher icon, and move the sketch to 

position it properly in relation to the part. 

 

 

3.  Click OK, and check the part in a folded view.



Looking For Sheet Metal Features

This task shows how to use the Search capabilities on Sheet Metal Features, in order to detect any 
specific kind of feature.

Open the PowerCopyStart.CATPart document.

1.  Select the Edit ->  Search menu item.

The Search dialog box is displayed. 

2.  From the Type Workbench list choose Sheet Metal.

You can then display the list of Sheet Metal features from the Type list: 

3.  Select the type of feature you wish to find within the open .CATPart document, and click Search.

The list of all elements of the selected type is displayed in the Objects found field:
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You can select an element from the list, it will be highlighted in the geometry area.

To find out more on the search capabilities, refer to Selecting Using the Search... Command (General 
Mode) and Selecting Using the Search... Command (Favorites and Advanced Modes) from the 
Infrastructure User's Guide.

 



Saving As DXF

 
This task shows how save the generated geometry as a DXF document.

To perform this scenario, you can open any sheet metal sample provided in this user's guide.

 
1.  Click the Save As DXF 

icon .

The Select a DXF file 

dialog box is displayed 

allowing you to 

navigate to the correct 

location. 

2.  Indicate the correct path and file name (we saved it as PartSavedAsDXF.dxf).

3.  Click Save.

The geometry has been saved, and can be imported as a DXF file in any system supporting this type.

4.  Close the CATPart Document.

5.  Click File -> Open.

6.  From the File Selection 

dialog box, choose the 

.dxf file type, then select 

the saved part 

(PartSavedAsDXF.dxf).



7.  Click Open.

     
The unfolded view of the part is opened within the Drafting workbench, because the .dxf type is recognized as 
being a drafting type of document.



Note that the axes of  bends and planar hems, tear drops, or flanges are automatically displayed on the drawing.

 
Refer also to DXF/DWG Settings from the Infrastructure User's Guide.

 

 



Workbench Description
The Generative Sheetmetal Design application window looks like this. Click the hotspots to display the related 
documentation. 

 

Menu Bar
Generative Sheetmetal Toolbar

Constraints Toolbar
Reference Elements Toolbar

Specification Tree



Menu Bar

The various menus and menu commands that are specific to Sheet Metal Design are described below.

 

Start File Edit View Insert Tools Windows Help

Tasks corresponding to general menu commands are described in the Infrastructure User's Guide. Refer to the 
Menu Bar section. 

Insert 
For... See...

 

Constraints
Setting Constraints in the Part Design User's 
Guide

Sketcher Refer to Sketching in the Sketcher User's 
Guide.

Sheet Metal 
Parameters...

Managing the Default Parameters

Wall... Creating Walls from a Sketch

Wall on Edge... Creating Walls From An Edge

Extrudes Insert -> Extrudes

Bend... Creating Bends on Walls

Swept Walls Insert -> Swept Walls

Unfold Insert -> Unfold

CutOut Creating a Cutout

Hole... Creating a Hole

Stampings Insert -> Stampings

Patterns Insert -> Patterns

CornerRelief... Creating a Local Corner Relief

Save As DXF... Saving As DXF
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Corner/Chamfer Insert -> Corner/Chamfer

Shape Mapping... Mapping Elements

Advanced 
Replication Tools

Insert -> Replication Tools

Instantiate From 
Document...

Instantiating PowerCopy Features

Insert -> Extrudes
 For... See...

Extrude... Extruding

Rolled Wall... Creating Rolled Walls

Insert -> Swept Walls
For... See... 
Flange Creating a Flange

Hem Creating a Hem

Tear Drop Creating a Tear Drop

User Flange Creating a User Flange

Insert -> Unfold
For... See... 
Unfold Folded/Unfolded View Access

MultiView Concurrent Access

Insert -> Stampings
For... See... 
Flanged Hole... Creating a Flanged Hole

Bead... Creating a Bead

Circular Stamp... Creating a Circular Stamp

Surface Stamp... Creating a Surface Stamp

Bridge... Creating a Bridge

Flanged CutOut... Creating a Flanged Cutout

Stiffening Rib... Creating a Stiffening Rib

Curve Stamp... Creating a Curve Stamp



User Stamp... Creating User-defined Stamping Features

Louver... Creating a Louver

Insert -> Patterns
For... See... 

Rectangular Pattern Creating Rectangular Patterns

Circular Pattern Creating Circular Patterns

User-Defined Pattern Creating User-Defined Patterns

Insert -> Corner/Chamfer
For... See... 

Corner... Creating Corners

Chamfer... Creating Chamfers

 

Insert -> Replication Tools
For... See... 

PowerCopy Creation Creating PowerCopies

PowerCopy Save in 
Catalog

Saving PowerCopies



Generative Sheetmetal Toolbar

  

See Managing the Default Parameters

   

See Recognizing Walls From an Existing Part  

   

See Creating Walls from a Sketch

See Creating Walls From An Edge

See Extruding

See Creating Rolled Walls

   

See Creating Bends From a Line

See Creating Conical Bends

See Local fold and unfold of bends

See Local fold and unfold of bends

   

See Creating Swept Walls

   

See Creating Hoppers  

   

See Unfolding

   

See Creating a Cutout  



see Creating a Hole  

See Stamping

   

See Patterning

   

See Creating a Local Corner Relief

 See Saving As DXF 

   

See Creating Corners

See Creating Chamfers

   

See Mapping Elements

See Creating Bends from a Line



Constraints Toolbar

  

See Setting Constraints from the Part Design User's Guide
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Reference Elements Toolbar

   

See Creating Points

See Creating Lines

See Creating Planes

 



Specification Tree
Within the Sheet Metal Design workbench, you can generate a number of features that are identified in the 
specification tree by the following icons.

Further information on general symbols in the specification tree are available in Symbols Used in the 
Specification Tree.

 

Sheet Metal Parameters  Rectangular Pattern

Wall Circular Pattern

Wall On Edge User-Defined Pattern

Extrude Corner Relief

 
Rolled Wall Corner

Bend Chamfer

Flange Mapping

Hem Point

Tear Drop Line

Swept Flange Plane

Cutout
 

Flat Bend

Hole   

Flanged Hole

Bead   

Circular Stamp   

Surface Stamp   

Bridge    

Flanged Cutout    

Stiffening Rib    
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Curve Stamp    

User-defined Stamp    

 
Louver    



Customizing
This section describes how to customize standards files and settings specific to the Generative Sheetmetal 
Design workbench. 

Customizing settings
Customizing Standard Files 



Customizing settings
 

 
This page deals with the following category of options in the Aerospace Sheet Metal Design tab: 
Standard Profiles Catalog File.

Standard Profiles Catalog File

Enter the default path in this field. You may click the Browse icon .

  By default, this field is empty.

If no catalog path has been defined prior to entering the Catalog Browser command, the default catalog 

is selected and its path is automatically added to the Standard Profiles Catalog File field.



Customizing Standard Files
This section describes how to customize settings.
The task described here deals with permanent setting customizing.

Using Sheet Metal Standards Files

This task explains how to access company standards files.

Open a new document.

1.  Click the Sheet Metal Parameters icon .

The Sheet Metal Parameters dialog box opens.

2.  Select the 

Sheet 

Standards 

Files... button. 

The Sheet Metal 

Part Samples 

window is 

displayed.

3.  Indicate the 

path to the 

Sheet Metal 

table.

These files are available under .xls or .txt format.



4.  Click Open.

In the Sheet 
Metal 
Parameters 
dialog box, 
the Design 
Table icon 

 appears 

opposite the 
Thickness 
and Bend 
radius fields.

The parameters are now in gray, indicating that you can no longer modify the values.

5.  Click the Thickness Design Table icon  and select the line containing the appropriate 

parameters (for example Line 1).

Using the Tools -> Options -> General -> Document tab, Other Folders option, you can specify 
where the files are located. Refer to Document.

This scenario can work when the .CATPart document and all reference table files (Design & Radius) are 
located in the same directory. This directory is the current one when  the Design table is created, and 
also when the .CATPart is open.
However, generally speaking,  you must reference the complete path indicating where the radius table 
files are to be found in the RadiusTable column. In this case, regardless of the current directory, the 
correct tables are located when re-opening the .CATPart document.



6.  Click OK.

The parameter values are updated in the Sheet Metal Parameters dialog box.

7.  Click the Bend 

Radius Design 

Table icon .

8.  Select line 2 

and click OK. 

The parameter 

values are 

updated in the 

Sheet Metal 

Parameters 

dialog box.

9.  Create a bend.

The Bend 

Definition 

dialog box 

displays a 

design table 

for the Bend 

Radius.

The default 

mode, that is 

to say the 

formula:

Bend 

Radius = 

Part Radius 



is 

deactivated.

Let's see the Bend Radius Table, using this icon . 

It shows the Bend Radius and the corresponding Bend Table. 

10.  Click OK.

If the Angle value is contained in the Bend Table, the Bend Allowance uses the 
corresponding value.
If not, the Bend Allowance is computed according to the KFactor. 

Using the Sheet Metal Design Tables:

Steps 1 to 4 are identical. 

5.  Click the Design Table icon  and select a line.



6.  Click OK.

The parameter values are updated in the Sheet Metal Parameters dialog box.

 
At that time, the parameters Thickness and Bend radius are driven by the design table.

They are now in gray, indicating that you can no longer modify the values.

Note that if you create a bend, there is no design table: it's the formula which is used.

 
To disable the access to design tables:

●     Select the Tools -> Options -> Part -> Display tab and check Relations:

the Design Table icon  is displayed in the specification tree.

●     Right-click this icon: the contextual menu appears.

●     Select SheetMetal Thickness Table object -> Deactivate

The relation is no longer used but still exists.

It can be activated at any time.

 



Glossary 

       

B

bend A feature joining two walls

bend extremity Axial relimitation for a straight bend

C

corner relief A feature created at the intersection of several bends or of a bend and a wall allowing to 
remove matter so that the part can fold/unfold without overlapping.

cutout A feature corresponding to an opening through a feature.
The shape of the opening corresponds to the extrusion of a profile.

E

extrusion A feature created by extruding a profile and adding thickness

F

flange A feature created by sweeping a profile along a spine.
The different flanges or swept walls available are: simple and swept flange, hem and tear 
drop.

P

pattern A set of similar features repeated in the same feature or part

profile An open or closed profile including arcs and lines created by the Profile command in the 
Sketcher workbench

R



reference wall The first created wall; when unfolding the part, it is the fixed wall.

S

stamping A feature created by embossing sheet metal.
The different stampings available are:
point/circular, extruded/flanged hole, flanged cutout, curve, surface, bridge, louver and 
stiffening rib.

W

wall A feature created by adding thickness to a profile

 



Index 

                  

A
Assembly Design workbench 

interoperability  
Automatic Bends 

command  

B
bead  
Bend 

command  
bend allowance 

defining  

bend extremities  

defining  
Bend From Flat 

command  
bend radius 

defining   
bends 

creating    
bisecting 

lines  

bridge  
browsing 

Sheet Metal catalog  

C
canonic hoppers, creating  



catalog  
Chamfer 

command  
chamfers 

creating  
Circular Pattern 

command  

circular stamp  

clearance  
command 

Automatic Bends  

Bead  

Bend  

Bend From Flat  

Bridge  

Chamfer  

Circular Pattern  

Circular Stamp  

Conical Bend  

Corner  

Corner relief  

Curve Stamp  

Cutout   

Extrusion    

Flange  

Flanged Cutout  

Flanged Hole  

Fold/Unfold Curves  

Hem  

Hole  

Hopper  

Line  

Louver  



Multi Viewer  

Plane  

Point  

PowerCopy Creation  

PowerCopy Instantiation  

PowerCopy Save In Catalog  

Recognize  

Rectangular Pattern  

Save As DXF  

Sheet Metal Parameters    

Stiffening Rib  

Surface Stamp  

Tear Drop  

Unfold  

Unfolded View   

User Flange  

User Pattern  

User Stamping   

Wall   

Wall on Edge  
Commands 

Search  
Conical Bend 

command  

conical bends  
Corner 

command  
corners 

creating  
create 

bead  

bridges  

circular stamp  



Corner relief  

curve stamp  

extruded hole  

flange  

flanged cutout  

hem  

Hole  

stiffness rib  

surface stamp  

tear drop  

user flange  

creating  

bends    

canonic hoppers  

chamfers  

circles  

conical bends  

corners  

curves  

cutouts  

extrudes  

hoppers  

lines  

louvers  

patterns    

planes  

points  

Power Copy  

stamps   

surfacic hoppers  

swept walls  

user-defined stamps  



walls      

creating line  

creating plane  

creating point  
crown 

defining  

Curve Stamp  
curves 

creating  
customizing 

Generative Sheetmetal Design settings  
Cutout 

command   

cutout  
cutouts 

creating  

cutting faces  

D
defining 

bend allowance  

bend extremities  

bend radius   

crown  

thickness   

design tables  

die stamps  

drawing  
drawings 

defining generative view styles  

producing  

producing with generative view styles  



DXF format  

E
editing 

user-defined stamps  
elements 

Sheet Metal Design  

extruded hole  

create  
extrudes 

creating  
Extrusion 

command    

F
Flange  
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