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Overview
Welcome to the Electrical 3D Design and Documentation User's Guide!
This guide is intended for users who need to become quickly familiar with the product. 

This overview provides the following information:

●     Electrical 3D Design & Documentation in a Nutshell 

●     Before Reading this Guide 

●     Getting the Most Out of this Guide 

●     Accessing Sample Documents 

●     Conventions Used in this Guide 

Electrical 3D Design & Documentation in a Nutshell

Electrical 3D Design & Documentation  is a product which provides machinery and consumer goods 
industry with a dedicated toolset for designing and documenting their electrical systems.

This product offers the following main functions:

●     electrical devices on parts and assemblies definition

●     geometrical and electrical bundle creation

●     assisted device placement according to the electrical specifications coming from external data (iXF file)

●     creation and management of wire and electrical device catalogs

●     wire routing

●     harness flattening capabilities.

Before Reading this Guide
Before reading this guide, you should be familiar with basic Version 5 concepts such as document windows, 
standard and view toolbars. Therefore, we recommend that you read the Infrastructure User's Guide that 
describes generic capabilities common to all Version 5 products. It also describes the general layout of V5 and 
the interoperability between workbenches.

Getting the Most Out of this Guide



To get the most out of this guide, we suggest that you start reading the User Tasks section, which deals with 
handling all the product functions.

The Workbench Description section, which describes the Electrical 3D Design & Documentation workbench, and 
the Customizing section, which explains how to set up the options, will also certainly prove useful.

Navigating in the Split View mode is recommended. This mode offers a framed layout allowing direct access 
from the table of contents to the information.

Accessing Sample Documents
To perform the scenarios, sample documents are provided all along this documentation. For more information 
about this, refer to Accessing Sample Documents in the Infrastructure User's Guide.

Conventions Used in this Guide
To learn more about the conventions used in the documentation, refer to the Conventions section.
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Conventions
Certain conventions are used in CATIA, ENOVIA & DELMIA documentation to help you recognize and understand 
important concepts and specifications. 

Graphic Conventions

The three categories of graphic conventions used are as follows:

●     Graphic conventions structuring the tasks

●     Graphic conventions indicating the configuration required

●     Graphic conventions used in the table of contents

Graphic Conventions Structuring the Tasks

Graphic conventions structuring the tasks are denoted as follows:

This icon... Identifies...

estimated time to accomplish a task

a target of a task

the prerequisites

the start of the scenario

a tip

a warning

information

basic concepts

methodology

reference information

information regarding settings, customization, etc.

the end of a task



functionalities that are new or enhanced with this release

allows you to switch back to the full-window viewing mode

Graphic Conventions Indicating the Configuration Required 

Graphic conventions indicating the configuration required are denoted as follows:

This icon... Indicates functions that are... 

specific to the P1 configuration

specific to the P2 configuration

specific to the P3 configuration

Graphic Conventions Used in the Table of Contents

Graphic conventions used in the table of contents are denoted as follows:

This icon... Gives access to...

Site Map

Split View mode

What's New?

Overview

Getting Started

Basic Tasks

User Tasks or the Advanced Tasks

Workbench Description

Customizing

Reference

Methodology

Glossary



Index

Text Conventions

The following text conventions are used:

●     The titles of CATIA, ENOVIA and DELMIA documents appear in this manner throughout the text.

●     File -> New identifies the commands to be used.

●     Enhancements are identified by a blue-colored background on the text.

How to Use the Mouse

The use of the mouse differs according to the type of action you need to perform.

Use this
mouse button... Whenever you read...

 
●     Select (menus, commands, geometry in graphics area, ...)

●     Click (icons, dialog box buttons, tabs, selection of a location in the document window, 
...)

●     Double-click

●     Shift-click

●     Ctrl-click

●     Check (check boxes)

●     Drag

●     Drag and drop (icons onto objects, objects onto objects)

●     Drag

●     Move

●     Right-click (to select contextual menu)



User Tasks

The User Tasks section explains and illustrates how to create various kinds of features.
The table below lists the information you will find.

Using Electrical 3D Design & Documentation
Defining Electrical Devices

Defining Electrical Connection Points
Creating Supports

Connecting/Disconnecting Devices
Using Catalogs

Creating a Geometrical Bundle
Creating a Bundle Segment Document

Creating an Electrical Bundle
Selecting External Data Systems
Routing Wires from External Data

Managing Links from External Data
Viewing Related Objects

Defining the Harness Flattening Parameters
Extracting Data

Flattening the Harness
Rotating Bundle Segments
Scaling Bundle Segments

Synchronizing the Environment
Using the Drawing Capabilities

Defining the Report Format
Generating a Report



Using Electrical 3D Design
& Documentation

This task explains how to set up the environment to work with CATIA - Electrical 3D Design & Documentation.
CATIA - Electrical 3D Design & Documentation includes two workbenches:

Electrical 3D Design Assembly workbench to work at the level of an assembly of electrical objects.

Electrical 3D Design Part workbench to add electrical behavior at the level of a part.



Entering the Electrical 3D Design
Assembly Workbench

The Electrical 3D Design Assembly workbench allows you to create electrical assemblies in CATProduct 
documents.

CATIA V5 is launched. A CATProduct document is displayed.

1.  Choose the Electrical 3D Design Assembly item from the Start ->  Equipments & Systems 

menu.

The Electrical 3D Design Assembly workbench is displayed and ready to use.

 



Using the Electrical 3D Design
Part Workbench

The Electrical 3D Design Part workbench is used to define electrical connectors or to convert standard 
parts into electrical devices.

CATIA V5 is launched. A CATPart document is displayed.

1.  Choose the Electrical 3D Design Part item from the Start ->  Equipments & Systems menu.

The Electrical 3D Design Part workbench is displayed with a CATPart document.

 



Defining Electrical Devices
These functionalities are available in both the Electrical Assembly and Part workbenches.
They are used to add an electrical behavior to a product or a part.
As a result, the product itself, the instance or the reference becomes an electrical element:

●     When you open a CATPart document and you add an electrical behavior to the part, it is the reference 
which will be modified. If you insert this part in an assembly, all the occurrences will be modified.

●     When you open a CATProduct document containing a CATPart, if you double-click to activate the product of 
the part or the part, and add an electrical behavior to it, the result is similar: you have modified the 
reference and all the occurrences will have an electrical behavior. As a consequence, you will have to save 
the part.

●     On the other hand, if the root product is activated and you select the product of the part, it is only this 
instance of the part which will become an electrical device. The reference is NOT modified.

This rule applies for all the devices.

Equipment: Click this button and select the part or product to be converted into an equipment.

Connector: Click this button and select the part or product to be converted into a connector.



Defining an Equipment 

This task explains how to add an electrical behavior to a standard part.
An equipment is an electrical device with one or more associated connectors placed into cavities.

Let's see two different cases to illustrate:

●     first, you will work with an instance of the product, i.e. only this instance will get the electrical 
behavior.
If you insert the part to another assembly, it remains a standard part.

●     then, you'll work with the reference of the part, i.e. all the instances of the part will get the 
electrical behavior.

Adding the electrical behavior to an instance...

The CATProduct document contains standard parts, which do not have electrical behavior.

1.  Click the Define Equipment button .
You are prompted to select a part or a product.

2.  Click the equipment either in the specification tree or in the geometry.

The Define Equipment Part dialog box opens:

3.  Enter/change the name in the Instance name field if necessary.

4.  Click OK  to validate.

The specification tree is updated. The part is not modified.

The equipment is now an electrical object as the electrical behavior has been added to this 
instance.



Adding the electrical behavior to the reference...

Now if you open the CATPart document or, if you double-click to activate the PartForEquipment 

document in the example shown below, you will modify the reference document.

1.  Click the Define Equipment button .
You are prompted to select a part or a product.

2.  Click the equipment (here PartForEquipment) either in the specification tree or in the geometry.

The Equipment Part Definition dialog box opens:

Note that it is the Part Number, which is displayed for edition.

3.  Change the name in the Part Number field if necessary.

4.  Click OK  to validate.

The specification tree is updated. The part has been modified.

The equipment is now an electrical object as the electrical behavior has been added to this 
reference.



An equipment allows bundle connection points, cavities as well as single insert connectors connected 
into cavities through a cavity connection point.

 



Defining an Electrical Connector 

This task explains how to add an electrical behavior to a standard part to turn it into an electrical 
connector.

You can add an electrical behavior to an instance or a reference.

Refer to Defining an Equipment.

The CATProduct document contains standard parts, which do not have electrical behavior.

1.  Click the Define Connector button .
You are prompted to select a part or a product.

2.  Click the connector either in the specification tree or in the geometry.

The Define Connector dialog box opens:

The only type available is Single Insert Connector: male or female connector.

3.  Change the name in the Instance name field if necessary.

4.  Enter the Number of termination to be defined onto the connector.

The electrical terminations are used to connect wires.

5.  Click OK to validate.

The specification tree is updated. The part is not modified.

The instance of the connector is now an electrical object as the electrical behavior has been 
added.



A single insert connector allows one connector connection point, bundle connection points and 
terminations.

 



Defining Electrical Connection Points
The connection functionalities are available in both the Electrical Assembly and Part workbenches.

Cavity: Click this button and select the equipment where you want to define a cavity.

Termination: Click this button and select the device where you want to define a termination.

Bundle Connection Point: Click this button and set the placement constraints for the connection point 
between connectors and bundle segments.
Connector Connection Point: Click this button and set the placement constraints for the connection 
point between connectors.
Cavity Connection Point: Click this button and set the placement constraints for the connection point 
between cavities and equipments.

It is possible to delete the electrical cavities, terminations and the connection points.
This applies to: 

●     termination

●     cavity

●     cavity connection point

●     connector connection point

●     bundle connection point.

Note that when deleting these objects, the associated publications are also deleted.

But the publications of the geometries which constrain their placement are NOT automatically deleted, since 
they may have been created earlier, from another application.
According to your choice, you can delete them using the publication management available in the Assembly 
Design workbench (Tools -> Publication menu item).

file:///E|/www/ADGdocR14/Doc/online/cfyugprt_C2/cfyugpublish.htm


Defining a Cavity 

This task explains how to define a cavity on an electrical device.
The cavity is used to specify the location of the electrical object when connecting.

Open any document containing an equipment where you want to place a cavity.

1.  Click the Define Cavity button .

The Cavity Definition dialog box opens:

2.  Select the equipment where you want the cavity to be defined.

3.  Change/enter a value in the IdNumber field.

Note that the IdNumber must be unique.

4.  Select a Representation, for example a pocket, a pad, a face...

5.  Optionally, place a Contact constraint, for example a surface or a point.

6.  Optionally, place a Coincidence constraint, for example a surface, a line or an axis.

7.  Optionally, place an Orientation constraint, for example a surface, a line or an axis.

The orientation is used to constrain the rotation i.e. the third degree of liberty.

8.  Click OK  to validate.

The specification tree is updated.



For more information about the placement constraints, refer to Using Assembly Constraints.

A cavity is allowed on equipments.
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Defining a Termination 

This task explains how to define a termination on a connector.
The termination is indissociable from the electrical component and corresponds to a contact crimped into 
a cavity.

Open any document containing a connector where you want to place a termination.

1.  Click the Define Termination button .

2.  Select the electrical device where you want the termination to be defined.

The Termination Definition dialog box opens:

3.  Change/enter a value in the IdNumber field.

Note that the IdNumber must be unique.

4.  Optionally select a Representation, for example a pocket, a pad, a face...

5.  Click OK to validate.

The specification tree is updated.



A termination is allowed on connectors.

 



Defining a Connector Connection Point 

This task explains how to define a connector connection point on a connector.
The connector connection point is used to specify how the mating connectors are placed when 
connecting.

Open any document containing a single insert connector where you want to place a connector connection 
point.

1.  Click the Define Connector Connection Point button .

2.  Select the electrical device where you want the connector connection point to be defined.

The Connector Connection Point Definition dialog box opens:

3.  Change/enter a value in the Name field.

4.  Select a Representation, for example a pocket, a pad, a face...

5.  Optionally, place a Contact constraint, for example a surface or a point.

6.  Optionally, place a Coincidence constraint, for example a surface, a line or an axis.

7.  Optionally, place an Orientation constraint, for example a surface, a line or an axis.

The orientation is used to constrain the rotation i.e. the third degree of liberty.

8.  Click OK  to validate.

The specification tree is updated.



For more information about the placement constraints, refer to Using Assembly Constraints.

A connector connection point is only allowed on single insert connectors.
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Defining a Bundle Connection Point 
This task explains how to define a bundle connection point on a device.
The bundle connection point is used to specify the position and the direction of the bundle segment 
connected to the connector or the equipment.

Open any document containing a connector where you want to place a bundle connection point.

1.  Click the Define Bundle Connection Point button .

2.  Select the connector or equipment where you want the bundle connection point to be defined.

The Bundle Connection Point Definition dialog box opens:

3.  Change/enter a value in the Name field.

4.  Select a Representation, for example a surface or a point.

5.  Set a Point constraint: select a point.

This point will possibly be used as bundle segment extremity.

6.  Set a Initial Condition constraint: select a plane or an axis.

This plane or axis will possibly be used to orientate the bundle segment.

7.  Click OK  to validate.

The specification tree is updated.



A bundle connection point is allowed on equipments and connectors.



Defining a Cavity Connection Point 

This task explains how to define a cavity connection point on an equipment.
The cavity connection point is used to specify how the connector is placed in the cavity when connecting.

Open any document containing an equipment and a connector, where you want to place a cavity 
connection point.

1.  Click the Define Cavity Connection Point button .

2.  Select the connector where you want the cavity connection point to be defined.

The Cavity Connection Point Definition 

dialog box opens:

3.  Change/enter a value in the Name field.

4.  Select a Representation, for example a pocket, a pad, a face.

5.  Optionally, set a Contact constraint, for example a surface or a point.

6.  Optionally, set a Coincidence constraint, for example a surface, a line or an axis.

7.  Optionally, set an Orientation constraint, for example a surface, a line or an axis.

The orientation is used to constrain the rotation i.e. the third degree of liberty.

8.  Click OK  to validate.

The specification tree is updated.



For more information about the placement constraints, refer to Using Assembly Constraints.

A cavity connection point is allowed on connectors.
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Creating Supports 

This task explains how to define a support for electrical bundle segments.
This functionality is available in Electrical Part Design workbench only.
A support is a mechanical object used to hold the bundle segments in position.

Open any document containing a standard part (with no electrical behavior).

1.  Click the Define Support button .

You are prompted to select a part.

2.  Click the Support either in the specification tree or in the geometry.

The Support Definition dialog box opens:

3.  Enter/change the name for the support.

4.  Select the point through the support, to define the reference position of the bundle segment in 
the support.



If the point is not already defined, click the  button.
For more information, refer to the Point Definition.

You are prompted to select the first plane: the way in of the support.

5.  Select the front face.

You are prompted to select a second plane: the way out of the support.

6.  Select the opposite face.

To be selectable, it must be parallel to the first face.

7.  Click OK to validate.

The specification tree is updated:
two extra planes have been defined (Plane.1 and Plane.2).

 



Connecting/Disconnecting
Electrical Devices

These functionalities are only available in the Electrical Assembly workbench.

Connecting: Click this button and select the devices you want to connect.

Disconnecting: Click this button and select the devices you want to disconnect .

  



Connecting Electrical Devices 

This task explains how to connect the electrical devices.

When you create an electrical connection between two devices: 
●     an electrical link is created between the connected components. See Related Objects.

●     if placement constraints have been defined on connection points, the mechanical assembly 
constraints are automatically created.

Since it's possible to use this command in visualization mode (with the cache activated), the scenario is 
described according to the two modes:

●     The design mode is mandatory to perform the connections.

●     In visualization mode, the model is lighter since the geometry is not loaded.
It allows you to display large assemblies.
When you work in visualization mode, CATIA switches to the design mode only for the elements 
which contribute to the connection.

In Design Mode

If you open the document in design mode (the cache is not activated), the whole geometry is loaded.

1.  Click the Connect Electrical Devices button  to connect two devices.

You are prompted to select the first device.

❍     it's the first selected object that moves to the second one's location

❍     an electrical connection has been created as well as mechanical constraints.

2.  Select the first device either in the geometry or in the specification tree:
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You are prompted to select another device.

3.  Move the cursor onto the second device before selecting it, as shown below:

The cavity connection point of the first device and the cavities of the second one are displayed in 
green: this means that it is possible to connect the connector into the cavity of the equipment.

According to the selection, if a cavity is already used or if no connection point is defined on the 
equipment, it is displayed in red.



4.  Click to select a connection point available on the equipment, Cavity1 for example.

The devices are connected together and the mechanical constraints are added to the 
specification tree:

Note that you can select the second connection point using one of the three following ways to get the 
same result:

●     the representation of the connection point in the geometry

●     the label with the name of the connection point

●     the connection point in the specification tree.

In Visualization Mode

If you open the document in visualization mode (the cache is activated), the geometry is not loaded.
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1.  Select the Connect Electrical Devices button  to connect two devices.

You are prompted to select the first device.

❍     it's the first selected object that moves to the second one's location

❍     an electrical connection has been created together with mechanical constraints.

2.  Select the first device either in the geometry or in the specification tree.

You are prompted to select the second device.

3.  Move the cursor onto the second device before selecting it, as shown below:

Note that:
❍     You cannot expand the specification tree since you are in visualization mode.

❍     No annotations are displayed on the device connection points.

4.  Click to select the equipment:

The geometry is loaded for both devices and the annotations display:



5.  Click to select a connection point available on the device, for example Cavity1.

The devices are connected together and the mechanical constraints are added to the 
specification tree:



Note that the specification tree also displays the plus sign  for the other devices: this is due to the 
update, which loads the publications. However the geometry for these components is not loaded, as 
shown in the picture below:



Disconnecting Electrical Devices 

 
This task explains how to disconnect electrical devices.

1.  Select the Disconnect Electrical Devices button  to disconnect devices.
You are prompted to select the first device.

2.  Select the first device you want to disconnect:

You are prompted to select another device.

3.  Select the second device that was connected to the first one:



The devices are disconnected.

❍     The electrical connection is deleted.

❍     The mechanical constraints are deleted in the geometry and the specification tree:

Note that the device position remains unchanged but as the mechanical constraints have been deleted, 
you can shift the connectors using the compass.

 



Using Catalogs
These functionalities are available in the Electrical Assembly workbench.
The first one is also available in the Electrical Part workbench.

 
Connecting Devices: Drag and drop the device from the catalog at its proper placing.

Using Smart Placement: Select the component, point to the correct position and click to place it.



Connecting Devices by Drag and Drop
at Placement

This task explains how to place devices by drag and drop with automatic connection to an existing 
component.

Open a new product document.

1.  Click the Catalog Browser button  to open the ElecIntegration.catalog.

The full path is:
.../online/cfysa_C2/samples/ElectricalIntegration\ElecIntegration.catalog

The dialog box opens on Chapter.1.

If necessary, use the Open button  to browse another catalog and select the 
ElecIntegration.catalog from the samples folder.

To know more about the Catalog workbench, refer to Using Catalogs.

2.  Double-click the Equipments: the folder contents displays.

3.  Select the Battery 6volts, drag and drop it onto the Product1 in the specification tree.

The equipment is imported.
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4.  Select Connectors as Current folder, then

5.  Select the Connector_F1, drag and drop it onto the cavity.

The connector is properly located into the cavity: the constraints are created.
The result looks like this:

The component is instantiated under the active product.

6.  Close the Catalog Browser.



Note that  when you insert a device into a product, you can take advantage of CATIA - Assembly 
capabilities to constrain the device within the digital mock-up, profiting therefore by the associativity. For 
more information, refer to Using Assembly Constraints.

 

file:///E|/www/ADGdocR14/Doc/online/cfyugasm_C2/cfyugasmut0300.htm


Using Smart Placement from Catalog 

This task explains how to place a component from a catalog using a compass.

Make sure you have set up the automatic compass option.

1.  Click the Smart Place button .

The Catalog Browser displays.

If necessary, navigate to select the catalog of interest using the Browse another catalog 

button .

2.  Select the part you want to place.

In the graphic area, a manipulator displays allowing you to select: 
❍     the placement point

❍     the privileged plane

❍     the direction. By pressing the Shift key, you can invert the direction.



 

3.  Point to the chosen position and click to place the support.

The support is placed on the plane selected, with a compass automatically snapped to the part.

 

4.  Use this compass to orientate the support.



 
You can also select an edge in the geometry:
A green arrow appears showing the orientation. By pressing the Shift key, you can invert the 
arrow direction.

 



Click to select the chosen orientation.
The support is orientated according to the edge you have selected: the rotation applied to the 
object aligns the compass V axis to the manipulator's green arrow.

 

5.  Point to the next position if you want to place the support again.

Otherwise, click a different part from the catalog and repeat these steps.

6.  Click Close when you are done.

●     The part is stored in the catalog with:

❍     an origin point

❍     a x, y and z direction.

●     The origin of the part (the support in this example) is placed at the point selected with the compass.

●     The x, y plane of the part is parallel to the plane selected using the compass.

●     The z direction of the part is collinear to the z direction selected using the compass.



Creating a Geometrical Bundle 

This task shows how to create a geometrical bundle.
A geometrical bundle is the representation of an assembly of wires grouped together with a common 
covering and connected to electrical connectors.

Make sure the design mode is activated otherwise a warning is displayed:

Click Yes.

It corresponds to the following settings in the Tools -> Options... menu item:

●     Select the Infrastructure -> Product Structure -> Cache Management tab.

●     In the Cache Activation, the Work with cache system option is not checked.

●     As a consequence, in the Product Visualization tab, the Visualization Mode Type is set to None.

Open a document containing devices to be connected within a geometrical bundle.



1.  Click the Geometrical Bundle button .
You are prompted to select the product you want to become the geometrical bundle.

2.  Select the product of interest: Product1

The geometrical bundle is created, with electrical capabilities.

In the specification tree, the name has been modified as well as the icon.

Only the following can be selected to become a geometrical bundle: 
●     a product which is not already electrified

●     a product which doesn't result from the New Part command

●     a product which doesn't result from the New Component command (inline product).

 



Creating a Bundle Segment Document 
This task explains how to create the document in which the bundle segments take place.
The bundle segment belongs to a part document with electrical properties.

To create and route a bundle segment, you have to:

●     define the bundle segment parameters

●     possibly create points, lines or planes if needed

●     then define the bundle segment route.

The document now contains a geometrical bundle.

1.  Double-click to activate the desired product: Geometrical Bundle1

2.  Click the Multi-Branchable Bundle Segment button .



The bundle segment document is created with the Multi-branchable1 product including: 
❍     the Multi-branchable1 part that becomes active

❍     the Flexible Curve.1 belonging to the part, which at that time, does not have any 
geometrical representation.

The Electrical 3D Design Assembly workbench switches to the Electrical 3D Design Part 
workbench.

 



Defining the Segment Parameters

This task shows you how to define the bundle segment parameters.

The bundle segment to be defined is activated in the specification tree.
You have switched to the Electrical 3D Design Part workbench.

1.  Click the Branchable Bundle Segment Definition button .

The dialog box opens:

2.  Enter a value in the Diameter field. The Section is automatically computed.

As an alternative, you can enter the Section, the Diameter will be computed.

The bend radius must be at least equal to the Diameter value to insure the correct 
bundle segment route computation. A message warns you if it is not the case.

3.  Enter a value for the Bend Radius.

The Bend Radius is the minimum bend radius allowed for the bundle segment.

As an alternative, you can select the Bend Radius Ratio option and set the ratio: the Bend 

Radius is automatically computed.

4.  Select the Mode:



The different options are:
❍     Slack:

the bundle segment length is increased by the percentage indicated in the Slack(%) field. 
The Length field is disabled.

❍     Length:
the bundle segment length is indicated in the Length field. The Slack(%) field is disabled.

❍     Bend:
the bundle segment length corresponds to the minimum distance between the points 
defining its route. The  Slack(%) and Length fields are disabled.

At this stage, the bundle segment parameters are defined.

You now need to route the bundle segment to be able to complete the definition: through this 

operation, you will create the geometrical representation of the Flexible Curve.

Note that OK and Apply are deactivated.

5.  See the next task which explains how to route the bundle segment according to the geometrical 

constraints.

 



Defining the Segment Route Constraints

This section explains how to define the bundle segment route creating the Flexible Curve representation.
See also Getting Information from the Specification Tree Icons

The Bundle Segment parameters have been defined in the previous task.

1.  Click the Route Definition button.

The Bundle Segment Route Definition dialog box opens:

2.  Click successively the connectors and/or supports:

CATIA finds the closest bundle connection point or section on supports, according to the 
selection point.



The Flexible Curve spline is displayed:

3.  Click OK to validate.

The Bundle Segment Route Definition dialog box closes and the Bundle Segment Definition is displayed 
afresh.
Note that OK and Apply are now activated.

4.  Click OK to validate the bundle segment definition.

The bundle segment is created

You can take advantage of the Related Objects viewer to focus on an object and see how it was constructed via its 
related objects. The related objects command identifies the parent, any children or connected objects and the 
relationship between objects.

Getting Information from the Specification Tree Icons



Each time you click the Apply or OK button during the definition phase, or if you update the bundle segment after 
any parameter modification, the following algorithm is launched to compute the best possible shape. Depending on 
the result, the specification tree is updated according to the following chart:

Note that working in Cache mode, the bundle segment does not display the  icon.



Creating Points

 

This task shows the various methods for creating points: 
●     by coordinates

●     on a curve

●     on a plane

●     on a surface

●     at a circle/sphere center

●     tangent point on a curve

●     between

 
Open the Points3D1.CATPart document.

 
1.  Click the Point icon  .

The Point Definition dialog box appears.

2.  Use the combo to choose the desired point type.

Coordinates 
●     Enter the X, Y, Z coordinates 

in the current axis-system.

●     Optionally, select a reference 
point.

The corresponding 
point is displayed.

 

 

When creating a point within a user-defined axis-system, note that the Coordinates in absolute axis-
system check button is added to the dialog box, allowing you to be define, or simply find out, the point's 
coordinates within the document's default axis-system.
If you create a point using the coordinates method and an axis system is already defined and set as 
current, the point's coordinates are defined according to current the axis system. As a consequence, the 
point's coordinates are not displayed in the specification tree.

The axis system must be 
different from the absolute axis.  
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On curve 
●     Select a curve

●     Optionally, select a reference 
point.

If this point is not on 
the curve, it is 
projected onto the 
curve.
If no point is selected, 
the curve's extremity 
is used as reference.

 

●     Select an option point to 
determine whether the new 
point is to be created: 

❍     at a given distance along 
the curve from the 
reference point

❍     a given ratio between the 
reference point and the 
curve's extremity.

    

●     Enter the distance or ratio 
value.
If a distance is specified, it 
can be: 

❍     a geodesic distance: the 
distance is measured 
along the curve

❍     an Euclidean distance: 
the distance is measured 
in relation to the 
reference point (absolute 
value).

The corresponding point is 
displayed.



If the reference point is located at the curve's extremity, even if a ratio value is defined, the created point 
is always located at the end point of the curve.

You can also: 
●     click the Nearest extremity button to display the point at the nearest extremity of the curve.

●     click the Middle Point button to display the mid-point of the curve.

Be careful that the arrow is orientated towards the inside of the curve (providing the curve is not closed) 
when using the Middle Point option.

●     use the Reverse Direction button to display: 
❍     the point on the other side of the reference point (if a point was selected originally)

❍     the point from the other extremity  (if no point was selected originally).

●     click the Repeat object after OK if you wish to create equidistant points on the curve, using the 
currently created point as the reference, as described in Creating Multiple Points in the Wireframe and 
Surface User's Guide. 

You will also be able 
to create planes 
normal to the curve at 
these points, by 
checking the Create 
normal planes also 
button, and to create 
all instances in a new 
geometrical set  by 
checking the Create 
in a new 
geometrical set 
button.
If the button is not 
checked the instances 
are created in the 
current geometrical 
set .

 

●     If the curve is infinite and no reference point is explicitly given, by default, the reference point is the 
projection of the model's origin

●     If the curve is a closed curve, either the system detects a vertex on the curve that can be used as a 
reference point, or it creates an extremum point, and highlights it (you can then select another one if 
you wish) or the system prompts you to manually select a reference point.

 

Extremum points created on a 
closed curve are now aggregated 
under their parent command and 
put in no show in the 
specification tree.



On plane 
●     Select a plane.

●     Optionally, select a point to 
define a reference for 
computing coordinates in the 
plane.

If no point is selected, 
the projection of the 
model's origin on the 
plane is taken as 
reference. 

 

 
 

●     Optionally, select a surface 
on which the point is 
projected normally to the 
plane.

If no surface is 
selected, the behavior 
is the same.

Furthermore, the 
reference direction (H 
and V vectors) is 
computed as follows: 
With N the normal to 
the selected plane 
(reference plane), H 
results from the 
vectorial product of Z 
and N (H = Z^N). 
If the norm of H is 
strictly positive then V 
results from the 
vectorial product of N 
and H (V = N^H).
Otherwise, V = N^X 
and H = V^N.

Would the plane 
move, during an 
update for example, 
the reference direction 
would then be 
projected on the 
plane. 



●     Click in the plane to display a point.

On surface 
●     Select the surface where the 

point is to be created.

 

●     Optionally, select a reference 
point. By default, the 
surface's middle point is 
taken as reference. 

●     You can select an element to 
take its orientation as 
reference direction or a plane 
to take its normal as 
reference direction.
You can also use the 
contextual menu to specify 
the X, Y, Z components of 
the reference direction.

●     Enter a distance along the 
reference direction to display 
a point.

 
    

Circle/Sphere center 
●     Select a circle, circular arc, 

or ellipse, or

●     Select a sphere or a portion 
of sphere.



A point is displayed at 
the center of the 
selected element.

    

Tangent on curve 
●     Select a planar curve and a 

direction line.

A point is displayed at 
each tangent. 

    

The Multi-Result 
Management dialog 
box is displayed 
because several points 
are generated. 

●     Click YES: you can then 
select a reference element, 
to which only the closest 
point is created.

●     Click NO: all the points are 
created.

For further information, refer to 
the Managing Multi-Result 
Operations chapter.

Between
●     Select any two points.
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●     Enter the ratio, that is the 
percentage of the distance 
from the first selected point, 
at which the new point is to 
be.
You can also click Middle 
Point button to create a 
point at the exact midpoint 
(ratio = 0.5).

Be careful that the arrow is orientated towards the inside of the curve (providing the curve is not closed) 
when using the Middle Point option.

●     Use the Reverse direction 
button to measure the ratio 
from the second selected 
point.

 
If the ratio value is greater than 1, the point is located on the virtual line beyond the selected points.

3.  Click OK to create the point.

The point (identified as Point.xxx) is added to the specification tree.

●     Parameters can be edited in the 3D geometry. For more information, refer to the Editing Parameters 
chapter.

●     You can isolate a point in order to cut the links it has with the geometry used to create it. To do so, 
use the Isolate contextual menu. For more information, refer to the Isolating Features chapter.
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Creating Lines
This task shows the various methods for creating lines: 

●     point to point

●     point and direction

●     angle or normal to curve

●     tangent to curve

●     normal to surface

●     bisecting

 
It also shows you how to create a line up to an element, define the length type and automatically reselect 
the second point.

 
Open the Lines1.CATPart document.

1.  Click the Line icon  .

The Line Definition dialog box is displayed. 

2.  Use the drop-down list to choose the desired line type.

 
A line type will be proposed automatically in some cases depending on your first element selection.

 

Defining the line type
 

Point - Point 

 
This command is only available with the Generative 
Shape Design 2 product.

●     Select two points.
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A line is displayed between the two 
points.
Proposed Start and End points of the 
new line are shown.

●     If needed, select a support surface.
In this case a geodesic line is created, i.e. going 
from one point to the other according to the 
shortest distance along the surface geometry 
(blue line in the illustration below).
If no surface is selected, the line is created 
between the two points based on the shortest 
distance.

If you select two points on closed surface (a 
cylinder for example), the result may be unstable. 
Therefore, it is advised to split the surface and only 
keep the part on which the geodesic line will lie. 

 
The geodesic line is not available with the Wireframe and Surface workbench.



 
●     Specify the Start and End points of the new line, that is the line endpoint location in relation to the 

points initially selected. These Start and End points are necessarily beyond the selected points, 
meaning the line cannot be shorter than the distance between the initial points.

●     Check the Mirrored extent option to create a line symmetrically in relation to the selected Start and 
End points.

 
The projections of the 3D point(s) must already exist on the selected support. 

Point - Direction 
 

●     Select a reference Point and a Direction line.
A vector parallel to the direction line is displayed 
at the reference point. 
Proposed Start and End points of the new line 
are shown.



●     Specify the Start and End points of the new 
line.
The corresponding line is displayed.

 
The projections of the 3D point(s) must already exist on the selected support. 

  

Angle or Normal to curve
 

●     Select a reference Curve and a Support surface 
containing that curve.



- If the selected curve is planar, then the 
Support is set to Default (Plane).

- If an explicit Support has been defined, 
a contextual menu is available to clear 
the selection.

 
●     Select a Point on the curve.

●     Enter an Angle value.

A line is displayed at the given angle with 
respect to the tangent to the reference 
curve at the selected point. These 
elements are displayed in the plane 
tangent to the surface at the selected 
point. 
You can click on the Normal to Curve 
button to specify an angle of 90 degrees. 
Proposed Start and End points of the line 
are shown. 

●     Specify the Start and End points of the new line.
The corresponding line is displayed.



●     Click the Repeat object after OK if you wish to 
create more lines with the same definition as the 
currently created line. 
In this case, the Object Repetition dialog box is 
displayed, and you key in the number of 
instances to be created before pressing OK.

As many lines as indicated in the dialog box are 
created, each separated from the initial line by a 
multiple of the angle value.

 

You can select the Geometry on Support check box if you want to create a geodesic line onto a support 

surface. 

The figure below illustrates this case.

 

Geometry on support option not checked Geometry on support option checked

 
This line type enables to edit the line's parameters. Refer to Editing Parameters to find out how to display 
these parameters in the 3D geometry.
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Tangent to curve
 

●     Select a reference Curve and a point or 
another Curve to define the tangency. 

❍     if a point is selected (mono-tangent mode): 
a vector tangent to the curve is displayed at 
the selected point.

❍     If a second curve is selected (or a point in bi-
tangent mode), you need to select a support 
plane. The line will be tangent to both 
curves.

 - If the selected curve is a line, then the 
Support is set to Default (Plane).

- If an explicit Support has been defined, 
a contextual menu is available to clear 
the selection.

 When several solutions are possible, you 
can choose one (displayed in red) directly 
in the geometry, or using the Next 
Solution button.

     

 

 

Line tangent to curve at a given point Line tangent to two curves
●     Specify Start and End points to define the new line.

The corresponding line is displayed.



 

Normal to surface 
 

●     Select a reference Surface and a Point.
A vector normal to the surface is displayed at 
the reference point. 
Proposed Start and End points of the new line 
are shown.

 If the point does not lie on the support surface, the minimum distance between the point and the surface 
is computed, and the vector normal to the surface is displayed at the resulted reference point.



●     Specify Start and End points to define the new 
line.
The corresponding line is displayed.

Bisecting 
 

●     Select two lines. Their bisecting line is the line 
splitting in two equals parts the angle between 
these two lines. 

●     Select a point as the starting point for the line. 
By default it is the intersection of the bisecting 
line and the first selected line.



 

●     Select the support surface onto which the 
bisecting line is to be projected, if needed.

●     Specify the line's length in relation to its starting 
point (Start and End values for each side of the 
line in relation to the default end points).
The corresponding bisecting line, is displayed.

●     You can choose between two solutions, using 
the Next Solution button, or directly clicking 
the numbered arrows in the geometry.



3.  Click OK to create the line.

The line (identified as Line.xxx) is added to the specification tree.

  
●     Regardless of the line type, Start and End values are specified by entering distance values or by 

using the graphic manipulators.

●     Start and End values should not be the same.

●     Check the Mirrored extent option to create a line symmetrically in relation to the selected Start 
point. 
It is only available with the Length Length type.

●     In most cases, you can select a support on which the line is to be created. In this case, the selected 
point(s) is projected onto this support.

●     You can reverse the direction of the line by either clicking the displayed vector or selecting the 
Reverse Direction button (not available with the point-point line type).

     

Creating a line up to an element
 This capability allows you to create a line up to a point, a curve, or a surface.

●     It is available with all line types, but the Tangent to curve type.

 

Up to a point
●     Select a point in the Up-to 1 and/or Up-to 2 

fields.

Here is an example with the Bisecting line type, 
the Length Length type, and a point as Up-to 2 
element.



 

Up to a curve
●     Select a curve in the Up-to 1 and/or Up-to 2 

fields.

Here is an example with the Point-Point line 
type, the Infinite End Length type, and a curve 
as the Up-to 1 element.

 

Up to a surface
●     Select a surface in the Up-to 1 and/or Up-to 2 

fields.

Here is an example with the Point-Direction line 
type, the Length Length type, and the surface 
as the Up-to 2 element.

  
●     If the selected Up-to element does not intersect with the line being created, then an extrapolation is 

performed. It is only possible if the element is linear and lies on the same plane as the line being 
created.
However, no extrapolation is performed if the Up-to element is a curve or a surface.

●     The Up-to 1 and Up-to 2 fields are grayed out with the Infinite Length type, the Up-to 1 field is 
grayed out with the Infinite Start Length type, the Up-to 2 field is grayed out with the Infinite End 
Length type.

●     The Up-to 1 field is grayed out if the Mirrored extent option is checked.

●     In the case of the Point-Point line type, Start and End values cannot be negative.

  
 

Defining the length type



 ●     Select the Length Type: 
❍     Length: the line will be defined according to the Start and End points values

❍     Infinite: the line will be infinite

❍     Infinite Start Point: the line will be infinite from the Start point

❍     Infinite End Point: the line will be infinite from the End point

By default, the Length type is selected.
The Start and/or the End points values will be greyed out when one of the Infinite options is chosen.

  
 

Reselecting automatically a second point
This capability is only available with the Point-Point line method.

1.  Double-click the Line icon .

The Line dialog box is displayed.

2.  Create the first point.

 

The Reselect Second Point at next start option 
appears in the Line dialog box.

3.  Check it to be able to later reuse the second 

point.

4.  Create the second point.

5.  Click OK to create the first line.

  



 

The Line dialog box opens again with the 
first point initialized with the second point 
of the first line.

6.  Click OK to create the second line.

 To stop the repeat action, simply uncheck the option or click Cancel in the Line dialog box.
  

●     Parameters can be edited in the 3D geometry. For more information, refer to the Editing Parameters 
chapter.

●     You can isolate a line in order to cut the links it has with the geometry used to create it. To do so, use 
the Isolate contextual menu. For more information, refer to the Isolating Features chapter.
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Creating Planes

 
This task shows the various methods for creating planes:

 

●     offset from a plane

●     parallel through point

●     angle/normal to a plane

●     through three points

●     through two lines

●     through a point and a line

●     through a planar 
curve

●     normal to a curve

●     tangent to a surface

●     from its equation

●     mean through points

 

 
Open the Planes1.CATPart document.

 
1.  Click the Plane icon  .

The Plane Definition dialog box appears.

2.  Use the combo to choose the desired Plane type.

 
Once you have defined the plane, it is represented by a red square symbol, which you can move using the 
graphic manipulator.

Offset from plane

●     Select a reference Plane then enter an 
Offset value.

A plane is displayed offset from the reference 
plane.
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Use the Reverse Direction button to  reverse 
the change the offset direction, or simply click on 
the arrow in the geometry.

      
●     Click the Repeat object after OK if you wish to create 

more offset planes . 
In this case, the Object Repetition dialog box is 
displayed, and you key in the number of instances to be 
created before pressing OK.

As many planes as indicated in the dialog box are 
created (including the one you were currently 
creating), each separated from the initial plane 
by a multiple of the Offset value. 

 

Parallel through point 

●     Select a reference Plane and a Point.



A plane is displayed parallel to the reference 
plane and passing through the selected point.

Angle or normal to plane 

●     Select a reference Plane and a Rotation 
axis.
This axis can be any line or an implicit 
element, such as a cylinder axis for example. 
To select the latter press and hold the Shift 
key while moving the pointer over the 
element, then click it.

●     Enter an Angle value.

 



A plane is displayed passing through the rotation 
axis. It is oriented at the specified angle to the 
reference plane. 

●     Click the Repeat object after OK if you wish to create more planes at an angle from the initial 
plane. 
In this case, the Object Repetition dialog box is displayed, and you key in the number of instances 
to be created before pressing OK.

As many planes as indicated in the dialog box are 
created (including the one you were currently 
creating), each separated from the initial plane 
by a multiple of the Angle value.

Here we created five planes at an angle of 20 
degrees.

 This plane type enables to edit the plane's parameters. Refer to Editing Parameters to find out how to 
display these parameters in the 3D geometry.

Through three points 

●     Select three points.
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The plane passing through the three points is 
displayed. You can move it simply by dragging it 
to the desired location.

Through two lines 

●     Select two lines.

The plane passing through the two line directions 
is displayed.
When these two lines are not coplanar, the 
vector of the second line is moved to the first line 
location to define the plane's second direction. 



Check the Forbid non coplanar lines button to specify that both lines be in the same plane.

Through point and line 

●     Select a Point and a Line.

The plane passing through the point and the line 
is displayed. 

 



Through planar curve 

●     Select a planar Curve.

The plane containing the curve is displayed.

Tangent to surface 

●     Select a reference Surface and a Point.



A plane is displayed tangent to the surface at the 
specified point.

Normal to curve 

●     Select a reference Curve.

●     You can select a Point. By default, the 
curve's middle point is selecte.



A plane is displayed normal to the curve at the 
specified point. 

Mean through points 

●     Select three or more points to display the 
mean plane through these points.

It is possible to edit the plane by first selecting a 
point in the dialog box list then choosing an 
option to either:

●     Remove the selected point

●     Replace the selected point by another point.



Equation 

●     Enter the A, B, C, D components of the Ax + 
By + Cz = D plane equation.

 

Select a point to position the plane through this 
point, you are able to modify A, B, and C 
components, the D component becomes grayed.

 

Use the Normal to compass button to position 
the plane perpendicular to the compass direction.

Use the Parallel to screen button to parallel to 
the screen current view.



3.  Click OK to create the plane.

The plane (identified as Plane.xxx) is added to the specification tree.
  

●     Parameters can be edited in the 3D geometry. For more information, refer to the Editing Parameters 
chapter.

●     You can isolate a plane in order to cut the links it has with the geometry used to create it. To do so, 
use the Isolate contextual menu. For more information, refer to the Isolating Features chapter.
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Creating the Electrical Bundle  

This task shows you how to create an electrical bundle.
A bundle or electrical bundle is a document containing wires.

Open a document containing a geometrical bundle composed of electrical devices and bundle segments.

 If you work in visualization mode, since routing is possible with this mode, you need to update your 
document at opening to load the publication.

a.  Click the Update button .

An update warning opens:

b.  Click OK to validate.

1.  Select the New Bundle button .

The New Bundle dialog box opens:

2.  Change the bundle name if needed.

3.  Select a geometrical bundle in the specification tree that you want to be connected to the new 

bundle.

4.  Click OK to validate.

The new bundle is automatically created under the active product.
It is added to the specification tree.



An electrical bundle is associated to a geometrical bundle by the wires it contains.

If the geometry is not loaded, check the Product Structure settings.

An alternative to display the geometry is to choose the Representations -> Activate Terminal Node 

item. Right-click Product1 to use the contextual menu or select Edit -> Representations.
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Selecting External Data Systems  

This task shows how to select the external system before routing.

The Electrical Bundle has been defined in the previous task.

Make sure you have set up the option to locate the iXF systems repository.

1.  Select the Select External Systems button . 

The System Selection dialog box displays with the XML files available:

2.  Select one or more system files and click the right arrow .

3.  Click OK to validate.

The component list is filled up with this data and available for routing. 

If a system has already been selected, data is reloaded.

 



Routing Wires from External Data 

This task shows you how to route wires.

The system has been selected in the previous task.

1.  Select the Automatic Wire Routing button .

2.  The Wire Routing dialog box opens with connectivity and attribute information:

3.  Select wires and click the right arrow .

The selected wires shift to the right column: they will be routed.

Using the double right-arrow  select all the wires and send them in the right column.

4.  Click Route.

The Automatic Wire Routing Report dialog box is displayed:



The specification tree is updated, showing the wires routed:

5.  Close the report window.

Place the mouse pointer over a wire in the specification tree to highlight in the geometry the bundle segments containing the 

selected wire. 



 



Managing Links from External Data 

This task explains how to link electrical components from the external device list to physical devices.

The system has been selected in the previous task.

 
1.  Click the Manage Links  button.

The device list displays:

The components you can link are:
❍     equipments

❍     connectors

❍     pins.

You can filter the list:
❍     Show all devices: the list displays all the devices referenced in the external data file, even if they are 

not placed in the geometry.

❍     Show only devices present in session: the list displays only the devices placed in the geometry.

❍     Show only changed devices: the list displays only the devices which part numbers have been 
changed in the external data file.

2.  Select a component.

If the component is not linked to a 3D element, the Link button becomes available.



3.  Click Link.

The 3D Component List opens.

4.  Select an equipment which is not linked and click OK.

An alternative is to select the component in the specification tree.
The equipment is linked, together with the connector that belongs to it.
The component list is updated: the equipment, connector and pins are shown as linked in the device list.

If all the sub-element part numbers are filled up in the device list with the correct Reference 
Designator, they are automatically linked.

5.  Click Close when you are done.



Viewing Related Objects  

This task shows how to use the Related Objects viewer to navigate through the objects connected to 
the selected object.

You can focus on an object and see how it was constructed via its related objects.
The related objects command identifies the parent, any children or connected objects and the 
relationship between objects. It is available when none of the icons of the workbench are activated that 

is to say when you are in Select command .
Accessing related objects can be done in two ways:

●     by clicking the Related Objects icon in the toolbar

●     from the contextual menu, by selecting Related Objects.

The different options available are: 

 Reframe on selection: reframes the main 3D window on the Related objects selection.

 Reframe on selection: the main window selection corresponds to the Related objects 
selection. The main window display is not reframed.

 Freeze: freezes the contents of the Related objects window. You can still 
navigate in the main window: the Related objects view will not 
be updated.

 Freeze: the Related objects selection corresponds to the main window 
selection.

 View related objects: displays the parent, any children or connected objects.

 View related objects: only displays the selected objects.

 Wire: displays the wires contained in the bundle segment, the bundle 
segments and devices connected to this bundle segment.

 Wire: hides the wires contained in the bundle segment, shows the 
bundle segments and devices.

 Harness: displays the relationship to the harness: connectors, equipments, 
bundle segments, wires.

 Harness: hides the children bundle segments, only shows the wires.

 Sub objects: displays the electrical contents.

 Sub objects: hides the electrical contents.

On a complex electrical system, the 3D view allows you to limit display to a specific area thus 
enlightening the information regarding this area.



1.  Select an object: a bundle segment for example.

2.  Click the Related Objects button .

The Related Objects dialog box appears. The geometry area and the specification tree are 
reframed on the object selected.

3.  Select an object in this window.

The dialog box focuses on the object selected: Bundle Segment1.1 (center of the window) and 
shows the parent and the connected objects:

❍     on the left is the parent object (Assembly meaning).
It represents the container object.

❍     on the right are the children objects (Assembly meaning), connected to the Bundle 
Segment1.1. They represent the contents.

4.  Click the 3D tab to display the geometry.



5.  Close the dialog box to exit the Related Objects viewer.



Defining the Harness Flattening Parameters 

This task explains how to define the flattening parameters.

This should be done before using any other function of the Harness Flattening toolbar.

Open a new product document using the File -> New... command.

Choose the Product type.

1.  Click the Harness Flattening Parameters button .

The Harness Flattening Parameters dialog box opens on the General tab:

This tab lets you define:

Name

In the specification tree, this icon  is displayed with the name chosen in this field.

 Flattening Parameters is the default value.

Minimum angle between two branches



During the flattening process, this minimum angle is applied every time an angle between two branches 

is null in the 3D design. That way, bundle segments are never superposed upon one another and can 

easily be made out.

 The default value is 5deg.

Keep existing tangent between bundle segment and connector during the flattening step

This option gives a better flattening shape for flattening.

 By default this option is not checked.

Extract only the supports inside the geometrical bundle

The supports which do not belong to the geometrical bundle will not appear in the extracted document. 

This option allows you to manage two types of support:

❍     The supports which must be assembled with the harness during the manufacturing step.

This type of support is created inside the geometrical bundle.

❍     The supports which are linked to the structure.

These supports are added to the harness during the installation step.

This type of supports is created outside the geometrical bundle.

 By default this option is not checked.

2.  Select the Drawing tab.



This tab lets you define:

❍     the type of representation for bundle segments:

■     with Double line
 It is the default value.

■     or Single line.

❍     the graphic representation you want to use when replacing devices or supports:
■     keep the 3D projection.

 It is the default value.

■     or use a 2D detail previously stored in a catalog.

In this case, the catalog name and path must be defined in the dedicated option.

3.  Select your options and click OK to validate.

The parameters you have entered will be automatically applied to the other functions available in this 

workbench. You will be able to modify them at any time during your session by double-clicking the Flattening 

Parameters icon in the specification tree.



Extracting 3D Data

This task explains how to extract the geometrical and electrical bundles, with all the devices that are 

associated to them, in order to duplicate the information they contained in the new document.

The 3D document containing a geometrical bundle and an electrical bundle is open as well as the new 

product document.

Make sure the source document has not been modified, otherwise you will be prompted to save it before 

extracting the data.

In the new product document:

1.  Click the Extract button .

You are prompted to select an electrical or a geometrical bundle.

It enables you to extract the information contained in the geometrical or the electrical bundles 

from your first document.

When duplicating an electrical bundle, all the links with the geometrical bundles associated to it 
are maintained.

2.  Select the geometrical bundle you want to extract from the source document, whether in the 

geometry or in the specification tree.



When the extraction is performed the source document automatically closes.

3.  Save your data.



Flattening the Harness

This task explains how to flatten out bundle segments.

The document contains the data extracted in the previous task.

You can now flatten the whole geometrical/electrical bundle.

To do so:

1.  Click the Flatten button .

2.  Select the geometrical bundle, in the specification tree or in the geometry.

3.  Click OK to validate.

The result looks like this:



Rotating Bundle Segments

This task shows you how to rotate a bundle segment.

Two types of rotation can be considered: you can 

●     rotate a bundle segment around a bundle segment extremity, whatever the direction.

●     bend a bundle segment whatever the selected plane.

 



Rotating Bundle Segments
whatever the Selected Plan

This task shows you how to rotate a bundle segment around a bundle segment extremity whatever the direction.

The document contains the flattened harness obtained in the previous task.

1.  Click the Rotate button .

You are prompted to select a bundle segment extremity in the geometry. It is impossible to select the 
bundle segment in the specification tree, since the exact position of the selected point has to be known.

2.  Select an extremity.

A green arrow and a dialog box appear at the same time. 

a.  A green arrow indicating the bundle direction appears on the geometry. The user can modify the 

angle by selecting the green arrow directly.

b.  The Define Direction dialog box pops up.



The default plane is the one you have defined in the Harness Flattening Parameters dialog box at 
the beginning of your session.

3.  Whether you indicate the bundle main direction or you specify its angle and direction values one at a time.

a.  Enter the main direction.

In this example, you can select a geometrical line or a pad edge as the main direction.

b.  Enter an angle value.

As you are changing the angle value, the green arrow is moving to show you the direction the 
bundle segment is about to take.

c.  Select two directions to retrieve the angle value.

As above, you can select a geometrical line or a pad edge. Once the two directions have been 
defined, the angle between them is automatically calculated.

Note that you can modify the direction of the bundle directly on the geometry by clicking the arc of 
circle around the selected point.

4.  Click Apply.



The entered values are applied but the dialog box remains open and you can still modify the inputs.

5.  Click OK to validate.

The result looks like this.



Bending Bundle Segments

This task shows you how to rotate a bundle segment around a bundle segment extremity whatever the 
direction.

The document contains the flattened harness obtained in the previous task.

1.  Click the Rotate button . 

2.  Select an intermediate point on a bundle segment.

The bundle segment must be selected in the geometry and not in the specification tree, since 
the exact position of the selected point has to be known.

a.  The Define Direction dialog box pops up.

b.  A green arrow indicating the bundle direction appears in the geometry.

You can also click the green arrow and circle arc to change the direction the bundle 

segment is about to take.



3.  As in the previous task, either you select the main direction, or you indicate the angle or you 
specify two directions and the angle will be automatically calculated.

4.  Click OK to validate.  

5.  The result looks like this. 



Scaling Bundle Segments

This task shows you how to enter a bundle segment fake length. Working with fake lengths enables you to fit the whole 
harness in the board.

The document contains the flattened harness obtained in the previous task.

1.  Click the Scale button .

You are prompted to select a bundle segment in the geometry.
The Scale dialog box pops up.
The bundle segment true length is indicated.

2.  Enter the fake length you want.

3.  Click OK to validate.

The support relative positions are maintained when working with fake lengths.
If you want to work with true lengths again, press the Restore true length button.



Synchronizing the Environment

This task shows you how to synchronize automatically your 3D flattened geometry at any time during 

your session. You can add the missing components or remove the additional components, and also 

synchronize the bundle segment structure.

Make sure you have set up the option for the synchronization report repository.

The document containing the flattened harness is open from the previous task.

Open the initial document as well.

1.  In the initial document, select a bundle segment and modify its length, diameter, bend radius, 

instance name or color.

2.  Save your document.

3.  Switch back to the flattened harness.

4.  Click the Synchronize button .

❍     If there is no selection in the specification tree, the first electrical bundle modified will 
be synchronized. But, if there is more than one electrical bundle, you must select one 
otherwise a warning will be displayed. 

❍     If there is no electrical bundle, all the geometrical bundles will be selected and 
updated.

❍     You can do a multi-selection (devices, supports, etc. at the same time).

The Synchronize dialog box pops up:

During the synchronization step, only the selected options will be performed. This will optimize 

the synchronization length.

The html report will be generated accordingly and will show only the selected options.



This dialog box lets you define what you want to synchronize:

Components

❍     Components allows you to choose which components you want to update:
■     Devices

■     Bundle segments

■     Supports

■     Wires.

You can select at the same time as many components as needed.

Actions



❍     Actions allows you to customize the actions during the synchronization step:
■     Remove the components deleted in 3D

■     Add the components added in 3D

■     Replace the reference of components changed in 3D  (it can only be used with the 
Supports or Devices options activated.)

■     Synchronize the bundle segment structure (it can only be used with the Bundle 
Segments option activated.)

It allows to:

■     add or remove intermediate bundle segments

■     replace one or more bundle segments with one or more different bundle segments.

■     Synchronize the attributes.
For the synchronization of the position of supports, you must select Bundle Segments 
instead of Supports.

You can select as many actions as needed.

Options

❍     Options:
■     Simulation (generates a report without applying changes to the flattened document.)

■     Html report (generates the report in the Tools -> Options predefined folder.)

■     Automatic flattening on the added components

■     Reset the synchronization attributes.
(all components will be set to the False value again, so only the newly changed 
components will be set to True. You can use Edit/Search to retrieve quickly all 
components.)

5.  Click OK to validate.



A status bar appears showing the synchronization progress:

Here are the different steps that can be seen through the synchronization process according to 

the options previously selected:

❍     Analyze step is processing

❍     Replaced components synchronization is processing

❍     Removed components synchronization is processing

❍     Bundle segment structure synchronization is processing

❍     Added components synchronization is processing

❍     Attributes synchronization is processing

❍     Generating Html report

An HTML file is generated in the synchronization report repository if Html report is checked.

For more information about the html report, see Generating the HTML Report during the 

Synchronization.

The extracted document is updated if Simulation is not checked:

❍     The attributes that have been modified will show the Synchronize property set to True.

❍     Once the attributes have been reset, the Synchronize property will turn back to False.



Thus you can visualize what electrical attributes have been modified in the initial model.



Generating the HTML Report
during the Synchronization

This file explains the contents of the Html Report created during the synchronization.

The HTML report is composed of accurate fields, which describe the changes that occurred during the 

synchronization.

Only the tables which have modified components are shown, except for the Synchronization Parameters 

table, which is always present.

They rely on the fields that can be found in the Synchronize dialog box.

●     Synchronization Parameters:

❍     Option:
■     Simulation

■     Automatic flattening on added components

■     Reset the synchronization attributes.

❍     Action:
■     Remove the components

■     Add the components

■     Replace the reference of components

■     Synchronize the bundle segment structure

■     Synchronize the attributes.

❍     Components:
■     Bundle segments

■     Devices

■     Supports

■     Wires.

●     List of Removed Components:
❍     Bundle Name

❍     Bundle Segments

❍     Devices

❍     Supports

❍     Wires.

●     List of Added Components:
❍     Bundle Name



❍     Bundle Segments

❍     Devices

❍     Supports

❍     Wires.

●     List of Replaced Components:
❍     Bundle Name

❍     Devices

❍     Supports.

●     List of Bundle Segment Structure Modifications:
❍     Bundle Name

❍     Modification Number

❍     Before

❍     After.

●     List of Bundle Segment Attribute Modifications:
❍     Bundle Name

❍     Name

❍     Reference Designator

❍     Length

❍     Diameter

❍     Bend Radius

❍     Separation Code

❍     Color.

●     List of Device Attribute Modifications:
❍     Bundle Name

❍     Instance Name

❍     Reference Designator

❍     Sub Type

❍     Part Number.

●     List of Support Attribute Modifications:
❍     Bundle Name

❍     Instance Name

❍     Part Number

❍     Support Position.

●     List of Wire Attribute Modifications:
❍     Bundle Name

❍     Instance Name

❍     Reference Designator



❍     Sub Type

❍     Diameter

❍     Linear Mass

❍     Bend Radius

❍     Separation Code

❍     Color

❍     Modified Route.

●     List of Elements Showing an Error:
❍     Bundle Name

❍     Instance Name

❍     Error Message.

In the Synchronization Parameters table, the options that have been selected in the Synchronize dialog box are 
set to YES, the others are set to NO:

Synchronization Parameters

Options Actions Components

Simulation NO Remove components YES Bundle segments YES

Automatic flattening
on added components

YES Add components YES Devices YES

Reset the synchronization
attributes

NO Replace component reference YES Supports NO

  Synchronize bundle segment
structure

NO Wires NO

  Synchronize attributes YES   

In all the fields of the attribute and structure modification list, two lines appear:

●     The first line indicates the status of the component before synchronization.

●     The second line indicates the parameters that have been changed with the synchronization.

List of Wire Attribute Modifications

Bundle 
Name

Instance 
Name

Reference
Designator

Sub
Type

Diameter Linear
Mass

Bend
Radius

Separation
Code

Color Modified
Route



Electrical 
Bundle2.1

Wire-
plus1

Wire-plus1  2mm 0kg_m 20mm Attribute 
unset

yellow  

    5mm     NO

The added, replaced, removed component fields have one line per element indicating the modifications.

List of Added Components

Bundle Name Bundle Segments Devices Supports Diameter Wires

Electrical Bundle2.1

    Wire-minus1

    Wire-minus2

    Wire-minus3

Find hereafter the list of the errors that can occur during the synchronization and that will be reported in the Html 
file:

●     "The 3D harness flattening and 3D harness design link is broken"

●     "Error during the Analyze"

●     "Error during the Remove Component Synchronization"

●     "Error during the Bundle Segment Structure Synchronization"

●     "Error during the Add Component Synchronization"

●     "Error during the Attribute Access"

●     "Error during the Replace Component Synchronization"

●     "Error during the Bundle Segment Attribute Synchronization - Different Bundle Segment Structure"

●     "Error during Attribute Synchronization - Internal link failed to 3D harness flattening from 3D harness design"

●     "Error during the Bundle Segment Attribute Synchronization - Different Number of Supports"

●     "Error during the Bundle Segment Attribute Synchronization - Different Supports Configuration"

●     "Error during the Add Component - The original component document is not saved"

●     "Error during Wire Route Synchronization"

●     "Error during the Device Move"

●     "Error during Bundle Segment Move"

List of Elements Showing an Error

Bundle Name Instance Name Error Message



Geometrical Bundle2.1
Connector_F.1 Error during Add Component Synchronization

Connector_F.2 Error during Add Component Synchronization

Note: The Html report is generated with a default Cascading Style Sheet document (.css) that can be 
personalized.



Using the Drawing Capabilities

You can use these functionalities only if a Drafting license is available.

These functionalities allow you to take advantage of the Interactive Drafting capabilities:

●     You can easily create a drawing of the flattened harness.

●     You can use the various drawing representation options.

●     The Wire Annotation command in the Interactive Drafting workbench allows you to create a wire annotation 
on bundle segments and connectors.

●     You can now gain in efficiency by creating dimensions for technological features such as electrical harness. 
For a drawing created with a flattened document, you can have dimensions only on bundle segments.

●     The Interactive Drafting workbench lets you define and store text templates into catalogs to be used when 
creating texts associated to technological objects: 

❍     Create Text Templates.

❍     Store Text Templates into a Catalog.

❍     Annotate Drawings using Text Templates.



Customizing a Drawing View

This task shows you how to generate a drawing view, using various representation options.

The document contains the harness obtained in Flattening the Harness.

Make sure the Drafting -> View options are set as follows:
Open the Tools -> Options... menu, then Mechanical Design:

In the Geometry generation / Dress-up frame, check the following options:

●     Project 3D wireframe 

●     Project 3D points

For more information, refer to the View tab documentation.

1.  Open the Tools -> Options... menu, then in the Equipment & Systems category, choose the 

Electrical 3D Design item to define a graphic replacement catalog.

To do so:

❍     click the Add button

❍     browse to the catalog.

❍     click OK to validate.

A mapping will be done between the connector external reference (or the part number if the external 

reference is not valuated) and the name of the 2D detail.

❍     If an equivalence is found, the corresponding 2D detail will replace the connector in the drawing.

❍     If not, the 3D projection will be displayed.

2.  In the Drawing tab, select:

❍     the double line for bundle segment representation

❍     the 2D detail option for device graphical representation
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3.  Click OK to validate.

4.  Perform the mapping:

a.  Right-click a connector to display the properties,

b.  Click the More... button to display the Electrical tab.

c.  Enter a value in the External Reference field.

d.  Click OK to validate.

Once this is done, you will generate the drawing.

5.  Open a new drawing document.



6.  Click the Front View button  and select a face of the connector as Plane.

The drawing document updates according to this choice:

The connectors have been replaced with the chosen 2D detail and bundle segments are displayed with a 
double line.

Note that the External Reference attribute does not exist for the support and you need to create it. 

To do so:

●     Right-click the support to display the Properties.

●     At the bottom of the Product tab, click the Define other properties... button.

The dialog box displays:



●     Select String in the combo and click the New Parameter of type button.

●     Edit the name: External Reference

This property is added to the support.

●     You can now enter a value to map a catalog 2D detail.



Generating a Drawing

You can perform this scenario only if a Drafting license is available.

This task explains how to generate a drawing from the flattened harness.

The document contains the flattened harness obtained in the previous task.

1.  Open a new product document using the File -> New... command.

Choose the Drawing type and click OK to validate the default New Drawing parameters.

CATIA switches to the Drafting workbench.

2.  Click the Front View button .

You are prompted to select a reference plane on the 3D geometry.

3.  Click a plane in the flattened harness document: for example the face of a connector.

The drawing document updates according to this choice:



Creating Wire Annotations

A dedicated command is available in the drafting workbench to create a wire annotation on bundle 

segments and connectors. The wire attributes in the annotation can be customized.

The document contains the flattened harness obtained in the previous task.

1.  Generate a drawing like it is explained in Generating a Drawing.

2.  In the Drafting workbench, click the Wire Annotation button .

Two dialog boxes open:



❍     The Tools Palette, which allows you to show or hide the wire annotation dialog box:

■     When it looks like this, the Wire Attributes dialog box is visible.

■     When it looks like that, the Wire Attributes dialog box is not visible: Click the Tools 
Palette to make it visible.

❍     The Wire Attributes dialog box, which allows you to select the attributes you want to see as 
annotations:

■     To add an attribute from Available to Favorites, select the attribute of interest then 

click the right arrow .

■     To remove an attribute from Favorites, select it in the list then click the left arrow .

■     By default, the last Favorites used are available when the dialog box is re-opened.

■     If you want to save different favorite lists: select the attributes needed, enter a name in 
the input field then validate. You can then display your favorite list in the combo box.

3.  Choose Reference designator, Diameter, Length and Bend Radius for example.

4.  Then, select a bundle segment or a connector in the geometry.

A table is created, showing all the attributes that you have selected in Favorites:



If you want to add another wire annotation, you have to click again the Wire Annotation 

button before selecting a bundle segment or a connector.

There is an automatic update of the modifications except if you remove or add some 

components.

If you want to customize the graphical representation of the table, right-click to display the contextual 
menu then select Properties.



Creating Intra-Technological Feature 
Dimensions  

This task will show you how to create dimensions for technological features such as electrical harness. 

You need an Electrical Harness Assembly license for the purpose of this scenario as we will be 
dimensioning Electrical Harness Assembly features. Intra-technological feature dimensioning is also 
available for other applications such as Structure Functional Design or Ship Structure Detail Design. For 
more information on the availability of technological feature dimensioning for a given workbench, refer 
to the related documentation. 

Refer to Before you Begin for general information about technological feature dimensions.

Open the ElectricalAssembly.CATProduct document and make sure it is loaded in the Electrical Harness 
Assembly workbench (if necessary, select Start -> Equipment & Systems -> Electrical Harness 
Assembly to launch the workbench). Open the ElectricalAssembly.CATDrawing document.

1.  Click the Multiple Intra Technological Feature Dimensions icon  from the Dimensioning 

toolbar, Technological Feature Dimensions sub-toolbar. 

 

 

 

You can also click the Technological Feature Dimensions icon  and then select the 

Multiple Intra Technological Feature Dimensions icon   from the Tools Palette. 

 

 
2.  Select the feature that you want to dimension. Note that the name of a feature is displayed as a 

help as you move the cursor over it.
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 The dimension is created as specified by the feature. In this specific example, the bundle 
segment specifies that the dimension should provide its overall length.

The dimension creation command remains active.

 



 
3.  Repeat step 2 for each additional feature that you want to dimension.

4.  End the dimension creation by clicking anywhere in the drawing (but not on a technological 

feature) or by lining-up the dimension. The intra-feature dimensions are created as specified by 

the feature. 

You can now handle the dimension(s) just like any other dimension.

 

 



Creating Text Templates

This task will show you how to create text templates. 

Before you begin, you need to make sure that the package corresponding to the type of object for 
which you want to create a template is correctly loaded. For the purpose of this scenario, you will load 
the Product package. Go to Tools -> Options -> General -> Parameters and Measure and click 
on the Language tab. Check Load extended language libraries and uncheck All packages. From 
the Available Packages list, select ProductPackage and click on the right arrow to add it to the 
Packages to load list. Click OK, and then exit and re-start the software.

Create a new drawing.

 1.  Click the Text icon  from the Annotations toolbar.

 

 
2.  Click anywhere in the drawing. A green frame appears, as well as the Text Editor dialog box.

3.  In the Text Editor dialog box, type Part number:.

4.  Without closing the Text Editor dialog box, right-click the frame and select Insert link 

template from the contextual menu which is displayed.

 

 
5.  In the Insert Link Template dialog box which is displayed, select the ProductPackage 

dictionary, the Product type and the PartNumber attribute, and click Insert.



 

 
6.  Back in the Text Editor dialog box, press the Enter key and type Revision:.

7.  Back in the Insert Link Template dialog box, select the Revision attribute (leave the other 

fields as is), click Insert and then Close.

8.  Click OK in the Text Editor dialog box. The text template is now created.

 

 

9.  Make sure the text template is selected and click the Frame icon  in the Text Properties 

toolbar. 

10.  From the Frames sub-menu, choose the Scored Rectangle frame .

11.  Right-click the text template, and select Add Leader from the contextual menu.

12.  Click in the drawing to end the leader creation. The text template is now set.

 



 
13.  Right-click the text template, and select Properties from the contextual menu. 

14.  Click the Feature Properties tab in the Properties dialog box which is displayed.

15.  In the Feature Name field, type Part number & Revision and click OK. You will use this 

feature name to identify this text template in the future.

16.  Create another text by repeating steps 1 to 3, this time typing Part name: in the Text Editor 

dialog box.

17.  Repeat steps 4 and 5, this time selecting the Name attribute in the Insert Link Template dialog 

box.

18.  Click Close in the Insert Link Template dialog box and then OK in the Text Editor dialog box. 

The text template is now created.

19.  Make sure the text template is selected and in the Graphic Properties toolbar, choose green 

from the Color list. The text template is now set.

 

 
20.  Repeat steps 13 to 15, this time typing Part name in the Feature Name field. You will use this 

feature name to identify this text template in the future. 

21.  Select File -> Save As and save the drawing as a .CATDrawing document.

Now that your text templates are defined, you need to store them in a catalog. 

 



Storing Text Templates in a Catalog 

This task will show you how to store text templates in a catalog. 

For more information on catalogs, refer to the Using Catalogs chapter in the Infrastructure User's Guide.

Open the TextTemplates.CATDrawing document.

1.  Select File -> New.

2.  In the New dialog box, select CatalogDocument from the list of types and click OK. The Catalog 

Editor workbench is launched and a new catalog is created. 

3.  In the left-hand pane, double-click Chapter.1 to activate it. 

4.  Select Insert -> Add Family.... The Component Family Definition dialog box is displayed.

5.  Type Text templates in the Name field.

6.  Make sure Standard is selected in the Type field, and click OK. The family is created.

 

 

7.  For more convenience, select Window -> Tile Horizontally to display your Catalog Editor and 

Drafting windows at once.

8.  In the Drafting window, select one of the text templates, e.g. Part number & Revision.

9.  In the left-hand pane of the Catalog Editor window, double-click Text templates to activate it.

10.  Select Insert -> Add Component.... The Description Definition dialog box is displayed.

11.  On the Reference tab, click the Select external feature button. The dialog box is updated with 

information about the selected text template, i.e. Part number & Revision.

file:///E|/www/ADGdocR14/Doc/online/cfysm_C2/samples/Drafting/TextTemplates.CATDrawing


 

 

12.  Click OK. The selected text template is listed on the Reference tab, in the right-hand pane of the 

Catalog Editor window.

13.  Go back to the Drafting window and select the other text templates, e.g. Part name.

14.  Return to the Catalog Editor window and repeat steps 10 and 11. The dialog box is now updated 

with information about the Part name text template.  

15.  Click OK. Both selected text templates are now listed on the Reference tab, in the right-hand pane 

of the Catalog Editor window.

 



 

16.  Select File -> Save As and save the catalog as a .catalog document.

 



Annotating Drawings Using Text Templates  

This task will show you how to annotate drawings using text templates stored in a catalog.

Before you begin, you need to make sure that the package corresponding to the type of object for which you want 
to create a template is correctly loaded. For the purpose of this scenario, you will load the Product package. Go to 
Tools -> Options -> General -> Parameters and Measure and click on the Language tab. Check Load 
extended language libraries and uncheck All packages. From the Available Packages list, select 
ProductPackage and click on the right arrow to add it to the Packages to load list. Click OK, and then exit and 
re-start the software.

Open the GEAR-REDUCER.CATDrawing document.

 1.  Click the Text Template Placement icon  from the Annotations toolbar.

 

2.  In the Place Text Template dialog box, browse to select the TextTemplates.catalog document. This 

document is located in your documentation installation folder (by default, this folder is C:\Program 

Files\Dassault Systemes\XXXdoc\online\), in cfysa_C2\samples\Drafting. Leave the Place Text 

Template dialog box open to perform the next steps.

3.  On any view, select the part that you want to annotate, making sure that you click where you want the 

anchor point of the annotation to be located. Note that the name of a part is displayed as a help as you fly 

the cursor over it. 
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The Place Text Template dialog box now lists all the templates available in the selected catalog and 

which can be applied to the selected object.

 



 
4.  In the Place Text Template dialog box, select the text template that you want to apply, Part number & 

Revision for example. The annotation is created at the point you clicked when selecting the part to 

annotate, and contains information retrieved from the 3D part. Note that this annotation is associative to 

the 3D part.

5.  If you want, select the other text template (Part name). Note that this annotation will also be created at 

the point you clicked, so it will overlap the first annotation. For better results, you will have to move it 

afterwards. 

6.  Repeat steps 3 to 5 for other parts that you want to annotate. 

Note that the last template you selected in the Place Text Template dialog box remains active when 
annotating other parts. You can de-activate it by clicking the Clear selection button.

 

 
7.  When you're done, click Close to close the Place Text Template dialog box. 

You can also multi-select the parts that you want to annotate (using the Ctrl key) prior to clicking the Text 
Template Placement icon. 

 



Defining the Report Format

This task shows you how to define the report format. You use this function, together with the function 
described in Generating a Report, to get the values of properties of objects in a document.

Examples from the Piping Design workbench are used here.
Substitute the appropriate resource or directory when working in another workbench.

Before you generate a report you need to define its format. This means deciding which properties you 
are interested in. This report format is kept in a file which you can use to generate reports from other 
documents.

To use this function you must first set up an option:

a.  Click Tools -> Options -> General -> Parameters and Measure

b.  Select the Language tab. 

c.  Under Language check Load extended language libraries.

d.  Click OK to validate.

1.  Click Tools -> Report -> Define.

The Report Definition dialog box displays.



2.  Enter a Report Name and select a directory location.

3.  Enter a Report Title - you can select anything but you must enter a title.

4.  Check the Show Inherited Attributes box if you want to.

5.  Click the down arrow and select the Dictionary related to your program.

6.  Select the Type of object.

The list of attributes you see in Step 7 depends on the type you select here. However, when you 



generate a report you will get values for all objects in the document that have the attributes in 

your report format. If you want to limit the objects for which you get a report you must create a 

query (Step 9).

7.  Select an attribute in the Attribute field and click the Add button.

The attribute is added in the window.

Add as many attributes as you want to.

8.  You can further refine your report by using the Edit -> Search function to define a query.

This allows you to generate a report on a narrower selection of check valve, say, of a certain 

size,  instead of all check valves in your document. The queries you create are available for 

selection when you click the arrow in the Query Name field above.

Detailed instructions on using the Search function can be found in the Infrastructure User's 

Guide under Basic Tasks - Selecting Objects.

Briefly: 

a.  Click Edit -> Search to bring up the Search dialog box.

b.  Select the Advanced tab, then select a workbench, type of object and attribute you are 

interested in.

c.  Clicking the Add to Favorites button brings up the Create a Favorite Query dialog 

box, where you can name the query and save it.

 



Generating a Report 

This task explains how to generate a report listing values of selected properties. Before you do this you need to define 
the report format.

Examples from the Piping Design workbench are used here.
Substitute the appropriate resource or directory when working in another workbench.

1.  Click Tools -> Report -> Generate.

The Generate Report dialog box displays.

2.  Click the Open button and select the format you want to use for your report, in this case NewReport.

3.  If you had defined a query in your report format then check Objects From Predefined Query.

4.  If you select one or more objects in the document then check Currently Selected Objects.

5.  Check All Objects in Document if you want a report on all objects in your document.

6.  Click OK and select a format, such as HTML, when you are prompted.

The report is generated. It shows values for all properties defined in your report format for all objects in the 
document that have them.
Where an object does not have a property the report displays asterisks.



7.  Click Insert in Document if you want to display these values in your document.

❍     To generate the report from a schematic and insert it in a schematic, click the Insert in Document button 
and click anywhere in your drawing.

❍     To generate the report from a 3-D document and insert it in a schematic, click the Insert in Document 
button and select the sheet or view in the specifications tree.
Do not select a point in the sheet. The data will be placed at the origin of the sheet or view, and can be 
moved to another location.

8.  Click Save As to save the report.

Specify a file name and location.

 



Workbench Description
Electrical 3D Design and Documentation application windows look like this:

Electrical 3D Design & Documentation - Assembly

Electrical 3D Design & Documentation - Part



Assembly Toolbars
Part Toolbars



Assembly Toolbars

This section describes the various icons available in the Electrical 3D Design Assembly workbench.
The toolbars are located on the right in the default set-up except for the Catalog Browser, which is located in 
the horizontal bottom toolbar.

Electrical Device Definition

Harness Definition

External Electrical System

Harness Flattening

Catalog



Related Objects

See Viewing Related Objects

See Defining an Equipment

See Defining a Connector

See Defining a Cavity

See Defining a Termination

See Defining a Bundle Connection Point

See Defining a Connector Connection Point

See Defining a Cavity Connection Point

See Connecting Devices

See Disconnecting Devices

See Creating a Geometrical Bundle

See Defining Bundle Segments

See Creating an Electrical Bundle

See Selecting External Systems

See Managing Links

See Routing Wires from External Data

See Defining the Harness Flattening Parameters

See Extracting Data



See Flattening the Harness

See Rotating Bundle Segments

See Scaling Bundle Segments

See Synchronizing the Environment

See Using a Catalog, Using Catalogs

See Using Smart Placement from Catalog
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Part Toolbars

This section describes the various icons available in the Electrical Library workbenches.
The toolbars are located on the right in the default set-up except for the Catalog Browser, the Measure and the 
Update icons which are located in the horizontal bottom toolbar.

Electrical Device Definition

Bundle Segment Definition

Catalog

See Defining an Equipment

See Defining a Connector

See Defining a Cavity

See Defining a Termination

See Defining a Bundle Connection Point

See Defining a Connector Connection Point

See Defining a Cavity Connection Point



See Creating a Support

See Defining Bundle Segments

See Using Catalogs
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Customizing Electrical 3D Design & Documentation 

Before you start your first working session, you can customize the way you work to suit your habits.

This type of customization is stored in permanent setting files: these settings will not be lost if you end your session.

Other information can be considered as customization:

Electrical Data Exchange Format deals with electrical specifications from external data.

1.  Select the Tools -> Options command.

The Options dialog box opens.

2.  Select the Equipment & Systems category in the left-hand box.

3.  Click the Electrical 3D Design workbench.

The options, organized in tab pages appear.

4.  Select the tab containing the options to be customized:

❍     The Electrical Process Interfacing tab lets you define the external data file repository

❍     The General tab lets you set the automatic compass

❍     The Harness Flattening tab lets you define the synchronization report repository

❍     The Harness Management tab lets you set the bundle segment creation options

❍     The Wire Routing tab lets you customize the options to optimize the routing.

5.  A tab located in the Infrastructure category, in the Part Infrastructure workbench, also interfere with 

Electrical 3D Design:

❍     General

6.  Another tab, located in the Mechanical Design category, in the Drafting workbench, also interfere with 

Electrical 3D Design:

❍     View
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7.  Set options in theses tabs according to your needs.

8.  Click OK when done.



Electrical Process Interfacing   

This page deals with the options concerning:

●     the electrical iXF repository path

Electrical iXF Data Repository 

System repository
You are required to identify the path of the folder in which the XML files available are stored.

Use  to locate the iXF systems repository.

 By default the field is empty.



General   

This page deals with the options concerning:

●     the automatic compass

Automatic Compass 

Snap to placed element

if this option is checked, you take advantage of the compass:

when you place an element, the compass snaps to this element allowing you to modify the orientation and 

location. 

 By default this option is checked.



Harness Flattening   

This page deals with the options concerning:

●     the synchronization report repository

●     the graphic replacement catalog

Synchronization Report Repository 

Path

Indicate the folder path where you want to save the synchronization report html files.

 By default, this field contains: ...\DassaultSystemes\CATTemp.

Graphic Replacement Catalog 

Catalog path and Catalog name

Indicate the catalog path and name where the drawing 2D details are stored.

 By default, this field is empty.



Harness Management   

This page deals with the options concerning:

●     the bundle segment creation

Bundle Segment Creation 

Bundle segment color

Use the color chooser to define the bundle segment color at creation.



Wire Routing   

This page deals with the options concerning:

●     the separation code file

●     the bundle segment bend radius update

Separation Code File 

This option is used to define separation code rules to optimize the routing.

No Rule

The separation code is not used. The routing is done according to the shortest route found.

 It is the default value.

File Based
The separation codes may be File Based.
In this case, define the path to access the compatibility table by clicking the Browse button to choose the 
separation code file.
This file is used during the automatic routing.

Bundle Segment Bend Radius Update 

According to the wire bend radius



Three modes are available:
●     Never: no update of the bundle segment minimum bend radius is performed. 

●     Always: the greatest bend radius of the wires routed in the bundle segment determines the segment bend 
radius to be applied. 

●     Conditional: the wire bend radius is taken into account for update when it is greater than the bundle 
segment bend radius.

 The default mode is Always.



Part Infrastructure for
Electrical 3D Design

This page deals with the following option:

●     the external references: keep link with selected object

Part Infrastructure General option 

Click here to know more about the Part Infrastructure General options.

Keep link with selected object

You need to select this option to take advantage of the associativity between the construction points or part 

body and the bundle segment.

 By default, this option is cleared.
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Drafting for
Electrical 3D Design

This page deals with the following option used with Electrical 3D Design:

●     Geometry generation / Dress-up

Drafting View options 

Click here to know more about the Drafting View options.

Project 3D wireframe

You need to select this option to take advantage of the line type personalization used to display the bundle 

segments as single line in the drawings you will generate.

 By default, this option is cleared.

Project 3D points

You need to select this option to display construction points in the drawings you will generate..

 By default, this option is cleared.
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Electrical Data Exchange Format

 

To complete the end-to-end process, it is possible to get electrical specifications from external data. 
Those specifications consist of:

●     a device list containing the device attributes and the assembly connectivity

●     and a wire or equipotential list containing their attributes and the from-to connectivity.

This information will be used by CATIA Electrical products to implement in the digital mock-up the 
electrical systems driven by any electrical authoring tool (schematics or database for example).
You can either access this information through CAA APIs (refer to CAA documentation) or through an 
XML file. This method (using an XML file) is described in Electrical Integration from External Data.

You will find hereafter the XML schema to create your own interface to CATIA Electrical Tools.

 

The exchange data model is different from the data model of CATIA Electrical solutions. Actually, this 
data model consists of pertinent information that needs to transit between Electrical specification tools 
(schematics, etc.) and CATIA. It only aims at implementing those specifications in the mock-up. So only 
this pertinent information (objects, attributes and connectivity) is described in the following XML schema 
and not all the information stored in the CATIA electrical product documents.

 
In the context of CATIA P1, the CAA APIs are not supported.

As well, several objects are not managed in CATIA P1:

●     equipotential

●     connector shell

●     splice

even if defined in the XML file: the same XML schema is shared for P1 and P2 products. 

Preamble
 iXF is a format defined by Dassault Systèmes, which is used for the data exchange in XML within CATIA.

Succinctly, iXF is based on the SOAP format and relies on  the XML and the XML schema concept. It 
makes it possible to describe a grammar (a specific data model) expressing the object, class and 
behavior concepts as well as documents containing data conforming to the defined grammar.

A detailed description of the iXF format can be found at the following address: http://www.ixfstd.org/

Describing the iXF Electrical Schema
Considering the iXF Schema in Greater Depth
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Describing the iXF Electrical Schema

 

The electrical schema, defined for the data exchange between CATIA V5 electrical products and external applications 
(CAA partners applications, etc.), describes a subset of electrical objects together with their relations.

This schema is based on the fact that an object is defined as a class, which one is associated to a behavior set. Thus, an 
electrical connector corresponds to the Connector class, to which the Connector and Product behaviors are 
associated.

Electrical Objects
The following classes with their associated behavior describe the electrical objects within the iXF Electrical Schema.

●     Harness
❍     Harness

❍     Product

●     Wire
❍     Wire

❍     Product

●     Equipotential
❍     Equipotential

●     Equipment
❍     Equipment

❍     Product

❍     Function

●     ConnectorShell
❍     ConnectorShell

❍     Product

●     Connector
❍     Connector

❍     Product

●     Splice
❍     Splice

❍     Product

●     Pin
❍     Pin

❍     Product

●     Cavity
❍     Cavity

All these classes derived from the Object abstract class. This one is not to be used as is but allows you to define the Name 
attribute for all the classes deriving from the Object class.



 
The units for all the attributes are given in the standard MKS system.

The following behaviors, associated to the electrical objects are defined in the iXF electrical schema (behavior named 
ClassBehavior):

●     Harness
❍     Attribute: SubType

●     Wire
❍     Attributes: InnerDiameter, OuterDiameter (mandatory), BendRadius, Length, Color, LinearMass, SeparationCode, 

SubType, SignalId

●     Equipment
❍     Attribute: SubType

●     ConnectorShell
❍     Attribute: SubType

●     Connector
❍     Attributes: SubType, Color, MatingConnector

●     Splice
❍     Attribute: SubType

●     Pin
❍     Attribute: SubType

●     Cavity
❍     Attribute: SubType

●     Product
❍     Attribute: PartNumber

●     Equipotential
❍     Attributes: EstimatedDiameter, SeparationCode, RoutingPriority, WirePartNumber, SubType

●     Function
❍     Attributes: System_Type (mandatory if the Function behavior is defined), Description, Localization

At last, all the objects expressed in a iXF document have an attribute identifying in a unique way each object within the project, 
except for the objects of Link type, which have a unique identifier within the document.

To illustrate how to describe an electrical object with the iXF format, let's take the example of an electrical connector:



This electrical connector of Connector class has:

●     as identifier: V242 (attribute 'id')

●     as name: Motor,Window_Driver (attribute 'Name')

●     as reference: 5584555 -5W (attribute 'PartNumber' via its Product behavior)

●     as subtype: Single Insert Connector (attribute 'SubType' via its Connector behavior)

●     as color: Yellow (attribute 'Color' via its Connector behavior)

Relations between Electrical Objects

Using a Link type behavior

Nearly all the relations between electrical objects take the form of objects with a Link type behavior To know about the 
standard behavior definition, refer to  http://www.ixfstd.org/std/ns/core/classBehaviors/links/1.0.

The Link object classes of the electrical schema are the following:

●     WireLink

●     EquipotentialLink

●     DeviceLink

●     HarnessLink

These object classes allow you to define:

a.  the connectivity of the wire and equipotential objects, that is to say their connections with the electrical components 

(instantiated standard parts).

b.  the aggregation relations between the electrical components (instantiated standard parts).

For example a connector with pins or an equipment with connectors and pins.

c.  the harness composition (wires and electrical components)

These links take the form of identifiers.
For example: a wire, which identifier is W1, connected to two electrical connectors, which identifiers are C1 and C2:



Using a Specific Attribute

The relation between two connectors (mating connector, connector) is not managed by a Link type object as above but using a 
specific attribute named MatingConnector (behavior attribute of Connector type). This attribute is optional and is valuated 
with the identifier of the mating connector on both sides of the connection.

Let see an example where two connectors are connected together. The connectivity between them is described as follows:



Considering the iXF Schema
in Greater Depth

 

The iXF electrical schema is split in four parts (four files):

●     the first one: ElectricalSchema.xsd refers to the other three and describes the Electrical Object Classes.

●     the second one: IXF_CB_NS1.xsd describes strictly the Electrical Behaviors.

●     the third one: IXF_CB_NS2.xsd describes the Link type Behaviors (iXF standard reference).

●     and last but not least, the fourth one: IXF_CB_NS3.xsd describes the Functional Behaviors.

Electrical Object Classes









Electrical Behaviors







Link Type Behaviors



Functional Behaviors





Glossary

          

B  
bend radius The minimum bend radius allowed for the bundle segment: it corresponds to the 

maximum torsion possibly applied to a wire according to its physical characteristics.
bundle A document containing wires
bundle segment A geometrical subdivision of a bundle

Also called segment or BNS in V4 environment.
bundle connection
point

Sub-element used to place the bundle segment extremity on the electrical 
components.

C
cavity Sub-element allowing one associated component such as a connector. An electrical 

connection can be defined between a cavity and a cavity connection point.
cavity connection
point

Sub-element allowing the connection into a cavity. This connection corresponds to an 
assembly relation. The connectors allow a cavity connection point but not the 
equipments.

connect Establishes peculiar constraints between two electrical objects: 
●     the electrical signal continuity is ensured between the connected components.

●     if connection points have been defined, the mechanical assembly constraints are 
automatically created.

connector Basic term to define the single insert connector.
connector connection
point

Sub-element allowing the connection with another connector connection point. Only 
the single insert connectors use the connector connection point.

convert
into electrical device

Act to add an electrical behavior to an existing component which becomes an 
electrical component. If the component is a reference, it becomes an electrical 
reference. As opposed, converting an instance only add an electrical behavior to this 
instance, but doesn't in any case modify the reference.

D
diameter Corresponds to the diameter of the wire together with the insulation.
disconnect Deletes the electrical connection between two electrical components.

E
electrical behavior Peculiar reactions of a component bound to additional rules adapted to the electrical 

domain.
electrical component A product or a part with an electrical behavior
electrical connection Constraint existing between two electrical objects. Allows connection relations as well 

as assembly constraints.
electrical system An electrical unit which accomplishes a specific function. Consists of equipment, 

connectors and signals. Described in a CATProduct document.



equipment An electrical device with one or more associated components: connectors placed in 
cavities. An equipment can also comprise terminations and bundle connection points.

I
instance Designation of reference placed in a context, i.e. in design mode. An instance can 

have additional characteristics that do not belong to the reference. For example, the 
instance of a wire has a length attribute in an assembly context when its reference 
doesn't out of this context.
As opposed, see reference.

P
properties Attributes of a component that define its electrical, mechanical, etc. characteristics.

R
reference Component model corresponding to the definition of a real object. A reference can be 

stored in a catalog. In the electrical context a reference corresponds either to a 
CATPart document being electrified or to a CATProduct document which root product 
is being electrified. As opposed, see instance.

S
section Corresponds to the section of the wire together with the insulation.
segment See bundle segment.

single insert connector Electrical connector male or female. It comprises terminations, also bundle 
connection points, only one connector connection point, only one cavity connection 
point.

store (a device) Place an electrical component into a catalog family.
support A mechanical object used to hold the bundle segments in position.

T
termination Sub-element ensuring the electrical signal conduction between any type of electrical 

component. It is indissociable from the electrical component and corresponds to a 
contact crimped into a cavity. Terminations are allowed on equipments and 
connectors. Also called pin.

W
wire Electrical wire: physical object corresponding to a signal (several wires can 

correspond to a signal).
A wire reference is characterized by properties such as: section, diameter, bend 
radius, color, linear mass, etc.



Index 

                 

A
annotating drawings using text templates  
annotations 

text templates, creating  

text templates, using  

B
bend  

bend radius  
bisecting 

lines  

bundle  

bundle connection point   
bundle segment 

creating document  

defining parameters  

route definition  

C
catalog 

connecting devices by drag and drop  

smart placement  

catalogs, storing text templates in  

cavity    

cavity connection point    
command 



Bundle Segment Definition  

Catalog Browser  

Connect Electrical Devices  

Define Bundle Connection Point  

Define Cavity  

Define Cavity Connection Point  

Define Connector  

Define Connector Connection Point  

Define Support  

Define Termination  

Disconnect Electrical Devices  

Extract  

Flatten  

Geometrical Bundle  

Harness Flattening Parameters  

Line  

Manage Links  

Multi-Branchable Bundle Segment  

New Bundle  

Plane  

Point  

Related Objects  

Rotate   

Route Definition  

Scale  

Smart Place  

Synchronize  

Text Template Placement  

Wire Annotation  
compass 

device position and orientation  

smart placement  



compatibility table  

connecting  

connecting devices by drag and drop  

connecting electrical devices  

connector connection point   

converting into electrical device  
creating 

intra-technological feature dimensions  

text templates  

creating a bundle  

creating line  

creating plane  

creating point  

D
defining bundle connection points  

defining cavities  

defining cavity connection points  

defining connector connection points  

defining electrical connectors  
defining parameters 

bundle segment  

defining supports  

defining terminations  

diameter  
dimensions 

intra-technological feature dimensions  

disconnecting  

disconnecting devices  
drag and drop 

connecting devices  



smart placement  

drawing options   

E
electrical behavior   

electrical bundle  

electrical connection  

electrical connector  

electrical data exchange format  

electrical object class  

F
fake length 

scaling  

flexible curve   

functional behavior  

G
geometrical bundle   

H
harness flattening parameters 

drawing options   

I



insert report in drawing  

instance   

intra-technological feature dimensions  

iXF electrical schema  

L
length  
line 

creating  
lines 

bisecting  

link type behavior  

linking to physical devices  

P
plane 

creating  
point 

creating  

R
ratio  

reference   

related object viewer  

related objects  
report 

define a query  

define format  

format  



generate  
restore true length 

scaling  

rotating   

active plane   
route definition 

bundle segment  

S
scaling 

fake length  

restore true length  

section  

separation code  

single insert connector  

slack  
smart placement 

compass  

drag and drop  

smart placement from catalog  

storing text templates in a catalog  

synchronizing  

T
technological feature dimensions 

intra  

termination   
text templates 

annotating drawings with  

creating  

storing in a catalog  
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