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Overview
Welcome to the DMU Space Engineering Assistant User's Guide. This guide is intended for users who 
need to become quickly familiar with the DMU Space Engineering product Version 5 Solution. 

This overview provides the following information:

●     DMU Space Engineering Assistant in a Nutshell

●     Before Reading this Guide

●     Getting the Most out of this Guide

●     Conventions Used in this Guide

DMU Space Engineering Assistant 
in a Nutshell
DMU Space Engineering Assistant shortens design cycle time in concurrent environment through the 
capability it gives the designers to check the consistency of their design with the data stored in 
ENOVIA V5 while they are working. This is done thanks to interference analysis piloted by 
Knowledgeware rules allowing best practices compliance at the company level. Interference analysis 
results can then be stored in ENOVIA V5.

Thus, DMU Space Engineering Assistant  fits the needs of designers working in a collaborative 
environment, in industries dealing with large assemblies (shipbuilding, automotive, aerospace, etc.).

Description

DMU Space Engineering Assistant checks the consistency of a design with the data stored in ENOVIA 
V5 according to pre-defined clash analysis rules allowing shorter design cycle time.

●     Defines knowledgeware rules that will pilot clash computation 
❍     Specifies the computation type (clearance, contact, clash) and the components on which the 

clash computation must be applied  

❍     User/company benefits : automation, productivity gains, best practices/standardization, more 
accurate and relevant clash results

●     Performs interference analysis according to predefined clash rules between in-session component 
(s) and components stored in ENOVIA V5.

❍     Interference analysis computation is done on a dedicated server 

❍     This interference analysis occurs when a component is created or modified in CATIA V5 

❍     This interference analysis occurs when a set of components are moved in CATIA V5 

❍     User benefits :  
■     while working a designer can check the consistency of his design with the stored data in 

ENOVIA V5 

■     productivity and shorter design cycle in concurrent environment



●     Stores the interference analysis results in ENOVIA V5 
❍     Browses the interference analysis results and manage conflicts 

■     The user can choose the status of conflicts (irrelevant, relevant)

■     Dedicated browser presenting the interference analysis results 

■     The user can also comment conflicts and filter them

❍     Loads from ENOVIA V5 the components interfering with the in-session components and the 
relevant interference analysis results 

❍     Stores automatically interference analysis results when storing the in-session component in 
ENOVIA V5

❍     Interferences are detected between user sessions data and any part effective in any 
configuration

Before Reading this Guide
Before reading this guide, you should be familiar with basic ENOVIA and CATIA Version 5 concepts. 
Therefore, we recommend that you read the Infrastructure User's Guide that describes generic 
capabilities common to all Version 5 products. It also describes the general layout of V5 and the 
interoperability between workbenches.The Engineering Life Cycle User's Guide may prove useful to 
understand ENOVIA cocnepts and learn how to perform basic operations in ENOVIA V5

You may also like to read the following complementary product guides, for which the appropriate 
license is required:

●     Knowledge Expert User's Guide (containing information necessary to create Expert rules)

●     DMU Space Analysis User's Guide

Getting the Most out of this Guide

To get the most out of this guide, we suggest you start reading the Getting Started.This section gives 
you background information on SPE functioning. 

Once you have finished, you should move on to the next section: User Tasks dealing with the 
maincapabilities of DMU Space Engineering Assistant. and software prequisites. It may also be a 
good idea to take a look at the section describing the menus and toolbars: Workbench Desciption

Conventions Used in this Guide
To learn more about the conventions used in this guide, refer to the Conventions section. 



Conventions
Certain conventions are used in CATIA, ENOVIA & DELMIA documentation to help you recognize and 
understand important concepts and specifications. 

Graphic Conventions

The three categories of graphic conventions used are as follows:

●     Graphic conventions structuring the tasks

●     Graphic conventions indicating the configuration required

●     Graphic conventions used in the table of contents

Graphic Conventions Structuring the Tasks

Graphic conventions structuring the tasks are denoted as follows:

This icon... Identifies...

estimated time to accomplish a task

a target of a task

the prerequisites

the start of the scenario

a tip

a warning

information

basic concepts

methodology

reference information

information regarding settings, customization, etc.

the end of a task



functionalities that are new or enhanced with this release

allows you to switch back to the full-window viewing mode

Graphic Conventions Indicating the Configuration Required 

Graphic conventions indicating the configuration required are denoted as follows:

This icon... Indicates functions that are... 

specific to the P1 configuration

specific to the P2 configuration

specific to the P3 configuration

Graphic Conventions Used in the Table of Contents

Graphic conventions used in the table of contents are denoted as follows:

This icon... Gives access to...

Site Map

Split View mode

What's New?

Overview

Getting Started

Basic Tasks

User Tasks or the Advanced Tasks

Workbench Description

Customizing

Reference

Methodology

Glossary

Index



Text Conventions

The following text conventions are used:

●     The titles of CATIA, ENOVIA and DELMIA documents appear in this manner throughout the text.

●     File -> New identifies the commands to be used.

●     Enhancements are identified by a blue-colored background on the text.

How to Use the Mouse

The use of the mouse differs according to the type of action you need to perform.

Use this
mouse button... Whenever you read...

 
●     Select (menus, commands, geometry in graphics area, ...)

●     Click (icons, dialog box buttons, tabs, selection of a location in the document 
window, ...)

●     Double-click

●     Shift-click

●     Ctrl-click

●     Check (check boxes)

●     Drag

●     Drag and drop (icons onto objects, objects onto objects)

●     Drag

●     Move

●     Right-click (to select contextual menu)



What's New?

Customizing Settings

Computation Parameters
A new setting lets you specify whether a beep sound should be triggered when the calculation 
is finished.



Getting Started

The following scheme aims at illustrating what happens when running an interference analysis using Space Engineering Assistant

Send your PRC to CATIA using Send To->CATIA V5 tool
 

●     The connection between CATIA and ENOVIA is established,

●     SPE is connected either automatically or manually

A calculation is launched using the Force Computation  icon.  A request is automatically sent to the Apache HTTP Server

The Apache HTTP Server launches the SPE server (process) .

The information  is passed to the Spatial index. The Spatial index runs a proximity query and performs other checking operations: 

The resulting data is sent  to the SPE server which performs the clash calculation with respect to the Knowledge clash Rules specified.

The result is sent back to CATIA and passes by the Apache HTTP Server.

The analysis interference results are available in your CATIA session (using the Browse Clash Result with committed models icon  in 
the Spy toolbar) to display the Check clash dialog box 
 About results and saving operations

You can then modify the status of one detailed clash result, add comments in the DMU Clash dialog box These (modified) clash results will be stored 
automatically in ENOVIA V5 while saving your session in ENOVIA V5.

 In the ENOVIA LCA session, click the Refresh icon and search for the clash result. 
 

●     Saving operation in the ENOVIA Data Base is launched

●     Clash results computed with Space Engineering Assistant based on Knowledge  Clash Rules and created in CATIA are displayed and refreshed in 
ENOVIA V5 session.

To one Product Class Root (ENOVIA document) (referred to as PRC throughout this guide) corresponds one spatial index.



User Tasks
Setting Up Your Session

Running an Interference Analysis 

 

  

 



Setting Up Your Session

 The following task shows you how to prepare your session before launching an interference analysis with Space Engineering Assistant. You will learn 
how to:
 

●     Display the ENOVIA LCA interoperability toolbar

●     Check ENOVIA LCA and DMU Space Engineering Assistant display

●     Establish the DMU Space Engineering Assistant/ENOVIA LCA connection

●     Customize DMU Space Engineering Assistant Settings 

●     Send an ENOVIA LCA document into CATIA V5

●     initialize connection to DMU Space Engineering Assistant
 

Have a CATIA and an ENOVIA as well as a Space Engineering sessions running.
We assume in this User's guide that you performed all preliminary installation steps. Read DMU Space Engineering Installation Guide.

How to display the ENOVIA LCA interoperability toolbar?

1.  In CATIA V5, select:

The ENOVIA LCA toolbar looks like this:

How to check ENOVIA LCA and DMU Space Engineering Assistant (Spy) toolbars display?

2.  Select View->Toolbars from the menu bar. Then, make sure Spy and ENOVIA LCA items are selected

How to establish the DMU Space Engineering Assistant/ENOVIA LCA connection?

3.  In CATIA V5 (you are in the Product Structure workbench), click the Connect to LCA icon  to establish a connection between CATIA V5 

and ENOVIA LCA. 

The Enovia toolbar looks like this now:

How to customize DMU Space Engineering Assistant Settings?

4.  In CATIA V5, select Tools->Options->Digital Mock-up from the menu bar and select DMU Space Engineering



The DMU Space Engineering tab lets you customize the following:
❍     Connection Mode 

❍     Server Connection Parameters 

❍     Clash Result Path 

❍     Computation Parameters

5.  Select Digital Mockup->DMU Space Analysis category, to access another option necessary for DMU Space Engineering Assistant

 ❍     DMU Clash - Rule

 For more information, read Customizing section

How to send an ENOVIA LCA document into CATIA V5? 

6.  Load your Product Class Root (referred to as PRC throughout this guide) from ENOVIA in CATIA V5, using the Send To->CATIA V5 

commands accessible from the contextual menu (all you need to is right-click the desired PRC in the Product Class Editor).

 

 

To create a PRC, refer to the appropriate ENOVIA LCA documentation (Engineering LifeCycle User's guide)

How to initialize connection to DMU Space Engineering Assistant?

6.  In CATIA V5, click the Connect/Disconnect icon   from the DMU Space Engineering toolbar: 

The icon becomes active , the connection is established for the product loaded in your CATIA session. 
You are now ready to work with DMU Space Engineering Assistant

❍     Modify the existing parts

❍     Create new parts...

Each time, you need to run an interference analysis, click the  icon to force the calculation: each and every part modified since last 
computation is sent to DMU Space Engineering server. An hourglass appears on the icon when the calculation is launched



Running an Interference Analysis
The following task shows you how to search clashes with Space Engineering Assistant

Have a CATIA and an ENOVIA sessions running 

You created a PRC in ENOVIA with the following instances
 

 

1.  In CATIA, click the Init Enovia V5 Connection...  icon to establish a connection between CATIA V5 and 

ENOVIA LCA. (this step is not necessary if the connection was automatically established)

2.  In the ENOVIA Homepage panel, select the Engineering Life Cycle folder and double-click the Product Class 

Editor bookmark:



The Product Class View panel is displayed

3.  Select an existing Product Class Root (PRC) in our example FBP_R9

4.  Right-click the PRC (FBP_R9) and select Send To -> CATIA V5 from the contextual menu displayed

The document is loaded in CATIA V5 but the instances are not.

5.  In CATIA V5, click the Connect/Disconnect icon   from the DMU Space Engineering toolbar: The icon 



changes in this: 

6.  Create a .CATPart document in your PRC.

 

For this:

❍     select the New Part icon  in Product Structure workbench

❍     select a reference plane

❍     swap to the Sketcher workbench

Please refer to:
❍     Part Design User's Guide to obtain detailed information on how to create CATPart documents

❍     Inserting a New Part in the Product Structure User's Guide

 
 

Double-click the PRC in the specification tree to swap to Product Structure workbench if necessary

7.  Click  the Force Computation  icon the DMU Space Engineering toolbar to launch the calculation. 

What happens?

The new created part is sent to DMU Space Engineering server. Space Engineering Assistant server launches a  
proximity query searching for clashes (to detect how this new part impacts the existing PRC instances)

An hourglass appears on the connection icon showing the calculation is in progress 

8.  Click the Browse Clash Result with committed models icon . The Check Clash dialog box is displayed.

 Click on the image below:



 

 The dialog box identifies the number of interferences detected along with the type: one interference has 
been detected (generated by the new part creation)

 

Status lights  are color-coded:
❍     red: at list one conflict is relevant

❍     orange: no relevant conflicts, at least one conflict is Not inspected

❍     green: all conflicts are irrelevant

Note: The 'List by product' and 'Matrix' tabs are deactivated when working with DMU Space Engineering 
Assistant.

9.  Select the clash of interest in the results list. By default, results are organized by conflict in the List by Conflict 

tab. 

10.  (Optional) Select the Sort conflicts checkbox to display the conflicts associated with each and every product. 

There may be more than one conflict per product. Let's take a simple example.

You run an interference analysis on the three products (P1, P2, P3) below:

file:///E|/www/fbpdocr14/Doc/online/speug_C2/images/dbcheckclash01NLS.gif


Two interferences are displayed by default:  (between: P1  P3 and P2  P3)

Now, if you want to display the conflicts associated with each product (combinations: P1 P3, P3 P1, P3 P2 and 
P2 P3) select the Sort conflicts checkbox:
 

The preview window is displayed. 



The parts in clash are automatically loaded in CATIA V5. In our example, only the Hull .CATPart document is 
loaded.

11.  Click the Save Data in ENOVIA V5 Server icon  to save the data in ENOVIA LCA.

What happens?

This operation launches a last clash computation to check the clash result is still relevant (i.e. other users can 
have performed modifications impacting the PRC).
The Save in ENOVIA V5 dialog box opens:



12.  Click Ok to perform the operation.

13.  Check the clash results are saved in ENOVIA. Please refer to  "Searching Clashes by Item Instance Selection" in 

Product Interference Management User's Guide.

Do not forget to a save in ENOVIA for this, in Product Class Editor, click .

14.  Close your PRC in CATIA (in our example FBP_R9).

15.  Now, reopen your PRC in CATIA: right-click the PRC (FBP_R9) and select Send To -> CATIA V5 from the 

contextual menu displayed.

16.  Select the Hull Product to search for interferences.

17.  Click the Browse Clash result involving a selected product icon . The Check Clash dialog box appears 

displaying all the related clashes previously stored.

About Browse Clash result involving a selected product capability

This command lets you search for interferences related to one (or more) selected product (s)
The Check dialog box only displays the interference results related to the selected product (s)
How does it work?

This filtered list is the result of a comparison between the currently stored interferences in database and the 
interferences detected in your current working session. When exiting the command, a reset action is performed 

on the filtered list. Next time, you  review your interference results using the  icon, the list will be complete 
(the clashes related to the entire session will be displayed).

 



Workbench Description
DMU Space Engineering Assistant Toolbar

ENOVIA LCA and CATIA V5 Interfaces
ENOVIA LCA Toolbars

ENOVIA LCA and CATIA V5 Menus 



DMU Space Engineering Toolbar
This section contains the description of the toolbar icons which are specific to the DMU Space Engineering Assistant 
The DMU Space Engineering Assistant  toolbar looks like this:

 
Icon Name Select this icon to...

 
Connect/Disconnect 

initialize (or interrupt) the connection to DMU Space Engineering 
server
the icon automatically swaps to:

Connection initialized  

 

 the hourglass appearing on the connection icon shows the 
calculation is in progress

 
Force Computation 

send each and every part modified to DMU Space Engineering 
server since last computation . Please refer to Running an 
Interference Analysis 

 

 
Browse Clash Result with committed models

display the clash results calculated by the Space Engineering 
Assistant in your CATIA session 

 

 
Browse Clash result involving a selected product

●     add the existing clash results stored in ENOVIA to the DMU 
Space Engineering Assistant clash results list

●     display the DMU Space Engineering Assistant clash results list 
in your CATIA session.

Note: All you need to do is select the clash of interest in the Check Clash dialog box list to display  the parts involved in the clash.



ENOVIA LCA and CATIA V5 Interfaces

CATIA V5 Product Structure Interface:

 looks like this, click the toolbar on the right to display the related information 

Product Class Editor Interface:

 

You can access the Product Editor interface from ENOVIA V5 by clicking Life Cycle folder and 
selecting the Product Class Editor bookmark





ENOVIA LCA Toolbars
ENOVIA LCA Interoperability Toolbar

Product Class Editor Toolbar 

  



ENOVIA LCA Interoperability Toolbar

The commands dedicated to ENOVIA LCA interoperability can be accessed through the ENOVIA LCA toolbar  displayed 
in CATIA V5 Product Structure interface.

The toolbar looks like this:

 
Icon Name Select this icon to...

Init Enovia V5 establish a backbone communication between CATIA and ENOVIA editor

Save Data in ENOVIA V5 Server save the modifications in ENOVIA LCA server without committing data

Identify in ENOVIA V5 identify the selected objects in ENOVIA V5 editor

Load children From ENOVIA LCA directly loads from ENOVIA LCA the children products of the selected 
instances

Unload Branch From CATIA LCA unloads the selected branche(s) of an ENOVIA imported product



Product Class Editor Toolbar

The Product Class Editor offers a series of basic functions that you use to maintain and revise 
product class structures.

These functions include the ability to delete specific nodes of the product class structure, copy 
and paste configurable views, to save changes, to reorder the view of the product class 
structure by ascending sort, etc.

●     Horizontal toolbar

●     Vertical Toolbar

Horizontal Toolbar

 

 
Icon Name Select this icon to...

New Root create a new product root

Open open in Product Editor

Save save changes you have made to the product class structure

Refresh refresh the view of the product class structure

Close close the current Product Editor

Help access Help information

Vertical Toolbar



Icon Name Select this icon to...

Ascending Sort reorder the view of the product class structure

Start Category Editor open the Category Editor dialog box

Start Rules Editor open the Rules Editor dialog box



ENOVIA LCA and CATIA V5 Menus
 

CATIA V5 Menu Bar
ENOVIA LCA Shortcut Menus 

  



CATIA V5 Menu Bar

This section presents the menu bar tools and commands dedicated to Space Engineering 
Assistant 

See How to display 
the ENOVIA V5 
Interoperability 
Toolbar

See How to check 
ENOVIA V5 and DMU 
Space Engineering 
Assistant (Spy) 
toolbars display

See Customizing DMU 
Space Engineering 
Assistant Settings



ENOVIA LCA Shortcut Menus
You access the following shortcut menus when you right-click a product, either in the Product 
Class View or the Product Class Editor Panel  

The shortcut menus displayed below may differ depending on the panel from which it was 
selected. 

See ENOVIA 
CATIA 
Interoperability 
User's Guide



See ENOVIA 
CATIA 
Interoperability 
User's Guide

See How to 
send an 
ENOVIA V5 
document into 
CATIA V5 

See ENOVIA 
CATIA 
Interoperability 
User's Guide

 



Customizing

Before you start your first session, you can customize the way you work to suit your habits. This type of customization is stored in 
permanent setting files: these settings will not be lost if you end your session.

To access them, proceed as follows:

1.  Select the Tools -> Options command.

The Options dialog box appears.

2.  Select the Digital Mockup category in the left-hand box. Various tabs appear.

3.  Click DMU Space Engineering tab.

The DMU Space Engineering tab page is displayed.

 

 

The DMU Space Engineering tab lets you customize options dealing with:
 

❍     Connection Mode

❍     Server Connection Parameters

❍     Clash Result Path

❍     Computation Parameters

4.  Another tab, located in Digital Mockup->DMU Space Analysis category, is also needed for DMU Space Engineering Assistant.

 

 ❍     DMU Clash - Rule lets you identify the path to the CATProduct containing knowledgeware clash rules.

Client workstations and servers must point to the same rule-based clash.

5.  Set options in this tab according to your needs. 

6.  Click Ok in the Options dialog box when done



DMU Space Engineering

This page deals with the following options:

●     Connection Mode

●     Server Connection Parameters

●     Clash Result Path

●     Computation Parameters
 

Connection Mode

 

 

Automatic

Select the Automatic check box to connect DMU space Engineering 
Assistant automatically to the http server, you do not need to click the 

Connect/Disconnect icon . 
(The connection is established during the Send to CATIA... operation)

If disabled (default mode), you need to connect manually to the server 
clicking the Connect/Disconnect icon in the Spy toolbar.

 By default, the Automatic check box is cleared.

Server Connections Parameters

 



 

Host Server

Specify the host server name (name of the machine hosting the Apache server) 
using the drop-down list.

 By default, this field is left blank.

Port Server

Specify the port server name.

 By default, this field is grayed out.

Clash Result Path

 

 

Path

Click Browse and specify the path directory where the XML files (clash results) are 
to be stored. 

 By default, this field is left blank.

Computation Parameters

 

Beep when computation ends

Clear this check box if you want to deactivate the beep sound which is triggered 
when the calculation is finished.

 By default, this check box is selected.



DMU Clash - Rule  

The DMU Clash - Rule tab contains only one category of options: CATProduct containing Rule(s).

CATProduct containing Rule(s)

Enter the full path to the CATProduct containing knowledgeware clash rules, or select this path using the icon.

 By default, this field is left blank.
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