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Overview
Welcome to the DMU Space Engineering Assistant Installation Guide. The DMU Space Engineering 
Assistant Installation Guide is intended for anyone who wants to install DMU Space Engineering 
Assistant. It is primarily intended for the system administrator, database administrator and data 
administrator, but it can also be used by general users or super users of  ENOVIA LCA and CATIA 
applications.

This guide is a reference; it assumes that you will be installing DMU Space Engineering Assistant and 
therefore presents all of the data administration tasks such as customization, etc.

This overview provides the following information:

●     DMU Space Engineering Assistant in a Nutshell

●     Before Reading this Guide

●     Getting the Most out of this Guide

●     Conventions Used in this Guide

DMU Space Engineering Assistant 
in a Nutshell
DMU Space Engineering Assistant shortens design cycle time in concurrent environment through the 
capability it gives the designers to check the consistency of their design with the data stored in 
ENOVIA LCA while they are working. This is done through interference analysis piloted by 
Knowledgeware rules allowing best practices compliance at the company level. Interference analysis 
results can then be stored in ENOVIA LCA.

Thus, DMU Space Engineering Assistant fits the needs of designers working in a collaborative 
environment, in industries dealing with large assemblies (shipbuilding, automotive, aerospace, etc.).

Description

DMU Space Engineering Assistant checks the consistency of a design with the data stored in ENOVIA 
LCA according to pre-defined clash analysis rules allowing shorter design cycles.

●     Defines Knowledgeware rules to pilot clash computation 
❍     Specifies the computation type (clearance, contact, clash) and the components on which the 

clash computation must be applied  

❍     User/company benefits : automation, productivity gains, best practices/standardization, more 
accurate and relevant clash results

●     Performs interference analysis according to predefined clash rules between in-session component 
(s) and components stored in ENOVIA LCA

❍     Interference analysis computation is performed on a dedicated server 



❍     This interference analysis is launched when a component is created or modified in CATIA V5 

❍     This interference analysis is triggered when a set of components are moved in CATIA V5 

❍     User benefits :  
■     while working, a designer can check the consistency of his design with the stored data in 

ENOVIA LCA 

■     productivity and shorter design cycles in concurrent environment

●     Stores the interference analysis results in ENOVIA LCA 
❍     Browses the interference analysis results and manage conflicts 

■     The user can choose the status of conflicts (irrelevant, relevant)

■     Dedicated browser presenting the interference analysis results 

■     The user can also comment conflicts and filter them

❍     Loads from ENOVIA LCA the components interfering with the in-session components and the 
relevant interference analysis results 

❍     Stores automatically interference analysis results when storing the in-session component in 
ENOVIA LCA

❍     Interferences are detected between user sessions data and any part effective in any 
configuration

Before Reading this Guide
Before reading this guide, you should be familiar with basic ENOVIA and CATIA Version 5 concepts. 
Therefore, we recommend that you read the Enterprise Architecture Installation Guide (containing 
information necessary to set up an ENOVIA database and client) and the CATIA Infrastructure 
Installation Guide (containing information necessary to install CATIA Version 5 and providing 
information for administrators on topics such as hardware and software prerequisites, network 
licensing, code distribution and environment management.

You may also like to read the following complementary product guides, for which the appropriate 
license is required:

●     Knowledge Expert User's Guide (containing information necessary to create Expert rules)

●     DMU Space Analysis User's Guide

Getting the Most out of this Guide



To get the most out of this guide, we suggest you start reading the Getting Started. 
This section gives you background information such as the basic concepts, a quick prerequisite 
checklist, a scheme explaining SPE functioning. 

Once you have finished, you should move on to the next section: Installation Guide Wizard, an 
overview of the various phases of such an installation depending on the user profile, it provides step-
by-step instructions for installing and setting up the server and client environments. 
The next section Detailed Installation Prerequisites describes hardware and software prerequisites. It 
may also be a good idea to take a look at the section describing how to write a clash rule intended 
for super users as well as Launching Space Engineering Assistant.

Conventions Used in this Guide

To learn more about the conventions used in this guide, refer to the Conventions section. 



Conventions
Certain conventions are used in CATIA, ENOVIA & DELMIA documentation to help you recognize and 
understand important concepts and specifications. 

Graphic Conventions

The three categories of graphic conventions used are as follows:

●     Graphic conventions structuring the tasks

●     Graphic conventions indicating the configuration required

●     Graphic conventions used in the table of contents

Graphic Conventions Structuring the Tasks

Graphic conventions structuring the tasks are denoted as follows:

This icon... Identifies...

estimated time to accomplish a task

a target of a task

the prerequisites

the start of the scenario

a tip

a warning

information

basic concepts

methodology

reference information

information regarding settings, customization, etc.

the end of a task



functionalities that are new or enhanced with this release

allows you to switch back to the full-window viewing mode

Graphic Conventions Indicating the Configuration Required 

Graphic conventions indicating the configuration required are denoted as follows:

This icon... Indicates functions that are... 

specific to the P1 configuration

specific to the P2 configuration

specific to the P3 configuration

Graphic Conventions Used in the Table of Contents

Graphic conventions used in the table of contents are denoted as follows:

This icon... Gives access to...

Site Map

Split View mode

What's New?

Overview

Getting Started

Basic Tasks

User Tasks or the Advanced Tasks

Workbench Description

Customizing

Reference

Methodology

Glossary

Index



Text Conventions

The following text conventions are used:

●     The titles of CATIA, ENOVIA and DELMIA documents appear in this manner throughout the text.

●     File -> New identifies the commands to be used.

●     Enhancements are identified by a blue-colored background on the text.

How to Use the Mouse

The use of the mouse differs according to the type of action you need to perform.

Use this
mouse button... Whenever you read...

 
●     Select (menus, commands, geometry in graphics area, ...)

●     Click (icons, dialog box buttons, tabs, selection of a location in the document 
window, ...)

●     Double-click

●     Shift-click

●     Ctrl-click

●     Check (check boxes)

●     Drag

●     Drag and drop (icons onto objects, objects onto objects)

●     Drag

●     Move

●     Right-click (to select contextual menu)



What's New?
This section identifies what new or improved capabilities have been documented in the Version 5 
Release 14 of DMU Space Engineering Installation Guide.

New Functionality

Installation procedure improved 
The SpE Installer component provides four different tab pages which let you customize and 
install simultaneously the necessary settings: General Settings, SpE Settings, SpI Setting and 
Catia Settings.
To get the most out of DMU Space Engineering installation guide, read Installation Guide 
Wizard carefully.

Customizing Settings

Computation Parameters
A new setting lets you specify whether a beep sound should be triggered when the calculation 
is finished.

 

 



 Getting Started
Basics

How Does SPE Work?
Quick Prerequisite Checklist



Space Engineering Assistant: Basics
Space Engineering Assistant product architecture can be divided into three main sections:

CATIA Client Side 

●     User Interface to interact with SPE, clash browsing capability

●     Model modifications detection system

●     HTTP client to send modification information to the server and receive results 

●     Clash results comparison algorithm.
 

SPE Server (Space Engineering Server)

●     launched by an Apache server, when a query is performed by a CATIA client. 

●     Spatial Index Client to perform proximity queries on modified parts. 

●     ENOVIA LCA Client to retrieve nearby parts geometry and related information. 

●     Rule-based clash computation capability between imported modified parts and digital mockup 
(retrieved from ENOVIA) nearby parts. 
 

 Spatial Index : 

●     Indexes a whole PRC from ENOVIA in space. 

●     Performs very fast proximity queries. 
 



Before You Begin: check everything is working (connections established)
This first scheme aims at illustrating a correct connection to Space Engineering 
Server 



Connection between CATIA and ENOVIA is established, using the dedicated toolbar below:

Click the Connect/Disconnect icon  in the Spy toolbar to send a request to the Apache server. 
This step is useless, if you selected the automatic connection beforehand  (Tools->Options>Digital 
Mockup->DMU Space Engineering)  

Note: the HTTP Apache server has been previously launched (as a service in automatic mode or in 
manual mode ) 

 The HTTP Apache server launches SPE server process.

The SPE server launches a request to the Spatial Index (Are you here and running ?)

The Spatial index is running, it sends the information back to the SPE server.

The SPE server passes the information to CATIA via the Apache server. 

DMU Space Engineering Assistant is ready to work: the icon changes in the Spy toolbar.



This second scheme aims at illustrating a failed connection to SPE 

Connection between CATIA and ENOVIA is established 

Click the Connect/Disconnect icon  in the Spy toolbar to send a request to the Apache server. 
You can also select the automatic connection beforehand ( Tools->Options>Digital Mockup->DMU 
Space Engineering)

Note: the HTTP Apache server has been previously launched (as a service in automatic mode or in 
manual mode) 

The HTTP Apache server launches SPE server process.

The SPE server sends a request to the Spatial Index (Are you here and running fine?)

The Spatial Index is not responding (it is not created nor running).

After a while, SPE server sends a message via the Apache server to CATIA. An error 
message is displayed.



How does Space Engineering Assistant work?

How does it work ?

Data coming from the ENOVIA LCA data base (please refer to "Set Up the ENOVIA Data base" in the 
Enterprise Architecture Installation Guide), an ENOVIA LCA Client session is running, the Product Editor is 
opened

The user sends data into CATIA V5 session (using the Send to... command);  the connection between 
CATIA and ENOVIA has been previously established.

Zooming on CATIA/DMU Session section:

The user connects to the host server, he either chooses between:



●     Automatic connection:

Please read Tools->Options>Digital Mockup->DMU Space Engineering

●     Manual connection:

In this case, all he needs to is click the Connection icon in the Space Engineering Assistant toolbar.

 The user works in session, in our example, let's say he selects the part floor and moves it.
 

The user needs to launch SPE computation, clicking the Force computation of clashes with 

committed models icon  in the Spy toolbar. A request is then sent to the Apache HTTP server.

The information (part identifier) is passed to the Spatial index (permanent running process).

 The Spatial index runs a proximity query and performs other checking operations: the resulting data 
is sent  to the Design Assistant server (nphSpaceEngCgi.bat) which performs the clash calculation with 
respect to the Knowledge clash Rules specified. Please refer to 

More About Knowledge Clash Rules.Clash results are sent to CATIA V5

Clash results are displayed in the Check clash dialog box (accessed via the Browse clash result with 
committed models icon).  

 The user can then modify the status of one detailed clash result, add comments in the DMU Clash 
dialog box. These (modified) clash results will be stored automatically in ENOVIA V5 while saving his session 
in ENOVIA LCA.

 In the ENOVIA LCA session, the user clicks the Refresh icon and searches for the clash result. 
●      Saving operation is launched in the ENOVIA Data Base

●      Clash results computed with Space Engineering Assistant based on Knowledge Clash Rules and created 
in CATIA are displayed and refreshed in the ENOVIA LCA session.

The ENOVIA Data Base passes the information to the Spatial index which is automatically updated 

accordingly taking into account the modified objects.

 



Quick Prerequisite Checklist

Server Side
Operating System Supported

Windows 2000 Yes

Client Side
Operating System Supported

HP-UX Yes

SOLARIS Yes

IRIX Yes

AIX Yes

Windows 2000 Yes

  

HTTP Server Prerequisites

Apache version 1.3.19 or later recommended.

Hardware and Software Prerequisites

Before starting the installation, refer to Detailed Installation Prerequisites to be sure you have 
all the hardware and software prerequisites.

File System Prerequisites

To perform all the following operations, the system administrator must have root authority.
The server must have a minimum of 512 Megabytes free disk space.

Database Prerequisites

An ENOVIA LCA data base must already have been set up before starting the SPE installation.

WINDOWS/UNIX File Transfer Prerequisites

You need to install a mapping server Windows/UNIX (NFS type) to enable the data transfer 
from one platform to another.



Licensing Prerequisites

 CATIA V5R14 must already have been installed on both client and server with:

●     DMU Space Analysis -P2  

●     KWE-product (To edit Knowledgeware rules, please also read Knowledgeware Rule-based 
Clash section in DMU Space Analysis User's Guide)

About Installation Default Path

The installation default destination is already proposed
By default it is: C:\Program Files\Dassault Systemes\B14\intel_a  (under windows)
/usr/Dassault Systemes/B14/OS_a/ (under Unix)

where "OS_a" is:

●     aix_a 

●     hpux_b 

●     irix_a 

●     solaris_a 

We assume throughout this Installation guide, that you keep the default location. 

Any way, it is strongly recommended to avoid blanks in the installation path. Therefore, feel 
free to change the default installation path. All you need to do is:

specify a folder of your choice in the Choose Destination Location dialog box, clicking the 
Browse...  button and navigate to select another folder and click OK.



Installation Guide Wizard
To get the most out of DMU Space Engineering installation guide, use the following installation guide wizard. It will help you better 
locate information relevant to you as well as to the way you work.

 External References

I prepare SPE installation 

Setting Up the Client Environment

●     Installing an ENOVIA LCA Client, refer to "Installing an ENOVIA LCA Client" in the 
Enterprise Architecture Installation Guide

●     Installing CATIA version 5 on Windows, please refer to the "Getting Started" section in 
the Installation User's Guide

Setting Up the ENOVIA Environment 

●     Setting Up the ENOVIA Data base on UNIX, refer to "Set up the ENOVIA Database: 
Initial & Final Common Steps in the Enterprise Architecture Installation Guide

●     Installing CATIA version 5 on Windows, refer to the "Getting Started" section in the 
Installation User's Guide 

●     Installing CATIA - ENOVIA V5 Integration Product version 5 on Windows, this 
additional product E5I (CATIA - ENOVIA V5 Integration Product) is a prerequisite to 
enable CATIA/ENOVIA integration. 

●     Installing the Apache HTTP Server, please refer to the installation procedure from 
http://www.apache.org/  

 
Go to:

I  have never installed DMU Space 
Engineering Assistant before...

If you need some help in understanding SPE architecture, read the Getting Started 
section. 
We also recommend you to read Quick Prerequisite Checklist section

Once you have finished, you should move on to the next sections of this guide:
 

●     Setting Up SPE: Initial Steps: lets you prepare your installation and provides 
background information about installation procedures as well as a SPE installer 
description.

●     Installing SPE (Beginner's Mode): provides a step-by-step scenario to understand how 
to install SPE product.

●     Setting Up SPE: Final Steps: lets you customize the Enovia server and provides 
instructions to check the various connections.

These three sections step you through basic installation procedures.
 

I have installed  DMU Space 
Engineering before...

 

●     Installing SPE (Advanced Mode): provides quick information and 

●     Setting Up SPE: Final Steps (read carefully the Checking Network Communications 
section of this guide)

Do not hesitate to refer to Preparing to Install... section at any time.

I  am a super user 
I want to perform manual 
operations...

If you want to perform manual operations, take a look at:
●     Customizing Space Engineering Server Environment Manually

●     Customizing CATIA Environment Manually

●     Customizing the Enovia Server Manually



 

I want to know more ...

 
●     Launching Space Engineering Assistant

●     Knowledgeware Clash Rules

●     Detailed Installation Prerequisites

●     Customizing SPE Product in your CATIA session

Also read DMU Space Engineering User's Guide

Licensing prerequisites 

Make sure, you install DMU Space Analysis -P2. This product is a prerequisite to install Space Engineering Assistant product.

 



 Setting Up SPE: Initial Steps
Preparing to Install...

SPE Installer Overview



Preparing to Install...
This section deals with specific creation and customization tasks to be performed before starting SPE installation:
 

●     Creating a Shared Rules CATProduct document

●     Creating a Predefined Comments File (optional)

●     Creating a CGR Repository

●     Recommendations
 

●     Customizing System Users' Setup

●     Customizing ENOVIA Users' Setup

●     Customizing the Apache HTTP Server on Windows
 

Creating a shared rules CATProduct document
 

●     Create a CATProduct document containing the clash rules to be used for the interference analysis. For more 
detailed information, please read Knowledgeware Clash Rules

●     This CATProduct document must be located in a shared directory accessible from the SPE server user (Apache 
User), the spatial Index process user and all CATIA client users.

(Optional) Creating a Predefined Comments file (.txt) 
 

●     Create a txt file in which CATIA client comments are to be stored. This .txt file should contain a comment per line.
Notes:

❍     This operation must be performed before having launched Space Engineering Assistant in a CATIA 
session.

❍     Refer to Reading Clash Command Results in DMU Space Engineering User's Guide

Creating CGR Repository

Create the CGR repository ('directory' where the tested cgr are to be written) for this:

Recommendations
●     When working with both UNIX and Windows machines, the best way to handle this, is to create shared directories 

on a Unix server and map them as network drives on Windows machines with the NFS Client. We recommend you 
to declare a specific Unix user  (for instance, specgr) to access a Unix directory in which will be located the 
following:
 

❍     CGR repository,  

❍     Predefined Comments file, 

❍     Clash Rules CATProduct document,

❍     Output results files.

●     This directory must be a network shared directory.

●     Each and every client and server machines must have full access to this directory. To do so, you can use any NFS 
mapping tool.

In our example we specified the following directory:

\\auro1dsy\/SHARED/SPE mapped on Y drive on each windows machine.



Read the procedure example below (when using NFS):

❍     Select Start->Programs->NFS Maestro -> NFS Network Access...
The NFS Network Access dialog box is displayed:

❍     Enter the appropriate network path.

❍     Click different user name to enter the specific Unix user you have just defined (specgr):

You now need to give full permissions to this CGR repository. All you need to do is:
❍     Select the Properties button,

❍     When done, select each and every R, W and X check boxes available in the NFS Connection Properties 
dialog box as shown below:



Later, in the installation procedure, you are going to specify SPACE_ENG_SERVER_REPOSITORY and 
SPACE_ENG_CLIENT_REPOSITORY variables referring to this directory respectively on the server and on the client.

System Users' Setup
 

●     Declare a specific user for the SpE server. 

●     This user must have the appropriate privileges:
❍     administrator rights on the SpE server machine, 

❍     read access rights on the above-mentioned shared file (CATProduct document containing clash rules) and 
directories.

If you plan to use several spatial indexes (for several PRCs) on several machines different from the SpE 
server, create several users who should have read access rights on the shared directories for running 
those servers.

ENOVIA Users' Setup

SPE needs to download any part instance from the ENOVIA database, therefore, you need to:

●     Declare an administrator user in ENOVIA P&O to enable the SPE server and spatial indexes ENOVIA connection 
(you can use the same administrator user for all servers). 

For more information, refer to the appropriate ENOVIA documentations:
❍     Starting the People and Organization Administration Utility in the Enterprise Architecture Administration 

Guide

❍     Getting Started with People and Organization in the Enterprise Architecture Administration Guide

Customizing the Apache HTTP Server on Windows

This procedure explains how to customize the Apache server on an Windows workstation.

Note: the host site can either be a Windows or UNIX workstation



Before customizing the Apache server, you should have installed the Apache server on your Windows server, following 
the installation procedure to be found at the following address:

http://www.apache.org/  

The server is installed (if you used the default location) in the folder:
C:\Program Files\Apache Group\

Also refer to Detailed Installation Prerequisites to check you have all the hardware and software prerequisites.

Note: It is recommended to install Apache as a service, if you do not want to launch it manually at each logon.

To check Apache installation is complete and the Apache server is running, try to connect to http://name_of_machine 
using an internet browser. 
For more detailed information, read Step 6: Checking Network Communications

1.  Logon as root. When done, customize the httpd.conf file as follows:

2.  In the Apache Configuration directory (for example located as follows: C:\Program files\Apache 

Group\Apache\conf)

3.  Comment the following line (corresponding to the default ScriptAlias/cgi-bin path): 

 #ScriptAlias /cgi-bin/ "C:/Program Files/Apache Group/Apache/cgi-bin/"

ScriptAlias controls which directories contain server scripts.

4.  Add the following line (default ScriptAlias/cgi-bin path):

ScriptAlias /cgi-bin/ "C:/Program Files/Dassault Systemes/B14/intel_a/code/bin/"

Of course, the path should be changed to whatever your ScriptAliased

5.  Add to the httpd.conf file, the following lines (security directives for Apache):

<Directory "C:/Program Files/Dassault Systemes/B14/intel_a/code/bin"> 
AllowOverride None 
Options None 
</Directory>  

6.  Start or restart Apache service.

Note: the green lines are to be modified accordingly (i.e. With the correct path, we specified here the default 
installation path).



 SPE Installer Overview
This section aims at presenting:
 

●     The two main installation procedures

❍     Installing SPE on each and every computer

❍     Installing SPE on several computers at a time

●     The SPE Installer dialog box 

●     SPE Installer functionalities and components
 

Installation procedures 

Installing SPE on each and every computer: 

You launch the Space Engineering Installer (SpaceEngineeringInstaller.exe) from a single computer running a supported Windows or a Unix 
operating system and repeat this operation on each computer, keeping the desired customization (choosing the specified fields or working from 
existing files using the File->Open menu).
 

Installing SPE on several computers at a time: 

This is possible only if the administrator performed a standard CATIA installation on every network workstation.

Step-by-step procedure (on Windows)

1.  Launch the SPE installer from a computer running a supported Windows operating system (referred to as reference machine).
2.  Customize the settings: filling in the required fields accessible from the tab pages available in the Space Engineering Installer dialog box 

(General Settings, SpE Settings, SpI setting and Catia settings), considering the current machine as a SpE/SpI server and CATIA client.
3.  Install the three products on this computer. The environment files and associated executable programs are automatically created (Read 

about .exe and environments).

We recommend you to read carefully Step 6: Checking Network Communications

4.  Copy the generated files (providing access to the desired service) on each machine running Windows with respect to the specified installation 
paths of the reference machine.

This is very handy to perform the same installation on each machine.  

5.  Modify the existing environment file on the machine hosting a SpE server and the executable program on the  SpI server.

Step-by-step procedure (on Unix)

1.  Repeat step 1 to 5 from a Unix workstation.
Notes:

❍     The installation on Unix seems more complicated than it is on Windows, but is very useful when dealing with a 
company network as it proves to be quicker and avoids configuration errors.

❍     You can of course, mix the two above-described procedures.

SPE Installer dialog box

The following dialog box is a useful tool to install quickly Space Engineering product. It will appear as soon as you launch the installer executable 
program. 

 



 

Four tabs let you customize and install simultaneously, the necessary settings:
 

●     General Settings

●     SpE Settings

●     SpI Settings

●     Catia Settings

Note: Only the General Settings tab is available by default. If you want to access the three following tabs:
 

●     SpE Settings

●     SpI Setting

●     Catia Settings

You need to select the appropriate check boxes in the Choose your Action area:
 



 
SPE Installer functionalities and components
 

Input Settings: correspond to all existing 'data' (paths to files or directories, variables, etc.) on the machine hosting the various services (SpI, 

SpE...). If they do not exist, you should create them.

Output Settings: correspond to the various data created during installation by the administrator. 

Note: This field is available in the SpE, SpI and Catia settings tab pages.

SpI Computation Settings: correspond to necessary parameters for SpI computation (PRC name, clearance value and voxel size).

Choose your Action:  lets you select the appropriate actions and thus access the corresponding tab pages.

Check boxes: let you choose your action(s) (selecting or clearing the appropriate check boxes).  

Browse button: lets you easily fill in the various fields (i.e. Browse lets you access the current path via an appropriate selection box).

File menu: lets you access existing 'settings files' (selecting Open menu item), create new files (selecting New) or Save the current settings 

(selecting Save and Save As... menu items).

Save button: lets you save the current settings. Note you can also use the File menu to perform saving operations.

Notes: 
●     You need to fill in each and every field to activate the Save (either using the Save button or File-> Save...).

●     The save operation performs a global save. 
It means that, when clicking Save, for example, in SpI Settings tab page, you will not be saving the SpI settings customization 
independently but saving the entire settings configuration (provided the required fields are filled) (all need to be)

Install (SpE, SpI, Catia) button: appears in the corresponding tab pages and lets you install respectively the SpE and the SpI servers as well as 
Catia V5.



 Installing SPE (Beginner's Mode)
Installation: an Architecture Example
Step 1: Customizing General Settings

Step 2: Customizing SpE Settings
Step 3: Customizing SpI Settings

Step 4: Customizing Catia Settings



Installation: an Architecture Example
This section provides a simple example of a client/server-based architecture for SPE installation purposes.
Note: the described installation procedure (How to install SPE from scratch) is based on this architecture example throughout this guide.

We decided to provide a simple example based on the following architecture:

●     Server Side

●     Client Side

 

 

Server Side
 

●     We decided to install a single SPE server and the Apache server on the same computer (Chronos). 
In our example, we customized the httpd.conf file as follows:

ScriptAlias /cgi-bin/ "C:/Program Files/Dassault Systemes/B14/intel_a/code/bin/"

<Directory "C:/Program Files/Dassault Systemes/B14/intel_a/code/bin"> 
AllowOverride None 
Options None 
</Directory>  
 

For more detailed information, refer to Customizing the Apache HTTP Server on Windows
 

●     Two spatial indexes: 
(Car_1) on a computer (Zeus), (Car_2) on another computer (Knossos).
 

To gain in performance, it is strongly recommended to respect the following rule: 
"One computer should host a single spatial index"

●     We chose Windows as operating system, note that we could have chosen another OS (i.e. Unix)

●     CGR: a shared directory. You need to install a mapping server Windows/UNIX (NFS type) to enable the data transfer from one platform to 
another. Read Quick Prerequisite Checklist

●     Clash Rules: directory where the CATProduct containing  the clash rule(s) to be used is located



●     Enovia Server: (enables interoperability) SpI and SpE servers are connected to the Enovia server (Enovia_Server_Name = Athena,  Port: 1234)

●     Standard CATIA installation on Chronos, on Zeus and Knossos

Client Side
 

●     Standard CATIA installation on a Unix client + ENOVIA Client (Dyonisos)

●     Standard CATIA installation on a Windows + ENOVIA Client (Minos)

We assume VaultClient_PropertiesFilePath and VaultClient_PropertiesFileName variables are correctly defined in CATIA environment files.



Step 1: Customizing General Settings
This task shows you how to customize General settings. 
In our example, we decided to launch the Installer (SpaceEngineeringInstaller.exe) from a single computer.

●     Input Settings

●     Choose your Action 

Input Settings

In the Input Settings area, customize the various paths and files as follows:

1.  In the CATIA V5 Installation Path field, select the local CATIA installation 'bin' directory path accordingly.

In our example: C:\Program Files\Dassault Systemes\B14\intel_a\code\bin 

If you kept the default location, you should obtain one of the following paths (depending on the operating 
system running on your machine)  

Under Windows: C:\Program Files\Dassault Systemes\B14\intel_a\code\bin

Under Unix: /usr/Dassault Systemes/B14/OS_a/code/bin

where "OS_a" is:

❍     aix_a 

❍     hpux_b 

❍     irix_a 

❍     solaris_a 

2.  For this, click Browse. The Path Browser-Choose local Binary Directory dialog box is displayed:

3.  In the CATIA environment file field, select the current environment file path. Click Browse and select C:\Documents and Settings\All 

Users\ApplicationData\DassaultSystemes\CATEnv\CATIA.V5R14.B14.txt in the File Browser - Choose Local Environment File dialog box 

displayed.

 



If you choose the default location, you should find the environment (created in a text file) (CATIA.V5R14.B14.txt) at the following address 
:

C:\Documents and Settings\All Users\ApplicationData\DassaultSystemes\CATEnv\CATIA.V5R14.B14.txt 

4.  In the Clash Rule File field, select the clash rule file path you want to use clicking Browse. The File Browser-Choose Clash Rule File is 

displayed. Select G:\Clash_Rule\Clash_Rule.CATProduct  

 Reminder: the clash calculation is performed with respect to these Clash rules, specified in a CATProduct document.

If this Clash Rule File does not exist yet, please read Writing your Cash Rule

5.  In the Cgr Location field, select the CGR Repository in which the cgr documents will be stored. 

G:\Cgr_Repository

This shared repository must be accessible from the following components communicating together: SpE and SpI servers and all CATIA clients. 

For more detailed information on how to share this directory, read WINDOWS/UNIX File Transfer Prerequisites and CGR Repository

Choose your Action

6.  

In the Choose your Action area, select the appropriate check boxes. The corresponding tab pages are no longer grayed out. For example, if you 

select the Customize and install the SPE Server and create an Enovia Shell check box, the corresponding tab page becomes available:

 

Then, all you need to do is click the SpE Settings tab and fill in each and every field displayed.

This capability is very useful to target the installation settings you want to customize. 

7.  Check your result, you should obtain something like this:

Now, let's have a look at our architecture example
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If we zoom in on the various components: 

CATIA V5 Installation Path CATIA environment file
  

Clash Rule File Cgr Location

 



Step 2: Customizing SpE Settings
This task shows you how to customize SpE settings.

●     Input Settings

●     Output Settings

●     Matching List

Input Settings

In the Input Settings area, customize the various paths and files as follows:

1.  In the Enovia User Name field, enter the administrator user ID.

In our example: pwd

2.  In the Enovia User Password field, enter the Enovia administrator password (pwdpwd).

3.  In the Enovia User Password Confirm field, type the Enovia administrator password and confirm this password (pwdpwd).

4.  In the Enovia Server Name field, specify the Enovia server name (i.e. Athena).

5.  In the Enovia Server Port field, specify the Enovia server port (i.e. 1234) of the Enovia server (Athena)

6.  In the Output File Path, specify the path to the directory, in which SpE will create, at run time, log and results files and a sub-directory 

(rep) containing xml result files. (E:\Install_Space_Engineering\Output)

For this, click Browse and select the path accordingly in the Path Browser- Choose SpE Output Directory dialog box displayed.

7.  When done, click Ok

Output Settings

In the Output Settings area, customize the various paths and files as follows: 

8.  In the Environment File Name field, enter a name of your choice. This environment file will be created during SpE server installation 

(i.e. Generated_SpE_Env).



9.  In the Environment File Path field, specify the path to the directory in which the environment file will be created. In our example: 

E:\Install_Space_Engineering\Generated_Env.

For this, click Browse and select the path accordingly in the Path Browser-Choose SpE Environment Directory dialog box displayed.

10.  When done, click Ok.

Notes: 
❍     The Generated_SpE_Env file will be created in E:\Install_Space_Engineering\Generated_Env

❍     When the installation is finished, the environment file cannot be moved without modifying the parameters of the associated 
executable program.

11.  In the Enovia Customization shell Name field, specify a name of your choice for the Unix shell. This shell enables to customize the 

Enovia server configuration. (i.e. Generated_Shell)

12.  In the Enovia Customization shell Path field, select the path to the directory in which the Unix shell will be created (using Browse-> 

Path Browser-Choose Enovia Shell Directory) or type it. 

Notes: For more detailed information, please read Step 5:Customize Enovia Server 

Matching List

In the Matching List area, configure the installation architecture as follows:

13.  Specify the 'mapping list' or 'mapping table' identifying the SpI(s) location on the network.

In our example, the SpE server (Chronos) must know that SpI Car_1 is located on Zeus and SpI Car_2 is located on Knossos. 

 

For this, click Add

❍     Enter Car_1 in the Product Name field.

❍     Enter Chronos in the Host Name field.

❍     Repeat the operation with Car_2 (Knossos).

 

Note: You can remove items from your matching list using the Remove button
All you need to is select the line to be removed, the Remove button is no longer grayed out.

14.  Click Ok when done.

15.  Check your result, you should obtain something like this



Now let's have a look at our architecture example

16.  Click Save when satisfied.

17.  Click Install SpE.
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Step 3: Customizing SpI Settings
This task shows you how to customize SpI settings.

●     Input Settings

●     Output Settings

●     SpI Computation Settings

Input Settings

In the Input Settings area, customize the various paths and files as follows:

1.  In the In the Enovia User Name field, enter the administrator user ID

In our example: pwd.

2.  In the Enovia User Password field, enter the Enovia administrator password (pwdpwd).

3.  In the Enovia user Password Confirm field, type the Enovia administrator password and confirm this password (pwdpwd).

4.  In the Enovia Server Name field, specify the Enovia server name (i.e. Athena)

5.  In the Enovia Server Port field, specify the Enovia server port (i.e. 1234) of the Enovia server (Athena)

Output Settings

In the Output Settings area, customize the various paths and files as follows:

6.  In the Environment File Name field, enter a name of your choice. This environment file will be created during SpI server 

installation (i.e. Generated_SpI_Env). 

7.  In the Environment File Path field, specify the path to the directory in which the environment file will be created. In our 

example: E:\Install_Space_Engineering\Generated_Env

 



For this, click Browse and select the path accordingly in the Path Browser-Choose SpI Environment Directory dialog box 

displayed. Click Ok when done.

Notes: 
❍     The Generated_SpI_Env file will be created in E:\Install_Space_Engineering\Generated_Env

❍     When the installation is finished, the environment file cannot be moved without modifying the parameters of the 
associated executable program. 

In the SpI Shell Path, specify the path to the directory in which the runSpaceIndexserver.bat executable program will be 

created.  E:\Install_Space_Engineering\Generated_Shell

For this, click Browse and select the path accordingly in the Path Browser- Choose SpI Shell Directory dialog box displayed. 

Click Ok when done.

Note: You can move this shell in any directory, provided that you do not rename it.

SpI Computation Settings

In the SpI Computation Settings area, customize the following parameters:

8.  In the Product Name field, enter the PRC name to which a spatial index will be associated, as it is or will be declared in Enovia 

(Car_1)

9.  In the Clearance (mm) field, specify a clearance value. 5mm for instance.

Reminder: the clearance value is used for proximity detection. This value has to be set as higher to the maximum 
clearance distance of all clash rules specified in the CATProduct document and used in the Space Engineering Assistant. 

10.  In the Voxel (mm) field, specify the voxel size to be used (i.e. 2mm)

The size of the voxels is calculated in millimeters. The voxel size is a critical factor impacting spatial index performance at 
creation time and at query time. 

❍     The smaller it is, the sharper the index is. 

❍     The smaller it is, the higher the memory consumption is for the spatial index. The spatial query computation is also 
longer.

11.  Check your result, you should obtain something like this:

Now, let's have a look at our architecture example:



12.  Click Save when satisfied.

13.  Click Install SpI. This operation creates the environment file and associated executable program (runSpaceIndexserver.bat)

 E:\Install_Space_Engineering\Generated_Env
E:\Install_Space_Engineering\Generated_Shell

14.  To install SpI server on Knossos, copy the two generated files (runSpaceIndexserver.bat) and the generated environment file 

(Generated_SpI_Env.txt) in the appropriate directories.

15.  Now, customize the SpI Car_2. For this, open the runSpaceIndexserver.bat located on Knossos and modify the variables as shown 

below:

@echo on
rem --------------------------------------------------------------------
rem Space Index & CATIA Variables
rem --------------------------------------------------------------------
set CV5_EV5_NoDelete=yes
rem --------------------------------------------------------------------
rem LAUNCH Spatial Index
rem --------------------------------------------------------------------
set PRC_TO_INDEX=Car_2
set MAX_CLEARANCE=10
set VOXEL_SIZE=3
C:\Program Files\Dassault Systemes\B14\intel_a\code\bin\CATSTART - run CATBackboneSpaceIndex.exe -object 
"%PRC_TO_INDEX% %MAX_CLEARANCE% %VOXEL_SIZE%" -env Generated_SpI_Env -direnv 
"E:\Install_Space_Engineering\Generated_Env"
rem -------------------------------------------------------------------- 

To summarize: 
Car_2 configuration includes: 

❍     3mm for the voxel size, 

❍     10mm as clearance value on the SpI server hosted by Knossos.
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Step 4: Customizing Catia Settings
This task shows you how to customize Catia settings.

●     Input Settings

●     Output Settings

Input Settings

In the area, customize the various paths and files as follows:

1.  In the Comments File field, select the full path Comments file. CATIA client comments are stored in this file. 

In our example: E:\Install_Space_Engineering\Comments 

For this, click Browse and select the path accordingly in the File Browser-Choose Comments file dialog box displayed. Click Ok when done.

Note: This pointed file must exist or must have been created before having launched Space Engineering Assistant in a CATIA session.

Output Settings

In the Output Settings area, customize the various paths and files as follows:

2.  In the Environment File Name field, specify the name of your choice for the CATIA environment file 

(i.e. Generated_Catia_Env).

3.  In the Environment File Path field, specify the path to the directory in which the environment file will be created.

In our example: E:\Install_Space_Engineering\Generated_Env

For this, click Browse and select the path accordingly in the Path Browser-Choose Catia Environment Directory dialog box displayed. Click 

Ok when done.

4.  Check your result, you should obtain something like this:

 



Now, let's have a look at our architecture example

If we zoom in on the various components 

Example of what you can obtain with a Unix interface:
 

 

file:///E|/www/fbpdocr14/Doc/online/speil_C2/images/architecture_exampleNLS.gif


5.  Click Save when satisfied. The Save Settings As dialog box is displayed:

 

 
❍     Enter a meaningful name (in our example spe_save01) to save your xml settings file.

❍     Click Save button

6.  Click Install Catia.

7.  A new CATIA environment file is generated (Generated_Catia_Env). Now, you need to replace the contents of the original CATIA environment file 

with the contents of this generated CATIA environment file (i.e. the file you have just created). For this:

 

1.  Duplicate the original CATIA environment file and rename this copy. 
For instance in: CATIA.V5R14.B14_backup.txt

2.  Replace the contents of the original CATIA Environment file (CATIA.V5R14.B14.txt) with the contents of the generated CATIA 
environment file (Generated_Catia_Env).

Note: If you have already set personal variables in the CATIA.V5R14.B14.txt file, make sure you do no loose any of them. 

If you want to perform a manual customization, read Customizing CATIA Environment 

For detailed information about CATIA environment file, also read About the Environment Created on Your Computer on Windows section in the 
'Infrastructure Installation Guide'



 Setting Up SPE: Final Steps
Step 5: Customizing the Enovia Server on Unix

Step 6: Checking Network Communications



Step 5: Customizing the Enovia Server on 
Unix

This task explains how to customize the ENOVIA server.

Once you have finished, both the specific setup steps for the ENOVIA database and for the 
ENOVIA Client installation, you will need to customize the ENOVIA server. 

Two types of methods are available:
 

●     Automatic customization

●     Manual customization

❍     Example
 

 
Automatic Customization

1.  Copy the Enovia generated shell (in our example Generated_Shell) in the 

code/command directory of the ENOVIA Server.

2.  Execute the Generated_Shell.sh followed with the required path (where your 

SPATIAL.CATSettings file is to be created).

 ...code/command> . Generated_Shell.sh /u/users/CATSettings
 The SPATIAL.CATSettings file will be created in /u/users/CATSettings

If you edit the SpE matching list, do not forget to modify the Enovia server 
customization accordingly.

Manual Customization

1.  Create a SPATIAL.CATSettings file where the CATUserSettingPath should be located. 

This operation enables the ENOVIA connection to the Spatial Indexes. ENOVIA 

application warns all spatial indexes for modifications in database and spatial indexes 

are updated accordingly.

2.  Execute the following commands in the code/command directory of the ENOVIA server: 



./catstart -run "VPMSettings -h" provides utility help 

touch SPATIAL.CATSettings updates the access and modification times of a file 

./catstart -run "VPMSettings -f SPATIAL -a -n DMU_SPATIAL_INDEX_HOST_NUMBER -v 
num"

For each spatial index to declare, run the following command: (i being a number 
incremented from 1 to num)

./catstart -run "VPMSettings -f SPATIAL -a -n DMU_SPATIAL_INDEX_HOST_i -v 
'prc_name:hostname'"

num corresponds to the number of the to be-declared spatial index hosts.
Example: 2 hosts to be declared 

Zeus and Knossos are declared as spatial indexes recognized by the
ENOVIA LCA Server, respectively indexing Car_1 or Car_2 

./catstart -run "VPMSettings -f SPATIAL -a -n DMU_SPATIAL_INDEX_HOST_NUMBER -v 
2"

./catstart -run "VPMSettings -f SPATIAL -a -n DMU_SPATIAL_INDEX_HOST_1 -v 
Car_1:Zeus" 

./catstart -run "VPMSettings -f SPATIAL -a -n DMU_SPATIAL_INDEX_HOST_2 -v 
Car_2:Knossos" 



Step 6: Checking Network Communications

This task shows you how to check network communications providing you quick instructions to answer the following questions:
 

●     Is Apache correctly installed?

●     Is SpE server running? (You need to test your nphSpaceEngCgi.bat is running correctly)

●     Is your Spatial index (SpI) recognized by the Space Engineering Server (SpE)?
 

Checking and Testing Apache Service

We assume you customized the httpd.conf file as described in Customizing the Apache HTTP Server On Windows

1.  Save the httpd.conf and restart Apache service to make sure the modifications are taken into account.

 
❍     select  Start-> Settings-> Control Panel-> Administrative Tools-> Services...

❍      In the Services dialog box, select Apache and click Start

 

You can also access restart Apache service using Start-> Programs-> Apache HTTP server-> 
Control Apache Server -> Restart...

2.  Check the Apache installation is complete and the Apache server is running, for this:

❍     Open an internet window 

❍     Try to connect to http://name_of_machine  

An Apache home Page is displayed.
You should obtain something like this:



 
Checking and Testing SpE Server

1.  Test your nphSpaceEngCgi.bat file is running correctly, for this:

❍     Open a internet window (Internet Explorer or Netscape)

❍     Try to connect to http://name_of_the_machine/cgi-bin/nphSpaceEngCgi.bat 

This is what you should obtain: an XML page containing an Error tag in which 'PRC not find in list, no Spatial Index host to communicate 
with' is written. 

If you obtain an http error instead, please check the following:
 

❍     httpd.conf cgi-bin path configuration. 

❍     Apache user rights (should be Administrator).

❍     nphSpaceEngCgi.bat file syntax.



 
Checking and Testing SpI

2.   Test that your spatial index is recognized by the Space Engineering Server:

❍     Launch Spatial Index (runSpaceIndexServer.bat)

❍     Make sure Apache is running with the customized http.conf file

❍     Open a internet window (Internet Explorer or Netscape)

❍     Try to connect to http://apache_host_name/cgi-bin/nphSpaceEngCgi.bat?PRCName=Prc_Name
Replace the green strings accordingly (depending on your apache host name and prc name)

In our example: http://Chronos/cgi-bin/nphSpaceEngCgi.bat?PRCName=Car_1
 

❍     You should obtain a html page containing the message 'INDEX HERE' is written. 

The message is different from the above image: 
❍     If it contains a http error, check the SpE server installation.

❍     If the following error message is displayed: 'PRC not found in list, no Spatial Index host to communicate with', check the 
DMU_SPATIAL_INDEX_HOST variable (to be found in the SPE server environment file) contains the PRC name you are indexing. 

❍     If the following error message appears: 'Index is not here', check the Spatial Index is running on the machine specified in 
DMU_SPATIAL_INDEX_HOST variable.



 Installing SPE (Advanced Mode)
Installation Settings: Essentials

Customizing SpE Server Environment Manually
Customizing CATIA Environment Manually



Installation Settings: Essentials 
This section provides the basics to know about installation settings:
 

●     General Settings

●     SpE Settings

●     SpI Settings

●     Catia Settings

We assume you selected all the 'Choose your Action' check boxes as shown below.
Reminder: you must fill in each and every field in every tab page before saving your configuration settings.

 
General Settings Tab Page

Input Settings

1.  CATIA V5 Install Path: Local CATIA installation 'bin' directory path 
2.  CATIA Environment File: Current environment file path.
3.  Clash Rule File: Clash rule file path.
4.  Cgr Location: CGR Repository in which the cgr documents will be stored.

Choose your Action

1.  select the appropriate check boxes 



SpE Settings Tab Page

Input Settings

1.  Enovia User Name: Administrator user ID.
2.  Enovia User Password: Enovia administrator password.
3.  Enovia User Password Confirm: Confirmation of the Enovia administrator password.  
4.  Enovia Server Name: Enovia server name.
5.  Enovia Server Port: Enovia server port.
6.  Output File Path: Path to the directory in which SpE will create, during installation, a sub-directory (Output) 

containing a log file.

Output Settings

1.  Environment File Name: Name of your choice for environment file which will be created during SpE server 
installation. 

2.  Environment File Path: Path to the directory in which the environment file will be created.
3.  Enovia Customization Shell Name: Name of your choice for the Unix shell. This shell enables to customize 

the Enovia server configuration. 
4.  Enovia Customization Shell Path: Path to the directory in which the Unix shell will be created.

Matching List

Specify the mapping list or mapping table identifying the SpI(s) location on the network.
Product Name: Spatial Index Host Name: click Add to enter the data of your choice and Ok.

 

SpI settings Tab Page



Input Settings

1.  Enovia User Name: Administrator user ID
2.  Enovia User Password: Enovia administrator password
3.  Enovia User Password Confirm: Confirmation of the Enovia administrator password  
4.  Enovia Server Name: Enovia server name
5.  Enovia Server Port: Enovia server port

Output Settings

1.  Environment File Name: Name of your choice for environment file which will be created during SpE server 
installation 

2.  Environment File Path: Path to the directory in which the environment file will be created.
3.  SpI Shell Path: Path to the directory in which the 'runSpaceIndexserver' executable program will be created.

SpI Computation Settings

1.  Product Name: PRC name to which a spatial index will be associated, as it is or will be declared in Enovia
2.  Clearance (mm): Clearance value
3.  Voxel (mm): Voxel size to be used 

Catia Settings Tab Page



Input Settings

1.  Comments File: Path to the Comments file. CATIA client comments are stored in this file. 

Output Settings

1.  Environment File Name: Name of your choice for the CATIA environment file
2.  Environment File Path: Path to the directory in which the environment file will be created



Customizing Space Engineering Server Environment Manually 
This task explains how to customize the SPE server environment if you decided to perform a manual installation.

 Logon as root.

We assume that you use the default installation folder proposed.
Note: one variable declaration must be written within the same line.

 

1.  Add the following variables to the CATIA environment file (CATIA.V5R14.B14.txt): 

ADL_ODT_USER=User_Name
Enovia user name (for the SPE server user)
 
ADL_ODT_PASSWORD=User_Password

ENOVIA LCA Vault localization:
 

VaultClient_PropertiesFilePath=Install_Path\intel_a\docs\java
You need to recover this file from the ENOVIA UNIX server  and copy it in the Install_Path\intel_a\docs\java 
VaultClient_PropertiesFileName=VaultClient.properties  
VaultClient.properties file name

DMU Clash variables:
 

DMU_CLASH_DEFINE_PRODUCT_FOR_RULE=e:\DesignAssistant\Sea\RuleBasicShape3.CATProduct 
the rule to be used for clash detection 
DMU_DONT_UNLOCK_DOC=1

Spatial Index and CATIA Variable
 

SPACE_ENG_SERVER_REPOSITORY=e:\DesignAssistant\Sea 
Directory where the tested cgr will be written (Note: this directory has to be created if it does not exist)
This directory is a shared by both the client and server.
CAT_SES_ENOVIA_SERVER=Machine_Name:Port_Number
DMU_SPATIAL_INDEX_HOST=Prc_Name_1:Index_Host_1;Prc_Name_2:Index_Host_2
 

❍     The Space Engineering Server must take into account the 'mapping table' existing between PRCs and host machines where spatial indexes are located. 

❍     Each Host should have a running Spatial Index Server indexing the corresponding PRC.

See example below: DMU_SPATIAL_INDEX_HOST=prc_Plane.1:Zeus;prc_Plane.2:Zeus;prc_Car.1:Knossos

A PRC is an ENOVIA LCA product. DMU Space Engineering Assistant can check for interferences within a PRC.

2.  Run CATIA V5 when logged with the SPE user (Apache Service user) and set up the CATIA environment as you would do for any CATIA client (except the SPE 

settings, DO NOT CHECK THE AUTOCONNECT BOX!) 

3.  Copy the nphSpaceEngCgi.bat file from:

 C:\Program Files\Dassault Systemes\B14\intel_a\code\command
 to C:\Program Files\Dassault Systemes\B14\intel_a\code\bin



4.  Replace the content of nphSpaceEngCgi.bat file with the following, modify the string in green with the appropriate path (depending on your installation).

 

@echo off

set SPE_OUTPUT_PATH=E:\ServerOutput

rem ----------- Set of dedicated Variables -----------------

set CLASH_RESULTS_FILE=ClashResults.%REMOTE_ADDR%.txt

set STDERR_OUTPUT=%SPE_OUTPUT_PATH%\%REMOTE_ADDR%2.txt

set STDOUT_OUTPUT=%SPE_OUTPUT_PATH%\%REMOTE_ADDR%.txt

rem ------------- End Dedicated Variables ------------------

rem ------------- Clean ------------------

del "%SPE_OUTPUT_PATH%\%CLASH_RESULTS_FILE%" 2>"%STDERR_OUTPUT%"

rem ------------- End Clean ------------------

rem ---------- We Call the Design Assistant ------------------

C:\Program Files\Dassault Systemes\B14\intel_a\code\bin\CATSpaceEngCgi.exe -env CATIA.V5Rn.B14 -direnv 
"CGI_environment_path" 1>"%STDOUT_OUTPUT%" 2>"%STDERR_OUTPUT%"

rem ----------------------------------------------------------

rem ---------- We put in stdout of Apache the Http Response --

type "%SPE_OUTPUT_PATH%\%CLASH_RESULTS_FILE%"

rem ---------------- OK Response returned --------------------

 

Remarks

CATIA.V5Rn.B14.txt is the default environment file created during CATIA installation

CGI_environment_path is the complete path to the directory containing the CATIA.V5Rn.B14 environment file.

E:\ServerOutput corresponds to the CGI outputs directory (you should create it if not existing)

The Apache user should have read/write access to this directory.

The @echo off must not be modified (switching @echo off to @echo on disables the SPE server).



Customizing CATIA Environment Manually 
This task shows you how to customize the CATIA Environment manually.

1.  Add the following variables to the CATIA environment file (CATIA.V5R14.B14.txt)

For detailed information about CATIA environment file, read About the Environment Created on Your Computer on Windows 
section in the 'Infrastructure Installation Guide'

 

SPACE_ENG_CLIENT_REPOSITORY=f:\DesignAssistant\Sea 
the directory where the cgr is written. This directory must have been created.

ENOVIA LCA Vault localization 

VaultClient_PropertiesFilePath=Install_Path\intel_a\docs\java 
You need to recover this file from the ENOVIA UNIX server  and copy it in the  Install_Path\intel_a\docs\java

VaultClient_PropertiesFileName=VaultClient.properties  
VaultClient.properties file name

The following variables have to be set if you want to perform clash detection using Knowledge rules in interactive mode: 

DMU_CLASH_DEFINE_PRODUCT_FOR_RULE=e:\DesignAssistant\Sea\RuleBasicShape3.CATProduct 
the rule to be used for clash detection 

DMU_CLASH_DISPLAY_COLUMN_PENETRATIONCANDIDATE=1
to see the penetration candidate column in the interactive clash panel

DMU_CLASH_FILE_FOR_COMMENT=e:\users\Clash_Result_Comments\Comments.txt
lets you add default comments (optional)

DMU_DONT_UNLOCK_DOC=1

DMU_CLEAN_ITF_ON_CLIENT=1

DMU_CLASH_ACTION_CANCEL=1

 



Launching DMU Space Engineering Assistant Server
This task shows you how to start DMU Space Engineering Assistant.
Prior to launching, Space Engineering Assistant, please read carefully Step 6: Checking Network Communications

Apache server side (Administrator)
 

 ●     launches Apache HTTP Server as a service ( automatic mode) or in manual mode 

Note: you can choose to install Apache as a service (during Apache Installation), very useful if you do not want to launch it manually at 
each logon

Spatial Index Server side (Adminsitrator)
 

●     Launches Spatial Index shell (runSpaceIndexServer.bat) located in C:\Program Files\Dassault Systemes\B14\intel_a\code\command 
(default installation path)

Client side (User)
 

 

●     launches a CATIA V5R14 session

●     launches an ENOVIA LCA session

●     connects to ENOVIA using the LCA Interoperability toolbar (to display this dedicated toolbar, click Toolbars -> ENOVIA LCA from 
the View menu).

●     Sends data from ENOVIA to CATIA V5 using the Send to... command

●     In CATIA V5 session, click the Connect/Disconnect icon from the Spy toolbar:

 

The icon changes into this:

 

DMU Space Engineering Assistant is ready to work.

●     You can also select the automatic connection beforehand (Tools->Options>Digital Mockup->DMU Space Engineering)

 Several verifications are performed, during the connection operation such as:
 

●     Is Apache server running?

●     Is the PRC sent to CATIA indexed?

●     Is the Spatial Index Server for the PRC running?

DMU Space Engineering Assistant will be ready to work if all the conditions are fulfilled.  

Also take a look at: Step 6: Checking Network Communications



Knowledgeware Clash Rules
Clash rules written using knowledgeware capabilities can be used in a standalone clash process or in an ENOVIA LCA clash 
process, ensuring clash analyses take corporate practices into account.

This task shows you how to write an Expert clash Rule to be used in further rule-based clash computation (using DMU Space 
Engineering Assistant).

 
Writing your Clash Rule

Before you begin, make sure you have selected the required packages. To load the required libraries, proceed as follows:

1.  To customize Knowledge Settings: 

 

❍     Select Tools->Options... command
 The Options dialog box is displayed. 

❍     Select General->Parameters and Measures and click the Language tab. 

❍     Select the load extended language libraries check box.

❍     Select All packages option.

Note:  when the administrator knows exactly what packages  are necessary in his 
working context (with respect to the Knowledgeware clash rules defined), he does not 
need to use All packages option.

 

2.  To customize Parameter tree Views settings:

 
❍     Still in General->Parameters and Measures  category, click the Knowledge tab.

❍     In the Parameter Tree View area, select both with value and with formula check boxes 

3.  To customize Product Structure Settings:

❍     Select the Infrastructure category, then the Product Structure sub-category, and click the Tree 
Customization tab:

❍     Activate both Parameters and Relations options (the Constraints option is set to Yes by default)



You are now ready to write your rule. 

4.  Select Knowledgeware->Knowledge Expert from the Start menu.

5.  Click the Expert Rule icon 

The Rule Editor dialog box appears:

6.  (Optional) Modify the Default name and comments

7.  Click Ok when done.

The Rule Editor appears:

8.  Write your rule



 

 

Let's zoom on the clash rule example: 

if (p1 != p2) 
              
{
   DefineInterferenceComputation (p1, p2,
                                 "Clash", 0mm,
                                 "Shape 1","Shape 1",
                                 ThisRule);
}
P1 and P2 correspond to identifiers used within this rule.

The arguments used in this rule are:

❍     P1 (object type 1)

❍     P2 (object type 2)

❍     Clash (type of calculation), 

the values for this type can be:

■     "Clash" (clash + contact checking)

■     "Clash_only" (clash checking only)

■     "Clearance" (clearance checking  with the clearance value defined)

■     "Authorized_penetration"(authorized penetration checking with the clearance value)

❍     0mm (clearance value)

❍     Shape 1 (name of the shape object type 1)

❍     Shape 2 (name of the shape object type 2)

9.  Click Apply to check rule syntax.

10.  Click Ok to add the expert rule to the document

11.  Click the Update icon to solve the rule base. If needed, update the document.

12.  Save your clash rule in the CATProduct document



You can save more than one rule in the CATProduct document. If you do so, do not forget to give rules a 
priority in the Rule Editor dialog box. When running your interference analysis, rule priority is taken into 
account and if pairs of products and shapes satisfy more than one rule, the results of the rule with the highest 
priority only are output.

13.  (Optional) Check your clash rule works, for this:

❍     In the Space Analysis workbench, run a standard interference analysis using the clash rule you have just created. 
You need to identify the path to the CATProduct containing knowledgeware clash rules. To do so, access the 
appropriate option to be found in DMU Clash - Rule tab using tools->Options-> Space analysis 

❍     Read Knowledgeware Rule-based Clash section in the DMU Space Analysis User's Guide



Detailed Installation Prerequisites
Hardware Requirements

Basic Software Requirements



Hardware Requirements

DMU Space Engineering Assistant Client Hardware 
Requirements

Common Requirements

Disk drive: 150 MB of disk space is required. 

Memory: minimum recommended, client workstation RAM: 512 MB 

Internal/external drives: A CD-ROM drive is required for program and online documentation 
installation. 

Display: A graphic color display, compatible with the selected platform-specific graphic adapter. The 
minimum recommended size for usability reasons is 17 inches. The minimum resolution required for 
Windows workstations is 800 x 600, and 1280 x 1024 on UNIX workstations.

Graphic Adapter: An OpenGL graphic adapter is required, compatible with the windowing manager 
of the selected operating system (CDE on AIX, HP-UX or Solaris; IRIX Interactive Desktop on SGI). 

LAN adapter: a network adapter is required to connect the server and clients to the LAN or WAN. 

Keyboard: a specific keyboard compatible with selected installation locale may be required for 
national language support. 

Pointing device: 2-button or 3-button mouse. 

Hardware Requirements for Windows 

System Unit: Intel Pentium II, Pentium III, or Pentium 4-based workstations running Windows.

Hardware Requirements for IBM AIX 

System Unit: Any RS/6000, based on PowerPC 604 (166 MHz minimum clock speed), Power2 or 
Power3 processor families, supported on AIX Version 4 Release 3.2 or 3.3. 

Hardware Requirements for SGI IRIX

System Unit: Any O2, Indigo2, Octane, Octane2, Onyx2 or Onyx3000 workstations based on R5000, 
R10000 or R12000 processors, supported on IRIX 6.5

  



DMU Space Engineering Assistant Server Hardware 
Requirements

Common Requirements

The following requirements are common to all operating systems supported by ENOVIA LCA V5. 
System unit requirements are platform specific and are detailed in the topics that follow: 

Disk drive: an internal or external disk drive is required to store program executables, program 
data, usage environment and paging space. 500 MB of disk space is required for program 
installation. Requirements may be larger when large amounts of data are used.

Memory: As a rule of thumb, ENOVIA LCA requires 512 MB of real memory for the first session plus 
60 MB for each additional session. Additional dimensioning rules will be provided after further 
capacity planning evaluations.

Note that if the ENOVIA LCA V5 server is installed on the same server as the database server, the 
amount of database memory required will be added to what is needed for ENOVIA LCA. 

Internal/external drives: A CD-ROM drive is required for program and online documentation 
installation. 

Display: A graphic color display, compatible with the selected platform-specific graphic adapter. The 
minimum recommended size for usability reasons is 17 inches. The minimum resolution required for 
Windows workstations is 800 x 600, and 1280 x 1024 on UNIX workstations.

Graphic Adapter: An OpenGL graphic adapter is required, compatible with windowing manager of 
the selected operating system (CDE on AIX, HP-UX or Solaris, IRIX Interactive Desktop on SGI). 

LAN adapter: A network adapter is required to connect the server and clients to the LAN or WAN. 

Keyboard: A specific keyboard compatible with selected installation locale may be required for 
national language support. 

Pointing device: 3-button mouse. 

Server Hardware Requirements for IBM AIX

System Unit: Any RS/6000, based on PowerPC 604 (166 MHz minimum clock speed), Power2 or 
Power3 processor families, supported on AIX Version 4 Release 3.2 or 3.3.



Basic Software Requirements

DMU Space Client Software Requirements

Specific Client Software Requirements

Windows 

Microsoft Windows 

●     Microsoft Windows 2000 delivers an implementation of OpenGL libraries. These libraries may be 
updated depending on the selected graphic adapter, when installing the graphic adapter and 
associated drivers. 

●     A localized version of the operating system may be required when the selected installation differs 
from Latin1.

DMU Space Engineering Assistant Server 
Requirements

Specific Server Software Requirements
●     Apache HTTP server

●     Do not use IBM HTTP server not yet supported.

●     You need to install a mapping server Windows/UNIX (NFS type) to enable the data transfer from 
one platform to another (i.e. in case of one UNIX Client).



Customizing

Before you start your first session, you can customize the way you work to suit your habits. This type of customization is stored in 
permanent setting files: these settings will not be lost if you end your session.

To access them, proceed as follows:

1.  Select the Tools -> Options command.

The Options dialog box appears.

2.  Select the Digital Mockup category in the left-hand box. Various tabs appear.

3.  Click DMU Space Engineering tab.

The DMU Space Engineering tab page is displayed.

 

 

The DMU Space Engineering tab lets you customize options dealing with:
 

❍     Connection Mode

❍     Server Connection Parameters

❍     Clash Result Path

❍     Computation Parameters
 

4.  Other tabs, located in Digital Mockup->DMU Space Analysis category, are also needed for DMU Space Engineering 

Assistant.

 

 

❍     DMU Clash - Rule lets you identify the path to the CATProduct containing knowledgeware clash rules.

❍     DMU Clash lets you customize basic clash settings.

❍     DMU Clash - Detailed Computation lets you define what is computed when you select a conflict or product in the 
Check Clash Results dialog box.

❍     DMU Clash - Penetration lets you define how penetration depth is computed.

Make sure, the client and servers point to the same rule-based clash.

5.  You also need to customize the 3D Accuracy setting located in  Performances tab page of General-> Display category.

 

 ❍     Performances lets you customize performance settings

Make sure the 3D Accuracy value is identical on each and every user workstation and servers.

6.  You also need to customize options in the Infrastructure-> Product Structure category.

 



 

❍     Tree Customization 

Click here if you want to know more about Product Structure category options.

 click the Tree Customization tab

7.  Other tabs located in General ->Parameters and Measures category interfere with SPE product

 

 

❍     Knowledge (Parameter tree view)

❍     Units lets you set the required units

❍     Language lets you specify the options you may need to check when working with Knowledge browsers

Click here if you want to know more about General category options.

8.  Set options in these tabs according to your needs. 

9.  Click Ok in the Options dialog box when done
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DMU Space Engineering

This page deals with the following options:

●     Connection Mode

●     Server Connection Parameters

●     Clash Result Path

●     Computation Parameters
 

Connection Mode

 

 

Automatic

Select the Automatic check box to connect DMU space Engineering 
Assistant automatically to the http server, you do not need to click the 

Connect/Disconnect icon . 
(The connection is established during the Send to CATIA... operation)

If disabled (default mode), you need to connect manually to the server 
clicking the Connect/Disconnect icon in the Spy toolbar.

 By default, the Automatic check box is cleared.

Server Connections Parameters

 



 

Host Server

Specify the host server name (name of the machine hosting the Apache server) 
using the drop-down list.

 By default, this field is left blank.

Port Server

Specify the port server name.

 By default, this field is grayed out.

Clash Result Path

 

 

Path

Click Browse and specify the path directory where the XML files (clash results) are 
to be stored. 

 By default, this field is left blank.

Computation Parameters

 

Beep when computation ends

Clear this check box if you want to deactivate the beep sound which is triggered 
when the calculation is finished.

 By default, this check box is selected.



DMU Space Analysis for DMU Space Engineering 
Assistant

 

This page deals with options you need to customize for DMU Space Engineering and located in the following tabs:

DMU Clash - Rule lets you identify the path to the CATProduct containing knowledgeware clash rules

DMU Clash 
 

●     Retrieve Information

●     During Initial Computation

Click here to know more about DMU Clash tab options

DMU Clash - Detailed Computation
 

●     Level of detail

Click here to know more about DMU - Detailed Computation tab options

DMU Clash - Penetration
 

●     Mode of Penetration

Retrieve Information

Select the None option (No comparison will be done)

 By default, no information is retrieved, the option is set to None

During Intial Computation
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file:///E|/www/fbpdocr14/Doc/online/bascuspa_C2/bascuspa0500.htm


Select Compute penetration depth or minimum distance option button to automatically compute and display the 
penetration depth and minimum distance for all interferences detected.

 By default, this option is set to None.

Level of Detail

Select the Product option to give information at product level only

 By default, the level of detail is set to Element.

Mode of Penetration

Select the Element option to define how penetration depth is computed

Note: his mode lets you assess the seriousness of a clash.

 By default, the level of detail is set to Element.



DMU Clash - Rule  

The DMU Clash - Rule tab contains only one category of options: CATProduct containing Rule(s).

CATProduct containing Rule(s)

Enter the full path to the CATProduct containing knowledgeware clash rules, or select this path using the icon.

 By default, this field is left blank.



Performances 
 

This tab deals with the following categories of options:
●     occlusion culling

●     3D accuracy

●     2D accuracy

●     level of detail

●     pixel culling

●     transparency quality

●     frames per second

●     frames per second for 3Dx devices

●     miscellaneous

●     halo when displaying the geometry with hidden lines removed

●     picking

Occlusion culling

 

Occlusion culling enabled

If this option is selected, it means that occlusion culling is activated.

Occlusion culling avoids redisplay of hidden elements, particularly useful when viewing highly 
compartmented scenes such as plants and buildings but it does not improve display performance.

Let's have a look at the picture below to see what happens when occlusion culling is activated:



 

 By default, this option is cleared.

3D Accuracy

 

The accuracy setting controls the tessellation of surfaces."Tessellation" means that the surfaces of your 
geometry are built using triangles. A triangulation is computed to describe the neighborhood relation of all 
points. 

You have two choices (the preview area to the right shows you the effect of each setting): 

Fixed

Sets a fixed sag value (from 0.01 to 10) for calculating tessellation on all objects, which does not vary with 
object size.

The sag value defines the chordal deviation for curves and surfaces.

The "curve chordal deviation" represents the maximum distance between a polyline ("chord") whose end 
points lie on a curve and a point on this curve:



 

 

The "surface chordal deviation" represents the maximum distance between the tessellation triangles and 
the surface.

●     a low value means that a very fine mesh is used to render surfaces because the distance between the 
geometry and the triangles in the tessellation is very low.
However, the drawback is that geometry will be redrawn more slowly when using the viewing tools.

 

 Example with default fixed sag value ( = 0.20)

●     a high value increases the distance between the geometry and the triangles and thus, decreases the 
number of triangles that will be computed on the object. This means that a very coarse mesh is used, 
but the advantage is that geometry will be redrawn more quickly.



Example with default fixed sag value set to 8.5

 By default, this option is activated.

Proportional to element size

Tessellation is calculated according to object size: the larger the object, the coarser the tessellation. For 
the same sag value, the tessellation on small objects will always be finer than on large objects.

The sag value used to calculate the tessellation of each object is calculated is as follows:

sag = coeff. x radius of sphere/100

where:

●     "coeff." is the value you set using the slider (between 0.1 and 1)

●     "radius of sphere" is the radius of a sphere encompassing the object entirely (this value is obviously 
higher on larger objects).

The following examples show the difference between a fixed and a proportional sag value applied to two 
spheres with different radiuses:

    
           Radius = 100 mm                                   Radius = 10 mm  

          Fixed sag value = 0.20                           Fixed sag value = 0.20



    
            Radius = 100 mm                                    Radius = 10 mm  

     Proportional sag value = 0.20                    Proportional sag value = 0.20

  By default, this option is cleared.

Start by setting a high fixed value in order to decrease the number of tessellation triangles and thus, pay a 
lower price in performance.

 

Warning:
●     when working with V4 models, be careful not to set a too high sag value for 3D accuracy, otherwise you 

will not be able to visualize them

●     as long as the CATPart is not modified (for instance, by creating a point or modifying the pad definition) 
the 3D accuracy is not taken into account when you save the CATPart using the File->Save command. 
However, if you use the File->Save As... command, the 3D accuracy is taken into account

●     bear in mind that modifying the value of the 3D accuracy will have an impact on the size of your 
CATPart document. The reason is that a CGR (CATIA Graphical Representation) is stored systematically 
in the CATPart and the size of this CGR depends on the value you set for the 3D accuracy. 

 

Curve accuracy ratio

This option lets you control the curve accuracy using the slider displayed to the right (you can choose a 
value between 0.1 and 1). 
The curve accuracy is a ratio of the 3D accuracy you define using the above-detailed 3D Accuracy option. 

The curve accuracy is calculated as follows:

sag = 3D accuracy x ratio

As a consequence, the tessellation on curves will be finer than the tessellation on surfaces.

For instance, setting the 3D sag value to 0.20 and the curve accuracy ratio to 0.10 means that:

●     faces will be tessellated with a 0.20 sag

●     curves will be tessellated with a 0.02 sag (0.20 x 0.10).



 
Example 1
Fixed 3D accuracy = 10
Curve accuracy ratio = 1

 

 
Example 2
Fixed 3D accuracy = 10
Curve accuracy ratio = 0.10

 

 
2D Accuracy

 

 Note that settings for 2D accuracy are the same as for 3D accuracy.

Level of Details



 

You do not always need to view a high level of detail in your geometry all the time. You can use the Static 
and While Moving settings to add or remove display quality:

●     Static: even if you do not want to move geometry, it is often useful to remove details you do not need 
to see. Set a low value if you want to see all the details, or a high value to remove details

●     While Moving: you will be able to move large parts more quickly if you set While Moving to a high 
value. When you release the mouse after moving the part, the normal level of detail will be redisplayed.

In both cases, the higher the value, the lower the level of detail. Normally, you set Static to a low value, 
and While Moving to a high value. The added value is increased display performance. 

More about LODs
●     If you are using the Level of Details option with Product Structure or DMU Navigator functions, you 

must activate the cache for your LOD settings to be taken into account

●     When working with a model onto which several colors have been applied (for instance, a different color 
for each face) using a static or dynamic level of detail, only one color will be displayed for performance 
reasons. 
How is this color selected? The application retrieves the color of all the faces the object is made of and 
looks for the dominant color (i.e. the most used color). This dominant color will then be used for the 
display.
If you want to see all the colors applied onto the object, set the static or dynamic level of detail to 0. 

Pixel Culling

 

 

This option is similar to Level of Details, but in that case, it lets you define the size in pixels of objects to be 
hidden/displayed in your geometry using the Static and While Moving settings.

●     Static: even if you do not want to move geometry, it is often useful to remove details you do not need 
to see. To do so, set a high value to remove these details. On the contrary, setting a low value displays 
the details. For instance, setting "2" means that objects whose size on screen is lower than 2 pixels will 
be static

●     While Moving: setting a high value will enable you to move large parts more quickly. When you 
release the mouse after moving the part, the Static size will be redisplayed.



Transparency Quality

 

Low (Screen Door)

Similar to viewing an object through a mesh or a screen. Use this setting when you need to look at objects 
through another transparent object. 
This mode is recommended for increased display performance but keep in mind that only one pixel out of 
two is rasterized and therefore, some objects might not be visualized.
When checked, the transparency is not impacted whatever value you set (between 1 and 255).

 By default, this option is activated.

High (Alpha Blending)

The produced effect is similar to looking through clear glass. Use this setting when you need to view 
several transparent objects located at different depths of a scene. For example, looking through a car 
windscreen at other opaque objects inside the car.

As far as polygons are concerned, the result might not be as expected because in that case, the triangles 
are blend with the rest of the scene. As it is too costly and may adversely affect performance, polygons are 
not drawn using a Z order (i.e. depth order) and therefore, it is not possible to be sure that when the 
transparent polygon is blended, all the scene is drawn behind. Transparent polygons are drawn at the end 
of the draw phase but they are not depth-stored.

When activated, the transparency is impacted according to the value you set.
You also need to set the transparency coefficient on selected objects using the Edit->Properties 
command or Properties command on the contextual menu, by dragging the Transparency slider on the 
Graphic tab. Refer to Displaying and Editing Graphic Properties for more information.  

Note that when working in Shading with Material mode, the Transparency Quality is automatically switched 
to High (Alpha Blending).

Note also that this mode is computation-intensive and consequently has an adverse affect on display 
performance.

 By default, this option is cleared.

Frames per second

 



Enabled

If this option is selected, it lets you control the minimum number of frames per second (frame rate) during 
animations (zooming, moving, flying,... etc.) when using a regular mouse. The frame rate varies from 1 to 
30. Setting a low frame rate keeps a maximum number of details visible, but animations are less smooth 
and fluid; setting a high frame rate limits visible details, but provides smoother, more fluid animations.

This option is particularly useful, for example, in Fly mode: when flying within large objects, you may not 
need to see all the details, but you want to navigate through the object in as smooth a manner as possible.

 By default, this option is cleared.

Frames per second for 3Dx Devices

 

 

If this option is selected, it lets you control the minimum number of frames per second (frame rate) during 
animations when using a 3Dx device such as a Space Mouse. This option works the same way as the above-
detailed "Frames per second", the only difference is that it is specific to 3Dx devices.

 By default, this option is cleared.

 
Miscellaneous

 

Show Hidden Edges (whenever possible)

Note that the display of hidden edges is now activated in the Custom View Modes dialog box.

Enable isoparametrics generation 



If this option is selected, it means that you can generate (in this context, it means to "display") the 
topological elements defined as being isoparametrics. 
By default, the option is not checked for performance reasons.

To use this option, just follow the steps below:

1.  Check the "Enable isoparametrics generation" option: you are then asked to restart your Version 5 
session

2.  Restart your Version 5 session
3.  Re-access the Performances tab then, if desired, specify the number of isoparametrics to be 

generated for u and v axes using the "Number of isoparametrics in U and V" spin box displayed to 
the right. You can generate up to 10 isoparametrics.

4.  Select the View->Render Style->Customize View command then check the "Isoparametrics" 
option which is now activated. 

The isopamametrics are displayed:

             

             Example 1                                                          Example 2
"Enable isoparametrics generation" and                "Enable isoparametrics generation" and
 "Isoparametrics" options are off.                             "Isoparametrics" options are on.
                                                                      2 isoparametrics are displayed for u and v
                                                                    axes since we entered the value "2" in step 
3.

 By default, this option is cleared.

Enable two side lighting for faces and surfaces only 

If this option is selected, it helps you viewing the two sides (i.e. front side and back side) of a face or 
surface by lighting them. 

        



Example with option on                                             Example with 
option off

 By default, this option is activated.

Enable back face culling for faces and surfaces only

If this option is selected, it avoids redisplaying of back sides of faces or surfaces. 

Note that when this option is checked along with the "Enable two side lighting for faces and surfaces only" 
option, only front faces will be lightened.

 By default, this option is cleared.

Enable OpenGL local viewer lighting

If this option is selected, it means that a the lighting quality is better. However, bear in mind that there is a 
price to pay in performance. 

 By default, this option is cleared.

Save lineic elements in cache

From V5R14 onwards, all options related to cgr management are grouped together in the Cgr Management 
tab in Tools->Options->Infrastructure->Product Structure. Therefore, the "Save lineic elements in cache" 
option is not displayed in the Performances tab anymore. 
Refer to "Customizing Cgr Settings" in the Version 5 - Product Structure User's Guide for detailed 
information.

Enable OpenGL Shader

If this option is selected, it lets you apply OpenGL materials when working with the Real Time Rendering 2 
product. These advanced materials are used to create textures such as paint, wood or marble. 
For detailed information, refer to the section entitled "Advanced Materials" in the Version 5 - Real Time 
Rendering User's Guide.

To be able to use these advanced materials, you need to download the OpenGL Shader™ development kit. 
To do so:

●     if you are working on IRIX, browse the following site: 

http://www.sgi.com/software/shader/downloads.html

then download the corresponding kit.

●     if you are working on Windows, browse the following site:



http://www.sgi.com/industries/manufacturing/partners/catia/

then follow the instructions.

The option will be displayed when re-accessing the Performances tab: 

 

  By default, this option is cleared.

Halo when displaying the geometry with hidden lines 
removed 

 

Enabled

If this option is selected, it lets you display a halo around intersecting edges to create a perspective effect.

Prior to using it, you need to switch to Hidden Line Removal mode otherwise, you will not be able to use 
this option. To do so, select the View->Render Style->Customize View then activate the "Dynamic 
hidden line removal" option before clicking OK to validate.

The following picture shows an example of halo:

 

  By default, this option is cleared.



Picking

 

This area enables you to pick elements, i.e. select elements when pointing them. In "normal" picking 
mode, you need to move your mouse to select an element whereas in accurate picking mode, the slightest 
move (one pixel, for instance) is enough to select.

Window size for picking

Lets you specify the size (in pixels) of the window you will use for picking elements in normal mode. You 
can set a value comprised between 1 and 100, the default value being 4 pixels.
The smaller the value, the more precise the picking.

Enable accurate picking

If this option is selected, it helps you select more precisely elements that are very close to each other when 
displaying the geometry. 
It is recommended to work with a magnified view of your document by selecting the View->Magnifier... 
command as shown below:

 



For more information, refer to Magnifying in this guide. 

When "Enable accurate picking option" is checked, the "Window size for accurate picking" option is 
activated to let you define the size of the window (in pixels) used for accurate picking.
The maximum value you can enter corresponds to the maximum value defined for the "normal" picking, 
i.e. the value entered in "Window size for picking". 

Note that if you this option enables you to use normal picking as well.

Activating this option may have a negative impact on the performances when using big models.

 

When working on UNIX workstations, you can use the "Double click latency" slider to manage the 
maximum duration (in milliseconds) between two mouse clicks so that they could be considered as a 
double-click. 
The default value is 500 ms but you can increase it up to 2 seconds.

 By default, this option is cleared.
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