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Overview 
Welcome to the Component Catalog Editor User's Guide. This guide is intended for any users wishing to create 
and manage catalog components within the Catalog Editor workbench.

This overview provides the following information:

●     Component Catalog Editor in a Nutshell 

●     Before Reading this Guide

●     Getting the Most Out of this Guide 

●     Accessing Sample Documents 

●     Conventions Used in this Guide 

Component Catalog Editor in a 
Nutshell

Component Catalog Editor  offers powerful tools to classify all the standard components (CATParts and 
CATProducts) according to keywords you can create and modify as needed.

In addition to the catalog creation, the Component Catalog Editor also lets you navigate through catalogs, 
instantiate catalog components, navigate with a browser to get a preview of any component contained in a 
catalog and query catalogs to find the required components.

Before Reading this Guide
All users should be familiar with basic Infrastructure concepts such as document windows, standard and view 
toolbars as well as the 3D compass.
Prior to reading this book, we therefore recommend that you read the Infrastructure User's Guide.

Getting the Most Out of this Guide
To get the most out of this guide, we suggest that you start reading the Getting Started tutorial providing 
information for starting the Catalog Editor workbench.

Once you have finished, you should move on to the User Tasks section of this guide. This steps you through 
procedures such as creating a catalog, managing catalog components and so on.

The Workbench Description section, which describes the Catalog Editor workbench, and the Customizing section, 
which explains how to set up the options, will also certainly prove useful.

You may need to access the Interoperability section for more information about interoperability between 

Component Catalog Editor and other applications. To do so, just click the Interoperability  icon from the 
table of contents.



Navigating in the Split View mode is recommended. This mode offers a framed layout allowing direct access 
from the table of contents to the information.

Accessing Sample Documents
To perform the scenarios, you will be using sample documents contained in the online/cceug/samples folder. 

For more information about this, refer to Accessing Sample Documents in the Infrastructure User's Guide.

Conventions Used in this Guide
To learn more about the conventions used in this guide, refer to the Conventions section.

 

http://canly1dsy/ajtCXR14/Doc/online/basug_C2/basugbt0208.htm


Conventions
Certain conventions are used in CATIA, ENOVIA & DELMIA documentation to help you recognize and understand 
important concepts and specifications. 

Graphic Conventions

The three categories of graphic conventions used are as follows:

●     Graphic conventions structuring the tasks

●     Graphic conventions indicating the configuration required

●     Graphic conventions used in the table of contents

Graphic Conventions Structuring the Tasks

Graphic conventions structuring the tasks are denoted as follows:

This icon... Identifies...

estimated time to accomplish a task

a target of a task

the prerequisites

the start of the scenario

a tip

a warning

information

basic concepts

methodology

reference information

information regarding settings, customization, etc.

the end of a task



functionalities that are new or enhanced with this release

allows you to switch back to the full-window viewing mode

Graphic Conventions Indicating the Configuration Required 

Graphic conventions indicating the configuration required are denoted as follows:

This icon... Indicates functions that are... 

specific to the P1 configuration

specific to the P2 configuration

specific to the P3 configuration

Graphic Conventions Used in the Table of Contents

Graphic conventions used in the table of contents are denoted as follows:

This icon... Gives access to...

Site Map

Split View mode

What's New?

Overview

Getting Started

Basic Tasks

User Tasks or the Advanced Tasks

Workbench Description

Customizing

Reference

Methodology

Glossary



Index

Text Conventions

The following text conventions are used:

●     The titles of CATIA, ENOVIA and DELMIA documents appear in this manner throughout the text.

●     File -> New identifies the commands to be used.

●     Enhancements are identified by a blue-colored background on the text.

How to Use the Mouse

The use of the mouse differs according to the type of action you need to perform.

Use this
mouse button... Whenever you read...

 
●     Select (menus, commands, geometry in graphics area, ...)

●     Click (icons, dialog box buttons, tabs, selection of a location in the document window, 
...)

●     Double-click

●     Shift-click

●     Ctrl-click

●     Check (check boxes)

●     Drag

●     Drag and drop (icons onto objects, objects onto objects)

●     Drag

●     Move

●     Right-click (to select contextual menu)



What's New?
No enhancements in this release.

 

 



Getting Started
The following tutorial introduces the basic functionalities you need to be familiar with when using The 
Component Catalog Editor.  

It provides 2 sections for: 

  

Entering the Component Catalog Editor Workbench
Getting Familiar with Catalogs

 

 

 

    



Entering the Component Catalog Editor 
Workbench

 

 
This first task will show you how to open the Component Catalog Editor workbench.

 
The only pre-requisite for this task is to have a current Version 5 session running.

 
1.  From the Start menu, select the Infrastructure->Catalog Editor command.

The Component Catalog Editor workbench is displayed: 

 



Getting Familiar with Catalogs

This section tells you what you need to know about catalogs. Users often need a way of storing and classifying the 
many objects they have at their disposal, whether they be screws, ball bearings or computer parts. These objects may 
number tens of thousands, each with its own specific characteristics such as shape, color, size, diameter, length, 
standard, etc. 
To facilitate fast and easy retrieval of such objects thus avoiding time-wasting redesign, Version 5 offers the possibility 
of creating catalogs (identified by the .catalog extension). These can either be created from scratch or through the 
conversion of CATIA Version 4 libraries.  

For details about creation from scratch see Creating a Catalog Using the Catalog Editor or Creating a Catalog in Batch 
Mode. To find out more about the conversion of V4 libraries see "Converting CATIA Version 4 Libraries into Version 5 
Catalogs" in the Version 5 - V4 Integration User's Guide.

Note that Dassault Systèmes does not guarantee downward compatibility for Version 5 catalogs.

A Version 5 catalog is in the form of a tree structure made up of:
●     chapters: a chapter references other chapters or families. It is a way of classifying the elements it refers to

●     families (end chapters): a family is a set of components

●     part families: a part family is a set of components referring to a .CATPart document. This part is unique but has 
been assigned different sets of parameter values, each of them being managed by a design table

●     components: a component is a reference to an external document or an entity such as a feature (e.g. 
PowerCopy), V4 documents (e.g. models) or V5 documents (e.g. CATPart, CATProduct, etc.) described with 
keyword values

●     keywords: a keyword is an attribute describing the chapter and family content. Each component may be assigned 
its own attribute value. You can associate keywords to chapters and families and thus, perform searches by 
attribute value to filter their content.

The example shown below and elucidated in some of the following tasks is a generic family comprising bolts, i.e. a 
chapter ALL_FASTENERS referencing end chapters (SCREWS and NUTS) which, in turn, reference entities. The entities 
referred to by the end chapters can be described using keywords such as Diameter, Length, Designation, etc.



After catalog creation, two functions facilitate and expedite navigation:
●     search by keyword allowing you to find more easily the entities that come closest to your requirements:

  

 

Obviously, the more criteria you use the easier it is to narrow down the search for as satisfactory a result as possible.
●     a preview function (detailed further in this guide) enabling the viewing of all entities in a given chapter to facilitate 

and expedite your search:



 

You can of course define more levels in the catalog's tree structure than shown above. 

There are two important points to bear in mind: 

●     any chapter can be referenced by one or more other chapters. This means that you have more than one way of 
accessing a catalog entity

●     any chapter can be considered to be an entry point into a catalog.

Finally, catalogs can be incorporated into the Team PDM database. For more information about this product, see the 
Team PDM documentation.



User Tasks
Creating and Editing a Catalog

Browsing a Catalog
Managing Catalog Components

Querying a Catalog
Creating a Customized Toolbar Containing a Catalog

 



Creating and Editing a Catalog
 

Creating a Catalog in Batch Mode
Creating a Catalog Using the Catalog Editor
Editing a Catalog Using the Catalog Editor

 



Creating a Catalog in Batch Mode

Creating a Catalog in Batch Mode

Creating a Catalog with a Part Family in Batch Mode

 

Creating a Catalog in Batch Mode
This task explains how to create a catalog in batch mode.

Have access to the files BatchCatalog.csv and Catalog.CATScript in the samples folder.

1.  Start the Catalog Editor workbench by selecting Infrastructure -> Catalog Editor from the Start menu.

 2.  Open the file BatchCatalog.csv. It looks like this:

 



 

The file BatchCatalog.csv contains the information required to create a complete chapter referencing 
subchapters  (CHAPTER is specified in cell 1A with its name FirstChapter in 1B).  

The first chapter displayed in the csv file is the root chapter (FirstChapter) and it references other chapters. 
Each entity description starts with the chapter type (either CHAPTER or SUBCHAPTER) and is separated from 
the other descriptions by the word END.

The names of the catalog documents containing the referenced chapters must also be given (SubChapter1 
and SubChapter2 in 4A and 5A). 

In this particular example, SubChapter1 references a terminal (i.e. "end") chapter (SubChapter3  with its 
name in 26A) which is empty.
These two families of entities are described in FirstChapter by a keyword NAME and identified by the names 
SubChapter1 and SubChapter2 (in cells 4A and 5A).

3.  An example of what one of the families could look like is given in the .csv file extract below:

 

For each chapter (family or not) you must create either a text file (with columns separated by a comma or a  
semi-colon) or an Excel file (with cells separated by a comma or semi-colon) and save it in the .csv format. 

Note the following:

●     The first cell is reserved for the declaration of the chapter type: CHAPTER for a chapter referencing 
subchapters or ENDCHAPTER  for a family referencing one or more entities

●     The second cell is reserved for the name of the chapter to be generated

●     If you do not wish to use the default icons supplied with the application to identify the chapter to be 
generated, you can reserve one of the cells to indicate your own icon to be referred to. This cell may be 
called, for instance, "MyIcon". For more information see Using Icons at the end of this task. Our example 
uses the default icons thus there is no ScrewIcon column in the above image

●     The mandatory items are Keywords to define the names of the keywords associated with the chapter and 
Types to define their unit (or their type for simple cases).
The types allowed are Real, String, Integer, Boolean and the units: m, mm or km for a LENGTH, etc. For 
more information see "About Parameters" in the Version 5 - Knowledge Advisor User's Guide

●     After Keywords and Types, each line represents a description of the constituent entities i.e. their keyword 
values, their name, their location and their associated external preview. The values attributed to the 
magnitudes are assumed to be in the unit (mm for LENGTH, g for MASS, etc). For more information see 
"About Parameters"  in the Version 5 - Knowledge Advisor User's Guide



●     The first column may be empty or contain the name you want to associate to the description

●     The V5 document names in the column located after the last keyword of the description line (in our 
example, the CATPart documents in last column of BatchCatalog.csv) can be preceded by their location 
(with the complete path), otherwise an attempt is made to find these documents based on the link 
resolution strategy. Refer to Linked Document Localization for detailed information

●     In the last column (and for families only), you can specify the external preview file you want to link to the 
component. This column is optional.
 

 Do not use the quote symbol (") in any cell (chapter name, keyword name, keyword value) to enable 
queries on your chapter. In the query syntax, this symbol is used exclusively to isolate keywords whose 
names may contain non-alphanumeric characters.
Example: "DESIGNATION :"=="CHC" 

 Make sure when entering paths and filenames in the .csv file that upper and lowercase characters are 
kept as is.

4.  On Windows:

Open an empty Excel file and, with the aid of the BatchCatalog.csv file supplied, complete the table giving all the 

keywords, types and catalog names required for the creation of the chapter.

5.  Once you have completed the Excel file save it in the csv format making sure it is comma or semi-colon 

delimited.

On UNIX:
The csv format is a text format recognized by UNIX. Any Excel file opened on Windows and saved in the csv 
format can subsequently be used on UNIX.
However, if you prefer to work exclusively on UNIX you can use any text editor provided you use the same 
syntax as the csv format i.e. cell separation by comma or semi-colon.

In case the catalog you create contains a family described by a CATPart with a design table, bear in mind that 
the CATPart will not be resolved. Resolving a CATPart with a design table requires another CATScript file 
detailed in Creating a Catalog with a Part Family in Batch Mode.  

6.  Before being able to use the CATScript file in order to run the batch operation you must make sure the 

CclTypeLib library is loaded. This library declares the catalog creation method. To do this, select the Tools-

>Options... command. The Options dialog box appears with the General category selected in the left-hand 

column.

7.  Click the Macros tab. The following dialog box appears:

http://canly1dsy/ajtCXR14/Doc/online/bascugen_C2/bascudocument0000.htm#hj-LinkedDocumentLocalization


8.  Click the All references... button. This displays the Current references dialog box containing a list of all the 

Version 5 typelibs because they are installed automatically.

9.  Check that the CclTypeLib library is displayed in the list:

 



 
10.  If the CclTypeLib library is not in the list click on the Add file... button and retrieve the library from 

intel_a\code\bin. Make sure it is in the Selected list before clicking OK.

11.  Open the file Catalog.CATScript. In our example, the content looks like this (comments are written in green):

InputFile Language="VBSCRIPT"

Sub CATMain() 

InputFile ="E:\users\Catalogs\BatchCatalog.csv"
(Defines the absolute path of the input csv or text file)

OutputFile ="E:\users\Catalogs\Catalog_Result.catalog"
(Defines the absolute path of the input csv or text file)

Dim Catalog As Document
Set Catalog=CATIA.Documents.Add("CatalogDocument")
(Creates a document of type CatalogDocument)

Catalog.CreateCatalogFromcsv InputFile, OutputFile
(Calls the CreateCatalogFromcsv method on Catalog to create the catalog)

Catalog.Close
(Closes the document)

End Sub 

As you can see, this file, written in the VBScript language, contains the information required to batch-
generate a .catalog file in the location you specify. It can be used on both Windows and UNIX.

12.  If you want to use it, copy it and change the csv file and catalog file paths to adapt them to your environment. 

The comments relating to these paths are shown above in red.

In the example above the CATScript file contains just one set of instructions for the batch-generation of one 
catalog. However, a CATScript file can of course include several series of instructions for the generation of 
several catalogs.

13.  You are now ready to run the batch operation. Select the Tools ->Macro->Macros command.  The following 

dialog box appears:



 
14.  Click the Select... button then navigate in the Select a macro file dialog box to choose the appropriate CATScript 

file. Click the Run button which is now grayed out.

This batch operation will generate:

●     a report named Catalog_Result.report in the same location as the catalog file, allowing you to check 
successful creation of the catalog. For example:



 

The above example shows only an extract but the .report file details each description, ending with the catalog 
creation status.

●     and a catalog named Catalog_Result.catalog, containing subchapters with the name originally given in the 
Excel file.

You are advised to keep the csv files used for catalog generation as no changes can be made to the catalog 
without completely regenerating it in the way described above. 

15.  If you want to open the catalog you have just created see "Browsing a Catalog".



  

Using Icons 

If you prefer not to use the default icons supplied with the catalog application, you can associate one of your 
own with each chapter. You can do that by putting:

●     either the complete path indicating the location of the icon

●     or just the name of the icon (without the .bmp extension)

in the cell reserved for referring to your own icons.

If for whatever reason the icon you wish to use is not found no icon will appear, neither the default icon nor 
of course the icon you wanted to associate yourself.

Entering the complete path has the disadvantage of presenting problems when exporting the catalog to 
another site.

Entering just the name means that you must put all your icons in a single folder or directory which you must 
create (and not in the Version 5 filetree). You must then concatenate the folder/directory location by resetting 
the Version 5 environment variable "CATGraphicPath" in your current environment to point to the 
folder/directory. When exporting the catalog, you then only have to reset the variable specifying the receiving 
site.

For more information about customizing environments, see "Managing Environments".

  

  

Creating a Catalog with a Part Family in Batch Mode

This task explains how to create a catalog containg parts with a design table in batch mode.

This creation mode lets you add only one design table to your catalog. 

Bear in mind that:

●     the design table must contain a column entitled "PartNumber"

●     you cannot add a part family if the generic part referenced by the design table is already opened in an editor

●     Excel files are not supported on UNIX. As a consequence, if your design table is in .xls format, you need to convert it 
to the .txt format to be able to use it. You must then reroute the link of the .CATPart document from the former .xls 
design table to the new .txt design table: to do so, select the Edit->Links... command then use the Replace button.

http://canly1dsy/ajtCXR14/Doc/online/basug_C2/basugbt2103.htm#hj-replace


Have access to the CatalogResolveDescription.CATScript and PartWithDT.CATPart located in the samples folder.

 If you want to indicate precisely whether a description should be resolved or not, edit the design table by adding the 
keyword "CATCatalog_ResolveDescription" then specifying the boolean value "TRUE" (or "T") or "FALSE" (or "F") next to 
each description.
To illustrate this, let's have a look at the example below in which the descriptions n° 1, 3 and 5 will be resolved:

 PartNumber PartBody\Pad.1\FirstLimit\Length (mm) CATCatalog_ResolveDescription
1 20 TRUE
2 40 FALSE
3 60 TRUE
4 80 FALSE
5 100 TRUE

 Note that when the keyword "CATCatalog_ResolveDescription" has been added to the design table, using the Add Part 
Family command in the Catalog Editor will resolve the descriptions indicated as "TRUE" (or "T").

Before being able to use the CATScript file in order to run the batch operation you must make sure the CclTypeLib 
library is loaded. To do this, repeat the above-mentioned steps 6 to 10 in "Creating a Catalog in Batch Mode".

 1.  Open the file CatalogResolveDescription.CATScript. It looks like this (comments are written in black):

 

Language="VBSCRIPT" 

Sub CATMain()
ChapterName ="NewChapter"
(Defines the name of the new part family) 

InputFile ="E:\users\Catalogs\PartWithDT.CATPart"
(Defines the absolute path of the CATPart file) 

Dim Catalog As Document
Set Catalog=CATIA.Documents.Add("CatalogDocument")
(Creates a document of type CatalogDocument)

Catalog.CreateChapterFromDesignTable ChapterName, InputFile
(Calls the CreateChapterFromDesignTable method on Catalog to create the part 
family)

Catalog.SaveAs ("E:\users\Catalogs\ResolvedDescription_Result.catalog")
(Saves the document under the specified name in the specified location)

Catalog.Close
(Closes the document)

End Sub 

your environment. 

In the example above the CATScript file contains just one set of instructions for the batch-generation of one 
part family. However, a CATScript file can of course include several series of instructions for the generation of 
several families.

3.  Select the Tools ->Macro->Macros command.  The following dialog box appears:



2.  If you want to use it, copy it and change the ChapterName and the InputFile name and path to adapt them to 

your environment. 

In the example above the CATScript file contains just one set of instructions for the batch-generation of one 
part family. However, a CATScript file can of course include several series of instructions for the generation of 
several families.

3.  Select the Tools ->Macro->Macros command.  The following dialog box appears:

4.  Click the Select... button then navigate in the Select a macro file dialog box to choose the appropriate CATScript 

file. Click the Run button which is now grayed out.

 

This batch operation will generate:

●     a catalog named ResolvedDescription_Result.catalog (according to the name originally given in the Excel 
file)

●     a new chapter containing the part and its associated design table

●     and the .CATPart document(s) referred to by the part family. These documents are saved in the folder you 
specified in the Folder field under the Tools->Options->Infrastructure->Catalog Editor tab.

Note: you can still resolve interactively a part family with a design table. For detailed information, refer to 
Resolving Part Families.



Creating a Catalog Using the Catalog Editor

This section introduces the Catalog Editor workbench which provides interactive commands to create and 
modify your own catalogs by adding chapters, keywords and descriptions. 
Once these elements are created, you can modify them afterwards when needed. Refer to Editing a 
Catalog Using the Catalog Editor for detailed information.

From the Start menu, select the Infrastructure->Catalog Editor command to open the Catalog 
Editor workbench.
An empty catalog containing a first chapter is created as you access the workbench.  

The icons available in the Catalog Editor are updated, i.e. grayed or not, according to the contextually 
edited element. For example, if you double-click a family you will only be able to add a keyword or a 
description.

 Now let's go to adding elements to our catalog!

Adding a Chapter

As shown in the Getting Familiar with Catalogs task, a Version 5 catalog is made up of chapters, each 
chapter describing what we call a "family". In our example, the ALL_FASTENERS.catalog comprises a 
chapter, ALL FASTENERS, and two families, SCREWS and NUTS. 
The ALL_FASTENERS.catalog is provided in the samples folder. For detailed information, refer to 
Accessing Sample Documents.

1.  In the left-hand part displaying the catalog structure, double-click to activate the chapter under 

which you want to create a chapter or a subchapter. This chapter must not be a family.

 2.  Click the Add Chapter icon  or select the Insert -> Add Chapter... commands from the 

main menu to display the Chapter dialog box .
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 3.  Key in the name of your new chapter in the Name field.

 

When creating a sub-chapter, you can check the "Copy of Keywords" option to copy the 
keywords of the father chapter. The values of the copied keywords are identical to those of the 
father chapter but you can modify them if needed. 

 

4.  Click OK.

The new chapter is created and displayed in the catalog structure. 

Adding a Link to Another Catalog

1.  Open the catalog to which you want to create a link.

2.  Activate the ALL_FASTENERS.catalog window.

 

3.  Click the Add link to another catalog icon  or select the Insert -> Add link to another 

catalog... command from the main menu.

4.  Activate the window of the other catalog, then select the chapter or the family to be linked.

The link is created. 

An icon is displayed in the graph and its appearance changes according to the selecting item: 
family or chapter. 



The family you are going to create will be directly added to the current chapter.

1.  Click the Add Family icon  or select the Insert -> Add Family... command from the main 

menu to display the Component Family Definition dialog box.

 

 
2.  Indicate the name of the family in the Name field.

3.  In the Type field, select an application type from the pulldown list. 

You can check the "Copy of Keywords" option to copy the keywords of the father chapter. The 
values of the copied keywords are identical to those of the father chapter but you can modify 
them if needed.

 
4.  Click OK.

The family is created. 

Adding a Keyword

The keyword will be added to the current chapter.

1.  Click the Add Keyword icon  or select the Insert -> Add Keyword... command from the 

main menu to display the Keyword creation dialog box.

An icon is displayed in the graph and its appearance changes according to the selecting item: 
family or chapter. 

Adding a Family



 

 

 2.  Specify a name for the new keyword.

 
3.  Use the drop-down list to select the keyword Type. This list provides all knowledge types, i.e. 

Integer, String, Boolean, Angle, and so on.

 

4.  Enter a Default Value for the keyword. 

This value may optionally be unset by clicking the Unset button.

When you position your pointer on the Value field then use the contextual menu and select the 
Range... command. This command lets you define a Minimum and a Maximum bound for the 
description value. 

You can uncheck the Visibility option if you do not wish the keyword to be visible. In that case, 
the keyword will be visible in the Catalog Editor only and not in the Catalog Browser. 

5.  Click OK. 

The keyword is created and associated to the selected chapter. 

 
Note: The "With discrete list of values" option lets you assign legal values to the keyword. 



1.  Activate the family.

 2.  Click the Add Component icon  or select the Insert -> Add Component... command from 

the main menu to display the Description Definition dialog box.

 

 The three buttons detailed below are the only way to modify links to catalog components. You 
cannot use the Edit->Links... command to do this because it is relevant only for links 
between catalogs and not for links to components such as CATParts, CATProducts, etc.

3.  Click the Select document button if you want to select a referenced object. You can select the 

following document types:

●     .CATDrawing (Generative Drafting or Interactive Drafting documents).

●     .CATPart (Part Design documents)

●     .CATProduct (Assembly Design documents)

●     .CATScript (macro files generated by Version 5)

●     .CATGScript (Generative Script files created by Version 5)

●     .igs (IGES documents)

●     .model (V4 model documents)

●     .session (V4 session documents).

You can uncheck the Visibility option if you do not wish the keyword to be visible. In that case, 
the keyword will be visible in the Catalog Editor only and not in the Catalog Browser. 

5.  Click OK. 

The keyword is created and associated to the selected chapter. 

 
Note: The "With discrete list of values" option lets you assign legal values to the keyword. 

Adding a Component to a Family



Your choice is displayed in the File name field.

Or

Click the Select external feature button to choose a PowerCopy, a Details, a Formula or 
Rules Checks features in another document open in the current session. 

Or 

Click the Select document in session button lets you create a component pointing to a 
document already opened in your current session.
Clicking this button opens the Session document window which enables you to select a file 
from the list of currently opened documents as shown below: 

 

This window lets you filter the files by type and displays a preview of the selected file. This file 
will be considered as a "Document" in the Type field. 

Note that as far as ENOVIA V5 or ENOVIA VPM documents are concerned, the DocId is taken 
into account in the File name field. 

4.  Click the Keyword values tab. This tab enables you to set values for all keywords you have 

previously defined.



 

  

 

5.  In the Keyword name list, select the element for which you want to set a value.

6.  Enter your value in the Value field.

You can click the Unset button to unset the displayed value. 

7.  Click the Preview tab.

 



A default document preview, which is the Referenced document, is displayed if you point to a 
document. If you point to a feature, nothing is displayed. 

8.  Choose the "Local preview" option if you want to refer to a document stored in the .catalog file or 

the "External file preview" option to preview an external file in .jpg, .bmp., etc. format.

If you click the "External file preview" radio button, you can select a file in the Select File 
dialog box. The complete path will then be displayed. 

You can also directly click the Select an external preview file button instead of clicking the 
External file preview radio button. 

9.  Click OK when you have finished. 

The description is created. 

Adding a Part Family

 A part family is made of components referring to a .CATPart document. This part is unique but has been 
assigned different sets of parameter values, each of them being managed by a design table.
For more information on design tables, refer to the Design Tables section. 

This section shows you how to add a part family from a selected document (i.e. a .CATPart document) 
managed by one or more design table(s).

Bear in mind that:

●     the design table must contain a column entitled "PartNumber", otherwise you will not be able to add 
the part family to the catalog

●     you cannot add a part family if the generic part referenced by the design table is already opened in 
an editor

●     Excel files are not supported on UNIX. As a consequence, if your design table is in .xls format, you 
need to convert it to the .txt format to be able to use it. You must then reroute the link of the 
.CATPart document from the former .xls design table to the new .txt design table: to do so, select 
the Edit->Links... command then use the Replace button.
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1.  Select a chapter.

2.  Click the Add Part Family icon  or select the Insert->Add Part Family... command to 

open the Part Family Definition dialog box.

A default name is given to the part family but you can modify it. 

 

 

 3.  In the Type field, select an application type from the pulldown list. 

 

4.  Under the Reference tab, click the Select Document button to define the document that will be 

referenced. This document should be a CATPart with a single design table, otherwise an error 

message will be displayed.

The Type field will be automatically filled according to the file you selected. 

In case the document you selected contains more than one design table, the following dialog 
box appears: 



 

 

 Just select a design table from the list before clicking OK to validate your choice. 

 Note: if you added the keyword "CATCatalog_ResolveDescription" to the design table, the 
descriptions containing the value "TRUE" (or "T") will be resolved.

 5.  Click the Browser Preview tab to specify the type of browser preview you want to use.

 

 



 

A Default document preview, which is the document stored in the .catalog file, is displayed .

6.  Choose the "Referenced document preview" option to preview the document you point to or the 

"External file preview" option to preview an external file in .jpg, .bmp., etc. format.

If you click the "External file preview" radio button, you can select a file in the Select File 
dialog box. The complete path will then be displayed. 

The "Store preview in catalog" option lets you save the preview in your catalog. 

 

7.  Click OK.

The part family is created and displayed in the specification tree. A sheet containing a 
component for each line of the design table is also created. 

 

When you double-click the part family in the specification tree, any corresponding information 
contained in the design table is displayed. Each information corresponds to a keyword in the 
chapter. 

 

 



 
Note that you can hide or add part family definition and keyword values by selecting the 
corresponding item from the contextual menu. 

Adding Part Family Components

 This section shows you how to add components managed by a design table to an existing part family.

Excel files are not supported on UNIX. As a consequence, if your design table is in .xls format, you need 
to convert it to the .txt format to be able to use it. You must then reroute the link of the .CATPart 
document from the former .xls design table to the new .txt design table: to do so, select the Edit-
>Links... command then use the Replace button.

1.  Double-click to activate the part family to be edited.

2.  Click the Add Part Family Components icon  or select the Insert->Add Part 

Components... command to open the Part Family Definition dialog box.

The name of the active part family is displayed and can be modified, if needed. 
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3.  Click the Select Document button to choose the component that will be referenced.

The Type of the selected document will be automatically displayed. 

In case the document you selected contains more than one design table, the Part Family 
Design Table List dialog box appears to let you choose the desired design table. 

 
4.  Click the Browser Preview tab to specify the type of browser preview you want to use. Refer to 

Adding a Part Family for more information.

 5.  Click OK to validate.

 
The new components are added to the part family with their related information. 

 

Note: another method to create a catalog is to click the New icon  or select the File-
>New... command.  

In the New dialog box, double-click the CatalogDocument type or select it then click OK.  



Editing a Catalog Using the Catalog Editor

This section explains how to modify chapters, keywords and descriptions in your catalog using the 
Catalog Editor. 

Open the catalog to be modified.

The icons available in the Catalog Editor are updated, i.e. grayed or not, according to the contextually 
edited element. For example, if you double-click a family you will only be able to add a keyword or a 
description.

Editing a Chapter

Once a chapter has been created, you can easily modify its name using two methods:

 
Method 1

1.  Right-click the chapter in the catalog structure then select the Chapter object->Definition... 

contextual command.

This opens the Chapter Definition dialog box which lets you enter the new chapter name:

 

 2.  Click OK to validate.

 



1.  Select a created description in the right part of the window then choose the Edit current 

chapter... command from the contextual menu.

This opens the Chapter Definition dialog box which lets you enter the new chapter name:

 

 
2.  Click OK to validate.

The family is created. 

Editing a Keyword

 Two methods can be used to modify keywords.

 
Method 1

1.  Right-click the chapter in the catalog structure then use the Chapter object->Keyword default 

values... contextual menu

This opens the Chapter Keywords dialog box:

 

 
Method 2



 

 

This dialog box lets you specify a new Name and a default Value for the selected keyword, 
unset the displayed values or even remove a keyword.  

The Visible option is used by the catalog administrator to make a keyword visible or not when 
a user browses the catalog. 

Position your pointer on the Value field then use the contextual menu and select the Range... 
command. This command lets you define a Minimum and a Maximum bound for the 
description value. 

2.  Click OK. 

The keyword is modified and associated to the selected chapter. 

 
Method 2

1.  Right-click a description in the right part of the window then choose the Keyword default 

values... command from the contextual menu.

This opens the Chapter Keywords dialog box:



 

Refer to Method 1 for information on how to use this dialog box.

2.   Click OK to validate.

Editing a Description

1.  Select the description to be modified in the right part of the window then double-click it or choose 

the Definition... contextual menu. 

This opens the Description Definition dialog box:

 



 
2.  Click the tab in which you want to modify data. Refer to Creating a Catalog Using the Catalog 

Editor for detailed information on the how to use the Description Definition dialog box.

If you modify the description name, a warning message is displayed: the reason is that when 
you modify a description referencing an object or a document, the modified description is 
synhronized with the referenced element. In that case, keyword values may also be impacted.

 
3.  When finished, click OK to validate.

 

Note: You can also update all the descriptions of a chapter at the same time using the value 
of a string type keyword. To do so, choose a chapter then select the Update descriptions 
name command from the Insert menu. 

 

The Update descriptions name dialog box enables you to indicate a new Reference keyword.



When you rename the description, the Name value will be modified as well but if no Name has 
been specified, you can modify the description without creating this keyword. 

If you want to delete a description, you can do so by right-clicking it under the Keywords tab 
then selecting the Remove description contextual command:

 

 
The selected description will be removed from the list.



Browsing a Catalog
Using the Catalog Editor

Using the Browser Display
Using the Catalog Browser



Browsing a Catalog Using the Catalog Editor

This task explains how to preview and navigate through catalogs using the Catalog Editor.

1.  In a Version 5 session, open the catalog to be previewed. In our example, the catalog is named 

ALL_FASTENERS.

The ALL_FASTENERS chapter, the only chapter contained in the ALL_FASTENERS.catalog appears in a 
catalog navigator window. 

Double-clicking on a family displays, in the navigator window, all the chapters referenced by the family. 

2.  Double-click ALL_FASTENERS. The entities contained in the chapter selected then appear in the left-hand part 

of the catalog navigator as shown:

 

 



Default Icons 

Two default icons are used:

●     the folder icon  identifies a chapter and the folder + arrow icon  identifies a chapter in another 
catalog

●     the sheet icon  identifies a catalog family and the sheet + arrow icon  identifies a family in 
another catalog.

To find out how to use other icons, see Using Icons. 

 

3.  Double-click a family name or icon:

●     The entities contained in the selected chapter appear in the form of a table in the Keywords tab on the 

right-hand side of the navigator:

 

 
The values assigned to each component attribute are displayed under the Keyword tab. 

 4.  Click the Reference tab:



 

 

 

Three columns are displayed: 

●     Name: name of the description

●     Type: type of the description. It may be a chapter, a file or a feature. 

●     Object Name: name of the pointed object. It may be a file or a CATPart. When a component is resolved, 
it points to the document generated in the storage folder. Refer to Resolving Part Families for detailed 
information.

This tab corresponds to the Reference tab of the Description Definition dialog box detailed in Creating a 
Catalog Using the Catalog Editor. 

In case the name of the pointed object cannot be found (i.e. the Object Name column indicates "Document 
not found"), access the Tools->Options->General->Document tab to indicate how to localize your linked 
documents.  

 5.  Click the Preview tab to visualize the listed entities:
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The Generative Data tab is dedicated to resolved queries. A resolved query is relevant for parts with design 
tables only since it aims at storing a filtered view of the design table data. This type of query is detailed in 
Creating Components from Catalog Filters. 

A design table is a feature created in Version 5 either from the current parameter values of your document 
or from external data. This feature facilitates the definition and management of mechanical parts by enabling 
you to regroup in the form of a table, in a .xls or .txt file, the various sets of parameter values that can be 
assigned to a part. Each set of parameter values is called a configuration.
For more information on design tables, refer to the Design Tables section. 

You can open an entity in one of the above-mentioned tabs by double-clicking it. If you want you can now edit the 
entity just like any other V5 document.

To narrow the selection criteria using the keywords you originally chose see Making a Standard Query in a Catalog.
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 When selecting an element in one of the above-detailed tabs, you can also use all or part of these contextual 
commands, according to the tab in which you perform your selection: 

●     Copy Keywords... lets you copy keywords from one chapter to another. Refer to Copying Catalog Chapters and 
Keywords

●     Definition... lets you modify the component description definition. For more information, refer to Editing a Catalog 
Using the Catalog Editor

●     Edit current chapter... lets you add a family to the current chapter. For more information, refer to Editing a 
Catalog Using the Catalog Editor

●     Keyword default values... lets you modify the component keyword values. For more information, refer to Editing 
a Catalog Using the Catalog Editor

●     Open as new document lets you open the document as a new document in a new window

●     Open as new reference document lets you open the referenced document as a new document in a new window

●     Open document lets you open the document in a new window

●     Open reference document lets you open the referenced document in a new window

●     Publish Catalog Object... lets you create a toolbar containing a catalog. Refer to Creating a Customized Toolbar 
Containing a Catalog.

●     Remove description lets you remove a component description. Refer to Editing a Catalog Using the Catalog Editor

●     Reorder sub-chapters... lets you reorder sub-chapters. Refer to Reordering Catalog Elements

●     Reorder keywords... lets you reorder keywords. Refer to Reordering Catalog Elements

●     Reorder components... lets you reorder catalog components. Refer to Reordering Catalog Elements

 



Browsing a Catalog Using the Browser Display

This task explains how to preview and navigate through catalogs using the browser display.

1.  In a V5 session, open the ALL_FASTENERS.catalog.  

The catalog opens in the Catalog Editor which lets you preview the catalog components as explained 
above.

2.  Click the Display with browser  icon from the Browser toolbar to open the Catalog Browser dialog 

box:

 

 

This dialog box lets you browse and preview the content of the current catalog. 

3.  Double-click a chapter, SCREWS for example.



 

 
The parts included in the SCREWS end chapter are displayed with their corresponding preview.

 
4.  Select Details from the pulldown list to show the catalog descriptions and keywords. By default, they are 

not displayed.

 

You can choose your preview type simply by selecting it from the pulldown list and  you can also click 
the Catalog tree icon to switch from a display mode to another.  

These display options are illustrated by the following picture: 

 



 
This browser also enables you to perform queries on keywords and descriptions:

 

5.  Enter your search string in the Filter field. 

For more information on how to query catalogs, refer to Querying a Catalog in this guide.

6.  Click the search icon.

The search result is displayed .

 

7.  Click Close to exit the Catalog Browser. 

For more information on the Catalog Browser, refer to Using the Catalog Browser in this guide.



Browsing a Catalog Using the Catalog Browser 

This task explains how to preview and navigate through catalogs using the Catalog Browser.

 The Catalog Browser provides interactive commands to browse a catalog. It slightly differs from the browser display 
since it is available in several workbenches such as Assembly Design, Part Design, Generative Shape Design or 
Drafting and it lets you instantiate components.

For more information on component instantiation, refer to Instantiating Catalog Components in this guide. 

1.  Open the Catalog browser dialog box by clicking the Catalog Browser icon  or selecting the Tools-

>Catalog Browser command. 

2.  Click the Browse another catalog icon  to open the File Selection dialog box. This dialog box enables 

you to navigate to the selected catalog. In our example, we have selected the SCREWS catalog:

 



Depending on the document environments you allowed in the Document settings, an additional window 
may appear simultaneously to let you access your documents using alternate methods.
These methods will enable you to browse, for instance, catalogs created using the SmarTeam-CATIA V5 
Integration product (provided that you have the required license) or catalogs already opened in your 
current Version 5 session as you could do it respectively with the former "SmarTeam Catalog" and "Select 
document" icons.
For detailed information, refer to Opening Existing Documents Using the Browse Window.

 
3.  Click Open to open your catalog in the browser.

 

 

The current catalog name is displayed in the title bar and the current chapter name is indicated at the top 
of the drop-down list. This drop-down list gives you access to the five latest catalogs selected. The icon 
with an ascending arrow returns to the previous chapter selected. 

You can also double-click an icon to directly open a chapter.

 By default, the catalog content is displayed with small icons but you can easily switch from small to large 

icons by clicking the corresponding button:  or .
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4.  Click the Table>> button to show/hide the catalog descriptions and keywords. By default, the table is 

hidden. 



 

5.  Enter your search string in the Filter field, for example,  x.DESIGNATION.Search("FHC")>=0mm. 

For more information on how to query catalogs, refer to the Making a Standard Query in a Catalog task in 

this guide.

6.  Click the search icon.

The search result is displayed.

If one of the catalog objects does not point to any element, its description appears in red and the word 

"Broken" is added at the end between brackets. An error icon  is also displayed if no preview can be 
found.

 
Just select the desired catalog from the list then click OK to open the catalog in the browser.



Managing Catalog Components
Instantiating Catalog Components
Reordering Elements in a Catalog

Copying Catalog Chapters and Keywords
Resolving Part Families and Part Family Components

Creating Components from Catalog Filters

 



Instantiating Catalog Components
  

This task introduces the Catalog Browser's interactive commands you can use to instantiate parts, products, V4 model documents, 
PowerCopy elements and details. 

Instantiating Parts and Products

1.  Open the product to which you want to instantiate a part.

2.  Open the Catalog browser dialog box by clicking the Catalog Browser icon  or selecting the Tools->Catalog Browser 

commands

3.  Click the Browse another catalog icon  to open the Select catalog dialog box then navigate to the desired catalog and 

select the part to be instantiated.

4.  Drag the part onto the product in the specification tree then drop it when the pointer shape changes.



 

 
The new CATPart is instantiated and displayed in the specification tree. 

 
This method can also be applied to instantiate a part from a part family as shown below: 

 

 

You can also double-click an element to instantiate it. In this case, the Catalog window opens and displays the selected 
element: 



 

 

 

You can manipulate the element wether in the Catalog window or in the geometry area, each view being independent from 
the other. 

In case you wish to instantiate an element onto another one, this method lets you choose the element location. To do so, 
simply select a point anywhere on the first instantiated element to indicate the origin of the second instantiation: 

 

 

Note: another way of instantiating a part/product is to right-click it from the catalog browser then use one of the 
contextual menus:

●     Instantiate component... to instantiate the component and keep its original name

●     Instantiate as new component... to instantiate the component with a default name (for instance, a part originally 
named "ISOScrew.CATPart" will be instantiated with the Part Number "Part1.1" and the document name will be:

❍     the name contained in the "PartName" or "PartNumber" column of the design table (if there is one)

❍     the original part name suffixed by "_New_" + a counter, e.g. "ISOScrew_New_1.CATPart"

●     Copy to copy the component to be instantiated then paste it to the place you will select in the specification tree.



Instantiating a V4 Model Document

1.  Open the product to which you want to instantiate the V4 model document.

2.  In the Catalog browser dialog box, select the document to be instantiated.

3.  Double-click the document or use one of these two contextual menus: Instantiate component...  (to instantiate the 

document with its original name) or Instantiate as new component... (to instantiate the document with a default name).

The Catalog window opens to display the selected element and the V4 model document is instantiated.

Instantiating a PowerCopy

A PowerCopy is a set of features (geometric elements, formulas, constraints and so forth) that are grouped in order to be used in a 
different context, and presenting the ability to be completely redefined when pasted.
This PowerCopy captures the design intent and know-how of the designer thus enabling greater reusability and efficiency. 

For more information on how to instantiate a PowerCopy from a catalog, refer to Instantiating PowerCopies from the Version 5 
Generative Shape Design User's Guide. For general information on PowerCopies, refer to Managing PowerCopies from the Version 5 
Generative Shape Design User's Guide.

Instantiating a Formula, a Check or Rules

Formulas, rules and checks can be stored in a catalog. They can then be reused in a document by using an instantiation mechanism. 

Refer to Instantiating Relations from a Catalog in the Version 5 Knowledge Advisor documentation.

Instantiating a Draw Detail

1.  Open your .CATDrawing document or, if you want to use an empty document, select the Mechanical Design->Drafting 

workbench from the Start menu.

2.  In the Catalog browser dialog box, select the detail you want to instantiate.

3.  Double-click the detail from the catalog then, in the drawing, click the location where you want to position the detail.

Or

 

Drag the detail from the catalog onto the drawing then click to validate the detail location. 



 

 

The detail is instantiated.

For more information on detail instantiation in the Drafting workbench, refer to Reuse a 2D Component from a Catalog 
from the Version 5 Interactive Drafting User's Guide.

For more information on the other uses, refer to the corresponding workbench documentation. 



Reordering Elements in a Catalog

This task shows you how to reorder the elements your catalog is made of, i.e. families, chapters, 
keywords, etc.) in order to classify them the way you want. 

 To do so, three contextual commands are provided: 
●     Reorder sub-chapters... to reorder children (sub-chapters, families or part families)

●     Reorder keywords... to reorder keywords

●     Reorder components... to reorder catalog components (references to external documents, 
features, V4 or V5 documents).

Note that according to the element you activated, some commands may be grayed. For instance, you 
will not be able to select the Reorder sub-chapters... command if you activated a family in the 
specification tree. 

 This scenario takes the Reorder sub-chapters... command as an example but the steps to follow are 
identical when using the other two reorder commands.

1.  In a Version 5 session, open a catalog. In our example, the catalog is named ALL_FASTENERS 

and is provided in the samples folder.

The ALL_FASTENERS chapter, the only chapter contained in the ALL_FASTENERS.catalog 
appears in a catalog navigator window. 

2.  Double-click ALL_Fasteners. The entities contained in the chapter selected then appear in the left-

hand part of the catalog navigator as shown:

 



 

3.  Double-click the element you want to reorder the components, for instance ALL FASTENERS.

4.  Right-click then select xxx object->Reorder sub-chapters... command to reorder the families 

contained in the ALL FASTENERS chapter. The reorder dialog box opens:

 

 

5.  Select the element to move.

6.  Click the up arrow to move the element up in the list or the down arrow to move it down.

7.  Use the  button to sort the list in ascending order.

8.  Use the  button to sort the list in descending order.

9.  Click OK to validate an close the dialog box.

When reordering keywords or components, the display is automatically updated in the corresponding tab 
(i.e. Keywords or Preview).



Copying Catalog Chapters and Keywords

This section explains how to copy catalog chapters as well as keywords from one chapter to another.

Open the catalog from which you want to copy elements. In our example, we have the following structure:

 

Copying keywords

1.  Select the target chapter (i.e. the chapter to which you want to paste keywords).

 
2.  Right-click the source chapter (i.e. the chapter from which you want to copy keywords) then select the Copy 

keywords... contextual command. The Copy keywords dialog box opens:

 



 The source chapter (Chapter 6) and target chapter (ALL FASTENERS) are displayed along with the list of 
keywords you can copy. 

 
3.  Choose the keywords to be copied from the list then click OK to validate.

The All button lets you select the whole list. You can also use multi-selection. 

 The keywords are pasted with their properties to the selected location. 

 

 

Copying chapters

1.  Select the chapter to be copied. In our example, we copy Subchapter2.

 



 

2.  Select the Copy contextual command or the Edit->Copy commands.

3.  Select the chapter under which you want to paste the copied chapter (Chapter.6 in our example).

4.  Select the Paste contextual command or the Edit->Paste commands.

As you can see it in the picture below, the chapter is copied with its keywords (Name, Diameter, Width and 
Height) but not its description: 

 

When copying a chapter, you cannot copy its description unless the copied chapter contains a subchapter.



Resolving Part Families and Part Family Components
  

In this task you will learn how to resolve a part family or a part family component.  

Resolving a part family or a part family component means that you generate the .CATPart document(s) referred to by the part 
family or the part family component.

You can open one of the default catalogs provided with the Catalog Editor. In our example, we are working with the EN_nuts 
chapter which contains a design table. This catalog can be accessed the following way: 

●     on Windows
$CATStartupPath\components\MechanicalStandardParts\EN_Standards\EN.catalog

●     on UNIX
$CATStartupPath/components/MechanicalStandardParts/EN_Standards/EN.catalog

 
Resolving a part family

1.  In the specification tree, select the part family to be resolved.

2.  Right-click then choose xxx object->Resolve from the contextual menu:

 

 

 
The status indicated in the Type column under the Reference tab changes to "Resolved part family configuration"... 

 



 

 
... and the corresponding reference documents are generated in the folder you specified... 

 

 



 By default, the name of each generated document corresponds to the part name (if there is one in the design table) or to the 
part number contained in the "PartName" or "PartNumber" column of the design table. 

 

After resolution, each catalog description points to the corresponding resolved part (this link may also be displayed with the Edit-
>Links... command) and thus, whenever a reference part is modified, you just have to use the Synchronize option from the 
Links dialog box to update your catalog.

Note: the resolved parts never contain the design table since it is removed during resolution.

You can also create a resolved part family in batch mode. For more information, refer to Creating a Catalog with a Part Family in 
Batch Mode.

 
Resolving a part family component

 If you want to resolve each part family component individually, follow the steps below:

1.  Access the Preview tab.

 
2.  Select the component to be resolved.

 3.  Right-click then select xxx object -> Resolve from the contextual menu:

 

 

 
 ...in the catalog settings, in the Tools->Options->Infrastructure->Catalog Editor->Catalogs tab as shown below: 

 



 The status displayed in the Type column under the Reference tab changes to "Resolved part family configuration":

 

 

The .CATPart document containing the resolved component is generated in the storage folder defined under the 

Catalogs tab mentioned above: the path of this folder is displayed in the Object Name column.

By default, the name of the generated document corresponds to the part name (if there is one in the design table) or 

to the part number contained in the "PartName" or "PartNumber" column of the design table. 

Note: the resolved part never contains the design table since it is removed during resolution.



Creating Components from Catalog Filters

This task explains how to create a resolved query in the Catalog Editor workbench. This functionnality aims at 
storing in a permanent way a filtered view of a catalog. 

During resolution, a local copy (i.e. a "sub-catalog") containing any description matching the query is 
generated. Each catalog description points to the corresponding resolved part (this link may also be displayed 
with the Edit->Links... command) and thus, whenever a reference part is modified, you just have to use the 
Synchronize option from the Links dialog box to update the sub-catalog.

 
1.  Select the File->New...->CatalogDocument command.

 

2.  Create the part family that will contain the resolved components by clicking the Add Part Family 

icon. 

Then, choose a name as well as the document that will be referenced to by the part family. For more 

information, refer to Adding a Part Family in this guide.

 

3.  Activate the part family by double-clicking its name or icon. The entities contained in the selected 

family appear in the form of a table on the right-hand side of the navigator and the Data toolbar icon 

are activated:



4.  Click the Add Catalog Resolved Filter Components  icon to open the Resolved Filter 

Definition dialog box:

 

5.  Indicate the catalog to be queried either by entering the corresponding path in the Resolve chapter 

field or by clicking the Browse... button. This button opens the File Selection dialog box which lets 

you browse your folders to the desired location.

 6.  Click the search  icon to open the Filter dialog box and define your filter criteria:



 

 

7.  Click Apply then OK to validate. 

The query is displayed under the Generative Data tab and can now be resolved. 

 
8.  In the Generative Data tab, double-click the query to be resolved to re-open the Resolved Filter 

definition dialog box. 

 

9.  Click the Resolve Query button that is now displayed.

Once the query is resolved, the Resolved Filter Definition dialog box re-opens and the 
corresponding components are displayed under the Generated Components section:

 

 
The file name of the resolved part (if there is one in the design table) is indicated in the PartName 
or PartNumber column.

When several criteria are entered in the Filter dialog box, the default operator used for the query is 
AND. However, you can change it to OR if necessary once the query syntax is displayed in the 
Filter field.

 

 
Note: no design table is contained in the resolved part since it is always removed during 
resolution. 



 

 

 
10.  If needed, modify your query before resolving it one more time or click Cancel to close the Resolved 

Filter Definition dialog box.

 
Note: no design table is contained in the resolved part since it is always removed during 
resolution. 



Querying a Catalog
Making a Standard Query

Making a Smart Query

 



Making a Standard Query in a Catalog

This task explains how to make a standard query in a catalog. 

If a chapter contains a large number of entities, one of the most effective ways of finding the entities you need is to 
narrow the selection criteria by means of the keywords you initially used to create the catalog.

Note that the search is case sensitive and thus, the string to be searched must be entered accordingly in the search field.

Have the ALL_FASTENERS.catalog open.

 
1.  Double-click on a family name or icon, SCREWS for example. The entities contained in the selected family appear 

in the form of a table on the right-hand side of the navigator:

 

 For any description contained in the selected family the query functionality evaluates the logical expression you 
enter and then displays the entities complying with the criteria you used. 

 In the expression, "x." must precede each chapter keyword name.

Here are some examples to be entered in the Filter: field below the Standard tab in the top-right of the 
navigator window.



 
2.  Let's take a simple expression first. Enter:

x.DIAMETER==4mm

(for numerical values)

The result is as follows: 

 

 or enter:

x.TYPE=="FHC"

(for the comparison of character strings) 

The result is as follows:

 



 or 

x.DIAMETER >=x.LENGTH

(for the comparison of values between different keywords) 

The result is as follows:

 

 For more information about this type of expression see the list of comparison operators in "Constants, Units and 
Operators" in the Version 5 - Knowledge Advisor Programming Guide. 

 
3.  Now let's take an example showing simple expressions connected by logical operators. 

Enter:

(x.DIAMETER<=4)AND(x.TYPE=="FHC")

(for the comparison of numerical values and character strings) 

The result is as follows:

 



 For more information about this type of expression see the list of logical operators in "Constants, Units and 
Operators" in the Version 5 - Knowledge Advisor Programming Guide. 

Here are some examples showing more complex expressions: 

 
4.  Enter an expression comprising arithmetic operators such as:

(x.DIAMETER + x.LENGTH)>=10mm

The result is as follows:

 



 For more information about this type of expression see the list of arithmetic operators in "Constants, Units and 
Operators" in the Version 5 - Knowledge Advisor Programming Guide.

 
5.  Enter an expression comprising arithmetic operators such as:

min (x.DIAMETER, x.LENGTH)>=6mm 

This particular formula is not applicable to our example but if you want to get more information about this type of 
expression, see the list of arithmetical operators in "Mathematical Functions" in the Version 5 - Knowledge Advisor 
Programming Guide. 

6.  Enter an expression comprising arithmetic operators such as:

x.DESIGNATION.Search ("FHC")>=0mm

The result is as follows: 

  

 

 

 

 For more information about this type of expression see the list of arithmetical operators in "String Functions" in the 
Version 5 - Knowledge Advisor Programming Guide.

If a keyword includes characters other than upper or lowercase alphabet characters and numbers from 0 
through 9, the name must begin and end with double quotes. 



7.  If at any time you wish to redisplay the query history, just click the descending arrow.

8.  When you have identified the entity you require you can:

●     either edit it by selecting the line where it appears and clicking the Open button

●     or copy it into an appropriate document (see "Inserting CATPart or CATProduct Documents from a Catalog" 
in the Version 5 - Assembly Design User's Guide).

Note that you can also make smart queries using the Catalog Editor or the Catalog Browser. Refer to Making a Smart 
Query in a Catalog for detailed information.



Making a Smart Query in a Catalog

This task explains how to make a smart query in a catalog using either the Catalog Editor or the Catalog Browser. 

If a chapter contains a large number of entities one of the most effective ways of finding the entities you need is to 
narrow the selection criteria by means of the keywords you initially used to create the catalog.

Querying with the Catalog Editor

1.  Open one of the default catalogs provided with the Catalog Editor, ISO for instance. By default, it is located

●     on Windows:
$CATStartupPath\components\MechanicalStandardParts\ISO_Standards\ISO.catalog

●     on UNIX: 
$CATStartupPath/components/MechanicalStandardParts/ISO_Standards/ISO.catalog

2.  Double-click the catalog entity you wish to query.

3.  Click the  button to open the Filter dialog box:



4.  Select the operators from the pulldown lists for the selected parameters along with the corresponding values 

or strings.

5.  Select Apply then OK to run the query.

The query syntax is displayed in the Filter field of the Catalog Editor and the result is as follows:

When you enter several criteria, the default operator is "AND" (as shown in the above screen grab) but 
you can change it to "OR" in the Filter field.



The  button lets you reset the currently displayed query but the query history is still accessible via 
the pulldown list.

Querying with the Catalog Browser

The Catalog Browser is available from the Catalog Editor and from several workbenches such as Assembly Design, 
Part Design, Generative Shape Design or Drafting.

You can perform two types of queries: on one level only (i.e. you query the chapter or the family you are in) or on 
multiple levels.

Querying on one level

1.  Click the  icon, if available, or select the Tools->Catalog Browser command to open the Catalog 

Browser. Note that the command name may vary according to the workbench you are working in.

2.  Click the Browse another catalog icon  to navigate to the catalog to be queried. In our example, we 

will use Catalog1.catalog provided in the samples folder:



3.  Double-click SubChapter.1 then double-click SCREWS. 

You can click the Table>> button to display the keywords defined for the components along with the 

corresponding values:

4.  Click the search  icon. The Filter dialog box opens and displays the keywords that have been defined for 

the SCREWS family:



The Filter dialog box facilitates the query creation since you just have to choose your operator from the 
displayed pulldown lists then enter the corresponding values/strings as shown below in our example:

5.  Under the Basic tab, select the following values:

This query will search for any component with a Length lower than 0.1 and with a Diameter greater than 
0.01.

6.  Click Apply then OK to run the search.

As you can see, the query syntax is displayed in the Filter field of the Catalog Browser and the search 
result is as follows:



7.  Click the Close button to exit the Catalog Browser.

 
Querying on multiple levels

1.  Click the  icon, if available, or select the Tools->Catalog Browser command to open the Catalog 

Browser. 

 

Note that:

●     the command name may vary according to the workbench you are working in

●     the browser must be accessed from a workbench (such as Assembly Design) and not from the Catalog 
Editor.

 
2.  Click the Browse another catalog icon  to navigate to the catalog to be queried. In our example, we 

will use Catalog1.catalog provided in the samples folder:



 

 3.  Double-click SubChapter.1 then click the Table>> button:

 



 4.  Click the search  icon:

 

 
As you can see it above, the regular query mode displays only the keywords defined at the subchapter 
level.

 5.  Click Cancel to close the Filter dialog box.

 6.  Click the Enable multi-level query  icon then the search  icon:

 

 

All the keywords that have been defined for the families contained in SubChapter.1 are retrieved and you 
can then perform your query on any family contained in SubChapter.1 without having to access each 
family specifically.

 7.  Under the Basic tab, select the following values:



 

 
In our example, we will search for any component with a Length greater than 0.1.

 8.  Click Apply then OK to run the search.

 

 

Note that if no query is displayed in the Filter field, a message appears to ask you if you want to retrieve 
all the descriptions contained in the current chapter and its sub-chapters. If you click Yes, all the 
descriptions will be displayed.

 9.  Click the Close button to exit the Catalog Browser.



Creating a Customized Toolbar Containing a Catalog
 

This task describes how to create a toolbar containing a catalog storing a rulebase. This scenario is made up of the 
following steps: 

●     you create the catalog containing the rulebase

●     you publish the catalog

●     you create the toolbar

●     you use the new toolbar to instantiate the rulebase

To know more about rulebases, see the Knowledge Expert User's Guide.

Note that you may store the following features in a catalog and associate them to a toolbar:

●     User Defined Features

●     PowerCopies

●     Document Templates

●     RuleBases

Note that the new toolbar will be available only in the workbench opened when it was created.

Prior to carrying out this scenario, make sure that the Relations option is checked (Tools->Options-
>Infrastructure->Part Infrastructure->Display tab)

 
1.  Open the KwrCatalog.CATPart file. The following image displays.

2.  Create a catalog containing the rulebase contained in the file. To do so, proceed as follows:

●     From the Start menu, select the Infrastructure->Catalog Editor workbench. The Catalog Editor 

http://canly1dsy/ajtCXR14/Doc/online/cceug_C2/samples/KwrCatalog.CATPart


opens.

●     Double-click Chapter.1 and click the Add Family icon. Enter the name of the family and click OK.

●     Double-click the family and click the Add Component icon.

●     Select the Select external feature button, select the rulebase stored in the KwrCatalog.CATPart file and 

click OK.

3.  In the Catalog Editor, right-click the RuleBase and select the Publish Catalog Object ... command. The 

Publishing Catalog Alias dialog box opens. 

4.  Enter the alias, RuleBase in this scenario, and click OK.  

5.  Save the catalog and close it. Open the KwrCatalogImport.CATPart file. 

6.  Select the Tools->Customize... command. The Customize window opens.

7.  Click the Commands tab. Select Catalogs in the Categories field: RuleBase is displayed in the right-hand 

pane.

8.  Click the Show properties button to add a new icon to the toolbar or to add accelerators.

9.  Drag and drop RuleBase to the toolbar. Close the customize window.

10.  Double-click the icon you associated to the toolbar. The RuleBase Catalog dialog box displays.

11.  Click the Import option: the rulebase contained in the catalog is imported into your file.

 

http://canly1dsy/ajtCXR14/Doc/online/cceug_C2/samples/KwrCatalogImport.CATPart


Component Catalog Editor Interoperability

In this section, you will find information about interoperability between CATIA Component Catalog Editor and 

other applications listed below:

ENOVIA LCA Interoperability
VPM Navigator Interoperability



ENOVIA LCA Interoperability
Saving a Version 5 Catalog in ENOVIA LCA



Saving a CATIA V5 Catalog in ENOVIA LCA 

Catalogs enable to store and classify objects, each with its own specific characteristics (such as shape, color, size, diameter, length, 
standard, etc.) so that they can be retrieved fast and easily.

This task explains how to save in ENOVIA LCA a CATIA V5 catalog containing a part family with a design table.

For this scenario, it is recommended to resolve all the part family components (i.e. generate the .CATPart document(s) referred to by 
the part family or the part family component).

 
For detailed information on managing catalogs in ENOVIA LCA, please refer to the ENOVIA LCA LifeCycle Applications documentation - 
Catalog Management.

1.  In CATIA V5, select Start -> Infrastructure -> Catalog Editor.

 
2.  Open a catalog by selecting File -> Open... from the menu bar. 

 
3.  Right-click one of the catalog components and select Definition... then, click the Preview tab to check that the component 

preview is stored in the catalog.

If the preview is not stored in your catalog, it will be lost when editing in CATIA V5 the catalog saved in ENOVIA LCA.

 



 The next step is to save your catalog in ENOVIA LCA.

 

4.  Click the Set PDM Properties  icon from the ENOVIA LCA toolbar to access the following dialog box:

 

 
5.  Choose "ENOVIA5" in the Destination PDM drop-down list then specify the storage mode:

●     Document kept in vault
❍     Publications Exposed: both Product and Part document files are saved in the vault. The catalog 

structure is not saved in ENOVIA LCA. This mode is also known as the "workpackage" mode. 
When working with part families with design tables, it is recommended to use this mode.
The "Publications Exposed" mode is detailed in the section entitled "Catalog saved in 
workpackage mode (Publications Exposed-Document kept)"

●     Document not kept
❍     Structure Exposed: the catalog structure is saved in ENOVIA LCA but not the catalog document 

(i.e. the .catalog file). CATPart documents pointed to by the catalog are also saved. This mode 
is detailed in the section entitled "Catalog saved in Explode mode (Structure Exposed-
Document not kept)".

Note that you can also click the Save data in ENOVIA LCA Server...  icon from the ENOVIA LCA toolbar:



 

 As you can see it in the above capture, this dialog box lets you save your documents in "Publications Exposed" mode only. 

For detailed information on this dialog box, refer to "Saving an ENOVIA LCA Document from CATIA V5" in the Version 5 - 
ENOVIA/CATIA Interoperability User's Guide.

 Please click the hyperlink corresponding to the storage mode you selected, "Publications Exposed-Document kept" or 
"Structure Exposed-Document not kept" to go on with the scenario.

 
Catalog saved in workpackage mode (Publications Exposed-Document kept)

 
6.  If you have accessed the Set PDM Properties dialog box, check that the "Publications Exposed" option is activated then click 

OK to validate.

If you have accessed the Save in ENOVIA V5 dialog box, you just need to click OK.

A progress bar is displayed to let you follow the save process.

 If two documents with the same name exist, a warning message will appear. In that case, close the warning dialog box 
then click the Save in ENOVIA LCA icon once again: the files will be automatically renamed with the [n] extension (where 
"n" is a number incremented for each document).

 The save result is then displayed under the Reference tab in the Catalog Editor as shown below:

 

 Now, you need to connect to ENOVIA LCA then search for the catalog you saved in the previous steps.



 

7.  In your CATIA V5 session, click the Connect to ENOVIA LCA  icon in the ENOVIALCA toolbar.

A logon window appears: enter the necessary data (user, password, etc.) then click Logon.

 

8.  Once you are connected to ENOVIA LCA, click the  icon.

 
9.  In ENOVIA Home, click Content Management, double-click Document Management then click Cancel in the dialog box 

that opens.

The following window is displayed:

 

 

10.  Click the icon Open  icon (or the Ctrl + O keyboard shortcut).

 
11.  In the Search for: field, select "Document File" then in the Extension column, enter "Catalog".



 

 
12.  Click the Search button to run the query.

The result of your query will be displayed in the bottom part of the search dialog box:

 

 
13.  Select the catalog in the list of result then click Add.

A node named "CatalogDocument" is added to "Documents" in the Web Tree:

 



 
14.  Right-clicking "CatalogDocument" lets you carry out the following operations: 

 
●     Send To->CATIA V5 Catalog Browser: this command enables you to browse your catalog using the catalog browser. 

Note: before sending your catalog to the Catalog Browser, check that a product is open in your CATIA V5 session, 
otherwise the catalog will open in the Catalog Editor.

 For detailed information on the Catalog Browser, refer to "Browsing a Catalog Using the Catalog Browser" in the CATIA 
Version 5 - Component Catalog Editor User's Guide.

 



 
●     Show->Iterations: lets you follow the life cycle of your catalog document. Selecting an iteration from the list lets you 

know what kind of action has been performed on your catalog, each action corresponding to one iteration. 

In the example below, the catalog document has three iterations:

 



 The following three iterations reflect the three actions that have been performed on the catalog:
- first, one chapter of the catalog has been modified 
- the second iteration corresponds to the update of the documents pointed to by the catalog
- the third iteration corresponds to the design modification of a catalog component.

Among your list of iterations, you can set one of them as "preferred" (i.e. "active") by selecting it from the list 
then choosing the "Set Preferred" command. In our example, Iteration.3 is the preferred one (identified by a 
different symbol in the tree).
By default, the active iteration is the most recent one.

 
●     Send To->CATIA V5 Catalog Editor: this command lets you send your catalog to CATIA V5 in order to modify it.

For instance, let's suppose you want to update a part family with a design table (still in workpackage mode, of 
course):

1.  once your catalog has been sent to CATIA V5, select the Edit->Links... command
2.  select the referenced part to be to modified then click the Open button
3.  perform the necessary modifications on the part or on the design table (in that case, the 

design table must stored in the part)
4.  close the part then go back to the Catalog Editor
5.  re-select the Edit->Links... command
6.  select the modified part then click the Synchronize button to synchronize the link with the 

reference part
7.  click the Save in ENOVIA LCA icon to save the modified catalog document in the ENOVIA LCA 

database: you will see that the Save panel will gray the "Publications Exposed" and the 
"Structure Exposed" modes.
This means that the modified catalog will be saved in the same mode as it was originally saved 
("Publications Exposed" in our example).
Moreover, only the new or updated documents will be displayed in the list of documents to be 
saved. 

8.  click OK to save your catalog document. A new iteration will be created under the 
CatalogDocument node.

 

 
Catalog saved in Explode mode (Structure Exposed-Document not kept)

 Before you begin

 IN CATIA V5
●     the previews of the catalog components must always be stored in the catalog

●     part families with design tables must always be resolved before saving your catalog in Structure Exposed mode.

IN ENOVIA LCA

●     you must lock catalogs and classifications before modifying them in order to prevent other users from working on your data 

simultaneously. To do so, click the Lock/Unlock  icon on the horizontal toolbar. This allows you to:
❍     create sub-classifications

❍     add parameters (such as a keyword)

❍     send your catalog to the CATIA V5 Catalog Editor.

 
6.  After accessing the Set PDM Properties dialog box, choose the Structure Exposed option in the "Document not kept" area: 



 

 
7.  Click OK to validate.

A progress bar is displayed to let you follow the save process.

As explained before, the catalog structure as well the .CATPart documents pointed to by the catalog are saved in ENOVIA 

LCA but not the catalog document (i.e. the .catalog file). 

 

8.  Connect to ENOVIA LCA by clicking the Connect to ENOVIA LCA  icon in the ENOVIA LCA toolbar.

 
9.  In your ENOVIA session, select ENOVIA HOME->Content Management->Document Management. 

 



 As you can see it in the above picture, the catalog document has not been saved and the catalog structure has been placed 
under the node "Catalogs".

 Note: when working with catalogs containing a large amount of components, we recommend that you use one of the two methods 
below. You can either:

●     store in ENOVIA V5 the catalog created in CATIA V5, send it from ENOVIA V5 to CATIA V5 then add new parts (i.e. add the 
missing components that have not been stored in ENOVIA V5) before saving it again in ENOVIA V5. 
You can repeat this process as many times as necessary until your catalog is complete 

or

●     you can also split your catalog in several smaller catalogs.

 



VPM Navigator Interoperability
Saving a CATIA V5 Catalog in ENOVIA LCA Using VPM Navigator

Loading a CATIA V5 Catalog with VPM Navigator



Saving a CATIA V5 Catalog in ENOVIA LCA Using 
VPM Navigator 

This task explains how to save a catalog created with CATIA Version 5 in ENOVIA V5 using VPM Navigator.

Prior to saving your catalog, we recommend that you read the VPM Navigator User's Guide to know more 
about this product.
This documentation can be found on the ENOVIA LifeCycle Applications Documentation CDROM.

1.  In CATIA V5, select Start -> Infrastructure -> Catalog Editor.

 
2.  Open the catalog to be saved by selecting File -> Open... from the menu bar. 

3.  Select Start -> ENOVIA V5 VPM -> VPM Navigator.

4.  Click the Connect  icon in the ENOVIA V5 toolbar. The connection dialog box displays:

 

 
5.  Enter a user name, a password and select the role to be used before clicking OK to validate.



 

6.  Click the Save data in Enovia V5  icon. This opens the Save in ENOVIA V5 dialog box:

 

 If you click the More>> button, the dialog box will look like this:

 

 To see how the checkboxes displayed in this dialog box are used, refer to "Saving Objects" in 
the VPM Navigator User's Guide.

 
7.  If you want to do a quick save, click OK.

 The catalog is saved in the storage mode known as Publications Exposed (Document kept in 
vault), i.e. both Product and Part document files are saved in the vault but the catalog structure 
is not saved in ENOVIA V5.

http://canly1dsy/ajtCXR14/Doc/online/xomugcce_C2/images/dbsave02NLS.gif


Loading a CATIA V5 Catalog with VPM Navigator 

This task explains how to open a catalog created with CATIA Version 5 using VPM Navigator.

Prior to opening your catalog, we recommend that you read the VPM Navigator User's Guide to know more about this 
product.
This documentation can be found on the ENOVIA LifeCycle Applications Documentation CDROM.

1.  Select Start -> ENOVIA V5 VPM -> VPM Navigator.

 

2.  Click the Connect  icon in the ENOVIA V5 toolbar. This opens the connection dialog box:

 

 
3.  Enter a user name, a password and select the role to be used before clicking OK to validate.

 

4.  Click the the Search data in ENOVIA V5  icon in the ENOVIA V5 toolbar or select the ENOVIA Search... 

command in the ENOVIA V5 menu.

This opens the VPM Search dialog box.

 
5.  Select the Advanced Search tab:



 

 
6.  In the Objects field, select "Document Revision" and in the Value field, select "catalog" in order to narrow the 

search to .catalog documents.

For detailed information on the other fields available and on the Easy Search tab, refer to "Performing a 
Search" in the VPM Navigator User's Guide.

 
7.  Click OK to validate the search and close the dialog box or Apply to validate the search and leave the dialog box 

open.

 The search result is displayed in the following window:

 



 Note that clicking the Search conditions... button lets you reopen the VPM Search dialog box.

 
8.  Right-click the catalog to open in the result list then select the Open contextual command. 

This opens the following dialog box:

 

 
9.  Select the application to be used to open your catalog by activating the corresponding radio button: Browser or 

Catalog Editor.

 
If you select "Catalog Editor", you can activate the Automatic Lock of all opened Parts and Documents 

option at the bottom of the dialog box to acquire the object from the ENOVIA database when opening it. 

 
10.  Click OK to validate.

The catalog opens in the selected application.



Workbench Description
The Version 5 Component Catalog Editor workbench lets you create and manage components in catalogs.
Click the hotspots to see the related documentation:

 

The section is organized as follows:

Menu Bar
Chapter Toolbar

Data Toolbar
Browser Toolbar

 



Menu Bar 
 

This section presents the menu bar tools and commands dedicated to the Component Catalog Editor workbench.

Many other operations are documented in the Version 5 Infrastructure User`s Guide.

Start File Edit View Insert Tools Windows Help

 

Start
The Start menu is a navigation tool intended to help you toggle between different workshops. The contents of the Start menu vary according to 
the configurations and/or products installed.

For... See...

Infrastructure->Catalog Editor For more information about the Start menu, refer to 
the Infrastructure documentation.

  

  

  

 

 

File
The File menu lets you perform file creation, opening, saving and printing operations. Refer to the Infrastructure documentation.

 

Edit
The Edit menu lets you manipulate selected objects. Please refer to the Infrastructure documentation.

http://canly1dsy/ajtCXR14/Doc/online/basug_C2/basugbt0302.htm
http://canly1dsy/ajtCXR14/Doc/online/basug_C2/basugwd0100.htm
http://canly1dsy/ajtCXR14/Doc/online/basug_C2/basugwd0100.htm


 

View
The View menu lets you view document contents. Please refer to the Infrastructure documentation.

View - >Toolbars

For... See...

  

  

  

  

Browser Browser Toolbar

Chapter Chapter Toolbar

Data Data Toolbar

Specification 
Catalog  

  

 

Chapter Toolbar

For... See...

Add Chapter Creating a Catalog Using the Catalog Editor

Add link to other catalog Creating a Catalog Using the Catalog Editor

Add Family Creating a Catalog Using the Catalog Editor

Add Part Family Creating a Catalog Using the Catalog Editor

Data Toolbar

For... See...

Add Keyword Creating a Catalog Using the Catalog Editor

Add Component Creating a Catalog Using the Catalog Editor

Add Part Family Components Creating a Catalog Using the Catalog Editor

Add Catalog Resolved Filter Components Creating Components from Catalog Filters

Browser Toolbar

http://canly1dsy/ajtCXR14/Doc/online/basug_C2/basugwd0100.htm


For... See...

Display with the Browser Using the Browser Display

 

Tools
The Tools menu lets you perform image capture and album management, set user preferences and manage macros. lease refer to the 
Infrastructure documentation.

 

Window
The Window menu lets you arrange document windows in relation one to the other. Please refer to the Infrastructure documentation.

 

Help
The Help menu lets you get help on the currently active command and the product in general. Please refer to the Infrastructure documentation.

http://canly1dsy/ajtCXR14/Doc/online/basug_C2/basugwd0100.htm
http://canly1dsy/ajtCXR14/Doc/online/basug_C2/basugwd0100.htm
http://canly1dsy/ajtCXR14/Doc/online/basug_C2/basugwd0100.htm


Chapter Toolbar

See Creating a Catalog Using the Catalog Editor

See Creating a Catalog Using the Catalog Editor

See Creating a Catalog Using the Catalog Editor

See Creating a Catalog Using the Catalog Editor



Data Toolbar

See Creating a Catalog Using the Catalog Editor

See Creating a Catalog Using the Catalog Editor

See Creating a Catalog Using the Catalog Editor

See Creating Components from Catalog Filters



Browser Toolbar

See Using the Browser Display



Customizing Catalog Editor

Before you start your first working session, you can customize the way you work to suit your habits.
This type of customization is stored in permanent setting files: these settings will not be lost if you end 
your session.

1.  Select the Tools -> Options command.

The Options dialog box displays. 

2.  Choose the Infrastructure category in the left-hand box.

3.  Click the Catalog Editor workbench.

The options for Catalog Editor settings appear, organized in tab pages.

4.  Select the tab corresponding to the parameters to be customized:

❍     the Catalogs tab lets you define options for resolved family components and performance.

5.  Change these options according to your needs. 

6.  Click OK when done.

 

    



Catalog Editor
 

 

This tab deals with the options concerning:
●     resolved family components

●     performance

 
Resolved Family Components

 

 

Create new reference for each instantiation

If this option is selected, it means that a component reference will be created from each instantiated 
reference part (just like the New from... command). In other words, each component instantiation will 
result in the generation of a .CATPart document saved in the folder specified in the Folder field above.

By default, this option is activated.

Allow family component dynamic resolution in catalog

If this option is selected, it means that catalog components will be dynamically resolved when intantiating 

them.

Selecting this option activates the Folder field which lets you enter the path to the folder in which you will 

store your resolved parts along with their configurations. This avoids recalculating the part resolution 

whenever you wish to use a part in a configuration.

To specify a folder, you can also click the icon to the right to open the Folder Chooser dialog box which lets 

you browse your folders to the desired location.

 By default, this option is cleared.



Instantiate only resolved family components

If this option is selected, it means that you can instantiate only resolved and stored components. 
Otherwise, an error message appears to warn you that the component cannot be resolved.

Selecting this option activates the Folder field which lets you enter the path to the folder in which you will 
store your resolved parts along with their configurations.

 By default, this option is cleared.

 
Performance

 

 

If this option is selected, it means that if the preview of a catalog component is not stored in the catalog, 
this preview will not be displayed (either in the Catalog Browser or in the Preview tab). Therefore, this will 
improve performance.

Checking this option also means that pointed catalogs will not be loaded and that the links to these 
catalogs will not be checked. As a consequence, you will not be aware of broken links, if any.

However, note that you can still display the preview of a pointed element by double-clicking it in the list.

 By default, this option is cleared.

 



Glossary 

             

 

C
 

catalog A catalog is a way of storing and classifying objects, each with its own specific 
characteristics (such as shape, color, size, diameter, length, standard, etc.) so that they 
can be retrieved fast and easily.

chapter A chapter references other chapters or families. It is a way of classifying the elements it 
refers to

component A reference to an external document or an entity such as a feature (e.g. PowerCopy), V4 
documents (e.g. models) or V5 documents (e.g. CATPart, CATProduct, etc.) described with 
keyword values

   

D
 

design table A feature created in Version 5 either from the current parameter values of your document 
or from external data. This feature facilitates the definition and management of mechanical 
parts by enabling you to regroup in the form of a table, in a .xls or .txt file, the various 
sets of parameter values that can be assigned to a part. Each set of parameter values is 
called a configuration.

document A common unit of data (typically a file) used in user tasks and exchanged between users. 
When saved on disk, a document is given a unique filename by which it can be retrieved.

   



F
 

family A set of components.

   

G
 

geometry area Area of a document window in which application data are displayed and edited.

   

I
 

icon A pictorial representation of an object.

interoperability
●     Ability to exchange data between CATIA Version 4 and Version 5

●     Ability to exchange Version 5 data between Version 5 workshops 

●     Ability to exchange data between Version 5 and OLE-compliant applications

●     Ability to exchange data between Version 5 and ENOVIA LCA.

   

K
 

keyword An attribute describing the chapter and family content. Each component may be assigned 
its own attribute value. You can associate keywords to chapters and families and thus, 
perform searches by attribute value to filter their content.

   



M
 

model CATIA Version 4 model.

O
 

object An entity or component identifiable by a user that can be distinguished by its properties, 
operations, and relationships.

   

P
 

part A 3D entity obtained by combining different features.

part family A set of components referring to a .CATPart document. This part is unique but has been 
assigned different sets of parameter values, each of them being managed by a design 
table..

product A 3D entity containing several components.

   

R
 

resolve To generate the .CATPart document(s) referred to by a part family or a part family 
component.

   



S
 

specification tree Area of the document window reserved for viewing the design specifications of a part, 
presented in the form of a tree structure.

   

W
 

workbench Set of tools for completing specific tasks. Each type of document can be edited with a 
document-specific set of tools.



Index 

                   

A
Add Catalog Resolved Filter Components command  

Add Chapter command  

Add Component command  

Add Family command  

Add Keyword command  

Add link to another catalog command  

Add Part Family command   

Add Part Family Components command  

B
Browse another catalog command  

Browser command  

Browser toolbar  
browsing 

using the Catalog Editor  

C
catalog 

browsing (Catalog Browser)  
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