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Overview 
Welcome to the Assembly Design User's Guide!
This guide is intended for users who need to become quickly familiar with the product. 

This overview provides the following information:

●     Assembly Design in a Nutshell

●     Before Reading this Guide

●     Getting the Most Out of this Guide

●     Accessing Sample Documents

●     Conventions Used in this Guide 

Assembly Design in a Nutshell

Assembly Design allows the design of assemblies with an intuitive and flexible user interface.

As a scalable workbench, Assembly Design can be cooperatively used with other current companion products 
such as Part Design and Generative Drafting.
The widest application portfolio in the industry is also accessible through interoperability with Solutions 
Version 4 to enable support of the full product development process from initial concept to product in 
operation.
Digital Mock-Up (DMU) Navigator inspection capabilities can also be used to review and check your 
assemblies. Interactive, variable-speed techniques such as walk-through and fly as well as other viewing 
tools let you visually navigate through large assemblies.

The Assembly Design User's Guide has been designed to show you how to create an assembly starting from 
scratch. This book aims at illustrating the several stages of creation you may encounter.

Before Reading this Guide

Before reading this guide, you should be familiar with basic Version 5 concepts such as document windows, 
standard and view toolbars. Therefore, we recommend that you read the Infrastructure User's Guide that 
describes generic capabilities common to all Version 5 products. It also describes the general layout of V5 and 
the interoperability between workbenches.

You may also like to read the following complementary product guides, for which the appropriate license is 
required:

●     Product Structure

●     Part Design



●     Generative Drafting

●     V4 Integration

Getting the Most Out of this Guide

To get the most out of this guide, we suggest that you start reading and performing the step-by-step Getting 
Started tutorial.

Once you have finished, you should move on to the User Tasks section, which deals with handling all the 
product functions.

The Workbench Description section, which describes the Assembly Design workbench, and the Customizing 
section, which explains how to set up the options, will also certainly prove useful.

Navigating in the Split View mode is recommended. This mode offers a framed layout allowing direct access 
from the table of contents to the information.

Accessing Sample Documents

To perform the scenarios, sample documents are provided all along this documentation. For more information 
about this, refer to Accessing Sample Documents in the Infrastructure User's Guide.



Conventions
Certain conventions are used in CATIA, ENOVIA & DELMIA documentation to help you recognize and 
understand important concepts and specifications. 

Graphic Conventions

The three categories of graphic conventions used are as follows:

●     Graphic conventions structuring the tasks

●     Graphic conventions indicating the configuration required

●     Graphic conventions used in the table of contents

Graphic Conventions Structuring the Tasks

Graphic conventions structuring the tasks are denoted as follows:

This icon... Identifies...

estimated time to accomplish a task

a target of a task

the prerequisites

the start of the scenario

a tip

a warning

information

basic concepts

methodology

reference information

information regarding settings, customization, etc.

the end of a task



functionalities that are new or enhanced with this release

allows you to switch back to the full-window viewing mode

Graphic Conventions Indicating the Configuration Required 

Graphic conventions indicating the configuration required are denoted as follows:

This icon... Indicates functions that are... 

specific to the P1 configuration

specific to the P2 configuration

specific to the P3 configuration

Graphic Conventions Used in the Table of Contents

Graphic conventions used in the table of contents are denoted as follows:

This icon... Gives access to...

Site Map

Split View mode

What's New?

Overview

Getting Started

Basic Tasks

User Tasks or the Advanced Tasks

Workbench Description

Customizing

Reference

Methodology

Glossary

Index



Text Conventions

The following text conventions are used:

●     The titles of CATIA, ENOVIA and DELMIA documents appear in this manner throughout the text.

●     File -> New identifies the commands to be used.

●     Enhancements are identified by a blue-colored background on the text.

How to Use the Mouse

The use of the mouse differs according to the type of action you need to perform.

Use this
mouse button... Whenever you read...

 
●     Select (menus, commands, geometry in graphics area, ...)

●     Click (icons, dialog box buttons, tabs, selection of a location in the document 
window, ...)

●     Double-click

●     Shift-click

●     Ctrl-click

●     Check (check boxes)

●     Drag

●     Drag and drop (icons onto objects, objects onto objects)

●     Drag

●     Move

●     Right-click (to select contextual menu)



What's New?

New Functionalities

Selecting Using a Filter
This new filter allows you to refine the feature/geometrical element you want to select in a constraint 
definition. Geometrical elements available are: point, line or curve, plane or surface, as feature or as 
geometrical element.

Refreshing Constraints
This new contextual command allows you to refresh the status for constraints based on published 
elements in a missing component. The status for these constraints is re-evaluated when you insert a 
component only, according to its published elements.

Enhanced Functionalities

Data Upgrade for Large Assemblies Performances
This utility is also now available through an user interface. The same functionalities as the batch 
command are offered. The user interface is available from the Tools -> Utilities menu item, 
CATAsmUpgadeBatch utility.

Displaying the Assembly Mass Properties
The mass property of any assembly component is available from its Product Properties, in the 
Mechanical tab. The mass property is now also available in Visualization mode and you can refine the 
mass to the main body or all the bodies of a Part component. The mass property is set according to 
the part material. If any material has been defined, a density of 1 is taken into account. 

Customizing Settings

Cgr Management for 3D Annotation
A new option allows you to take into account 3D Annotations in cgr documents. 3D Annotations are 
now displayed in Visualization mode.



Getting Started

 If in Sketcher and Part Design you generated parts, now will learn how to finish  your design by 
assembling parts in Assembly Design workbench.
Before  we discuss the detailed instructions for using the Assembly workbench, the following 
scenario aims at giving you a feel for what you can do with an Assembly document. You just need 
to follow the instructions as you progress.

 The Getting Started section is composed of the following tasks:

 Entering Assembly Design Workbench and Opening a CATProduct Document
Fixing a Component
Inserting an Existing Component
Setting Constraints Between Components
Moving Constrained Components Using the Compass
Adding and Renaming a New Component
Designing a Part in an Assembly Context
Editing a Parameter
Replacing a Component
Analyzing Assembly Constraints
Reconnecting a Broken Constraint
Detecting Clashes
Editing a Component
Displaying the Bill of Material
Exploding the Assembly

This scenario should take about 15 minutes to complete.

Eventually, the assembly will look like this:



Entering Assembly Design Workbench and Opening a 
CATProduct Document

This first task shows you how to enter Assembly Design workbench and how to open an existing product.

1.  Select the Start -> Mechanical Design -> Assembly Design command to launch the required workbench. 

 The workbench is opened. The commands for assembling parts are available in the toolbar to the right of the application 
window. For information on these commands, please refer to  Product Structure documentation.
You will notice that Product1 is displayed in the specification tree, indicating the building block of the assembly to be created.

To know how to use the commands available in the Standard and View toolbars located in the application window border, 
please refer to Infrastructure documentation.

 

 
2.  Before following the scenario, set the following options:



 
●     make sure the option Work with the cache system is deactivated : use the Tools -> Options command, click 

Infrastructure -> Product Structure to the left of the dialog box that appears and uncheck the option Work with the 
cache system. Do not forget to restart the application after turning off the cache.
For more information, refer to Working with a Cache System.

●     use the Tools -> Options command, click Infrastructure -> Product Structure to the left of the dialog box that 
appears, then click the Product Structure tab and uncheck the option Manual Input.
For more information, refer to Customizing Product Structure Settings.

●     use the Tools -> Options command, click Infrastructure ->Part Infrastructure to the left of the dialog box that 
appears, then check the option Keep link with selected Object.
For more information, refer to Customizing General Settings.

 Note also that the default mode for the Update capability is "manual". For the purposes of this scenario, set the automatic 
mode.

 
3.  Open the Assembly_01.CATProduct document.

 You will start the scenario with an existing assembly. Product1 is composed of three parts created in the Part Design 
Workbench:

●     CRIC_FRAME (in turquoise)

●     CRIC_BRANCH_3 (in blue)

●     CRIC_BRANCH_1 (in red)

From now on, these parts will be referred to as components

 

 

 Surface and Coincidence constraints have been defined for these parts in the Assembly workbench.

 
4.  Select Edit  -> Representations -> Design Mode. This mode lets you access technical data. 

 
5.  Click the + sign to the left of the Constraints text  in the tree and apply the show mode on these constraints if you wish to 

view them in the geometry area.

http://canezou/AwsDocV5R14/Doc/online/bascupst_C2/bascupst0100.htm
http://canezou/AwsDocV5R14/Doc/online/bascupst_C2/bascupst0400.htm
http://canezou/AwsDocV5R14/Doc/online/bascuprt_C2/bascuprt0200.htm
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/Assembly/Assembly_01.CATProduct


Fixing a Component

 

This task shows you how to set the first constraint. This operation consists in fixing the position of a 
component in space so as to use this component as the base of the assembly.

1. Select CRIC_FRAME in the specification tree or in the geometry area.

2. 
Click the Fix Component  icon in the Constraints toolbar.

The  component CRIC_FRAME is immediately fixed. The application indicates this by displaying a 
green anchor symbol on the component. 

Note also that the Constraints branch now displays the new constraint. The anchor symbol is 
preceded by a lock symbol, to make a distinction between "fix in space" and "fix operations". For 
more information, pleaser refer to Fixing a Component.



 

 



Inserting an Existing Component

 

This task shows you how to insert an existing component into the assembly.

 

1.  Select Product1 in the specification tree.

2. 
Click the Existing Component  icon  in the Product Structure Tools toolbar.

The File Selection dialog box is displayed.
3. Select Sub_Product1.CATProduct  from the sample directory.

4. Click Open. 

A new component is added to the specification tree. The assembly now includes four components: 
three parts and a sub-assembly.

This is the component you have just imported:



 

To know the different document types you can insert in a CATProduct document, refer to Product 
Structure documentation However, to know how to insert .asm documents properly, refer to 
Opening a .asm Document.

http://canezou/AwsDocV5R14/Doc/online/asmug_C2/asmugbt0200.htm


Setting Constraints Between Components

This task consists in setting a coincidence constraint, then a contact constraint between the 
component you have just inserted (Sub_Product1) and CRIC_BRANCH_1.

1.  Click the Coincidence icon: 

 A message window appears, providing information on the coincidence constraint command. 
If you do not want to see this dialog box appear any more, check Do not prompt in the 
future.

 
2.  Select Axis publication in the specification tree. 

 

 The application detects it once selected. The axis is now highlighted in the geometry.

 

 
3.  Select one of the two inner faces of CRIC_BRANCH_1 to select the associated axis.



 

 As the coincidence constraint is created, CRIC_SCREW and CRIC_BRANCH_1 are aligned:

 

 Now, you are going to set a contact constraint between CRIC_SCREW and a circular face of 
CRIC_BRANCH_1.

 

4.  Click the Contact Constraint icon: 

 
5.  Select Face publication in the specification tree. 



 

 

 
6.  Select the red circular face in the direction opposite to the published face.

 

 As the contact constraint is created, the turquoise cylinder is located exactly on the red 
face.



 

The created  constraints are automatically updated because the automatic update mode is 
activated. As the color defining valid constraints is green, our constraints are green. The 
application allows you to customize constraint colors as explained in Customizing Constraint 
Appearance.

 The assembly now looks like this:

 



Moving Constrained Components Using the 
Compass 

 

This task consists in manipulating the assembly to check if the components react the way we want, i.e. 
according to the constraints we set in the previous task.

 

1. Select the red patch at the center of the compass and drag it onto CRIC_SCREW. For details 
about how to use the compass, please refer to Infrastructure User's Guide.

As the compass is snapped to the component, you can manipulate the component.

2. Now, if you press and hold down the Shift key, select v/z axis on the compass, then drag and drop 
the component up and down, you can see that three components are moving.

This is an example of what we can get:



3. Repeat the operation as many times as you wish.

The assembly reacts correctly. CRIC_FRAME does not move because it is fixed. The other three 
components can move.

4.  Release the left mouse button before releasing the Shift key.

5. Drag the compass away from the selected object and drop it.

 

  

  



Adding and Renaming a New Component

 

This task consists in adding a new component to the assembly. You will then rename this component. 
This component is a part created in the Part Design workbench.

 

1. 
Click Product1 and select the Part  icon in the Product Structure Tools toolbar.

The New Part: Origin Point dialog box appears, presenting two possible options: Either you define 
the point of your choice to locate the new part, or you use the origin point of the assembly as the 
origin point to be used for the part.

2. Click No to use the origin point of the assembly.

The new component "Part5 (Part5.1)" is now displayed in the specification tree:



If the Manual Input option is activated (see Customizing Product Structure Settings), the Part 
Number dialog box appears before the New Part: Origin Point dialog box and lets you enter the 
name of your choice.

3. Right-click Part5 (Part5.1) and select the Properties... contextual command.

4.  In the Properties dialog box that appears.

The options available in the Product tab let you enter the information you required.

http://canezou/AwsDocV5R14/Doc/online/bascupst_C2/bascupst0400.htm


5. Enter CRIC_JOIN.1 in the Instance name field and CRIC_JOIN in the Part Number field.

6.  Click OK to validate the operation.

The new names are now displayed in 
the specification tree:

 

  

  



Designing a Part in an Assembly Context

 

This task consists in designing the part you have just added to the assembly. It shows you how easy it 
is to access the tools required for designing components in an assembly context.

 

1. Double-click CRIC_JOIN in the specification tree to access the Part Design workbench.

2. Select the blue face as shown and click the 

Sketcher icon  to access the Sketcher 
workbench.

3. Now that you are in the Sketcher, click the 

Normal View  icon in the View toolbar 
and sketch a circle on the face using the 

Circle command .

Do not bother about positioning the circle.



4. Now to obtain the same radius value as the one used for CRIC_JOIN circular edge and to make 
sure that this circular edge and the circle share the same axis, use the Constraints Defined in 

Dialog Box command  to create a coincidence constraint (select the circle -if not already 
done- and the circular edge, then click the Constraint Defined in Dialog Box command and 
check "Coincidence").

After validating the operation, the circle is 
coincident with the circular edge. You must 
obtain this:

5. 
Exit the Sketcher and use the Pad command  with the "Up to Plane" option to extrude the 
sketched circle. Select the blue face as shown to specify the limit of the pad.



After validating the operation, you should obtain this cylinder:

The part is designed.

For information about Part Design and designing in context, refer to Part Design User's Guide 
and Designing in Assembly Context respectively.



Editing a Parameter

 

In this task, you are going to edit the diameter of the pocket belonging to CRIC_BRANCH_3. You will see 
how this edition affects the part you created in the previous task.

 

1.  

2. 

Double-click CRIC_BRANCH_3 to access the Part Design workbench. 

Select Pocket.2 and use the Pocket.2 object -> Edit Parameters contextual command to display the 
associated parameters.

 

3. Double-click D11 in the geometry area to display the Constraint Edition dialog box.

4. Enter 20 as the new diameter value and click OK to generate the new pocket.

5. Update Product1 by double-clicking on Product1 in the specification tree.



The pocket is modified accordingly. The coincidence previously set between the two parts is 
maintained. 

This result is made possible thanks to the option Keep link with selected Object you set at the very 
beginning of the scenario.

 

 

  

 



Replacing a Component

 

This task shows you how to replace Sub_Product1.CATProduct by another component.

 

1. Select Sub_Product1.CATProduct in the specification tree.

2. 
Click the Replace Component icon  in the Product Structure Tools toolbar.

3. In the dialog box that appears, select Sub_Product2.CATProduct as the replacement component 
and click Open. 

The Impacts on Replace dialog box is displayed:

4. Check Yes to replace all instances of the selected element and click OK to confirm.

Sub_Product1.CATProduct is no longer visible. This is Sub_Product2.CATProduct:



If necessary update the document. 

Note that the coincidence constraint is maintained. This is due to the publication of the axis used in 
the constraint definition. As the axis is a published element, the application can reconnect the 
constraint.

Conversely, the contact constraint is broken. You will know how to reconnect it later.

 

  

 



Analyzing Assembly Constraints

 

This task shows you how to analyze the status of all assembly constraints defined for Product1.

 

1.  Select the Analyze -> Constraints... command.

The Constraints Analysis dialog box that appears displays all the information you need. The 
Constraints tab contains a detailed status of the assembly: the number of non-constrained 
components and the status of the defined constraints.

2. Click the Broken tab to see the list of broken constraints. We have only one broken constraint, a 
contact constraint.

3. Click on the name of the constraint. 

The constraint is highlighted in the specification tree.
4. Click on OK to close the dialog box. 

Reconnecting this contact constraint is our next task.



Reconnecting a Broken Constraint

 

In this task, you will learn how to reconnect the broken constraint detected by the application.

 

1.  Double-click the broken constraint in the specification tree. Note that this broken constraint is indicated by a yellow 
warning symbol.

2. In the Constraint Definition dialog box that appears, click More to access additional information.

3. Click Disconnected in the Status frame, then Reconnect...

4.  You are then prompted to select a component to rebuild the constraint. Select the same faces as the ones used for 
setting the first contact constraint. If you need some help, refer to Setting Constraints Between Components.

5. 
Click OK to validate the operation and update the document.

The constraint is reconnected:



 

  

 



Detecting Clashes

 

In this task, you will learn how to detect possible clashes between two components.

 

1. Select CRIC_BRANCH_1.1 in the specification tree.

2. 

Select the Analyze -> Compute Clash... command.

The Clash Detection dialog box appears. It displays the first component selected for computing 
possible clashes.

3. As you need another component, select SUB_PRODUCT2 using the Ctrl key.

This component also appears in the dialog box.

4. Click Apply to compute clashes.

The application detects a clash between the brown cylinder and the red face. This is indicated by 
two red circles in the geometry, as the arrow shows in the figure below:



The result of the computation also appears in the dialog box.

5. Click Cancel to close the dialog box. 

Well, now that you know that your assembly needs to be modified to work properly, let's edit the 
cylinder.

 

  

 



Editing a Component

 

This task shows you how to edit the component causing the problem.

 

1.  Double-click the brown cylinder to access the Part Design workbench.

2. Double-click the cylinder again to edit it. The Pad definition dialog box is displayed.

3. Enter 20mm to reduce the pad length and click OK.

4. The cylinder is updated and now looks like this:





Displaying the Bill of Material

 

This task shows you how to access all the information available about the structure of the assembly.

 

1.  Return to Assembly Design workbench and select the Analyze -> Bill of Material... command.

The Bill of Material is displayed.



It is composed of these sections:

 Bill of Material: lists all parts and sub-products one after the other
 Recapitulation: displays the total number of parts used in the product
 Define formats: customizes the display of the bill of material

The Listing Report tab displays the tree of the product using indents

2. If you wish, you can save this document using the html format or the txt format. Just click the Save As... 
button, then give a name and the appropriate extension to your file.

For more information about the bill of material, refer to  Displaying the Bill of Material.

 

  

  

http://canezou/AwsDocV5R14/Doc/online/pstug_C2/pstugbt0314.htm


Exploding the Assembly

 

This last task illustrates the use of the Explode capability. Exploding the view of an assembly means 
separating the components of this assembly to see their relationships.

 

1. Make sure Product 1 is selected.

2. 
Click the Explode icon   in the Move toolbar.

The Explode dialog box is displayed.

Product 1 is the assembly to be exploded. The Depth parameter lets you choose between a total 
(All levels) or partial (First level) exploded view.

3. Set All levels if not already set.

4. Set 3D to define the explode type.

5. Click Apply to perform the operation.

The Scroll Explode field gradually displays the progress of the operation. The application assigns 
directions and distance.

Once complete, the assembly looks like this:



The usefulness of this operation lies in the ability of viewing all components separately. 

Note that you can move products within the exploded view using the 3D compass.

6. Click OK to validate the operation and then click Yes at the prompt or click Cancel to restore the 
original view.

Well, you have done all the tasks of the Getting Started section. Why not consult the rest of the 
documentation?

 

  

 



User Tasks
Here is the list of the tasks you will perform in this section:

Creating an Assembly Document
Updating an Assembly
Analyzing an Assembly

Defining a Multi-Instantiation
Fast Multi-Instantiation

Inserting an Existing Component with Positioning
Managing Constraints
Moving Components
Using Assembly Tools
Creating Annotations

Detecting Clashes
Sectioning

Measuring Minimum Distances
Improving Performances

Generating CATPart from Product
Displaying the Assembly Mass Properties

Modifying an Assembly
Editing a CATPart in an Assembly Design Context

Assembly Features
Assembly Symmetry

Flexible Sub-Assemblies
Reusing a Part Design Pattern

Managing Part and Assembly Templates
Managing Enhanced Scenes

Selecting Using a Filter



Creating an Assembly Document

This task will show you how to enter the Assembly Design workbench to create a new assembly from scratch.

1.  Select the Start -> Mechanical Design -> Assembly Design command to launch the required workbench. 

 The Assembly Design workbench is opened. You can see that Product1 is displayed in the specification tree, indicating the 
building block of the assembly to be created. To create an assembly, you need products. The application uses the term 
product or component to indicate assemblies or parts. You can use parts to create products. Those products can in turn be 
used to create other products.

The commands for assembling different products (or components) are available in the toolbar Product Structure Tools to the 
right of the application window. For information on these commands, please refer to Product Structure user's guide.

 

 The document contains:

●     a specification tree to the left of the application window

●     specific toolbars to the right of the application window

●     a number of contextual commands available in the specification tree and in the geometry. Note that these commands can 
also be accessed from the menu bar.

   



Updating an Assembly 

This task will show you how to update an assembly.

 
●     Updating an assembly means updating all elements affected by this functionality, see Assembly 

Update reference information.

●     You can update automatically or not your assembly, see Assembly Design-Update option.

●     You can define the update propagation in the assembly, see Assembly Design-Update 
propagation option.

●     You can compute the update status when you open an assembly document or insert an 
assembly component, see Assembly Design-Compute exact update status at open option.

When you are opening an assembly document or inserting a component:

 

●     In Design Mode, the update status can be determined, the Update All icon  or the 

Updated icon  is displayed.

●     In Visualization Mode: the update status cannot be determined, the  Status Unknown icon 

 is displayed. When you click this icon, the minimal data needed to determine the update 
status are loaded:

❍     If the minimal data loaded to determine the status allow the application to perform an 
update and if the Update option is Automatic, then the assembly is updated, the Updated 

icon  is displayed.

❍     If the status is not up to date, the Update All icon  is displayed. When you click this 
icon, the needed data to perform  the update are loaded, then the assembly is updated, the 

Updated icon  is displayed.

To perform this task you must work in Visualization Mode, select the Tools->Options... 
command.
In the Infrastructure category, select the Product Structure sub-category then the Cache 
Management tab and check the option Work with the cache system. Close and re-open the 
application if needed.

 Open the Assembly_01.CATProduct document.

http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/Assembly/Assembly_01.CATProduct


 
The Update Status Unknown icon  is displayed because there is not enough information to 
determine the update status of assembly's elements: the constraints reference assembly 
components which are in Visualization Mode.

 

 You can keep this state and work or determine the update status. In our example, we want to 
determine it.

1.  Click the Update Status Unknown icon:  

When you click this icon, the application loads the minimal data to determine the update 
status. This is mean that the constraints' related components may be switched to Design 
Mode, warning is displayed in this case.

 The Update Warning dialog box appears, you can:

 

 
●     Click OK to determine the update status.

●     Click Cancel to keep the unknown status.

 
2.  Click OK, a progress bar appears during the data loading.

 The update status has been determined: the assembly is up to date and the Updated icon 

is displayed:  



 The components have been loaded and constraints have been resolved.

 



Analyzing an Assembly

Compute a Clash: Select Analyze -> Compute Clash, multiselect the components and click Apply.

Compute a Clearance: Select Analyze -> Compute Clash, multiselect the components, enter the 
clearance value and click OK.

Analyze Constraints: Select Analyze -> Constraints, and select the constraints in the dialog box.

Analyze Dependences: Select  the component and the Analyze -> Dependency...command, check 
the display options of the dialog box or select elements and use the different contextual commands.

Analyze Updates: Select the product or component of interest and select the Analyze -> Update 
command.

Analyze Degrees of Freedom: Select the Analyze -> Degrees of Freedom command.



Computing a Clash Between Components 

 

As assemblies may be very complex and are made up of a large number of components, you may find it 
difficult to see possible clashes. This task shows you how to analyze clashes or compute clearance between 
components.

Open the AnalyzingAssembly01.CATProduct document.

 

1.  Select Analyze -> Compute Clash...

The Clash Detection dialog box is displayed. It lets you compute possible clashes or clearance. The default 
option is Clash.

2. Multiselect the components CRIC_FRAME1 and CRIC_BRANCH_3.

The components are displayed in the Compute Clash dialog box.

3. Click Apply to compute a possible clash.

The icon in the Result frame now flashes red indicating that an interference has been detected.

http://canezou/AwsDocV5R14/Doc/online/asmug_C2/samples/AnalyzingAssembly01.CATProduct


The application detects a clash between the components. This result is shown by two red areas as the arrow 
shows in the figure opposite:

4. Click Cancel.

5. 
 

Repeat the operation to compute a possible clash between CRIC_BRANCH1 and CRIC_BRANCH_3.

The application detects a contact between the components. The icon in the Result frame now shows yellow 
indicating this.



6.  Click Cancel to exit.

7. 
 

Repeat the operation to compute a possible clash between CRIC_JOIN1 and CRIC_BRANCH_1.1.

The icon in the Result frame now shows green indicating that no interference has been detected.



 

  

 



Computing a Clearance Between Components 

 

Once components have been added or constrained, you may need to analyze the clash or compute the 
clearance between components. This task shows you how to compute the clearance between two 
components of an assembly.

Open the AnalyzingAssembly01.CATProduct document.

 

1. Select Analyze -> Compute Clash...

The Clash Detection dialog box is displayed.

2. Select Clearance in the combo box. 

The Clash Detection dialog box displays a field where you specify the clearance value.

3. Enter the clearance value: 50 mm.

4. Click the first component: CRIC_JOIN.1.

5. Control-click the second component: CRIC_BRANCH_3.1.

The components are displayed in the Clash Detection dialog box.

6. Click Apply to compute possible clearance.

The application detects a clearance violation. The distance between the components is less than 
50 mm. The status icon is yellow in the dialog box.
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7. Click Cancel to perform another operation.

8. Now multiselect CRIC_BRANCH_3 and CRIC_BRANCH_1.

9. Repeat steps from 1 to 3.

10. Click Apply.

The application detects a contact between the components. The status icon in the dialog box has 
turned yellow.

11. Click Cancel to exit.

 

  



Analyzing Constraints 

This task shows you how to analyze the constraints of an active component.

All the items displayed in the Constraint Analysis dialog box are editable according to their respective behavior (Copy, Cut, Paste, Delete, 
etc).

Open the AnalyzingAssembly02.CATProduct document.

1.  Select Analyze -> Constraints. 

 The Constraint Analysis dialog box is displayed. The Constraints tab displays the status of the constraints of the selected 
component:

 

 The Constraints tab displays the status of the constraints of the selected component:

●     Active Component displays the name of the active component.

●     Component displays the number of child components contained in the active component.

●     Not constrained displays the number of child components not constrained in the active component.

●     Status displays the status of the constraints:

❍     Verified displays the number of verified constraints.

❍     Impossible displays the number of impossible constraints. "Impossible" means that the geometry is not compatible with the 
constraint. For example, a contact constraint between two cylinders whose diameter is different is impossible.

The yellow unresolved symbol is displayed in the specification tree on the constraint type icon: 

❍     Not updated displays the number of constraints to be updated. The application has integrated new specifications, which 
affect constraints.

The update symbol is displayed in the specification tree on the constraint type icon: 

❍     Broken displays the number of broken constraints. A reference element is missing in the definition of these constraints. It 
may have been deleted for example. You can then reconnect this constraint (see Reconnecting Constraints).

The yellow unresolved symbol is displayed in the specification tree on the constraint type icon: 

❍     Deactivated displays the number of deactivated constraints (see Deactivating or Activating Constraints).
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The deactivated symbol is displayed in the specification tree. It precedes the constraint type icon: .

❍     Measure Mode displays the number of constraints in measure mode.

❍     Fixed Together displays the number of fix together operations.

❍     Total displays  the total number of constraints of the active component.

 In our scenario, the command displays the status of all constraints defined in AnalyzingAssembly product.

The command Analyze -> Constraints. displays the status of constraints defined for sub-assemblies too. What you have to do is set 
the combo box on top of the dialog box to the sub-assembly name of your choice.

In addition to the Constraints tab, the Broken tab and the Deactivated tab provide the name of the broken and deactivated 
constraints already indicated in the Broken and Deactivated fields.

The constraints are clearly identified in these tabs and you can select them. Once selected, they are highlighted both in the tree and 
in the geometry area.

 

 Additional tabs may be displayed if one of these constraint status exists:

●     Impossible.

●     Not updated.

●     Measure Mode.

The tab Degrees of freedom also displays if all constraints of a given component are valid.

To redefine the colors of the different type of constraints, see Customizing Constraint Appearance.

 This capability does not show overconstrained systems. The application detects them when performing update operations. For more 
information, see Inconsistent or Over-constrained Assemblies. You can also use the command Analyze -> Dependence, see 
Analyzing Dependences.

 
2.  Click OK to exit and delete the following constraints to perform the rest of the scenario: Coincidence.12, Parallelism.15 and Line 

Contact.16.

 The document now contains only seven constraints. They all are verified.

http://canezou/AwsDocV5R14/Doc/online/bascuprt_C2/bascuprt0100.htm


 
3.  Select Analyze -> Constraints again. The Constraints Analysis dialog box no longer contains the tabs Broken and Deactivated.

4.  Click the Degrees of freedom tab. 

 

 The application displays this tab only if all constraints are verified. The tab displays the components affected by constraints and the 
number of degrees of freedom remaining for each of them.

 
5.  Double-click CRIC_TOP.1.

 The Degrees of Freedom Analysis dialog box is displayed.

 

 One rotation as well as one translation remain possible for CRIC_TOP.1. For more information, please refer to Analyzing Degrees of 
Freedom.



 

 
6.  Click Close then OK to exit.



Analyzing Dependences 

This task shows you how to see the relationships between components using a tree.

Open the AnalyzingAssembly03.CATProduct document.

1.  Select the component CRIC_BRANCH_3.1.

 

You can analyze the dependencies of your assembly by selecting the root of the tree too.

 
2.  Select Analyze -> Dependencies... command.

 The Assembly Dependencies Tree dialog box appears.

 

 
3.  Right-click CRIC_BRANCH3.1 and select the Expand node command from the contextual menu.
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 The constraints defined for this component then appear:

 

 
4.  Right-click CRIC_BRANCH3.1 and select the Expand all command from the contextual menu.

 Now, the constraints and components related to the component you have selected are displayed:

 

 You can notice that there are:

●     a coincidence constraint between CRIC_BRANCH_3.1 and CRIC_BRANCH_1.1: Coincidence.4

●     a surface contact constraint between CRIC_BRANCH_3.1 and CRIC_FRAME.1: Surface contact.5

●     a surface contact constraint between CRIC_BRANCH_3.1 and CRIC_AXIS.1: Surface contact.9

●     a surface contact constraint between CRIC_BRANCH_3.1 and CRIC_BRANCH_1.1: Surface contact.6

●     a coincidence constraint between CRIC_BRANCH_3.1 and CRIC_FRAME.1: Coincidence.7

 
5.  Checking the different options available in the Elements frame.

 You can display the following:

●     Constraints: by default, this option is activated

●     Associativity: shows components edited in Assembly Design context, see Designing in Assembly Design Context. Contextual 
components are linked to support components by green lines in the graph.

●     Relations: shows formulas. For more information, please refer to Knowledge Advisor User's Guide.

 
6.  You can also display the relationships by filtering the components you wish to see. Either check the Child option to take the children of 

the component  into account or check Leaf to hide them.

 Contextual commands are available:

●     Expand all: lets you see the whole relationship. Note that double-clicking produces the same result.

●     Expand node: lets you see the relationship under the node.

●     Set as new root: sets the selected component as the component whose relationships are to be examined.

Zooming in and zooming out in the tree is allowed.



 
7.  Click OK to close the dialog box.



Analyzing Updates 

Operations such as moving components (see Moving Components) or editing constraints (see 
Editing Constraints) sometimes affect the integrity of the whole assembly. You then need to know 
what to do to restore a correct product. The application provides a tool for detecting if your 
assembly requires updates. This tool is particularly useful when working with large assemblies.
You can update a part or a product without updating the whole assembly, using the Analyze 
Update command.

Open the AnalyzingAssembly04 document.
This scenario assumes that the Manual Update option is on. For more about this option, refer to 
Update.

1.  Select Analysis product in the specification tree.

 

 
2.  Select the Analyze -> Update command. 

 The Update Analysis dialog box appears.
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 In our example, it provides the name of the entities to be updated, i.e:

 
●     name of the product or component under study

●     name of the constraints defined on this product or component

●     name of the children of this product or component

●     name of the constraints defined on the children

●     name of the representations defined on the children

 In some cases, it also displays the name of the representations associated to parts.

 
3.  Select Concidence.4 from the Constraints field.

 The application highlights this constraint both in the specification tree and in the geometry 
area.



 
4.  Set the Components to be analyzed to Analysis/Product2.

 Two constraints need updating.

 

 
5.  Set the Components to be analyzed to Analysis.

6.  Click the Update tab and multi-select Analysis/Product2.



 

 

7.  Click the Update  icon to the right of the dialog box. 

 The part is updated:



 

 The Update Analysis dialog changes and displays the update status for the Analysis 
component.

 

 
8.  Click OK to close the dialog box.



Analyzing Degrees of Freedom 

This task explains how to see if you need to set additional constraints to the components making up your assembly.

The degrees of freedom analysis is performed from assembly constraints only. This is mean that constraints from design in 
context or assembly pattern are not taken into account.

The analysis is performed from the active component and its child components set, but you must know that:

●     Selecting of any sub-component of a child component returns the analysis of this child component relative to its active 
parent component only. If you want to analyze the sub-component relative to a child component, activate the child 
component before.

●     Flexible child components (and their flexible sub-components) of the active component are not taken into account for the 
analysis. In this case, the analysis is performed from the first rigid sub-component found in the selection, under the active 
component.

Translations can be performed in a plane is represented by two vectors. These vectors define the translation plane but 
depending on the geometry, they can constitute an orthonormal system or not. In other words, a planar translation which 
normal to the plane has the coordinates (x=0, y=1, z=0) can sometimes be represented by:

●     These two vectors:
❍     vector 1: x=0, 707107, y=0, z=0,707107

❍     vector 2: x=-0, 707107, y=0, z=-0, 707107

●     or by these ones:
❍     vector 1: x=1, y=0, z=0

❍     vector 2: x=-0, y=0, z=1

Open the AnalyzingAssembly04 CATProduct document.

1.  Click the Update icon to update the assembly: 

 
2.  Right-click CRIC_SCREW (CRIC_SCREW.1) and select the Analyze -> Degrees of Freedom command command 

from the contextual menu.
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 The Degrees of Freedom Analysis dialog box is displayed.

 

 The dialog box displays all rotations and translations that remain possible for the selected component. In our scenario, 
you can rotate CRIC_SCREW (CRIC_SCREW.1) in two ways or translate it in one way. 

 If you look at the geometry, you can notice that these rotations and translations are represented in yellow.

 
3.  Click the Rotation_2 button.

 The graphic element representing this possible rotation is now highlighted in the geometry for easy identification.

 



 As detailed in the dialog box, you can perform a rotation around the vector which coordinates are x=1, y=0 and z=0 
and using the point with coordinates x=0, y=-23.4839 and z=-151.254 as the rotation center.

 
4.  Click the Translation_2 button.

 The graphic element representing this possible rotation is now highlighted too.

 

 As detailed in the dialog box, you can perform a translation along the vector which coordinates are x=0, y=0.984808 
and z=-0.173648.

 
5.  Click Close to exit the command.



Defining a Multi-Instantiation

This task shows you how to repeat components as many times as you wish in the direction of your 
choice.

 The option "Automatic switch to Design mode" is now available for this command. For more about 
this option, refer to Access to geometry.

Open the Multi_Instantiation.CATProduct document.

1. Select the component you wish to instantiate, that is CRIC_BRANCH_3.

2. 
Click the Define Multi-Instantiation icon:  

The Multi-Instantiation dialog box is displayed, indicating the name of the component to be 
instantiated.

The shortcut Ctrl + E calls the command too.
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3. The Parameters option lets you choose between the following categories of parameters to 
define:

Instances & Spacing
Instances & Length
Spacing & Length

Keep the Instances  & Spacing parameters option and enter 3 as the number of instances and 
90mm as the value for the spacing between each component.

4. To define the direction of creation, check x axis.

There is another way of defining a direction. You can select a line, axis or edge in the 
geometry. In this case, the coordinates of these elements appear in the Result field.

Clicking the Reverse button reverses the direction.

The application previews the location of the new components:



5. Make sure the option Define as Default is on. If it is so, the parameters you have just defined 
are saved and will be reused by the Fast Multi-Instantiation command.

6. Click OK to create the components.

Three additional components are created in the x direction. The tree displays them as well.

The Apply button executes the command but the dialog box remains open so as to let you 
repeat the operation as may times as you wish.

 



Fast Multi-Instantiation

This task shows you how to repeat components using the parameters previously set in the Define 
Multi_Instantiation command.

You will use the Fast Multi-Instantiation command to quickly repeat the component of your choice. 
The operation is very simple.

Make sure the option Work with the cache system is deactivated (for more refer to Working with a 
Cache System) and open the Fast_Multi_Instantiation.CATProduct document.

1. Select the component you wish to instantiate, that is CRIC_BRANCH_3.

2. 
Click the Fast Multi-Instantiation icon  .

The shortcut Ctrl + D calls the command too.

The result is immediate. Three components are created according to the parameters defined in 
the Multi-Instantiation dialog box.

http://canezou/AwsDocV5R14/Doc/online/bascupst_C2/bascupst0100.htm
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Inserting an Existing Component with 
Positioning

This task will show you how to insert and position a component as the same operation.

This functionality is an enhancement of the Insert Existing Component command for Assembly 
Design workbench. The Smart Move interface will enable the easy positioning of inserted 
components in the assembly, at the very moment of their insertion. It will also enable the 
positioning by creation of constraints. If there is no geometry to position when the component is 
inserted, this functionality has the same behavior as the Insert Existing Component command plus 
a visualization. See Smart Move or Smart Move with Viewer.

Open the MovingComponents01 document.

1.  Click the Existing Component with Positioning icon:  

 
2.  Select Product1 in the specification tree.

 
3.  Select the CRIC_JOIN CATPart document in the File Selection dialog box.

 The Smart Move dialog box appears.

 
4.  In this dialog box, select the axis of the part.
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5.  In this geometry window, select the axis of the CRIC_BRANCH_3 part.

 



 CRIC_JOIN is snapped with CRIC_BRANCH_3 part.

 

 
6.  Click OK in the Smart Move dialog box.

   



Managing Constraints

 This section describes the notions and operating modes you will need to set and use constraints in 
your assembly structure. Constraints allow you to position mechanical components correctly in 
relation to the other components of the assembly. You just need to specify the type of constraints 
you wish to set up between two components, and the system will place the components exactly the 
way you want. You can also use constraints to indicate the mechanical relationships between 
components. In this case, constraints are included in the specifications of your assembly.

Create a Coincidence Constraint: Click this icon, select the faces to be constrained and enter the 
properties of the constraint in the dialog box.

Create a Contact Constraint: Click this icon and select the faces to be constrained.

Create an Offset Constraint: Click this icon, select the faces to be constrained and enter the 
properties of the constraint in the dialog box.

Create an Angle Constraint: Click this icon, select the faces to be constrained and enter the 
properties of the constraint in the dialog box.

Fix a Component: Click this icon and select component to be fixed.

Fix Components Together: Click this icon, select the components to be fixed and enter a name for 
this group in the dialog box.

Quick Constraint: Check the list of constraint creation, click the icon and select the elements to be 
constrained.

Change Constraint: Select the constraint to be changed, click this icon and select the new type of 
constraint in the dialog box.

Deactivate or Activate Constraints: Select the constraint to be (de)activated and use the Deactivate 
or Activate contextual command.

 Select the Constraints of Given Components: Select the components, right-click and select xxx 
object -> Component Constraints contextual command.

 Editing Constraints: Double-click the constraint to be edited.

 Update One Constraint Only: Right-click the constraint to be updated and select the Update 
contextual command

 Modify the Properties of a Constraint: Double-click the constraint and enter new properties in the 
dialog box.

Use a Part Design Pattern: Select the pattern, select the component to be repeated, click this icon 
and enter the specifications in the dialog box.

Set a Constraint Creation Mode: Click any of these three constraint creation mode icons



 Inconsistent or Over-constrained Assembly

 Search for URLs Associated with Constraints: Click this icon and select the constraint of interest.

 Reordering Constraints in the Specification Tree

 Refreshing Constraints

 



Creating a Coincidence Constraint  

This task consists in applying a constraint between two faces. See Coincidence Constraints 
reference.

 Before constraining the desired components, make sure it belongs to a component defined as active 
(the active component is blue-framed and underlined).

Open the Constraint1.CATProduct document.

1.  Click the Coincidence Constraint icon:  

2.  Select the face to be constrained, that is the red face as shown.

 

3.  Select the second face to be constrained, that is the blue circular face in the direction 

opposite to the red face.

 Green arrows appear on the selected faces, indicating orientations.
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4.  The Constraint Properties dialog box that appears displays the properties of the constraint. 

The components involved and their status are indicated. You can define the orientation of 

the faces to be constrained by choosing one of these options: 

 

●     Undefined (the application finds the best solution)

●     Same

●     Opposite

 
Note that when changing a Same orientation into an Opposite orientation or vice-versa, 
the application may sometimes positions the parts in an unexpected way especially if your 
system is under-constrained.

 For the purposes of our scenario, set the Opposite option.

 

5.  Click OK to create the coincidence constraint.

 
The application chooses which component is to be moved to adopt its new position. As the 
assembly is not iso-constrained, any component can be moved. In other words, you cannot 
control which components will be moved.  

 Green graphic symbols are displayed in the geometry area to indicate that this constraint 
has been defined.

 This constraint is added to the specification tree too.



 

Graphic symbols used for constraints can be customized. For more information, refer to 
Customizing Constraint Appearance.

 



Creating a Contact Constraint 

This task consists in applying a constraint between two faces. See Contact Constraints reference.

You can create contact constraint between oriented plane.

Open the Constraint7.CATProduct document.

 Before constraining the desired components, make sure it belongs to a component defined as active 
(the active component is blue framed and underlined).

1.  Click the Contact Constraint icon:  

2.  Select the face to be constrained, that is the red face as shown.

 

3.  Select the second face to be constrained, that is the blue inner face in the direction opposite 

to the red face.

 
As the contact constraint is created, the red component is moved so as to adopt its new 
position. Green graphic symbols are displayed in the geometry area to indicate that this 
constraint has been defined.

 This constraint is added to the specification tree too.
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Graphic symbols used for constraints can be customized. For more information, refer to 
Customizing Constraint Appearance.

  



Creating an Offset Constraint 

This task consists in applying an offset constraint between two faces. For information about this type of 
constraint, see Offset Constraints reference section.

 Before constraining the desired components, make sure it belongs to a component defined as active (the 
active component is blue-framed and underlined).

Open the AssemblyConstraint02.CATProduct document.

1.  Click the Offset Constraint icon:  

2.  Select the face to be constrained, that is the yellow face as shown.

 

3.  Select the second face to be constrained, that is the blue face in the direction opposite to the 

yellow face.
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Green arrows appear on the selected faces, indicating the orientations.

The Constraint Properties dialog box that appears displays the properties of the constraint. The 
components involved and their status are indicated. You can define the orientation of the faces to 
be constrained by choosing one of these options:

●     Undefined (the application finds the best solution)

●     Same

●     Opposite

Note that when changing a Same orientation into an Opposite orientation or vice-versa, the 
application may sometimes position the parts in an unexpected way especially if your system is 
under-constrained.

 For the purposes of our scenario, keep the Opposite option.

 

4.  Enter 38 mm in the Offset field. 

Affecting a value to an offset constraint, means that the constraint drives the distance between 

the components.

 Instead of entering a value, you can check the Measure option. In this case, the value is 
obtained from the geometry.



 
5.  Click OK to create the offset constraint.

A green arrow is displayed in the geometry area to indicate that this constraint has been defined. 
The offset value is displayed too. This constraint is added to the specification tree too.

 

 
Editing Offset Constraints

If you decide to make your constraint a measure (for that, just check the Reference option), the 
offset constraint value displayed in the Value field is the distance between the components at the 
time you created the constraint. If you wish to modify that value, enter the new value, update the 
document, then check the Reference option.

 

Graphic symbols used for constraints can be customized. For more information, refer to 
Constraint Creation. 



Creating an Angle Constraint 

This task consists in setting an angle constraint between two planes. See Angle Constraints reference.

 Before constraining the desired components, make sure it belongs to a component defined as active (the active component is blue-
framed and underlined).

Open the AssemblyConstraint03.CATProduct document.

1.  Click the Angle Constraint icon:  

2.  Select the face to be constrained, that is the blue face as shown.

 

3.  Select the second face to be constrained, that is the red face in the same direction of the blue face.

 

 The Constraint Properties dialog box is displayed with the properties of the selected constraint and the list of available constraints:

 
●     Perpendicularity

●     Parallelism (you then need to define the orientation of the faces. You can choose between Undefined, Same, Opposite options)

●     Angle

●     Planar angle (an axis is to be selected. This axis must belong to both planes)
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Note that when changing a Same orientation into an Opposite orientation or vice-versa, the application may sometimes positions 
the parts in an unexpected way especially if your system is under-constrained.

 

4.  Keep the Angle option.

5.  Enter 40 deg in the Angle field and keep Sector 1.

A Sector combo box appears only when you select two geometries for which the orientation can be defined (this rule excludes 
line or edge).
Four angle sectors are available:

 

 

Direct Angle

Angle + 180 deg

180 deg - Angle

360 deg - Angle

6.  Click OK to create the angle constraint.

 As the angle constraint is created, the red component is moved so as to adopt its new position. A green arrow is displayed in the 
geometry area to indicate that this constraint has been defined. The angle value is displayed too. This constraint is added to the 
specification tree too.

 

Graphic symbols used for constraints can be customized. For more information, refer to Customizing Constraint Appearance.



Fixing a Component 

Fixing a component means preventing this component from moving from its parents during the 
update operation. There are two ways of fixing a component: 
 by fixing its position according to the geometrical origin of the assembly, which means 

setting an absolute position. This operation is referred to as "Fix in space".
 by fixing its position according to other components, which means setting a relative 

position. This operation is referred to as "Fix".

This scenario first shows you how to fix a component in space, then how to fix it.

Before fixing the desired component, make sure it belongs to a component defined as active.

Open the Fix.CATProduct document.

1. 
Click the Fix icon:  

Fix in Space

This command is also available from the Insert menu.

 By default, the  Fix command fixes components in space.

2. Select the component to be fixed, that is the light blue component.

The constraint is created. A green anchor is displayed in the geometry area to indicate that 
this constraint has been defined. 

A lock symbol preceding the anchor 
is displayed in the specification tree 
too:

Graphic symbols used for constraints can be customized. For more information, refer to 
Customizing Constraint Appearance.

3. Move the fixed component using the compass.
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4. Update the assembly to see which component is moved: the fixed component returns to its 
previous location:



Fix 

5. Double-click the fix constraint you have just created to edit it.

6. In the dialog box that appears, click More to expand the dialog box.

7. 

 

Uncheck the Fix in space option to the left of the dialog box. The lock symbol is no longer 
displayed in the specification tree, meaning that the component is positioned according to the 
other components only.

8. Move the fixed component using the compass.

9. Click OK to confirm.

10. Update the assembly: now the 
component remains at its location. 
Conversely, the dark blue 
component is moved to the fixed 
component.



Fixing Components Together 

This task consists in fixing two components together.

The Fix Together command attaches selected elements together. You can select as many 
components as you wish, but they must belong to the active component.

Open the Fix.CATProduct document.

1. 
Click the Fix Together icon:  

This command is also available from the Insert menu and works both in design and 
visualization mode.

2. Select  CRIC_FRAME.

3. Select CRIC_BRANCH_3.

You can select the components in the specification tree or in the geometry area.

4. The Fix Together dialog box appears, displaying the list of selected components.

To remove a component from the list, just click it.
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 5. In the Name field, enter a new name for the group of components you want to create. For 
instance, enter FT1.

6. Click OK.

The components are attached to each other.  

Note 

Moving one of them (using the compass combined with the Shift key or using the option "With 
respect to constraints" in the Manipulate dialog box) moves the other one too. 

The specification tree displays this operation.

 
Because you can inadvertently move these components, the application displays the dialog 
box Move Warning to remind you that you are moving components fixed together. According 
to the selected options, Move components involved in a Fix Together option is affected.



  

  
●     If you check the Extend selection with all involved component option, these 

components will be move together as long as the option will be checked.

●     If you check the Do not show this warning next time option, the dialog box will not be 
displayed and:

❍     If the Extend selection with all involved component option is checked, the Move 
components involved in a Fix Together option is set to Always.

❍     If the Extend selection with all involved component option is unchecked, the Move 
components involved in a Fix Together option is set to Never.

❍     To display again this dialog box, check Ask each time option in Move components 
involved in a Fix Together.

A Few Notes about Fix Together
 You can select a set of attached components to apply the Fix Together command between this set 

and other components.

 You can set constraints between components belonging to a set of components fixed together.

 If you set a constraint between a component and a set of attached components, the whole set is 
affected by the constraint.

 You can deactivate or activate a set of attached components by using the Deactivate/Activate 
contextual command available in the specification tree. Red parentheses preceding the graphic 
symbol indicate deactivated sets.

 

   



Using the Quick Constraint Command 

The Quick Constraint command creates the first possible constraint as specified in the priority list. 

This task consists in using this command to create two constraints.

Open the QuickConstraint.CATProduct document.

1. Make sure the list specifying the order of constraint creation is composed as follows:

1.  Surface contact
2.  Coincidence
3.  Offset
4.  Angle
5.  Parallelism

For more about this list, please refer to Quick Constraint option.

2. 
Double-click the Quick Constraint icon:  

Select the axis as shown.

3. Select the axis of AXIS_BRANCH_3.

As the application cannot set a surface contact due to the type of selected elements, it creates 
the second optional constraint mentioned in the list, that is a coincidence constraint.
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4. Now select the faces as shown:

The first constraint in the list can now be set. A surface contact constraint is created.

Graphic symbols used for constraints can be customized. For more information, refer to 
Customizing Constraint Appearance.



Changing Constraints 

Changing a constraint means replacing the type of this constraint by another type. This operation is 
possible depending on the supporting elements. You can select any constraints, not necessarily in 
the active component.

This task consists in changing the parallelism constraint into an offset constraint.

Open the AssemblyConstraint05.CATProduct document.

1. Select the constraint to be changed.

2. 
Click the Change Constraint icon:  

The Change Type dialog box that appears, displays all possible constraints.

3. Select the new type of constraint. For the purposes of our scenario, select Offset.

4. Click Apply to preview the constraint in the specification tree and the geometry.
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5. Click OK to validate the operation.

 



Deactivating or Activating Constraints 

Deactivating or activating constraints means specifying if these constraints must be taken into 
account during updates or not. This task consists in deactivating then activating a constraint.

Open the AnalyzingAssembly04.CATProduct document and make sure the Design Mode is on.

1.  Right-click the Coincidence.3 constraint and select the Deactivate command from the 

contextual menu.

 The constraint is deactivated.
The mask representing a deactivated constraint appears with red parentheses, on the 
constraint's icon in the specification tree.

 

 The deactivated constraint is now displayed in white in the geometry window.

 

2.  Right-click the Coincidence.3 constraint and select the Activate command from the 

contextual menu.
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Selecting the Constraints of Given Components 

This task consists in selecting all the constraints defined for a component.
You can only select child components of the active component.
The Component Constraints command allows you to select the constraints linked to one or more 
selected components. These components are child components of the active component.

Open the Assembly_01.CATProduct document, use the Show capability if the constraints are not 
visible, and ensure the design mode is on.

1.  Select the component whose constraints are to be selected. Multi-selection is also possible.

 

 
2.  Right-click and select CRIC_FRAME.1 object -> Component Constraints command from 

the contextual menu.

 The application highlights two constraints, both in the specification tree and the geometry 
area.
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Editing Constraints 

This task explain how to edit constraints.

When you are editing a constraint, you can:
●     Rename the constraint.

●     Change the referenced geometries.

●     Modify its options.

 The Copy/Cut/Paste commands are available for valuated constraints only. In this case, only the constraint's value, for the same type of 
constraint offset or angle, can be pasted. Concerning the Cut command, it deletes the constraint and copy its value.

Open the Assembly_01.CATProduct document.

1.  Double-click the Surface contact.3 constraint.

 The Constraint Definition dialog box appears.

 

 
2.  Click the More>> button to expand the dialog box.

 

 The traffic light displays the constraint's status:

●      verified.

●      impossible.

●      not updated.

●      broken.

 Two contextual commands improving display are available in the Supporting Elements field:

●     Reframe on views the constraint of the selected component at the center of the geometry window.

●     Center Graph zooms in the selected component in the specification tree.
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Constraints and Object in Work
 When you are setting constraints and designing part in the assembly at the same time, it is possible that you are modifying the referenced 

geometries of the constraints. In other words, the geometry of the current feature does not contain the original geometry referenced by the 
constraint. In fact, the constraint references the original geometry which already exists in the history but not for the current object in work.
In this case, the application cannot highlighted the geometry or the constraint seems to be wrong.
This can happen for Sheet Metal Design features or when you add a transformation feature in Part Design context for example after the 
constraint's creation.

 

 The body or the brick-red part has been translated using the translate transformation feature of Part Design, note that its magenta axis 
system has not been moved. The constraint is already verified although one of its referenced geometry has been moved.

 



Updating One Constraint Only 

 

When you need to update your constraints, either you update all the constraints of the active 
component or update one or more constraints of the active component. 

By default, constraints needing an update are displayed in black. To redefine the colors of the 
constraints, please refer to Customizing Constraint Appearance.

This task consists in updating the  constraints you explicitly specify.

 

1. Right-click the constraint to be updated.

Constraints needing an update are displayed with specific graphic properties. The Properties dialog 
box indicates too if constraints need updates or not. For more information, please refer to 
Modifying the Properties of a Constraint.

You can select the constraint in the specification tree or in the geometry.

2.  Select Update from the contextual menu.

The selected constraint is updated.

3. Click the second constraint to be updated.

4. Control-right-click the third constraint to be updated.

5.  Select the Update contextual command.

The two selected constraints are updated too. Remember, valid constraints are green by default.



 



Modifying the Properties of a Constraint 

 

This task consists in modifying the mechanical properties and attributes of a constraint.

Open the AssemblyConstraint02.CATProduct document and create an offset constraint.

1. Right-click the offset constraint to be modified.

You can select the constraint in the specification tree or in the geometry.

2. Select Properties from the contextual menu.

The Properties dialog box that appears displays four tabs.
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Constraint tab

The Constraint tab displays the name of the constraint as well as the name and type of the 
supporting components. You can rename the constraint if desired.

The constraint status is also indicated. In our scenario, the constraint is connected. To find out how 
to reconnect broken or misconnected constraints.

3. Enter a new value in the Offset field. For example, enter 75 mm.

4. Set the Orientation option to Same so as to reverse the blue component.

Instead of using the Properties contextual command to edit the properties as  described above,  
you can double-click the constraint to be edited to display the related dialog box: in which you can 
modify the same properties:

  

Mechanical tab 

5. Click the Mechanical tab.

6.

Three attributes characterize constraints: 
 Deactivated: deactivated constraints are not taken into account when updating the 

assembly
 To update: the constraint does not reflect the latest changes to the assembly
 Unresolved: the application detects problems

7. Check Deactivated.

The constraint is modified accordingly.

Note that parentheses precede the constraint value, indicating that the constraint is deactivated. 
These parentheses precede the name of the constraint in the specification tree too. The color of the 
graphic symbol is modified. 



Feature Properties tab

8.
Click the Feature Properties tab.

This tab displays the constraint's name as well as its creation and last modification date. You can 
edit the constraint's name.

Graphic tab

9. Click the Graphic tab. 

The Graphic tab lets you define the graphic properties of your constraint. 

 Color
 Line type (Dotted, Small dotted etc.)
 Thickness (Different values)

 
Select the color of your choice from the list. You can also define your own colors by selecting the 
More Colors... command at the bottom of the list. To know more about defining personal colors, 
please refer to Infrastructure User's Guide.

You cannot define a new color for deactivated constraints. For the purposes of our scenario, you 
need to reactivate the constraint.

 



 

If you wish to change the color for a given status (resolved, unresolved, over-contrained, invalid 
geometry)  use the Tools -> Options command. For more, see Customizing Constraint 
Appearance.

 



Setting a Constraint Creation Mode 

This task shows you how to set one of the three modes available to create constraints. These 
modes are: 
 Default mode
 Chain mode
 Stack mode

Open the Constraint_Creation.CATProduct document.

Default mode

1. 
Click  the Default Mode icon:  

This mode lets you create as many constraints as you wish by explicitly selecting two 
geometrical elements. In our example, you can set an offset constraint between the 
highlighted face and the face of another geometrical element. For the purposes of this 

scenario, double-click the offset constraint  icon to make it permanently active.

The offset constraint  icon still active, you can then set another offset constraint between 
two other faces.
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2. For the purposes of our scenario, delete these constraints.

Chain mode

1. 
Click the Chain Mode icon:  

This mode lets you create as many constraints as you wish by always reusing the last face you 
selected.

2. 
The offset constraint  icon still active, you can then set another offset constraint between 
the second face you selected and any other face.



3.  

 

The offset constraint  icon still active, you can then set another offset constraint between 
the third face you selected and any other face.

And so on...

4. For the purposes of our scenario, delete these constraints.

Stack mode

1. 
Click the Stack Mode  icon:  

This mode lets you create as many constraints as you wish by reusing the very first face you 
selected to create the first constraint.

2.
The offset constraint  icon still active, you can then set another offset constraint between 
the first face you selected and any other face.



3.
The offset constraint  icon still active, you can then set another offset constraint between 
the first face you selected and any other face.

4. And so on...



Inconsistent or Over-constrained Assemblies 

This task shows you what happens when the application detects an over-constrained assembly.

Open the AssemblyConstraint02.CATProduct document.

1.  Create the offset constraints as shown below:

 
●     top face of Part5 and bottom face of CRIC_FRAME

●     top face of Part5 and top face of CRIC_FRAME
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The two constraints are green colored because they are consistent. There is any overconstraint, their 
values respect the position of the two parts.

2.  Set the value of Offset.7 constraint to 45.

 

3.  Update the assembly if you are in manual update.

 The update operation detects difficulties to obtain a valid constrained system: the Update Diagnosis 
dialog box appears providing the diagnosis of the problem.



 

 The constraints involved in the inconsistent or over-constrained system are displayed.
The application indicates:

 
●     The constraint causing trouble: Offset.7

●     Constraint Offset.6, which is valid but involved in the inconsistent or over-constrained system .

 To resolve the problem, you can edit, deactivate, isolate or delete the desired constraint.

4.  Select Offset.6, click the Deactivate button and click Close.

5.  Close the dialog box, update the assembly if needed.

 The assembly is now consistent.

 



Searching for URLs Associated with Constraints 

 

This task shows you how to check that a constraint has been assigned URLs (Universal Resource 
Locators), then how to search for a given URL.

Open the Moving_Components_02 document that contains URLs created in the Knowledge Advisor 
workbench. 

 

1. 

Click the Comment and URLs icon:  

The URLs and Comment dialog box is displayed.

2. 
Select the constraint "Surface contact.18".

The URL field indicates that this constraint has been assigned two URLs: "Dassault Systèmes" and 
"Delmia".
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3. 
Click "Delmia".

The associated URL is displayed in the URL field.  

You just need to click the Go button to access the corresponding web site.

Searching for a URL

4. Click the Explore tab.

The list of all the URLs assigned to all the constraints defined in this CATProduct document is 
displayed.

5. 

Enter the name of the URL to be searched for in the Search field. For example, enter "Delmia".

6. Click Search. 

If the specified URL is found, "yes" is displayed in the Found column. In the Edit tab, the URL is 
highlighted.

 



Reordering Constraints in the Specification Tree

This task shows you how to modify the location of assembly constraints in the specification tree to 
classify them the way you want. The application lets you reorder constraints but also gather them 
in sets.
You can perform these operations within the Constraints node:

●     Reordering Constraints

●     Gathering Constraints in a Set

●     Creating a Set Before Gathering Constraints

●     Handling Sets

●     You can move all types of constraints. What is more, the application does not take their status 
into account: if they are deactivated or even broken, you can relocate them.

●     Whatever operation you perform for modifying their locations in the tree, it never affects the 
geometry of your assembly.

●     You cannot create a set of constraints in a flexible assembly. If you make a rigid sub-assembly 
as flexible, set of constraints will be removed.

Open the AnalyzingAssembly02 CATProduct document.

 

Reordering Constraints

1.  Select Coincidence.4 as the constraint to be moved and right-click the Coincidence.4 

object-> Reorder constraints contextual command.
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2.  Select Coincidence.10 as the constraint below which Coincidence.4 is to be located.

 Coincidence.4 has been moved.

 

 

Gathering Constraints in a Set



 
3.  To group Surface contact.5 and Surface contact.6 constraints, multi-select them and use 

the Selected objects -> Group in new set contextual command.

 The application has created Set.1 containing both surface constraints.

 
4.  Select Set.1 and right-click to use the Properties contextual command.

 
5.  In the Properties dialog box that appears, rename Set.1 as Surface Contact Constraints 

in the Feature Name field of the Feature Properties tab.

 
6.  Expand this node.

 You must obtain this:

 

 

Creating a Set Before Gathering Constraints



 
7.  Select the node Constraints and right-click to use the Constraints object->Add Set 

contextual command.

 A new set, Set.2, appears in the tree, at the same level as 'Surface Contact Constraints' 
set. It has been created at the first level of the Constraints node.

 

 
8.  Multi-select Coincidence.7, Coincidence.10 and Coincidence.4 and right-click to use the 

Selected objects -> Reorder constraints contextual commands.

 
9.  Select Set.2 as the new location for these constraints.

 
10.  Expand the new node to check that Set.2 contains the three constraints:



 

 

Handling Sets
 

11.  Right-click Set.2 and select Set.2 object to display the contextual menu available for this 

node.

 The following contextual commands are available:

●     Add set: creates a set at the level below (in our example, Set.3 would be created below 
Set.2).

●     Remove set: deletes the set, not the constraints it contained.

●     Group in new set: locates the selected set within a new set.

●     Move Set after: moves the set after the set you select.

●     Move Set inside: moves the set within the set you select.



 Refreshing Constraints

This task consists in refreshing constraints.

For constraints pointing published element in a missing component, the constraint's masks remain 
broken after inserting the missing component. Because there is now way to inform these 
constraints that the component is back, they cannot be automatically re-evaluated.

 This contextual command is available for:
●     A constraint object, only the selected constraint is refreshed.

●     A constraints node in the specification tree, all constraints in the node are refreshed.

●     A set of constraints, all constraints in the set are refreshed.

Open the Assembly_02.CATProduct document.

1.  Expand the specification tree.

 Concidence.3 and Concidence.4 constraints are broken.

 

2.  Right-click Assembly_02 and select Components -> Existing Component... from the 

contextual menu.

Select the Sub_Product1.CATProduct document.

 Constraint's status still broken.
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3.  Right-click Constraints and select Constraints object -> Refresh Constraint from the 

contextual menu.

 Constraint's status have been modified. Their status have been re-evaluated to not up to 
date.

 



Moving Components 

Translate Components: click this icon, select the component to be translated and enter the offset 
values.

Rotate Components: click this icon, click the Rotation tab, select the component to be rotated, 
choose an axis and enter the angle values. 

Manipulate Components: click this icon, click the parameters you wish, select the component to be 
moved and drag this component.

Snap Components: click this icon and select both elements.

Smart Move: click this icon and select the components to be moved (and constrained if you check the 
Automatic constraint creation option).

Smart Move with Viewer: select the components to be moved (and constrained if you check the 
Automatic constraint creation option) and click this icon.

Explode a Constrained Assembly: click this icon, select the parameters you need and select the 
assembly to be exploded.

Stop Manipulation on Clash: click this icon and use the compass or the Manipulation command.



Translating Components 

This task will show you two ways to translate a component:

 
●     by entering translation values

●     by selecting geometrical elements to define a translation direction.

If you are working in Assembly Design workbench, this task is P1-only.

 Using P2 configuration, you can rotate constrained components by means of the Shift key and the 
compass.

The element to be translated must belong to the active component.

 The option Automatic switch to Design mode is available for this command. For more about this 
option, refer to Access to geometry in the Infrastructure User's Guide.

 Open the Moving_Components_01 document.

1.  Click the Translate or Rotation icon:   

 The Move dialog box is displayed. Either you specify an offset value between the element 
and  x, y or z axis, or you select a geometric element to define the direction you need.

 

2.  Select the component to be translated, that is CRIC_BRANCH_3.
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By Entering Values

3.  Enter 50 mm as the offset value, in the Offset X field. The component will be translated 

along x axis.

4.  Click Apply.

 The selected component is translated accordingly.

 

5.  Click the Invert button to reverse the previous operation and translate the component in 

the opposite direction.

 The component is translated in the opposite direction. You can click Apply as many times as 
you wish to translate the component to the desired position.



 

6.  Click OK to close the dialog box.

7.  Repeat steps 1 and 2.

 

By Selecting Geometric Elements

8.  Click the Selection button to define a new translation with respect to a geometric element.

 The Translation tab contents is grayed out. If you select a line or a plane you need to enter 
a distance value. The translation is then done along the selected line or normal to the 
selected plane. Selecting two faces or planes assumes these elements are parallel.

9.  Select the red and blue faces as shown. These faces are parallel.

 



 The application computes the distance between these faces.
The Offset field then displays this distance value:

 Offset X: 20mm

 Offset Y: 0mm

 Offset Z: 0mm

10.  Click Apply to translate the blue component.

 

 You can apply this translation to any other components. You just need to select it and click 
the Apply button.

11.  Click OK to exit.



Rotating Components

This task will show you the two ways of rotating a component:

 
●     by entering the rotation angle and specifying the rotation axis

●     by selecting a geometric element as the rotation axis and entering the angle value

If you are working in Assembly Design workbench, this task is P1-only.

 Using P2 configuration, you can rotate constrained components by means of the Shift key and the 
compass.

The element to be rotated must belong to the active component.

 The option "Automatic switch to Design mode" is available for this command. For more about this 
option, refer to Access to geometry in the Infrastructure User's Guide.

 Open the Moving_Components_01 document.

1.  Click the Translate or Rotation icon:   

 The Move dialog box is displayed. Translation options are available. To find out how to 
translate components, refer to Translating Components.

2.  Click the Rotation tab.
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3.  Select the component you wish to rotate, that is CRIC_BRANCH_1.

 

 
Entering a Rotation Angle

4.  For example, check the Axis Y option to specify the axis of rotation.

5.  Enter 90 as the angle value in the Angle field.

 The selected component is rotated accordingly.

 

7.  Click OK to close the dialog box.

8.  Repeat steps 1, 2 and 3.



 
Selecting Geometry to Define the Axis of Rotation

9.  Click the Selection button to define a new rotation with respect to a geometrical element.

10.  Select the edge as shown to specify the new rotation axis.

 

11.  Enter 90 in the Angle field.

12.  Click Apply to rotate the red component.

 

 You can apply this rotation to any other components. You just need to select it and click the 
Apply button.

13.  Click OK to exit.



Manipulating Components 

This task will show you how to manipulate a component. The Manipulate command lets you move a 
component freehand with the mouse. It is less constraining than the Translate Component and Rotate 
Component commands. See Translating Components and Rotating Components.

The element to be manipulated must belong to the active component.

 Open the Moving_Components_02 document.

1.  Click the Manipulate icon:  

 The Manipulation Parameters dialog box appears. You can translate or rotate components using one 
of the following options:

 The first and second horizontal rows are reserved for translations. You can move your 
component along the x, y or z-axis as well as in the xy, yz and xz planes.

 The third row is reserved for rotations. You can rotate your component around the x, y or z-
axis.

 The fourth column lets you specify the direction of your choice by selecting a geometric 
element. This element defines the direction of the move or the axis of rotation.

 

2.  Click the Drag along Y axis icon:  

3.  Select Set1 as the component to be translated.
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4.  Drag Set1.

 The component is translated in the Y axis direction.

 

5.  Now select CRIC_FRAME and click Drag around Y axis icon:  

6.  Drag the component. You are rotating it around the Y axis.



 

7.  Check the option With respect to constraints. If you repeat the previous operation, you will notice 

that you are not allowed to do it. The existing parallelism constraint prevents you from moving the 

component.

8.  Click OK to exit.

Use the Shift key and the compass to manipulate constrained components.

 Flexible components cannot be moved via the Manipulate command.



Snapping Components  

The Snap command projects the geometric element of a component onto another geometric 
element belonging to the same or to a different component. Using this command is a convenient 
way to translate or rotate components.

 The Snap is able to work in visualization mode, which means the positioned component and the 
positioning parts will no longer need to be switched into design mode. However, in order to select 
points, you must be working in Design mode.

For DMU Navigator, this task is P1-only.

The element to be snapped must belong to the active component.

 Open the Moving_Components_01 document.

 Depending on the selected elements, you will obtain different results. This table indicates what you 
can do:

 

First 
Element 
Selected

Last Element 
Selected Result

point point Identical points.

point line The point is projected onto the line.

point plane The point is projected onto the 
plane.

line point The line passes through the point.

line line Both lines become collinear.

line plane The line is projected onto the plane.

plane point The plane passes through the point.

plane line The plane passes through the line.

plane plane Both planes become parallel.

Make sure you work in Design mode (use Edit->Representations->Design Mode) 

1.  Click the Snap icon:  
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2.  Select the red face as shown.

 

The element selected first is always the element that will move.

3.  Select the blue face as shown.

 

 The red face is projected onto the plane defined by the blue face.



 A green arrow is displayed on the first face you selected.

 

4.  Click this arrow to reverse the orientation of the face.

 



Smart Move 

This task illustrates how to move a component and create a coincidence constraint between two 
axes.
 

●     The Smart Move combines the Manipulate and Snap command capabilities, see Manipulating 
Components and Snapping Components. Optionally, it creates constraints. See also Smart Move 
with Viewer.

●     The Smart Move is able to work in visualization mode, which means the positioned component 
and the positioning parts will no longer need to be switched into design mode. However, in 
order to create constraints, you must be working in Design mode.

●     The Smart Move is disabled when the Automatic switch to Design mode is off and related 
components of the Active component in Visualization mode.

Open the Moving_Components_01 document.

1.  Click the Smart Move icon   and expand the Smart Move dialog box that appears.

 The Quick Constraint frame contains the list of the constraints that can be set. This list 
displays these constraints in a hierarchical order and can be edited by using both arrows to 
right of the dialog box.

 

 
2.  Check the Automatic constraint creation option. 
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 The application creates the first possible constraint as specified in the list of constraints 
having priority. For more about this list, please refer to Quick Constraint.

 
3.  Select the axis of CRIC_BRANCH_1 as shown:

 

 
4.  Select the axis of CRIC_BRANCH_3.

Instead of explicitly selecting both axes, you can select the axis of CRIC_BRANCH_1 and 
then drop it onto the blue inner cylinder face when your cursor points to this face.

 The application detects a possible constraint between the axes. As the option Create 
constraint is on, the application can set a coincidence constraint between both axes.

 



 
5.  Click the green arrow to reverse the direction of the component.

 

 
6.  Click OK to confirm and quit the command. 

 The coincidence constraint is created.

  



Smart Move with Viewer

This task illustrates how to move a component and create a coincidence constraint between two 
axes.

●     The Smart Move combines the Manipulate and Snap command capabilities, see Manipulating 
Components and Snapping Components. Optionally, it creates constraints. See also Smart Move 
with Viewer.

●     The Smart Move is able to work in visualization mode, which means the positioned component 
and the positioning parts will no longer need to be switched into design mode. However, in 
order to create constraints, you must be working in Design mode.

●     The Smart Move is disabled when the Automatic switch to Design mode is off and related 
components of the Active component in Visualization mode.

Open the Moving_Components_01 document.

1.  Select CRIC_BRANCH_1 and CRIC_BRANCH_3 in the specification tree.

 

2.  Click the Smart Move icon   and expand the Smart Move dialog box, including the 

viewer that appears.

●     The Viewer frame: this window appears only if you pre-select the components affected 
to perform the smart move. These components must belong to the same parent 
component. 
Using the viewer allows you to select with more accuracy the geometrical element to be 
moved and constrained. In the viewer window you can move and rotate the component 
regardless of its position the geometry window. The viewer do not forbid the selection of 
the geometrical element in the geometry window.

●     The Quick Constraint frame contains the list of the constraints that can be set. This list 
displays these constraints in a hierarchical order and can be edited by using both arrows 
to right of the dialog box.

http://canezou/AwsDocV5R14/Doc/online/cfyugasm_C2/samples/Moving_Components_01.CATProduct


 

 
3.  Check the Automatic constraint creation option. 

 The application creates the first possible constraint as specified in the list of constraints 
having priority. For more about this list, please refer to Quick Constraint.

 
4.  Select the face of CRIC_BRANCH_3 as shown in the dialog box.



 

 
5.  Click Next component.

 
6.  Select the face of CRIC_BRANCH_1 as shown in the dialog box.



 

 
7.  Click OK to confirm and quit the command. 

 The contact constraint is created.



 

  



Exploding a Constrained Assembly

This task shows how to explode an assembly taking into account the assembly constraints. This 
Explode type is applicable only to specific cases:
when the assembly is assigned coincidence constraints: 

 
●     axis/axis

●     plane/plane

Open the Moving_Components_03 document.

1.  Click the Explode icon:  

 The Explode dialog box appears.

 
2.  Wheel Assembly is selected by default, keep the selection as it is.

●     You can also use the drag and drop capability (drag the explode icon and drop it onto 
the required product in the specification tree.

●     The Depth parameter lets you choose between a total (All levels) or partial (First 
level) exploded view.

 
3.  Keep All levels set by default.

 
4.  Set the explode type. 3D is the default type. Keep it.

 
5.  Click Apply to perform the operation.

http://canezou/AwsDocV5R14/Doc/online/cfyugasm_C2/samples/Moving_Components_03.CATProduct


 

You can move products within the exploded view using the 3D compass.

 

In DMU Fitting Simulator only: the manipulation toolbar is also available once you move an 
object with the 3D Compass.

 The Scroll Explode field gradually displays the progression of the operation. The 
application assigns directions and distance. Once complete, the resulting exploded view 
looks like this:

 

 You are not satisfied with this result as the nuts are not correctly positioned. The 
constraints are not respected. Replay the scenario selecting the constrained type.

 
6.  Still in the Explode dialog box, set the constrained type.



 
7.  Define a fixed product: in our example select the Rim1 either in the specification tree or in 

the geometry area

 

 

 
8.  Click Apply to perform the operation.



 

 Once complete, the resulting exploded view looks like this:

 

 The nuts are correctly positioned, the exploded view corresponds more to the reality and to 
a technical documentation.

 
9.  Click OK to validate the operation or click Cancel to restore the original view.

If you click Ok, the following warning message is displayed as the exploded view is kept 
when exiting the command. In this case, if you need to restore the initial view click the 

Reset icon:  

 

The explode functionality aims at understanding better how the assembly is structured. You 
can use it for further purposes: creating scenes, print, keep the exploded view as archive 
document or generate a drawing  (please refer to Create Scenes in the DMU Navigator 
User's Guide)



Stop Manipulation on Clash 

When moving assemblies (using the compass along with the Shift key or the Manipulate command, 
see Manipulating Components), components may sometimes clash.
This task shows you how to view the minimum distance between these components to avoid a 
clash. 

A clash is detected only when the With respect to constraints option is checked in the 
Manipulation parameters dialog box:

 

 Open the Assembly_01.CATProduct document and perform all the tasks of the Assembly Design 
Getting Started section until "Moving Components".

1.  Drag the compass onto CRIC_SCREW. 

 
2.  Press and hold down the Shift key, select v/z axis on the compass, then drag and drop the 

component so as to obtain this clash:

 The components involved in the clash are now highlighted to facilitate your work.

http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/Assembly/Assembly_01.CATProduct


 

 

3.  Click the Manipulation on Clash icon:  

 
4.  Move the component slowly from right to left, then from left to right to repeat the clash.

 The application stops the move operation just before the clash occurs.

 

 
5.  Repeat the operation more quickly: the operation is stopped earlier, which makes the gap 

larger between both components.



 

 What you need to know is that the more slowly you handle the mouse, the smaller the 
distance between the components will be.

 

6.  To quit the command, simply click the Manipulation on Clash icon again: . You can 

compute clashes again if needed.

The accuracy of clash detection directly depends on the one used for tessellation (SAG) on objects. 
This is set in the Performances tab of Tools -> Options -> General -> Display. By default, this 
value is set to 0.2 mm.

For more details, refer to About Interference Checking & Analysis in DMU Space Analysis 

documentation.

  



Using Assembly Tools

 
Manage Products in an Assembly:  Select Tools -> Product Management...,modify the part number 
in the New part number field and replace the associated representation in the New representation 
field. 

 
Publish Elements: Select Tools -> Publication...,select the element to be published then rename this 
element.

 
Use a Part Contained in a Parametric Standard Part Catalog: Open the catalog of your choice, 
navigate through the catalog, select the desired part, use the Copy then Paste commands.

 Modify a Parametric Standard Part Catalog



Managing Products in an Assembly 

This task consists in managing products in an assembly.

Open the AssemblyTools01.CATProduct document.

1. Select Tools -> Product Management... 

The Product Management dialog box is displayed.

The following is displayed for each components contained in the assembly: 
 part Number
 document source file
 status of the component
 associated representation.

You can modify the part number in the New part number field and replace the associated representation in 
the New representation field of the selected product.

2. Click the ... button to open the Replace Representation dialog box.

3. Click OK to validate.

http://canezou/AwsDocV5R14/Doc/online/asmug_C2/samples/AssemblyTools01.CATProduct


Publishing Elements  

 

Publishing geometrical elements is the process of making geometrical features available to different users. 
This operation is very useful when working in assembly design context

This task shows you the method for making elements publicly available: you will publish a plane, a sketch 
then a parameter not visible in the specification tree.

In this page, you will also find information about the following subjects:

●     Publishing Part Design Features

●     Assembly Constraints and Published Generative Shape Design Geometry

●     Publishing in Assembly Design

●     Replacing a Published Element

●     Publishing Parameters

●     Importing and Exporting Published Names

●     What Happens When Deleting a Published Element?

 

Open the Publish.CATPart document or if you are working in Assembly Design,  for example open  the 
AssemblyTools01.CATProduct document, and ensure that the component containing the element you wish to 
publish is active.

 

1. 
Select Tools -> Publication. 

The Publication command lets you:

●     Publish a geometric element

●     Edit the default name given to the published element

●     Replace the geometric element associated with a name

●     Create a list of published elements

●     Import a list of published elements

●     Delete a published element.

The Publication dialog box appears.

http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/Publish.CATPart
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 If you are working in Assembly Design, the dialog box also displays a Browse button. For more 
information, refer to Publishing in Assembly Design. 

 2. 
Select the element to be published. For example, select Plane.1.

You can publish the following elements: 

●     points, lines, curves, planes

●     sketches

●     bodies (selecting a feature selects the body it belongs to)

●     Generative Shape Design features (Extrudes Surfaces, Offsets, Joins etc.)

●     Free Style Features (Planar patches, curves etc.)

●     parameters

●     sub-elements of geometrical elements: when switched on, the option Publish a face, edge, vertex or 
extremity lets you directly select faces, edges, vertices. axes. extremities. 

●     Part Design features.

 

 
To select axes, select cylindrical faces and use the Other Selection contextual command. 

For more about this command, please refer to CATIA Infrastructure User's Guide.

The dialog box displays the name and status of the selected element as well as "Plane.1", that is the 

default name given to the published element



3. 
Click Plane.1 in the dialog box. 

The plane is highlighted in the 

geometry. 

4. Rename it as New plane. 

The plane is published as New plane. However, you can notice that the geometric element 
Open_body.1/Plane1 has not been renamed.

5. Before publishing another element, click Options to access rename options. 

When using the Publication command, you can actually decide to rename or not the elements you are 
publishing. Prior to renaming, you can set one of the three following work modes:

●     Never: the application will not allow you to rename the published element. This is the default option.

●     Always: the application will always allow you to rename the published element

●     Ask: the application will ask you what you decide to do, namely rename or not the published element.



  Note that:
●     You can rename any element except for axes, edges and faces.

●     Some characters, such as the exclamation mark, are not allowed for renaming elements.

6.Check Ask and click OK to exit.

7.Prior to selecting the element to be published, deselect New plane if not already done. 

8.Select Sketch.1 as the new element to be published.

9.Rename it as "New sketch". A message is issued asking you whether you wish to rename the published 
element "Sketch.1" as "New sketch".

10.Click Yes to confirm. The published element's name is "New sketch" and the geometric element is 
renamed too.

 Notes
●     Pointing at or selecting published elements simultaneously highlights the geometry, the element node 

and the publication node.

  

  
●     The Publish capability lets you give a specific name to a geometrical element in a given context (for 

example, in a "defined in work object"). If this geometrical element is to be used in a different context 
(another "defined in work object"), the application does not recognize this element from its published 
name. In short, you need to select this object from the geometrical area, not from the Publication 
node.

  

Publishing Part Design Features



  Publishing Part Design Features requires that the Enable to publish the features of a body capability 
available in the Options dialog box is on. If your administrator did not lock the option, you can activate 
the option yourself.

  

Assembly Constraints and Published Generative Shape 
Design (GSD) Geometry

  Depending on your geometry, there are cases where constraints pointing to a certain type of published 
GSD features do not reconnect if, for example, you replace constrained parts. What happens is that links 
between constraints and the geometry do not take advantage of the publication. You can notice this 
behavior even if you selected the geometry through the Publication node.

GSD features concerned are those whose geometrical results depend on the number and type of the 
parents used for the result. This is the case of features such as Intersect or Project.

The solution to this, is to publish the geometrical result, not the feature itself. In concrete terms, rather 
than publishing the Intersect feature, you recommend you publish the vertex, not the point.

The application reminds you of this behavior when you are setting constraints on published features 
through the following warning message:

  
Publishing in Assembly Design 

  

When publishing geometry in the Assembly Design workbench, the Browse button is available in the 
Publication dialog box. Clicking the button launches the Component Publication dialog box that 
displays only the published elements belonging to the levels inferior to the active level.

In the following example, the user is publishing an element of CRIC_BRANCH_1. When clicking the 
Browse button, the Component Publication dialog box displays published faces belonging to 
CRIC_BRANCH_3.



  

  

This capability works as a filter: it does not display the whole publications of the assembly. Thus, you will 
use it as an help for selecting already published elements whenever you wish to replace published 
elements. 

Replacing a Published Element

11.Click "Open_body.1/Plane.1" to replace it with another geometric element.



12.Select "Plane.2" as the 
replacing element. 

 

 The orientation of both 
elements is displayed. The 
green arrow indicates the 
orientation for the new element, 
the red arrow indicates the 
orientation of the published 
element.

A message is issued asking you 
to confirm the change.

13.Click Yes to confirm. 

Plane.2 has been 
published.Plane.1 is not 
published any more. 

The dialog now displays the 
following information:

  

Publishing Parameters

 14.You can publish the parameters of a part that are not displayed in the specification tree. To do so, click the 
Parameter... button available in the Publication dialog box. This displays a new window listing all 
parameters defined for the feature previously selected in the specification tree.



 

 15.If the list of parameters is too long, you can filter out the parameters by entering a character string in the 
Filter Name field. For example, enter "offset". 

The list now displays only the parameters including the string "offset".

 16.Select the parameter of interest. 

You can also use one of the following filter types:

●     All

●     Renamed parameters

●     Hidden

●     Visible

●     User

●     Boolean

●     Length

●     Angle

●     String

 17.Click OK when done. This closes the dialog box. The selected parameter is displayed in the Publication 
dialog box.

 

Importing and Exporting Published Names



  Published names can be gathered in ASCII .txt files.

To export published names to an ASCII .txt file,  

●     click the Export button.

●     enter a name for the file you are creating in the Export dialog box that displays.

●     click Save : the file is created: it contains the list of all published elements as specified in the 
Publication dialog box.

To import published names to an ASCII .txt file,  

●     click the import button.

●     navigate to the file of interest in the Import dialog box that displays.

●     select the file containing the list of published elements.

●     click Open: the names are added to the list of the Publication dialog box

18.Click OK when satisfied. 

The Publication entity has 
been added to the specification 
tree. The three published 
elements are displayed below 
Publication node:

What Happens When Deleting a Published Element?

When deleting a published element, the application informs you that this element is published. What you 
need to do is confirm the deletion (Yes) or cancel it (No).



Using a Standard Part Contained in a 
Parametric Standard Part Catalog 

This task explains how to use mechanical parts contained in catalogs delivered with the product. 
These parts are standard parts. 

Dassault Systèmes does not warrant that provided data are compliant with the ISO or EN 
standards. For further information, please contact the AFNOR organization for ISO or EN standards 
(www.afnor.fr) or the ISO organization for ISO standards (www.iso.org). 

Catalogs containing a limited number of parts compliant with JIS and ANSI standards are available 
too. 

1. Select the Tools -> Mechanical Standard Parts -> XX catalogs command to access the catalog 
of interest. You can choose between the following caralogs: 
 EN catalogs
 ISO catalogs
 JIS catalogs
 US catalogs

The Catalog Browser dialog box displays:

 



For your information, catalogs are located in these directories: 

ISO:../$OS/Startup/Components/MechanicalStandardParts/ISO_Standards

EN:  ../$OS/Startup/Components/MechanicalStandardParts/EN_Standards

2. Navigate through the chosen catalog.

3. Select the desired family and within this family the part you need. For example, you can 
instantiate in an assembly: 
 screws
 bolts
 nuts
 washers
 pins
 keys

This list is not exhaustive.

4. Right-click to select the Copy contextual command.

5. Select the base of your assembly.

6. 

 

Right-click to select the Paste contextual command. 

The part is copied into your assembly. Note that this part is no longer linked to the catalog.

7. Using the Save As capability, you can save this part in the directory of your choice.



Modifying a Parametric Standard Part Catalog

This task explains how to modify a catalog containing parametric parts delivered with the product. 

Since Release 5 Service Pack 3, we no more use CSV files to create the EndChapters of the 
MechanicalStandardParts Catalogs.

To complete or modify an existing parts family:

 
1.  Complete or modify an existing DesignTable (located in the sub-directory Design_Tables).

 
2.  Launch an application session.

 
3.  Select the Tools-> Macro command to run the macro EN_EndChapters.CATScript (for EN) 

located in the sub-directory VBScript.

The dialog box that appears displays the following:

Path of the models directory: path of the sub-directory Models.

Path of the catalog output directory: path of the directory where the catalog 
documents will be created.

You can modify the default paths in the CATScript document according to you install.

To add a new family:

 
1.  Create the parametric CATPart.

 
2.  Create the design table as follows: PartNumber in the first column, PartName in the 

second column



 
3.  Complete the script EN_EndChapters.CATScript (for EN) with your family, remove the others 

and run the macro.

 
4.  Complete the main chapters description of you catalog.

Edit an existing CSV file (located in the sub-directory CSV) or create a new one.

Edit the script EN.CATScript, complete it with your new Chapter and run it.

For more about catalogs, refer to the Infrastructure User's Guide.

   



Creating Annotations 

Create Weld Features: click this icon, select a geometrical element which represents the weld.

Create a Text With Leader: click this icon, select a face and enter your text in the dialog box.

 
Create a Flag Note With Leader: click this icon, select the object you want to represent the hyperlink, 
enter a name for the hyperlink and the path to the destination file.

 



Creating Weld Features 

This task  shows you how to set welding specifications on components. These specifications will be used 
later on to weld these components.

Open the Weld_Planner document.

1.  Click the Weld Feature icon:   

2.  Select the edge between Green Part and Blue Part.

 

 The Welding creation dialog box appears.

 

http://canezou/AwsDocV5R14/Doc/online/cfyugfdt_C2/samples/Weld_Planner.CATProduct


3.  Enter your specifications in the Welding Creation dialog box. In the first entry field to the left, 

enter 70 as the weld length.

4.  For example, set the angle symbol.

 The symbols available are:

  

  

  

  

  

  

  

 

4. For example, set the angle symbol. The symbols available 
are:

5. Choose among the three weld types available to set your 
weld type:

6. Enter 2.5 as the weld length. 

7.
Enter Weld 2 in the Reference entry field. This field is reserved for your own specifications or codes. 



  You can also import a file by clicking the Import file button. The contents of this file is then displayed in the 
geometry. 

Note also that you can click: 

 the field-weld symbol (flag symbol): reserved for welds not made at the location of the initial part 
construction.

 the weld-all-around symbol (circle circle): reserved for welds made all around the contour of the 
part

 the "up" option: a display option. You can display the symbols and values above or below the 
welding symbol. It is a quick way of transferring the data from the first row to the row below and 
vice versa.

 the indent line side
 the weld tail symbol

 
8. Click OK to confirm. 

The annotation is created in the geometry.

 

9. Drag and drop the annotation to move it.  

You can obtain this result:



Contextual Commands

A certain number of contextual commands are available on specifications: 

 'Associated Geometry': manages annotation connections
 'Select Views/Annotation Plane': selects the annotations of an annotation plane and the 

annotation plane of an annotation
 'Transfer to View/Annotation Plane': transfers specifications from one view to another
 'Add Leader'  adds a leader to the selected specification (Right-click the specification to which you 

want to add a leader, select the Add Leader contextual command and click where you want to 
begin the leader).

 'Annotation Links': creates or deletes positional or orientation links

Contextual commands are also available on the yellow manipulator at the extremity of the arrow end: 
 'Add a Breakpoint': adds a breakpoint on the leader line 
 'Add an Interruption': adds an interruption on the leader line 
 'Remove a Breakpoint': removes a breakpoint on the leader line 
 'Remove Leader/Extremity': removes a leader line or an extremity
 'All Around': adds the All Around symbol
 'Switch to perpendicular leader': sets the leader perpendicular to the annotation

For more information about those commands, please refer to the 3D Functional Tolerancing and 
Annotations User's Guide.

 'Symbol shape': edits the shape of the 
manipulator pointed at by the arrow

 



At any time, you can modify the welding symbol. For this, double-click the welding symbol to be modified 
and enter the modifications in the displayed dialog box.



Creating a Text with Leader

This task shows you how to create an annotation text with leader

A text is assigned an unlimited width text frame. 
You can set  graphic properties (anchor point, text size and justification) either before or after you 
create the free text.
You can change any text to another kind at any time.

Open the Common_Tolerancing_Annotations_01 CATPart document.

●     Improve the highlight of the related geometry, see Highlighting of the Related Geometry for 3D 
Annotation.

1.  Double-click the Projected View.1 annotation plane to activate it. 

2.  Click the Text with Leader icon:   

3.  Select the face as shown to define a location for the arrow end of the leader.

http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/Tolerancing/Common_Tolerancing_Annotations_01.CATPart
http://canezou/AwsDocV5R14/Doc/online/cfyugfdt_C2/cfyugfdtcu0200.htm
http://canezou/AwsDocV5R14/Doc/online/cfyugfdt_C2/cfyugfdtcu0200.htm


If the active view is not valid, a message appears informing you that you cannot use the 
active view.
Therefore, the application is going to display the annotation in an annotation plane normal 
to the selected face.
For more information, see View/Annotation Planes.

The Text Editor dialog box appears.

4.  Enter your text, for example "New Annotation" in the dialog box.

http://canezou/AwsDocV5R14/Doc/online/cfyugfdt_C2/cfyugfdtut0100.htm


5.  Click OK to end the text creation. You can click anywhere in the geometry area too.

The text appears in the geometry. 
The text (identified as Text.xxx) is added to the specification tree.

 The leader is associated with the element you selected. If you move either the text or the 
element, the leader stretches to maintain its association with the element.

 Moreover, if you change the element associated with the leader, application keeps the 
associativity  between the element and the leader.

 Note that using the Text Properties toolbar, you can define the anchor point, text size and 
justification.

You can move a text using either the drag capability.
Note also that you can resize the manipulators
For more information, refer to Customizing for 3D Functional Tolerancing & Annotations.



Creating a Flag Note with Leader

This task shows you how to create an annotation flag note with Leader.

A flag note allows you to add links to your document and then use them to jump to a variety of 
locations, for example to a marketing presentation, a text document or a HTML page on the intranet.
You can add links to models, products and parts as well as to any constituent elements.

A flag note is assigned an unlimited width text frame. 
You can set  graphic properties (anchor point, text size and justification) either before or after you 
create the free text.
You can change any flag note to another kind at any time.

Open the Common_Tolerancing_Annotations_01 CATPart document.

●     Improve the highlight of the related geometry, see Highlighting of the Related Geometry for 3D 
Annotation.

1.  Double-click the Projected View.1 annotation plane to activate it.

 

2.  Click the Flag Note with Leader icon:   

3.  Select the face as shown to define a location for the arrow end of the leader.

http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/Tolerancing/Common_Tolerancing_Annotations_01.CATPart
http://canezou/AwsDocV5R14/Doc/online/cfyugfdt_C2/cfyugfdtcu0200.htm
http://canezou/AwsDocV5R14/Doc/online/cfyugfdt_C2/cfyugfdtcu0200.htm


If the active view is not valid, a message appears informing you that you cannot use the 
active view.
Therefore, the application is going to display the annotation in an annotation plane normal to 
the selected face.
For more information, see View/Annotation Planes.

The Manage Hyperlink dialog box appears. 

 You may specify the flag note's name link in the Name field.

 You may specify one or several links associated with the flag note in the URL field clicking the 
Browse... button.

 In the Link to File or URL list  you can see the list of links.

 To activate one of them, select it and click the Go to button.

http://canezou/AwsDocV5R14/Doc/online/cfyugfdt_C2/cfyugfdtut0100.htm


 To remove one of them, select it and click the Remove button.

 To edit one of them, select it and click the Edit button.

4.  Enter your flag note name, for example "New Annotation" in the dialog box and specify a link: 

www.3ds.com

5.  Click OK to end the flag note creation. You can click anywhere in the geometry area too.

The flag note appears in the geometry.



The leader is associated with the element you selected. If you move either the text or the 
element, the leader stretches to maintain its association with the element.

 Moreover, if you change the element associated with the leader, application keeps the 
associativity  between the element and the leader.

 Note that using the Text Properties toolbar, you can define the anchor point, text size and 
justification.

The flag notes (identified as Flag Note.xxx and its name between brackets) are added to the 
specification tree in the Notes group.

You can move a flag note using either the drag capability.
Note also that you can resize the manipulators
For more information, refer to Customizing for 3D Functional Tolerancing & Annotations.



Detecting Clashes 

Detect Interferences: Click the Clash icon, define the type in the Check Clash dialog box, then select 
the product and click Apply.

Read Clash Command Results: Run a check for interferences and read the global results in the Check 
Clash dialog box and Preview window.

 
View Results in a Dedicated Window: Run a check for interferences then click the Results window 
icon.

 
Export Clash Results: To save results in text and XML format, click the Export As icon.



Detecting Interferences

This task explains how to use the Clash command to check for interferences in your document. 

Checking for interferences is done in two steps: 

 Initial computation: detects and identifies the different types of interference.
 Detailed computation: computes the graphics representation of interferences as well as the 

minimum distance.

Open the AnalyzingAssembly01.CATProduct document.

1. Click the Clash  icon.

The Check Clash dialog box appears.

 

The default interference analysis is detecting clashes and contacts between all components in the 
document.

Two interference types are available: 
 Contact + Clash: checks whether two products occupy the same space zone as well as 

whether two products are in contact (the minimum distance is less than the total sag).
 Clearance + Contact + Clash: In addition to the above, checks whether two products are 

separated by less than the pre-defined clearance distance.

Results differ depending on the interference type selected for the analysis. See figure.

2. Set the interference type to Clearance + Contact + Clash.

3. Enter the desired clearance value in the field that becomes active next to the interference type. For 
example, enter 25mm.

4. Activate the second Type drop-down list box and select the computation type.

http://canezou/AwsDocV5R14/Doc/online/cfyugasm_C2/samples/AnalyzingAssembly01.CATProduct


Four computation types are available: 
 Between all components (default option): tests each product in the document against all 

other products.
 Inside one selection: within any one selection, tests each product of the selection against 

all other products in the same selection.
 Selection against all: tests each product in the defined selection against all other products 

in the document.
 Between two selections: tests each product in the first selection against all products in the 

second selection.

5. Select the computation type to Between all components. 

If you set the computation type to Between two selections, define the first selection then click to 
activate the second selection field (Selection 2) and select desired products.

Notes:

 Any sub-assembly in the specification tree is considered a valid selection.
 Continue clicking to select as many products as you want. Products are placed in the active 

selection. To de-select products, reselect them in the specification tree or in the geometry 
area.

 Click in selection fields (fields turn black) to view your selections and be certain that you have 
selected the products you intended: selected products are highlighted.

6. Click Apply to check for interferences. 

A progress bar is displayed letting you monitor and, if necessary, interrupt  (Cancel option) the 
calculation. The Check Clash dialog box expands to show the results.



Notes: 

To run another interference analysis, simply change the calculation parameters (interference type 
and selection) and click Apply.

To know more about Clash command results, refer to Reading Interference Results.

  



Reading Clash Command Results

Interference results differ depending on the interference type selected for the analysis. The following illustrates 
expected results for the different analysis combinations.

Clash

Given for information only. This option is not available.

Contact + Clash

 If red zones overlap, a clash is detected. If yellow zones only overlap, a contact is detected.



Note: sag (yellow zone) is offset from the skin inwards. 

 If the minimum distance between the yellow zones is less than the total sag (sag1 + sag2), a contact is 
detected.

Clearance + Contact + Clash

Sag
The sag corresponds to the fixed sag value for calculating tessellation on objects (3D fixed accuracy) set in the 
Performances tab of Tools -> Options -> General -> Display. By default, this value is set to 0.2 mm. The sag value 
set in this tab is offset from the skin inwards on both selection 1 and selection 2, . 

This value is valid for both the Part to Part Clash and the Clash commands.

 

This task explains how to read the global results in the Check Clash dialog box and browse through them in the 
Preview window.

Open the AnalyzingAssembly01.CATProduct document.

1. Click the Clash  icon and run a check of type Clearance (25mm) + Contact + Clash between all 

components. For more information, refer to Detecting Interferences. 

The Check Clash dialog box expands to show the results.

http://canezou/AwsDocV5R14/Doc/online/cfyugasm_C2/samples/AnalyzingAssembly01.CATProduct


The dialog box identifies the number of interferences detected along with the type: 4 interferences have 
been detected. 

Status lights are color-coded as follows:

 red: at least one conflict is relevant
 orange: no relevant conflicts, at least one conflict is Not inspected
 green: all conflicts are Irrelevant.

Interference results are presented in two different ways in the dialog box:

 List by Conflict tab: lists results by conflict with one conflict per line.
 List by Product tab: lists results by product. There may be more than one conflict per product.

2. Select the first conflict in the list, that is a clash, to run a detailed computation. 

A Preview window appears showing the products in conflict only.



The minimum distance is specified in the dialog box and both the minimum distance and red intersection 
curves identify clashing products separated by less than the specified clearance distance of 25mm are 
displayed in the geometry area.

Color Coding for Conflicts  

 Clash: red intersection curves identify clashing products.
 Contact: yellow triangles identify products in contact.
 Clearance: green triangles identify products separated by less than the specified clearance 

distance.

If necessary, pan, zoom and/or rotate in the Preview window to visualize the interference better.

3. Select contact and clearances in turn in the List by Conflict tab to run a detailed computation. 

As you select them, the Value and Status columns in the Check Clash dialog box, and the Preview 
window are updated.

4.
You can also view the selected interference in a dedicated viewer. To do so, click the Results window  
icon in the Clash Tools toolbar.

Filtering the Display in the Dialog Box

You can filter the display of  results in tabs by:

 All types
 Type of interference: clash, contact or clearance
 Value: no filter, increasing value or decreasing value.
 Status: all, not inspected, relevant, irrelevant. Until selected, all interferences are reported not 

inspected. Inspected interferences can be relevant or irrelevant

5. Set Clearance as the filter type.



6. Click Apply filters to update the display.

7. To change the status of an inspected conflict, click the status field of the appropriate conflict. 

The conflict status changes from relevant to irrelevant and vice-versa depending on the initial value.

 8. You can also add comments to selected conflicts: Click the Comment field. 

The Comment dialog box appears.

9. Enter your comment, for example "Test" and click OK.

10. Click the List by Product tab to display conflicts associated with products. 

Results are organized by product in the List by Product tab. There may be more than one conflict per 
product.



Viewing Results in a Dedicated Window

This task explains how to view selected interferences in a separate viewer.

Open the AnalyzingAssembly01.CATProduct document.

1. Click the Clash  icon and run a check of type Clearance (25mm) + Contact + Clash 

between all components. For more information, refer to Detecting Interferences. 

The Check Clash dialog box expands to show the results of the initial computation. The first 
interference is selected by default and a detailed computation has been run.

2. Close the Preview window.

3. 
Click the Results window  icon in the Clash Tools toolbar to view the selected 
interference in a dedicated viewer. 

The Interference Results.1 window opens.

http://canezou/AwsDocV5R14/Doc/online/cfyugasm_C2/samples/AnalyzingAssembly01.CATProduct


Color Coding for Conflicts

 Clash: red intersection curves identify clashing products.
 Contact: yellow triangles identify products in contact.
 Clearance: green triangles identify products separated by less than the specified 

clearance distance.

Object viewing commands and commands in the Window menu are available in this window. 
You can, for example, tile the Interference results window and the original document window 
vertically or horizontally.

4. For example, select Window -> Tile Vertically from the menu bar to organize the open windows 
vertically.

5. Click OK in the Check Clash dialog box to exit when done.



Exporting Clash Results

This task explains how to export clash results to a text file and publish clash results to an XML file.  

Open the AnalyzingAssembly01.CATProduct document.

1. Click the Clash  icon and run a check of type Clearance (25mm) + Contact + Clash between all 

components. For more information, refer to Detecting Interferences. 

The Check Clash dialog box expands to show the results of the initial computation. 

2. Browse through results using the Results viewer.

3. 
To publish results to an XML file, click the Export As  icon in the Clash Tools toolbar: 

The Export As dialog box is displayed:

 Set Type to XML (Extensible Markup Language): a standard format that can be used as a simple 
way to exchange data.

 Identify the folder in which you want to save the file.
 Enter a file name.
 Click Save to publish the results.

Note: Each time you export results, a folder containing all necessary files and images is created.

http://canezou/AwsDocV5R14/Doc/online/cfyugasm_C2/samples/AnalyzingAssembly01.CATProduct


4. Open your browser and read the results.

5. Click the interference (computation result table) in the browser to jump to the part of the page displaying 
the selected interference and appropriate results.

Notes:  
 The viewpoints set when visualizing the interferences in the Results window are saved and 

exported along with the clash results.

 Any filters applied to the results in the dialog box are taken into account so you can use the 
filters to export only pertinent results. 

6.
To write results to a text file, click the Export As  icon in the Clash Tools toolbar: 

The Export As dialog box is displayed.

 Set Type to *.txt
 Identify the folder in which you want to save the file.
 Enter a file name.
 Click Save to save the results in a text file.

7. Click OK to exit when done.
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Sectioning 

 About Sectioning

Creating Section Planes: Click the icon.

 Creating 3D Section Cuts:  Create a section plane then click the icon.

Manipulating Section Planes Directly: Create a section plane, drag plane edges to re-dimension, drag 
plane to move it along the normal vector, press and hold left and middle mouse buttons down to 
move plane in U, V plane or local axis system or drag plane axis to rotate plane.

 Positioning Planes on a Geometric Target: Create a section plane, click the icon then point to the 
target of interest.

 Positioning Planes Using the Edit Position and Dimensions Command: Create a section plane, click the 
icon and enter parameters defining the plane position in the dialog box.

 More About the Section Viewer: Create a section plane then click the icon.



About Sectioning

Using cutting planes, you can create sections, section slices, section boxes as well as 3D section cuts 
of your products automatically.

Creating section slices and section boxes are DMU-P2 functionalities.

The Section Plane

The section plane is created parallel 
to absolute coordinates Y, Z. The 
center of the plane is located at the 
center of the bounding sphere around 
the products in the selection you 
defined.

●     Line segments represent the 
intersection of the plane with all 
surfaces and volumes in the 
selection. By default, line 
segments are the same color as 
the products sectioned. 

 

 

 

 
●     Points represent the intersection of the plane with any wireframe elements in the selection, and are 

visible in both the document window and the Section viewer.

 

 Notes:
●     Any surfaces or wireframe elements in the same plane as the section plane are not visible.

●     If no selection is made before entering the command, the plane sections all products.

http://canezou/AwsDocV5R14/Doc/online/cfyugspa_C2/cfyugspabt0207.htm
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In DMU-P1, you cannot select products to be sectioned: the plane sections all products.

A plane has limits and its own local axis system. The letters U, 
V and W represent the axes. The W-axis is the normal vector of 
the plane.

You can customize settings to locate the center and orient the normal vector of the plane as well as de-
activate the default setting taking wireframe elements into account. This is done using the Tools -
>Options..., Digital Mockup ->DMU Space Analysis command (DMU Sectioning tab).

Manipulating the Plane

Sectioning is dynamic (moving the plane gives immediate results). You can manipulate the cutting 
plane in a variety of ways:

●     Directly

●     Position it with respect to a geometrical target, by selecting points and/or lines

●     Change its current position, move and rotate it using the Edit Position and Dimensions command.

Section Results

Results differ depending on the sag value used. 
 Using default value (0.2mm): Using a higher value:
 

 Sag corresponds to the fixed sag value for calculating tessellation on objects (3D fixed accuracy) set in 
the Performance tab of Tools -> Options -> General -> Display. By default, this value is set to 0.2 
mm.
In Visualization mode, you can dynamically change the sag value for selected objects using the Tools -
> Modify SAG command.

 
The 3D Section Cut

3D section cuts cut away the material from the cutting plane to expose the cavity within the product, 
beyond the slice or outside the box.

http://canezou/AwsDocV5R14/Doc/online/cfyugspa_C2/cfyugspabt0216.htm


Creating Groups of Products

In DMU-P2, prior to creating your section plane, you can create a group containing the product(s) of 

interest using the Group  icon in the DMU Space Analysis toolbar or Insert -> Group... in the 
menu bar.

Groups created are identified in the specification tree and can be selected from there for sectioning. 
Only one group per selection can be defined. 



Creating Section Planes

This task shows how to create section planes and orient the normal vector of the plane. 

Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, 
NOZZLE2.cgr, REGULATION_COMMAND.cgr, REGULATOR.cgr, TRIGGER.cgr and VALVE.cgr.

They are to be found in the online documentation filetree in the common functionalities sample folder 
cfysm/samples.
1. Select Insert -> Sectioning from the menu 

bar, or click the Sectioning  icon in the 

DMU Space Analysis toolbar to generate a 
section plane.

The section plane is automatically created. If 
no selection is made before entering the 
command, the plane sections all products. If 
products are selected, the plane sections 
selected products.

P1 Functionality

In DMU-P1, you cannot select products to be 
sectioned: the plane sections all products. 

 
The Section Plane

The plane is created parallel to absolute coordinates Y,Z. The center of the plane is located at the 
center of the bounding sphere around the products in the selection you defined. 

●     Line segments represent the intersection of the plane with all surfaces and volumes in the 
selection. By default, line segments are the same color as the products sectioned. 

●     Points represent the intersection of the plane with any wireframe elements in the selection.

A section plane has limits and its own local axis system. U, V and W represent the axes. The W-axis 
is the normal vector of the plane. The contour of the plane is red.

You can dynamically re-dimension and reposition the section plane. For more information, see 
Manipulating Section Planes Directly.



Using the Tools ->Options... command (DMU Sectioning tab under Digital Mockup ->DMU 
Space Analysis, you can change the following default settings:

●     Location of the center of the plane

●     Orientation of the normal vector of the plane

●     Sectioning of wireframe elements.

P2 Functionalities

In DMU-P2, you can create as many independent section planes as you like.
 

Results Window

A Section viewer is automatically tiled vertically alongside the document window. It displays a front 
view of the generated section and is by default, locked in a 2D view.

Notice that the section view is a filled view. This is the default option. The fill capability generates 
surfaces for display and measurement purposes (area, center of gravity, etc.).

 

 



Sectioning Definition Dialog Box

The Sectioning Definition dialog box appears.

This dialog box contains a wide variety of 
tools letting you position, move and rotate 
the section plane as well  as create slices, 
boxes and section cuts. For more information, 
see Positioning Planes with respect to a 
Geometrical Target, Positioning Planes Using 
the Edit Position Command, Creating Section 
Slices, Creating Section Boxes and Creating 
3D Section Cuts.

P2 Functionalities

Creating section slices and section boxes are DMU-P2 functionalities.
 2. Click the Selection box to activate it.

3. Click products of interest to make your selection, for example the TRIGGER and BODY1.

Products selected are highlighted in the specification tree and geometry area.

Note: Simply continue clicking to select as many products as you want. Products will be placed in 
the active selection. To de-select products, reselect them in the specification tree or in the 
geometry area.

The plane now sections only selected products.
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You can change the current position of the section plane with respect to the absolute axis system of 
the document:

 4. Click the Positioning tab in the Sectioning Definition dialog box.
  

5. Select X, Y or Z radio buttons to position the normal vector (W-axis) of the plane along the selected 
absolute system axis. 

Select Z for example. The plane is positioned perpendicular to the Z-axis. 



6. Double-click the normal vector of the plane (W-axis) or click the Invert Normal  icon to invert 

it. 



7. Click OK when done.

The section plane definition and results are 
kept as a specification tree feature.

By default, the plane is hidden when exiting the command. Use the Tools->Options, Digital 
Mockup-> DMU Space Analysis command (DMU Sectioning tab) to change this setting.

To show and edit the plane again, double-click the specification tree feature or select Hide/Show the 
plane representation in the contextual menu.



Creating 3D Section Cuts

3D section cuts cut away the material from the plane, beyond the slice or outside the box to expose the cavity within the 
product.

 

This task explains how to create 3D section cuts.

Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, 
REGULATION_COMMAND.cgr, REGULATOR.cgr, TRIGGER.cgr and VALVE.cgr.

They are to be found in the online documentation filetree in the common functionalities sample folder cfysm/samples.

 

1. Select Insert -> Sectioning from the menu bar, or click the Sectioning  icon in the DMU Space Analysis toolbar 

and create a section plane.

The Sectioning Definition dialog box appears.

 
2. In the Definition tab, click the Volume Cut  icon to obtain a section 

cut:

The material in the negative direction along the normal vector of the plane 
(W-axis) is cut away exposing the cavity within the product.

Note: In some cases, the normal vector of the plane is inverted to give 
you the best view of the cut.



Double-click the normal vector of the plane to invert it, or click the Invert Normal  icon in the Positioning tab of the 

Sectioning Definition dialog box.

3. Re-click the icon to restore the material cut away.
4. Click OK when done.
 

3D Section Cut Display

The 3D section cut display is different when the sectioning tool is a plane. To obtain the same display as for slices and 
boxes (see illustrations below) and make measures on the generated wireframe cut:

●     Select the Allow measures on a section created with a simple plane option in the DMU Sectioning tab 
(Tools -> Options, Digitial Mockup -> DMU Space Analysis)

●     Then, create your section cut based on a plane. 

When the Sectioning Tool is a Slice: When the Sectioning Tool is a Box:



 

P2 Functionality

In DMU-P2, you can turn up to six independent section planes 
into clipping planes using the Volume Cut command to focus on 
the part of the product that interests you most.

  
DMU Review

Section cuts created during DMU Reviews are not persistent and are only valid for the duration of the review. If you 
exit the DMU Review, the section cut is lost.

 



Manipulating Planes Directly

 

 

 

You can re-dimension, move and rotate section planes, or the master plane in the case of section slices and boxes, 
directly. As you move the cursor over the plane, the plane edge or the local axis system, its appearance changes 
and arrows appear to help you.

Re-dimensioning:
Moving along the normal 
vector
of the plane:

Rotating:
Moving in the x,y 
plane of the
local axis system:

Sectioning results are updated in the Section viewer as you manipulate the plane.  

To change this setting and have results updated when you release the mouse button only, de-activate the 
appropriate setting in the DMU Sectioning tab (Tools ->Options..., Digital Mockup ->DMU Space Analysis).
This task illustrates how to manipulate section planes directly.

Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, 
REGULATION_COMMAND.cgr, REGULATOR.cgr, TRIGGER.cgr and VALVE.cgr.

They are to be found in the online documentation filetree in the common functionalities sample folder 
cfysm/samples.
1. Select Insert -> Sectioning from the menu bar, or click the Sectioning  icon in the DMU Space Analysis 

toolbar and create a section plane.

A Section viewer showing the generated section is automatically tiled vertically alongside the document 
window. 

The generated section is automatically updated to reflect any changes made to the section plane.

You can re-dimension the section plane:
2. Click and drag plane edges to re-dimension plane:

Note: A dynamic plane dimension is indicated as you drag the plane edge.



 
You can view and edit plane dimensions in the Edit Position and Dimensions command. The plane height 
corresponds to its dimension along the local U-axis and the width to its dimension along the local V-axis.
You can move the section plane along the normal vector of the plane:

3. Move the cursor over the plane, click and drag  to move the plane to the desired location.
You can move the section plane in the U,V plane of the local axis system:

4. Press and hold down the left mouse button, then the middle mouse button and drag (still holding both buttons 
down) to move the plane to the desired location.

You can rotate the section plane around its axes: 
5. Move the cursor over the desired plane axis system axis, click and drag to rotate the plane around the selected 

axis.

 
6. (Optional) Click the Reset Position  icon in the Positioning tab of the Sectioning Definition dialog box to 

restore the center of the plane to its original position.



7. Click OK in the Sectioning Definition dialog box when done.

 



Positioning Planes On a Geometric Target

You can position section planes, section slices and section boxes with respect to a geometrical target (a face, edge, 
reference plane or cylinder axis). In the case of section slices and boxes, it is the master plane that controls how the slice 
or box will be positioned.

 

This task illustrates how to position a section plane with respect to a geometrical target.

Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, 
REGULATION_COMMAND.cgr, REGULATOR.cgr, TRIGGER.cgr and VALVE.cgr.

They are to be found in the online documentation filetree in the common functionalities sample folder cfysm/samples.

 

1. Select Insert -> Sectioning from the menu bar, or click the Sectioning  icon in the DMU Space Analysis toolbar 

and create a section plane.

The Sectioning Definition dialog box appears. 

A Section viewer showing the generated section is automatically tiled vertically alongside the document window. 

The generated section is automatically updated to reflect any changes made to the section plane.

 2. Click the Positioning tab in the Sectioning Definition dialog box.

3. Click the Geometrical Target  icon to position the plane with 

respect to a geometrical target.

4. Point to the target of interest:

A rectangle and vector representing the plane and the normal 
vector of the plane appear in the geometry area to assist you 
position the section plane. It moves as you move the cursor.

5. When satisfied, click to position the section plane on the target.

Notes: 
●     To position planes orthogonal to edges, simply click the desired edge.



●     A smart mode recognizes cylinders and snaps the plane directly to the cylinder axis. This lets you, for example, 
make a section cut normal to a hole centerline. To de-activate this mode, use the Ctrl key.

  
●     Selecting the Automatically reframe option in the DMU Sectioning tab (Tools -> Options -> Digital Mockup -> 

DMU Space Analysis), reframes the Section viewer and locates the point at the center of the target at the center 
of the Section viewer.

Zooming in lets youpinpointthe selected point.
This is particularly useful when using snap capabilities in a complex DMU session containing a large number of 
objects.

  

 

P2 Functionality

In DMU-P2, you can move the plane along a curve, edge or surface: 

●     Point to the target of interest

●     Press and hold down the Ctrl key

●     Still holding down the Ctrl key, move the cursor along the target. The plane is positioned tangent to the small 
target plane. As you move the cursor, the plane moves along the curve or edge.

6. (Optional) Click the Reset Position  icon to restore the center of the plane to its original position.

7. Click OK in the Sectioning Definition dialog box when done.

 



Positioning Planes Using the Edit Position and 
Dimensions Command 

In addition to manipulating the plane directly in the geometry area, you can position the section plane 
more precisely using the Edit Position and Dimensions command. You can move the plane to a new 
location as well as rotate the plane. You can also re-dimension the section plane.

In the case of section slices and boxes, it is the master plane that controls how the slice or box will be 
positioned.

 

This task illustrates how to position and re-dimension the section plane using the Edit Position and 
Dimensions command.

Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, 
NOZZLE2.cgr, REGULATION_COMMAND.cgr, REGULATOR.cgr, TRIGGER.cgr and VALVE.cgr.

They are to be found in the online documentation filetree in the common functionalities sample folder 
cfysm/samples.
1. Select Insert -> Sectioning from the menu bar, or click the Sectioning  icon in the DMU Space 

Analysis toolbar and create a section plane.

A Section viewer showing the generated section is automatically tiled vertically alongside the 
document window. The generated section is automatically updated to reflect any changes made to 
the section plane.

The Sectioning Definition dialog box is also displayed.
 2. Click the Positioning tab in the Sectioning 

Definition dialog box.



3. Click the Edit Position and Dimensions  

icon to enter parameters defining the position 
of the plane: 

The Edit Position and Dimensions dialog box 
appears.

4. Enter values in Origin X, Y or Z boxes to position the center of the plane with respect to the absolute 
system coordinates entered.
By default, the center of the plane coincides with the center of the bounding sphere around the 
products in the current selection. 

Using the Tools -> Options... command (DMU Sectioning tab under Digital Mockup ->DMU 
Space Analysis), you can customize settings for both the normal vector and the origin of the plane.
You can move the section plane to a new location. Translations are made with respect to the local 
plane axis system.

5. Enter the translation step directly in the Translation spin box or use spin box arrows to scroll to a 
new value, then click -Tu, +Tu, -Tv, +Tv, -Tw, +Tw, to move the plane along the selected axis by 
the defined step. 

Note: Units are current units set using Tools-> Options (Units tab under General-> Parameters 
and Measure).

Change the translation step to 25mm and click +Tw for example. The plane is translated 25 mm in 
the positive direction along the local W-axis.



 
You can rotate the section plane. Rotations are made with respect to the local plane axis system.

6. Enter the rotation step directly in the Rotation spin box or use spin box arrows to scroll to a new 
value, then click -Ru, +Ru, -Rv, +Rv, -Rw, +Rw, to rotate the plane around the selected axis by the 
defined step. 

Note: Units are current units set using Tools -> Options.

With a rotation step of 45 degrees, click +Rv for example to rotate the plane by the specified 
amount in the positive direction around the local V-axis.



 
You can edit plane dimensions. The plane height corresponds to its dimension along the local U-axis 
and the width to its dimension along the local V-axis. You can also edit slice or box thickness.

7. Enter new width, height and/or thickness values in the Dimensions box to re-dimension the plane.

The plane is re-sized accordingly.

 

 

●     Use Undo and Redo icons in the Edit Position and Dimensions dialog box to cancel the last action 
or recover the last action undone respectively.

●     Use the Reset Position  icon in the Positioning tab of the Sectioning Definition dialog box to 

restore the section plane to its original position.

●     You can also view and edit plane dimensions in the Properties dialog box (Edit -> Properties or 
via the contextual menu).
This command is not available when using the sectioning command.

8. Click Close in the Edit Position and Dimensions dialog box when satisfied.

9. Click OK in the Sectioning Definition dialog box when done.



More About the Section Viewer 
This task illustrates how to make the most of section viewer capabilities. 

 Orienting the section
Working with the 2D grid
Working with a 3D view

Detecting collisions
 Most of the commands described in this task are to be found in the Result tab of the Sectioning Definition 

dialog box or in the Section viewer contextual menu.
  

Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, 
REGULATION_COMMAND.cgr, REGULATOR.cgr, TRIGGER.cgr and VALVE.cgr.

They are to be found in the online documentation filetree in the common functionalities sample folder 
cfysm/samples.

 

1. Select Insert -> Sectioning from the menu bar, or click the Sectioning  icon in the DMU Space 

Analysis toolbar and create the desired section plane, slice or box and corresponding section.
 The Section viewer is automatically tiled vertically alongside the document window. It displays a front view 

of the section, and is by default, locked in a 2D view. Points representing the intersection of the section 
plane with any wireframe elements are also visible in the Section viewer. 

Notice that the section view is a filled view. This is the default option. The fill capability generates surfaces 
for display and measurement purposes (area, center of gravity, etc.). To obtain a correct filled view, the 
section plane must completely envelop the product.

To obtain an unfilled view, de-activate the Section Fill  icon in the Result tab of the Sectioning 

Definition dialog box.
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●     In the Section viewer, the appearance of the cursor changes to attract your attention to the existence 

of the contextual menu.

●     You can change the default settings for this window using Tools ->Options... command (DMU 
Sectioning tab under Digital Mockup ->DMU Space Analysis).

  
Orienting the Section

2. Orient the generated section.  

Flip and Rotate commands are to be found in the 
contextual menu. Right-click in the Section viewer 
and:

●     Select Flip Vertical  or Flip Horizontal  to 
flip the section vertically or horizontally 180 
degrees.

●     Select Rotate Right  or Rotate Left  to 
rotate the section right or left 90 degrees.

 

  Orienting the section using Flip and Rotate commands is not persistent. If you exit the section viewer, any 
flip and rotate settings are lost.

Working with the 2D Grid



3. Click the Result tab in the Sectioning Definition 

dialog box, then select the Grid  icon under 

Options to display a 2D grid. 

By default, grid dimensions are those of the 
generated section. Moving the section plane re-sizes 
the grid to results.

To size the grid to the section plane, clear the 
Automatic grid re-sizing check box in the DMU 
Sectioning tab (Tools -> Options..., Digital 
Mockup -> DMU Space Analysis).
You can edit the grid step, style and mode using the Edit Grid command.

4. Select the Edit Grid  icon to adjust grid 

parameters: 

The Edit Grid dialog box appears:

In the above example, the grid mode is absolute and 
the style is set to lines.

 



In the absolute mode, grid coordinates are set with respect to the absolute axis system of the document.

The grid step is set to the default value of 100. The arrows let you scroll through a discrete set of 
logarithmically calculated values. You can also enter a grid step manually.

Units are current units set using Tools-> Options (Units tab under General-> Parameters and 
Measure).

5. Scroll through grid width and height and set the grid 
step to 10 x 10.

6. Click the Relative mode option button: 

In the relative mode, the center of the grid is placed 
on the center of section plane.

7. Click the Crosses style option button.

Grid parameters are persistent: any changes to 
default parameters are kept and applied next time 
you open the viewer or re-edit the section.

8. Click the Automatic filtering checkbox to adjust the level of detail of grid display when you zoom in and 
out.

9. Right-click the grid then select Coordinates to display the coordinates at selected intersections of grid lines. 
The Clean All command removes displayed grid coordinates.



Note: You can customize both grid and Section viewer settings using the Tools -> Options... command 
(DMU Sectioning tab under Digital Mockup ->DMU Space Analysis). 

 Alternatively, select Analyze ->Graphic Messages ->Coordinate to display the coordinates of points, 
and/or  Name to identify products as your cursor moves over them. 

Clicking turns the temporary markers into 3D annotations. 
10.Click OK in the Edit Grid dialog box when done.

 

 
Working with a 3D View

By default, the Section viewer is locked in a 2D view. De-activating the 2D view lets you:

●     Work in a 3D view and gives you access to 3D viewing tools

●     Set the same viewpoint in the Section viewer as in the document window.

Returning to a 2D view snaps the viewpoint to the nearest orthogonal view defined in the Section viewer.

 
11.Right-click in the Section viewer and select the 2D Lock command from the contextual menu.

The Import Viewpoint command becomes available.
 12.Manipulate the section plane.

 

 



 

13.Right-click in the Section viewer and select the 
Import Viewpoint command from the contextual 
menu.

The viewpoint in the Section viewer is set to that of 
the document window.

 

14.Continue manipulating the section plane.



 

15.Return to a locked 2D view.

The viewpoint in the Section viewer snaps to the 
nearest orthogonal viewpoint in this viewer and not 
to the viewpoint defined by the local axis system of 
the plane in the document window.

 You can also save sectioning results in a variety of different formats using the Export As command in the 
Result tab of the Sectioning Definition dialog box or the Capture command (Tools ->Image ->Capture).

16.Click OK in the Sectioning Definition dialog box when done. 

If you exit the Sectioning command with the Section viewer still active, this window is not closed and filled 
sections remain visible.

 

P2 Functionality - Detecting Collisions

In DMU-P2, You can detect collisions between 2D 

sections. To do so, click the Clash Detection  icon in 

the Result tab of the Sectioning Definition dialog box.

Clashes detected are highlighted in the Section viewer. 

 

Collision detection is dynamic: move the section plane 
and watch the Section viewer display being updated.
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Measuring Minimum Distances 

This task explains how to measure minimum distance between products.

Open the AnalyzingAssembly01.CATProduct document.

1.
Click the Distance and Band Analysis  icon to calculate distances. 

The Edit Distance and Band Analysis dialog box appears.

Three computation types are available: 
 inside one selection: (default type): within any one selection, tests each product of 

the selection against all other products in the same selection.
 Between two selections: tests each product in the first selection against all products 

in the second selection.
 Selection against all: tests each product in the defined selection against all other 

products in the document.

2. Select Between two selections.

3. Select CRIC_TOP (CRIC_TOP.1) to define Selection 1.
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4. Click Selection 2 field and multi-select CRIC_BRANCH_3 (CRIC_BRANCH_3.1) and CRIC_JOIN 
(CRIC_JOIN.1)

You can select as many products as you want. Products will be placed in the active selection. 
To de-select products, reselect them in the specification tree or the geometry area.



5. Click Apply to calculate the distance. 

A Preview window appears visualizing selected products and the minimum distance 
(represented by a line, two arrows and a value). The Edit Distance dialog box expands to show 
the results.

If necessary, pan, zoom and/or rotate in the Preview window to visualize the results better.



Minimum distance and other information identifying all distance components is given in the 
expanded dialog box. X, Y, Z coordinates of start and end points on products selected for the 
distance calculation as well as products themselves are identified.

6. Click OK  to close the dialog boxes.



Improving Performances

As you know, you can set two different work modes prior to performing tasks in this workbench:

 
●     The Design Mode uses the original component documents. In other words, geometric data is 

available. All workbench commands are available if this mode is activated.

●     The Visualization Mode uses documents in cgr format. Only the external appearance of the 
component is visualized. The geometry is not available, which may be useful when you deal 
with sophisticated assemblies with large amounts of date but only need a few components to 
work on.

 This task illustrates the use of the Visualization mode and more precisely one way of improving the 
performances of the product.

●     Make sure that the Work with the cache system option is on (by default, the cache is not 
activated).
See Cache Management for CATProduct and CATProcess Document.

●     Make sure that the Automatic switch to Design mode option is on.
See General settings.

●     Make sure that the Compute exact update status at open option is manual.
See General settings.

1.  Open the AssemblyConstraint07.CATProduct document.

●     Using a cache system considerably reduces the time required to load your data.

●     When opening assembly documents in visualization mode, the Status Unknown icon 

 is always active, because the application cannot identify whether the assembly is 
up-to-date or not.

 Looking closer at the specification tree, you can notice that the nodes are expandable, 
components are displayed with the following format: Instance_Name 
[Document_Name] .

 

 
2.  Click the nodes to expand the two components.
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 Looking closer at the specification tree, you can notice that the nodes are not expandable, 
components are displayed with the following format: Product_Name (Instance_Name).

 

●     More information have been loaded from the cgr document, in this sample nothing. 
Information contained in the cgr document, about annotation, publication or contextual 
part for example, will be displayed.

●     The assembly has performed the update status: the Update icon  is grayed, the 
assembly is up to date.

 

3.  Click the Offset Constraint icon  to define an offset constraint between Part.5 and 

Blue_Part.

 According to the activated options, as you are moving your cursor onto any geometrical 
element of the parts in visualization mode, you can notice that an eye symbol is located 
next to your arrow.
This indicates that the geometrical element can be constrained, but take into account that 
once the it will be selected, the part will loaded in session.

 When setting the constraint on the Part.5, the CATPart document is loaded and appears 
under the related component.

 

 Then on the Blue_Part, the CATPart document is loaded and appears under the related 
component.



 

 Once the constraint is set, take a look at the tree.

 

 The fact that the application resolves constraints while working in visualization mode is 
possible only if your document contains data created from Release 10, and not using 
previous releases. 

 The application resolves constraints set from published elements from R11 version.

 Contextual parts in visualization mode remain in this mode if they are up-to-date, on 
contextual publication all version, on contextual geometry from R11 version.

Setting the Design or Visualization Mode
 To define a mode specific to a component, you simply need to select your component and then use 

the Representations -> Visualization Mode or Representations -> Visualization (or 
Design) Mode contextual commands.

 



Generating CATPart from Product 

This task will show you how to generate a CATPart from a product.

When you are generating the CATPart:

 
●     The command will capture all geometrical representation detected in all activated nodes that are 

children of the selected node. Each geometrical representation found, will be created in the 
CATPart as an isolated body.

●     Do not mistake the ObjectName Object -> Activate/Deactivate Component contextual 
command with the Representations -> Deactivate Node command. This last command 
deactivates the representation visualization of the component, not the component.

●     V4 model will be processed like the standard V4 to V5 interactive translation does it (copy break 
link result).

●     All positions of the geometrical representation are kept in the new CATPart relatively to the 
higher root product currently opened in the V5 session. In other words, the new CATPart origin 
is created by the command, using the root higher level of the opened CATProduct, which is not 
necessary the node selected by the user.

●     Visualization Mode is taken into account: if conversion is launched on a CATProduct open in 
visualization mode, all CATPart and model are processed. In fact they are switched one by one 
from Visualization Mode to Design Mode, processed and switched back to Visualization Mode. It 
avoids memory peak and allows you to convert very large products.

●     Elements in No Show are not converted.

●     Empty Geometrical Set and Geometrical Set containing only geometrical features in No Show 
are not processed (no empty body after creation).

●     For V4 model, all wireframe features are created inside one specific Geometrical Set named 
Wireframe.

●     Reference planes of created CATPart are in No Show.

●     Axis System of CATPart are not converted.

●     Only the color of part bodies are kept. This is means that color on sub-elements and Part Design 
features are not kept during process.

●     Only one product can be selected, the multi-selection is unavailable.

●     All processed objects are renamed with the path of instance in reference product. It allows user 
to understand easily from which CATPart comes each elements. Notice that it could generates 
very long names if the product structure is depth (or if instance name are long).

●     An empty PartBody is already created (default body of a new part).

Open the Assembly_01.CATProduct document.

1.  Select Product1 in the specification tree.
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2.  Select Tools->Generate CATPart from Product... menu.

 The Generate CATPart from Product dialog box appears.

 

●     The default name for the generated part is ProductName_AllCATPart.

●     The Merge all bodies of each part in one body option allows you to merge, for each 
part, in one body all its part bodies through an add operation and all its Geometrical 
Sets through the Change Geometrical Set command.

❍     The name of this body is the name of the instance the CATPart with its full path.

❍     Names of all geometrical features and bodies are kept as in original CATPart.

❍     This option is also efficient for V4 model.

 
3.  Click OK.

 The Product1_AllCATPart has been created.

 



Displaying the Assembly Mass Properties

This task will show you how to display the assembly mass properties.

The mass property of any assembly component is available from its Properties, in the Mechanical 
tab. The mass property is also available for component in Visualization mode and you can refine 
the mass to the main body or all the bodies of a Part component. The mass property is set 
according to the part material. If any any material has been defined, a density of 1 is taken into 
account.

●     Be sure that you are working in Design mode, see Cache Management for CATProduct and 
CATProcess Document.

●     Open the Assembly_01.CATProduct document.

 The option Automatic switch to Design mode is available for this command. For more about this 
option, refer to Access to geometry in the Infrastructure User's Guide.

1.  Right-click Assembly_01 in the specification tree and select Properties... from the 

contextual menu.

 The Properties dialog box is displayed. 

 
2.  Select the Mechanical tab.

 Three main properties are displayed:

●     Characteristics:

❍     Volume

❍     Mass

❍     Surface

●     Inertia center

●     Inertia matrix

 The Only main bodies option allows you to take into account only the main body of the 
related parts in the assembly, to determine the mechanical properties.
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3.  Redo the two previous steps, working with the Visualization mode.

 
●     The same characteristics and option are displayed.

●     Note that values can be different due that the geometry is not exact in Visualization 
mode, and has been approximated. A message is displayed in this case.



 

 
4.  Click OK.



Modifying an Assembly 

 
Replace Components: click this icon and select a component.

Reconnect a Replaced Representation: Right-click a component and select Representations -> 
Manage Representations from the contextual menu.

Reconnect Constraints: Double-click a constraint to edit it,



Replacing Components 

 

This task shows you how to replace components into an assembly.

 

In an assembly you may replace:

A component by a component completely different (a jack by a wheel for example).

A component by a component from the same family (a gearbox by another for example).

Both cases the constraints reconnection is only warranted either:

 Component's product structure is the same. 
 Instance's names of products in the replacing component are the same.
 Constraints reference the same published elements.

See Reconnecting Constraints.

 

1.  Select a component in the specifications tree.

2.  Click the Replace Component icon  in the Product Structure Tools toolbar.

 



Reconnecting a Replaced Representation

 

This task first consists in replacing a representation then in reconnecting geometrical elements.

 

Open the Reconnect01.CATProduct document.

 

1. Right-click on SCREW in the specifications tree. 

2. Select Representations -> Manage Representations from the contextual menu. 

The Manage Representation dialog box is displayed.
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3. Click on CRIC_SCREW.model in the Source field.

4. Click  Replace...  

The Associate Representation dialog box is displayed.
5. Navigate to open the CRIC_SCREW_NEW.model.

6. The Reconnect Representation dialog box is displayed. 



A window containing the assembly with the old representation is displayed in  the window to the left of the 
dialog box. 

A window containing only the new representation is displayed to the right of the dialog box. You are going to 
reconnect the geometrical elements in this window.

 
5. To reconnect the highlighted geometric element of the old representation, that is a line, select the axis of the 

new representation.

6. Select Plane  and select the circular face as shown to reconnect the plane.

Two "Yes" are now displayed in the Reconnect field.

6. Click OK to validate.

7. Click Close to close the Manage Representation dialog box.

The representation is replaced and constraints are valid.



Reconnecting Constraints

 

Reconnecting constraints means defining new supporting elements for these constraints. You perform this operation to 
correct mistakes you made while assembling components or the mistakes detected by updates.

This task shows you how to reconnect two constraints.

Open the AssemblyConstraint06.CATProduct document.

 

1. The assembly contains a contact and a coincidence constraint that need to be reconnected. Double-click the contact 
constraint to be reconnected.

2. In the Constraint Edition dialog box that appears, click More to access additional information.

The names of supporting elements are now displayed.

3. Click CRIC_BRANCH_3 then Reconnect.

4. Select the blue face as shown to specify the new supporting face.
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5. Click OK.

The contact constraint is reconnected:

6. Now select the coincidence constraint in the geometry or in the specification tree.

7. Select the Properties contextual command.

8. In the Properties dialog box that appears, click CRIC_BRANCH_3.

9. Click Reconnect...



The window that appears displays the components.



10. Select the axis passing through the circular faces.

11. Click OK to close the window.

12. Click OK to close the  Properties dialog box. 

Because they are only two constraints defined on this product, the application can compute several results. This is an 
example of what you can obtain:

 

  

 



Editing a Part in an Assembly Design Context 

This task shows you how to edit a Part (CATPart) in Assembly Design context. See Design in 
Assembly Context for more information.

Open the ManagingComponents01 Product document.

1.  Click on the + sign to the left of the CRIC_SCREW (CRIC_SCREW.1) component in the 

specification tree.

 The CATProduct is identified by the Product document icon.

 
2.  Double-click on the CRIC_SCREW to open the Part Design workbench.

Do not mistake the Product document (CATProduct) for the Part document (CATPart).
The CATPart is identified by the Part Design document icon.
If the Product document containing the Part document is set to Visualization Mode, 
editing the Part document switch automatically the Product document to Design Mode. This 
is not an Assembly Design behavior because the Design Mode is the only mode for Part 
document.

 

 The Part Design workbench is displayed.

 
3.  Click on the + sign to the left of Part Body.
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4.  Double-click the feature you need to edit. For example, double-click on Pad2 to display the 

Pad Definition dialog box. You can then enter the parameters of your choice.

For information about Part Design and the Sketcher , please refer to Part Design User's 
Guide and Dynamic Sketcher User's Guide respectively.

 
5.  Once you have edited the part, double-click on ManagingComponents01 to return into 

Assembly Design workbench. The specification tree remains unchanged.

 
6.  Double-click on the part CRIC_SCREW to open Part Design workbench again.

 
7.  Select any circular face of CRIC_BRANCH1 and enter the Sketcher workbench.

 
8.  Create a circle and set a coincidence constraint for example:

 

 
9.  Exit from the Sketcher and double-click on ManagingComponents01 to return into Assembly 

Design workbench.

 Assembly Design workbench is then displayed and a green wheel is added to CRIC_SCREW 

in the tree to represent the contextual nature of the component: .
Note however that this symbol is displayed only if the option Keep link with selected object 
is selected. For more information, please refer to Part Design User's Guide.



 

Contextual components are considered as the children of the components used for their creation. 
This means that if you delete these support components, you will need to consider if you wish to 
delete contextual components or not. Remember, you can choose to delete affected elements by 
checking the Delete all children option in the Delete dialog box.

 

Copy/Paste As Special command
 If you wish to apply the Copy -> Paste As Special command to parts included into your assembly, 

remember the following: if you have already used the As Result With Link option when pasting 
Part.1 onto Part.2, you then cannot paste Part.2 onto Part.1 using the As Result With Link option. 
An error message is issued informing you that a cycle has been detected. For more about Copy -> 
Paste As Special command, please refer to Infrastructure User's Guide.



Assembly Features 

 Prior to creating assembly features, keep in mind the following:

●     You can create assembly features only between the child components of the active product. The 
active product at least must include two components which in turn must contain one part at 
least.

●     You cannot create assembly features between two geometric elements belonging to the same 
component.

●     You can only create assembly features on a component which allows part feature creation to be 
performed in assembly context. This excludes cross references, the component containing the 
inputs is contextual from one or several affected components, and external references, affected 
components which are already referenced from another assembly document.

 See Assembly Features reference for more information.

 The different assembly features you can create are:

Split: click this icon, select the splitting face or surface, define the parts you need to split and define 
the portion of material to keep.

Hole: click this icon, select a face to define the hole location, define the parts on which you need to 
make the hole and define your hole.

Hole Series: in the Assembly Features Definition dialog bow, click the Series tab and select the 
parts of interest prior to defining holes.

Pocket: click this icon, select the profile to be extruded, define the parts from which you need to 
remove material and define the pocket.

Remove: click this icon, select the body to removed and define the parts from which you need to 
remove material.

Add: click this icon, select the body to be added and define the parts to which you need to add 
material.



Assembly Split 

 

The Assembly Split command splits parts rapidly and very productively. You could actually split each 
part in the Part Design workbench, but the Assembly Split command is more  productive since it 
requires only one interaction.  

This task  shows you how to split a product including four parts. You will actually split three of these 
parts by using a surface.

Open the AssemblySplit.CATProduct document.  Ensure the design mode is on.

 

1.  
Click the Split icon:  

2. Select the splitting surface, that is Loft.1.

The dialog box that appears displays the names as well as the paths of the parts that may be 
affected by the split action.

 

The assembly feature's name now appears in the top left corner of the dialog box. If desired, you 
can edit this name.
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3. The frame 'Affected parts' is exclusively reserved for the parts you wish to use. For the purposes 
of our scenario, you are going to split Bulkhead A.1, Bulkhead A.2 and Bulkhead B. Note that 
Bulkhead A.2 and Bulkhead A.1 are two instances of Bulkhead A. 

Move the parts to the list 'Affected parts". To do so, select Bulkhead A.1 and click the   
button. 



4. Repeat the operation for the other two parts. Alternatively, double-click each part.

The other three buttons let you move the names of the parts from one list to another too:

  moves all selected parts to the list 'Affected parts' 

  moves all selected parts to the list 'Parts possibly affected'

  moves the selected part to the list 'Parts possibly affected'

The Split Definition dialog box that has appeared, indicates the splitting element.

5. Arrows in the geometry indicate the portion of parts that will be kept. If the arrows point in the 
wrong direction, click them to reverse the direction.

6. Check the option Highlight affected parts to clearly identify the parts to split.



7. Click OK to confirm. 

The parts are split. Material has been removed from Bulkhead A.1, Bulkhead A.2 and Bulkhead B. 
Conversely, Bulkhead C is intact.

A new entity 'Assembly Features' appears in the specification tree. It contains the assembly split 
referred to as 'Assembly Split.1" and the name of affected parts. 

Moreover, this feature has generated a split feature in Bulkhead B and two split features in  
Bulkhead A.1 and Bulkhead A.2, these parts being instances of a same original part. An arrow 

symbol identifies these splits  in the tree, meaning that a link exists between Assembly 
Split.1and them.



Editing an Assembly Split

To edit an assembly split, double-click 'Assembly Split.X' entity then you can either: 
 modify the list of the parts you wish to split
 change the splitting surface
 redefine the portions of material to keep

If you need to cut the link between a generated split  and Assembly Split.X, just use the 
Isolate contextual command. You will then obtain a 'traditional' split feature as if you had 
designed it in Part Design and you will be able to edit it in Part Design.



 

Reusing Part Design Splits

 
To increase your productivity, you can create Assembly splits from existing Part Design splits, or 
more precisely by reusing the specifications you entered for designing Part Design splits. To do so, 
just proceed as follows:

 

1.  Click the Split icon .

 2. Select the Part Design split of interest.

 3. Both the Split Definition and the Assembly Features Definition dialog boxes display. You then just 
need to specify the parts to split.  

The assembly split inherits the specifications as displayed in the Part Design Split Definition dialog 
box. You can edit these specifications at any time. Editing an Assembly feature created in this way 
does not affect the specifications used for the Part Design feature.

 
Reusing Assembly Design Splits

 The application also lets you reuse Assembly Splits specifications to accelerate the design process. 
In this case, you just need to select the existing assembly split, click the Assembly Split icon and 
then select a face. Only the Assembly Features Definition dialog box appears to let you determine 
the parts of interest.



Assembly Hole 

The Assembly Hole command lets you create holes going thru different parts. You could actually 
create holes for each part in the Part Design workbench, but the Assembly Hole command available 
in Assembly Design workbench creates holes more rapidly and more productively: the command 
creates a hole going thru several parts in only one interaction. 

 You can create distinct shapes of holes going thru the individual parts of an assembly and this, in one 
shot. To know how to do this, please refer to Using Hole Series.

This task  shows you how to create a hole on a product including three parts, but you will create the 
hole on two parts only.

Open the AssemblyHole.CATProduct document.

1.  Click the Hole icon:  

 
2.  Select the purple face as shown to define the location of the hole:

 

 The Assembly Features Definition dialog box appears.
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 The dialog box displays the names as well as the paths of the parts that may be affected by 
the hole creation. 

 The assembly feature's name appears in the Name field. If desired, you can edit this name.

 The frame Affected parts is exclusively reserved for the parts you wish to use. Purple Part is 
displayed in this frame.

 Note that the Hole Definition dialog box is displayed.

 
3.  As you wish to create a hole between Part5 and Purple Part, move Part5 to the list Affected 

parts.

 The other three buttons lets you move the names of the parts from one list to another too:



 

●      moves all selected parts to the list Affected parts.

●      moves all selected parts to the list Parts possibly affected.

●      moves the selected part to the list Parts possibly affected.

 
4.  Check the option Highlight affected parts to clearly identify the parts.

 At this point, you can now define the hole you wish.

 

You cannot edit the hole positioning sketch from the assembly hole definition, this why the 
icon still grayed.
If you wish to edit it, double-click the Positioning Sketch created in the part from which you 
have defined the assembly hole, or edit the reused hole.

 Whatever hole you choose, you need to specify the limit you want. If you do not specify a 
depth value, four types of limits are available:



 

 

Blind Up to Last Up to Plane Up to Surface

 
5.  Set the Up to Last option. The application will extend the hole from the sketch plane to the 

last face encountered.

 
6.  Enter 25mm as the diameter value.

 By default, the application creates the hole normal to the sketch face. But you can also define 
a creation direction not normal to the face by deselecting the Normal to surface option and 
selecting an edge or a line.

 If you are designing a blind hole, you can set the Bottom option to V-Bottom to create a 
pointed hole and then enter the angle value of your choice.

 Clicking the Type tab lets you create the following holes:

 

 

Simple Tapered Counterbored Countersunk Counterdrilled

 Make sure the option Simple is set. 

 Clicking the Thread Definition tab lets you access to the options defining threads. For more 
information about threads and holes, please refer to Part Design User's Guide.

 
7.  Click OK to confirm.

 The hole is created on Part 5 and Purple Part. Conversely, CRIC_FRAME is intact.



 

 A new entity Assembly features appears in the specification tree. It contains the assembly 
hole referred to as Assembly Hole.1 and the affected parts.

 Moreover, this feature has generated a hole in each part. An arrow symbol identifies these 

holes  in the tree, meaning that a link exists between Assembly Hole.1and them.

 

Editing an Assembly Hole
To edit an assembly hole, double-click Assembly Hole.X entity then you can either: 

 
●     modify the list of affected parts.

●     edit the hole.

 If you need to cut the link between a generated hole and Assembly Hole.1, just use the Isolate 
contextual command. You will then obtain a classical hole as if you had designed it in Part Design and 
you will be able to edit it in Part Design.

 

Reusing Part Design Holes
 To increase your productivity, you can create Assembly holes from existing Part Design holes, or 

more precisely by reusing the specifications you entered for designing Part Design holes. To do so, 
just proceed as follows:

Before reusing Part Design hole, take note that:
●     You cannot reuse hole for which the reference geometry for creation is not a planar surface.

●     You cannot reuse a hole with the Up to next option, because this option is not applicable for 
assembly hole.

●     You cannot re-affect an assembly hole on the part which contains the part hole, except if the 
diameter of the assembly hole exceed the diameter of the part hole, or if the assembly hole 
location is different. In fact, you cannot drill vacuum.



 

1.  Click the Hole icon: 

 
2.  Select the Part Design hole of interest.

 
3.  Both the Hole Definition and the Assembly Features Definition dialog boxes display. You 

then just need to specify the parts to pierce.

 The assembly hole inherits the specifications as displayed in the Part Design Hole Definition 
dialog box. You can edit these specifications at any time. Editing an Assembly feature created 
in this way does not affect the specifications used for the Part Design feature.

Reusing Assembly Design Holes
The application also lets you reuse Assembly Holes' specifications to accelerate the design process. In 
this case, you just need to select the existing assembly hole, click the Assembly hole icon and then 
select a face. Only the Assembly Features Definition dialog box appears to let you determine the parts 
to drill.

   



Using Hole Series

 

The new concept of "hole series" lets you create different holes cutting the individual parts of an assembly. 
The "series" option,  available in the Hole command lets you determine the parts that are to be cut or not, and 
the hole types to define for these parts. 

In this task, you will create one assembly hole feature composed of three different holes cutting four parts.

Open the AssemblyHole2.CATProduct document.

 

1.  
Click the Hole icon .

2. Select the upper purple face to define the location of the hole: 

The Hole Definition and Assembly Features Definition dialog boxes appear.  

The Assembly Features Definition dialog box displays the names as well as the paths of the parts that 
may be affected by the hole creation. For more details, refer to the task "Assembly Hole".

 
3. 

 Click the button  to move all parts to the list 'Affected parts'. 

 

4. To define the hole cutting the assembly, set these parameters: " Up to Last", 10 mm as the diameter 
value,  "Counterbored", 18 mm as the diameter option.  

The application previews the counterbored hole.

 

Creating Series

A hole series gathers one or more assembly parts that must be cut by a hole different from the hole 
previously defined.

5. Click the button "Add Series". 

A new tab "Series 1" displays, containing all parts selected in the "affected parts" field of the Default tab.
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6. To identify the parts you wish to include in Series 1, multi-select Part5 and Part6 then click the Select 
button.

The mention "Yes" now displayed in the Selected field, confirms that Series 1 includes these parts that 
will be cut by a hole which parameters are still to be defined.

Series 1 then includes two parts through which the hole will pass. On the contrary, Part7 and Purple part 
are excluded from the series as indicated by the mention "No".

7. 
To define the hole you need for Series 1, enter these parameters: "Up to Last", 12 mm as diameter value 
and "Simple" in the Hole Definition dialog box.



The application previews this hole type on the purple 
face.

 8. Click the button "Add Series" again to create another series. 

A new tab "Series 2" displays, containing all parts selected in the "affected parts" field of the Default tab..

 9. 

Select Part 7 then click the Select button to set this part as the only part composing the series. 

The mention "Yes" confirms that this part will be cut by a new hole which parameters are still to be 
defined.

 
Another way of selecting the part is to double-click its name. 

 10. To define the hole you need for Series 2, enter these parameters: "Blind", 10 mm as diameter value, 
160mm as depth value, "V-Bottom",  "Simple", "Threaded" and the thread values of your choice in the 
Hole Definition dialog box.

 

 The application previews this hole type on the purple 
face.

 
 Note that the Default button removes one part from a series.



 11. Click OK to confirm.

The hole defined through three series cuts the 
assembly. 

 

 

In the specification tree, the Assembly Hole node 
displays the different parts cut by the Hole feature. 
Note that the icon identifying the threaded hole 
differs from the other icons.

 

  

 



Assembly Pocket  

Creating a pocket consists in extruding a profile and removing the material resulting from the 
extrusion. You could actually create pockets for each part in the Part Design workbench, but the 
Assembly Pocket command available in Assembly Design workbench creates pockets more rapidly 
and more productively: the command creates a pocket on several parts in only one interaction.

 This task shows you how to create a pocket by removing material from two parts.

Open the AssemblyHole.CATProduct document and sketch a rectangle on the purple face.

1.  Click the Pocket icon  

 
2.  Select the profile you created.

 

 You can use profiles sketched in the Sketcher workbench, sub-elements of sketches or 
planar geometrical elements created in the Generative Shape Design workbench.

 The Assembly Features Definition dialog box appears.
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 The dialog box that appears displays the names as well as the paths of the parts that may 
be affected by the extrusion.

 The assembly feature's name appears in the Name field. If desired, you can edit this name.

 The frame Affected parts is exclusively reserved for the parts you wish to use. Purple Part 
is displayed in this frame.

 Note that the Pocket Definition dialog box is displayed.

 
3.  The frame Affected parts is exclusively reserved for the parts you wish to use. As you wish 

to create a pocket between Part5 and Purple Part, move them to the list Affected parts. To 

do so, click the  button. Alternatively, double-click each part.

 The other three buttons lets you move the names of the parts from one list to another too:

 

●      moves all selected parts to the list Affected parts.

●      moves all selected parts to the list Parts possibly affected.

●      moves the selected part to the list Parts possibly affected.



 
4.  Check the option Highlight affected parts to clearly identify the parts.

 

 You can define a specific depth for your pocket (using the Dimension and Depth entry fields) 
or set one of these options to define the pocket type:

 
●     Up to last 

●     Up to plane

●     Up to surface

 If you wish to use the Up to plane or Up to surface option, you can then define an offset 
between the limit plane (or surface) and the bottom of the pocket.

 The other options available are:

 
●     Mirrored extent: mirrors the extrusion using the specifications defined for Limit1.

●     Reverse Direction: inverts the extrusion direction.

 Additional options appear if you click the More button.

 
●     You can define Limit2 as the second limit by using the same options as for Limit1 

(Dimension, Up to last, up to plane, up to surface). 

●     You can choose between a direction normal to the sketch or define a new direction by 
selecting geometry.

 
5.  For the purposes of our scenario, enter 110mm as the depth value and click OK to confirm. 

For more information about pockets, please refer to Part Design User's Guide.



 The pocket is created on both parts.

 

 A new entity 'Assembly features' appears in the specification tree. It contains the assembly 
pocket referred to as 'Assembly Pocket.1" and the affected parts. 

 Moreover, this feature has generated a pocket in each part. An arrow symbol identifies 

these pockets  in the tree, meaning that a link exists between Assembly Pocket.1and 
them.

 



 

Editing an Assembly Pocket
To edit an assembly hole, double-click Assembly Pocket.X entity then you can either: 

 
●     modify the list of affected parts.

●     edit the pocket.

 If you need to cut the link between a generated pocket and Assembly Pocket.1, just use the 
Isolate contextual command. You will then obtain a 'traditional' pocket as if you had designed it in 
Part Design and you will be able to edit it in Part Design.

 

Reusing Part Design Pockets



 To increase your productivity, you can create Assembly pockets from existing Part Design pockets, 
or more precisely by reusing the specifications you entered for designing Part Design pockets. To do 
so, just proceed as follows:

Before reusing Part Design pocket, note that:
●     You cannot reuse a pocket with the Up to next option, because this option is not applicable for 

assembly pocket.

●     You cannot re-affect an assembly pocket on the part which contains the part pocket, except if 
the size of the assembly pocket exceed the size of the part pocket, or if the assembly pocket 
location is different. In fact, you cannot dig vacuum.

 

1.  Click the Pocket icon: 

 
2.  Select the Part Design pocket of interest.

 
3.  Both the Pocket Definition and the Assembly Features Definition dialog boxes display. 

You then just need to specify the parts to extrude.

 The assembly hole inherits the specifications as displayed in the Part Design Hole 
Definition dialog box. You can edit these specifications at any time. Editing an Assembly 
feature created in this way does not affect the specifications used for the Part Design 
feature.

Reusing Assembly Design Holes
The application also lets you reuse Assembly Pockets' specifications to accelerate the design 
process. In this case, you just need to select the existing assembly pocket, click the Assembly 
pocket icon and then select a face. Only the Assembly Features Definition dialog box appears to let 
you determine the parts to dig.

   



Assembly Remove 

 

This task  shows you how to remove a body from two parts in assembly context.

Open the AssemblyRemove_Add.CATProduct document.

 

1. 
 Click the Remove icon: 

2. Select Body.1 from MoldedPart as the body to be removed.

3. The dialog box that appears displays the names as well as the paths of the parts that may be 
affected by the removal.

 

The assembly feature's name now appears in the top left corner of the dialog box. If desired, you 
can edit this name.
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The frame 'Affected parts' is exclusively reserved for the parts you wish to use. For the purposes of 
our scenario, you are going to remove material from Part2 and Part3. 

Move these parts to the list 'Affected parts". To do so, select Part2 and click the   button. 
Repeat the operation for Part3. Alternatively, double-click each part.

The other three buttons lets you move the names of the parts from one list to another too:

  moves all selected parts to the list 'Affected parts' 

  moves all selected parts to the list 'Parts possibly affected'

  moves the selected part to the list 'Parts possibly affected'



The Remove dialog box that has appeared, 
indicates the part to be removed.

4. Check the option Highlight affected parts to clearly identify the parts affected by the operation.

5. Click OK to confirm. 

Material is removed from Part 2 and Part3.

6. To better visualize the result, put Part 5 and Body.5 in no show mode. You can see the portion of 
material that has been removed.



A new entity 'Assembly Features' appears in the specification tree. It contains the assembly 
removal referred to as 'Assembly Remove.1" and the name of affected parts. 

Moreover, this feature has generated a remove feature in Part2 and a remove feature in Part 3. An 

arrow symbol identifies these removals  in the tree, meaning that a link exists between 
Assembly Remove.1and them.



Editing an Assembly Remove

To edit an assembly remove operation, double-click 'Assembly Remove.X' entity. You can then 
modify the list of the parts possibly affected by the removal.

 

Reusing Part Design Remove Features

 

To increase your productivity, you can create Assembly Remove Features from existing Part Design 
Remove features, or more precisely by reusing the specifications you entered for designing Part 
Design remove features. To do so, just proceed as follows:

 
1. 
 

Click the Remove icon .

 2. Select the Part Design Remove feature of interest.

 3. Both the Remove Definition and the Assembly Features Definition dialog boxes display. You then 
just need to specify the parts of interest.  

The assembly remove feature inherits the specifications as displayed in the Part Design Remove 
Definition dialog box. You can edit these specifications at any time. Editing an Assembly feature 
created in this way does not affect the specifications used for the Part Design feature.

 

 
Reusing Assembly Design Remove Features



 

 

The application also lets you reuse Assembly Remove Features' specifications to accelerate the 
design process. In this case, you just need to select the existing assembly remove feature, click 
the Assembly remove icon and then select a face. Only the Assembly Features Definition dialog box 
appears to let you determine the parts of interest.

 

   



Assembly Add 

 

This task  shows you how to add several parts belonging to a same product.

Open the AssemblyRemove_Add.CATProduct document, perform the Asssembly Remove as explained 
in the documentation and put Part5 and Body.5 in show mode.

 

1.  
Click the Add icon:  

2. Select Body.5 as the body to be added.

The dialog box that appears displays the names as well as the paths of the parts that may be 
affected by the add operation.

The assembly feature's name now appears in the top left corner of the dialog box. If desired, you 
can edit this name.
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3. The frame 'Affected parts' is exclusively reserved for the parts you wish to use. For the purposes 
of our scenario, you are going to add Body.5 to Part5. 

Move Part5 to the list 'Affected parts". To do so, select Part5 and click the   button.

The other three buttons lets you move the names of the parts from one list to another too:

  moves all selected parts to the list 'Affected parts' 

  moves all selected parts to the list 'Parts possibly affected'

  moves the selected part to the list 'Parts possibly affected'

The Add dialog box that has appeared, indicates 
the part to be added.



4. Check the option Highlight Impacted Parts to clearly identify the parts affected by the operation.

5. Click OK to confirm. 

6. To better visualize the result, put Part2 and Part3 in no show mode. You can see the portion of 
material that has been removed.

A new entity 'Assembly Features' appears in the specification tree. It contains the assembly 
removal referred to as 'Assembly Add.1" and the name of affected parts. 

Moreover, this feature has generated a remove feature in Part5. An arrow symbol identifies this 

addition  in the tree, meaning that a link exists between Assembly Add.1and this remove 
feature.



 
Editing an Assembly Add

 To edit an assembly add operation, double-click 'Assembly Add.X' entity. You can then modify the 
list of the parts possibly affected by the addition.

Reusing Part Design Add Features

 
To increase your productivity, you can create Assembly Add Features from existing Part Design 
Add features, or more precisely by reusing the specifications you entered for designing Part Design 
Add features. To do so, just proceed as follows:



 

1.  Click the Add icon .

 2. Select the Part Design add feature of interest.

 3. Both the Add Definition and the Assembly Features Definition dialog boxes display. You then just 
need to specify the parts of interest.  

The assembly add feature inherits the specifications as displayed in the Part Design add Definition 
dialog box. You can edit these specifications at any time. Editing an Assembly feature created in 
this way does not affect the specifications used for the Part Design feature.

 
Reusing Assembly Design Add Features

 

The application also lets you reuse Assembly Add Features' specifications to accelerate the design 
process. In this case, you just need to select the existing assembly add feature, click the Assembly 
add icon and then select a face. Only the Assembly Features Definition dialog box appears to let 
you determine the parts of interest.

 



Assembly Symmetry

Performing a Symmetry: click this icon, select the reference plane and the component, then check 
required options. 

 Modifying a Symmetry

 Rotating a Component by Using the Symmetry Command



Performing a Symmetry on a Component  

 

This task teaches you how to obtain new parts, products or instances by means of symmetry operations.

The Symmetry command also lets you obtain new instances by translation as explained at the end of the 
scenario.

In this section, you will find the following information:

●     Scenario

●     Components Chosen for Duplication

●     More About the Mirror, New component Option

●     Translation

●     Keep Link Options

●     Part Including Surfacic Elements

●     New Components or New Instances?

 

If you do not have a Part Design license (PD1 or GSD), the options Keep link in position and Keep link with 
geometry will be grayed out in the Assembly Wizard dialog box.

If you do not have an Assembly Design license (ASD), Assembly features do not appear in the Specification 
Tree.

 

Open the Symmetry1.CATProduct  document.

 

1. 

Click the Symmetry icon . 

The Assembly Symmetry Wizard dialog box displays, prompting you to select the reference plane.

  

2. Select the element used as the reference of the symmetry. This element can be a plane or any planar face 
that the system recognizes as a plane. Select Plane.1.
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  Components chosen for duplication

The component you select for duplication must be the child of the active product.

Example 1: the element to duplicate is not a symmetrical element 

In this case, the symmetrical element will be a new component

3. Select NewDoor (NewDoor.1) as the product to be duplicated.

NewDoor (NewDoor.1) is highlighted and the symmetry is previewed. 



 The Assembly Symmetry Wizard dialog box appears. It displays the list of all elements that will be 
duplicated, that is all components composing NewDoor product: Door.1 and Pane.1.

The three icons to the left of the window represent symmetries as well as the creation of new components.

 

 The Rotation, same instance option moves the selected geometry symmetrically in relation to a plane. 
It does not create any new geometry. In short, the Bill of Material is not affected by the resulting 
geometry. For an example, please refer to Rotating a Component by Using the Symmetry Command.

Notes 
●     If you wish to preview the symmetry of the door only, select Symmetry of Door (Door.1). Likewise, 

if you prefer to preview the symmetry of the pane, simply select Symmetry of Pane (Pane.1).

●     Instead of new components, you can also create new instances for Symmetry of Door (Door.1) or 
Symmetry of Pane (Pane.1). To do so, select them and check the option "Rotation (new instance)". 
For more about this option, refer to Example 2.

●     If the product to duplicate includes a part composed of several bodies, only the part body of this part 
is taken into account by the Symmetry command.

4. Click Finish to confirm the operation. 

A window appears, displaying results:



5. Click Close. You obtain a second door:

The new component Symmetry of NewDoor (Symmetry of Door.1) is displayed as well as the parts it 
contains (Symmetry of Door and Symmetry of Pane).  

A new entity Assembly features also appears in the specification tree. It contains the symmetry referred 
to as Assembly Symmetry.1 which in turn contains the symmetry plane and the affected component.



  

More About the Mirror, New component option

Once you have created a symmetrical component using the Mirror, New component option, you cannot 
apply the Symmetry command with the Mirror, New component option to:

●     Any instance of the initial component (even if the reference plane is distinct).

●     The component obtained by symmetry.

Example 2: the element to duplicate is a symmetrical element itself 

In this case, the symmetrical element will be a new instance.

6. 
Click the Symmetry icon .  

The Assembly Symmetry Wizard dialog box displays.

7. Select the element used as the reference of the symmetry: select Plane.1.

8. Select Wheel (Wheel.2).

 

The wheel is highlighted and the symmetry is previewed. 



The Assembly Symmetry Wizard dialog box appears. It displays the list of all elements that will be 
duplicated: all components composing Wheel Assembly product.

9. Select Symmetry of jantes from the list. Only the symmetry of that component is now previewed in the 
geometry area.



10. Check the Rotation, new instance 
option. 

A new icon reflects this change in the 
list.

 

11. The object is positioned with respect to Plane.1. Now, as it is intrinsically symmetrical, you need to define 
which of its three reference planes must be symmetrical with respect to Plane.1. For example, check XZ 
plane option.

It is moved accordingly.

12. Check XY plane option.

It is re-positioned.

13. Eventually, the first option is the right one. Check YZ plane. The symmetry is performed.



14. Click Finish to confirm the operation.

A window appears, displaying results. Two new components and one instance have been created.

15. Click Close.

The new component Symmetry of Wheel (Symmetry of Wheel.2.1) is displayed in the specification 
tree. It contains one new instance (jantes (symmetry of jantes.1.1) and one new component 
(Symmetry of pneu (Symmetry of pneu.1.1).

The Assembly features entity contains the new symmetry referred to as Assembly Symmetry.2 which 
in turn contains the symmetry plane and the affected component.



Translation
16.

Click the Symmetry icon . 

The Assembly Symmetry Wizard dialog box displays.

17. Select Plane.1 as the reference to compute the translation.

18. Select the Wheel (Wheel.1) as the component to be translated.

19. Check the Translation, new instance option.  

A new icon  reflects this change. 

To calculate the translation, the application projects the center of the axis system onto the plane you 
selected. The distance between the center and the plane is repeated twice.

20. Click Finish to confirm the operation.  

A window appears, displaying results:



21. Click Close. The wheel is translated:

Keep Link Options

●     The Keep link in position option guarantees associativity with the initial part or product: if you edit 
their positions, symmetrical elements inherit these modifications and are therefore repositioned 
accordingly.

●     The Keep link with geometry option guarantees associativity with the geometry of the initial part: if 
you edit its shape, symmetrical elements inherit these modifications. However this type of associativity 
is restricted to elements made visible via the External View... command or to Part Bodies. For more 
information, refer to Generative Shape Design User's Guide and Part Design User's Guide respectively.

Parts Including Surfacic Elements
If you need to perform a symmetry on a part including surfacic elements, the application creates the 
corresponding symmetry provided that an external view of these elements has been previously specified.  

Conversely, if these elements  have not been specified as such, the symmetry cannot be performed.

For more about the External View command, please refer to the Generative Shape Design User's Guide.

In the Assembly Symmetry Wizard dialog box, the External View or Part Body options inform you 
about the result you will obtain. For example, if the Part Body option is checked, the Symmetry 
command will affect the Part Body, not surfacic elements.

 

New Components or New Instances?



If you compare the symmetry obtained by using the Mirror, new component option... 

... to the symmetry obtained first using the Mirror, new component option, then the Rotation, new 
instance option, then reusing Mirror, new component, both results are different as indicated by the 
icons:

The behavior is the following: after changing the symmetry type, that is Rotation, new instance, to 
reuse the Mirror, new component option, the children of the product to be mirrored remain as new 
instances whereas the product is assigned the new component definition. 

What you need to do

To make sure that you obtain the same results for both operations, you need to use the Mirror, new 
component, all children contextual command available in the dialog box instead of checking Mirror, 
new component.

Result:



 

 For more information about the Symmetry command, refer to Modifying a Symmetry.



Modifying a Symmetry

 

This task shows you how to edit a symmetry and what happens when you replace or delete the original 
component.

 

Open the Symmetry1.CATProduct  document and perform the steps from 1 to 5 of the scenario 
described in Performing a Symmetry.

This scenario assumes that the automatic update mode is on.

 

1. Double-click Assembly Symmetry.1 in the specification tree. 

The Assembly Symmetry Wizard displays. Two new fields are available at the top right corner of 
the dialog box.

2. 

Enter a new name in the Name field. For example, "New Symmetry".

3. Click the arrow to change the symmetry plane. 

The <None> term appears in the field.
4. Select, for example a door's face 

as  the new symmetry plane. 

The field now contains 
"Door.1/Face". 
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5. Click Finish to confirm and close the 
dialog box.

Once updated, the symmetry looks 
like this:

Replacing the initial component
6. Select Door (Door.1) and use the Components -> Replace Component... contextual command.

7. From the cfyug/samples directory 
select Door.2.CATPart as the 
replacing component. 

 

The symmetry is no longer valid. 
You need to be redefine it as 
indicated in the specification tree.

8. Double-click New Symmetry. 

The Assembly Symmetry Wizard dialog box displays.



9. Select Door.2 (Door.1) and check 
the option "Mirror, new 
component".

10. Click Finish to confirm. 

The new door is obtained by 
symmetry.

Deleting the original component
11. Delete Pane (Pane.1). 

Its symmetrical element is deleted too.

The assembly and the specification tree now look like this:





Rotating a Component by Using the Symmetry 
Command

 
This task shows you how to rotate a component by using the new option "Rotation, same instance". 

 

Notes 
this command is the only one you will use to save transformations within the Enovia database. 
The positioning matrix will be saved in the Enovia database.

 

Open the Symmetry2.CATProduct document. 

This scenario assumes that the automatic update mode is on.

 

1. 

Click the Symmetry icon  to move LeftDoor.

The Assembly Symmetry Wizard dialog box displays, prompting you to select the mirror plane.

2. Select the element used as the reference of the 
symmetry: select Plane.1. This plane is used to 
position the assembly.

Note that the local axes of the two products are 
superimposed, in our example, to make sure that 
the final products will be in front of each other.

3. Select LeftDoor (LeftDoor.1) as the component to be moved.

LeftDoor (LeftDoor.1) is highlighted and the symmetry is previewed. 
4. Check the option "Rotation, same instance" and 

"XZ plane". This plane is specific to LeftDoor and 
is used to define the axis for the rotation. 

The axis is the intersection between this plane 
and the first plane you selected (see step1).
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When using the "Rotation, same instance" option, the associativity options "Keep link in position " 
and "Keep link with geometry" are not available. For more information, see Performing a 
Symmetry.

5. Click Finish to confirm the operation.

The Assembly Symmetry Result  window appears, indicating that no component, nor any instance 
have been created.

6. Click Close. LeftDoor (LeftDoor.1) has been moved in relation to the selected plane. No geometry 
has been created so that the bill of material remains unchanged.

 



Flexible Sub-Assemblies 

In the product structure from earlier versions you could only move rigid components in the parent 
assembly. Now, in addition to this behavior, you can dissociate the mechanical structure of an 
assembly from the product structure, and this within the same CATProduct document. As a 
consequence, you can move the components of a sub-assembly in the parent assembly. 

 In a first time, this task recalls the behavior of rigid assemblies, then illustrates how to make sub-
assemblies flexible and how constraints defined in the reference document affect them. Eventually 
you learn how to analyze the mechanical definition of an assembly whenever this assembly includes 
flexible sub-assemblies (and components attached together, see Fixing Components Together).

●     When a sub-assembly is flexible, you can apply updates to it, move it when constrained and set 
constraints to it.

●     What you need to keep in mind is that rigid sub-assemblies are always synchronous with the 
original product, whatever mechanical modification you perform.
Flexible sub-assemblies can be moved individually, without considering the position in the 
original product.
Since Release 7, you can edit the constraints defined for flexible sub-assemblies. The changes 
made to these constraints do not affect the constraints defined for the original product 
contained in the reference document.

●     You can edit the following attributes:
❍     values

❍     orientation

❍     driving/driven properties

●     Set of constraints in a rigid sub-assembly will be removed when you make it flexible.

Open the Articulation.CATProduct and chain.CATProduct documents.
The product Articulation includes one CATProduct and two CATPart documents as follows:
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1.  Drag and drop the compass onto link (link.1), then select link (link.1) and drag it. The whole 

chain -and not link.1 only- is moved.

 

2.  Undo this action to return to the initial state.

3.  To make chain (chain.1) flexible, right-click it and select the chain.1 object -> 

Flexible/Rigid Sub-Assembly contextual command.

Alternatively, click the Flexible Sub-Assembly icon . 

 You can notice that the little wheel to the left corner of the chain icon has turned purple. 
This identifies a flexible sub-assembly.

 



4.  You can now move link (link.1) independently from link (link.2). For example drag and drop 

the compass onto  link (link.1) and move it in the direction of your choice. 

 

5.  Copy and paste chain (chain.1) within Articulation.CATProduct. You can notice that the 

property "flexible" is copied too.

 



6.  To make chain (chain.2) rigid, right-click it and select the chain.2 object -> Flexible/Rigid 

Sub-Assembly contextual command. A message window appears.

7.  Drag and drop chain (chain.2) to clearly see both instances of chain.CATProduct.

 

8.  In chain.CATProduct, move link (link.1) using the compass.

 

 You can notice that because chain (chain.2) is rigid, it inherits the new position of the 
original chain.CATProduct. Conversely, chain (chain.1) remains unchanged.



 

 What you need to keep in mind is that rigid sub-assemblies are always synchronous with 
the original product, whatever mechanical modification you perform.
Flexible sub-assemblies can be moved individually, without considering the position in the 
original product.
Since Release 7, you can edit the constraints defined for flexible sub-assemblies. The 
changes made to these constraints do not affect the constraints defined for the original 
product contained in the reference document.

 You can edit the following attributes:

●     values

●     orientation

●     driving/driven properties

9.  Set an angular constraint between Link 1 and Link 2 in chain.CATProduct. For example, set 

80 as the angle value.

 

 You can notice that both instances, chain (chain.2) and chain (chain.1) inherit this 
constraint.



 

10.  Edit the value of the angle constraint for chain (chain.1). Enter 100 for example. This new 

value is specific to chain (chain.1). Because chain (chain.1) is a flexible sub-assembly, this 

value can no longer be affected by changes to the value set in the reference document.

 

11.  Edit the value of the angle constraint set in chain.CATProduct. For example, enter 50 as the 

new value: because chain (chain.2) is a rigid sub-assembly, and as the constraint value for 

chain (chain.1) has been already redefined, chain (chain.2) is the only sub-assembly to 

inherit this new value.



 

 

Mechanical Structure

12.  Select the Analyze -> Mechanical Structure... command to display the mechanical 

structure of Articulation.CATProduct. This mechanical structure looks different from the 

product structure.

 In Mechanical Structure Tree dialog box, chain.2 is displayed because it is a rigid sub-
assembly. Conversely, chain.1 is not displayed since it is a flexible sub-assembly.

 



 

 This display is merely informative. Note that you can use the Reframe graph contextual 
command and the zoom capability to improve the visualization, but also the Print whole 
contextual command to obtain a paper document. For information on printing, please refer 
to Printing Documents.



Reusing a Part Design Pattern 

This task shows you how to repeat a component reusing a pattern created with the Part Design 
workbench. 

There are two work modes according to the Keep link with the pattern option:
●     The option is on: you are creating associativities between the geometry and the pattern definition.

●     The option is off: there is no associativity.

Working with associativity, you can decide whether you need to make instances associative with the 
pattern or generated constraints. This is mean that you can modify a reused pattern through the its 
definition only: if you delete any instantiated element (geometry or constraint) outside the definition, it 
will be recreated during the next update of the reuse pattern.

Three types of patterns are reusable:

●     Rectangular pattern.

●     Circular pattern.

●     User pattern.

The option Automatic switch to Design mode is available for the Reuse Pattern command. For more 
about this option, refer to Access to geometry.

Open the Pattern.CATProduct document.

1.  Select the rectangular pattern in the tree or in the geometry.

 

2.  Control-click to select the component to be repeated, that is Part2.

http://canezou/AwsDocV5R14/Doc/online/cfyugasm_C2/samples/Pattern.CATProduct


Selecting a constraint linking a pattern to a component selects both the pattern and the 
component.

3.  Click the Reuse Pattern icon:  

 The Instantiation on a pattern dialog box appears, indicating;

●     the name of the pattern.

●     the number of instances to be created (for information only).

●     the name of the component to be repeated.

 



4.  Ensure that the option Keep link with the pattern is on and check pattern's definition to 

make instances associative with the pattern's geometry.

To know more about associativity with constraints, refer to Re-using constraints.

 To define the first instance of the component to be duplicated, three options are available:

●     reuse the original component: the original component is located on the pattern, but remains 
at the same location in the tree.

●     create a new instance: the original component does not move and a new one is created on 
the pattern.

●     cut & paste the original component: the original component is located on the pattern and 
moved in the tree.

5.  Make sure the option re-use the original component is selected.

 To control the location of the components in the tree, two options are available:

●     You can check the option Put new instances in a flexible component to gather all 
instances in the same component

●     or conversely uncheck the option to create as many components as there are generated 
instances.

6.  Check the option Put new instances in a flexible component.

7.  Click OK to repeat the screw.

31 instances are created on the pattern. 



The new component Gathered Part2 on RectPattern.1 is displayed in the tree. An entity 
Assembly features has been created in the tree. Reused Rectangular Pattern.1 is displayed 
below this entity.

The Apply button executes the command but the dialog box remains open so as to let you 
repeat the operation as may times as you wish.

8.  Double-click RectPattern.1 to edit it. Enter 5 instances for both directions.

9.  Return to Assembly Design and make sure that the assembly is updated.

You can notice that associativity between the pattern and the instances of Part2 has been 
maintained since the option Keep link with pattern and Pattern's definition were switched 
on. Only 17 instances have been generated.



Reusing Constraints
If you use the option generated constraints, the Reuse Constraints section displays the constraints 
detected for the component and makes all original constraints available for selection: You can define 
whether you wish to reproduce one or more original constraints when instantiating the component.

To remove a constraint from the list, click on that constraint. To remove all constraints from the list, 
click Clear. Conversely, Click All to include all constraints in the selection.

Contextual Commands
The following contextual commands are available for Reused Rectangular Pattern.1:

●     Definition: displays information on the pattern. If some instantiated components are not verified, 
you can select them and apply a local update.

●     Deactivate/Activate: deactivates or activates the constraints defined on the instantiated 
components.

More about Patterns
This task you have just performed shows you that you can reuse constraints set between the part to be 
duplicated and the pattern: the generated instances are constrained too.

You can reuse constraints set between the part to be patterned and other parts. In the following 
example, two constraints are set between screw.1 to be patterned and Tray.1 (green part) and two other 
constraints are set between the screw.1 and Bracket.1 (blue part).



After applying the Reuse Pattern command to the screw, generated instances are constrained too:

  



Managing Part and Assembly Templates

Refer to the Quick Reference topic for a comprehensive list of interactions to be carried out on 
part and assembly templates. Refer to To know more about Part and Assembly Templates to 
know more about these features.

 

Creates a Document Template: Select the Insert -> Document Template Creation ... 
command, select the elements making up the document template from the specification 
tree, define a name for the document template and its reference elements then choose an 
icon for identifying it.

Introducing the Document Template Definition Window
Creating a Part Template

Instantiating a Part Template
Adding an External Document to a Document Template

Document Templates: Methodology
To know more about Part and Assembly Templates...

Document Templates: Limitations

http://canezou/AwsDocV5R14/Doc/online/cfyugpkt_C2/cfyugudf0011.htm


  Introducing the Document Template Definition 
Window      

The Document Template Definition window can be accessed by selecting the Insert->Document 

Template Creation... command from the following workbenches:

●     Product Structure

●     Part Design

●     Assembly Design

●     Generative Shape Design

●     Wireframe and Surface Design

The user can access the Product Knowledge Template workbench from the Part Design and the 
Product Structure workbenches. 

The Documents tab  

The Documents tab shows the complete path and Action of the files referenced in 
the Template. The Action status can be either:

●     Same Document or

●     New Document.

If the document is seen as New Document, it is then duplicated and does not have 
any link with the original component (equivalent of the New from... command.)

If the document is seen as Same Document, a link is maintained with the original 
file.

The  button enables you to modify 
the Action of the components.

The  buttons of the External documents sections enable you to 
select external documents and insert them into the template.

http://canezou/AwsDocV5R14/Doc/online/cfyugpkt_C2/images/pktPartTemplate1NLS.gif


It is now possible to associate non CATIA (ENOVIA VPM V5, ...) documents 
to a template. To do so, make sure you have enabled the desired 
environment in the Document Environments field (Tools->Options-
>General->Document.) Your documents will be accessible via the 
Document Chooser.  

The Inputs tab

The Inputs tab enables you to define the reference elements making up the 
Template by selecting them in the geometry or in the specification tree. 
 

The Accept instantiation even if not all inputs are filled option enables 
users to determine if the template can be instantiated even if not all inputs 
are valuated. If all inputs are not valuated, old inputs will be kept and isolated 
at instantiation. This option can be useful if there is more than one way to 
position the template in context, if you want all these combinations to be 
available but you want to use only one of them at the same time. To see an 
example, see Creating a Part Template and lnstantiating a Part Template.

For a clearer definition, you can select these items in the viewer and enter a new 
name in the Role field.

The Role field enables you to select one of the items displayed in the window and to 
rename  it. It is used at instantiation through the Use identical name button in the 
Insert object panel.

The Type column indicates if the input is manual or automatic. The inputs are 
considered as 

●     Manual if they are added manually

●     Automatic if they are external references that point an object defined outside 
the template. 

The Published Parameters tab

The Published Parameters tab enables you to define which parameter value used 
in the Template you will be able to modify when instantiating it. 

The Edit List... button enables you to access the list of parameters, and to select 
those you want to publish. These parameters are displayed in the Part Numbers 
viewer.

The Auto modify part numbers with suffix check box, if checked, automatically 
modifies the part numbers at instantiation if the part numbers already exist.

http://canezou/AwsDocV5R14/Doc/online/cfyugpkt_C2/images/pktPartTemplate5NLS.gif
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●     Note that if the user wants to manage the way part numbers are 
modified at instantiation, he just needs to uncheck this option and click, 
at instantiation, the Parameters button in the Insert Object dialog box. 
This way he can access the part numbers that he wants to modify.

●     The unicity of part numbers is now ensured when instantiating document 
templates into different documents or when the document template is 
used by different users. When the part numbers renaming mode is set 
to automatic, a suffix parameter is automatically published by the 
document template. At instantiation, after valuating the inputs of the 
document template, suffixes can be changed by clicking the Parameters 
button in the Insert Object window. Note that it is not possible to 
"unpublish" the suffix or to change its role.

The Icon tab

The Icon tab enables you to modify the icon identifying the Template in the 
specifications tree. A subset of icons is available when clicking the Icon choice 
button. 

Clicking  ... displays the Icon Browser, showing all icons loaded in your CATIA 
session.

The Grab screen button enables you to capture an image of the template to be 
stored along with its definition. 

The Remove preview button enables you to remove the image if you do not need 
it.

The assembly structure of the documentation template should not be modified after the document 
template definition (you cannot add or remove documents for example.)

http://canezou/AwsDocV5R14/Doc/online/cfyugpkt_C2/images/pktPartTemplate9NLS.gif


  Creating a Part Template 

This scenario explains how to create a part template containing a keypad that will be instantiated into a 
CATProduct document. In this scenario, the user: 

●     Creates 2 document templates. When creating the first document template, he does not check the Accept 
instantiation even if not all inputs are filled option (Steps 1 to 4). When creating the second document 
template, he checks the Accept instantiation even if not all inputs are filled option (Steps 5 to 8). To 
know more about this option, see Introducing the Document Template Definition Window.

●     Saves both document templates in a catalog.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Creating the first template

1.  Open the PktMobilePhoneKeypad.CATPart 

file. The following image displays.

2.  From the Insert menu, select the Knowledge Templates->Document Template ... command (in the 

Part Design workbench) or, if in the Product Knowledge Template workbench, click the Create a 

Document Template icon ( ). The Document Template Definition window displays. 

3.  In the Document Template Definition window, click the Inputs tab to select the inputs. To do so, 

proceed as follows: 

http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktMobilePhoneKeypad.CATPart


 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

❍     In the geometry, select the following features:  

- Curve.8

- Sharp_Sketch.3

- Arrow_down_Sketch.6

- Ok_Sketch.7

- Arrow_up_Sketch.8

- Cancel_Sketch.9

- Surface.3

❍     In the Inputs tab, select the Curve.8 feature and assign it a role in the Role field. Repeat the 

same operation for the features you selected. The final Inputs tab should look like the picture 

below. 

4.  Click the Published Parameters tab to publish parameters. To do so, proceed as follows: 

❍     Click the  

button. The Select 

parameters to insert 

window displays. 

❍     Use the arrow to select 

the Button_Offset and 

the Button_top_angle 

parameters in the 

Parameters to publish 

column. 



 

 

 

 

❍     Click OK twice. The 

Document template is 

added to the 

KnowledgeTemplates 

node. 

❍     Right-click DocumentTemplate.1 and select the Properties command to rename the 

document template.

❍     In the Feature Name field, enter Keypad1. Click OK to validate.

Creating the second template

1.  From the Insert menu, select the Knowledge Templates->Document Template ... command (in the 

Part Design workbench) or, if in the Product Knowledge Template workbench, click the Create a 

Document Template icon ( ). The Document Template Definition window displays. 

2.  In the Document Template Definition window, click the Inputs tab and select the following inputs in 

the specification tree: 

❍     Curve.8

❍     Sharp_Sketch.3

❍     Arrow_down_Sketch.6

❍     Ok_Sketch.7

❍     Arrow_up_Sketch.8

❍     Cancel_Sketch.9

❍     Surface.3

3.  Check the Accept instantiation even if not all inputs are filled check box.

4.  Click the Published Parameters tab to publish parameters. To do so, proceed as follows: 



❍     Click the  

button. The Select 

parameters to insert 

window displays. In the 

Parameters to publish 

column, click the 

Button_Offset and the 

Button_top_angle 

parameters and use the 

arrow to select them. 

❍     Click OK twice. The Document template is added to the KnowledgeTemplates node. 

❍     Right-click DocumentTemplate.2 and select the Properties command to rename the document 

template.

❍     In the Feature Name field, enter Keypad2. Click OK to validate.

❍     Save your file.

5.  Store the document template in a catalog. To do so, proceed as follows: 

❍     If not already in the Product Knowledge Template workbench,  from the Start-

>Knowledgeware menu, access the Product Knowledge Template workbench.

❍     Click the Save in catalog icon ( ). The Catalog save dialog box displays.

❍     Click OK to create a new catalog or the ... button to change the name of the catalog. The 

catalog is created.

❍     Click here to display the result catalog file. Click here to display the result .CATPart file.

6.  Close your file and proceed to the next task: lnstantiating a Part Template.

Refer to the Quick Reference topic for a comprehensive list of the interactions that can be carried on Document 
Templates.

http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktKeypadscatalog.catalog
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktMobilePhoneKeypadResult2.CATPart
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 lnstantiating a Part Template 

This scenario explains how to instantiate a template into a CATProduct file. It is divided into 2 
different parts:

●     The user instantiates Keypad1, a document template saved in the PktKeypadscatalog.catalog.

●     The user instantiates Keypad2, a document template saved in the PktKeypadscatalog.catalog.

To carry out this scenario, you need the following files:
●     PktMobilePhoneSupport.CATProduct that is made up of the following CATPart and CATProduct 

files:

PktBottomcase.CATPart PktBattery.CATPart

PktBody.CATPart PktLens.CATPart

PktIndus.CATPart PktLCD30-28.CATPart

PktFrontShell.CATPart PktElectronic.CATProduct

PktPlanarCard.CATProduct PktSpeaker.CATPart

InteractiveBoard.CATPart PktCapacitor_500.CATPart

PktCapacitor_700.CATPart PktChip_AC30.CATPart

PktChip_AC110.CATPart PktChip_AC20.CATPart

●     PktKeypadscatalog.catalog: This catalog contains 2 document templates: Keypad1 and Keypad2. 
When creating Keypad1, the Accept instantiation even if not all inputs are filled option was 
unchecked. When creating  Keypad2, the Accept instantiation even if not all inputs are 
filled option was checked.

 

 

 

 

 

 

Instantiating Keypad1

1.  Open the PktMobilePhoneSupport.CATProduct file.

http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktMobilePhoneSupport.CATProduct
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktBottomcase.CATPart
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktBattery.CATPart
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktBody.CATPart
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktLens.CATPart
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktIndus.CATPart
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktLCD30-28.CATPart
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktFrontShell.CATPart
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktElectronic.CATProduct
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktPlanarCard.CATProduct
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktSpeaker.CATPart
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/InteractiveBoard.CATPart
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktCapacitor_500.CATPart
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktCapacitor_700.CATPart
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktChip_AC30.CATPart
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktChip_AC110.CATPart
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktChip_AC20.CATPart
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktKeypadscatalog.catalog


 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2.  Click the Open Catalog icon ( )and select 

the PktKeypadscatalog.catalog that you created 

in the Creating a Part Template topic. The 

Catalog Browser opens.  

3.  Double-click DocumentTemplate, 7 inputs and 

Keypad1. The Insert Object window opens. 

(Click the graphic opposite to enlarge it).

 

 

To know more about the Insert Object dialog box, 
click here. 

4.  Value the Inputs by selecting the publications located below the Industrial Design node in 

the specification tree or click the Use Identical Name button in the Insert Object 

window.

http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktKeypadscatalog.catalog
http://canezou/AwsDocV5R14/Doc/online/cfyugpkt_C2/images/pktTemplate6NLS.gif
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5.  Make the appropriate selections in the Replace Viewer window (see picture below) and 

click OK when done. 

Note that in some cases, when instantiating a part or assembly template, the replacing 
element does not present the same sub-elements as the replaced element. Therefore you 
need to clearly indicate in a specific dialog box, the Replace Viewer, how to rebuild the 
geometry from the replacing element.

6.  Click OK in the Check warning box, then Close. The keypad is instantiated (see picture 

below.) 

7.  Close your file.



 
 
 
 
 
 
 
 

 

Instantiating Keypad2

1.  Open the PktMobilePhoneSupport.CATProduct file.

2.  Click the Open Catalog icon and select the PktKeypadscatalog.catalog that you created in 

the Creating a Part Template topic. The Catalog Browser opens.  

3.  Double-click Document Template,  7 inputs and Keypad2. The Insert Object window opens.

4.  Click OK in the Insert Object window. The keypad is instantiated. Note that you do not have 

to value the inputs since the Accept instantiation even if not all inputs are filled option 

was checked when creating the Keypad2 part template.

http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktMobilePhoneSupport.CATProduct
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktKeypadscatalog.catalog


Refer to the Quick Reference topic for a comprehensive list of the interactions that can be carried on 
Part Templates.

 

http://canezou/AwsDocV5R14/Doc/online/cfyugpkt_C2/cfyugudf0011.htm


Adding an External Document to a Document 
Template 

This task shows how to insert a drawing into a part template and how it is updated at instantiation. 
The scenario is divided into the following steps:

●     Creating a drawing from an existing part

●     Creating the part template

●     Instantiating the part template and updates the generated drawing.

Note that the document(s) that can be added to part and assembly templates must belong to one of 
the following types:

●     .CATDrawing

●     .CATProcess

●     .CATAnalysis

Prior to carrying out this scenario, make sure that the Keep link with selected object is checked 
(Tools->Options...->Infrastructure->Part Infrastructure->General).

1.  Open the PktPadtoInstantiate.CATPart file. The following image displays.

2.  From the Start->Mechanical Design menu, access the Drafting workbench. The New 

http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktPadtoInstantiate.CATPart


Drawing Creation Window displays. 

3.  Select the All views configuration and click OK.

4.  The drawing corresponding to the pad is generated. 

4.  Save your drawing and close the file. Click here to see the generated drawing.

5.  Go back to the PktPadtoInstantiate.CATPart file to create a part template. To do so, proceed as 

follows:

❍     Select the Knowledge Templates->Document Template ... command. The 

Document Template Definition window displays.

❍     Click the Add... button in the External documents field and select the .CATDrawing 

file you have just created in the File Selection window (or use the 

PktPadDrawing.CATDrawing). Click Open.

❍     Click the Inputs tab and select Sketch.1 and Sketch.2 in the geometry or in the 

specification tree.

http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktPadDrawing.CATDrawing
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktPadDrawing.CATDrawing


❍     Click the Published Parameters tab and click the Edit List... button. The Select 

parameters to insert window displays. Select the following parameters using the 

arrow button:

 
❍     PartBody\Pad.1\FirstLimit\Length

 
❍     PartBody\Pad.2\FirstLimit\Length

❍     In the Published Parameters tab, select PartBody\Pad.1\FirstLimit\Length and 

rename it to Pad_Width in the Name: field, then select 

PartBody\Pad.2\FirstLimit\Length and rename it to Pad_Length.

❍     Click OK to validate. Save your file and close it.

6.  Open the PktProduct.CATProduct  file.

7.  From the Start->Knowledgeware menu, access the Product Knowledge Template 

workbench (if need be).

8.  Click the Instantiate From Document icon ( ) and select the 

PktPadtoInstantiate_result.CATPart containing the document template. Click Open. The Insert 

Object dialog box displays.

9.  Expand the PartBody\Pad.1 node in the specification tree, select Sketch.1, and make the 

appropriate selections in the opening Replace Viewer window (see graphic below). Click 

Close when done.

http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktProduct.CATProduct
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/ProductKnowledgeTemplate/PktPadtoInstantiate_result.CATPart


10.  Select Sketch.2 in the geometry or in the specification tree.

11.  Click the Parameters button and enter 10mm in the Pad_Width field and 90 in the 

Pad_Length field.

12.  Click Close and OK to validate. A message is fired indicating that the external document was 

regenerated. Click OK. The document template was instantiated. (see picture below).



13.  From the Window menu, access the generated .CATDrawing file. Right-click CATDrawing2 in 

the left part of the window and select the Update Selection command. The drawing is 

updated and matches the new product.



Refer to the Quick Reference topic for a comprehensive list of the interactions that can be carried out 
on document templates.
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 Document Templates: Methodology  

●     It is possible for the user to define document templates based on contextual products and parts or on 
isolated parts and products. It is highly recommended to work with isolated documents: not so many 
documents will be instantiated (when working with contextual products, the context products are needed 
for instantiation).

●     The assembly structure of the documentation template should not be modified after the document 
template definition (you cannot add or remove documents for example.)



To know more about Part and Assembly 
Templates...

Part and Assembly Templates are templates that work at the part or at the assembly level.  

The Document Template Definition window can be accessed by selecting the Insert->Document 

Template Creation... command from the following workbenches: 

●     Part Design

●     Generative Shape Design

●     Wireframe and Surface Design

●     Assembly Design

●     Product Structure

Working with Part Templates

A part created in Catia may contain user parameters and geometry data. It is not a contextual part. The user 
can create a part template that references that part. This template is a feature that is created in the CATPart 
document itself (very similar to the PowerCopy definition) and stored in a catalog. Several part templates 
may be defined in the same CATPart document.

To create a part template, the user: 

●     selects parameters and geometry data that will be considered as the template inputs (he can assign a role 
and a comment to each input). 

●     publishes some internal parameters (name and comment). The part number is automatically published. 

●     gives a name, comment, URL, icon to this template.

In product structure context, the part is inserted as a component of the current product.

Working with Assembly Templates

A user creates an assembly interactively. Then, he wants to create an assembly template that references the 
root product of this assembly.

To create an assembly template, the user:



●     selects parameters and geometry data that will be considered as the template inputs (he can assign a 
name to each input). 

●     publishes some internal parameters (name and comment). 

●     chooses if: 

- the part numbers of replicated components are automatically published.

- for each part or each sub-assembly, this sub-component will be replicated at instantiation  or if 
only a reference to this sub-component will be created (a standard component). 

- he wants to select external documents (Drawings / Analysis) that references elements of the 
product structure. Those elements will be replicated at instantiation.

●     assigns a name, comment, URL, icon to this template.

The template definition is a feature located in the CATProduct document itself. Several assembly 
templates may be defined in the same CATProduct document.



Document Templates: Limitations

A publication cannot point an object already published more than once. When creating the import link, the 
published object is looked for and the import is created on the first publication found which might not be the 
one that has the same name as the input.
The only information that the Document Template can provide is the final object itself (infrastructure does not 
allow to specify the publication, but only the pointed object). The publication is then automatically retrieved 
by the link infrastructure.



 Managing Enhanced Scenes
 

About Enhanced Scenes   
Creating an Enhanced Scene 
Generating an Enhanced Scene from an Old Scene 
Browsing Enhanced Scenes using the Scenes Browser
Activating an Enhanced Scene
Exploding an Assembly  
Overloading Product Position in Enhanced Scene Context   
Adding, Replacing and Deleting Components in the Assembly 
Checking Component Position 
Saving a Viewpoint in Enhanced Scene Context
Creating an Enhanced Scene Macro 
Applying an Enhanced Scene Context to an Assembly 
Applying an Assembly Context to a Enhanced Scene 
Automating Enhanced Scene Context Application Using User-defined Attributes
Saving an Enhanced Scene in ENOVIAVPM 
Exiting Enhanced Scene Context



About Enhanced Scenes
 

 
Enhanced Scenes will extend the limited capabilities of Old Scenes. It will now be possible to create and 
edit applicative data. 

 

Enhanced Scenes

 

An Enhanced Scenes can be seen as a snapshot of an assembly in a defined state. 

An Enhanced Scene corresponds to an assembly with specific component positions and specific 
attributes. It enables you to overload the following attributes:

●     Component Positioning (using compass manipulation, snap or explode commands)

●     Component Graphical attributes (color, transparency, line type, line thickness)

●     Node Activation state 

●     Component Hide / show state 

●     Viewpoint 

One of the major benefits of Enhanced Scenes is that the applicative data container will be available 
and functionalities associated with the applicative data will also be available in Enhanced Scene context. 

It will be possible to generate Enhanced Scenes from Old Scenes. 

Overloading of attributes (graphical, show / no show state, etc.) is limited to Products, i.e. these 
modifications are not replicated between scene and assembly for Products, however, for parts, models 
and manikins these modifications will be replicated (modifications on parts, models and manikins are 
always replicated in both directions).

Overload Modes in Enhanced Scenes



When you work in Enhanced Scenes, there are two Overload Modes, Full and Partial.

Overload Mode Full

●     When you create a Enhanced Scene in Overload Mode Full, all attributes are immediately considered 
overloaded. 

●     All subsequent modifications to the Assembly will have no impact on the Enhanced Scene and vice-
versa. 

●     If you choose to apply the Enhanced Scene context on the Assembly or to apply the Assembly 
context on the Enhanced Scene, after the operation, all attributes will still be considered overloaded 
and subsequent modifications to either the Enhanced Scene or the Assembly will continue to be 
independent, one from the other.

Overload Mode Partial

●     When you create a Enhanced Scene in Overload Mode Partial, by default, none of the attributes are 
considered overloaded.

●     Modifications to the Assembly will impact those attributes of the Enhanced Scene that are not 
overloaded (so, for example, if you make some modifications to the Assembly immediately following 
the Enhanced Scene creation, all of these modifications will impact the Enhanced Scene).

●     Modifications to the Enhanced Scene never impact the Assembly, the result of such modifications to 
the Enhanced Scene is to overload the modified attributes. 

●     Attributes in the Enhanced Scene are overloaded implicitly when you modify the attribute in 
Enhanced Scene context.

Graphical attributes, activation state, hide / show state, and viewpoint, once modified in the 
Enhanced Scene, will be considered overloaded. The overloaded values do not impact the 
Assembly. These overloaded attributes will subsequently be independent from the Assembly, 
i.e. modifications to the corresponding attributes in the Assembly will not impact the values 
of the attributes in the Enhanced Scene.

Position attributes are implicitly overloaded when modified in the Enhanced Scene, however, 
you can also overload them explicitly by selecting the components for which you wish to 
overload the position and then clicking the Overload Position icon in the Enhanced Scenes 
toolbar (see Overloading Product Attributes in Enhanced Scene Context).

●     If you choose to apply the Enhanced Scene context on the Assembly or to apply the Assembly 
context on the Enhanced Scene, after the operation, those attributes that were considered 
overloaded will continue to be considered so (even though they may momentarily have the same 
value as the corresponding attribute in the Assembly).

Subsequent modifications of these overloaded attributes in either the Enhanced Scene or the 
Assembly will continue to be independent, one from the other.

Subsequent modifications to the Assembly of those attributes that are not considered 
overloaded will continue to impact the Enhanced Scene. 



 

 
Applicative Data Available in Enhanced Scene Context
The following applicative data are available in the Enhanced Scene context:

●     Annotated Views

●     3D Annotation

●     Hyperlinks

●     Group

●     Cumulative snap

●     Reset position

●     Init position

●     Current selection

●     Applicative data reordering

●     Apply material

●     Publish

●     Camera

●     Cache content

●     Modify sag

●     DMU Move

●     Measure 

●     Section

●     Clash

●     Rendering lights 

●     Rendering Environments 

Note: The automatic update of Enhanced Scene associated applicative data is managed by a variable in 
the DMU Navigator Settings. See Customizing DMU Navigator Settings.
 

 
The Assembly is the Reference for Enhanced Scene Creation



Enhanced Scene creation always uses the Assembly as the reference. In Overload Mode Partial, any 
modifications to attributes in the Assembly will affect every Enhanced Scene that does not overload 
those attributes.
 

Therefore, the command Apply Scene on Assembly will affect all of the Enhanced Scenes with Overload 
Mode Partial that have not overloaded the attributes corresponding to those that will be updated in the 
Assembly. 

  

 
Propagation of Overloaded Attributes in Enhanced Scene Context

The propagation of attributes in Enhanced Scene context will work exactly as in Assembly context. 
Note, however, that the propagation of the value of a Product's overloaded attribute to its children will 
not cause the child Product's attribute to be considered overloaded, with the exception of hide/show, 
for which all children of a hidden attribute will also be hidden.

  

 
Save Command in Enhanced Scene Context
The Save command will be enabled in Enhanced Scene context, but you should be warned that it is the 
Assembly that will be saved (it will be the equivalent of doing Exit Scene + Save in Assembly context 
+ Double-clicking the Enhanced Scene in the specification tree to re-enter the Enhanced Scene).

  

 
Restrictions

●     In Enhanced Scene context, only products can be UI-Activated. 

●     Enhanced Scene context is NOT intended for assembly edit (add part, delete part, geometry 
modification), its intent is strictly review-oriented.

  

 



Creating an Enhanced Scene 
 

Enhanced Scenes enable you to work on an alternative state of a product.

Insert the following GARDENA model documents from the cfyug samples folder:

GARDENAATOMIZER.model
GARDENABODY12.model
GARDENABODY22.model
GARDENALOCK.model
GARDENANOZZLE12.model
GARDENAREGULATOR.model
GARDENATRIGGER.model
GARDENAVALVE.model
GARDENA_NOZZLE22.model
GARDENA_REGULATION_COMMAND.model

1.  In the specification tree, select the products of the Assembly that will define the Enhanced 

Scene content.

 Selecting Enhanced Scene Content

Note that there are three ways to select Enhanced Scene content:

●     No selection: the entire Assembly will appear in the Enhanced Scene 

●     One or more products selected (a subset of the Assembly): only the components in the 
branches leading back to the Assembly root of these selected products will appear in the 
Enhanced Scene 

●     An existing Scene selected (Enhanced Scene or Old Scene): the new Enhanced Scene will 
be a copy of the selected one

If only a subset of the Assembly is selected, the Enhanced Scene will contain only the 
selected products and their components. Regardless of the level of the selected products, the 
branches leading back to the Assembly root will be displayed in the Enhanced Scene tree and 
all representations in the branches will appear in the Enhanced Scene.

http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/GARDENAATOMIZER.model
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/GARDENABODY12.model
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/GARDENABODY22.model
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/GARDENALOCK.model
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/GARDENANOZZLE12.model
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/GARDENAREGULATOR.model
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/GARDENATRIGGER.model
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/GARDENAVALVE.model
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/GARDENA_NOZZLE22.model
http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/GARDENA_REGULATION_COMMAND.model


2.  In the DMU Review Creation toolbar, click the Enhanced Scene icon .

The Create Scene dialog box appears.

 

3.  To define the name of the Enhanced Scene, click the Automatic naming radio button to 

deselect it and enter the name in the Name text-entry field.

Note: Automatic naming enables you to automatically attribute names to Enhanced Scenes of 

the form Scene.1, Scene.2, Scene.3, etc. (The automatic naming mechanism is National-

Language Supported.)

4.  To define the Overload Mode, click the Partial radio button or click the Full radio button.

Overload Mode Partial: The scene will only overload attributes for a few products and  

modifications to the main assembly of those attributes not overloaded in the scene will impact 

the scene. Overload Mode Partial favors performance as long as you don't  overload too 

many attributes. An Enhanced Scene created with Overload Mode Partial will be indicated in 

the specification tree by the symbol .

Overload Mode Full: All attributes supported for overloading of each element of the assembly 

(under the products selected at scene  creation) will be overloaded by the scene. Products 

overloaded by the scene will henceforth not be impacted by modifications to the main assembly 

regarding attributes supported for overloading. Overload Mode Full favors Enhanced Scene 

independence from the Assembly. An Enhanced Scene created with Overload Mode Full will 

be indicated in the specification tree by the symbol .



Once the scene is created, it is not possible to change the overload mode; nevertheless, it is 
possible to create a new Enhanced Scene from an existing Enhanced Scene and to affect a 
different overload mode to the new Enhanced Scene at its creation. 

 
5.  Click OK to validate.

The Enhanced Scene is created.

The Enhanced Scene appears. A background (the color of which you define in the Tools -> 

Options -> DMU -> DMU Navigator settings)  indicates that you are now in Enhanced Scene 

context. The DMU Scenes toolbar appears.

 



 Applicative Data in Enhanced Scene Context
 

If the Assembly from which the Enhanced Scene was created had an Applicative Data container, this 
container will also be available in the Enhanced Scene. You will be able, therefore, to modify the 
existing applicative data and to create new applicative data.

 

Enhanced Scene Contextual Menu
 

The Enhanced Scene contextual menu is composed of the following commands:

 

Contextual Menu Entry Action

Definition activates the Enhanced Scene

Check Position
highlights all components for which the position attribute is 
different from the corresponding Assembly position 
attribute (see Checking Component Position)

Save Viewpoint
overloads the viewpoint attribute with the current 
viewpoint (see Saving a Viewpoint in New Scene Context)

Exit Scene exits the Enhanced Scene and return to Assembly context

Apply Scene on Assembly
applies the overloaded attributes of the Enhanced Scene 
context on the Assembly (see Applying a Enhanced Scene 
Context to an Assembly)

Apply Assembly on Scene 
applies the attributes of the Assembly context on the New 
Scene (see Applying an Assembly Context to a Enhanced 
Scene)

In Assembly context, the available commands are:

●     Definition

●     Apply Scene on Assembly

●     Apply Assembly on Scene

In Enhanced Scene context, when right-clicking an inactive Enhanced Scene, the available command is:

●     Definition 

In Enhanced Scene context, when right-clicking the active Enhanced Scene, the available commands 
are:



●     Definition 

●     Apply Scene on Assembly

●     Apply Assembly on Scene

●     Check Position

●     Save Viewpoint

●     Exit Scene 

 

 



Generating an Enhanced Scene from an Old 
Scene 

 

There is currently no formal process for automatically converting Old Scenes to  Enhanced Scenes. The 
available solution consists of selecting the Old Scene in the specification tree and then creating an 
Enhanced Scene. 
 
You have created an Old Scene in which you've modified one or more attributes (e.g. you've modified 
the color of one of the components and you've modified the viewpoint of the Old Scene).

 
1.  Open the GardenaScene.CATProduct.

2.  In the Specification Tree, select the Old Scene.

3.  In the DMU Review Creation toolbar, click the Enhanced Scene icon  and create the 

Enhanced Scene with the name and overload mode of your choice (see Creating an Enhanced 

Scene).

Once created, the Enhanced Scene will be displayed and its state (the value of all possibly 

overloaded attributes) will be the same as that of the Old Scene from which it was created.

  

If you have chosen Overload Mode Partial, each attribute in the Enhanced Scene which is different from 
the corresponding attribute in the Assembly will now be considered overloaded.

The Old Scene will not be destroyed.

The Old Scene and the Enhanced Scene will be independent one from the other.
 
Scripts can be written using VBScript for generating Enhanced Scenes from Old Scenes.

 

http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/GardenaScene.CATProduct


Browsing Enhanced Scenes using the Scenes 
Browser

 

You can browse your Enhanced Scenes visually using the Scenes Browser. Appropriate customization of 
the Scenes Browser settings enables you to:

●     activate a scene by simply double-clicking its image

●     apply a scene to the assembly by simply double-clicking its image
 

 1.  In the DMU Review Navigation toolbar, click the Scenes Browser icon .

The Scenes Browser appears. An image representation of all defined Enhanced Scenes 

associated to the current Assembly will be found in the Scenes Browser.



 

Customizing double-click behavior in the Scenes Browser

2.  In the Scenes Browser, click the Customize button.



3.  Check the radio button corresponding to the desired double-click behavior:

●     double-clicking will activate the Enhanced Scene

●     double-clicking will apply the whole Enhanced Scene to the Assembly

4.  Click OK to validate.

Implementing the chosen behavior (Activating an Enhanced Scene or 
Applying an Enhanced Scene to the Assembly)

5.  In the Scenes Browser, double-click the image of an Enhanced Scene to implement the 

chosen behavior.

The Enhanced Scene title associated to each image in the Scenes Browser also indicates whether the 
Enhanced Scene was created with overload mode Partial or Full.

 

 



Activating an Enhanced Scene
 

An Enhanced Scene can be activated at any time by simply double-clicking its entry in the Specification 
Tree.
 

 
1.  In the Specification Tree, expand the Applications node and then expand the Enhanced Scenes 

node.

A list of all Enhanced Scenes will be displayed.

2.  In the Specification Tree, double-click the entry of the Enhanced Scene you wish to activate. 

The Enhanced Scene will be displayed.

The background color will change to indicate that you are in Enhanced Scene context.

Even if you are working in Enhanced Scene context, you can activate a different Enhanced Scene by 
double-clicking its entry in the Specification Tree.

It is also possible to activate an Enhanced Scene by right-clicking it in the Specification Tree and 
selecting Scene.X object -> Definition in the contextual menu.
 

 



Exploding an Assembly 
You can explode a product in New Scene context without affecting the original product. 

You've created an Enhanced Scene.

 
1.  Double-click Scene.1 either in the specification tree or in the geometry area.

The context is changed to the Enhanced Scene context.

2.  Select Product.1 and click the Explode icon .

The Explode dialog box appears.

Note that if the assembly is assigned coincidence constraints (axis/axis, plane/plane), the 

Explode can take these constraints into account by use of the Explode type "Constrained". 

3.  Click the Apply button.



4.  Click the Exit Scene icon  to swap to Assembly context.

For more details about explode functionality, see the DMU Fitting Simulator User's Guide.

 

 



Overloading Product Position 
in Enhanced Scene Context 

Overloading product position enables you to declare independence for the positioning of products in an 
Enhanced Scene with respect to the positioning of that same product in the Assembly. 

 
 Overload Mode Impact on Component Positioning

 

In Overload Mode Partial, repositioning a product in Enhanced Scene context will implicitly overload 
the position attribute. However, if a modification was first made to the product position in the 
Assembly, the position would be modified correspondingly in the Enhanced Scene since the position 
attribute would not have been overloaded. 

 

 
1.  Either in the specification tree or in the geometry area, select the products for which you wish 

to overload the position attribute.

The selected components are highlighted in both the specification tree and the geometry area.

2.  Click the Overload Positions icon .

The position attributes of the selected products are now considered overloaded and will be 

independent from positioning modifications to the Assembly.

When you overload the product position attribute using this command:
●     all child product position attributes will also be overloaded 

●     all ancestor product position attributes will also be overloaded

When you use move a product in Enhanced Scene context:

●     the moved product's position attribute will be overloaded

●     all ancestor product position attributes will also be overloaded

 

 



Adding, Replacing and Deleting Components in 
the Assembly

This task shows you how an Enhanced Scene is affected when you add, replace and delete components 
in the Assembly.
 
The Add, Replace and Delete functionalities are not available in Enhanced Scene context, only in 
Assembly context.
 
Insert the following sample model files in the cfyug samples folder:

●     ATOMIZER 

●     BODY1 

●     BODY2 

●     LOCK 

●     REGULATOR 

●     TRIGGER 

●     VALVE

●     REGULATION_COMMAND 

 1.  Click the Enhanced Scene icon  and create an Enhanced Scene.

You are now in a scene window.
The background color has turned to green and Scene.1 is added in the specification tree.

2.  Click the Exit Scene icon  to swap to the main window.

You return to Assembly context.

Adding Components in the Assembly
In Overload Mode Full, components added in Assembly context will have not appear in the Enhanced 
Scene.

In Overload Mode Partial, the behavior will be as described below.



You will now add the NOZZLE:

3.  Right-click Product1 in the specification tree and select Components -> Existing 

Component. 

4.  Shift-select NOZZLE1.model and NOZZLE2.model and then click Open.

The added components (NOZZLE_1 _2 and NOZZLE_1_2) are identified in the specification tree 

and added in the geometry area. 

5.  In the specification tree, double-click Scene.1 to swap to the Enhanced Scene context.

The newly-added components will appear in the specification tree and in the geometry area, 

assuming that, when they were added in the Assembly, they were added under the node that 

was selected for the creation of the Enhanced Scene. Otherwise, they will not appear.

 For example, given the following Assembly configuration, 

if you created an Enhanced Scene that contained only product P1 and you add a product 
under product P1 in the Assembly, then the added product will appear under P1 in the 
Enhanced Scene. However, if you add a product under the Root in the Assembly, it will not 
appear in the Enhanced Scene. 

6.  Click the Exit Scene icon  to return to Assembly context.



Replacing Components in the Assembly

7.  Replace, for example, the BODY1 in the Assembly with the BODY2.model (right-click BODY1 

in the specification tree, select Components -> Replace Component from the contextual 

menu, then, in the File Selection dialog box, select BODY2.model and click Open.)

The Assembly is updated accordingly. 

8.  Double-click Scene.1 in the specification tree to enter the scene.

Scene.1 has been updated in the same manner as the Assembly, assuming that the replaced 

product was previously visible in the Enhanced Scene.

9.  Click the Exit Scene icon  to return to Assembly context.

 

Deleting Components from the Assembly

10.  Delete, for example, the BODY2 from the Assembly (right-click it in the specification tree and 

select Delete from the contextual menu.)

The Assembly is updated accordingly. 

11.  Double-click Scene.1 to enter the Enhanced Scene.

Scene.1 has been updated in the same manner as the Assembly, assuming that the deleted 

product was previously visible in the Enhanced Scene.

 

 



Checking Component Position 
 

This task shows you how to reset and check component position.

You've created an Enhanced Scene in which you've modified the position attributes.

 
1.  Double-click Scene.1 either in the specification tree or in the geometry area.

The context is changed to the Enhanced Scene context. 

2.  In the specification tree, right-click Scene.1 and select Scene.1 object -> Check Position. 

All moved items are highlighted in the specification tree and in the geometry area.

 

To reset the position of the moved items, see Applying an Assembly Context to an Enhanced Scene.

 



Saving a Viewpoint in Enhanced Scene  Context 
 

This task shows you how to save a viewpoint in Enhanced Scene context. 

You've created an Enhanced Scene.

 
1.  Modify the viewpoint of the Enhanced Scene.

2.  In the Enhanced Scenes toolbar, click the Save Viewpoint icon .

3.  Click the Exit Scene icon  to return to the initial document window.

You return to the main window.

4.  Double-click Scene.1 either in the specification tree or in the geometry area to swap to the 

scene window.

The viewpoint you saved is now taken into account in the Enhanced Scene.

 



Creating an Enhanced Scene Macro
 

If you perform a task repeatedly, you can take advantage of the macro mechanism to automate it. A 
macro is a series of functions, written in a scripting language, that you group in a single command in 
order to perform the requested task automatically. 

This task will show you how to create an Enhanced Scene macro. 
 
You stored your recorded macros in a text format file. For more detailed information about macros, see 
Recording, Running and editing Macros in the Infrastructure User's Guide.

 

Here is an example of an Enhanced Scene macro in which you create a Enhanced Scene:

' COPYRIGHT DASSAULT SYSTEMES 2003
Option Explicit 

' **************************************** **************
' Purpose: Create two new scenes.
' Assumptions: A CATProduct document should be active.
' Languages: VBScript
' Locales: English 
' CATIA Level: V5R12
' ******************************************************* 

Sub CATMain() 

' Get the root of the CATProduct
Dim RootProduct As Product
Set RootProduct = CATIA.ActiveDocument.Product 

' Retrieve the ProductScenes collection
Dim TheScenes As ProductScenes
Set TheScenes = RootProduct.GetTechnologicalObject("ScenesCollection") 

' Create a FULL product-scene on Root-Product
Dim xProducts1(0)
Set xProducts1(0) = RootProduct 
Dim oScene1 As ProductScene
Set oScene1 = TheScenes.AddProductSceneFull ("", xProducts1) 

' Create a PARTIAL product-scene on Root-Product with "PartialScene" persistent name
Dim xProducts2(0)
Dim oScene2 As ProductScene
Set oScene2 = TheScenes.AddProductScenePartial ("PartialScene", xProducts2) 

End Sub



 

●     Create the scene launches the scene creation.

●     Scene1 corresponds to the to-be-created scene.

●     RootProduct corresponds to Product1.

 



Applying an Enhanced Scene Context to  an Assembly 
 

The command Apply Scene to Assembly enables you to reset the values of selected attributes of the Assembly with the values of 
the corresponding overloaded attributes in the Enhanced Scene.
 

You've created an Enhanced Scene in which you've modified at least one of the following:
●     component position

●     component hide / show status 

●     component graphical properties

●     component activation status 

Enhanced Scene creation always uses the Assembly as the reference. Therefore, the command Apply Scene on Assembly will affect 
all of the Enhanced Scenes with Overload Mode Partial that have not overloaded the attributes corresponding to those that will be 
updated in the Assembly. 
 

1.  Double-click Scene.1 in the specification tree to activate the Enhanced Scene 

2.  Click the Apply Scene on Assembly icon .

The Apply Scene.1 on Assembly dialog box is displayed.

All differences between the Assembly and the Enhanced Scene are indicated by an "X" in the dialog box.

You can also access the Apply Scene on Assembly command by right-clicking Scene.1 in the specification tree and selecting 
Scene.1 object -> Apply on Assembly in the contextual menu.
 

 

3.  Select the products for which you wish to apply modifications.

The rows corresponding to the products will be highlighted. 

In the Attributes management area, the attribute types that could potentially be applied as a function of the selected 

products will be un-grayed (in the above example, only the Position attribute has been modified for the selected products, 

so only the Position attribute type has been un-grayed).

4.  In the Attributes management area, click the attribute types of the modifications you wish to apply.



The entry in the table of the corresponding modification will change from "X" to "Apply".

5.  Click OK to validate.

Using the Contextual Menu

You can use the contextual menu to:

●     select all product rows or to unselect all product rows

●     designate selected attributes as "Apply" or "X" (Do not apply)

As an example:

●     in step 3 above you would still select the product rows manually

●     in step 4 above you would right-click the selection, which would display the following contextual menu (because only position 
attributes are potentially applicable from the Enhanced Scene onto the Assembly):

●     you would select Apply Position (or Apply All) to designate the selected attributes to be applied:



Customizing Displayed Attributes

You can customize the list of attribute types displayed in the Attributes management area:

●     click the Customize button

●     deselect the attribute types you don't wish to appear in the list

●     click OK to validate

 



Applying an Assembly Context to an  Enhanced Scene 
The command Apply Assembly on Scene enables you to reset the values of selected overloaded attributes in the Enhanced Scene 
with the values of the corresponding attributes in the Assembly.
 

You've created an Enhanced Scene in which you've modified at least one of the following:
●     component position

●     component hide / show status 

●     component graphical properties

●     component activation status 

1.  Double-click Scene.1 in specification tree to activate the Enhanced Scene. 

2.  Click the Apply Assembly on Scene icon .

The Apply main assembly on Scene.1 dialog box is displayed.

All differences between the Assembly and the Enhanced Scene are indicated by an "X" in the dialog box.

You can also access the Apply Scene on Assembly command by right-clicking Scene.1 in the specification tree and selecting 
Scene.1 object -> Apply on Scene in the contextual menu.
 

 

3.  Select the products for which you wish to apply  modifications.

The rows corresponding to the products will be highlighted. 

In the Attributes management area, the attribute types that could potentially be applied as a function of the selected 

products will be un-grayed (in the above example, only the Position attribute has been modified for the selected products, 

so only the Position attribute type has been un-grayed).

4.  In the Attributes management area, click the attribute types of the modifications you wish to apply.

The entry in the table of the corresponding modification will change from "X" to "Apply" or vice-versa. 



5.  Click OK to validate.

You can use the contextual menu to:
●     select all product rows or to unselect all product rows

●     designate selected attributes as "Apply" or "X" (Do not apply)

As an example:

●     in step 3 above you would still select the product rows manually

●     in step 4 above you would right-click the selection, which would display the following contextual menu (because only position 
attributes are potentially applicable from the Assembly onto the Enhanced Scene):

●     you would select Apply Position (or Apply All) to designate the selected attributes to be applied:



You can customize the list of attribute types displayed in the Attributes management area:
●     click the Customize button

●     deselect the attribute types you don't wish to appear in the list

●     click OK to validate

 



 Automating Enhanced Scene Context Application Using 
User-defined Attributes

 

This command enables you to streamline the application of an Enhanced Scene context to an Assembly by allowing you to pre-
define those attributes that you would like to apply by default and then allowing you to apply those attributes from a contextual 
menu. 

You've created an Enhanced Scene in which you've modified at least one of the following:
●     component position

●     component hide / show status 

●     component graphical properties

●     component activation status 

Enhanced Scene creation always uses the Assembly as the reference. Therefore, the command Apply Scene on Assembly will 
affect all of the Enhanced Scenes with Overload Mode Partial that have not overloaded the attributes corresponding to those that 
will be updated in the Assembly. 
 

1.  In the specification tree, right-click Scene.1 and select Scene.1 object -> Set User Defined Attributes in the 

contextual menu.

 

2.  Select the products for which you wish to apply modifications.

The rows corresponding to the products will be highlighted. 

In the Attributes management area, the attribute types that could potentially be applied as a function of the selected 

products will be un-grayed (in the above example, only the Position attribute has been modified for the selected products, 

so only the Position attribute type has been un-grayed).

3.  In the Attributes management area, click the attribute types of the modifications you wish to apply.

The entry in the table of the corresponding modification will change from "X" to "Lock".



4.  Click OK to validate.

The use of the contextual menu is the same as in Applying an Enhanced Scene Context to an Assembly.

The customization of displayed attributes in the dialog box is the same as in Applying an Enhanced Scene Context to an Assembly.
 

 



Saving an Enhanced Scene in ENOVIAVPM
Enhanced Scenes can be saved in ENOVIAVPM, but only in the context of a DMU Review. See Saving 
DMU Applicative Data in ENOVIAVPM  in the DMU Navigator User's Guide.
 
The Enhanced Scenes saved in ENOVIAVPM cannot be used in a drafting scenario: it is not possible to 
create a drawing with a view from this scene.
 

 



Exiting Enhanced Scene Context 
 

You can exit Enhanced Scene context and return to Assembly context at any time.
 

 1.  In Enhanced Scenes toolbar, click the Exit Scene icon .

You exit the Enhanced Scene context.

You will now be back in Assembly context.

All modifications to your Enhanced Scenes are implicitly persistent, with the exception of viewpoint 
modification (see Saving a Viewpoint in Enhanced Scene Context).

If you hide the Enhanced Scenes toolbar, you will automatically exit Enhanced Scene context.

 



 Selecting Using a Filter

This task will show you how to manage and customize the sub-geometry selection in order to avoid any 
ambiguity.

 The User Selection Filter toolbar is divided into two sections:
●     The first section lets you filter elements according to their type:

❍      point type.

❍      curve type.

❍      surface type.

❍      volume type.

●     The second section lets you filter elements according to their mode:

❍      Feature Element Filter selects the whole feature whether it is a sketch, product, pad, join, 
etc.

❍      Geometrical Element Filter enables to sub-elements of a feature such as faces, edges or 
vertices.

 By default, all the icons are deactivated which means that no filter is applied but you can restrict the 
selection to specific element types by clicking the corresponding icons.

 Bear in mind that:
●     If you deselect a type, it cannot be selected in the geometry anymore unless all other types are 

deselected.

●     If you deselect a mode, it cannot be selected anymore for each active type unless other modes are 
deselected.

●     It is not possible to activate both filter modes simultaneously (it does not make sense anyway). Only 
two states are available: either Feature Element Filter or Geometrical Element Filter is activated or 
both modes are deactivated. 

 By selecting Assembly Design commands, some filtering types turn disabled because they are inconsistent 
according to the elements allowed in the command.

●     You need to activate the User Selection Filter toolbar by selecting the View -> Toolbars command 
and clicking User Selection Filter.

●     Open the Assembly_01.CATProduct document.

http://canezou/AwsDocV5R14/Doc/online/cfysm_C2/samples/Assembly/Assembly_01.CATProduct


1.  Click the Coincidence Constraint icon: 

Note that the Volume Type icon is disabled according to the Coincidence Constraint 
specifications.

 

2.  Click the Surface Type icon: 

 
3.  Drag the mouse over any surface assembly.

 The cursor shape is modified when passing over a selectable element.

 

 

4.  Un-click the Surface Type icon:  and click Curve Type icon: 

 
5.  Drag the mouse over the same surface as previous.

 The forbidden cursor appears when passing over a selectable element.



 



Interoperability
This section contains interoperability information about the Assembly Design workbench.

Opening a CATIA Version 4 Assembly Document
Optimal CATIA PLM Usability for Assembly Design



Opening a CATIA Version 4 Assembly Document

This task will show you how to open a asm document, that is a CATIA V4 assembly into Assembly 
Design workbench.

1.  Click the Open icon:  

 The File Selection dialog box appears.

 
2.  In the File Selection dialog box, select the asm document of interest and click Open.

 The application converts the asm document into a CATProduct document. The new 
document has the same properties as the V4 document.

However, if the name of the V4 document includes special characters, the application 
converts these characters into new ones according to the characters equivalence table. For 
more about this table, please refer to Infrastructure User's Guide.

 In our example, the CRIC product normally includes three sub-products (BRANCH, 
CRIC_SCREW and CRIC_FRAME), but the application informs us that these components 
could not be retrieved. As a consequence, geometry is not available and constraints appear 
as broken in the specification tree:

 



 
3.  What you need to do is resolve the links to these documents. To do so, use the "Linked 

Document Localization" capability. To access it, select the Tools->Options... command 

then in the General category, click  the Document tab. Proceed as explained in 

Infrastructure User's Guide.

 Once the operation is done, you can reopen your asm document and note that the links are 
resolved. 

 You can then perform any operation you want. When saving this CATProduct document, you 
will not alter the original asm document

  



Optimal CATIA PLM Usability for Assembly 
Design

When working with ENOVIA V5, the safe save mode ensures that you only create data in CATIA 
V5 that can be correctly saved in ENOVIA V5.

 
ENOVIA V5 offers two different storage modes: Workpackage (Document kept - Publications 
Exposed) and Explode (Document not kept). Assembly Design has been configured to work in the 
both mode.

Assembly Design Commands in Enovia V5

 Please find below the list of the Assembly Design commands along with their accessibility status in 
Enovia V5.

Category Command Accessibility in 
Enovia V5 

Comment

Product 
Structure

Product management Available None

 Component Degrees of 
freedom

Available None

 Component constraints Available None

 Insert existing component 
with positioning

Available None

 Multi-instantiation / fast 
multi-instantiation

Available None

Assembly Update Available None

 Apply material Available None

 Catalog browser Available None

 Mechanical standard parts Available None

 Convert product to 
CATPart

Available None

Assembly 
Features

Local Update Available None

Constraints Coincidence Available None

 Contact Available None

 Offset Available None

 Angle Available None



 

 Fix Available None

 Quick constraint Available None

 Change constraint Available None

 Default mode Available None

 Chain mode Available None

 Stack mode Available None

 Fix Together Available You cannot perform a fix 
together containing another fix 
together.

 Deactivate Available None

 Display with leader Available None

 Display without leader Available None

 Name Display Available None

 Value Display Available None

 Formula Display Available None

 Reorder constraints Available None

 Stack mode Available None

Space 
Analysis

Clash Available None

 Sectioning Available None

 Distance Available None

 Compute Clash Available None

 Measure Item Available None

 Measure between Available None

 Measure inertia Available None

Move Manipulate Available None

 Smart Move Available None

 Snap Available None

 Translate / Rotate Available None

 Explode Available None

 Compass Available None

Analyze Update Available None

 Constraints Available None



 Degree of Freedom Available None

 Dependencies Available None

 Mechanical Structure Available None



Workbench Description

 The Assembly Design workbench looks like this (move the mouse over image's links and have the enlarged image and 
corresponding description pop up):

 

 

Assembly Design Menu Bar
Product Structure Tools Toolbar

Move Toolbar
Tools Toolbar

Constraints Toolbar
Assembly Features Toolbar

Annotations Toolbar
Space Analysis Toolbar

Scenes Toolbar
User Selection Filter Toolbar

Miscellaneous Symbols
Specification Tree

Symbols Reflecting an Incident in the Geometry Building
Referenced Geometry

http://canezou/AwsDocV5R14/Doc/online/asmug_C2/asmugwd0700.htm


 

Symbols Used in the Specification Tree

Miscellaneous Symbols
Product Structure

Symbols Reflecting an Incident in the Geometry
Referenced Geometry Symbols



Assembly Design Menu Bar
This section presents the main menu bar available when you run the application and before creating or opening a document:

Start File Edit View Insert Tools Analyze Windows Help

File
For... See...

New
Creating a New Assembly 
Document

Edit
For... See...

Update Updating an Assembly

Move Moving Components

Component Constraints
Selecting Constraints of  Given 
Components

Properties
Modifying the Properties of a 
Constraint



Insert
For... See...

Coincidence... Creating a Coincidence Constraint

Contact... Creating a Contact Constraint

Offset... Creating an Offset Constraint

Angle... Creating an Angle Constraint 

Fix Together... Fixing Components Together

Fix Fixing a Component

Quick Constraint Using the Quick Constraint 
Command

Reuse Pattern... Using a Part Design Pattern

Document Template Creation... Working with Interactive Templates

Create Scene Creating an Enhanced Scene



Fast Multi-Instantiation Fast Multi-Instantiation

Define Multi-Instantiation Defining a Multi-Instantiation

Views Creating a Projection View, 
Creating a Section View, Creating a 
Section Cut

Annotations Creating Annotations

Assembly Features Assembly Features

Tools
For... See...

Options... Customizing

Product Management... Managing Products in an Assembly

Publication... Using a Standard Part Contained in a 
Parametric Standard Part Catalog

Generate CATPart from Product... Generating CATPart from Product

Mechanical Standard Parts Using a Standard Part Contained in a 
Parametric Standard Part Catalog 

http://canezou/AwsDocV5R14/Doc/online/cfyugfdt_C2/cfyugfdtut0102.htm
http://canezou/AwsDocV5R14/Doc/online/cfyugfdt_C2/cfyugfdtut0103.htm
http://canezou/AwsDocV5R14/Doc/online/cfyugfdt_C2/cfyugfdtut0104.htm
http://canezou/AwsDocV5R14/Doc/online/cfyugfdt_C2/cfyugfdtut0104.htm
http://canezou/AwsDocV5R14/Doc/online/bascuasm_C2/bascuasm0000.htm


Scenes Browser Browsing Enhanced Scenes using the 
Scenes Browser

Analyze
For... See...

Update... Analyzing Updates

Constraints... Analyzing Constraints

Degrees of freedom... Analyzing Degrees of Freedom

Dependencies... Analyzing Dependences

Mechanical Structure... Flexible Sub-Assemblies

Compute Clash... Computing Clash between 
Components

Measure Item... Measure Minimum Distances and 
Angles

Measure Between... Measure Elements

Measure Inertia... Measure Inertia

Clash... Detecting Interferences

Sectioning... Sectioning

Distance Measuring Minimum Distances

http://canezou/AwsDocV5R14/Doc/online/cfyugmeasure_C2/cfyugmeasurebetween.htm
http://canezou/AwsDocV5R14/Doc/online/cfyugmeasure_C2/cfyugmeasurebetween.htm
http://canezou/AwsDocV5R14/Doc/online/cfyugmeasure_C2/cfyugmeasureitem.htm
http://canezou/AwsDocV5R14/Doc/online/cfyugmeasure_C2/cfyugmeasureinertia01.htm


Product Structure Tools Toolbar

See Fast Multi-Instantiation

Jump to Multi-Instantiation Sub-Toolbar

Multi-Instantiation Sub-Toolbar

See Defining a Multi-Instantiation

See Inserting an Existing Component with Positioning



Move Toolbar

See Translating Components or Rotating Components(P1 configuration)

See Manipulating Components

Jump to Supports Sub-Toolbar

See Exploding a Constrained Assembly

See Stop Manipulation on Clash

Snap Sub-Toolbar

See Snapping Components

See Smart Move or Smart Move with Viewer



Update Toolbar 

See Updating an Assembly 



Constraints Toolbar 

See Creating a Coincidence Constraint 

See Creating a Contact Constraint 

See Creating an Offset Constraint 

See Creating an Angle Constraint 

See Fixing a Component 

See Fixing Components Together 

See Using the Quick Constraint Command 

See Flexible Sub-Assemblies 

See Changing Constraints 

See Using a Part Design Pattern 



Assembly Features Toolbar 

Jump to Assembly Features Sub-Toolbar

See Performing a Symmetry on a Component 

Assembly Features Sub-Toolbar

See Assembly Split

See Assembly Hole and Using Hole Series

See Assembly Pocket

See Assembly Add

See Assembly Remove



Annotations Toolbar

See Creating Weld Features  

See Creating a Text With Leader  

See Creating a Flag Note With Leader 



Space Analysis Toolbar

See Detecting Interferences 

See Sectioning 

See Measuring Minimum Distances 



Scenes Toolbar 

See Creating an Enhanced Scene.

See Browsing Enhanced Scenes using the Scenes Browser.



User Selection Filter Toolbar 

See Selecting Using a Filter 

See Selecting Using a Filter 

See Selecting Using a Filter 

See Selecting Using a Filter 

See Selecting Using a Filter 

See Selecting Using a Filter 



Miscellaneous Symbols
 

 Miscellaneous

 

 PartBody

A part body. You have access to the part's features, 
the way it is organized (Pad, Pocket, Intersection, 
etc.).

xy plane

xy plane, yz plane or zx plane. You can click the 
desired reference plane either in the geometry area or 
in the specification tree.

Formula defined for Point.1. For more about formulas, 
please refer to Infrastructure User's Guide Version 5.

 BODY1
A model with geometrical representation.

 Sketch.1

Sketch. For more information about Sketcher 
Workbench, refer to : Entering the Sketcher 
Workbench in Sketcher User's Guide.

 AbsoluteAxis

Absolute Axis: contains information about Origin, 
HDirection and VDirection.

 Origin
Origin. 

 HDirection
HDirection or VDirection.



 Geometry

Geometry (Point, Line,...): Wireframe and Surfaces 
features.

 Constraints
Constraints: Parallelism, Perpendicularity, etc.

 face

Publication : a CATPart or CATProduct element is 
published that is to say its geometrical data is 
exposed. For more information refer to Managing a 
Product Publication in Assembly User's Guide.

Assembly hole. For more about Assembly features, 
please refer to Assembly Design User's Guide Version 
5. 

 Open_body.1

External references branch of the part : external 
geometry (a face, a point or a line) is copied/imported 
from driving parts to contextual parts that are being 
driven (Design in context). You can customize 
External References in Tools -> Options -> 
Infrastructure -> Part Infrastructure, select the 
General tab and check the box Keep links with 
selected object.

  

 Product4

A product in NO SHOW. By clicking in the 
CATProduct's contextual menu or by using the 

Hide/Show icon , you can put the product in the 
SHOW or NO SHOW area, the product's geometry is 
hidden. As a consequence, the documents under it, 
for instance the CATPart is in the NO SHOW space as 
well. 
For more information about the SHOW/NO SHOW 
modes, see Displaying Hidden Objects in 
Infrastructure's User Guide.



 Part5
A part in NO SHOW.

The Sketcher symbol is by default in NO SHOW. By 
this means the geometry lighter. But you can 
reactivate the Sketcher representation by clicking in 
the contextual menu or by using the Hide/Show icon 

. By double-clicking on this symbol you can 
return into the Sketcher workbench.



Product Structure Symbols

Product Structure

 Product1

A product. For more information, refer to Insert a New Product 
in Product Structure User's Guide.

 Product2

A component or sub-product. For more information, refer to 
Insert a New Component in Product Structure User's Guide.

 Flexible_product

The purple little wheel to the left corner of the CATProduct icon 

and the light bar  identify a flexible sub-assembly. For more 
information, refer to Soft Sub-Assemblies in Product Structure 
User's Guide.

 Part.1
Instance of a part. This symbol  means that there is a 
geometrical representation of the part and that it is activated.

  

 
Part_with_DeactivatedRepresentation

The representation of this part is deactivated. This symbol 
means the geometric representation is deactivated. Before 
opening a document, you choose the activate or deactivate 
Shape representation in Tools->Options->Infrastructure, 
select the Product Structure tab and check the box entitled Do 
not activate default shapes on open.
For a particular instance in the document, you can deactivate or 
activate it by selecting the Representations -> Deactivate 
Node / Activate Node contextual commands.

 
Component_with_DeactivatedRepresentation

The representation of this component is deactivated.



Contextual parts:

For contextual parts, the reference keeps a link with the Original or Definition Instance (or Original Part).

For each parts, every instance keeps a link with its reference. But the Contextual Reference (or Contextual 
Part) has only one link, with a single instance which is contextual. This unique link allows you to know the 
name of the document (CATProduct) on which the part 's external geometry rests.

There is a distinction between the Original Instance and the subsequent Contextual References because the 
geometrical definition of contextual Parts depends on neighboring components (support) in the Assembly. 
The Geometry of the Contextual Part depends on another instance in the same Assembly (second link).

Three Instances of Contextual Part exist:

_  Definition Instance

This icon shows that the Part Reference is contextual and this 
Instance is the Definition Instance. The green gear and the blue 
chain signify the "original" instance of a part that is contextual 
(driven by another part, built with another part's data) in a 
CATProduct.

_  Instance of the Definition Instance

This contextual part, represented by the white gear and the 
green arrow, is an Instance of the Definition Instance, coming 
from the Contextual Part. The geometry of this instance is 
connected with the Definition Instance (contextual link). Note 
that you can edit this contextual part.

 

_  Other Instance of the Contextual 
Part

The brown gear and the red flash signify that the Part reference 
is contextual and that this instance is not used in the Part 
Definition. Note that you can edit this Contextual Part. This 
symbol can appear when you copy / paste or insert a Contextual 
Part into another CATProduct without taking into account the 
contextual links.

In this case the user needs to resort to the "Define Contextual 
Links" or "Isolate Part" commands in order to redefine the 
context of the Part and this red flash will be turned into a blue 
chain or green arrow.

For more information, please read the following scenarios: 
Defining Contextual Links: Editing and Replacing 
Commands, and Isolating a Part in Product Structure User' 
Guide.

 Part1

Reference of a part. For more information, refer to Insert a New 
Part in Product Structure User's Guide.



  

 Deactivated_Component

A deactivated component. The shape representation is 
deactivated; its geometry is not visible. This functionality can 
occur simultaneously on several documents containing this 
component, especially when this component is the instance of a 
reference. This operation is equivalent to the Delete operation 
because the reference of the component no longer exists within 
the Bill Of Material.

 Deactivated_Product
A deactivated product.

 Unloaded_Product

The geometry  of the component disappears. The product is 
downloaded, its references are missing but the user is able to 
find them back.



Symbols reflecting an incident in the Geometry building
Miscellaneous Incidents

Incidents on Constraints

Miscellaneous Incidents

Part to be updated

 Product5

No visualization of the product or the part. The product's reference cannot be found. The geometry of the component 
disappears.

 PartBody
A broken link. The access to this product is impossible because the link with the root document has been lost.

A broken shaft.

The pocket's representation is deactivated.

Isolated plane (can no longer be edited)

Incidents on Constraints

 Offset.1
A broken constraint. The access to this product and the information about its constraints cannot be retrieved.

 Parallelism.1
A deactivated constraint (a parallelism constraint).



 Perpendicularity.1
A constraint to be updated (a perpendicularity constraint).



Referenced Geometry

 Referenced Geometry
Geometry copied from a document different from the 
CATPart document in which it is pasted.

Initial geometry has undertaken modifications in the 
original CATPart document: solid to be synchronized.

Initial geometry has been deleted in the original 
CATPart document or the original CATPart document 
has not been found

Pointed document found but not loaded (use the Load 
contextual command or the Edit -> Links command)

External link deactivated so that geometry cannot be 
synchronized during the update of the part (even if the 
option "Synchronize all external references for update" 
is on).
Geometry pasted (using the As Result with Link option) 
within the same CATPart document from which it is has 
been copied
Point referenced in the CATPart document is a 
published element.

Sketch referenced in the CATPart document is a 
published element. The published point has undertaken 
modifications so that a synchronization is required.



Customizing

 Before you start your first working session, you can customize the way you work to suit your habits.
This type of customization is stored in permanent setting files: these settings will not be lost if you end your session.

1.  Select the Tools -> Options command.

 The Options dialog box opens.

 
2.  Select the Mechanical Design category in the left-hand box.

 
3.  Select the Assembly Design sub-category.

 Various tabs let you set assembly and constraint settings to be used in an assembly document.

 

 
●     The General tab lets you set the general options.

●     The Constraints tab lets you define the constraint options.

●     The DMU Sectioning tab lets you define the digital mock-up sectioning options.

 
4.  Select the General category in the left-hand box.

 
5.  Select the Parameters and Measure sub-category.

 Various tabs are displayed, the symbol tab lets you set constraint appearance settings to be used in an assembly document.

 

 
●     The Symbols tab lets you set the constraint appearance options.

 
6.  Select the Infrastructure category in the left-hand box.

 
7.  Select the 3D Annotations Infrastructure sub-category.

 Various tabs let you set annotation settings to be used in an assembly document.

 

 
●     The Tolerancing tab lets you set the tolerancing options.

●     The Display tab lets you define the annotation display options.

●     The Manipulators tab lets you set the manipulator options.

●     The Annotation tab lets you the annotation display options.

●     The View/Annotation Plane tab lets you define the view/annotation plane options.

 
8.  Select the Product Infrastructure sub-category.

 Two tabs also interfere with Assembly Design.

 



●     Cache Management

●     Cgr Management

 
9.  Select the General category in the left-hand box.

 
10.  Select the General sub-category.

 The General tab lets you set whether the referenced documents in a CATProduct are loaded.

 

 
●     Loading of Referenced Document



General 

This page deals with the options concerning:
●     The Update.

●     The Update propagation depth.

●     The Compute exact update status at open.

●     The Access to geometry.

●     The Move components involved in a Fix Together.

Update

Defines the assembly update activating options, which affects Assembly constraints, Assembly features, Weld features, contextual design:

●     Automatic: updates the assembly automatically after each interaction.

●     Manual: lets you decide when you need to update your assembly.

 By default, the Manual option is selected.

Update propagation depth

Defines the assembly update propagation options, which affects Assembly constraints, Assembly features, Weld features:

●     Active level: updates the child components of the active components only.

●     All the levels: updates all the components recursively from the active components.

 By default, the All the levels option is selected.

Compute exact update status at open

Defines the update status when you are opening an assembly document or inserting an assembly component.

This option is only taken into account when you work with the Work with the cache system option selected, which is located in 
the Infrastructure -> Product Structure ->Cache Management -> Cache Activation frame.

 

 

  By default, this option is not selected.



●     Automatic: loads the minimal data needed in assembly components to determine the update status of the assembly: updated or not.

●     Manual: displays the Unknown Status Update icon when the minimal data needed are not loaded to determine the update status of 
the assembly.

 By default, the Manualoption is selected.

Access to geometry

Ensures that the application will automatically launch the Design mode when using the following commands: constraints creation, reuse 
pattern and define multi-instantiation.

This option is only taken into account when you work with the Work with the cache system option selected, which is located in 
the Infrastructure -> Product Structure ->Cache Management -> Cache Activation frame.

 

 

  By default, this option is not selected.

Automatic switch to Design mode

Defines whether the automatic switch is allowed.

 By default, this option is selected.

Move components involved in a Fix Together

Defines the move behavior for the components involved in a Fix Together.

Extend selection to all involved components?

Defines the move selection extending.

●     Always: ensures to move all the components involved in a Fix Together without warning.

●     Never: ensures to move only the selected component involved in a Fix Together without warning.

●     Ask each time: ensures to display of a warning message that appears when moving components.
The warning message will appear whenever you will apply the following commands to components fixed together: compass, Snap, 
Translation or Rotation or Manipulate.

 By default, the Never option is selected.



Constraints 

This page deals with the options concerning:
●     The Paste components.

●     The Constraints creation.

●     The Quick Constraint.

Paste components

Defines the paste component behavior options:

●     Without the assembly constraints: pastes one or several components without the assembly constraints applying to them.

●     With the assembly constraints only after a Copy: pastes one or several components with the assembly constraints applying 
to them, only after the Copy command.

●     With the assembly constraints only after a Cut: pastes one or several components with the assembly constraints applying 
to them, only after the Cut command.

●     Always with the assembly constraints: pastes one or several components always with the assembly constraints applying to 
them.

 By default, the Without the assembly constraints option is selected.

Constraints creation

Defines the constraint creation options:

●     Use any geometry: allows you to select any geometrical element.

●     Use published geometry of child components only: allows you to select any published element belonging to child 
components.
For more information about publication, refer to Managing a Product Publication in the Assembly Design documentation.

●     Use published geometry of any level: allows you to select any published element.

 By default, the Use any geometry option is selected.

Quick Constraint



The Quick Constraint command is based on a ordered list of constraints to be created by the application. The setting available 
here lets you reorder the list of constraints having priority when applying the Quick Constraint command to the selected 
geometrical elements. What you need to do is select the constraint type you wish to reorder and click the arrows to the right of the 
selection to reorder the selected constraint.

 By default, the ordered list is the following:
●     Surface contact.

●     Coincidence.

●     Offset.

●     Angle.

●     Parallelism.

●     Perpendicularity.

Creation verified constraints first 

Defines whether you want to create verified constraints with the Quick Constraint command.

 By default, this option is not selected.



DMU Sectioning  

The DMU Sectioning tab contains three categories of options:

●     Section planes

●     Section grid

●     Results window

Section Planes

Default color

Use the color chooser to define the default color of section planes.

 By default, color is as shown above.



Normal X, Y, Z

Select the option specifying the absolute axis along which you want to orient the normal vector of the section 
plane (master plane in the case of slices and boxes).

 By default, the normal vector is oriented along X.

Origin

Select the option locating the center of the plane: 

●     0,0,0: at absolute coordinates 0,0,0

●     Selection: at the center of the bounding sphere around the products in the selection you defined.

 By default, the origin option is set to Selection.

Hide the plane

Selecting this checkbox hides the plane on exiting the command. If cleared, the plane is kept in the Show 
space on exiting the command.

 By default, this option is selected.

Hide the section results in the No Show space

Selecting this checkbox transfers the section results to the No Show place on exiting the command.

 By default, this option is cleared.

Automatic computation of the result

Selecting this checkbox automatically updates sectioning results while manipulating the plane. If cleared, 
sectioning results are computed when you release the mouse button.

 By default, this option is selected.

Wireframe elements cut

Selecting this checkbox takes wireframe elements into account and the section plane sections any wireframe 
elements present. Points represent the intersection of the plane with wireframe elements.
If cleared, wireframe elements are not taken into account. 

 By default, this option is selected.



Allow measures on a section created with a simple plane

Selecting this checkbox gives the same 3D section cut display for a plane as in the case of a slice or box and 
lets you make measures on the wireframe section cut.

 By default, this option is checked.

Section Grid

Mode

Select the option to locate the grid:

●     Absolute: sets grid coordinates with respect to the absolute axis system of the document.

●     Relative: places the center of the grid on the center of the section plane (master plane in the case of 
slices and boxes).

 By default, the mode is set to Absolute.

Style

Select the option defining how the grid is represented: Lines or Crosses.

 By default, the style is set to Lines .

Steps - Automatic filtering

Selecting this checkbox automatically adjusts the level of detail of the grid display when you zoom in and out.

 By default, this option is cleared.



Steps - Width, Height

In the Width and Height boxes, type or select a new value to specify the spacing between grid lines. Units 
are current units set using  Tools -> Options.

 By default, width and height are set to 100.

Steps - Automatic grid resizing

Selecting this checkbox automatically re-sizes the grid to section results when moving the section plane. If 
cleared, the grid has the same dimensions as the section plane.

 By default, this option is selected.
Automatic grid resizing ON: Automatic grid resizing OFF:

Results Window



Automatically open

Selecting this checkbox always displays the Section viewer when in the Sectioning command. 
Note: If cleared, the preview window is displayed. 
If, in addition, you clear the Sectioning preview option in the Digital Mockup General tab (Tools -> Options -
> Digital Mockup -> General), then no viewers are displayed.

 By default, this option is selected.

Always 2D view

Selecting this checkbox locks the Section viewer in a 2D view. If cleared, you can work in a 3D view.

 By default, this option is selected.

Automatically reframe

Selecting this checkbox automatically fits the results into the available space in both the Section viewer and 
preview window when manipulating the section plane in the document window.

 By default, this option is cleared.

Section fill

Selecting this checkbox fills in the section to generate a surface for measurement and display purposes.

 By default, this option is selected.



Symbols

This tab deals with with these categories of options:

●     Constraint Style

●     Dimension Style

●     Display at Creation

●     Preview

Constraint Style

Defines the constraint style options:

Resolved constraint

Defines the color status for resolved constraints.

 By default, the color is green. See the screen capture.

Unresolved constraint

Defines the color status for unresolved constraints.

 By default, the color is dark green. See the screen capture.

Overstrained 

Defines the color status for overstrained constraints.

 By default, the color is purple. See the screen capture.

Invalid geometry

Defines the color status for constraints set on a geometry became invalid.

 By default, the color is dark red. See the screen capture.

Status Color Visualization



Defines if the default status color or the graphical user defined color is displayed on constraint.

 By default, this option is not selected (default status color).

View Angle

Defines the angle from which the constraint is displayed in the geometry area, when you are rotating the geometry.
This angle is measured between the normal to the screen and the constraint direction.

 By default, the value is 1deg.

Filter...

Click this button to display the Constraint Filter dialog box.

Filter

Defines the general filter options:
●     Show all: displays all the constraints.

●     Conditional Filter: displays the constraints according to the Status Filter, Product and Filter by Type selected options.

●     Hide all: hides all the constraints.

 By default, the Show all option is selected.

Status Filter



Defines the status filter options:
●     Do not filter status: displays the constraints without take into account their status, verified or not.

●     Filter unverified constraints: displays the unverified constraints only.

●     Filter verified constraints: displays the verified constraints only.

 By default, the Do not filter status option is selected.

Product

Defines the product filter option:
●     Show on active product: defines whether the constraints of the active product only are displayed.

 By default, this option is not selected.

Filter by Type

Defines the filter by type options:
●     Dimensions: defines whether dimension constraints are displayed.

●     Angles: defines whether angle constraints are displayed.

●     Fixed Angles: defines whether fixed angles constraints are displayed.

●     Tangencies: defines whether tangency constraints are displayed.

●     Coincidences: defines whether coincidence constraints are displayed.

●     Equalities: defines whether equal constraints are displayed.

●     Fixities: defines whether fix constraints are displayed.

●     Concentricities: defines whether concentricity constraints are displayed.

●     Chamfers: defines whether chamfer constraints are displayed.

●     Driven: defines whether driven constraints are displayed.

●     Driving: defines whether driving constraints are displayed.

 By default, all these options are selected.

Dimension Style

Defines the dimension style options:

Scale



Defines the size of the graphical symbols for constraint (tangency, parallelism, leader arrow) options:
●     Small: displays small symbols.

●     Medium: displays medium symbols.

●     Large: displays large symbols.

 By default, the Medium option is selected.

Displays iconified constrained elements

Defines whether the iconified constrained elements are displayed.

 By default, this option is selected.

Highlight constrained elements

Defines whether the constrained geometries are highlighted when you pre-select a constraint.

 By default, this option is selected.

Gap

Defines the distance between the constrained geometries and constraint extension lines.

 By default, the value is 2mm.

Overrun

Defines the distance between the constraint dimension lines and constraint extension lines.

 By default, the value is 2mm.

Display at Creation

Defines the constraint display options:

Display Mode

●     Value: displays the constraint value only.

●     Name: displays the constraint name only.

●     Name+Value: displays the constraint name and value only.

●     Name+Value+Formula: displays the constraint name and value or the constraint name and formula.

 By default, the Value option is selected.

Preview



Pre-visualizes the constraint appearances according to the Constraint Style, Dimension Style and Display at Creation options.



Tolerancing 

This page deals with the options concerning:
●     The Tolerancing Standard.

●     The Leader associativity to the geometry.

Tolerancing Standard

Defines conventional standard options:

Default standard at creation

●     ASME: American Society for Mechanical Engineers

●     ASME 3D: American Society for Mechanical Engineers

●     ANSI: American National Standards Institute

●     JIS: Japanese Industrial Standard

●     ISO: International Organization for Standardization

 By default, the ISO standard is selected.

Leader associativity to the geometry

Defines the leader associativity options:

●     Free: specifies that leader annotations are freely positioned relative to their geometrical elements.

●     Perpendicular: specifies that leader annotations are positioned perpendicular to their geometrical elements.

 By default, the Free option is selected.



Display 

This page deals with the options concerning:
●     The Grid.

●     The Annotations in Specification Tree.

Grid

Defines the grid options:

Display

Defines whether the grid is displayed.

 By default, this option is not selected.

Snap to point

Defines whether annotations are snapped to the grid's point. 

 By default, this option is not selected.

Allow Distortions

Defines whether grid spacing and graduations are the same horizontally and vertically.

 By default, this option is not selected.

H Primary spacing

Defines the grid's horizontal spacing.

 By default, the value is 100mm.

H Graduations

Defines the grid's horizontal graduations.

 By default, the number of graduation is 10.

V Primary spacing

Defines the grid's vertical spacing, available only if Allow Distortions is selected.

 By default, the value is 100mm.

V Graduations



Defines the grid's vertical graduations, available only if Allow Distortions is selected.

 By default, the number of graduation is 10.

Annotations in Specification Tree

Defines the annotations in specification tree options:

Under Geometric Feature nodes

Defines that 3D annotations should be displayed under the geometric feature nodes in the specification tree. This lets you view 3D 
annotations under the Part Design or Generative Shape Design feature nodes to which they are applied.

 By default, this option is not selected.

Under View/Annotation Plane nodes

Defines that 3D annotations should be displayed under the view/annotation plane nodes in the specification tree. This lets you view 
3D annotations under the view node to which they are linked.

 By default, this option is not selected.

Under Annotations Set node

Defines that 3D annotations should be displayed under the annotation set node in the specification tree, available only if Under 
View/Annotation Plane nodes is selected.

 By default, this option is selected.



Manipulators

This page deals with the options concerning:
●     The Manipulators.

Manipulators

Defines the manipulator options:

Reference size

Defines the annotation manipulator's size.

 By default, the reference size is 2mm.

Zoomable

Defines whether the annotation manipulator is zoomable or not.

 By default, this option is selected.



Annotation 

This page deals with the options concerning:
●     The Annotation Creation.

Annotation Creation

Defines the annotation creation options:

Annotation following the mouse (Ctrl toggles)

Defines whether the annotation is positioned according to the cursor, following it dynamically during the creation process or not.

 By default, this option is not selected.



View/Annotation Plane 

This page deals with the options concerning:
●     The View/Annotation Plane Associativity.

●     The View/Annotation Plane Display.

View/Annotation Plane Associativity

Defines the View/Annotation Plane associativity options:

Create views associative to geometry

Creates views associative to the geometry, so that views and their annotations are automatically updated when the geometry is 
modified.

 By default, this option is selected.

View/Annotation Plane Display

Defines the View/Annotation Plane display options:

Current view axis display

Defines whether the active annotation plane axis system is displayed.

 By default, this option is selected.

Zoomable

Defines whether the annotation plane axis is zoomable.

 By default, this option is selected.

Visualization of the profile in the current view

Defines whether the view/annotation plane profile on the part/product is displayed. 

 By default, this option is not selected.



Cache Management for CATProduct and CATProcess 
Document 

This page deals with the options concerning:
●     The Cache Activation.

Cache Activation

Please refer to Infrastructure user's guide to know more about the Product Structure Cache Management options.

Work with the cache system

You need to select this option to work with the cache system. When selected, this option allows you work in Visualization mode, 
otherwise you are working in Design mode.

 By default, this option is not selected.



 Cgr Management for 3D Annotation 

This page deals with the options concerning:
●     The Applicative data.

Applicative data

Please refer to Infrastructure user's guide to know more about the Product Structure Cgr Management options.

Save FTA 3D Annotation representation in cgr

You need to select this option to add the 3D annotations representation contained in a CATProduct or a CATProcess document to 
the generated cgr documents. This option is taken into account when the Cache Activation option is selected only.

 By default, this option is not selected.



Loading of Referenced Document 

This page deals with the options concerning:
●     The Referenced Documents.

Referenced Documents

Please refer to Infrastructure user's guide to know more about the Product Structure General options.

Load referenced documents

You need to select this option to load the related documents with a CATProduct document.

 By default, this option is selected.



Reference Information
This section contains reference information about the Assembly design workbench.

Assembly Update
Constraints

Design in Assembly Context
Assembly Features
Batches and Macros



Assembly Update

This reference will describe the assembly update behaviors which are apply to Assembly Design, 
Weld Design and other related workbenches.

When updating an assembly, you are updating the following elements:

●     Assembly constraints.

●     Assembly features.

●     Knowledgeware relations.

●     Weld features.

●     Geometry of part document.

●     Functional Tolerancing & Annotations features.

●     Measures.

See also Update, Update propagation and Compute exact update status at open options.

Update Status
There are three update status when you are designing an assembly, these status are computed 
from the current state of the assembly: 

The assembly is updated: all elements are up to date.

The assembly is not updated: one element at least is not up to date.

The assembly update status is unknown: there is not enough information to determine the 
update status (updated or not). This status appears when an element is contained into a 
component in visualization mode.



Constraints

This reference will describe assembly's constraints.

 About Assembly Constraints

Coincidence Constraints

Contact Constraints

Offset Constraints

Angle Constraints



About Assembly Constraints 

This reference describes what you should know to create assembly constraints:
●     Rules

●     Symbols

●     Tip

●     Geometry

●     Customizing Constraints

●     Selection

●     V4 Interoperability
 

 

Rules
Setting constraints is rather an easy task. However, you should keep in mind the following::

●     You can apply constraints only between the child components of the active component.
Do not mistake the active component for the selected component:

❍     The active component is blue framed (default color) and underlined. It is activated by double-
clicking.

❍     The selected component is orange framed (default color). It is selected by clicking.

●     You cannot define constraints between two geometrical elements belonging to the same 
component.



●     You cannot apply a constraint between two components belonging to the same subassembly if this 
subassembly is not the active component.

●     If you modified any geometrical elements of a constraint, take care if it already exists to solve the 
constraint, example, the axis of the spot facing in a counterbored hole disappears when the hole 
type is changed.

❍     There are two offset constraints:
■     Offset.1 between the Part2 and the axis of the hole (sky blue) in Part1.

■     Offset.2 between the Part2 and the axis of the spot facing of the hole (orange) in Part1.

❍     When changing the hole type from Counterbored to Simple, the spot facing is deleted as its 
axis.

■     The Offset.2 constraint is disconnected:



●     The following example illustrates what you are allowed to do:

❍     (1) The constraint cannot be applied because Product K does not belong to the active 
component Product B. To define this constraint, Product A must be made active.

❍     (2) The constraint cannot be applied because Product E and Product F both belong to a 
component other than the active component Product B. To define this constraint, Product D 
must be made active.



❍     (3) The constraint can be applied since Product C belongs to the active component Product B 
and also Product E is contained within Product D which is contained within the active 
component Product B.

●     When you set a constraint, there are no rules to define the fixed and the movable component 
during the selection. If you want to fix a component, use the Fix command. See Fixing a 
Component.

 

Symbols
 The following table lists the symbols used to represent the constraints you can set between your 

components:

 
Constraints Symbol used in the geometry 

area
Symbol displayed in 
the specification tree

Coincidence

Contact

Contact
(point)

Contact
(line)

Offset

Angle
Planar Angle



Parallelism

Perpendicularity

Fix

 
Note also that deactivated constraints are preceded by the symbol ( ) in the specification tree.

 

Tip
 The name of a constraint displays when passing the mouse over that constraint. 

 

 

Geometry
 To set constraints it is possible to select the geometry (plane, line or point) resulting from 

intersections, projections or offsets from the specification tree. For more about these operations, 
please refer to Generative Shape Design User's Guide.

 

Customizing Constraints



 The application lets you customize the creation and the display of constraints. For more information, 
please refer to Customizing Assembly Constraint and Customizing Constraint Appearance.

 

Selection
 To facilitate alternative selections when the geometry to be constrained is not directly accessible, the 

Other Selection... contextual command allows to you select the desired geometry.

 In a cone example, its face is selected when you select the Other Selection... contextual command.

 

 The Other Selections dialog box appears, the Face geometry element is selected.

 



 In the the dialog box you can directly select the Extremity or the Axis geometry elements of the cone 
and show this selection in the geometry window as in the following images:

 



 

 

V4 Interoperability
 You can set a constraint on a SOLIDE (solid exact) CATIA V4 feature, but you cannot set set a 

constraint on a SOLIDM (solid mockup) CATIA V4.



Coincidence Constraints 

Coincidence-type constraints are used to align elements.

 Depending on the selected elements, you may obtain concentricity, coaxiality or coplanarity. The 
tolerance i.e. the smallest distance that can be used to differentiate two elements is set at 10 -3 
millimeters.

 The following table shows the elements you can select for a coincidence constraint.

 

Point Line Plane Sphere 
(center)

Cylinder 
(axis) Cone Axis 

System Curve Tabulated 
Cylinder Surface

Point
 

NA NA

Line NA NA NA NA NA

Plane NA NA NA NA NA

Sphere 
(center) NA NA NA NA NA NA

Cylinder 
(axis) NA NA NA NA NA NA

Cone NA NA NA NA NA NA NA NA NA

Axis 
System NA NA NA NA NA NA NA NA NA

Curve NA NA NA NA NA NA NA NA NA

Tabulated 
Cylinder NA NA NA NA NA NA NA NA NA

Surface NA NA NA NA NA NA NA NA NA

 
●     NA: Not Applicable.



To create a coincidence constraint between axis systems, they must have the same direction and the 
same orientation in the product.

 You can also create coincidence between an axis system and components of another axis system:

 
●     Origin point.

●     Reference plane, in this case the reference plane must be parallel to the axis system.



Contact Constraints 

Contact-type constraints can be created between two directed surfaces. Directed means that an 
internal side and an external side can be defined from a geometrical element, a surface of a pad for 
example. This definition excludes surfacic element and wireframe surface because they are not 
directed.

 The common area between the two surfaces  can be a plane (plane contact), a line (line contact) or 
a point (point contact).

 The following table shows the elements you can select for a contact constraint.

 

 
Planar 
Surface Sphere Cylinder Cone Circle

Planar 
Surface  

NA NA

Sphere
   (1)

NA

Cylinder NA
  (2)

NA NA

Cone NA NA

Circle NA NA NA

 
●     NA: Not Applicable.

●     (1) A sphere-sphere contact is possible when their radius are equal. The contact constraint 
resulting is equivalent to a coincidence constraint, spheres look like merged.

●     (2) A cylinder-cylinder contact is possible when their radius are equal. The contact constraint 
resulting is equivalent to a coincidence constraint, cylinders look like merged.



Offset Constraints 

When defining an offset-type constraint between planar elements, you need to specify how faces should be oriented.
The offset value is always displayed next to the offset constraint.

 The unit used is the unit displayed in the Units tab of the Tools -> Options dialog box. If you wish, you can customize it.

 The following table shows the elements you can select for defining an offset constraint.

 

 
Point Line Plane Planar 

Face

Point NA

Line NA

Plane

Planar 
Face NA NA

 
●     NA: Not Applicable.

 

Positive and Negative Offsets
 When setting an offset constraint, you can define positive or negative offset values. For this, remember that:

 
●     At least one of the components to be constrained must be a planar element, otherwise you cannot set positive nor negative offset 

values.

●     The vector normal to the planar element indicates the positive offset value.

●     If the planar element is an oriented plane, the normal vector pointing to the side opposite to material indicates the positive value.

●     If the planar element is a wireframe plane, the application automatically deduces the positive or negative value. Green arrows show 
the positive value.

 

 
●     If both components are planar elements, the selection order of the elements affects the result when using the orientation 

option (Same, Opposite, Undefined). The normal to the first selected element gives the positive value.



 



Angle Constraints 

Angle-type constraints fall into three categories.
When defining an angle constraint between planar elements, you need to specify how faces should 
be oriented.
The offset value is always displayed next to the offset constraint:

 
●     Angle

●     Parallelism (when angle value equals zero), when setting a parallelism constraint, green arrows 
appear on the selected faces to indicate the orientations.

●     Perpendicularity (angle value equals 90 degrees)

 When setting an angle constraint, you will have to define an angle value. Note that this angle value 
must not exceed 90 degrees.

 The tolerance i.e. the smallest angle that can be used to differentiate two elements is set at 10-6 
radians.

 The following table shows the elements you can select for an offset constraint.

 

 
Line Plane Planar 

Face
Cylinder 
(axis)

Cone 
(axis)

Line

Plane

Planar 
Face

Cylinder 
(axis)

Cone 
(axis)



Design in Assembly Context 

Assembly Design can be cooperatively used with Part Design in many ways.
If in a CATProduct document you can design parts from scratch or reshape them, you can also 
create associative links between several parts. These links can be geometrical and are then referred 
to as External references"or parametrical then referred to as External parameters  in the 
specification tree. Assembly Design provides a large range of commands or options to manage 
those links.
These capabilities are:

 
●     Keep link with selected object option lets you maintain the links between external 

references, copied elements for example, and their origins when you are editing these 
elements. For more information, see Customizing General Settings, External References.

●     Isolate contextual command: cuts the link between external references and their origins.
Management of both assembly constraints and design in context: it is possible to set constraints 
between published geometrical elements. See Constraint Creation in customizing assembly 
constraints.

●     Edit Links, see Displaying Document Links and Editing Documents Links in Infrastructure User's 
Guide.

●     Copy of external elements to update parts outside assembly context.

●     Automatic synchronization during update operations, or manual synchronization.

●     Activate/Deactivate link.

●     Publication: to reuse existing designs and manage links. For more information, see Customizing 
General Settings, External References.

●     Copy Break/Link/New From to quickly reuse a part.

http://canezou/AwsDocV5R14/Doc/online/bascuprt_C2/bascuprt0200.htm
http://canezou/AwsDocV5R14/Doc/online/bascuprt_C2/bascuprt0200.htm
http://canezou/AwsDocV5R14/Doc/online/bascuprt_C2/bascuprt0200.htm




Assembly Features

This reference will describe Assembly Feature behaviors in assembly document and their Resulting 
Features in part document.

 

Visualization Mode
 According to the Access to geometry option, part documents in Visualization Mode affected by an 

Assembly Feature swap automatically or not to the Design Mode:

 
●     If the Automatic switch to Design mode option is checked:

❍     Assembly feature creation: selected part documents swap automatically from Visualization 
Mode to the Design Mode to create it.

❍     Assembly feature edition: affected part documents swap automatically from Visualization 
Mode to the Design Mode to edit it.

❍     Assembly feature deletion: affected part documents swap automatically from Visualization 
Mode to the Design Mode to delete it.

 
●     If the Automatic switch to Design mode option is unchecked or if the part document is 

unloaded:
❍     Assembly feature creation: selected part documents are not modified.

❍     Assembly feature edition: affected part documents cannot be modified.

❍     Assembly feature deletion: the Assembly Feature is deleted in the assembly document, but 
not the Resulting Features in the affected part documents. The Broken mask will appear on 
the specification tree Resulting Features icons, when the part will be loaded.

 

Links of Resulting Features
 In Part Design context:

●     The Edit -> Links... command show the links of the part's Resulting Features.

●     The Parent/Children... command on a Resulting Feature show the Assembly Feature link.

If the link is broken, the Broken mask appears on the specification tree icons.

 

Isolate Resulting Features
 To edit, copy, paste or delete a Resulting Feature, you must isolate it before these operation. In 

this case the resulting Feature behavior is the same as its Part feature equivalent. Take care that 
you cannot reconnect an isolated Resulting Feature.

 

Design in Context



 Assembly features are always design in context and the Keep link with selected object option 
lets you maintain the links between external references only:

●     If you wish to isolate a resulting feature, run the Isolate contextual command.

●     If you wish to create a feature on only one part, edit the part directly.

See Design in Assembly Context for more information.



Batches and Macros

This reference will describe batches and macros dedicated for Assembly Design workbench.

 Data Upgrade for Large Assemblies Performances: Tool to upgrade Assembly data to benefit from 
V5R10-11 performances improvements.



Data Upgrade for Large Assemblies Performances

In Releases 10, 11 and 12, several projects have been conducted to reduce the amount of memory 
required for an assembly in specific scenarios.

All those scenarios start with loading the assembly in visualization mode, and allow the user:

 
●     To stay in visualization mode (actually product mode, typically from 10% to 15% more than 

visualization mode) and to get the up-to-date status of the assembly, with constraints, design in 
context or knowledgeware relations.

●     To switch to Brep mode for assembly constraint creation, for drawing update.

 The major benefit of those enhancements is to lower the required amount of memory used in those 
typical scenarios. The drafting creation can start at a much lower memory point, leaving enough 
memory for the necessary processing to generate the drawing.

 Yet, the benefit of those enhancements is only available with newly created data. This means that all 
our current customers, using Releases 8 or 9, will not benefit from them, unless they recreate their 
data... or migrate it, thanks to this new development.

 

Needed Options
Select Tools -> Options... menu item:

●     Cache Management on:
❍     Select the Infrastructure category.

❍     Select the Product Infrastructure sub-category.

❍     Select the Cache Management tab.

❍     See Cache Management for CATProduct and CATProcess Document.

●     Load Referenced documents:
❍     Select the General category.

❍     Select the General sub-category.

❍     Select the General tab.

❍     See Loading of Referenced Document.

 

Before You Begin
The upgrade macro/batch might fail for very large assembly, in this case we suggest you to upgrade its 
subassemblies before.

 

Macro Usage
The macro is delivered in the application runtime view (./operating_system/VBScript)



 
1.  Launch the application.

2.  Open the assembly to be upgraded (CATProduct document).

3.  SendTo if you want to keep the original data.

4.  Close the original assembly.

5.  Open the copy.

6.  Launch Macro (Alt-F8 + UpgradeActiveDocumentMacro.CATScript)

7.  Save Management.

8.  Close the application.

 

Batch Usage
The batch is delivered in the application runtime view (./OS_a/code/bin), where OS_a is:

●     intel_a

●     aix_a

●     hpux_b

●     irix_a

●     solaris_a. 

The syntax of the command is as follows:

 catstart -run "CATAsmUpgrade [-c|--check] [-f|--force] [-h|--help] [-n|--no-copy] [-o|--output-dir 
TargetDirectory]
[-p|--path ConcatenationPath] [-s|--stats] [-v|--verbose] DocumentList"

The CATAsmUpgrade and its related options must be included between double-quotes when using the 
catstart command.
For more information about catstart command see Starting a Session on Windows or Starting a Session 
on UNIX.



 -c or --check Prints for each document its upgrade status.
This option performs a check only and disables -f and -n options.

-f or --force Forces the CATPart documents upgrade to take benefit of Semantic 
Unstreaming.

-h or --help Displays the help.

-n or --no-copy Overwrites input data. This option disables -o option.

-o or --output-dir 
TargetDirectory

Defines the target directory for upgraded documents.
The default location is C:\temp for Windows and /tmp for Unix.

-p or --path 
ConcatenationPath

Defines the paths where to find relative documents and dependencies. 
Paths are separated by a semi-colon.
This option disables the application search order specifications.

-s or --stats Prints statistics at the end of upgrade.

-v or --verbose Verboses output.

DocumentList The list of CATProduct documents to be upgraded. Document name 
containing blank character must be included between double quotes.

Batch Monitor Usage
The batch monitor allows you define this batch through an user interface.

 
1.  Select Tools -> Utilities... menu item.

2.  In the Utilities tab of the Batch Monitor dialog box, double-click the CATAsmUpgadeBatch 

utility.

 The CATAsmUpgadeBatch dialog box appears.

 



 
3.  Click Select Documents to process button.

4.  In the File Selection dialog box which appears, select the desired CATProduct documents to be 

processed.

5.  Keep the Overwrite Document option checked if you wish, otherwise you must specify the 

Target Directory field.

6.  Select the desired action: Upgrade Documents or Check Documents Only.

7.  Check the Verbose Logs option if you whish to verbose the resulting log.

8.  Check the Force upgrade to take benefit of Semantic Unstreaming option to force the 

CATPart documents upgrade to take benefit of Semantic Unstreaming.

9.  Click Run to upgrade or check your CATProduct documents.

 

Result File Location



 The result file location is available on:
●     Windows in: C:\temp\upgrade.log

●     Unix in: /tmp/upgrade.log

 

Example
Run the batch or the macro with the following Articulation CATProduct document.

 The result file displays the following result:

 

 

[I] CATAsmProxyUpgrader Reporting:
Number of Constraint: 8
Number of tried upgraded Constraint: 7
Number of successfully upgraded 
Constraint: 7
Number of unsuccessfully upgraded 
Constraint: 0
Number of Publication: 0
Number of tried upgraded Publication: 0
Number of successfully upgraded 
Publication: 0
Number of unsuccessfully upgraded 
Publication: 0
Number of Context: 0
Number of tried upgraded Context: 0
Number of successfully upgraded 
Context: 0
Number of unsuccessfully upgraded 
Context: 0
[I] CATKweProxyUpgrader Reporting:
Number of Relation: 0
Number of tried upgraded Relation: 0
Number of successfully upgraded 
Relation: 0
Number of unsuccessfully upgraded 
Relation: 0

http://canezou/AwsDocV5R14/Doc/online/asmug_C2/samples/Articulation.CATProduct


Glossary

           

A

active component A selected component currently being edited. This component is underlined in the 
specification tree.

active object An object currently being edited.

angle constraint A constraint used to define an angle or parallelism between two geometric elements.

assembly An entity composed of various components which have been positioned relative to 
each other.

B

bill of material A list of data about the properties of the components contained in the active 
component.

C

child component One or more components originating from a single component. Compare parent 
component.

coincidence
constraint

A constraint used to align two geometric elements, or get them to coincide.

component A reference integrated in an assembly. A component possesses characteristics 
related to how it is integrated in an assembly (for example, its relative location in an 
assembly).

constraint A geometrical or dimensional relation between several geometric elements of 
different components. It may be used to define the positioning of components.

context-specific
representation

A hierarchical design of an assembly in a specific context (for example: engineering 
or manufacturing).

contact constraint A constraint used to define a contact area between two elements (tangent or 
coincident).

F



fixed component A component for which all degrees of freedom are locked, in relation to the parent 
component.

G

geometric element The geometric elements which can be constrained in the Assembly workbench are: 
 point
 line
 plane (or plane surface from a model)
 sphere
 cone
 cylinder

L

leaf component The last component at the end of each branch of the specification tree.

M

manipulation A freehand translation or rotation of a component with the mouse.

model A CATIA Version 4 model.

O

offset constraint A constraint used to define a distance or an offset between two geometric elements.

P

parent component A component that is hierarchically just above one or more components. Compare 
child component

part Within the Assembly workbench, it is either a part of the Part Design workbench, or 
a 3D entity whose geometry is contained in a model.

primary child
component

One or more components originating from the first level under the active component.



product A 3D entity which contains several components.

R

reference A product or part with its own characteristics. Compare component.

representation See context specific representation.

S

search order A hierarchical set of paths used when searching for the files included in the 
assembly. The search begins with the first path, and stops when the file is found.

snap Projects a geometric element onto another one.

subassembly An assembly contained within another assembly.

U

update In the Assembly workbench, updates the position of the constrained components so 
as to satisfy the constraint requirements.



Index 

                    

A
analyzing 

dependences  

update  
annotation 

creating  

specifying  

ANSI standard  

asm document  
assembly 

exploding in a scene  

modify  
Assembly Design workbench 

creating  

entering   

assembly features  

associativity  

Auto modify part numbers with suffix option  

B
bill of material  
broken 

constraints  

C
catalog   
CATProduct 



document  
changing position 

section plane(s)  

children  

clash  

color coding  

clearance  

color coding  
color coding 

clash  

clearance  

contact  

interference(s)  
command 

Add (Assembly Features)  

Angle Constraint   

Chain Mode  

Change Constraint   

Clash  

Clash Detection  

Coincidence Constraint   

Comment and URLs  

Compute Clash (Analyze)   

Constraints (Analyze)  

Contact Constraint   

Copy constraint  

Curve Type   

Cut constraint  

Default Mode  

Define Multi-instantiation  

Degrees of Freedom  

Distance  

Distance Constraint  



Drag along Y axis  

Drag around Y axis  

Edit Grid  

Edit Position and Dimensions  

Existing Component with Positioning  

Explode  

Fast Multi-instantiation  

Feature Element Type   

Fix  

Fix Component  

Fix Together   

Flag Note with Leader   

Flexible/Rigid Sub-Assembly  

Flip Horizontal  

Flip Vertical  

Generate CATPart from Product  

Geometrical Element Type   

Geometrical Target  

Grid  

Hole  

Invert Normal  

Manipulate  

Manipulation on Clash  

Mechanical Structure  

Offset Constraint   

Open  

Paste constraint  

Pocket  

Point Type   

Product Management (Tools)  

Publication  

Quick Constraint   



Remove (Assembly Features)  

Reset  

Reset Position  

Results Window  

Reuse Pattern   

Rotate Left  

Rotate Right  

Section Fill  

Sectioning   

Smart Move   

Snap  

Split (Assembly Features)  

Stack Mode  

Surface Type   

Text with Leader   

Translate or Rotation   

Update  

Update Status Unknown  

Updated  

Volume Cut  

Volume Type   

Weld Feature   

compass    
component 

deleting  

editing  

fixing  

moving  

new  

part  

repeating  

replacing  
components 



replacing  
constraints 

about  

analyzing  

angle  

associating URLs  

broken  

coincidence  

contact  

creation mode  

customizing  

deactivating   

deactivation mask  

editing  

name  

negative offset  

offset  

parallelism  

pattern  

perpendicularity  

positive offset  

properties  

sector for angle  

symbols  

tolerance for angle  
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